P. 1
A Comprehensive Introduction to Photoshop Selection Techniques

A Comprehensive Introduction to Photoshop Selection Techniques

|Views: 11|Likes:
Published by Pankaj Phartiyal

More info:

Published by: Pankaj Phartiyal on Feb 18, 2011
Copyright:Attribution Non-commercial


Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less






Tutorials from http://psd.tutsplus.com/

Compiled by <<coldbing>>

Have you ever had difficulties making selections and thought there was a better way? Let's review both quick solutions, and on the other side, comprehensive and details techniques for making selections. Each approach has its place in your workflow. The more methods you know how to use, the faster and more effectively you'll move in Photoshop.

Photoshop selects pixels based one of the three properties, as shown in the image below: 1. Chroma: is the color of the pixel. Color of a pixel is the level of RGB values and color based select tools like the Magic Wand. Select by color uses the RGB & percnt; as a criteria to group pixels based on the set tolerance values. 2. Luma: is a selection based on Illumination levels. Illumination levels are whiteness of the image, which is nothing but higher values for all the three R, G and B channels. Photoshop doesn't have a native interface for a Luma based selection, but many existing tools can be hacked to get a similar result. 3. Masks: are based on spatial position. Pixels are selected and discarded or masked by a parallel layer bound to corresponding image layer. Masks are grayscale and brightness of the mask is called an Alpha level, which is the degree of opaqueness of the corresponding layer pixel. It's also called the Transparency/Opacity channel as in RGBA etc.

A NOTE ON MASKS In this article. Step 1: Open a new image that you want to use as a mask." on top of it and fill with a uniform color. The process of transferring images to layer masks will be shown once and then used repeatedly without explicitly mentioning thereafter. Double-click the background layer and create a new layer. words like Masks and Alpha will be used interchangeably. then hide "Layer 1. which is "Layer 1." . which is "Layer 0." Make a new layer.

. click Edit > Copy (Command + C) to copy all pixels to the clipboard. Initially an all transparent Layer Mask will be created. Next. Step 3: Go to "Layer 1" and create an empty Layer Mask.Step 2: Go to "Layer 0" and click Select > Select All (Command + A) to select all pixels. Alt-click the layer mask to see it in the canvas.

Step 4: With the Layer Mask visible. A grayscale version of the copied image will be pasted in as the layer mask. Any image can be applied as a Layer Mask to another layer. . Step 5: Click on the fill layer thumbnail (not mask) to see the result. paste onto the canvas by clicking Edit > Paste (Command + V). The opacity of the layer will be controlled by grayscale level of the mask.

MORE ON MASKS The easiest way of creating a Layer Mask is to click the Add Layer Mask button with something selected on the canvas. . Activate Layer Masks Alt-clicking on the Layer Mask makes it active for editing. Only activated layer masks can be edited which are represented by a thin white outline around them. The selection will be saved as a layer mask attached to the current layer and everything outside the selection marquee will be masked and hidden.

Add Brush Strokes to Layer Masks The same is true for brush strokes. by painting everything else black on the Layer Mask. To draw it again on the layer we need to deactivate the Mask by clicking on the layer thumbnail. White brush strokes will reveal and blacks will conceal. Anything painted on the canvas with a Layer Mask selected will draw it on the Mask instead of the Layer.Add Shapes to Layer Masks Dragging any shape onto the canvas while a layer mask has been activated will draw it on the Mask instead of the layer itself. We can use this property to select objects with irregular boundaries from backgrounds. .

we can transfer the Layer Mask to another layer by simply loading it as a selection (Command-click) and unloading as we did in the first step by clicking the Add Layer Mask button. Or by Alt-dragging the mask to another Layer (Not Shown). BOOLEAN OPERATIONS WITH SELECTIONS This example shows how to Load. .Copying a Layer Mask to Another Layer Finally. Subtract. Add. and Intersect selections between overlapping layers just with quick thumbnail clicks.

Addition With the "Layer 2" loaded as a selection. This is not the same as copying the layer. . only its outline. Now non-transparent pixels of both "Layer 1" and "Layer 2" are combined as the new selection.Load Pixels to Selections In "Layer 2" Command-click to load a fill as a selection. Let's call this state (with "Layer 2" selected) the initial state. The green fill shows the selected region although you will get only the surrounding Marquee. Any pixel which is not transparent in "Layer 2" will be loaded as a selection. Command + Shift-click on "Layer 1" to add it to the selection. Notice the small plus sign in the Command-Click box.

. If the layers are not overlapping." Notice the minus sign." This will subtract any overlapping pixel of "Layer 1" from the current selection of "Layer 2.Subtraction Revert to the initial state and Command + Alt-click on "Layer 1. this action will deselect all. Notice the X sign. Intersection Revert to initial state and Command + Alt + Shift-click on "Layer 1" to keep only the overlapping pixels as a selection.

Vector and Raster Selections Draw an outline around the region of interest in the image with any of the Lasso Tools and double-click to complete the selection. With the Lasso selection click Add Layer Mask to save it as a Layer Mask. . A Garbage Mask needs to be saved for further refining. Further trimming is carried out inside the Garbage Mask with precision. which can be done both as a Layer or Vector Mask.GARBAGE MASKS Garbage Masks are created to roughly isolate the 'region of interest' from rest of the image. We must choose it depending on complexity of the outline and how we are planning to trim it later on.

then Command-click on control points to move them. go to the Paths tab (3b) and click Make Working Path from the Selection button at the bottom. delete. Regular curvy shapes are best to be extracted with this process. Click and drag on the handles. With the Lasso selection still intact (2). Drag directly on the Control Point to reset handles. The Convert Point tool is most suitable for altering Vector shapes and Paths.Alternatively. we can also save the selection as a Vector Mask which can be later refined by working on the shape spline that defines its outline. Saving selections as Vector Masks or Shapes saves memory. You can disable. and return to Layers tab. Delete points when necessary. Click Add Layer Mask once to create a Layer Mask (Command-click to load again) then click the same button( 6b) once more to Add Vector Mask. Dragging handles with Command + Shift will lock their relative slopes. Selecting with Vector Mask Click on the Vector Mask to activate it. or save the Layer Mask with another Layer. Vector Masks are modified by adjusting the spline positions (Control Points) and curvature (Tangents). Now load the selection again. Once a acceptable outline has been achieved use the Add Points tool to refine and further match the outlines. Or selecting any of the Shape tools will make it active. . This will save the selection outline as a Shape Working Path.


but does a great job in minimizing manual work. This tool can be used to setup Garbage Masks around the subject and later refine it with editing the Mask. Click Select > Color Range and select a color with the Eyedropper Tool available. SELECT BY COLOR RANGE Selecting by color is the fastest way to Chroma select. . Select by color is not a one-click solution.This method is also best in situations where boundaries are not clearly visible. Once selected certain shades can be removed selectively with the Minus (-) Eyedropper or again added with the Plus (+) Eyedropper. There is also a preview window that displays the selected region or the original image.


Click Image > Adjustments > Curves or Press Command + M to apply curves modification on the current channel. This process is helpful only when background and foreground have separate color distribution in at least one channel. Our subject here is the patch of vegetation in foreground. We are going to exploit this property to separate the two. Picking the Best Channel A simple observation of the three channels tell us that. which can be viewed in the Channels Tab. Duplicate (Command + J) the Layer and go to the Blue channel of the Copied layer. We can use the channel wise variations in color intensities for selecting objects in the image. . the blue channel has the highest contrast between the Sky and Grass.CHROMA FROM CHANNELS Color information of each type is stored in as separate channels. Advanced Chroma In the Histogram we can see that the blue channel is predominant in the image and it extends up to the highlights where other channels are very weak.

Channel as Mask Command-click on the channel thumbnail to load the channel into the selection. This will make the darker pixels uniformly more darker. Areas which have no blue (the black parts) will be left from the selection. drag it a little back to left if it does. go to the Layers tab and click Add Layer Mask to save the selection as a Mask.Applying Curves Select the point closer to the dark grays of the channel and drag it (2) forward in the x-axis (horizontally) keeping y-axis at 0 (shown by the small circle). Make sure the whole background turns white or almost so. Next. . What we are doing is saturating the dragged range of blue up to 100 percent. With the selection in place. It shouldn't affect the background. and there is a very high contrast between the Grass and Sky. drag it (3) back towards the midtones keeping the y-axis (vertical) at maximum (shown by the small circle). Areas which are predominantly blue will be selected totally and the rest according to respective degrees. select another point closer to the White Point.

Inverting the Mask Press Command + I to invert the Layer Mask. .

It is also used to refine selections made with other techniques.SELECTING BY BRUSHING ON MASKS Brush based selection is used to extract foregrounds with complex outlines with accuracy. Brushing with Layer Masks Here too Layer Masks can be used. Erasing is probably the first thing that comes to mind when we talk about brush based selection. We can brush out backgrounds in the same way as in using the Eraser tool and get it back by painting with White. And it also supports transparency (softness). to preserve the workflow of Eraser and additional possibility of recovering removed portions if they are needed. Painting on the Layer Mask with a White or Black will reveal or hide the contents respectively. But it is not a recommended process at all. Erasing is a destructive process and can permanently damage the original image as recovery is limited only to a number of undo levels we have set. .

Multiplied gradient maps will show-up as high contrast versions of the subject outlines if violated. . Immediate Feedback This problem can be averted by following a simple rule of keeping a multiplied duplicate of the current layer in the background as a guide layer. This is highly probable when foreground background have similar hues and there is no immediate visual feedback.No Feedback When brushing the mask we may sometimes trim off relevant parts accidentally and keep focusing on the wrong silhouette only to be discovered later.

and there are no intermediate grayscale levels. Simplest Luma Hack Unlock the background and make a duplicate of it. then hide the original Layer. You will notice that some parts of the image have been turned instantly black and rest are pure white. Apply Threshold Apply a Threshold Adjustment Layer on top. .LUMA SELECT As already mentioned Luma is the illumination levels of an image. Luma can be used to extract components from the image which have a considerable brightness difference than others.

Adjust Threshold Adjust the Threshold Slider and try to enclose the subject or background (whichever is darker) in black. . Select the bottom layer. Merge Layers Command-click to select the top two layers and Merge them into one. Hide the Threshold layer and look at the original image for guidance when required. make it visible and create a blank Layer Mask.

Invert if necessary. We have our Layer Mask ready. but in most cases there will be holes and parts of our background visible. Using Luma to Mask with Transparency Unlock and Create a layer from the background (1). The following method can be useful in situations where we need Luma extraction with transparency. Use the Mask Painting technique discussed above to make it tidy.Add Layer Mask Copy the merged image and paste to the Layer Mask. Here we are going to remove the ice-water from the rest of the rocks. following the process discussed above. LUMA SELECT WITH TRANSPARENCY The Threshold technique discussed above is very fast to implement. Apply an Adjustment Layer Black and White on top and then a Brightness-Contrast Adjustment Layer above it. . but is only useful for extracting solid objects as it lacks transparency.

.Reduce Brightness Select Use Legacy mode and slowly move the Brightness slider to left. try to get as many black areas from the rocks as possible. This process will reduce the brightness of the Water too so don't overdo it.

. . if so there will be no translucency left.Increase Contrast Now slowly increase the Contrast slider to the right. Over increasing the contrast will make it look like a Threshold Layer. We are going to get the whites as opaque and grays as semi-transparent. Try to get both Whites and Grays where necessary. With each increase dark-grays will turn to black and lighter grays will glow more brightly.

.Merge the Layers When satisfied with the results merge the top three Layers. Go to the background layer and add a Layer Mask and copy the merged Layer into the Layer Mask.

You can play with that channel and try to isolate some element from the background.YET ANOTHER POSSIBILITY Other than the above two procedures there is also another way of Luma based extraction using the Lab color method. And filters that doesn't work on the image in Lab Color mode works on the Lightness channel. This is where the illumination levels of all pixels are indexed in the Lab Color mode. . Go to Channels Tab and find the lightness channel or press Ctrl+1 to directly select it. Lab Color Technique Open an image and turn it to Lab Color mode by clicking Image> Mode> Lab Color. and yield almost similar results. Don't forget to duplicate the Layer or the Channel before you alter any channel.

CONCLUSION Photoshop has quite a few options when it comes to selection techniques. Compiled by <<coldbing>> . Try applying some of these solutions in your workflow to increase your productivity and effectiveness.

You're Reading a Free Preview

/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->