ERDAS IMAGINE Exercise 1.

by: Sonya Remington 1. Open ERDAS IMAGINE from your desktop by going to Start --> Programs --> ERDAS IMAGINE 8.4. When ERDAS opens, a Menu Bar running across the top of the screen and a Viewer window below the Menu Bar appear. All available functions for ERDAS can be activated from the Menu Bar; however, not all functions can be activated from the Viewer. 2. In the Viewer window go to File --> Open --> Raster Layer..... and find the bbcgis folder. Open the "pnw98_bbg.img" file from the folder. Make sure that the file type is ".img".

3. On the toolbar inside the the Viewer window, click on the Zoom In button . Zoom in on the image a few times. Click on the image with the right mouse button and choose "Fit Image to Window" from the menu that appears. This command is analogous to the "Zoom to Theme Extent or Full Extent" buttons in ArcView. This part of the exercise is to illustrate the point that ***Clicking on the right mouse button gives you access to many of the functions in ERDAS*** So.....if you cannot find a function in the menu or on the tool bar, try clicking once on the right mouse button.

4. Change back to the arrow button appear

and click on

. The following menu will

and white cross-hairs will appear on the image. Use your pointer to move the cross-hairs by clicking once in the intersection of the two lines and dragging the center of the cross around. As

you do this, notice that the X and Y values in the table change. Zoom in on the image a few times so that you can see each individual pixel.

Move the cross-hairs again, but this time stay within one pixel. Notice that the X and Y values in the table still change, but that the values in the File Pixel and LUT (Look Up Table) Value columns do not change. The columns assign to each pixel a value from 0 to 255 (called a DN number). The File Pixel columns are the actual pixel values of your data. The LUT Value column assigns a number to each pixel based on a combination of red, green, and blue used to make the colors on your screen. 5. Changing Band Combinations. Zoom back out to fit the image to the window and close the table that is now open to get rid of the cross-hairs. From the Viewer menu choose Raster --> Bands Combinations and a table will appear:

Change the values on the right-hand side of the table to 5,2,1

and notice that the forested and grassy areas now appear green. You can play around with this band combination to give the image some really funky colors, but this feature is also useful. For example, by knowing that soils shows up really well with a certain band combination you can use this combination to see them more clearly than you would with another combination of bands. Forests might show up more clearly in a different band combination than soils. 6. The purpose of the next part of the exercise is for you to see how ERDAS can help you see that different features (i.e. water, urban areas, forested areas, etc.) reflect different wavelengths. Change The band combination back to 4,3,2. Now click on the graph button in the toolbar and a menu with appear:

Choose Spectral from this menu and hit OK. A new screen will appear:

Click on the cross button on this NEW Spectral Profile menu in the water on the image. and then click somewhere .

Now choose a point over an urban area and see that you will get a different spectral profile on your graph. .A line will appear on your graph that describes the spectral profile at given point.

.Finally. choose a forested area and repeat the procedure.

With your new knowledge about the spectral profile for a given feature.As you have probably figured out by now. the forest has a different spectral profile. 8. you can go back and change your band combinations to make that feature show up more clearly on the image. This part of the exercise shows you how ERDAS can help you visualize how different wavelength reflect along a transect of the land surface. Close the Spectral Profile window to get .

Each time you want to change the direction of the line click on the left mouse button. notice the the axes are different. On the image. but this time choose Spatial and hit OK.rid of your profile points. click once with the left mouse button to start drawing a straight line. A similar looking window as for the Spectral Profile will appear. Click again on the graph button in the toolbar in the Viewer window. Click on the line button . however. .

.another graph will appear: ... except that it is in 3D. which is similar to the Spatial Profile. Choose surface and hit OK. You guessed it. The next exercise will use the Spectral Profile Surface. double click with the left mouse button. 9.To stop drawing the line and to display the results on your graph.. Close the Spatial Profile table and click again on the graph button in the Viewer toolbar.

Click on the square button in the graph window and choose and area of interest (AOI . . To do this. Release the mouse button and a graph will appear.get use to this term) on the image. Click and hold with the left mouse button on this x and drag the resulting rectangle to the areal extent you desire. click once on the image with the left mouse button and a little x will appear .

.Cool! Now change the "PLOT LAYER" value in the Surface Profile window to display the surface of each of the bands of reflectence within the profile AOI.

This means that when two images have been geo-registered in a common real world projection and coordinate system they therefore have both spatial information (the X. In image processing. we will learn about geo-linking image with ERDAS.img) to select the GeoLink/Unlink option. Your desktop may look like this Now use you RIGHT MOUSE BUTTON in the viewer #2 (the iconisbbc. Lets start by fitting the existing image to the window of viewer #1. Geographic data my be "linked" through their common locational data and quired about their variation or differences. Finally. Open a new viewer and load the iconisbbc.img image file. . this is most often done to aid in understanding the nature of the data by linking "high" resolution data with "coarse" resolution data. You'll see the following window.10. This means that the geo-registered image data may be considered "geographic" data.Y locations for each pixel or raster grid cell) and they have descriptive data (the value of reflected energy for a given number of wavelengths).

The instructions tell you to click the left mouse button in the viewer with the image you wish to "link" with. Open the "pnw98_bbg.4. In the Viewer window go to File --> Open --> Raster Layer. IMPORTANT: When you close ERDAS. 3. Close both viewers. unless you really have something against trees. Say NO. Open ERDAS IMAGINE from your desktop by going to Start --> Programs --> ERDAS IMAGINE 8. Now zoom in and out in BOTH viewers and see what happens. The mouse will change symbols to inform you what action will take place in each window. An "index box" (or some call it the "zoom box" ) will appear.img" file from the folder.. That's it for now. ERDAS IMAGINE Exercise 2.. Select viewer #1 with you left mouse. Unsupervised by: Miles Logsdon 1. 2. and select EXIT IMAGINE from the session menu on the top tool bar.. and find the bbcgis folder. you will be asked if you want to print the Log File. Click on the image with the right mouse button and choose "Fit Image to Window" from the menu that appears. .. Change the size of the "index box" (use the tool).

Complete the Input window option. Click on the classifier icon from the icon pane the dialog opens Select Unsupervised classification. 5. .4.

95 (ie.NOTE: Input raster file (*. Stop processing when 95% of the pixels stay in the same cluster between interations) Click OK on the dialog and on the status dialog when the process is completed. Initial clusters can be generated either arbitrarily or from an existing signature mean.img) and provide an output name. 6. You can select to initial from statistics y y y Enter the number of different NUMBER OF CLASSES (ie. Try 9) Set the maximum iterations up to 15 (this insure the process will not run on forever) Set the convergence threshold to . When the process is completed open a second viewer and load the new image. . You can output a signature file.

Make a color selection for the other pixel values. . the image is now a single dimension where each pixel has a value between 1-9 which assigns that pixel to a cluster of similar pixels.7. 8. Remember that you can geo-link to the other view to help you understand what the clustered values might mean. This image is a RASTER data layer. From the viewer #2 select RASTER > ATTRIBUTE and click on one of the shaded cells to change the color attribute for that attribute. Remember. It therefore has "attributes".

5. change the opacity for class 7.9. In the Raster Attribute Editor. from that viewer tool bar open a classified raster layer. NOTE: you can edit the way this editor appears by selecting Edit > Column Properties 12. One very nice function that helps evaluate clusters and/or classes is to visually overlay images. Start by setting opacity for all classes to "0". and click on Apply. click on the word OPACITY at the top of the Opacity column. make sure the "clear display" option is turned off from the "raster options tab" found from that dialog box select Raster > Attributes from the viewer. click on the "0" (the zero on the number pad). this class will be shown in the viewer. 13. « click on the color patch and change the color. Change the opacity for class 1 in the Cell Array to 1 and press return. .to something like Yellow or red so it¶s easier to see. If you have not already change the color for class 1 do so now .3 respectively 10. Make sure you have a view with the spectral image file opened (file >open > raster layer and display bands 4. Also. the editor will be displayed 11. then right-click-hold on the word Opacity and select formula from the column option menu.

15.14. . The flashing pixels are the pixels in this class. Now you go figure out what Utility > Swip and Utility > Blend will do. From the viewer menu bar select Utility |> Flicker « the dialog opens « turn on the auto mode. click on the Class_Name in the editor and give it meaningful name and assign it a meaningful color . Repeat for the other classes.

1. The method that I have used and found to work the fastest is the following: . Say NO. unless you really have something against trees. you will be asked if you want to print the Log File.IMPORTANT: When you close ERDAS. Subset and Mosaic by: Miles Logsdon There are multiple ways to clip (SUBSET) an image. Open ERDAS IMAGINE from your desktop by going to Start --> Programs --> ERDAS IMAGINE 8.4. . many of them use the subset command. ERDAS IMAGINE Exercise 3.

This will make a .. Fill out the options selecting the image input and output.2.. Move the box and enlarge it to include the area you want to clip 5. and click on FROM INQUIRE BOX button. In the Viewer window go to File --> Open --> Raster Layer.. . Click on UTILITY --> INQUIRE BOX 4.img" file from the folder. Click the DATAPREP button. and data type you selected. and select SUBSET IMAGE 6.img file that contains the area. and find the bbcgis folder. 3. Open the "pnw98_bbg. layers..

Do the following: 1. Click the DATA PREP button. Add all your clipped images . you will want to put them back together for your unsupervised classification. Once you have all your clipped images. Click EDIT and ADD IMAGE or use the button . NOW here is one method to (MOSAIC) multiple Images (individual blocks) together.REPEAT those steps until you have the subsets you wish to work with. and select MOSAIC IMAGE 2.

3. . Raster --> Contrast --> General Contrast. You'll need to contrast stretch the resulting image. 5. This will make a new . Then click PROCESS and RUN MOSAIC 4. Try the linear option.img file with all your clipped images included.

Begin by opening ERDAS from your Start Menu: Start > Programs > ERDAS IMAGINE 8. and check your data for accuracy by using Accuracy Assessment in ERDAS. Select Signature Editor from the menu and a Signature Editor table will appear. .You can play with the contrast to make the visual that you like. 2. perform a Supervised Classification.4. IMPORTANT: When you close ERDAS. This exercise will show you how to edit the signature file created from an Unsupervised Classification. Click on the Classifer button located in the main menu bar. Say NO. ERDAS IMAGINE Exercise 4. by: Sonya Remington 1. you will be asked if you want to print the Log File.

. You may want to do this after you go into the field and decide that two of the classes that were separately grouped during the unsupervised classification are really the same thing (i. you first need to select them from the table. This part of the exercise will show you how to merge two classes. click on the row of one of the Class #'s that you want to merge. To do this. Now that your .Go to the File menu in the Signature Editor window and open the .sig file is open. You should now get values in your Signature Editor table. In this example we will be merging classes 2 and 3 that were generated from an unsupervised classification into nine total classes.e. Hold down the shift key and then click on the other class(es) being merged. 3. you may begin to edit it. both are alder).sig file that you named in your unsupervised classification. To merge two classes. The classes that you see here are those that were generated by the unsupervised classification and are based on spectral properties.

You will now learn how to perform a Supervised Classification using the edited Signature File. go to Edit > Delete to get rid them. The table should now look like this: Save the new Signature File and close the Signature Editor table. . Notice that a new class containing the data that you merged has been added to the last row in your table. The following will appear. Click on the Classify button again and select Supervised Classification. 4. With the two merged classes still selected.Now go to Edit > Merge.

This is because they no longer exist as separate classes. that they are now "No Data" and the red color does not appear on the image. 5. Open two Viewer windows. When you are entering the "Input Signature File" by sure that you enter the edited Signature file. In one Viewer open the image Unsupervised Classification image and in the other viewer open the Supervised Classification image. Remember. not the original signature file from the Unsupervised Classification. . One of the first things to notice is that if you change to color to red (or any other color) for the two classes that you merged together. Don't worry about what they mean for right now. the "Classified File" will be the output file for the Supervised Classification and you can name it whatever you want. Hit OK when the classification is finished.Enter fields as they are in the above example table. Hit OK and wait for the image to be classified. Open a raster attribute table for each viewer by going to Raster > Attributes from the menu of each. Fill in the Decision Rules section as shown above.

Now make Class 10 (your new class from the merge) red and notice that it does appear on the image. .

Another way to see that Classes 2 and 3 have been merged together is to go to the Raster Attribute table for the Unsupervised Image and make Class 2 red. . Now you can compared the two images and notice that the red area in the Supervised image is much more extensive than that is in Unsupervised image.

then the red areas in the two images will cover the same area. .If you make class 3 in the raster attribute table of the Unsupervised image red.

The following window will appear: . you want to determine how accurate your classification was by doing an Accuracy Assessment. Now that you have classified your image based on spectral properties and field observations. Click on the Classifier button in the ERDAS menu bar. Selected Accuracy Assessment and close the Classifier menu. You will compare pixels in a classified image to reference pixels. First open the pnw98_bbc. which are the pixel for which you know the correct class.img in a Viewer.6.

use the GPS points for your samples from the first field trip.img image. These points are currently in an Excel file along with the attributes for each point (i. you need to enter the GPS coordinates for the reference points (the points for which you are sure of the class because you actually went out in the field and had a look).txt file to import. Since you may not have this at the time that you are trying this exercise. 7. First you'll want to make a file in Excel with ONLY the X-Y coordinates for your GPS points. stem density. Click OK when this is done.e.In this window. This will be that image that will be used in you accuracy assessment. Now that you have told ERDAS which image you want to use in your accuracy assessment (the supervised classification image). biomass. In the Accuracy Assessment window go to View > Select Viewer and then click on the Viewer that is displaying the pnw98_bbc. You should end up with an Excel file that looks something like this: . you will have the GPS coordinates from your ground truth field exercise entered into a . When you actually do an accuracy assessment for your project. Now go to View > Change Color and be sure that the Change colors window looks like this: "Points with no reference" should be white and "Points with Reference" should be yellow. Navigate to the file and then click OK to load it. go to File > Open and select the image that resulted from your supervised classification. or whatever you collected in the field).

txt" file.txt file (not a . Now save this new file as a . You can do this by selecting the "Text (Tab delimited)" option from the "Save as type:" field when you are saving the file.) Now that you have done this. Doing this will change the file from ". Select the file with your GPS coordinates from the ASCII Point File window that pops up and hit OK. but be sure that your X values are in the 1st column and your Y values are in the 2nd.xls" to a " . . You now see an Import Options window. From the Accuracy Assessment window go to Edit > Import User-defined Points. (See the below for example.xls file). go back into ERDAS.Do not label the columns X and Y.

Click OK. Your Accuracy Assessment window should not look something like this: In this window. . select Delimited by Separator and don't worry about the rest right now. go to View > Show All and notice that the points now appear on the pnw98_bbc.img image in your Viewer.For Field Type.

that the reference numbers for your points are as follows (Remember.If you Zoom In on the image. the class values that you put in the reference column are determined from field observations): The value in the reference column probably do not mean anything to you now. for the purposes of this exercise. Now you can enter your class values for the reference numbers in the Accuracy Assessment table. you can see that these points more clearly. Lets just say. but they will after you have done you're field work. . Go to Edit > Show Class Values and the Class column will be filled in with the values that are the actual values of the pixels located at the X-Y coordinates that you indicated.

Finally.You can see that the first three points have the same values in the Class and Reference columns. do so. Say NO. you can find the Confusion Matrix (call the Error Matrix in ERDAS) and the other report options that you selected. you can look at the statistics of your accuracy assessment by first going to Report > Options. Then go to Report > Accuracy Report and the following table will appear: In this table. Points four through nine do not match. meaning that your supervised classification did not assign values correctly to these pixels. This means that your supervised classification was correct ion assigning values to these pixels. Accuracy Totals. If they are not. and Kappa Statistics options are all turned on. you will be asked if you want to print the Log File. Check to make sure that the Error Matrix. IMPORTANT: When you close ERDAS. .

and examine the spectral and spatial profiles of the data. As your mouse moves within the display window note that the coordinates displayed in the lower left of the viewer are in "row" and "column". .Georegistration and Correction ERDAS Example By this time you should be able to open for display an image file. select the band combinations that work best for your purpose. you should refere to the earlier exercises. (This may be r:\lawers\data\landsat\bbc\bbc_2000.img) and display it and "fit" it in a viewer. The basic proceedure will be to: y y y y y display files start Geometric Correction tool record Geometric (ground) Control Points (GCPs) resample the image verify 1. If not.) Begin by opening the file which you wish to georegister.

img). (This may be r:\lawers\data\landsat\bbc\pnw98_bbc. note the pixel coordinates in the lower left.) Start the Geometric Correction tool from the viewer displaying the file to be retified. 2. note the coordinates in the lower left of the viewer for this georegistered image. Once again. This image is georegistered to the UTM projection and coordinate system.) Display an existing georegistered image in a second viewer.Again. If you don't feel you understand map projections you may wish to visit the USGS site call Map Projections 3. .

Note all the different way inwhich you can collect reference points.) The next dialog box is the Reference Setup dialog. The polynomial model has the most general application. You can close the Polynomial model Properties (you will be selecting these parameters later) 5. Select (or accept) the option to use the Existing Viewer and click OK. Each of these geometric models relate to specialized tasks.) Two dialogs boxes will appear. .Select RASTER > Geometric Correction from the viewer's menu bar and Polynomial from the dialog box. 4. The Geo Correction Tool menu will be used now.

You will be prompted to click in the Viewer from which you wish to select the reference cooridnates. Click in your second view - the pnw98_bbc.img. The refernce map information dialog will open. Make sure the information is correct (which it is) and click OK.

6. You are now ready to begin assigning real world coordinates to the non-geographic registered image. Your display will be filled with widows!

First, each viewer now has it's own "zoom" window above it. The zoom window display that part of the image which is inside the "box" (some time called the link box). The Ground Control Points (GCPs) are the small targets which are place on the image using the GCP tool. It is a good idea to click on the "non-registered" image first. You can move the GCP with your mouse, and the GCP can be placed in either the Viewer or in that viewer's zoom window. The coordinates for each GCP is place in the GCP Tool CellArray (the table in the lower third of your display). The Xinput and Yinput are the coordinates of the image to be registered and the Xreference and Yreference are the coordinates of in the image that has already been registered. Your proceedure is click on the GCP icon and then click on a location in the first viewer that are easily identifiable in both images (the GCP #1 will be placed at that point and it's coordinates will be filled into the CellArray). Then click again on the GCP icon and this time click on the same location in viewer two (a coresponding GCP #1 will be placed at that point along with it's real world coordinates in the CellArray) REMEMBER, you can move the GCPs in the zoom window for better placement. Just click on the arrow icon .

You see that after you have collected Three or more matching pairs the software will begin to place GCPs for you in an automatic mode. Also, you can right-hold you mouse button in the Color column of the CellArray table to change the color of the GCP points. Repeat this proceedure until you have all the points you want. (try to get 7 or 8 at a minium). To delete a GCP, select the GCP in the CellArray and then right-hold in the POINT # column to select Delete Selection. When you have finished your points should spread out over the image.

7.) Clearly there is much more you can do with this tool. For now we will accept the limited number of points and accept the solution to the transformation. Our next task is to resample the image . Resampling is the process of calculatin the values for the rectified image and creating the new file. All of the raster data layers (all bands) in the source file are resampled. The best known algorithms for resampling are Nearest Neighbor, Bilinear Interpolation, and Cubic Convolution. We'll use the Bilinear algorithm.

Click on the resampling icon from the Geo Correction Tool Menu . The resample dialog opens. Enter a file name for the output (know where on the drive you will put the file) - select the Bilinear Interpolation resampling method - click to exclude zero file values in the statistics. Also set the Output cell size to 30.00 (we will be using a 30 meter DEM in the later exercises). Click OK. This shouldn't take much more that a minute or two for this size of file.

. 8.) Verify the rectification by displaying the new image in a viewer and Geo. Link the reference image with the new image and use an Inquire Cursor to check that they are georegistered to each other.A job status dialog opens to let you know when the processes is complete.

img). Display the 432 band combination. Note along the way all the other options.I did really well! If you don't like you finished product. The HAZE REDUCTION dialog will appear. . you may use the image I just made for other exercises.) Begin by opening the file which you just finished georegistering (or use r:\lawers\data\landsat\bbc\my_resample. (r:\lawers\data\landsat\bbc\my_resample. 2.img) Simple corrections ERDAS Example 1.) Select INTERPRETER > Radiometric Enhancement > Haze Reduction option from the main icon bar menu.

Click on the VIEW button to start the ERDAS Model build. The DeHaze model will be loaded. .This dialog offers you a chance to see the "model" that will preform a transformation on the data.

The grahic model illustrates the steps that ERDAS will go through. The products are summed. In this way a simple spatial frequency of haze may be reduced. The software now knows that the data is Landsat TM data and will now pick a "DeHaze" model for Landsat. the PSF Kernel is a convolution filter. When used with pixels in which a relatively high value is surrounded by lower values the high value becomes higher. It is but one of the various approaches. It illustrates the steps that ERDAS will take. imagine that the convolution kernel is overlaid on the data file values of the image (in one band). The kernel is then moved to the next pixel. each value in the kernel is multiplied by the image pixel value that corresponds to it. 3.) Now fill out the input and output fields of the Haze Reduction dialog. The output value for the convolution is. A High-Frequency kernel (high pass) has the effect of increasing spatial frequency. and the total is divided by the sum of the values in the kernel and assigned back to the center pixel. Fill out the dialog for input and output and click OK. That is to say. when this kernel is used on a set of pexels in which a relatively low value is surrounded by higher values the low value gets lower. This "model" is specific to Landsat TM data and as you can see it consist of picking between a matrix of weights for either landsat 4 or 5 data and the then determining the majority value with a kernel. To understand how one pixel is convolved. so that the pixel to be convolved is in the center of the window. put that data out to memory and the determining if any pixel has a value of zero before making the output file. Display your results side by side and look at the spatial profiles of the reflectence values . The Input Raster is your image. I wouldn't try to figure this one out.This model is very simple. Click on VIEW to see it.

.I also did a Point_Spread model (not using the model for Landsat Data). Look at the results.

) To preform topographic correction. 5.img) and then select INTERPRETER > Topographic Analysis > Topographic Normalization. Display the Digital Elevation Model for the site (r:/users/lawers/data/landsat/bbc/bbc_dem30.It looks like more haze. . but what are the DN values like? You should do one or both of these models and save a result.

SUN_AZIMUTH=137.88. . Remember to look at the VIEW of the model which is being preformed.SUN_ELEVATION=59. Click Okay and display your result.92. I'm glad someone else wrote this one for me.You will need the following information .

Extra Skills VirtualGIS 1. (I suggest the Landsat pnw_bbc.) Open ERDAS and load your favoriate band combination.Make some notes about what you see. Select the VirtualGIS Viewer option from the menu available under VirtualGIS icon from the main icon menu bar .img).

) If the DEM is still in Arc/Info grid format you may open it in that format. If you have already exported the DEM as an ERDAS image file then you may open it as an image (this is the case for our class . However you will have to change the "file type" option in the file navigation widow to GRID. select the viewer with the 2-D image (i.the DEM for the pnw_bbc image is named bbc_dem30. viewer #1). 3.) Link the two viewers by selecting VIEW > LINK/UNLINK Viewers. 4. by selecting FILE > OPEN > Raster Layer. When prompted.2.img.) Drape either a classified image or a different band combination onto the 3-D representation of the DEM. . You may select the OPTION tab to define the RGB bands. The image will now shift to include a position location for the "EYE" and for the "TARGET" that defines the viewing angle for the linked 3-D image.) In the VirtualGIS view window load the DEM for the associated image using the FILE > OPEN > DEM option. Navigate to the directory where the DEM is located.e.

) Now move the location of the "EYE" and/or "Target" to change the perspective of the VirtualGIS viewer. .5.

) Select the NAVIGATION > POSITION EDITOR to adjust the viewing angle. Make sure the Auto Apply checkbox is selected. Now reposition the "EYE" and "Target" in the linked 2-D window. It may be best to alter only the PITCH attribute at this time (try -20).6. . 7.

Select KNOWLEDGE ENGINEER from the Classifier icon menu .Expert Classifier 1.

) Select EDIT > NEW Hypothesis to add the first hypothesis.) Select the RULE graphic tool from the Knowledge Engineer icon bar. Click on the green hypothesis rectangle for vegetation and then double-clik on the yellow NEW RULE rectangle to open the RULE Propserties dialog. and Click APPLY 3. select the input image the layer (4) and use Cell Value .2. variable type (raster). File this dialog out and make sure you change the name.) Repeat those steps and create a second hypothesis for the class water. Change the name and leave the Compute from Conditions button selected for Rule Confidence 5. Set the color to green and since you want this class as an output click on that checkbox.) Click with the cell under Variable and select NEW VARIABLE. 4. Change the name to Vegetation.

.) Once completed click on the RUN TEST icon. Here is how bad mine look. .) Once you've applied this variable you can add others and edit them until you have a finished knowledge map 7.6.

Third. 2. you may add to the signature file the result of a "supervised" clustering approach. 3. or water). Second. if the unsupervised approach to forming signature clusters fails to distinguish a land or sea surface material which "YOU KNOW IS PRESENT". How to clip and mosaic Images An exercise in Unsupervised Classification Evaluating Classifications An exercise in Supervised Classification Evaluate Again Accuracy Assessment exercise GIS@UW Search Follow the steps below for an example of a "single" path through the steps of the Hybrid Approach Remember that the hybrid approach is designed to let you first work with smaller subsets of the image that have been clipped and mosaiced together to form a selection of the image heterogeneity for a given theme (such as forest. Fourth. these mosaiced images are allowed to "self-orgainized" themselves into spectral clusters using an unsupervised approach. all signatures either from the unsupervised or supervised approach are appended together to form a single signature file which . 4. or urban.ERDAS Hybrid Approach UW Home HOME MORE ON THE TOPIC OF: 1. 5. 6.

and data type you selected. 4. Group multiple Images blocks Once you have all your clipped images. Unsupervised clustering on representative data 1. Below are the basic steps in more detail. many of them use the subset command.is used to "classify" (as a supervised classification step) the complete and full extent of the originals image. select initial from statistic 6. 2. Do the following: 1. 2. The method that I have used and found to work the fastest is the following: 1. Click the DATA PREP button Select MOSAIC IMAGE Click EDIT and ADD IMAGE or use the button Add all your clipped images Then click PROCESS and RUN MOSAIC This will make a new . Try 3 times the number of expected classes) 7. layers. and select SUBSET IMAGE Fill out the options selecting the image input and output. you will want to put them backtogether for your unsupervised classification. 4.img file that contains the area. 4. the dialog opens Input raster file (*. 5. 3. 3. 3. This will make a .img file with all your clipped images included. 2. Set the maximum iterations up to 40 (this insure the process does not run on forever) 8. There are more then one path through this approach.95 (ie. Stop processing when 95% of the pixels stay in the same cluster between interations) . CLIP Representative Data There are multiple ways to clip an image. Set the convergence threshold to . 5.img from the moasic step) and provide an output name NOTE: you should output a signature file Initial clusters can be generated either arbitrarily or from an existing signature mean. Enter the number of different NUMBER OF CLASSES (ie. 5. and click on FROM INQUIRE BOX button. With ERDAS running click on the classifier icon from the icon panel Select Unsupervised classification. Start with the image you want to clip in a viewer Click on UTILITY and select INQUIRE BOX Move the box and enlarge it include the area you want to clip Click the DATAPREP button.

This part of the exercise will show you how to merge two classes. The flashing pixels are the pixels in this class. or false color image while also viewing the unsupervised clusters.the unsupervised classified data layer you just created). click on the color patch and change the color. From the viewer menu bar select Utility | Flicker. click on the Class_Name in the editor and give it meaningful name and assign it a meaningful color Repeat steps 6 thur 9 for the other classes. and click on Apply.5. select Raster | Attributes from the viewer. This will add two data layers into a single viewer (one on top of the other).3 . click on the word OPACITY at the top of the Opacity column. Now that your . Now change the color for class 1 to something like Yellow or red so it is easier to see. click on the "0" (the zero on the number pad). Edit signature file Based upon what you discovered when evaluating the location and pattern of the unsupervised clusters you may wish to remove or combine some clusters from the signature file. You should now get values in your Signature Editor table. Evaluate 1. Now the dialog opens. The classes that you see here are those that were generated by the unsupervised classification and are based on spectral properties. You may want to do this after you go into the field and decide that two of the classes that were separately grouped during the unsupervised . this class will be shown in the viewer. Click OK. make sure the "clear display" option is turned off from the "raster options tab" found from that dialog box. you may begin to edit it. Go to the File menu in the Signature Editor window and open the .9. Click OK on the dialog and on the status dialog when the process is completed.this can be either the original "un-clipped" image of the mosiac image) it doesn't matter.sig file that you named in your unsupervised classification. then right-click-hold on the word Opacity and select formula from the column option menu. Change the opacity for class 1 in the Cell Array to 1 and press return.or should be . the editor will be displayed NOTE: you can edit the way this editor appears by selecting Edit | Column Properties Start by setting opacity for all classes to "0". Check for spatial distribution y y y y y y y y y y file|open|raster layer and display your multi bands combination (ie. 2. You will now go through the steps to allow you to view the "true color". In the Raster Attribute Editor. 4. so turn on the auto mode.sig file is open. y y y Click on the Classifer button located in the main menu bar. Select Signature Editor from the menu and a Signature Editor table will appear. All you are going to do is display the classified product "on top" of the unclassified image to help determine what surface material the various self-organized clusters relate to. from the viewer tool bar open a classified raster layer (this could be .

y y classification are really the same thing (i. NOTE: Remember you can go to the View/Arrange layers from the viewer menu and "rightmouse-hold" on the AOI layer and delete the AOI you don't need any longer. There are a number of options for creating supervised training areas (drawing AOI's. Supervised You may also wish to add a signature cluster (a signature or cluster mean) to the signature file for a surface material that you know is present in the image but that you feel is too generally addressed by the unsupervised approach. To do this. you don't need the RED. go to Edit > Delete to get rid them Save the new Signature File and close the Signature Editor table. click on the POLYGON icon.) Repeat these steps for one or two other landcover types 3. In the viewer draw a polygon around the feature In the signature editor click on the add signature icon or select edit/add In the signature editor click inside the signature name column you just added and change the name to something you understand (ie. etc. both are alder). Notice that a new class containing the data that you merged has been added to the last row in your table. In this example we will be merging classes 2 and 3 that were generated from an unsupervised classification into nine total classes Now go to Edit > Merge. you first need to select them from the table. GREEN.e. zoom in) In the AOI tool palette. you can close the classification menu bar explore how to view selected columns by selecting the view/columns option (ie. growing AOI's. click on the row of one of the Class #'s that you want to merge. Display y y y y Display file the representative mosaic as you like click on the Classifier icon on the ERDAS "icon" panel select signature editor to start the signature editor dialog box. With the two merged classes still selected. BLUE columns displayed 2. Hold down the shift key and then click on the other class(es) being merged. 1. To do this you may "supervise" the assignment of the cluster signature by "training" the signature. selecting AOI's from feature space) you can use one or any combinations of these to define training signatures. urban. Options for making training area (AOI) > Growing areas . To merge two classes. AOI = area of interest y y y y y y y from the viewer menu bar select AOI/TOOLS using the viewer ZOOM make sure you can see a feature well (ie. forest.

the dialog box will come up Fill in the name of the input raster layer you are viewing (ie. Scroll down until you see the <imagename_2_5. enter a value (try 300) and press return For spectral distance. Again do as many as you feel happy doing 4. Now link the feature by selecting feature/view/linked cursors from the signature editor. and wait.y y y y y y y y y Select AOI/Seed Properties from the viewer menu bar. When you're happy click on the added Signature (or edit/add) in the signature editor .Click on the Classifer button located in the main menu bar. . the region growing dialog opens Under geographic constraints. Open any of the signature files you wish to append. select) that row. Remember to change the names on all of you signatures.fsp. A polygon will be created based upon the region growing properties you selected « you can play around with those settings. Select Signature Editor from the menu and a Signature Editor table will appear. *. Append the signature files of the unspervised and supervised y y y If a signature file is not currently openned . the area should be check. However.img> row and click on (ie. white cross hairs should come up in both the feature space viewer and the image viewer Drage the inquire cursor around in either viewer and see where geographic objects fall in feature space Use the AOI tool to draw a polygon IN THE FEATURE SPACE VIEWER around the geographic object. A dialog will open Set the viewer to feature space viewer number (or click on the select) Click link. enter something like 10 Click on options and make sure "include island Polygons" is checked Close In the AOI tool palette click on the region grow icon (looks like a magnifying glass) Click inside a different landcover type (say residential) in the viewer.img) and click the "output to viewer" button. Click OK when the job is done and a feature space viewer will come up. Select FILE > OPEN from the menu bar of the Signature Editor and locate a second signature file. clearly you can select a different combination Click OK. That will output band 2 with band 5. Options for making training areas (AOI) > from feature space y y y y y y y y y y y y y Select feature/create/feature Space Layers from the signature editor. Now Add signature in the signature editor The signature you have just added is a non-parametric signature so select feature/statistics from the signature editor menu bar to generate statistics. this time MAKE SURE the Append button is selected.

Image association ensures that the signature file be applied to the "raw" (the original) image.d. maximum. Do a supervised classification of whole image using appended signature file y y y y y y It may be necessary to "associate" the signature file with the image you wish to classify. mean and st. select feature space Click OK wait . In the signature editor menu bar select classify/supervised to perform a supervised classification Enter a new name for both the output and the output distance file Click Attribute options and select minimum.y Repeat these steps until all of the signature files have been append into a single file. Under the NON-parametric rule. Navigate to the whole raw multispectral original image. In the signature editor menu bar select EDIT > Image Association.

Sign up to vote on this title
UsefulNot useful