Perangkat Lunak Basis Data

BAB 1 KONSEP DATABASE DAN PENGENALAN MICROSOFT ACCESS

Tujuan Materi: mahasiswa dapat memahami konsep database dan dapat menjalankan program Microsoft Access 1.1 PERLUNYA DATA Data diperlukan dalam segala hal, baik berupa pengukuran, pencatatan, pengumpulan informasi, maupun pengambilan keputusan semuanya memerlukan data. Dengan kata lain data sangat dibutuhkan karena informasi yang ada akan memberikan arti yang sangat penting baik untuk saat ini maupun untuk akan datang. 1.2 PENGERTIAN DATABASE Database adalah suatu kumpulan data-data yang disusun

sedemikian rupa sehingga membentuk informasi yang sangat berguna. Database terbentuk dari sekelompok data-data yang memiliki jenis/sifat sama. Contohnya : data mahasiswa, data dosen, data pegawai, dll. Demikian juga, kumpulan dari data-data mahasiswa, data-data dosen, data-data keuangan dan lainnya dapat dikumpulkan lagi menjadi kelompok besar, misalkan data-data POLITEKNIK ACEH. Bahkan dalam perkembangannya, data-data tersebut dapat berbentuk berbagai macam data, misalkan dapat berupa program, lembaran-lembaran untuk entry (memasukkan) data, laporanlaporan. Kesemuanya itu dapat dikumpulkan menjadi satu yang disebut dengan database. Beberapa alasan mengapa database diperlukan adalah sebagai 1

Perangkat Lunak Basis Data

berikut: 1. Salah satu komponen penting dalam sistem informasi, karena merupakan dasar dalam menyediakan informasi 2. Menentukan kualitas informasi : akurat, tepat pada waktunya dan relevan. Informasi dapat dikatakan bernilai bila manfaatnya lebih efektif dibandingkan dengan biaya mendapatkannya. 3. Mengurangi duplikasi data (data redudancy) 4. Hubungan data dapat ditingkatkan (data relatability) 5. Untuk memberikan kemudahan dan efisiensi saat kita ingin menyimpan data/informasi dan mengambilnya kembali 1.3 DEFINISI DASAR 1. Database : 2. Data 3. Tabel 4. Field : : : Sekumpulan data yang saling berhubungan untuk mencapai suatu tujuan. fakta-fakta yang dapat disimpan dan mempunyai arti tertentu Tempat untuk menyimpan data, tabel terdiri dari field dan record disebut juga dengan kolom, yaitu bagian tabel tempat menyimpan sebuah item data. Sehingga sebuah field merepresentasikan suatu atribut dari record yang menunjukkan suatu item dari data, seperti misalnya nama, alamat dan lain sebagainya. Kumpulan dari field membentuk suatu record, yang harus memenuhi komponen berikut ini: • field name: Field harus diberi nama untuk membedakan field yang satu dengan lainnya • field representation: harus field didefinisikan (karakter, angka, tipe teks, dsb),

tanggal,

2

Perangkat Lunak Basis Data

lebar diisi • 5. Record : field value: isi

field yang dengan dari field

(ruang dapat karakteruntuk

maksimum

karakter data). masing-masing record. disebut juga dengan baris, yaitu satu bagian informasi yang disimpan dalam tabel, misal data seorang mahasiswa akan disimpan dalam satu record yang terdiri dari beberapa kolom/field Berikut ini adalah sebuah contoh tabel, yang berisi data Dosen: Field

NAMA
Aang Afandi, SE, MM Drs. A. Jarnuzi, Ak, M.Si Andi K. Indrawan, S. Kom Dra. Anik K, MM

NIP
132 311 347 132 057 613 132 310 106 131 789 043

ALAMAT
Jl. Teuku Umar 33 Lhokseumawe Jl. Mawar No. 176 Lhokseumawe Jl. Dr. Wahidin 28 Lhokseumawe Jl. P. Diponegoro 55 Lhokseumawe Baris Record ke 1….n

Data Value

Gambar 1.1 Komponen Table

Ada beberapa sifat yang melekat pada suatu tabel : 1. Tidak boleh ada record yang sama (kembar) 2. Urutan record tidak terlalu penting, karena data dalam record dapat diurut sesuai dengan kebutuhan. 3. Setiap field harus mepunyai nama yang unik (tidak boleh ada yang sama). 4. Setiap field mesti mempunyai tipe data dan karakteristik 3

1. 2. Untuk memulai microsoft Access dimulai dengan klik tombol Start – All Program –Microsoft Office > Microsoft Access 2003 Gambar 1. DBMS adalah sebuah program yang memiliki fasilitas penyimpanan dan pemanggilan struktur informasi pada sistem komputer.mdb.4 MEMULAI MICROSOFT ACCESS Microsoft Access adalah salah satu dari Relasional Database Management System (DBMS).Perangkat Lunak Basis Data tertentu. macros dan program Visual Basic untuk memperluas fungsionalitas dari aplikasi database. Selain tabel. queri untuk mengorganisasi data. sebuah file database Access juga berisi bermacam-macam obyek database yang lain diantaranya: 1. 3. 4. forms untuk berinteraksi dengan data pada layar.2 Langkah Memulai Microsoft Access Berikutnya and akan mendapati jendela Micosoft Access sebagai 4 . Semua obyek ini disimpan dalam file <filename>. Data dalam Microsoft Access disimpan ke dalam suatu Tabel. reports untuk mencetak hasil.

4 Jendela Dialog Membuat Sebuah File Baru Klik tombol Create. maka anda akan mendapatkan sebuah jendela yang berisi obyek-obyek sebuah file database sebagai berikut : 5 . anda akan mendapatkan jendela dialog penyimpanan file sebagai berikut : Lokasi Penyimpanan Nama File Type File Gambar 1.Perangkat Lunak Basis Data berikut: 1 2 Klik Untuk membuat sebuah file database baru Gambar 1. klik Tombol ‘New » pada standart toolbar. akan tampil Task Pane New. dan klik ( new Database ) pada Task Pane.3 Jendela Microsoft Access Untuk memulai membuat sebuah filedatabase baru.

Report. form. Untuk menampilkan bentuk laporan dari hasil output yang sesuai dengan data yang diproses dan di entri. Untuk membuat rancangan dalam tampilan form sebagai bahan untuk memasukan data. 1. mengorganisasi data atau pengabungan dari beberapa table.5 MENUTUP FILE DATABASE DAN KELUAR DARI MICROSOFT ACCESS 6 .Perangkat Lunak Basis Data Gambar 1. Untuk membuat rancangan modul pengolahan database yang dibuat dengan menggunakan kode pada Visual Basic untuk aplikasinya. Query menjadi tombol dan menu secara otomatis. Untuk mengkoordinasikan dari menu Tabel.5 Jendela Obyek Dalam File Database Penjelasan masing-masing obyek tersebut adalah sebagai berikut: OBJECT Table Form Queries Reports Macros Pages Modules KETERANGAN Merupakan struktur data untuk menentukan nama fieldfield beserta perancangan suatu table. dan tempat untuk menyimpan data. Untuk membuat relasi. Untuk merancang tampilan data access pada halaman web melalui system jaringan(server).

Klik menu File Exit. 4. Berikut . Klik Menu File pilih Close 2. Klik Icon control Menu yang terletak disudut kiri atas pilih Close 3. 1. 7 . Untuk Keluar dari MS Access. Klik ganda pada icon control menu yang terletak di bagian sudut kiri atas dari jendela database. Tekan Tombol Close yang ada dibagian sudut kanan atas dari jendela database 6. atau klik tombol Close pada pojok kanan atas. Tekan tombol kombinasi shorcut Key Ctrl + F4 atau Ctrl + W 5.Perangkat Lunak Basis Data Bila Anda telah selesai bekerja dengan file database MS Access maka sebelum menutup file simpan seluruh data yang pernah Anda buka untuk menutup file database salah satu langkah.

Soal praktek Jalankan Microsoft Access dan buat database baru dengan nama Penjualan.Perangkat Lunak Basis Data LATIHAN 1 1.mdb. Pilih menu Microsoft Access pada menu yang tersedia dalam windows. Kerjakan sesuai dengan petunjuk langkah-langkah berikut : • • • • Langkah-langkah untuk menjalankan microsoft access adalah : Siapkan instalasi Microsft Acces yang merupakan satu paket dengan Microsoft Office. Kemudian pilih Blank Database untuk membuat database yang baru. Soal teori (Essay/Multiple Choice) • • Jelaskan dasarnya Berikan ilustrasi komponen tabel yang terdiri dari field (kolom) dan record (baris) 2. pengertian tentang konsep Database dan definisi 8 .

Perangkat Lunak Basis Data BAB 2 MEMBUAT TABEL Tujuan Materi: mahasiswa dapat membuat tabel dan menyimpan data ke dalam tabel di Microsoft Access 2. tempat menyimpan. bagaimana struktur table table satu tersebut dengan dan seperti lain apa jika hubungan/relasi antar table informasinya terpadu. maka lakukan langkah berikut ini: 1. Klik object table Klik untuk membuat sebuah table baru Gambar 2. dan mengelola data dalam database sama seperti Excel kertas kerja menyimpan informasi dalam buku kerja. Pada saat akan membuat sebuah database. Langkah awal yang harus dikerjakan adalah harus merancang table yang akan dibuat.1 MEMBUAT TABLE Tabel adalah obyek untuk tempat menyimpan informasi. Untuk membuat sebuah table baru.1 Membuat Table Access menyediakan tiga cara untuk membuat tabel yang mana 9 .

Setelah tabel disimpan. pilih Field Size. dll. Pilih create table in design view. tentukan juga type datanya dan atur lebarnya data. Field diberi nama umum seperti "Field1". Create table by entering data akan memberi anda datasheet kosong tanpa kolom label yang kelihatan seperti. Pilih Format|Rename Column dari menu bar atau sorot kolom. sesuai dengan perancangan informasi yang akan dibangun. • • Create table using wizard langkah anda dalam membuat tabel. Untuk menggantinya dengan julul lain.Perangkat Lunak Basis Data ada icon dalam Database Window. Ini adalah cara umum untuk membuat tabel dan penjelasannya ada dibawah. 10 . 2. sel kosong datasheet akan dihias. Klik ganda pada icon untuk membuat tabel. Anda akan dihadapkan dengan pilihan untuk memasukkan primary key field. Ketik nama fieldnya. klik kanan didalamnya.2 Dialog Perancangan Table 3. • Create table in Design view akan mengijinkan anda untuk membuat field tabel. Ketik struktrur table yang akan dibuat. anda akan mendapatkan tampilan sebagai berikut: Gambar 2. Excel worksheet. Masukkan data pada sel dan klik tombol Save. dan pilih Rename Column dari shortcut menu. "Field2".

dan tanda baca.Perangkat Lunak Basis Data Gambar 2.3 Struktur Table Keterangan : Field name : Data Type : Untuk memasukan nama-nama field yang akan dibuat Untuk membedakan jenis atau type data yang akan diolah. angka. Macam-macam type data adalah sebagai berikut: • Text: Serangkaian huruf. spasi dan tanda baca Memo: Serangkaian kata yang sangat panjang berupa data • • campuran antara huruf. perihitungan 11 . spasi. Number: Data berupa angka.

Untuk menentukan nilai atau harga awal dari sebuah bilangan secara otomatis sesuai dengan format yang ada. judul title pembacaan Form. format tanggal. format angka. Menjelaskan dari nama Field Data yang berupa object atau Field Properties : Field Size Format : : Untuk menentukan lebar dari nama-nama field tersebut. • • • • Date/Time: Data berupa tanggal atau waktu Currency: Data yang berupa nilai mata uang AutoNumber: Bilangan atau penomeran yang beraturan atau berurutan secara otomatis. Decimal Place Caption Default value : : : Untuk Untuk memasukan penulisan data sesuai atau dengan pada format angka decimal. Validasi Rule : Untuk menentukan nulai atau batasan dan 12 karakter atau label diwakili dengan huruf “L” dan numeric diwakili . waktu dll.Perangkat Lunak Basis Data secara matematik. report dsb. dengan “9”. Untuk menentukan dan mengatur bentuk dari nama field tersebut. Input Mask : Untuk penulisan data pada saat data dimasukan. Yes/No: gambar OLE Object: Data yang berupa object atau gambar Hyperlink: Data yang dapat dihubungkan dengan alamat hyperlink pada lokasi penyimpanan. • Description : Lookup Wizard: Memasukan data dengan memilih salah satu data pada daftar table.

Cara membuat field menjadi Primary Key : • • Letakkan kursor di field tersebut yaitu KodeBuku Klik kanan maka akan muncul menu menentukan Primary Key sebagai berikut : 13 . Indexed Left Right Mid : : : : Untuk menentukan index pada field tersebut. Fungsi string untuk mngambil N karakter dari kiri(Field. dan selalu bersifat Unique. field sebagai Primary Key adalah KodeBukukarena sebagai informasi utama yang membedakan Buku satu dengan Buku lain. Membaca N karakter dari posisi yang diinginkan (Field. bila suatu field digunakan sebagai kunci utama.Perangkat Lunak Basis Data aturan pemasukan data pada sebuah field. Tentukan konstring.N). Required : Untuk menentukan batasan pemasukan data. Validasi text : Untuk mengatur dan mengontrol pemasukan data pada sebuah field. sesuai dengan aturan yang telah ditentukan oleh Validasi Rule.N. 4. batasan-batasan table. jawab “Yes” apakah data akan diisi atau “No” data akan dikosongkan.N) Fungsi string untuk mngambil N karakter dari kanan(Field. Allow Zero Length : Untuk menentukan pemasukan data pada sebuah field jika data tersebut valid atau tidak.N).maka field tersebut harus menjadi Primary Key Struktur table diatas.

misalkan diberikan ketentuan sebagai berikut : “Input Mask : L99” Bila ingin membuat format entri Kode Buku karakter pertama harus berupa abjad dan diikut dengan dua angka numerik.4 Menentukan Primary Key Maka Field yang merupakan primary key akan ditandai dengan gambar kunci disebelah kiri field tersebut.1)=”D” Melakukan validasi. abjad pertama dari kiri yang bisa di entri adalah huruf H dan D. Bila ingin memberi aturan atau validasi rule pada fields tertentu misalnya KodeBuku dengan tujuan agar Kode Buku yang dimasukan memiliki bentuk kode yang standart sehingga tidak sembarang entri kode bisa diterima. 5.Selain itu tidak diijinkan memasukan data 14 .1)=”H” or Left([KodeBuku ]. Sebagai berikut: Validasi Rule : Left([KodeBuku ].Perangkat Lunak Basis Data Gambar 2.

Simpan perancangan struktur table diatas.Perangkat Lunak Basis Data sembanrang selain huruf H atau D. Validasi Text : “Tidak boleh sembarang memasukan data” 6. Gambar 2.5 Menyimpan Tabel 15 . lalu pilih simpan maka beri nama table tersebut. klik menu File.

mdb pada folder anda. Akuntansi. selanjutnya anda harus menyimpan semua pekerjaan pada foder tersebut! 2.Perangkat Lunak Basis Data LATIHAN 2 1. Buat file untuk menyimpan data Buku yang ada di ruang referensi Jur. dan buatlah sebuah file baru. Bukalah Microsoft Access. simpan dengan nama Latihan2. 3. Buatlah sebuah folder dengan nama :ACCESS-KELAS-NO ABSEN. File tersebut memiliki tabel sebagai berikut (tanpa Primary Key): 4. Isikan datanya dengan data berikut ini: 16 .

MEMASUKKAN DAN MENGHAPUS KOLOM Walaupun yang terbaik adalah membuat field baru (tampilan kolom dalam datasheet) pada design view karena banyak pilihan 17 . 3. untuk menghapus Letakkan Kursor di sini.3. pertama. dan akhir tombol arsip pada bawah datasheet membantu dalam manuver datasheet.1 Menghapus dan Mengedit Record 3. mudah saja tempatkan kursor dalam arsip yang akan diedit dan buat perubahan yang penting. untuk mengedit Gambar 3. Letakkan Kursor di sini. Gunakan panah untuk memindahkan arsip.2 MENGHAPUS RECORDS Menghapus arsip pada dataseheet dengan menempatkan kursor dalam baris dan pilih Edit|Delete Record dari menu bar atau klik tombol Delete Record pada datasheet toolbar. Sebelumnya.1 MENGEDIT RECORDS Untuk mengedit arsip. selanjutnya.Perangkat Lunak Basis Data BAB 3 MENGELOLA TABEL Tujuan Materi: mahasiswa dapat mengelola data/record yang ada dalam tabel di Microsoft Access 3.

kolom pada datasheet bisa berbeda lebarnya. tinggi semua baris dalam datasheet akan berubah menjadi value yang baru. mereka bisa juga dengan cepat memasukkannya dalam datasheet view.4 MENGUBAH UKURAN BARIS DAN KOLOM Tinggi baris dalam datasheet bisa diubah dengan mendrag garis abu antara label baris diatas dan bawah dengan mouse. Kolom pada tabel Access table bisa dibekukan (Freezing).Perangkat Lunak Basis Data disediakan. Pilih option yang sama untuk menghilangkan freeze kolom atau pilih Format|Unfreeze All Columns. 3. Sorot kolom yang merupakan kolom baru yang ditampilkan ke sebelah kiri dengan mengklik label di atas datasheet dan pilih Insert|Column dari menu bar. Freeze kolom dengan cara menempatkan kursor pada suatu arsip dalam kolom lalu pilih Format|Freeze Columns dari menu bar. Tidak seperti baris. Klik ganda pada baris untuk mendapatkan kolom otomatis cocok untuk value yang panjang dari kolom. Ini membantu jika datasheet memiliki banyak kolom dan data relevan akan tidak tampak dilayar pada saat bersamaan. 18 . Memasukkan kolom bisa juga dengan menghapus dengan menempatkan kursor dalam kolom dan memilih Edit|Delete Column dari menu bar. Ukuran nya bisa diubah dengan memilih Format|Row Height atau Format|Column Width dari menu bar. Lebar kolom bisa diubah dalam beberapa cara dengan mendrag ukuran baris antara kolom.5 FREEZING COLUMNS Sama seperti dalam Excel. Dengan mengubah tinggi satu baris. 3.

dan pilih Format|Hide Columns dari menu bar Untuk menampilkan kolom yang disembunyikan.3 Melakukan Unhide Kolom 3. pilih Format|Unhide Columns dari menu bar.Perangkat Lunak Basis Data Gambar 3. Ceklist kotak disaming semua field yang ingin ditampilkan pada tabel data dan klik tombol Close.7 MENCARI DATA DALAM TABEL 19 .6 MENYEMBUNYIKAN KOLOM Kolom bisa juga disembunyikan dari tampilan dalam datasheet walaupun mereka tidak akan dihapus dalam database. Untuk menyembunyikan kolom. tempatkan kursor pada sembarang arsip dalam kolom atau sorot beberapa kolom yang bersebelahan dengan mengklik dan mendrag mouse sepanjang kolom header. Jendela akan menampilkan semua field dalam tabel daftar dengan daftar kotak disamping masing-masing nama field. Gambar 3.2Melakukan Freeze Pada Kolom 3.

Buka tabel dalam tampilan datasheet. Jika lebih dari satu arsip menemukan kriteria.). 6. Pilih kriteria yang sesuai dari Match: dan klik tombol >> untuk menambahkan parameter pencarian. Tempatkan kursor dalam suatu arsip dalam field yang ingin dicari dan pilih Edit|Find. Ketika semua kriteria pencarian diset.Perangkat Lunak Basis Data Data dalam datasheet bisa dengan cepat ditemukan lokasinya dengan menggunakan perintah Find 1. dari menu bar 3.8 MENCARI DAN MENGGANTI Fungsi Find and Replace mengijinkan anda untuk secara cepat mengganti data tunggal denan value baru atau mengganti semua kejadian dalam tabel 1..4 Jendela Dialog Find 3. 5. 2. terus klik Find Next sampai anda mencapai arsip yang benar. Dari Look In: menu panah kebawah.. dari menu bar (atau klik Replace tab jika menemukan jendela telah terbuka. Pilih Edit|Replace.. Masukkan nilai kriteria value dalam kotak Find What: . gambarkan area pencarian dengan memilih keseluruh tabel atau hanya field dalam tabel yang tempat anda meletakkan kursor dalam langkah ke 2. 20 .. klik tombol Find Next. 4. Gambar 3.

3.5Jendela Dialog Find and Replace 21 . Klik Replace All untuk mengganti semua data dalam satu langkah. Klik tombol Find Next dan tombol Replace untuk membuat pergantian tunggal.Perangkat Lunak Basis Data 2. Ikuti langkah prosedur pencarian data untuk mengganti dan mengetik nilai baru dari data dalam kotak Replace With:. Gambar 3.

menjadi Primary Key Ubahlah Record dengan kode K01.10 Judul TahunTerb it Eksempla r 17 12 Pengarang Siti Sunrowiyati Andy Syahputra 22 . pada folder anda 2.Perangkat Lunak Basis Data LATIHAN 3 1.. Ubahlah Field KodeBuku. 5. Tambahkan Record-Record berikut ini: KodeBuk u K07 K07 Tip dan Trik 2008 Microsoft Access 2003 Linux Red Hat 2006 V. 4. menjadi Pemrograman C++ Hapuslah Record dengan KodeBuku K03. Copykan File LATIHAN 2.MDB. pada filed Judul : Pemrograman C. 3.MDB. menjadi file baru dengan nama LATIHAN 3.

Untuk link field dalam dua tabel yang berbeda. diedit atau dihapus. 5. 3. Pilihan ini memberikan Access izin untuk secara otomatis membuat perubahan tabel petunjuk jika kunci arsip dalam satu tabel yang dihapus. pilih field yang berbeda jika perlu dan pilih option dari Enforce Referential Integrity jika perlu. 4.Perangkat Lunak Basis Data BAB 4 MERELASIKAN TABEL Tujuan Materi: mahasiswa dapat membuat relasi antar tabel di Microsoft Access 4. klik dan drag field dari satu tabel ke field yang sesuai dalam tabel yang lain dan lepaskan tombol mouse. klik Close. Ketika anda selesai memasukkan tabel. Klik tombol Relationships pada toolbar. Ceklist kotak Enforce Referential Integrity untuk memastikan hubungan bisa dilakukan dan data bukan secara kebetulan dihapus ketika data dimasukkan. Dari jendela Show Table (klik tombol Show Table pada toolbar untuk membuat tampilan ). Datasheet suatu hubungan tabel akan menyediakan perluasan dan tanda penghapusan untuk melihat isi subdatasheets 23 .1 MERELASIKAN TABEL Untuk mencegah duplikasi informasi dalam database dengan pengulangan fields dalam satu tabel. Klik ganda pada nama tabel yang akan dimasukkan ke dalam hubungan. 2. Dari window ini. Ikuti langkah dibawah untuk membuat hubungan database. hubungan dapat dibentuk untuk link field tabel secara bersama. Edit Relationships window akan muncul. Klik Create untuk membuat link. Baris sekarang menghubungkan dua field dalam hubungan relationships window. 1.

Anda akan mendapatkan tampilan berikut ini: Gambar 4. lakukan langkah-langkah berikut ini: 1. Tambahkan tabel satu persatu. pilih Add table Gambar 4.2 MEMBUAT RELASI ANTAR TABEL Untuk membuat relasi antar tabel.1Menambahkan Tabel Pada Jendela Relationship 3. pilih Format| Subdatasheet|Expand All atau Collapse All dari menu toolbar. 5. Untuk memperluas atau menghilangkan semua subdatasheets sekaligus. klik Tools -> Relationships 2. dan drag ke field yang akan direlasikan pada table lain. pilih tabel kemudian klik tombol Add. Klik Kanan pada Mouse. Terakhir klik tombol Close 6.. tekan tombol 24 . 4.1Tabel Yang Siap Direlasikan 7. Tambahkan tabel-tabel yang akan digunakan pada relasi 4. pada menu.Perangkat Lunak Basis Data informasi yang sesuai dari tabel lain. Relasikan dengan Mengklik salah satu field pada tabel.

Perangkat Lunak Basis Data “create” untuk membuat relasi. 8.3Tampilan Relashionship Gambar 4.4Tabel yang telah direlasikan 25 . Hasilnya tampak seperti ini: Gambar 4.

Perangkat Lunak Basis Data

LATIHAN 4 1. Buatlah sebuah file database, simpan dengan nama LATIHAN 4.MDB pada folder anda. 2. Buatlah tabel-tabel di bawah ini, untuk struktur tabel silahkan anda tentukan sendiri. Tabel Barang
NomerBrg B01 B02 B03 B04 B05 B06 B07 B08 B09 B10 B11 B12 B13 B14 B15 B16 B17 B18 B19 B29 B30 B31 B32 B33 B34 B35 NamaBrg Pensil Staedler 2B Bolpoint Weiyada Hitam Bolpoint Weiyada Merah Bolpoint Weiyada Biru Spidol Board Marker Swallow Hitam Spidol Board Marker Swallow Merah Spidol Board Marker Swallow Biru Gunting Kecil Stapler Staples,500 Staples,250 Notes Kecil Kertas Surat KotakPensil Penghapus Staedler Kecil Penghapus Staedler Besar Penggaris Besi 30 Cm Penggaris Besi 20 Cm Cutter Besar Kenko Cutter Kecil Kenko Isi Cutter Besar Isi Cutter Kecil Kertas A4 Sinar Dunia Kertas F4 Sinar Dunia Correction Fluid Kenko Correction Pen Tipex Harga 1500 2000 2000 2000 4500 4500 4500 5000 10250 3000 2500 7000 2500 13000 8250 12500 6000 4000 15000 10000 4000 2500 24000 29000 14000 17000 1 5 1 2 2 3 8 4 6 9 1 2 8 7 4 9 9 7 8 7 4 6

Tabel Detail_Order
NomerOrder NomerBrg Jumlah B02 B02 B03 B04 B05 B05 B06 B07 B09 B09 B11 B12 B14 B16 B17 B19 B22 B26 B29 B31 B34 B35 3 12 3 15 2 6 5 2 5 10 3 2 10 4 2 19 12 10 10 5 2 10

26

Perangkat Lunak Basis Data

Tabel Order
NomerOrder NomerPlg TanggalOrder 1 2 3 4 5 6 7 8 9 P01 P01 L01 L02 L01 P02 P03 L03 L04 07/05/2008 07/05/2008 08/05/2008 08/05/2008 08/05/2008 09/05/2008 09/05/2008 10/05/2008 10/05/2008

Tabel Pelanggan
NomerPlg L01 L02 L03 L04 P01 P02 P03 NamaPlg Toharudin Iffa Soraya Habadal Arif Diana Pungki Ali Mansyur Alamat Jl. Anggrek 66 Kota Telpon Lhokseumawe 08123334455 Lhokseumawe 08156622111 Lhokseumawe 08585667799 Lhokseumawe 08585663322 Lhokseumawe 08195558888 Lhokseumawe 08585992222

Abubakar Husin Jl. Rinjani 33 Jl. Borobudur 67 Jl. Dr. Soetomo 11 Jl. Teluk Etna 77

Jl. Danau Kintamani 44 Lhokseumawe 08172299999

Saleh Al Habsi Jl. Dahlia 90

3. Relasikan tabel-tabel tersebut, sehingga Realtionshipnya memiliki tampilan sebagai berikut:

27

Perangkat Lunak Basis Data

4. Sedangkan Tabel Pelanggan, jika dibuka mempunyai tampilan sebagai berikut:

28

Untuk memfilter dengan memilih. Pilih Records|Sort|Sort Ascending atau Records|Sort|Sort Descending dari menu bar atau klik Sort Ascending atau tombol Sort Descending pada toolbar. kursor ditempatkan dalam City field pada arsip kedua yang berbubungan dengan "Ft.Perangkat Lunak Basis Data BAB 5 MENGURUTKAN DAN MENYARING DATA Tujuan Materi: mahasiswa dapat mengurutkan dan menyaring data/record dalam tabel di Microsoft Access 5. Seperti dalam contoh dibawah. Untuk menyortir lebih dari satu kolom (seperti menyortir dalam tanggal dan lalu menyortir arsip dengan tanggal yang sama dalam alphabet). 5. Myers" lau 29 . Pada tabel view. sorot kolom dengan mengklik dan mendrag mouse melewati label field dan pilih satu dari metode diatas. tempatkan kursor dalam filed yang ingin disaring dalam arsip dan klik tombol Filter by Selection dalam toolbar atau pilih Records|Filter|Filter By Selection dari menu bar. tempatkan kursor dalam kolom yang ingin di sortir.1 SORTING Anda boleh melihat arsip dalam tabel dalam perintah berbeda dari yang mereka tampilkan seperti menyortir dalam tanggal atau memberi perintah secara alphabet. 1.2 FILTER BY SELECTION (MENYARING DENGAN MEMILIH) Fitur ini akan menyaring arsip yang berisi data identik bernilai pada field seperti menyaring semua arsip yang berhubungan dengan "Smith" dalam field. untuk contoh. Ikuti langkah untuk menyortir arsip dalam tabel dengan menggunakan angka pada satu field. 2.

5. Setelah anda memilih semua kriteria yang diinginkan untuk disaring. klik tombol Apply Filter pada toolbar. Untuk menetapkan suatu kriteria jika arsip berisi satu dari dua nilai spesifik. 30 .3 FILTER BY FORM Jika tabel sangat luas.Perangkat Lunak Basis Data penyaringan tabel akan menunjukkan hanya arsip dimana city dari Ft. dengan menggunakan Filter by Form akan sangat menguntungkan. Myers. Metode berikut dapat digunakan untuk memilih arsip berdasar arsip yang dipilih dengan tidak memiliki nilai yang sama persis. Lebih Or tabs akan muncul setelah satu kriteria diset untuk mengijinkan anda untuk memasukkan lebih kriteria dengan filter. Metode ini membuat versi kosong dari tabel dengan menu panah kebawah untuk masingmasing field berisi hubungan nilai yang ditemukan dalam arsip pada field. klik Or tab pada bawah jendela dan pilih kriteria lain dari menu panah bawah. sangat sulit untuk mencari arsip yang berisi hubungan yang ingin disaring. klik dalam field untuk masuk ke kriteria filter. Dibawah default Look for tab dalam jendela Filter by Form.

Masukkan nama dari query dan klik OK. 5. Query sekarang disimpan dalam database 31 .4 MENYIMPAN FILTER Isi dari dari saringan tabel bisa disimpan dengan memilih File| Save As Query dari menu bar.Perangkat Lunak Basis Data Ketikan format ini ke dalam field dimana menu panah kebawah akan tampil sebagai pengganti pemilihan nilai absolut.

secara Descending sehingga mempunyai tampilan sebagai berikut: 4. Copy file LATIHAN 4. Gunakan Filter By Selection Untuk Menampilkan Banang yang harganya Rp. menjadi sebuah file baru dengan nama LATIHAN 5. sehingga memiliki sebagai berikut: tampilan 32 . secara Ascending sehingga mempunyai tampilan sebagai berikut: 3.MDB pada folder anda.Perangkat Lunak Basis Data LATIHAN 5 1. Buka Tabel Pelanggan. urutkan berdasar nama.MDB . Buka Tabel Barang. urutkan berdasar nama. 2000. 2. masih menggunakan tabel Pelanggan.

Perangkat Lunak Basis Data 5. 6. 2000. Jalankan Query pada soal No 4. Buka Tabel Barang. di atas sehingga memiliki tampilan sebagai berikut: BAB 6 33 . simpan sebagai Query dengan nama Query Harga > 2000. Gunakan Filter By Form Untuk Menampilkan Banang yang harganya >Rp.

1 Membuat Query 2.Perangkat Lunak Basis Data MEMBUAT OBYEK QUERIES Tujuan Materi: mahasiswa dapat membuat obyek query di Microsoft Access 6. Ikuti langkah dibawah untuk membuat new query dalam Design View: 1. Pilih Create Query in design. sehingga informasi bias sesuai dengan kebutuhan yang dicari maupun yang akan dilaporkan.1 MEMBUAT QUERY DALAM DESIGN VIEW Membuat Queries pada dasarnya adalah perintah untuk menyajikan informasi dengan menggunakan hubungan antara variable yang saling melengkapi informasinya. Buka object/menu Query seperti sebagai berikut : . maka akan muncul dialog memilih query seperti dibawah ini : 34 . Gambar 6.

Pilih semua tabel (Klik Tabel Barang. sambil menekan tombol Shift.Perangkat Lunak Basis Data Gambar 6. anda akan mendapatkan Tampuilan sebagai berikut: Gambar 6.3 Hasil pemilihan query table 4. Klik Tabel Pelanggan)  Tekan tombol Add  Tekan Tombol Close. seperti sebagai berikut : 35 . pilih Field pada table yang berisi informasinnya.2 Memilih Query 3. Lalu tentukan informasi yang akan ditampilkan.

yang berisi penjumlahan ataupun perkalian dari field-fiel yang ada.2 MENAMBAHKAN FIELD BERISI PENJUMLAHAN PADA QUERY Anda bisa menambahkan satu atau beberapa Field dalam sebuah Query. lalu beri nama Query Penjualan 6. Untuk Menjalankan hasil Query . kemudian tuliskan formulanya sebagai berikut: 36 . Untuk menyimpan Query : Pilih File dan klik Save. maka anda akan mendapatkan tampilan sebagai berikut Gambar 6.7 Tampilan Query 6.4 Menentukan informasi relasi antar table 5. Untuk membuatnya. letakkan kursor pada field yang diinginkan.Perangkat Lunak Basis Data Gambar 6. Klik Tombol Run pada toolbar.

1]*[Field..9 Tampilan Query. dengan field yang ditambahkan Maka jika Query tersebut dijalankan.8 Design Query.2]*[Field.. anda akan mendapatkan tampilan sebagai berikut: Field Baru Gambar 6.Perangkat Lunak Basis Data Nama Field baru:[Field. dengan field yang ditambahkan 6.3 MENAMBAHKAN KRITERIA PADA QUERY 37 .n] Misal: kita mebuat sebuah Query penjualan. dengan susunan fieldfield sebagai berikut: Field yang dibuat dengan menggunakan Rumus Gambar 6..

4 MENGHAPUS RELASIONSHIPS ANTAR TABLE 38 . harus diapit tanda “ ”. Sebagai Contoh. bila numeric tanpa tanda “ ”. maka pada Field Anggota. bila ingin menyajikan data pembali yang membeli mulai tanggal 08/05/2008 maka pada Criteria tanggal isi dengan >#20/2/2006#. bila sebagai criteria berupa data teks. tuliskan kriteria yang ditentukan. misalnya menampilkan pembelian yang hanya dilakukan oleh Toharudin. kita akan menampilkan pembelian yang dilakukan oleh Toharudin.Perangkat Lunak Basis Data Bila ingin ingin menyajikan hasil queri dengan memberikan criteria.10 Query dengan Kriteria Hasilnya adalah sebagai berikut: Gambar 6.11 Hasil Query dengan Kriteria 6. maka design Query-nya adalah sebagai berikut: Gambar 6.

Gambar 6.Perangkat Lunak Basis Data Untuk menghapus relasi antar tabel maka.12 Menghapus Relasi Query 39 . hubungan antar table tersebut. lalu pilih Delete. maka tanda [penghubung akan terhapus. klik garis penghubung antar tabel atau ditunjuk dengan mouse lalu klik kanan maka akan muncul seperti dibawah ini.

Buatlah sebuah file database dengan nama LATIHAN 6. simpan pada folder anda masing-masing. Adapun tabel struktur tabel-tabelnya adalah sebagai berikut: Tabel: Produk Field Name IdProduk NamaProduk Katagori HargaPerUnit LevelOrder LeadTime Tabel: Katagori Field Name IdKatagori Katagori 3. 2. Data Type Autonumber Text Decription Data Type Autonumber Text Text Text Number Number Decription Jumlah persediaan minimum Waktu pemesanan Adapun isi tabelnya adalah sebagai berikut: 40 .MDB.Perangkat Lunak Basis Data LATIHAN 6 1.

MDB. untuk field Katagori. Katagori. a.MDB. untuk produk yang Level Ordernya kurang dar 8. Tampilkan Relationship. b. Tampilkan Relationship. Ubahlah struktur tabel Produk. HargaPerUnit. NamaProduk. Katagori. Buatlah sebuah relasi antar tabel Katagori dan Tabel Produk. HargaPerUnit. menjadi data type “Lookup Wizard”. dengan menggunakan Field Katagori sebagai field relasi. LeadTime. Katagori 6. Buatlah sebuah Query untuk menampilkan field-field : IdProduk. 5. 25. HargaPerUnit. LeadTime. IdKatagori. IdKatagori. NamaProduk. dan lihatlah jenis relasi apa yang dimiliki 41 . untuk produk makanan 7. Katagori. LevelOrder. Katagori. yang merujuk pada Field Katagori pada Tabel: Katagori. LevelOrder. Simpan File LATIHAN 6. dan lakukan perubahan sebagai berikut: Hapus relasi yang dimiliki Tabel Katagori dan Tabel Produk. LevelOrder. dan lihatlah jenis relasi apa yang dimiliki Buatlah sebuah Query untuk menampilkan field-field : IdProduk. dengan nama baru File LATIHAN 6A. NamaProduk. 4. Buatlah sebuah Query untuk menampilkan field-field : IdProduk. Katagori. LeadTime. IdKatagori.Perangkat Lunak Basis Data 3.

Langkah-langkah : 1. Klik Obyek Form Dalam aplikasi database. dll. form barang. Form digunakan untuk menginputkan data dan memodifikasi data yang ada dalam tabel. contoh form siswa. dll. • Form transaksi : yaitu form yang digunakan untuk data transaksi. dibedakan menjadi : • Form master : yaitu form yang digunakan untuk data pada tabel master. Buka database CV FAJAR UTAMA 2. contoh : form penjualan.1 MEMBUAT FORM DENGAN WIZARD Form dibuat dengan tujuan untuk memberikan tampilan hasil pengelolaan informasi yang disajikan dengan lebih mudah. form entri nilai. lebih menarik serta informatif menggunakan Graphical User Interface.Perangkat Lunak Basis Data BAB 7 MEMBUAT OBYEK FORM Tujuan Materi: mahasiswa dapat membuat obyek form di Microsoft Access 7. form dapat 42 .

Misal tabel DATA PRIBADI 5. Cara memilih dengan menekan tombol botton panah satu bila ingin menyeleksi satu persatu dan pilih tombol panah dua jika seluruh field diinginkan. maka masukan field-field yang dibutuhkan yang nampak dalam kotak Available Fields.Perangkat Lunak Basis Data Gambar 7. Double Click Create Form By Using Wizard. anda akan memperoleh tampilan sebagai berikut:Pilih dan klik Form Wizard Untuk memilih tabel source Untuk memindah 1 field Untuk memindah semua field Gambar 7.1 Create Form By Using Wizard 3.2 Form Wizard memilih tabel dan field 4. Pilih table yang akan dibuat form entrinya.Seperti namap berikut seperti nampak dibawah ini: 43 .

Pilih Layout Form yang diinginkan. Tabular.3 Memilih Tabel dan Field yang dimasukan di Form 6. Ini ditunjukkan dalam gambar berikut ini: 44 . apakah Columnar.Perangkat Lunak Basis Data Gambar 7. dan lain-lain. anda akan mendapatkan jendela pemilihan Layout sebagai berikut: Gambar 7. Pilih Next jika sudah menentukan jenis layout yang diinginkan. maka akan muncul dialog jenisjenis style yang diinginkan dalam form nantinya. dengan tampilan yang diinginkan : 8. Klik Next ke langkah selanjutnya. misalnya tadi dipilih Columnar.4 Memilih Layout Form 7.

Pilih Next untuk melanjutkan bila sudah ditentukan jenis style yang diinginkan. Misalnya pilih Expedition untuk contoh style diatas. Pilih Next untuk melanjutkan maka akan diminta memasukan judul dalam form yang akan ditampilkan: DATA PRIBADI Gambar 7.5 Style Form Wizard 9. 10.6 Memberi Nama pada Form Wizard 11. Bila ingin memodifikasi atau merubah rancangan form maka pilih Modify the form’s design. 45 .Perangkat Lunak Basis Data Gambar 7.

Jika anda tidak ingin memodifikasi atau merubah rancangan form maka pilihlah Open The Form To View or Enter Information.2 MEMBUAT FORM DENGAN DESIGN VIEW 46 . kemudian klik Finish.Perangkat Lunak Basis Data Gambar 7.7 Form Design untuk merubah Desain Form 12. maka anda akan mendapatkan tampilan Form sebagai berikut: Gambar 7.8 Tampilan Form DATA PRIBADI 7.

Sehingga nampak seperti dibawah ini : 47 .10 Lembar design view dalam form Lalu field dalam table yang telah tampil diatas pilih dan geser. 2. pilih Design View. dan Form lalu. Pilih menu Insert. letakan pada lembar yang telah disediakan oleh section detail. Pilih Tabel/Query yang akan digunakan sebagai source-nya Gambar 7.9 Merancang form dengan Desin View Gambar 7.Perangkat Lunak Basis Data Tujuannya untuk membuat rancangan form yang kosong dengan memasukan nama-nama field dengan cara menarik dari form ke kiri dan ke kanan. ke atas dan ke bawah. Langkah-langkah : 1.

11 Memasukan Field di Lembar Detail dalam form Gambar 7. Hasil running perancangan form dengan Design View 7. baik yang kita buat melalui Form Wizard.Perangkat Lunak Basis Data Klik dan Drag Gambar 7.3 MEMODIFIKASI FORM Kita bisa memodifikasi form.12. maupun dengan menggunakan Design view. dalam tampilan Design View: 48 . Berikut ini adalah bagian-bagian dari sebuah form.

Menambahkan form header.Perangkat Lunak Basis Data Gambar 7. kemudian klik dan drag untuk memperlebar jaraknya sehingga cukup tercipta satu ruang. lakukan juga klik dan drag. Anda juga dapat memperlebar batar grid (garis kotak-kotak0 juga dengan melakukan klik dan drag. Untuk memindahkan label dan data. buatlah sebuah texbox pada form header dan tuliskan nama perusahaan Gambar 7. berupa nama perusahaan.13 Menambahkan Nama perusahaan menggunakan Label 49 . 1.12 Hasil running perancangan form dengan Design View Pada gambar di atas. Klik pada form header. kemudian pilih label pada toolbox. anda bisa meletakkan kursor di batas antara Form Header dan Detail.

Merubah Type Font dan Ukuran Font Untuk merubah ukuran dan type font. kemudian ubahlah ukuran dan type font menggunakan fasilitas yang ada pada standar toolbar.Perangkat Lunak Basis Data 2. klik label yang anda buat. Hasilnya adalah sebagai berikut: Gambar 7. lengkapi juga dengan Alamat dan Nomor telpon perusahaan 3. Menambahkan Logo Perusahaan Anda juga bisa menambahkan logo perusahaan. (tenbtukan lokasi gambar/ClipArt yang diinginkan. Hasil akhir nya adalah sebagai berikut: 50 . Caranya adalah: Klik pada lokasi Form Header  Insert  Picture.14 Merubah Font Type dan Font Size Dengan cara yang sama. maupun ClipArt.

Perangkat Lunak Basis Data Gambar 7.14 Tampilan Form Data Pribadi 51 .15 Tampilan Akhir Dalam Form Design Gambar 7.

Perangkat Lunak Basis Data LATIHAN 7 1. Buatlah tabel DATA PRIBADI. simpan dengan nana FORM DATA PRIBADI. dengan struktur sebagai berikut: 2. dengan struktur sebagai berikut: 4. yang memilki tampilan sebagai berikut: 52 . Buatlah SEBUAH Form untuk mengisikan DATA PRIBADI Karyawan. dengan struktur sebagai berikut: 3. Buatlah tabel DATA KERJA. Buatlah tabel TARIF UPAH LEMBUR.

RAYA 135 JL. Melalui Form tersebut isikan Data Pribadi Karyawan. yang memilki isi sebagai berikut: Tabel: DATA PRIBADI NIP NAMA GOLONGAN 3 2 2 2 1 1 1 1 1 ALAMAT JL. Bentuk Form anda atur sendiri. Dr. LUMBAN BATU 96007 MARIA ULFAH 97010 TENGKU RAFLI 98012 SUMARDI 99014 ZASKIA HASAN 99015 MARDIANSYAH JL. simpan dengan nama form yang sama dengan nama tabelnya. Buatlah Form untuk mengisikan Tabel DATA KERJA dan TARIF UPAH LEMBUR. Atur tampilannya sehingga tampak menarik. HASANUDIN 19 JL. dengan bagian Form Header buat sama dengan foRM data pribadi 53 . SOETOMO 56 JL. SLAMET RIYADI 66 JL. DIPONEGORO 78 JL.Perangkat Lunak Basis Data Form header Detail 5. MERAPI 90 JL. CEMARA 34 JL. DANAU TOBA 35 KOTA BANDA ACEH BANDA ACEH BANDA ACEH KOTABARU BANDA ACEH KOTABARU BANDA ACEH KOTABARU BANDA ACEH 95001 ZAINAL ARIFIN 95002 AHMAD SYARIF 95003 CUT MEUTIA 96006 K. CUT NYA' DIN 21 JL. PANGLIMA POLIM 99 BANDA ACEH 99017 TOGAR SIMATUPANG 1 6.

Gunakan Form untuk mengentry data: Tabel: TARIF UPAH LEMBUR GOLONGAN UPAH PER HARI LEMBUR PER JAM 1 2 3 15000 20000 25000 1500 2000 2500 Tabel: DATA KERJA NIP BULAN HARI KERJA JAM LEMBUR 24 3 5 12 12 0 0 5 0 12 8 0 10 8 2 0 5 3 12 15 0 22 25 26 24 22 23 22 26 25 22 24 25 23 20 25 22 26 26 22 95001 MEI 95001 JUNI 95002 MEI 95002 JUNI 95003 MEI 95003 JUNI 96006 MEI 96006 JUNI 96008 MEI 96008 JUNI 97010 MEI 97010 JUNI 98012 MEI 98012 JUNI 99014 MEI 99014 JUNI 99015 MEI 99015 JUNI 99017 MEI 99017 JUNI Tabel: 54 . Isikan tabel-tabel di atas dengan data berikut ini.Perangkat Lunak Basis Data 7.

Untuk menamambahkan command button. Klik tombol command button.Perangkat Lunak Basis Data BAB 8 MENAMBAHKAN COMMAND BUTTON PADA FORM Tujuan Materi: mahasiswa dapat menambahkan obyek command button dalam form di Microsoft Access 8. Pilih Catagories dan Actions. 1. 55 . Pastikan tombol ini aktif berada Tombol command button Gambar 8. dan yang jika diklik maka aka\n menjalankan suatu perintah tertentu.1 Toolbox 2.1 MENAMBAHKAN COMMAND BUTTON Command Button adalah tombol-tombol yang bisa ditambahkan pada Form. Form harus pada tampilan Form Design.

Pilih gambar untuk simbol command button. Gambar 8.Perangkat Lunak Basis Data Gambar 8.2 Memilih katagori dan Action 3. Tentukan nama command button (dapat diabaikan) 56 .3 Memilih Simbol untuk Button 4.

Perangkat Lunak Basis Data Gambar 8.5 Form Design Dengan Tambahan Command Button Gambar 8.4 Memilih nama untuk command Button Gambar 8.6 Form Design Dengan Tambahan Command Button 57 .

tambahkan Tulisan “Design By: Nama anda”. Tambahkan beberapa command button. 58 . Tambahkan beberapa command button. Copykan file LATIHAN 7. Serta pada Form Footer. Untuk 2 Form Lainnya.MDB. Sehingga memiliki tampilan sebagai berikut: Exit Form Add New Record Delete Record Save Record Record Navigation 3. tambahkan Tulisan “Design By: Nama anda”.Perangkat Lunak Basis Data LATIHAN 8 1.MDB 2. Serta pada Form Footer. menjadi file baru dengan nama baru LATIHAN 8. aturlah sesuai selera anda.

akan tetapi dibutuhkan report untuk keperluan pelaporan yang sesuai dengan kebutuhan manajemen. yaitu Create Report in Design View dan Create Report by Using Wizard. Klik Next untuk melanjutkan ke step berikutnya. dan Pilih Report Wizard. laporan dapat dipreview atau dicetak ke kertas. seperti contoh berikut : Gambar 9. tidak cukup dilihat dalam form.Membuat laporan dalam acces ada dua fasilitas. Buka database. missal table buku.1 Memilih Source dan Field 2. Langkah-langkah : 1.1 MEMBUAT LAPORAN MELALUI REPORT BY USING WIZARD Data yang telah dimasukan dalam table. yaitu menentukan Field apa yang digunakan sebagai dasar 59 . tabelnya.Perangkat Lunak Basis Data BAB 9 OBYEK REPORT Tujuan Materi: mahasiswa dapat membuat obyek report di Microsoft Access 9.

(misal kita ikuti pilihan yang disediakan. Klik Next untuk melanjutkan ke step berikutnya. yaitu menentukan Field apa yang digunakan sebagai dasar pengurutan (sorting) Gambar 9.3 Memilih Field Untuk Dasar Pengurutan 60 .2 Memilih Source dan Field 3. yaitu berdasar GOLONGAN) : Gambar 9.Perangkat Lunak Basis Data pengelompokkan.

Gambar 9. yaitu menentukan nama Report yang akan disimpan.Perangkat Lunak Basis Data 4. Klik Next untuk melanjutkan ke step berikutnya.4 Memilih layout report Gambar 9. Klik Next untuk melanjutkan ke step berikutnya.5 Memilih style report 5. 61 . yaitu menentukan Layout dan style apa yang diinginkan.

Perangkat Lunak Basis Data Gambar 9. sebagai berikut: Gambar 9.7 Tampilan Hasil Report 62 . Klik Tombol Finish untuk melihat hasilnya.6 Menentukan Nama Obyek Report 6.

MDB 2. LUMBAN BATU 97010 TENGKU RAFLI 98012 SUMARDI 99014 ZASKIA HASAN 99015 MARDIANSYAH 99017 TOGAR SIMATUPANG 550000 520000 440000 440000 360000 345000 375000 390000 330000 12500 24000 0 0 15000 3000 7500 18000 0 562500 544000 440000 440000 375000 348000 382500 408000 330000 63 . Buatlah sebuah Query. Copykan file LATIHAN 7.Perangkat Lunak Basis Data LATIHAN 9 1. yang memilik tampilan sebagai berikut: 3. menjadi file baru dengan nama baru LATIHAN 9.MDB. yang memiliki tampilan sebagai berikut: TOTAL GAJI JUNI BULAN NIP NAMA GAJI LEMBUR TOTAL GAJI JUNI JUNI JUNI JUNI JUNI JUNI JUNI JUNI JUNI 95001 ZAINAL ARIFIN 95002 AHMAD SYARIF 95003 CUT MEUTIA 96006 K. Buatlah sebuah Query.

Perangkat Lunak Basis Data 4. Buatlah sebuah Report. yang halaman 1 memiliki tampilan sebagai berikut: 64 .

1 Menentukan Source Dan Field Gambar 10.1 Menggunakan Summary Option Kita bisa melakukan rangkuman perhitungan pasa saat membuat sebuah report.Perangkat Lunak Basis Data BAB 10 OBYEK REPORT DENGAN SUMMARY OPTION Tujuan Materi: mahasiswa dapat membuat obyek report dengan bantuan fasilitas report wizard di Microsoft Access 10.2 Jendela menentukan Group Level 65 . Fasilitas ini disebut sebagai Summary option Gambar 10.

4 Menentukan layout 66 .3 Jendela menentukan Group Level Gambar 10.Perangkat Lunak Basis Data Gambar 10.

Perangkat Lunak Basis Data Gambar 10.6 Menentukan Nama Report 67 .5 Menentukan Style Gambar10.

Perangkat Lunak Basis Data Gambar 10.7 Report Dengan Summary Option 68 .

MDB. menjadi sebuah file baru dengan nama LATIHAN 10. Buatlah Query. dengan hasil sebagai berikut: Query Penjualan NamaPlg Diana Pungki Diana Pungki Diana Pungki Diana Pungki Diana Pungki Diana Pungki Toharudin NomerOrder TanggalOrder 1 1 1 2 2 2 3 NamaBrg Harga Jumlah 2500 2000 2000 4500 2000 7000 4500 14000 6000 4500 2000 17000 10250 2500 13000 4500 10000 10250 15000 3 3 3 2 15 2 6 2 2 2 12 5 4 5 5 Total 7500 6000 6000 9000 30000 14000 27000 28000 12000 9000 24000 51250 50000 12500 22500 07/05/2008 Staples. simpan dengan nama Query Barang Terjual. Buatlah Query.MDB 2. simpan dengan nama Query Penjualan. dengan hasil query sebagai berikut: 69 . Copykan File LATIHAN 4.Perangkat Lunak Basis Data LATIHAN 10 1.250 07/05/2008 Bolpoint Weiyada Hitam 07/05/2008 Bolpoint Weiyada Merah 07/05/2008 Spidol Board Marker Swallow Hitam 07/05/2008 Bolpoint Weiyada Biru 07/05/2008 Notes Kecil 08/05/2008 Spidol Board Marker Swallow Hitam 08/05/2008 Correction Fluid Kenko 08/05/2008 Penggaris Besi 30 Cm 08/05/2008 Spidol Board Marker Swallow Biru 08/05/2008 Bolpoint Weiyada Hitam 09/05/2008 Correction Pen Tipex 09/05/2008 Stapler 09/05/2008 Isi Cutter Kecil 10/05/2008 KotakPensil 10/05/2008 Spidol Board Marker Swallow Merah 10/05/2008 Cutter Kecil Kenko 10/05/2008 Stapler 10/05/2008 Cutter Besar Kenko Abubakar Husin 4 Abubakar Husin 4 Abubakar Husin 4 Toharudin 5 Saleh Al Habsi 6 Saleh Al Habsi 6 Ali Mansyur Ali Mansyur Iffa Soraya Iffa Soraya Iffa Soraya Habadal Arif Habadal Arif 7 7 8 8 8 9 9 10 170000 09/05/2008 Penghapus Staedler Besar 12500 10 130000 10 100000 10 102500 19 285000 Catatan: Total= Harga*Jumlah 3.

Buatlah sebuah Report Berdasar Query Penjualan.sebagai berikut 70 . dengan tampilan halaman 1.Perangkat Lunak Basis Data Query Barang Terjual NamaBrg Staples.250 Bolpoint Weiyada Hitam Bolpoint Weiyada Merah Bolpoint Weiyada Biru Notes Kecil Correction Fluid Kenko Penggaris Besi 30 Cm Spidol Board Marker Swallow Biru Bolpoint Weiyada Hitam Correction Pen Tipex Stapler Penghapus Staedler Besar Isi Cutter Kecil KotakPensil Cutter Kecil Kenko Stapler Cutter Besar Kenko NomerOrder TanggalOrder Jumlah 1 1 1 2 2 4 4 4 5 6 6 7 7 8 8 9 9 07/05/2008 07/05/2008 07/05/2008 07/05/2008 07/05/2008 07/05/2008 08/05/2008 08/05/2008 08/05/2008 08/05/2008 08/05/2008 09/05/2008 09/05/2008 09/05/2008 09/05/2008 10/05/2008 10/05/2008 10/05/2008 10/05/2008 10/05/2008 3 3 3 2 15 2 6 2 2 2 12 10 5 4 5 10 5 10 10 19 Spidol Board Marker Swallow Hitam 2 Spidol Board Marker Swallow Hitam 3 Spidol Board Marker Swallow Merah 8 4.

dengan tampilan halaman 1.Perangkat Lunak Basis Data 5. sebagai berikut Selamat Bekerja 71 . Buatlah sebuah Report Berdasar Query Barang Terjual .

Perangkat Lunak Basis Data REFERENSI 72 .

/HP Email : Jl.Kom.com 73 . Jend. Yani III/22A Blitar 66131 : (0342) 802047 / 0816553781 : mohariefs@yahoo.Perangkat Lunak Basis Data CURRICULUM VITAE Nama: Drs. A. Mohamad Arief Setiawan. Alamat Telp. M.

Sign up to vote on this title
UsefulNot useful