Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

Mengenal Crystal Report 8.0

Crystal report merupakan salah satu product report designer yang banyak digunakan oleh para developer. Crystal report merupakan produk dari perusahaan Seagate. Crystal report tersedia langsung pada Visual Basic 4.0 dan 5.0, tetapi pada Visual Basic 6.0 telah diganti dengan Data Report yang dibuat oleh Microsoft.

Pada Visual Basic 6.0, pada dasarnya Crystal report dapat diinstall secara terpisah dari folder \Misc yang merupakan versi 5.0.

Menjalankan Crystal Report

1. Dari Start, pilih Programs, pilih Seagate Crystal Report.

2. Akan muncul suatu Dialog box Welcome

Create a New Crystal Report Document--------,

jil'(+' lQ.~·h~·.·.tb~·.ii.~.p..;;i~.·.·~·.~·p.·~·;.~

U ,r As a Elank Report

\1/ elcome to S eagate Crystal Reports 13

1M- ,r .Qpen an Existing Report

More Files ...

M _2how welcome dialog at startup

OK

Cancel

tielp

3. Anda dapat memilih Using Report Expert untuk pembuatan report secara step by

step.

4. Step 1

5. Kemudian akan muncul dialog Choose an Expert, dan pilihlah Standard.

6. Kemudian akan muncul Standard Report Expert, yang memiliki 8 step, yaitu :

Data, Fields, Group, Total, TopN, Chart, Select, Style.

7. Klik pada Database, dan akan muncul dialog Database Explorer. Klik pada Database Files, dan Double Klik pada Find Database File.

8. Pilih Pentacom.mdb, dan masukkan password yang sesuai, sehingga menjadi :

Indoprog

1

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

I

e,dd II

~l!I Data Explorer 13

$ .. Ii.!! History ~··fj!ODBC

B·· tal! Database Files

! .... 1j Find Database File B·· a PentaCom. mdb

~ .... ~~ !····~Beli

! .... ~ BeliDetail L. .. ~ Pemasok

Itl·· tal! More Data Sources lB·· ~ Dictionary! Query

B.emove II

Add to E avorites

Q. elete Favorite

Data Explorer-------------, Browse through the folders to find your data source's tables. Select and Add tables that contain data you want to report on. You can also double-click a table

to add it.

Qptions ...

tielp

Close

9. Klik pada tabel Barang, dan klik Add untuk memasukan tabel ke report.

10. Step 2

11. Klik pada Fields, dan masukkan field-field yang diinginkan. Anda dapat juga mengubah judul untuk masing-masing kolom dengan mengatur Column Heading.

12. Step 8

13. Klik pada Style, dan pada Title ketik Laporan Data Pemasok, dan pilihlah Style yang sesuai dengan keinginan anda.

14. Klik pada Preview Report untuk melihat hasil.

Mendesign report hasil Report Expert.

Klik pada tab design dan akan menampilkan layar design

Design II Preview II

Reoort Header Page Header

Details

R eoort Footer Page Footer

Indoprog

2

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

Report Header, tulisan yang akan ditampilkan pada halaman pertama Report. Page Header, tulisan yang akan ditampilkan pada awal tiap halaman.

Details, merupakan baris-baris yang berasal dari field-field dalam tabel. Report Footer, tulisan yang akan ditampilkan pada halaman terakhir.

Page Footer, tulisan yang ak:an ditampilkan pada akhir tiap halaman.

Menyimpan design report ke file

Menyimpan report dilakukan seperti biasanya dengan menu File, Save kesebuah file dengan extension rpt.

Menampilkan report dari Project Visual Basic

Untuk menampilkan Crystal Report ke project anda dapat dilakukan dengan menggunakan komponen "Crystal Report Viewer Control" melalui menu Project, Components, dan Reference ke "Crystal Report 8 Activex Designer runtime library"

~ CRviewer

1. Tanamkan kontrol CRViewer ke Form anda

iii. Pentacom Report Viewer I!!IlIilI3

J X ~ "1 ~ ~ I J I~ I J It III •••• - mil

Preview ~

~--------------~

2. Lakukan koding sebagai berikut :

Dim xApp As New CRAXDRT.Application Dim xRpt As CRAXDRT.Report

Dim xDbf As CRAXDRT.DatabaseTable

Private Sub Form_LoadO

Set xRpt = xApp.OpenReport("C:\Workshop\Pemasok.rpt") If xTitle <> "" Then

xRpt.ReportTitle = xTitle End If

For Each xDbf In xRpt.Database. Tables xDbf.SetLogOnInfo '"', "", "", "Pentacom"

Indoprog

3

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

xDbf.Location = "C:\Pentacom.Mdb" Next

On Error GoTo Keluar xRpt.DiscardSavedData CRViewer1.ReportSource = xRpt CRViewerl. ViewReport

Exit Sub

Keluar:

MsgBox "Ada Masalah Dengan Laporan !!", vbInformation, "PERHA TIAN" End Sub

Private Sub Form_ResizeO

CRViewerl.Move 0,0, Me.ScaleWidth, Me.ScaleHeight End Sub

Membatasi data dengan Selection Formula

Anda dapat membatasi data pada saat runtime dengan menggunakan RecordSelectionFormula

xRpt.RecordSelectionFormula = "{Pemasok.KodePemasok} >= '001' And {Pemasok.KodePemasok} <= '100'"

Indoprog

4

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

Membuat report dengan Crystal Report

Jika pada pertemuan sebelumnya kita telah belajar bagaimana membuat report dengan menggunakan Report Expert, maka pada pertemuan ini kita akan membuat report dengan melakukan design secara langsung.

Melakukan design dengan Crystal Report

1. Pada dialog Welcome to Seagate Crystal Reports pilih As a blank report.

2. Pada dialog Data Explorer, klik pada "Dataf'iles"; dan double klik pada "Find Database File".

3. Selanjutnya buka database C:\Pentacom.mdb dan password: Pentacom.

4. Klik pada tabel barang dan klik Add

I

e,dd II

~m Data Explorer 13

Itl··[ij) Current Connections ~ .. tal! Favorites

~ .. tal! History ~··~ODBC

S··1Z2J Database Files

~ ~ .... 1'j Find Database File ~ B·· a PentaCom. mdb

~ ~ ~ Barang

~ ~ ~ Beli

~ ~ ~ BeliDetail

~ L. .. ~ Pemasok

IRir1I More Data Sources

B.emove II

Add to E avorites

Qelete Favorite

Data Explorer-------------, Browse through the folders to find your data source's tables. Select and Add tables that contain data you want to report on. You can also double-click a table

to add it.

tielp

Qptions ...

Close

5. Pada menu File, klik pada Summary Info, dan ketikan "Laporan Data Barang" pada field Title.

6. Pada field explorer, Special fields, Drag Report Title ke bagian Page Header, dan lakukan drag field KodeBarang, NamaBarang, Satuan, HargaJual

7. Klik kanan pada Formula Fields, dan pilih New:, Pada FormulaName ketikan "SaldoAkhir", dan buatlah formula {Barang.bO}+{Barang.bl}, dan klik pada "Check" untuk memeriksa kebenaran dari formula yang diketik, dan akhiri dengan klik pada "Save and Close"

Indoprog

5

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

~l!I Formula Editor:@SaldoAkhir IIlIi1I3

A. 5\. ;.. r. I ti I ~ I-!! I ~ I ? I ,I Crystal Syntax 3

I .sl J

8. Pada kolom @SaldoAkhirtambahkan Grand total.

Mengatur Formula pada runtime

Anda dapat menggunakan FormulaFields(n).Text, untuk memanipulasi Formula pada saat runtime.

Contoh:

xRpt.FormulaFields(l).Text = 11 {Barang.bO}+{Barang.b1 }+{Barang.b2 }+{Barang.b3} 11

untuk memperbaiki @SaldoAkhirmenjadi bulan Maret.

Dengan petunjuk instruktur anda, buatlah Faktur Pembelian, Laporan Pembelian Per Pemasok, Laporan Pembelian Per Barang.

Project

Buatlah program cetak Databarang dimana @SaldoAkhirnya disesuaikan dengan Bulan yang akan dicetak.

Indoprog

6

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

Membuat report dengan Crystal Report 8.5

Crystal report 8.5 menawarkan pembuatan report yang dapat terpadu dengan project Visual Basic 6.0, dimana pembuatan report dapat langsung dilakukan pada IDE Visual Basic dengan menggunakan menu Project, Add Crystal Reports 8.5.

Bekerja dengan Crystal Report Designer dan ADO

1. Dari Menu Project, pilih Add Crystal Report 8.5

2. Pada Crystal Report Gallery pilih As blank Report

3. Berijawaban Yes pada Do you want the expert to add a form containing the Crystal Report Control Viewer?, dan No pada Would you like the expert to modify the project properties to set this form as the startup object? dan Klik Ok

4. Selanjutnya dihadapan anda akan ditampilkan Crystal Report Designer

J ~I i? ~ ti I ~ ? I h!:l1,1100% Gl IJ:E {§ ffifl ~ I

Main Report ~

! W Database Fields

~ X+t Formula Fields

~····l?'] Parameter Fields

~ ~ Group Name Fields

~ 2' Running Total Fielc

~ .. ~ Special Fields lB·· "" Unbound Fields

, , , I ' , , 1 ' , , I ' , , 2 ' , ,

Report Header (Section8)

Page Header (SectionS)

I: 'I

Details (S ection 1 0 )

Report Footer (Section9)

I : '1

Page Footer (Section?)

I: 'I

5. Klik kanan pada "Database Fields" dan pilih Add Database to report.

6. Pada dialog "Database Explorer", pilih "More Data Source", klik pada "Active Data", double klik pada "Active Data (ADO)", dan buatlah ConnectionString seperti biasanya, dengan menggunakan ADO

7. Buatlah datasource dengan SQL statement berikut:

SELECT Beli.Nomor, Beli.Tanggal, Beli.KodePemasok, Beli.Total, Pemasok.Nama, Pemasok.Alamatl, Pemasok.Alamat2, BeliDetail.KodeBarang, BeliDetail.N amaBarang, BeliDetail. Qty, BeliDetail. UnitPrice, BeliDetail.Amount

FROM Pemasok INNER JOIN (Beli INNER JOIN BeliDetail ON Beli.Nomor = BeliDetail.Nomor) ON Pemasok.KodePemasok = Beli.KodePemasok;

Indoprog

7

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

8. Klik kanan pada "Group Name Fields", dan pilih "Insert Group", dan buatlah group berdasarkan "Nomor"

9. Rancanglah report anda sebagai berikut :

- - - - - - -=

I_..:' 'I' "1" 'I" '2'" I" '3'" I" '4'" I' "5" 'I' "e" 'I" '7'" 1

R eporl Header (S ection8 )

Page Header (SectionS)

I : II ~aktur Pembelian~

Group Header If': ado. N omor - A (S ection'l )

I

rom.or : N~

~: ~

j-;.ode P=oh : j-;.odeP=oh '

~ I j-;.odeBonni I rom.oll~

D etels (S ectionl 0 ) nTj-;.odeBonniTr~om.oll-~---------:T:

Group F ooter If': ado. N omor - A (S ection'l 2 )

~~I--

ThitPric~ I :

~I

R eport F ooter (S ection9 )

Page F ooter (S ection 7 )

to. Lakukan pengaturan format untuk Qty, UnitPrice, Amount, Total, PrintDate serta PrintTime.

11. Lakukan koding pada Report jika tidak ada data yang dicetak

Private Sub Report_NoData(pCancel As Boolean) MsgBox "Tidak Ada yang dicetak!"

End Sub

12. Modify Koding untuk Form Viewer sehingga lokasi database dapat disesuaikan kembali sebagai berikut :

Dim Report As New CrystalReportl Dim MyConn As New Connection Dim MyRs As New Recordset

Private Sub Form_LoadO

MyConn.ConnectionString = "Provider=MicrosoftJet.OleDbA.O; Data Source=C:\Pentacom.Mdb; Jet Oledb:Database Password=Pentacom;" MyConn.Open

sSQL = "SELECT Beli.Nomor, Beli.Tanggal, Beli.KodePemasok," & _ "Beli. Total, Pemasok.Nama, Pemasok.Alamatl, Pemasok.Alamat2," & _ "BeliDetail.KodeBarang, BeliDetail.NamaBarang, BeliDetail.Qty," & _

Indoprog

8

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

"BeliDetail.UnitPrice, BeliDetail.Amount " & _ "FROM Pemasok INNER JOIN" &

"(Beli INNER JOIN BeliDetail ON Beli.Nomor = BeliDetail.Nomor) " & _ "ON Pemasok.KodePemasok = Beli.KodePemasok;"

MyRs.Open sSQL, MyConn Report.Database.SetDataSource MyRs, , 1 Screen.MousePointer = vbHourglass CRViewerl.ReportSource = Report CRViewerl. ViewReport Screen.MousePointer = vbDefault

End Sub

Private Sub Form_ResizeO CRViewer1.Top = 0 CRViewer1.Left = 0 CRViewer1.Height = ScaleHeight CRViewer1.Width = ScaleWidth End Sub

13. Lengkapi program diatas untuk kemampuan mencetak Faktur nomor tertentu saja.

14. Tambahkan nomor baris untuk masing-masing baris faktur

15. Tambahkan PPN dan Nett

Indoprog

9

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

Membuat graphic dengan Crystal Report 8.5

Crystal report 8.5 menawarkan berbagai fasilitas kemudahan dalam pembuatan report, salah satunya adalah pembuatan grafik

Bekerja dengan Crystal Report Designer dan ADO

16. Buatlah sebuah report dengan datasource dengan SQL statement berikut :

SELECT Beli.KodePemasok, Pemasok.Nama, Pemasok.Attn, Beli.Nomor, Beli.Tanggal, Beli.Total FROM Pemasok INNER JOIN Beli ON

Pemasok.KodePemasok = Beli.KodePemasok;

17. Buatlah Group berdasarkan KodePemasok dengan klik pada toolbar {§l

18. Rancanglah Report sebagai berikut:

- - - - -_
L 1 ' 1 1 ' 2 ' 1 ' 3 ' 1 ' <1 ' 1 ' 5 ' 1 ' G
Report Header (SectionS)
Page Header (S ection6 )
Lap oran P emb elian ,
"
~d.e Pema:;ok: r ama ' r- Nomoi ~ , r- Totaj
-
" L " L
Group Header **1: ado. KodePemasok - A (S ection 1 ) I
IT~d.ePema:;ok :-5;1'01111 #1 Name :-~ttn ,
" I
Details (S ection 1 0 )
1- "I : N omo;-5:' anggal ,-r Tot.,J
" L
Group Footer **1: ado. KodePemasok - A (S ection2 ) I
I ~ ill ~ub Total , r- Sum ofado.Tota.!
" L
Report Footer (S ection9 ) I
1- III ~and Total ,-r Sumofado.To~
" L
Page Footer (Section?) I
1 - 111 P";,.,tp~ , P";,.,t n~t~ P";,.,tTimp , 19. Tambahkan Graphic Bar ke Report, dengan melakukan klik pada toolbar ~ , dimana dengan pengaturan sebagai berikut :

• Place chart: Once per report: Header

• On change of : ado.KodePemasok

• Show: sum of ado. Total

• Title: Graphic Pembelian per customer

• Group Title: Nama Pemasok

• Data Title : Total

Indoprog

10

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

Report Header (SectionS)

Graphic Pembelian Per Customer

.:l2~
21ll}
2.oj~
2W
;;; till}
;§ t2~
'" Ill}
4~
~
t~~7 t~~~
Nama Pemasok
<Co 20. Lakukan pemrograman pada Visual Basic untuk membatasi pencetakan dari dan sampai tanggal tertentu saja.

21. Aktitkan fasilitas Drill down untuk bagian detail, petunjuk: klik kanan pada detail, dan pilih Format Section, beri tanda check pada Hide (Drill down ok)

Indoprog

11

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

Konektivitas Crystal Report dengan SQL Server Design report dengan sumber data

Klik pada More Data Sources, dan DblClik pada Microsoft SQL Server

.•.. _-

Il::!l Data Explorer ~

~ .. ~ Current Connections ~ .. tal! Favorites

~ .. Q] History ~··[bjJODBC

~ .. @] Database Files

B·· [ij) More Data Sources ~ .. ~ Active Data

$ .. ~ Local File System

$ .. ~··eOLE DB lB·· [ill,] 0 r acle Server

1+1 .. Rill M etadata ! Q uerv

• ~Microsoft SQL Server

Data E:-:plorer--------------, Browse through the folders to find your data source's tables. Select and Add tables that contain data you want to report on. You can also double-click a table

to add it.

e,dd

B.emove

Kemudian akan muncul dialog berikut, isikan nama server, user id, password, dan nama database sumber data .

Add to E avorites

Qelete Favorite

Qptions ...

tielp

Close

. '._-

Mic reseft 5QL Se rYe r 1Rl

_2erver: jcdnsql OK I
Isa I
User ID: Cancel

Eassword: I xxx:.::.:=-:
Qatabase: 1r.ir;ff111i1111 ::J r T rusted Connection Selanjutnya klik pada tombol Option untuk menampilakn sumber data report yang menggunakan Storeprocedure.

Indoprog

12

Pemanfaatan Crystal Report pada VB6

Oleh Hendra, ST .

•.. _-

o~~ ~

Database I

r-Show: Explorer 0 ptions

p Iables T able name LI KE: I (%,_l
P ~iews I
r System Tables Qwner LIKE: V_l
r S!,!nonyms
p l~."i.~ii.4j~i~.~.~.~.0ii.·~ r Beprompt user when connecting
, List T abies and Fields by: ,Sorting:
r. Name P" 20rt Tables Alphabetically
r Q escription r Sort fields Alphabetically
r Botb
Advanced Options
P Use Indexes or Server for Speed P Translate DQS Memos
r Perform §.rouping On Server P Auto-Smart1inking
P !d se D ef ault Alias r Cartesian Eroduct
P Iranslate DOS Strings r Perform Query e,synchronously
P _Case-Insensitive SQL Data P Select Distinct Data for Erowsing OK

Cancel

tielp

Selanjutnya proses design report tidak. jauh berbeda dengan sumber data yang berasal dari .Mdb.

---------------------------------------------------

1m Data Exp 10 re r (Rl

Tables

e,dd

+

: Stored Procedures

~

.. jTI CdnAH R D MS. dbo. Proc(APPf

! jTI CdnAH R D MS. dbo. Proc(CAI R

! jTI CdnAH R D MS. dbo. Proc(CAN I

! jTI CdnAH R D MS. dbo. Proc(CAN I

! jTI CdnAH R D MS. dbo. Proc(CAN I

! jTI CdnAH R D MS. dbo. Proc(CAN I

! jTI CdnAH R D MS. dbo. Proc(CAN I

i····jTI CdnAH R D MS. dbo. Proc(CAN I

i .... n r.rln.ll.H R n M C; rlhn Prnr-:fr AN 18

~~i~--M~II~~·l ~

Bemove

Add to favorites

Qelete Favorite

Data Explorer ----------------------------, Browse through the folders to find your data source's tables. Select and Add tables that contain data you want to report on. You can also double-click a table

to add it.

Qptions ...

tielp

CJose

Indoprog

13

Pemanfaatan Crystal Report pada VB6

Oleh Hendra, ST.

Menampilkan Report pada Visual Basic (SQL Server)

Sumber data Tabel atau View

Dim xApp As New CRAXDRT.Application Dim xRpt As New CRAXDRT.Report

Dim xServer As String

Dim xDatabase As String

Private Sub Form_Load() xServer = "cdnsql" xDatabase = "cdnAHRDMsn

Set xRpt = xApp.OpenReport("C:\fbindoprog.rpt") xRpt.DiscardSavedData

xRpt.Database.LogOnServerEx "p2ssql.dll", xServer, xDatabase, "sa", "xxxxxxn xRpt.Database.Tables(l) .SetLogOnlnfo xServer, xDatabase, "sa", "xxxxxx" xRpt.Database.Tables(l) .Location = xDatabase & ".dbo.LAPORAN_MUTASI_STOCK" CRViewer.ReportSource = xRpt

CRViewer.ViewReport

End Sub

Catatan :

Kalau nama server/database berbeda pada saat implementasi dengan ketika design, maka akan muncul pesan berikut :

.. _-

Crystal Re pe rt Viem! r 1Rl

Server has not yet been opened,

I C::::::::::¢.:~:::::::::::J

Solusinya adalah menanbah tiga baris berikut ini :

xRpt.Database.LogOnServerEx "p2ssql.dll", xServer, xDatabase, "sa", "xxxxxxn xRpt.Database.Tables(l) .SetLogOnlnfo xServer, xDatabase, "sa", "xxxxxx" xRpt.Database.Tables(l) .Location = xDatabase &".dbo.Proc(LAPORAN_MUTASI_STOCK)"

Sumber data Storeprocedure

Dim xApp As New CRAXDRT.Application Dim xRpt As New CRAXDRT.Report

Dim crParamDefs As CRAXDRT.ParameterFieldDefinitions Dim crParamDef As CRAXDRT.ParameterFieldDefinition Dim xServer As String

Dim xDatabase As String

Private Sub Form_Load() xServer = "cdnsql" xDatabase = "cdnAHRDMsn

Set xRpt = xApp.OpenReport("C:\fbindoprog.rpt") xRpt.DiscardSavedData

xRpt.Database.LogOnServerEx "p2ssql.dll", xServer, xDatabase, "sa", "xxxxxxn xRpt.Database.Tables(l) .SetLogOnlnfo xServer, xDatabase, "sa", "xxxxxx" xRpt.Database.Tables(l) .Location = xDatabase &".dbo.Proc(LAPORAN_MUTASI_STOCK)" xRpt.EnableParameterPrompting = False

Set crParamDefs = xRpt.ParameterFields

Indoprog

14

Pemanfaatan Crystal Report pada VB6

Oleh Hendra, ST.

For Each crParamDef In crParamDefs

Select Case crParamDef.ParameterFieldName Case n@DARITANGGALn

crParamDef.SetCurrentValue DlgLMutasiStokL.txtDariTanggal.Value Case n@SAMPAITANGGALn

crParamDef.SetCurrentValue DlgLMutasiStokL.txtSampaiTanggal.Value Case n@KODELOKASIn

crParamDef.SetCurrentValue DlgLMutasiStokL.cboKodeLokasi.Text End Select

Next CRViewer.ReportSource CRViewer.ViewReport End Sub

xRpt

Indoprog

15

Pemanfaatan Crystal Report pada VB6

Oleh Hendra, ST.

Konektivitas Crystal Report dengan Firebird melalui ODBC

•.. _-

1m Data Exp 10 re r ~

e,dd

B.emove

Add to E avorites

Qelete Favorite

Qptions ...

tielp

Close

Itl·· ~ .. a Favorites ~··aHistory ~··[LjJODBC

~ .. [ig) Database Files

~ .. Ii.!! More Data Sources iB··a Metadata! Query

Data Explorer----------------, Browse through the folders to find your data source's tables. Select and Add tables that contain data you want to report on. You can also double-click a table

to add it.

Pilih More Data Sources, dan DblKlik pada Make New Connection

•.. _-

1m Data Exp 10 rE! r ~

$··aODBC

~··a Database Files

B·· a More Data Sources ~ .. [ill,] Active Data

~ .. ~ Local File System ~··~Microsoft SQL Server

$ .. ~OLE DB

! ! .... 1j

~ L. .. 1j Connect Using Data Link File

iB··1Zj 0 r acle Server

1±l .. [LjJ Metadata ! Query

Make New Connection

Data Explorer----------------, Browse through the folders to find your data source's tables. Select and Add tables that contain data you want to report on. You can also double-click a table

to add it.

e,dd

B.emove

Add to E avorites

Qelete Favorite

Indoprog

Qptions ...

tielp

CJose

16

Pemanfaatan Crystal Report pada VB6

Oleh Hendra, ST .

•.. _-

~ Data u nk Pro pe rties [RJ

Provider I Connection I Advanced I All

Select the data you want to connect to:

OLE DB Provider s fAll

r=~~~==~------------------~~

Crystal Server Closed Integrator Base Crystal Server Closed XML ADO Provider M ediaCatalogD BOLE DB Provider

M ediaCatalogM ergedD BOLE DB Provider MediaCatalogWebDB OLE DB Provider Microsoft I SAM 1.1 0 LE DB Provider Microsoft Jet 3. 51 0 LE DB Provider Microsoft Jet 4.0 0 LE DB Provider

Microsoft OLE DB Provider For Data Mining Services Microsoft OLE DB Provider for DTS Packages Microsoft OLE DB Provider for Internet Publishing

Microsoft OLE DB Provider for ODBC Drivers

Microsoft OLE DB Provider for Oracle Microsoft OLE DB Provider for Outlook Search Microsoft OLE DB Provider for SQL Server Microsoft 0 LE DB Simple Provider

M S D ataS hape

Next»

OK

Cancel

Help

Pilih Microsoft OLE DB Provider for ODBC Drivers

Indoprog

17

Pemanfaatan Crystal Report pada VB6

Oleh Hendra, ST .

•.. _-

~ Data u nk Pro pe rties [RJ

Provider Connection I Advanced I All

Specily the following to connect to DDBC data: 1. Specily the source of data:

r Use .£lata source name

::::!J B efresh I

r. Use c.Qnnection string .connection string:

B!dild ... I

2. Enter information to log on to the server User .Dame:

Eassword: r Elank password r Allow laving password

3. Enter the jnitial catalog to use:

lest Connection I

DK

Cancel

Help

Klik pada Use connection string, dan ketikan pada Connection string :

DRIVER=Firebird/lnterBase(r) driver;UID=SYSDBA;PWD=MASTERKEY;DBNAME=c:\firebirddb\fbindoprog.fdb

~ .. --

Mic resoft Data u nk ~

T est connection succeeded,

IC::::::::::¢K:::::::::J

Indoprog

18

Pemanfaatan Crystal Report pada VB6

Oleh Hendra, ST .

. '._-
1m Data Exp 10 re r [8J
I
~ .... 1'j Make New Connection 8 e,dd
~ .... 1j Connect Using Data Link File B.emove I
B··f\ OLE DB
~····~AKSES B
~ .... ~ CET AKFAKTURKELUAR
~ .... ~ DATMDJUST Add to favorites I
~ .... ~ DATACOMPANY
~ .... ~ DAT ACUSTOMER Qelete Favorite I
~ .... ~ DATAHPP
~ .... ~ DATAHPPLOKASI 8
i····1Dm1 nAT AKARTIIPART
~i 1111 ] ill

Data Explorer
I c:::::::::tJ.pti?h:s.::.:::::::::::::;1
Browse through the folders to find your data source's
tables. Select and Add tables that contain data you tielp I
want to report on. You can also double-click a table
to add it. Close I
.,. __ .

O~~ ~

Database I

r-Show: Explorer 0 ptions

P" Iables T able name LI KE: I (%,_l
P" ~iews I
r System Tables Qwner LIKE: (%,_)
r S!,!nonyms
P" l~."i.;;i~4j~-;_;;.~.~.~.0i~·~ r B.eprompt user when connecting
, List T abies and Fields by: ,Sorting:
r. tlame P" .9_ort Tables Alphabetically
r Q escription r Sort fields Alphabetically
r Botb
Advanced Options
P" Use Indexes or Server for Speed P" Translate D Q S Memos
r Perform §rouping On Server P" Auto-Smart1inking
P" il se D ef ault Alias r Cartesian Eroduct
P" Iranslate DOS Strings r Perform Query e,synchronously
P" _Case-Insensitive SQL Data P" Select Distinct Data for Erowsing OK

Cancel

tielp

Indoprog

19

Pemanfaatan Crystal Report pada VB6

Oleh Hendra, ST.

•.. _-
1m Data Exp 10 re r (8J
I
El-. taJ! Current Connections e,dd
i B··~OLE DB B.emove I
: ~ .. ~ Tables
: 1B .. [@llJlllliilU'!!!W1m
~ .. [ij) Favorites
~ .. Ii.!! History Add to E evorites I
~··taJ!ODBC
~ .. taJ! Database Files Qelete Favorite I
~ .. taJ! More Data Sources
lB··@] Metadata! Query
Data Explorer
Browse through the folders to find your data source's Qptions ... I
tables. Select and Add tables that contain data you tielp I
want to report on. You can also double-click a table
to add it. I Close I
Menampilkan report dari Project Visual Basic (Firebird)

Untuk menampilkan Crystal Report ke project anda dapat dilakukan dengan menggunakan komponen "Crystal Report Viewer Control" melalui menu Project, Components, dan Reference ke "Crystal Report 8 Activex Designer runtime library"

Dim xApp As New CRAXDRT.Application Dim xRpt As New CRAXDRT.Report

Private Sub Form_Load()

Set xRpt = xApp.OpenReport("C:\fbindoprog.rpt") xRpt.DiscardSavedData

xRpt.Database.LogOnServerEx "pdsoledb.dll", "OLE DB", "", "", "", "", "DRIVER=Firebird!InterBase(r) driver;UID=SYSDBA;PWD=MASTERKEY;DBNAME=c:\firebirddb\fbindoprog.fdb" xRpt.Database.Tables(l) .SetLogOnlnfo "OLE DB", "c:\firebirddb\fbindoprog.fdb", "SYSDBA", "MASTERKEY" CRViewer.ReportSource = xRpt

CRViewer.ViewReport

End Sub

Indoprog

20

Pemanfaatan Crystal Report pada VB6

Oleh : Hendra, ST.

Package dan Deployment pada program VB6 yang menggunakan Crystal Report

Salah satu permasalahan yang sering ditemukan bagi programmer pemula yang menggunakan Crystal Report pada proyek VB adalah setelah program berhasil diinstalasi pada komputer Client tetapi laporan yang dibuat dengan Crystal Report tidak berhasil berjalan dengan baik. (Kecuali kalau di komputer Client juga diinstalasi Crystal Report).

Masalah tersebut terjadi karena, pada package installer kita tidak mengikutsertakan beberapa file .dll yang dibutuhkan oleh Crystal Report.

Untuk mengetahui .dll apa saja yang perlu dimasukan kedalam package installer dapat dibaca pada file Runtime.hlp yang terdapat pada folder:

c:\program files\seagate software\crystal reports\developer files\help

Jenis file .dll yang dibutuhkan sangat tergantung bagaimana anda menggunakan Crystal Report dalam project anda, dan kadang-kadang .dll juga membutuhkan .dll lainnya,

The application you created is using one of the following methods to access the Crystal Reports Engine. Click the appropriate method from the following list to determine the files you are required to include.

METHOD PROJECT REFERENCE NAME DESCRIPTION

Report Designer Component Crystal Report 8 ActiveX 32-bit only COM object model, dual interface,

(craxdrt .dll) Designer Runtime library apartment model

Embeddable Crystal Reports Embeddable Crystal Reports 32-bit only COM object model, dual interface,

Designer Control Designer Control apartment model, not thread safe

( crdesignerctrl.dll)

Crystal Reports Automation Crystal Report Print Engine 8 32-bit COM object model, dispatch only

Server (cpeaut32 .dll) Object Library

Crystal Report Engine API (crpe32.dll)

Crystal Report API Interface, Interface for C developers

declares encapsulated in either

global32.bas or crpe.h

Crystal ActiveX Control (crystI32.ocx)

ActiveX Control

32-bit OCX

NOTE: Th~ EmlJ~ddalJl~ Crystal R~ports lRsign~r Control accesses th~ r~port ~ngin~ using CRAXDDRT.DLL (Crystal R~ports Activ~X lRsign~r lRsign and Runtim~ Support DLL.

Indoprog

21

Pemanfaatan Crystal Report pada VB6

Oleh Hendra, ST.

Relwrt Designer Component

The requirecl runtime files for an application clevelopecl using the Report Designer Component are listed below.

LOCATION

\PROGRAM FILES\sEAGA TE SOFTVVAREIREPORT DESIGNER COMPONENT

\PROGRAM FILES\sEAGA TE SOFTVVARE\VIE\fVERSVl.CTIVEXVIE\fVER

NOTE: YOll mllst r~gist~r th~ DLLs lIsing r~g.svr32.~x~.

FILE

DESCRIPTION

CRAXDRT DLL

Crystal Reports ActiveX Designer Runtime

Support DLL

Crystal Report Viewer

CRVIE\fVER DLL

NOTE: Th~ Cryst;'ll R~port Vi~Wl!r DLL n~~ds to b~ distribllt~d if report» ;'lr~ b~ing print~d to th~ screen. Ifth~ reporte ere b~ing ~xport~d or print~d to th~ print~r, ;'lnd not b~ing vi~Wl!d to ;'l window, th~n this DLL is not r~qllir~d. Not~: Emb~dd;'lb/~ Cryst;'ll R~ports ~ign~r Control ;'lCCI!SS"l!S to th~ report ~ngin~ throllgh lIsing CRAXDDRT.DLL (Cryst;'ll R~ports Activ~X ~ign~r ~ign end RlIntim~ SlIPPOrt DLL

FILE LOCATION DESCRIPTION
IMPLODEDLL WNDQ\f\.IS\sVSTEM or Compression Library
WNDQ\f\.IS\sVSTEM32
(NT only)
SSCSDK80 DLL \PROGRAM FILES\sEAGA TE Charting DLL
SOFTVVARE\sHARED
PG32CONV DLL \PROGRAM FILES\sEAGA TE Auxiliary Charting DLL
SOFTVVARE\sHARED
CRP AIG80 DLL WNDQ\f\.IS\sVSTEM or T ext object DLL
WNDQ\f\.IS\sVSTEM32
(NT only)
MFC42DLL WNDQ\f\.IS\sVSTEM or MFCDLL Sharecl Library
WNDQ\f\.IS\sVSTEM32
(NT only)
MSVCRTDLL WNDQ\f\.IS\sVSTEM or C Runtime Library
WNDQ\f\.IS\sVSTEM32
(NT only) NOTE: IncllId~ IMPL ODE.DLL only for ;'lpplic;'ltions lIsing report» cr~;'lt~d in versios« previoue to SCR 3.

Kemudian file .dll berkaitan dengan jenis database driver yang digunakan :

Database Access

Runtime File Requirements Inde~ I

Click the topic of interest from the following list for further information:

Direct Access Databases ODBC Data Sources

Active Data ancl Crystal Data Object OLE DB Data Sources - ADO Crystal SOL Designer Files

Crystal Dictionaries

Indoprog

22

Pemanfaatan Crystal Report pada VB6

Oleh

Hendra, ST.

OLE DO Data Sources - .ADO Database Access I ndex I

Crystal Reports custom applications using utilizing ActiveX Data Object (ADO) Components may require both Seagate and Microsoft resources when they are distributed.

Seagate Resources

A fter installing the Microsoft Data Access (MDAC) files and copying P2S0DBC DLL, no addition files are needed for this data source. For more information, see ODBC - Required Runtime Files.

Microsoft.ADO Resources

F or information on the packaging and distribution of Microsoft ADO components, please refer to Microsoft's documentation and on-line resources at http://www.microsoft.comidataiand http://msdn.microsoft.comi.

ODoe; - Re<luireli Runtime Files DDBe Data Sources I

Microsoft. Data .Access (MD.AC)

Required runtime files can be distributed by including the Microsoft Data Access program (MDAC _ TYP .EXE) found on the Crystal Reports CD in the REDIST directory (this directory contains version 2.1 of MDAC). If you'd like to check for a newer version of MDAC, visit the Microsoft web site at: http://www.microsoft.comidata .

Install MDAC on a target machine to ensure the required runtime files are available to your application. Many ODBC data sources require additional files to be distributed.

Additional Refillired Runtime File

In addition to the files included in MDAC, always distribute the following file with any application that uses ODBC:

NOTE: B~ sur» to ch~ck th~ reqairements for th~ sp~cific ODBC driv~r you er« using. S~~ th~ list of ODBC Diiltiil SOUrcH b~/ow.

FILE P2S0DBCDLL

LOCATlOII

DESCRIPTION

WNDOVVS\sYSTEM or WNDOVVS\sYSTEM32 (NT only)

Crystal Reports Physical Server DLL for ODBC

NOTE: You must etso r~gist~r iilny distribut~d ODBC driv~rs on th~ u~r 's syst~m by modifying th~ syst~m r~gistry.

NOTE: Aft~r ODBC driv~rs iilr~ r~gist~r~d on th~ u~r 's syst~m, ODBC Administriiltor must b~ u~d to cr~iilt~ iiln ODBC diiltiil eoure« for th~ diiltiil thet will b~ iilccessed by your distribut~d reports, Provid~ informiiltion to your u~rs on how to u~ ODBC Administriiltor to cr~iilt~ diiltiil SQUrcH.

Dan jenis Exporting filter yang digunakan :

Exporting

Runtime File Requirements Index I

Click the topic of interest from the following list for further information:

Export Destinations Export Formats

Indoprog

23

Pemanfaatan Crystal Report pada VB6

Oleh Hendra, ST.

Export Destinations E~porting I

If your application will give users the ability to export reports, you must include files from the following list appropriate to the export destinations provided:

FILE U2DAPPDLL U2DDISK DLL U2DMAPIDLL U2DNOTESDLL U2DPOST DLL U2DVIMDLL

LOCATIOII W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL

DESCRIPTlotl

Application destination Disk file destination

MAPI format (Microsoft Mail, Microsoft Exchange) Lotus Domino destination

Microsoft Exchange Public Folders

VIM destination

Export Formats E~porting I

If your application will give users the abimy to export reports, you must include files from the following list appropriate to the export formats provided:

FILE U2FCRDLL U2FDIFDLL U2FHTMLDLL

U2FODBCDLL CRXF _PDF DLL

U2FRDEFDLL U2FRECDLL CRXF _RTF DLL

U2FSEPVDLL U2FTEXTDLL U2F\f\!KS DLL U2f\.'YORDWDLL U2FXMLDLL U2FXLSDLL

LOCATION W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL

W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL

W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL

W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL W\IlNDOVVS\cRYST AL

DESCRIPTION

Crystal Reports format DIF format

HTML format

See HTML under Additional Components for additional runtime information.

ODBC data source PDF format

Replaces U2FPDF DLL from version 8.

See Page Ranged Export under Additional Components for additional runtime information.

Report Definition format Record format

Rich Text Format

Replaces U2FRTF DLL from version 8 and earlier.

See Page Ranged Export under Additional Components for additional runtime information.

Comma Separated Values format Text format

Lotus 1-2-3 format

Microsoft Word for Wndows format XML format

Microsoft Excel format

Indoprog

24

Sign up to vote on this title
UsefulNot useful