Pengolahan Data Peta Dengan Quantum GIS

Oleh: Ruslan Nuryadin PT Webgis Indonesia

Dokumen ini terbuka dan gratis. Silahkan disebarkan, disalin, dicetak dan digunakan sebagaimana mestinya.

Pengolahan Data Peta Dengan Quantum GIS

1

Daftar Isi
I.Pengantar.................................................................................................................. 3 II.Instalasi.................................................................................................................... 3 III.Konfigurasi Quantum GIS............................................................................................... 5 IV.Membuat Layer Baru..................................................................................................... 6 V.Tutorial: Membuat Layer Polygon......................................................................................7 VI.Tutorial: Membuat Layer Garis.......................................................................................17 VII.Tutorial: Membuat Layer Titik.......................................................................................19 VIII.File Projek Quantum GIS............................................................................................. 21 IX.Mengisi Data Atribut................................................................................................... 21 9.1 Mengubah Data Atribut Menggunakan Tombol Identity Features..........................................22 9.2 Mengubah Data Atribut Melalui Tabel Data Atribut..........................................................23 9.3 Mengubah Data Atribut Menggunakan Field Calculator.....................................................24 9.3.1 Mengubah Atribut Objek Peta Terseleksi...............................................................24 9.4 Mempermudah Pengisian Data Atribut Dengan Fitur Value Map...........................................26

Pengolahan Data Peta Dengan Quantum GIS

2

4. pilih tautan Current Version.I. Setelah proses instalasi selesai. Instalasi Installer Quantum GIS dapat diunduh pada situs http://qgis.org/en/download. atau dengan memilih Start > All Programs > Quantum GIS Enceladus > Quantum GIS Enceladus. tanpa modul GRASS (Geographic Resources Analysis Support System). Meskipun Quantum GIS sendiri adalah perangkat lunak multi platform.exe. Quantum GIS akan dipasang di direktori C:\Program Files\Quantum GIS Enceladus. jalankan Quantum GIS dengan double click ikon Quantum GIS di desktop. Untuk mengambil versi terbaru.4. dengan nama file: QGIS-1.0-1-No-GrassSetup.html.0 Enceladus. versi yang digunakan adalah versi WindowsStandalone 1. sebagai alternatif dari perangkat lunak komersial seperti ArcView. Tulisan ini akan menjelaskan penggunaan Quantum GIS untuk keperluan digitasi dan pengolahan data peta dalam format vektor. II. ArcGIS atau MapInfo Professional. Untuk instalasi. Secara default. Pada tulisan ini. dalam tulisan ini hanya akan dijelaskan penggunaan pada platform Microsoft Windows. kemudian ikuti petunjuk yang muncul di layar. Pengantar Quantum GIS merupakan salah satu perangkat lunak gratis dan open source untuk keperluan pengolahan data peta. jalankan file installer. Tampilan awal Quantum GIS seharusnya muncul seperti gambar berikut: Pengolahan Data Peta Dengan Quantum GIS 3 .

com/downloads/details.microsoft.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D3802B2AF5FC2&displaylang=en Pengolahan Data Peta Dengan Quantum GIS 4 . kita harus memasang library Microsoft Visual C++ terlebih dahulu. Pesan error yang mungkin muncul seperti di bawah ini: Untuk mengatasi kegagalan instalasi tersebut.com/downloads/details.Troubleshooting: Quantum GIS memerlukan library Microsoft Visual C++ yang mungkin belum terpasang pada komputer kita.com/downloads/details.microsoft.aspx?familyid=32bc1bee-a3f9-4c13-9c99220b62a191ee&displaylang=en • Visual C++ Library Redistributable 2005 SP1: http://www. download dan kemudian install library Microsoft Visual C++ dari situs-situs berikut (untuk platform Windows 32 bit): • Visual C++ Library Redistributable 2005: http://www. Jika Quantum GIS tidak bisa dijalankan setelah proses instalasi seperti di atas.aspx?familyid=200B2FD9-AE1A-4A14-984D389C36F85647&displaylang=en • Visual C++ Library Redistributable 2008: http://www.microsoft.aspx?familyid=9B2DA534-3E03-4391-8A4D074B9F2BC1BF&displaylang=en • Visual C++ Library Redistributable 2008 SP1: http://www.

selain terhadap node 5 pixel Pilih 'pixel' agar proses snapping tidak terpengaruh zoom level. disajikan dalam tabel berikut: Bagian Rendering & SVG Setting Number of features to draw before updating the display 1000 Nilai Deskripsi Diisi nilai 1000 agar progres penggambaran peta kelihatan. Konfigurasi Quantum GIS Sebelum memulai menggunakan Quantum GIS. Sesuaikan angka piksel dengan preferensi kita. III. CRS (Coordinate Reference System). Angka 5 menurut pengalaman – cukup memadai. Overlay. download dan pasang library versi 64 bit. Digitising. Rendering & SVG.exe untuk memasang library Microsoft Visual C++ Redistributable. Tampilan dialog setting seperti gambar di bawah ini: Setting konfigurasi dibagi menjadi beberapa bagian (bisa di-klik di sebelah kiri dialog): General. Jika kita menggunakan versi Windows 64 bit. serta Network & Proxy . sebaiknya kita melakukan pengaturan global terlebih dahulu. pengaturan konfigurasi global ada pada menu Edit > Options). Map tools. tampilan peta kita tidak bergeser To vertex and Agar kita bisa melakukan snapping segment terhadap segmen. Make line appear less jagged at Check the expense of some drawing (aktifkan) performance Map tools Mouse wheel action Zoom to Agar ketika zooming (in/out) dengan mouse cursor mouse scroller. Agar tidak semua node diberi marker 5 Digitising Default snap mode Default snapping tolerance Show marker only for selected Pengolahan Data Peta Dengan Quantum GIS Check . Locale. Bagian-bagian setting yang disarankan untuk diubah. Nonaktifkan jiga terasa memperlambat kinerja komputer kita. melalui menu Settings > Options (pada versi Linux.Jalankan file vcredist_x86. terutama untuk data berukuran besar Aktifkan opsi ini agar gambar peta kita lebih bagus (halus).

yang akan membuat tampilan peta terlalu 'padat' Sesuaikan dengan selera kita IV. klik tombol Specify CRS. Pada dialog.Coordinate Reference System). Kita bisa memilih koordinat geografik (Lintang/Bujur) atau Projected (dalam sistem proyeksi tertentu. Line (garis) atau Polygon. proses pembuatan sebuah layer baru mengikuti langkah-langkah berikut: 1. 2. Akan muncul dialog pembuatan layer baru seperti di bawah ini: 1 2 3 Secara garis besar. Untuk membuat layer baru. pilih salah satu pilihan tipe objek peta. pilih tipe Line. misalnya UTM – Universal Transverse Mercator). kemudian pilih salah satu CRS dari dialog berikut: Pengolahan Data Peta Dengan Quantum GIS 6 . yang nantinya akan disimpan sebagai file Shapefile (SHP). Jika kita ingin mendigitasi bangunan. Sebagai contoh.features Marker style (aktifkan) Semi transparent circle (penanda). pilih tipe Polygon. Membuat Layer Baru Quantum GIS dapat digunakan untuk membuat layer peta baru (vektor). Memilih tipe objek peta: Point (titik). Pada dialog. jika kita ingin mendigitasi data jalan. Menentukan sistem koordinat (CRS . pilih menu Layer > New Vector Layer.

dapat diisi teks dengan panjang maksimum tertentu • Whole number. klik tombol OK. misalnya Whole number • Isikan lebar field (Width). Pilih menu Layer > New Vector Layer. sekarang terdapat satu field tambahan: Setelah ketiga langkah di atas dilakukan. misalnya 6 • Klik tombol Add to attribute list Dalam daftar atribut. kita akan membuat sebuah layer berbentuk polygon. lakukan langkah: • Isi nama field (Name). dapat diisi angka/bilangan bulat • Decimal Number. pilih tipe Polygon: Pengolahan Data Peta Dengan Quantum GIS 7 . Menentukan data atribut. Data atribut pada layer baru kita bisa berupa: • Text data. misalnya ID • Pilih tipe data (Type). Pada dialog pembuatan layer baru. Pada dialog seperti di bawah. Tutorial: Membuat Layer Polygon Pada tutorial ini. dapat diisi bilangan desimal/pecahan Data atribut perlu minimal satu. Langkahlangkah yang harus kita lakukan adalah sebagai berikut: 1.3. kemudian pilih pilih nama file tempat layer yang baru saja kita buat akan disimpan. mewakili objek bangunan. dan bisa lebih dari satu. V.

Akan muncul dialog berikut: A B Pilih Geographic Coordinate System > WGS 84 dari daftar pilihan seperti bagian A pada gambar di atas.2. 3. tambahkan field dengan nama id. atau klik tombol “WGS 84 (EPSG:4326)” dari bagian B pada gambar di atas. Setelah CRS dipilih. seperti gambar di bawah ini: Pengolahan Data Peta Dengan Quantum GIS 8 . tekan tombol OK untuk kembali ke dialog utama. Klik tombol Specify CRS. Pada dialog utama. Bagian B akan terdiri dari tombol-tombol yang dapat digunakan untuk memilih sistem proyeksi yang sering kita gunakan. tipe Whole number. dengan lebar 6.

Ulangi langkah tadi untuk field kedua. sebagai file bangunan. sehingga pada daftar field sekarang bertambah satu field. Simpan pada direktori C:\digitasi. Klik tombol OK. seperti pada gambar berikut: Pengolahan Data Peta Dengan Quantum GIS 9 . lebar 20.shp. tipe Text data. Kita akan diminta untuk menyimpan layer tersebut.Klik tombol Add to attribute list. dengan nama jenis. Tampilan pada daftar field sekarang menjadi seperti gambar di bawah: 4.

maka tombol-tombol editing akan aktif. Untuk mengubah status menjadi bisa diedit. arsiran layer polygon berwarna coklat dengan garis luar berwarna hitam. Untuk mulai manambahkan objek peta. akan dipilih secara acak oleh Quantum GIS. Pada contoh di atas. atau dari bisa diedit menjadi tidak bisa diedit (mengakhiri editing dan menyimpan/membatalkan hasil editing). yakni layer bangunan yang bertipe polygon. Ketika layer berada pada kondisi bisa diedit. Capture polygon Capture line Pengolahan Data Peta Dengan Quantum GIS 10 . Membuat objek garis baru. Tombol Toggle editing ini digunakan juga untuk mengakhiri pengeditan layer. sekarang akan ada tambahan satu layer. 5. Tombol ini hanya akan aktif kalau layer yang sedang aktif dan bisa diedit adalah layer bertipe Line. dan menyimpan hasil editing. Tombol ini hanya akan aktif kalau layer yang sedang aktif dan bisa diedit adalah layer bertipe Polygon. seperti pada gambar berikut: Fungsi masing-masing tombol editing adalah sebagai berikut: Tombol Nama Fungsi Toggle editing Untuk berganti status. seperti gambar berikut: Warna garis dan arsiran untuk layer polygon yang baru saja kita buat. atau menekan tombol (Toggle editing). 7. Pada Quantum GIS. klik tombol Save. 6.Setelah memilih nama file (tidak perlu menuliskan ekstensi SHP). kita bisa memilih menu Layer > Toggle editing. seperti pada contoh layer bangunan yang sedang kita bahas. layer bangunan tadi harus berada pada kondisi editable (bisa diedit). dari tidak bisa diedit menjadi bisa diedit (memulai editing). Membuat objek polygon baru.

Tombol ini hanya akan aktif kalau layer yang sedang aktif dan bisa diedit adalah layer bertipe Point. Bentuk garis dan polygon hasil penyederhanaan akan terlihat lebih kasar. dengan cara mengurangi jumlah node. Untuk memilih node kedua dan seterusnya. kemudian geser ke posisi yang kita inginkan Proses menghapus dan menggeser node dapat kita lakukan terhadap lebih dari satu node. Tombol Cut features hanya aktif kalau ada objek peta yang terseleksi. Membatalkan perintah sebelumnya. Proses seleksi objek peta dapat dilakukan dengan: • klik objek peta untuk memilih satu objek peta • Ctrl + klik objek peta lain untuk memilih objek peta berikutnya • menggunakan kotak seleksi untuk memilih objek-objek peta yang berada pada area tertentu Untuk menonaktifkan objek terseleksi. Tombol Delete selected hanya aktif kalau ada objek peta yang terseleksi. Menggeser sebuah objek peta (bisa titik. Keuntungan penyederhanaan objek antara lain dapat dibaca/ditulis dan digambar lebih cepat. Delete selected Cut features Menghapus objek-objek peta yang terseleksi. Seleksi objek peta dapat dilakukan menggunakan tombol (Select features). gunakan tombol (Deselect features from all layers). dan menyimpannya di dalam clipboard. kemudian tekan tombol 'Delete' pada keyboard komputer kita • menggeser sebuah node: klik node yang mau kita geser. Copy features Paste features Undo Redo Simplify feature Pengolahan Data Peta Dengan Quantum GIS 11 . Menghapus objek-objek peta yang terseleksi. garis maupun polygon). Menyederhanakan objek peta garis atau polygon. dan menyimpannya di dalam clipboard. klik node tersebut sambil menekan tombol Ctrl di keyboard komputer kita. dengan fungsi-fungsi: • menambah node garis atau polygon: double click pada segmen yang ingin kita tambahi node • menghapus sebuah node: klik node yang mau kita hapus. Move feature Node tool Digunakan untuk editing node. tanpa menghapus objek petanya. Memindahkan objek-objek peta yang berada dalam clipboard ke layer aktif yang sedang diedit. untuk nanti dipindah misalnya ke layer lain.Capture point Membuat objek titik baru. Menjalankan kembali perintah sebelumnya. Menyimpan objek-objek peta yang terseleksi.

Add ring Membuat polygon berbentuk donat. maka hasilnya adalah satu garis single part. Klik node-node polygon dengan tombol kiri mouse. dengan cara meng-klik salah satu node pada polygon dalam. dengan cara mendigitasi dengan mengawali dari satu node. dan diakhiri pada satu node yang lain Memotong polygon atau garis yang terseleksi. Ilustrasi: Pengolahan Data Peta Dengan Quantum GIS 12 . yang batas-batasnya mengikuti batas-batas terluar kedua polygon • Jika kita menggabungkan dua polygon yang tidak saling beririsan atau bersentuhan. menggunakan sebuah garis sebagai garis pemotong dengan Add part Delete ring Delete part Reshape features Clip features Merge selected features Menggabungkan (merge) beberapa objek peta. Propinsi Kepulauan Riau bisa diwakili oleh polygon multi part. dengan menambahkan satu polygon lagi di dalam polygon yang sudah ada Membuat polygon multi part. baik titik. maka hasilnya adalah satu objek polygon multi part Memutar simbol titik (belum bisa digunakan ketika tulisan ini dibuat) Rotate point symbols 8. Rempang dan Galang. Contoh penggunaan polygon multi part antara lain dalam penggambaran wilayah administratif yang terdiri dari pulau-pulau. tetapi masih dianggap sebagai satu objek peta. yang merupakan gabungan dari kedua garis tadi • Jika kita menggabungkan dua garis yang saling terpisah. Klik tombol kanan mouse untuk mengakhiri pembuatan polygon. hasilnya akan berupa sebuah objek garis multi part • Jika kita menggabungkan dua polygon yang saling beririsan atau bersentuhan. hasilnya adalah objek titik multi part • Jika kita menggabungkan dua garis yang ujung-ujungnya bertemu. maka hasilnya adalah satu buah polygon single part. seperti wilayah Propinsi Kepulauan Riau. Membuang polygon dalam dari sebuah polygon berbentuk donat. Beberapa kondisi berlaku ketika kita melakukan penggabungan (merging): • Jika kita menggabung beberapa titik. dengan cara meng-klik salah satu node dari polygon yang mau dihapus Mengubah bentuk polygon atau garis. Menghapus sebuah polygon yang menjadi bagian dari polygon multi part. Polygon multi part terdiri dari dua atau lebih polygon (area tertutup). garis maupun polygon menjadi satu buah objek baru. dengan terlebih dahulu memilih tombol (Capture polygon). Buat sebuah polygon. dengan bagian-bagiannya (part) berupa pulau-pulau seperti Batam.

b dan c Pengolahan Data Peta Dengan Quantum GIS 2. Buat 3 node baru.4. kita perlu menggeser tampilan peta. karena dengan cara ini. Klik kiri 1. Dialog pengisian atribut 3. kita mempunyai dua pilihan: • Pertama. Kita ingin mengubah bentuk polygon sehingga menjadi seperti ini. Buat polygon baru dengan bentuk seperti polygon yang sudah kita buat tadi. Klik kiri 1. karena tombol aktif kita sekarang adalah tombol Capture polygon. zoom level peta kita tidak berubah. agar area peta yang mau kita digitasi terlihat seluruhnya di layar 9. atau bisa juga membiarkannya kosong terlebih dahulu. dan langsung menekan tombol OK. memperkecil tampilan peta dengan mouse scroll. Hasil digitasi Pada waktu muncul dialog pengisian atribut. Klik kiri 2. Kita tidak bisa menggeser tampilan peta menggunakan tombol penggeser (Pan the map). kita bisa mengisikan atribut sesuai keinginan. Ini cara yang dianjurkan. Pada kondisi ini. Proses digitasi 2. Tarik node b ke posisi baru 13 . yang batas-batasnya berada di luar area peta yang tampil di layar monitor saat ini. dengan menggunakan tombol (Node tool) : Urutan langkahnya seperti pada ilustrasi di bawah ini: a b b c a c 1. menggeser area peta dengan menggunakan tombol-tombol panah pada keyboard komputer kita. Catatan: Jika kita sedang mendigitasi sebuah polygon berukuran besar. yang artinya ketelitian kita melakukan digitasi tidak adakan berkurang • Kedua. dengan cara double click di titik-titik a. Klik kanan 3.

Urutan langkahnya seperti pada ilustrasi di bawah ini: Pengolahan Data Peta Dengan Quantum GIS 14 . Hasil proses Reshape akan berbentuk seperti gambar di atas 11. Kita ingin membagi polygon ini menjadi empat bagian. 2. dengan menggunakan tombol (Split features). dengan menggunakan tombol (Reshape features): Urutan langkahnya seperti pada ilustrasi di bawah ini: d c a b 1. Setelah mengaktifkan tombol Reshape features. Kemudian klik kanan pada titik d. dengan double click di titik d 10. b dan c.a d c b a d b c 4. Buat polygon baru dengan bentuk seperti polygon yang pertama kita buat tadi. Titik d harus cukup dekat ke segmen yang sudah ada. Kita ingin mengubah bentuknya menjadi seperti ini. Tarik node d ke posisi baru 3. Buat node baru. Buat polygon baru dengan bentuk seperti polygon yang pertama kita buat tadi. Titik a harus cukup dekat ke node yang sudah ada. klik kiri pada titik a.

klik kiri klik kanan 1. kemudian buat sebuah garis memotong polygon yang terpilih tadi. Pembuatan garis menggunakan klik tombol kiri mouse. dan diakhiri dengan klik tombol kanan mouse. dengan menggunakan tombol Select features (dengan Ctrl + klik pada polygon kedua. atau menggunakan kotak seleksi) Pengolahan Data Peta Dengan Quantum GIS 15 . Aktifkan tombol Split features. 3. Pilih kedua polygon pada gambar 3. dengan menggunakan tombol Select features 2. akan terpotong menjadi dua bagian seperti ini 4. Pilih polygon asal. Polygon asal.

5. Polygon asal. Aktifkan tombol Split features. akan muncul dialog pemilihan data atribut. sekarang telah terbagi menjadi empat bagian 12. Kita akan menggabungkan dua polygon hasil langkah 11 tadi menjadi satu. Polygon baru hasil penggabungan kedua polygon Pengolahan Data Peta Dengan Quantum GIS 16 . dengan urutan langkah seperti ilustrasi berikut: 1. mau diambil dari atribut salah satu polygon atau mendefinisikan atribut baru 3. dengan menggunakan tombol (Merge selected features). Klik tombol Merge selected features. Gunakan tombol Select features untuk memilih dua polygon 2. kemudian buat garis yang memotong kedua polygon terpilih tadi 6.

lebar 6 • kelas_jalan. pilih lagi menu Layer > Toggle editing untuk mengakhiri pembuatan layer bangunan. tipe Text data. Sampai tahap ini.13. Sesudah kita membuat beberapa buah polygon. Sebagai langkah awal. akan muncul dialog konfirmasi seperti ini: Klik Save untuk menyimpan hasil perubahan. ketika menentukan tipe layer. lebar 20 Tampilan dialog pembuatan layer baru seperti gambar di bawah ini: Pengolahan Data Peta Dengan Quantum GIS 17 . kita akan membuat layer jalan. yang bertipe garis. tipe Whole number. kita sudah punya layer bangunan yang terdiri dari beberapa polygon. Tutorial: Membuat Layer Garis Pada tutorial ini. pilih Line. Tambahkan dua buah field untuk data atribut. Kalau ada modifikasi terhadap layer. Tampilan layer bangunan kira-kira seperti gambar di bawah ini: VI. hanya saja. masing-masing: • id. ikuti 3 langkah awal pembuatan layer polygon seperti sudah kita bahas.

Selanjutnya.shp. Ilustrasi: 1. Dialog pengisian atribut 3.Simpan layer ini di direktori C:\digitasi. Klik kiri 2. Gambar garis hasil digitasi Pengolahan Data Peta Dengan Quantum GIS 18 . Klik kiri 3. Pembuatan garis 2. Buat sebuah garis. dengan terlebih dahulu memilih tombol (Capture line). Klik tombol kanan mouse untuk mengakhiri pembuatan garis. Klik kiri 4. Klik node-node garis dengan tombol kiri mouse. ikuti langkah-langkah berikut untuk menambahkan objek peta berupa garis: 1. Klik kanan 1. dengan nama jalan.

dan akan menggambarkan titiktitik baliho. Klik kanan 1. Untuk pembuatan layer garis. Split features dan Merge selected features seperti pada layer polygon. Tambahkan dua buah field untuk data atribut. Buat garis-garis berikutnya. yang bertipe titik. Klik titik awal garis. masing-masing: Pengolahan Data Peta Dengan Quantum GIS 19 . Tampilan layer jalan ketika ditumpuk dengan layer bangunan. kemudian simpan data dengan memilih menu Layer > Toggle editing. Pada layer bertipe garis. Ilustrasi: 1. Sesudah garis kedua selesai didigitasi 3. Kemudian klik kiri pada node berikutnya. kira-kira berbentuk seperti gambar di bawah ini: VII. harus cukup dekat sehingga menempel ke segmen garis yang pertama. Klik kiri 2.2. pilih tipe layer Point pada dialog pembuatan layer baru. Tutorial: Membuat Layer Titik Pada tutorial ini. Buat garis kedua. dengan titik awal menempel pada node atau segmen garis yang tadi sudah kita buat. kita dapat menggunakan tombol Node tool. tempat pemasangan iklan. akhiri dengan klik kanan 2. Klik kiri 3. Reshape features. kita akan membuat layer reklame. Silahkan dicoba sendiri bagaimana menggunakan tombol-tombol tersebut pada layer garis.

lebar 6 jenis. Buat titik-titik berikutnya. 2. Klik titik lokasi yang diinginkan dengan tombol kiri mouse. Buat sebuah titik. Tampilan layer reklame ketika ditumpuk dengan layer bangunan dan jalan. tipe Text data. kira-kira berbentuk seperti gambar di bawah ini: Pengolahan Data Peta Dengan Quantum GIS 20 . Selanjutnya. dengan nama reklame.shp. tipe Whole number. dengan terlebih dahulu memilih tombol (Capture point). lebar 20 Tampilan dialog pembuatan layer baru seperti gambar di bawah ini: Simpan layer ini di direktori C:\digitasi.• • id. ikuti langkah-langkah berikut untuk menambahkan objek peta berupa titik: 1. kemudian simpan data dengan memilih menu Layer > Toggle editing.

Simpan pada direktori C:\digitasi. Dari tampilan yang terdiri dari tiga layer yang sudah kita buat (bangunan.qgs (ekstensi . dengan nama projek digitasi.qgs akan diberikan secara otomatis. jalan dan reklame).VIII. pewarnaan layer dan sebagainya. simpan sebagai projek Quantum GIS dengan memilih menu File > Save Project. Untuk membuka kembali file projek yang sudah kita simpan. ketika kita selesai membuat sebuah objek peta baru. pilih menu File > Open Project. File Projek Quantum GIS Kita dapat menyimpan pekerjaan kita sebagai file projek. Kita bisa memilih untuk Pengolahan Data Peta Dengan Quantum GIS 21 . sebagai penanda bahwa file tersebut adalah file projek Quantum GIS). Mengisi Data Atribut Pada kondisi default (tanpa perubahan konfigurasi). akan muncul dialog untuk mengisikan data atribut bagi objek peta tersebut. zoom level. IX. atau menu File > Save Project As. File projek Quantum GIS akan menyimpan informasi layer apa saja yang sedang aktif.

kemudian klik salah satu polygon pada layer bangunan yang ingin kita ubah data atributnya. Selanjutnya klik kanan pada daerah yang ditandai kotak merah pada gambar di atas 2. Kita akan menggunakan layer bangunan yang sudah kita punya. Pada bagian ini kita akan membahas beberapa hal mengenai cara pengisian data atribut. sebagai contoh. Ilustrasi: 1. Isikan data atribut. Tampilan setelah klik salah satu objek peta pada layer bangunan. Pengolahan Data Peta Dengan Quantum GIS 22 . kemudian klik OK untuk menyimpan Setelah data atribut diubah sesuai kebutuhan.mengisikan data atribut saat itu. Aktifkan tombol Identify features. atau memilih menu Layer > Toggle editing. adalah dengan menggunakan tombol (Identify features). Ikuti urutan langkah-langkah di bawah ini untuk mengubah atribut objek peta. pilih Edit feature form 3. 9. Pada popup menu. atau ditunda dulu dan data atributnya diisikan atau diubah belakangan. dengan menekan tombol Toggle editing. Pastikan agar layer bangunan aktif dan berada pada kondisi bisa diedit.1 Mengubah Data Atribut Menggunakan Tombol Identity Features Salah satu cara mengubah data atribut sebuah objek peta. 2. 1. simpan kembali hasil perubahan dengan memilih menu Layer > Toggle editing.

Tampilan tabel data atribut 2. simpan kembali hasil perubahan dengan memilih menu Layer > Toggle editing. atau memilih menu Layer > Toggle editing. Ilustrasi: (Open attribute table). Pastikan agar layer bangunan aktif dan berada pada kondisi bisa diedit. dengan menekan tombol Toggle editing. Hasil seleksi sinkron antara data peta dengan atributnya. atau klik kolom paling kiri pada tabel data atribut. Untuk mengubah data atribut layer bangunan melalui tabel data atribut. kita dapat mengubah data atribut melalui tabel data atribut.2 Mengubah Data Atribut Melalui Tabel Data Atribut Selain melalui penggunaan tombol Identify features. 3. 2. double click pada sel tempat data tersebut 4.9. Untuk mengubah sebuah data. Kita bisa pilih objek pada peta dengan menggunakan tombol Select features. atau 1. Pengolahan Data Peta Dengan Quantum GIS 23 . Tutup jendela tabel data atribut ketika proses perubahan data sudah selesai Setelah data atribut diubah sesuai kebutuhan. Tampilkan tabel data atribut dengan mengklik tombol memilih menu Layer > Open attribute table. ikuti langkah-langkah berikut: 1.

kita dapat mengubah semua data atribut objek peta yang terseleksi dengan sebuah nilai tertentu.3. klik tombol (Field calculator) dari tampilan tabel data atribut. yang salah satu fungsinya untuk melakukan perubahan data atribut terhadap banyak data sekaligus.9. dengan tombol Field calculator 2. Dalam contoh-contoh ini kita akan menggunakan layer bangunan. Gambar di bawah ini menunjukkan cara menampilkan Field calculator untuk layer bangunan: 1. seperti yang digambarkan pada tutorial berikut: Pengolahan Data Peta Dengan Quantum GIS 24 .1 Mengubah Atribut Objek Peta Terseleksi Dengan menggunakan Field calculator. Tampilan Field calculator Kita akan mencoba hal-hal yang bisa dilakukan melalui Field calculator pada bagian-bagian di bawah ini.3 Mengubah Data Atribut Menggunakan Field Calculator Field calculator terdapat pada tabel data atribut. jadi pastikan dahulu layer ini aktif dan berada dalam kondidi bisa diedit. Untuk menampilkan dialog Field calculator. 9. Tampilan tabel data atribut.

Jika field yang kita ubah. Kita akan mengisi data field jenis untuk semua objek yang terseleksi. Pengolahan Data Peta Dengan Quantum GIS 25 . dengan nilai 'Rumah': a) Update existing field: pilih jenis b) Check pilihan Only update selected features. karena field jenis tipenya teks. datanya tidak perlu diapit tanda petik tunggal. Data-data dari objek peta yang terseleksi akan kelihatan sebagai baris-baris yang terseleksi juga di sini a b c 3. isikan 'Rumah'. c) Pada Field calculator expression. dengan menggunakan tombol Select features 2. Pilih/seleksi beberapa objek peta. tipe datanya numerik.1. Harus diisikan dengan diapit tanda petik tunggal. agar hanya field yang terseleksi saja yang diubah nilainya. Klik tombol Open attribute table.

untuk field jenis Pengolahan Data Peta Dengan Quantum GIS 26 . Pada tampilan Layer Properties. pilihannya hanya ada tiga: rumah. Pastikan agar layer bangunan aktif dan berada pada kondisi bisa diedit. Tampilkan jendela Layer Properties dengan memilih menu Layer > Properties. Contoh lain. dengan tiga pilihan ketika mengisi field jenis: Rumah. kita dapat memberikan pilihan ketika mengisikan data atribut pada field tertentu. 2.4 Mempermudah Pengisian Data Atribut Dengan Fitur Value Map Kita sudah mencoba mengisikan data atribut dengan cara mengetikkan nilai yang kita inginkan. Untuk melakukan hal tersebut. dengan klik 2. pilihannya hanya jalan nasional/arteri. Kita akan menggunakan contoh layer bangunan. kita sebenarnya tidak diperbolehkan mengisi data atribut secara bebas. toko. dalam pengisian kelas jalan. atau Toko. Sebagai contoh. Setelah itu. dalam pengisian jenis bangunan. Dalam banyak kasus. atau memilih menu Layer > Toggle editing. Tampilkan Layer Properties. kemudian ikuti langkah-langkah seperti pada ilustrasi di bawah ini: 1. atau pabrik. klik tombol Edit widget Layer > Properties (Line edit).2. Pabrik. secara bebas. dengan menekan tombol Toggle editing. ikuti langkah-langkah di bawah ini: 1. Dengan Quantum GIS. pilih bagian kanan pada layer bangunan. atau memilih menu Attributes. pilih bagian Attributes. Hasil akhir. jalan kolektor atau jalan lokal.4. seperti pada contoh di bagian 9. tetapi harus memilih salah satu dari beberapa pilihan.1 dan 9. isi field jenis dari semua data terseleksi telah berubah menjadi 'Rumah' 9.

Gunakan Value map untuk membatasi pengisian field kelas_jalan pada layer jalan. atau Iklan Rokok. Iklan Minuman. Gunakan juga Value map untuk membatasi pengisian field jenis pada layer reklame. pilih Value map 4. Pengolahan Data Peta Dengan Quantum GIS 27 . Isikan Rumah. atau Jalan Lokal. Sekarang model pengisian field jenis sudah berubah menjadi tiga pilihan: Rumah. Toko atau Pabrik. dari Line edit menjadi Value map. Jalan Kolektor. Coba lagi ubah data atribut seperti penjelasan pada bagian 9. Model pengisian field jenis sekarang telah berubah. Klik OK jika sudah selesai membuat pilihan 5.2. supaya hanya boleh diisi: Iklan Makanan. Pada pilihan Attribute edit dialog. Klik OK untuk menyimpan konfigurasi layer. Toko dan Pabrik pada daftar nilai yang boleh dipilih.3. seperti pada tampilan di atas. supaya hanya boleh diisi: Jalan Nasional. 6.

Sign up to vote on this title
UsefulNot useful