P. 1
Pads Tutorial 2

Pads Tutorial 2

|Views: 68|Likes:
Published by Sachin Datarkar

More info:

Published by: Sachin Datarkar on Jul 01, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

07/01/2011

pdf

text

original

Creating a simple 5V Regulator Circuit using PADS

Note: This tutorial is modified from the original tutorial to bring it up to date for version 9 and to expand on some additional features that may be useful for ECE477 senior design students. The original tutorials are located at:

http://www.people.vcu.edu/~rhklenke/tutorials/PADS/PADS_Tutorial_3.3V_ Reg/SimpleReg.html
http://www.people.vcu.edu/~rhklenke/tutorials/PADS/PADS_Tutorial_New_Part/NewPart Type.html

What you will learn: Creating a Circuit Schematic with PADS Logic Creating a PCB Design with PADS Layout Routing a PCB Design with PADS Router Linking PADS Logic to PADS Layout & PADS Router Generating Gerber Files with PADS Layout Note: This tutorial assumes that you've completed the PADS User Interface tutorial and the New Part Type tutorial. 1. Creating a Circuit Schematic using PADS Logic 1.1 Begin by opening PADS Logic. Select Start > Programs > Mentor Graphics SDD > PADS 9.0 > Design Entry > PADS Logic.

1.2 Ensure that your user library is loaded by using the library manager - File > Library. (Refer to section 3 of the New Part Tutorial for step-by-step instructions).

1.3 Start a new design by selecting File > New. Your PADS Logic window should look something like this.

1.4 Use the Add Part window to add an LM2675 voltage regulator to your design. To add a part to your design, click on the button on the design toolbar. This will open the Add Part from Library window as shown below.

To locate the LM2675 part, you will need to select your custom library from the Library dropdown list in the filter. Select N:\Pads Library\user. Ensure that the Items field contains a single asterisk * and then press Apply. This will filter the results, displaying only the parts in your user library. The window should look like the one below.

5 Add capacitors to your design. Many parts come with the application and are . You should spend a little time acquainting yourself with the naming conventions used by the application to designate the parts. respectively. Press ESC to exit add part mode.Press the Add button. Hold the mouse roller wheel down while dragging the mouse up or down to zoom in or expand the view. An outline of the LM2675 part will appear below the mouse pointer while it is within the design window. Note: You may wish to zoom in on the LM2675 before completing the following steps. 1. Close the Add Part window and click somewhere near the center of the sheet to add an instance of the LM2675 part. You schematic window should look similar to the one below.

In the library dropdown list. When you click the add part icon. CAP1206 designates a surface mount capacitor having the dimension 120 x 60 mils. The part designated CAP7343 does not designate a part dimensioned as 730 x 430 mils. and select the Library drop-down button you will see the following: Select the various libraries. In the Items menu. To view a footprint. however. Move the Add Part window so that most or all of the design area is visible. select Properties from the menu and click on the PCB Decals button Open the add part window by clicking the button on the toolbar. A common way to define a capacitor is by its physical geometry. . A good practice is to use PADS Logic and PADS Layout Decal Editor together to match up the parts and geometries that you need. right-click the part. Most is not all of the library parts have associated PCB footprints. This will filter the results to display only the parts starting with 'CAP' that exist in the 'misc' library. Your screen should look similar to the one below. Select the part named CAP7343 from the list and press Add. clicking on various part numbers to see the schematic symbols associated with the part numbers.arranged in libraries based on function and vendor. choose the misc library (C:\MentorGraphics\2005PADS\SDD_HOME\Libraries\misc). For instance. type CAP* and then press Apply. and scan the parts list. Many capacitors are vendor-specific while others are more generic. . add a part to your schematic. The same is not necessarily true of all parts. press Apply.

Now select CAP1206 from the Add Part window.Place the CAP7343 capacitor to the left of the LM2675 as shown above. . Place the capacitor to the right of the LM2675 as shown below. Before adding the capacitor to your design. Press ESC to leave the insert mode. press Add and close the window. right-click the mouse and select Rotate 90 to turn the symbol. Place a second CAP7343 to the far right as shown in the schematic below.

Both of these parts are found in the 'misc' library.7 Assign values to your components. Double-click on the left-most capacitor. Use the INDMOLDED part for the inductor and the DIODE part for the diode. . This can also be achieved by pressing the button on the filter toolbar.1. 1. Ensure that part selection is enabled by right clicking in an empty area and selecting the Select Gates option.6 Add additional circuit components to your design. Add an inductor and diode to your design as shown in the image below. This will open the Part Properties window as shown below.

Press OK to close the Part Attributes window and return to the Part Properties window. double click and enter 15uF in the text box. To change this. .Click on the Attributes button to open the Part Attributes window. Scroll down to the Value field. By default. the CAP7343 part will not display its value in the schematic. click the Visibility button to open the Part Text Visibility window.

33uH . Repeat this process for the other components.Check the Value checkbox on the right side to enable display of the capacitor's value. Your schematic should now look like the one below.0.33uF Middle Capacitor .01uF Inductor . assigning the values listed below: Right Capacitor . Press OK to close the Part Text Visibility window and then press Close to close the Part Properties window.

.8 Change the PCB footprints assigned to the inductor and diode. We will change these parts to use surface mount footprints. The Get PCB Decal from Library window will appear. This window functions almost identically to the Add Part window. . Click Browse. The IND-MOLDED and DIODE parts both default to using through-hole footprints.. Double click the inductor to open the Part Properties window. Click on the PCB Decals button to open the PCB Decals Assignment window.1.

9 Adding Header Pins to your design. selecting the DIODE2 footprint from the 'common' library. Open the Add Part window. Press Apply and select HEADER02 from the list of parts. Repeat this process for the diode.The footprint we will be using for the inductor is named IND7 and is found in the 'common' library. One 2-pin header will be used for the input voltage source (12V). . Then press OK in the PCB Decal Assignment window and close the Part Properties window. and the other will be used for the 5V output. We will now add a pair of 2-pin headers to the schematic. 1. Select this decal and press OK. Select the 'connect' library from the dropdown list and enter HEADER* in the Items filter.

10 Connecting your parts. and two to the right (Use Ctrl+F to mirror a part horizontally). Your schematic should look similar to the one below. Your schematic should look like the image below. Press the button on the design toolbar.Note: PADS implements connectors as if they were multi-gate IC's. . Move the cursor to the left until it is horizontally aligned with the left capacitor. In this case. This will add a vertex / pivot point to your connection. This will activate Add Connection Mode. Move the cursor down and click on the top terminal of the left capacitor to complete the connection. 1. Add two header pins to the left of the schematic. Click once. each pin is treated as a separate gate and must be added individually. Place the cursor on pin 7 of the LM2675 and click once to begin adding a connection.

ensure that the selection filter allows selecting connections.Continue adding connections until your schematic is fully connected as shown below. . Then click on the connection you wish to remove and press delete. You can also activate Delete Mode by pressing the button on the design toolbar. Then right click and select Ground from the context menu. Begin by starting a new connection from the bottom-most net and moving down 2 or 3 spaces. This will allow you to remove objects with a single click. Note: To remove a misplaced connection. 1.11 Adding Power and Ground Connections To add a ground connection to your design. enter Connection Mode.

By default. Begin by starting a new connection from the net connected to pin 7 of the LM2675 and moving up.Position the ground symbol at the desired location and click once to place it. Right click and select Power from the context menu. Adding a power connection is done in a similar manner. all power connections are automatically connected to a net named +5V. . Your schematic should look like the one below. Repeat this process for the net connected to the top right header pin. We will need to change this for our design. Position the power symbol and click once to place it.

linking also enables a feature known as cross-probing. you must transfer the schematic netlist to PADS Logic.1 Linking PADS Logic to PADS Layout Before you can begin laying out your PCB. The recommended way of doing this is to create an application link between PADS Logic and PADS Layout. This will open the Net Properties window shown below.sch. Repeat this process for the right power symbol. Press OK. 1. This basically allows the selection of a part or net in PADS Logic to result in the selection . setting the Net Name to +5V. The completed schematic should look similar to the image shown below. In addition to allowing automatic synchronization of the schematic and layout information. Creating a PCB Design using PADS Layout 2.12 Save your schematic. 2.Double click on the left power symbol. Select File > Save and save the schematic to H:\PADS Tutorial\Tutorial. Change the Net Name field to +12V and select the Net Name Label check box.

select Tools > PADS Layout. You can maximize it onto the second monitor. click the New button.of the corresponding PCB footprint or trace in PADS Layout. Follow the instructions on the pop-up If the “Server Busy” reoccurs wait few seconds and click on the Switch To… button again . 2. Since we have not yet created a PCB Design file. and vice versa. this is because the Layout program is acquiring the license data. you will click Open and select your existing design file. A “Server Busy” message may pop up stating that it cannot connect or start because the other program is busy. A new PADS Layout window should appear as shown below. The Connect to PADS Layout dialog will appear. . Note: If you have the available screen real estate. The PADS Layout will very likely be minimized as well. A multimonitor setup is especially useful for this.2 Transferring the Netlist from PADS Logic to PADS Layout Note: Before transferring the netlist. ensure that your custom user library has be added to Layout's Library List. Note: On subsequent connections to PADS Layout or PADS Router. To connect PADS Logic to PADS Layout. it is recommended that you resize the PADS Logic and PADS Layout windows so that both are visible simultaneously. Refer to the New Part Tutorial if necessary.

there are some errors with the schematic. Switch back to the PADS Layout window. Print this page out and correct the errors before proceeding to the Layout portion. An annoying error that keeps popping us states that the power symbol has the wrong net name where you changed the power symbol to +12 volts. The PADS Layout Link window should be visible. Click on the Preferences Tab and select the Compare PCB Decal Assignments checkbox. You should now see a cluster of parts located at the origin (Location 0. If a padsnet. Press the Send Netlist button to transfer your design to PADS Layout.While PADS Layout is still open. switch back to PADS Logic.err pops up. .0). Ignore this for now. Now click on the Design Tab. This will ensure that the modified inductor and diode footprints are properly sent to PADS Layout.

a 1. button to enter board outline mode. you will need to create a board outline. . refer to the location indicator at the bottom-right corner of the window. . Place the cursor at the origin (location 0. On the Drafting Toolbar. Locations are given assuming that design units are in mils. 700 and click once to form the top edge of the PCB. right-click and select Complete the finish the board outline. Move the cursor up to location 0. Move the cursor down to location 1000. 0 and double click to complete the PCB outline (forming the right edge and bottom edge of the PCB).7 inch PCB should be large enough. 0) and click once to begin drawing the outline.3 Creating the board outline. After transferring the netlist. Note: For the following steps. to enable the Drafting Toolbar. Press the Drafting Toolbar button. click on the Since our circuit is extremely simple. Your PADS Layout window should look similar to the one shown below. Move the cursor right to location 1000. 700 and click once to form the left edge of the PCB.0 inch by 0. Alternatively.2.

. press the Modify. . Select Setup > Layer Definition... button to display the Enable/Disable Layers window. button and enter 2 in the popup window to fix this. you should modify the board's Layer Definitions. It is also recommended that you disable any unused layers..4 Setup the Board Layers Before placing the components on the board.2. Our board will only need two electrical layers. If more than two electrical layers are assigned. Click on the Enable/Disable... to open the Layers Setup dialog.

To flip a component to the opposite side of the board. One possible layout is shown below. as shown below. 2. Press OK to return to the Layer Setup window and then press OK again to confirm your changes.5 Positioning circuit components This tutorial includes two layouts. The second one in Section 6 uses the recommended layout procedure from the manufacturer and demonstrates some more techniques. The first will demonstrate the most common method of producing a layout. To make it easier to select individual parts. . select Tools > Disperse Components.Uncheck layers 3 to 20 and layer 25. This will reposition the components around the perimeter of the board. You can now begin placing the components within the board outline using drag and drop. press Ctrl + R. press Ctrl + F. With nothing selected. To rotate components. right-click in an empty area and select the Select Components option from the context menu.

Note: You may need to resize the placement grid to fit all of the parts on the board. Select File > Save and save the file as H:\PADS Tutorial\Tutorial. Use the modeless grid command. to resize the grid. G. With nothing selected. Close PADS Layout and restore the PADS Logic window. . 2. 2. Ex: type g 50 to set the grid interval to 50 mils. You can now click and drag the reference designators to reposition them as shown below.6 Position the Reference Designators You should now take the time to reposition the reference designators for your design.7 Save your PCB Layout. Close the PADS Layout Link window if it is still open. right-click and choose Select Documentation from the context menu.pcb.

select Open.3. The PADS Router program should open as shown below. This will open the Design Properties window shown below.pcb. Then browse to H:\PADS Tutorial and open Tutorial. The Connect to PADS Router window will appear. 3. .2 View/Modify the Design Properties To view the current design properties. right-click and select Properties from the context menu. Since we already have a PCB file. Select Tools > PADS Router.. Routing your design using PADS Router 3..1 Linking PADS Logic to PADS Router You will now connect PADS Logic to PADS Router in the same way that you connected to PADS Layout.

among other things. Change the Recommended value to 15 and the Maximum value to 20. The results of the test will appear in the Output Window located at the bottom right corner of the screen. Now select the Routing tab. Then press OK to confirm your changes. the default width of your PCB's traces. We will now use the built-in autorouter to route the pcb design. 3.From this window you can adjust a plethora of attributes that affect your design. After a few seconds.4 Verify your design You should now run a design check to ensure there are no routing errors with your design. Select Tools > Autoroute > Start to begin the autoroute process. Select Tools > Verify Design. Select the various tabs to get an idea of all the options available. . From this tab you can control.3 Use the PADS AutoRouter to route your design. the design should be fully routed as shown below. 3.

Close the PADS Router Link dialog if it is still open. Select Tools > PADS Layout to open the Connect to PADS Layout window.. Now press the button to enter Copper Pour Mode.2 Adding Copper Pours to your PCB You will now add a copper pour to each side of your PCB.pcb. browse to H:\PADS Tutorial and open Tutorial.. 4.3.5 Save your design. Finishing your design in PADS Layout 4. displaying your fully routed design.1 Linking PADS Logic to PADS Layout. returning to PADS Logic. PADS Layout should open. 4. Enable the drafting toolbar by pressing the button. Select Open.. Select File > Save and then close PADS Router. . You will now connect to PADS Layout again and complete the final steps in your design.

Select Top from the Layer dropdown list and select GND from the Net assignment dropdown list. Press OK. you will need to remove the copper pours and . the design window should appear as shown below. After the copper pours have been added. Repeat this process using the same coordinates and choosing Bottom for the Layer. Note: If you need to re-route your design. Select GND for the Net. Move the cursor to location 1000. The Add Drafting should appear as shown below.700 and click to draw the top edge. Move the cursor to location 1000.700 and click to draw the left edge.Move the cursor over the origin and click once to start drawing the outline of the copper pour. Move the cursor to location 0. 0 and double click to complete the copper pour outline.

Select Tools > Pour Manager to open the Pour Manager window. press the Setup button to open the Options > Thermals window.save your file before opening it in PADS Router. You will now flood your design. Press Start to begin the flood process.3 Flooding your design. Your design window should now look similar to the image below. 4. . filling in the copper pours with copper. close the Pour Manager. If you fail to do this. PADS Router may not correctly route your PCB. If there were no errors. If there were any errors.

you . Changing the type to 'Flood Over' should always prevent the 'too few spokes generated' error. Press OK and select Connectivity from the Check list. Press Start to run the check. close the Verify Design window. Select Clearance from the Check list and press start. Select Tools > Verify Design to open the Verify Design window. changes the method used to connect the copper pour to vias and pads of the same net.Any copper pour errors can often be corrected by changing the type or width of the thermal spokes. the following dialog will be displayed. of course. If there were no errors. Note: Not all copper pour errors are critical. If there are no errors.4 Verify Design You should now check your completed design for errors. If any errors were detected. it may not be deemed necessary to modify the Thermals parameters. 4. This.

select File > CAM to open the Define CAM Documents window.1 With your layout active. 5.5 Save your design.2 Top Layer Click on the Top Fabrication Layer and click Edit.should locate the error image on your design and correct the problem. Select File > Save to save your completed PCB design. then Yes to generate the desired output. PADS Router may not correctly route your PCB. This section will show the steps needed to create Gerber files for an ECE477 senior design layout. 5. If none are present. press Add and select the files to process. In the Output Device selection window click Print and click Device Setup button underneath it. Click Run. Select the desired printer and click OK. The separate layers are listed by Document Name and Fabrication Layer as shown below. If you fail to do this. 4. you will need to remove the copper pours and save your file before opening it in PADS Router. 5. Note: If you need to re-route your design. Generating Gerber Files The steps needed to generate the appropriate Gerber files will vary depending on the number of layers used and the PCB service that will be creating the board. Click Edit. The Edit Document window similar to the one shown below comes up . 4.6 Generating PCB printed output – Go to File > CAM and select the layer you want to print.

The Add Document window should look similar to the one below.Type (filename). Check the Board Outline checkbox and press OK.top in the Output File box Select Routing/Split Plane from the Document Type dropdown list if not already selected and select Top from the popup window. . Press the Layers button to open the Select Items window.

Change the Justification setting to Scale to 1 to 1 and press OK. You can zoom in and out using the mouse left and right buttons respectively. . Press the Options button to display the Plot Options window. press the Device Setup button to display the Photo Plotter Setup window.With the Photo button highlighted. Press OK. Press the Regenerate button and click yes. Press the Preview Selections button on the Add Document window to verify your settings.

5. close the preview window and then press OK to add the Top document.2. Press OK. Press OK. 5. . Press the Preview Selections button to verify your design.If everything looks correct.3 Bottom Layer Repeat part 5. substituting the Bottom Layer for the Top Layer in each step. Select Top from the Selected List and uncheck Part Type. Press the Options button and set the Justification to Scaling to 1 to 1. Select Silkscreen from the Document Type list and then select Top from the popup window. Press the Layers button to open the Select Items window.4 Silkscreen Top Click on the Silkscreen Top and select Edit.

4. 5.Close the preview and press OK to add the Silkscreen Top document. substituting Silkscreen Bottom for Silkscreen Top. Press the Preview Selections button to verify your design. . 5.5 Silkscreen Bottom Repeat Section 5.6 Solder Mask Top Select Solder Mask Top from the list. Select Solder Mask from the Document Type dropdown list and then select Top from the popup list.

5. Repeat Section 5. . substituting Solder Mask Bottom for Solder Mask Top.7 Solder Mask Bottom.Close the preview and press OK to add the Solder Mask Top document.6.

Close the preview and press OK to add the Drill Drawing document. Select Drill Drawing from the Document Type dropdown list and then select Top from the popup list. Type Drill Drawing for the Document Name. Select Options and press the Drill Symbols button and enter 1000 for Location X.8 Drill Drawing Press the Add. .5. button.. Press the Preview Selections button to verify your design. Press OK to close the Drill Drawing Options and Press OK again to return to the Add Document window..

Select NC Drill from the Document Type dropdown list. Enter H:\PADS . button.9 NC Drill Document Press the Add..5. Type NC Drill for the Document Name.. 5.10 Generate the Gerber Files Click on the CAM Directory dropdown and select <Create>. Press the Preview Selections button to verify your design. Close the preview and press OK to add the NC Drill document.

Click Yes to generate the Gerber Files. After the files have been successfully generated.html This comes courtesy of bugmenot. it is recommended that you verify them with an external tool. PCBExpress recommends using the PentaLogix ViewMate Gerber Viewer.1 The illustration below shows a layout which approximates the one found in the data sheet for the LM2675 Simple Switcher device used in this tutorial. Ignore for now. A warning may indicate a symbol size error.com Password: 9968292 6 ALTERNATIVE LAYOUT METHOD USING MANUFACTURER’S RECOMMENDED LAYOUT 6.pentalogix. The data sheet is located here and the recommended layout located on page 22. This requires administrator permissions to install. http://www.com/Download/download. Highlight all of the documents and press Run. Press OK.Tutorial\Cam\ for the CAM Subdirectory.11 Verify Gerber Files Before sending your Gerber Files to the PCB Company. 5.com Email : jperry@lensexpress. press Save and then close the CAM Documents window. .

we select the Copper icon. This area covers the previous traces. Click a starting location and draw the outline as shown below. the top side color. click OK and observe that the outline is now filled in. right-click an select Complete. . An Add Drafting message will pop up. which enables us to draw a polygon outline which is then filled with copper.6. To finish the outline. . Continue until the layout approximates the manufacturer’s recommended layout. our approximation is shown below. Press ESC and click on the Layout to show the new copper area in red.2 To create the large and irregular copper patterns.

Note that the data sheet states that there should be NO COPPER POUR UNDER THE INDUCTOR since the ground plane reduces the inductance. following the instructions in section 4.2. Use the Copper Pour Cut Out. copper pour with cut out as shown below. . to Produce a You have now completed the Mentor Graphics PADS Tutorial.A ground plane may be used as recommended. .

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->