Finite-Element Project ABAQUS Tutorial

Mohith Manjunath July 30, 2009

1

Contents
1 Introduction 2 Problem Description 3 Pre-processing 3.1 Part . . . . . . . . . . 3.1.1 Ceramic . . . . 3.1.2 Cap . . . . . . 3.1.3 Solder . . . . . 3.1.4 Copper . . . . . 3.1.5 PC Board . . . 3.2 Property . . . . . . . . 3.2.1 Assign Sections 3.3 Assembly . . . . . . . 3.4 Step . . . . . . . . . . 3.5 Interaction . . . . . . . 3.6 Load . . . . . . . . . . 3.7 Mesh . . . . . . . . . . 3.7.1 Partitioning . . 3.7.2 Meshing . . . . 3.8 Job . . . . . . . . . . . 3 3 4 5 5 6 10 16 18 19 20 21 22 24 24 26 26 37 44

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

. . . . . . . . . . . . . . . .

4 Postprocessing 45 4.1 Visualization . . . . . . . . . . . . . . . . . . . . . . . . . . . 45 4.1.1 Selecting the field output to display . . . . . . . . . . . 45 4.1.2 Plotting . . . . . . . . . . . . . . . . . . . . . . . . . . 45

2

1

Introduction

ABAQUS is a finite-element analysis software. Abaqus/CAE provides a preprocessing and postprocessing environment for the analysis of models. It is used in a wide range of industries like automotive, aerospace etc., and also is extensively used in academic and research institutions due to its capability to address non-linear problems. The Abaqus interface is shown in figure 1.

Figure 1: Abaqus Interface Get familiar with the icons in the tool bar especially the zoom icons which are absolutely necessary in the modeling process.

2

Problem Description

Lifetime equations for micro-electronic solder needs to be predicted in order to guarantee reliable in-field operation of micro-electronic components. Typical micro-electronic solder is shown in figure 2. The solder joints are under thermo-mechanical stress due to the change in temperature during in-field operation. Basically, there is a mismatch in coefficient of thermal expansion between boards and components. This might lead to thermal fatigue failures 3

and can be very catastrophic. Figure 3 shows the failure of solder joint after many cycles in operation.

Figure 2: Microelectronic Solder

Figure 3: Microelectronic Solder after 3000 cycles of operation

3

Pre-processing

Pre-processing is the initial phase of a finite element analysis program. This phase includes various modules for creating a model, defining material properties, specifying boundary conditions and external loads and meshing the assembly of the model. 1. Start Abaqus CAE. 2. Click Create Model Database to create a new model. 3. The previous chapter explains the different sections of Abaqus. 4. Continue with the next section for creating various parts of the model. 4

the model is divided into five parts . So. In the menu bar. 3. Solder. Click Rectangle icon to create a rectangle. On the grid draw an arbitrary rectangle. Cap. click Part -> Create. Deformable. divide the whole model into various parts and create each part using this module.1 Ceramic 1. Click Add Dimension tool and click the left side and 5 . Later all the parts can be assembled to form the entire model. Enter the name Ceramic and select 3D. Figure 4: Create Ceramic Part 2.Ceramic. Here. Solid->Extrusion and enter Approximate size as 10 (See Figure 4). What follows now is a step-by-step procedure to create each of these parts. for convenience.1.1 Part Part module is used to build different parts of the model. Copper and PC Board.3.

25 and press enter.25 and press enter. 4.Select the edges as shown 3. Select the bottom side. Enter 0. Select the five edges as shown in Figure 5(Multiple edges can be selected by holding shift key). Select the bottom side. left-click and enter 0. 6 . left-click and enter 1.2 Cap 1.1. Deformable. Enter depth of 0. Enter the name Cap and select 3D. Solid->Extrusion and enter Approximate size as 10.03. click Part -> Create. At the bottom click Done (Sketch the section for the solid extrusion).left-click to enter the dimension.625 and click OK. Cancel procedure by pressing the ”X” mark in the ”prompt area”(remember to do this every time you want to come out of a procedure and you can also press Esc key to exit an operation).0 for the dimension and press enter. Click Add Dimension tool and click the left side and left-click to enter the dimension. Click Rectangle icon to create a rectangle. Click Done. click Shape -> Blend -> Round/Fillet. On the grid draw an arbitrary rectangle. 2. In the menu bar. 3. From the menu bar. Click Done. Enter 0.3 for the dimension and press enter. Enter radius of 0. Figure 5: For ceramic .

Connect points 1 and 4 using Add -> Line -> Connected Lines.01 for the endpoint. draw a line through points 8 and 9 as shown in the figure. Repeat the same procedure for point 3 and enter 0.0 for the endpoint. Click Add -> Point and create three points.03 and press enter.01.0. 7 .005 for the endpoint and press enter again.-0. one on the top left corner of the rectangle and two on the corners of the arc of the fillet(See Figure 6). Fillet has been created. 5 and 6(you might have to zoom in a bit). press enter and then enter 0. Also. Enter fillet radius as 0. See Figure 7. Now click Add -> Arc -> Center/Endpoints. Click Edit -> Transform -> Translate and click Copy. Now. select the top and right side edges of the rectangle.095 for the endpoint. Repeat the same procedure for point 1 and enter 0. click Add -> Fillet.3.135.Three points created 5.0 for the start position. Repeat the same procedure for point 3 and enter 0.-0.0. Now. Now. Enter 0. Repeat the same procedure for point 3 and enter 0. In the menu bar. click Add -> Spline and draw a spline through the points 4. select the points 1 and 2(holding shift key) and click Done.005. while performing any of these operations if a point vanishes then you have to undo and zoom in to the area and complete the operation(keep this in mind).095 for the endpoint. Figure 6: Section sketch for cap . Select the center of the circle(for the arc) and then select the two endpoints of the arc. Repeat the same procedure for the points 7 and 8(first click point 7 then click somewhere in the middle(as shown) and then click point 8). Suppose. 4.

draw straight lines at top and bottom ends to make it a closed figure. In the menu bar. In the section which was copied to the right. select the right edge of the rectangle and then the horizontal line passing through the center of it.1. click Edit -> Transform -> Mirror and click Copy.Figure 7: Create spline through the points 4-5-6 and 7-8 6. Now delete the center horizontal line. Now. Click Done. Click Edit -> Split. Click Done. A mirror image is created. click Edit -> Delete and select the left edge. Now click Edit -> Transform -> Translate and click Copy. Select all the edges in the middle portion and also the arcs at the top and bottom. Click Done to exit the section sketch. click Shape -> Solid -> Revolve. press enter and then enter 0. Select one of the edges in the middle portion(vertical line in the C-Section). Enter 0. Click Edit 8 . Select the plane section(C-Section) at the back(see figure 8) of the cap.0 for the start position. Now. Enter 0. Section sketch appears(inverted C). Then. Now select all the entities above the mirror line. pick the center horizontal line as the mirror line.595 for depth and press OK. Click Done.0 for the endpoint and press enter again. bottom edge and the bottom half of the right edge(hold shift while selecting all three). 7.

Enter angle as 90 and press OK. Cancel the operation(X mark).0 for the start position. press enter and then enter 0. Finally. click Shape -> Solid -> Revolve.After the section sketch has been extruded -> Transform -> Translate and click Move.1. 8.0 for the start position.0 for the start position.1 for the endpoint and press enter again. In the section which was copied. press enter and then enter -0. Select the top section. Click Done. draw a straight line at the left end to make it a closed figure. click Add -> Construction -> Horizontal and click on the center of the arcs(top).1 for the endpoint and press enter again. Enter 0. click Add -> Construction -> Vertical and click on one of the centers of the arcs. press enter and then enter 0. Now select all the entities which were just copied(closed figure) and click Done. it should look like as shown in figure 6. Click Shape -> Wire -> Sketch. In the menu bar.0 for the endpoint and press enter again.-0. Enter angle as 90 degrees and press OK. Section sketch appears. Repeat the above procedure for the bottom section. Using 9 .0. Click Done to exit the section sketch. Now. Click Done to exit the section sketch. Now click Edit -> Transform -> Translate and click Copy. Enter 0. 9.Figure 8: Cap . Select the edge on the right. Enter 0. Select all the edges in the top portion(3 edges). Now. Select the face marked one(the face facing east) in the figure 6 and select one of the right edges. Now select all the entities which were just copied(closed figure) and click Done. Click Edit -> Transform -> Translate and click Move.

In the context bar. Now. click Insert After and select all the edges in the plane 1. Then. Now. click Shape -> Wire -> Point to point.1. Now. click Add. In the menu bar. select Chained wires and click Add. click Instance 10 .After the edges have been revolved connected lines tool draw the rectangle as shown in figure 7(wire sketch number 1). Now select two points at a time and complete the crooked rectangle number 2 as shown in figure 7. Now. Solid->Extrusion and enter Approximate size as 10. 3. All the points will be shown. click Module -> Assembly. See figure 8.Figure 9: Cap . Select the bottom edge. click Shape -> Solid -> Loft and click Insert Before. click Part -> Create.0 and click OK. Deformable. 4. Enter depth of 1. 3.3 Solder 1.6 for the dimension and press enter. Now. At the bottom click Done (Sketch the section for the solid extrusion). Enter the name Solder and select 3D. left-click and enter 0. On the grid draw an arbitrary rectangle. Click OK when done. Click Rectangle icon to create a rectangle. Select all the edges of plane 3(six edges to make it a closed loop) in figure 7. Enter 0. Click Add Dimension tool and click the left edge and left-click to enter the dimension.6 and press enter. click the tab Transition and select method as Select path. 4 and 5). select the edges one by one going from plane 3 to plane 1(two edges in plane 2. 2.

Click Done.0. Click Constraint -> Coincident Point and select the two points as shown in the figure. click Constraint -> Coincident Point and select the center of the top arc in the ceramic and the corresponding point in the cap so that they fit together(figure 12). click Instance -> Translate and select the solder instance. Now. Select Ceramic.0 for starting point and -0. Cap and Solder and toggle on auto-offset from other instances and click OK.0 for the 11 . Enter 0.Figure 10: Cap . Now.Part created -> Create.Creating wires Figure 11: Cap .0.27.

Now. select the solder for the instance to be cut and select the other two(ceramic and cap) for the instances that will make the cut(holding down the shift key). Select the front facing plane and then the right edge.Coincident points Figure 13: Solder . Click Yes. Click Shape -> Cut -> Extrude. Figure 12: Solder .end point. Click Instance -> Merge/Cut. Select Part -> Solder-1 in the context bar. 6. Now. click Add -> Point and click on the top-left point.Cut the geometry of cap in the rectangular solid 5. Select Cut geometry and click Continue. Select the point 12 . Give part name as Solder-1. Click Edit -> Transform -> Translate and click Copy. See figure 14. Click Done.

Figure 14: Solder . 7. Click Tools -> Partition and select Face -> Sketch. Click Done. click the tab Transition and select method as Select 13 . Click Shape -> Cut -> Loft. Now.-0.02 for the end point. Click Done. Select the bottom face. In the window that opens select type as blind and enter depth as 0. Select the front facing plane and then the right edge. Now.0 for start point and 0. Click done and then click OK in the window that opens. 10.After using Merge/Cut instance that was just created and enter 0. Now. Click Done and select the edge which is on the right. Now. Then.595 and click OK. 9. Click Insert before.2 and 3. draw a spline(Add -> Spline) as shown in figure 15 and make it a closed figure by drawing lines 1. Click Shape -> Cut -> Extrude. Select the left facing plane and then the right edge.270 and click OK. See figure 17. Click Shape -> Cut -> Extrude. In the window that opens select type as blind and enter depth as 0. draw a rectangle(covering the entire area towards the bottom and towards the right) with the copied point as its top-left corner.2 and 3. draw a spline as shown in figure 18 and click Done. 8. draw a spline(Add -> Spline) as shown in figure 16 and make it a closed figure by drawing lines 1. select the edges holding down shift button as shown in figure 19 and click Done. Now. Now. click Insert after and select the edges as shown in figure 20 and click Done.

Figure 15: Solder . Now. remove the part that got cut by using Shape -> Cut -> Extrude and by selecting any face and any edge draw a closed 14 . after the extrusion on both sides path. Select the top curve and the bottom curve(one after another.Top view.Front view. section sketch to extrude solid Figure 16: Solder .Side view. Click Add. by clicking add) which was created using partition method and click OK. section sketch to extrude solid Figure 17: Solder .

the solder should look something like figure 21. 15 . Click Done and click OK. The edges are now merged into one. Click Tools -> Geometry Repair and select Edge -> Remove redundant entities. Figure 19: Solder .Bottom view.Insert before operation(select the edges as shown) 11. Now.Figure 18: Solder . Finally. select the edges(holding shift) as shown in figure 22 and click Done. section sketch figure around it.

1. In the menu bar.Insert after operation(select the edges as shown) Figure 21: Solder . Deformable.Part created 3. Enter the name Copper and select 3D.Figure 20: Solder . click Part -> Create. 16 .4 Copper 1. Solid->Extrusion and enter Approximate size as 10.

See figure 23. 3. Figure 23: Copper . Enter depth of 0.8 and click OK. left-click and enter 0. On the grid draw an arbitrary rectangle. Click Add Dimension tool and click the left edge and left-click to enter the dimension. At the bottom click Done (Sketch the section for the solid extrusion).06 and press enter.Part created 17 . Click Rectangle icon to create a rectangle. Select the bottom edge.63 for the dimension and press enter. Enter 0.Figure 22: Remove redundant entities on the edge shown 2.

left-click and enter 3. Enter depth of 2 and click OK. Click Rectangle icon to create a rectangle. Deformable. Enter 1.1. See figure 24.3. On the grid draw an arbitrary rectangle. Solid->Extrusion and enter Approximate size as 10. Enter the name PC Board and select 3D.Part created 18 .5 PC Board 1.6 and press enter.5 for the dimension and press enter. At the bottom click Done (Sketch the section for the solid extrusion). 2. 3. In the menu bar. Figure 24: PC Board . Select the bottom edge. click Part -> Create. Click Add Dimension tool and click the left edge and left-click to enter the dimension.

Click Mechanical -> Expansion and enter 2.2 19 Activation Universal Gas Energy(J/mol/K) Const(J/mol/K) 4. enter the value 120000 MPa in the box below Young’s Modulus and 0.314 .31 for Poisson’s Ratio. 1. Click Mechanical -> Expansion and enter 8E-6 for Expansion Coeff alpha. Click OK. a the hyper˙ bolic law multiplier. This section of creating the properties of materials can be done later also. Enter the material name Cap and click Mechanical > Elasticity -> Elastic. n the stress order.2 Property Property module is used to define properties of various materials used in the model. enter the value 35000 MPa in the box below Young’s Modulus and 0. 6. Click Create. if required to do so. In the drop-down menu for Law select Hyperbolic-Sine and enter the values shown in the table below. Power Law Hyperb Law Eq Stress Multiplier(/s) Multiplier(/MPa) Order 4.5E4 8. A new window opens. Enter the material name Ceramic and click Mechanical -> Elasticity -> Elastic. 4. 5. Now.005 4. click Material -> Manager. Now click the button Create to create new material. Then.3E-5 for Expansion Coeff alpha.41E5 0. 2. In the context bar click Module -> Property to enter into property module. Now. Click Mechanical -> Plasticity -> Creep. The values of these parameters have been taken from reference 2. Q the activation energy and R the universal gas constant. enter the value 220000 MPa in the box below Young’s Modulus and 0. 3.3 for Poisson’s Ratio. Click Mechanical -> Expansion and enter 1. C is the power law multiplier. Click Create. Hyperbolic-sine law is given by: −Q ε = C sinh(aσ )e RT ˙ n (1) Where ε is the strain rate.3.34 for Poisson’s Ratio.6E-5 for Expansion Coeff alpha. Click OK. Enter the material name Solder-SnAgCu and click Mechanical -> Elasticity -> Elastic. Now. sections are created and materials are assigned to each section. In the menu bar.

Click Section -> Create.4 G12(MPa) G13(MPa) G23(MPa) Temp(K) 8400 8400 8400 293 Click Mechanical -> Expansion and select Type as Orthotropic and enter the following values.65E-5 for Expansion Coeff alpha. E1(MPa) E2(MPa) E3(MPa) Nu12 Nu13 Nu23 19300 8300 19300 0.1 Assign Sections After the materials have been creates we need to assign these materials to the parts which were previously created. Select Solid -> Homogenous and click Continue. Click Mechanical -> Expansion and enter 1. Select Solid -> Homogenous and click Continue. Y and Z directions respectively in the material.5E-5 Click OK. From the material list select Ceramic and click OK. From the material list select SolderSnAgCu and click OK.15 0. From the material list select Cap and click OK. 3. 8. Enter name as Cap.4E-5 1. Enter the material name Copper and click Mechanical -> Elasticity -> Elastic. The values have been taken from reference 3. 3. alpha11 alpha22 alpha33 1. Click Section -> Create. 1. Enter name as Solder.2 and 3 refer to the X.Click OK. 7.5E-5 8. Click Section -> Create.32 for Poisson’s Ratio. Click OK. enter the value 90000 MPa in the box below Young’s Modulus and 0. Enter name as Ceramic. Now. In the drop-down menu for Type select Engineering Constants and tick the checkbox next to Use temperaturedependent data and enter the following values.4 0. Select Solid -> Homogenous and click Continue. Directions 1. 2.2. 20 . Click Create. Click Create. Enter the material name FR4-PC Board and click Mechanical -> Elasticity -> Elastic.

Now. select Ceramic from the list and click OK. Select the solder by clicking on it and click Done. Click Assign -> Section. 8. In the window that opens. After doing this we can apply the necessary constraints and loads on the assembly. In the context bar select part as Copper. From the material list select FR4-PC Board and click OK. Select the PC Board by clicking on it and click Done. See figure 21. 9. Select Solid -> Homogenous and click Continue. Select Module -> Assembly. Repeat the same procedure as before to make the solder fit right under the cap. 7. Click Assign -> Section.3 Assembly In this module. select Solder from the list and click OK. 21 . 5. select Solder-1 and toggle on auto-offset from other instances. select Cap from the list and click OK. In the window that opens. Select Ceramic and Cap holding down Ctrl. 6. 1. Click Instance -> Create. In the context bar select part as PC Board. the sections have been assigned to the parts with corresponding material. Click Section -> Create. Click Assign -> Section. From the material list select Copper and click OK. In the context bar select part as Ceramic. Enter name as PC Board. In the window that opens. Enter name as Copper. Select the ceramic by clicking on it and click Done. In the window that opens. In the context bar select part as Cap. Click Assign -> Section. Click Section -> Create. Select Solid -> Homogenous and click Continue. Click Instance -> Create. Select the cap by clicking on it and click Done. 3. Now. Select the copper by clicking on it and click Done. 10. select PC Board from the list and click OK. In the window that opens. all the parts created earlier can be put together(assembly) to get the required model. select Copper from the list and click OK. 2. Click Assign -> Section.4. click Constraint -> Coincident point and select the center of the top arc in the ceramic and the corresponding point in the cap so that they fit together. In the context bar select part as Solder-1.

Now.7. Type Extra-Step for name and select Procedure type -> General -> Visco and click Continue. Type:Automatic.0. 4. select all the instances and click Done. all the instances have been assembled and take a look at the assembled model by rotating the figure.0. select PC Board and toggle on auto-offset from other instances.Figure 25: Three instances assembled 3. mainly to create analysis steps and specify output requests. select Copper and toggle on auto-offset from other instances. 5.0 for the start point and -0. Click Instance -> Merge/Cut. Enter part name as Full-Model. 22 . Click Instance -> Create. Click Step -> Create. In the description field enter Abkhlung and enter time period as 30. See figure 26. click Constraint -> Coincident point and select the top-left corner of copper and bottom-left corner of solder. Click Instance -> Create. Now. Select Module -> Step. Enter 0. Now. Now. select Merge -> Geometry and select Retain in intersecting boundaries section and click Continue. 1.4 Step This module is used to perform many tasks. Then. click Instance -> Translate and select PC Board instance. Go to incrementation tab and enter the following.0 for the end point and click yes and then OK. All the instances are now merged and a new part by name Full-Model has been created. click Constraint -> Coincident point and select the top-left corner of PC Board and bottom-left corner of copper. 3.

Click OK. Maximum number of increments:10000. Max=10. Click Step -> Create.Figure 26: All instances(Ceramic. Click OK. Go to incrementation tab and enter the following. Enter time period as 900.005 and Integration:Explicit/Implicit.5. Max=900.5. Maximum number of increments:10000. Type:Automatic. Go to Other tab and select Iterative method and select ramp linearly over step. Max=30. Type:Automatic. Min=1E-6. Type Step-1-Abkhlung for name and select Procedure type -> General -> Visco and click Continue. Increment size:Initial=0. Go to Other tab and select Iterative method and select ramp linearly over step. 2. Click Step -> Create. Go to Other tab and select Iterative method and select ramp linearly over step. Increment size:Initial=0.5. Cap and Solder) assembled Maximum number of increments:10000. Tolerance=0. Enter time period as 10. Click OK. Increment size:Initial=0. Select Module -> Step. 23 . 3. Tolerance=0. Min=1E-6. Type Step-2-Halten40C for name and select Procedure type -> General -> Visco and click Continue. Min=1E6.005 and Integration:Explicit/Implicit.005 and Integration:Explicit/Implicit. Select Module -> Step. Tolerance=0. Go to incrementation tab and enter the following.

Maximum number of increments:10000. The interactions can be mechanical or/and thermal. boundary conditions and predefined fields. Go to incrementation tab and enter the following.005 and Integration:Explicit/Implicit. Increment size:Initial=0. Go to incrementation tab and enter the following. Select Module -> Step. Click OK. Select Displacement/Rotation and click Continue. this module is used to define various interactions within the model or interactions between regions of the model and its surroundings. Click Step -> Create. 5.5 Interaction As the name suggests. Go to Other tab and select Iterative method and select ramp linearly over step. Maximum number of increments:10000.5. Click Done and then just tick the box next to U1 to constrain that degree of freedom. Click BC -> Create. 3.4. Enter time period as 900. Min=1E-6. 2. Type Step-3-Aufheizen for name and select Procedure type -> General -> Visco and click Continue. Type Step-4-Haltenauf-125C for name and select Procedure type -> General -> Visco and click Continue. Select Displacement/Rotation and click Continue. Click Step -> Create. 3. Click BC -> Create. Go to Other tab and select Iterative method and select ramp linearly over step. Select Displacement/Rotation and click Continue. Click BC -> Create.5. Tolerance=0.6 Load Load module is used to define and manage various conditions like loads. Max=10.005 and Integration:Explicit/Implicit. Select the corner point which was previously not selected and click Done and then just tick the box next to U2 to constrain that degree of freedom. 3. Analysis constraints can also be applied between regions of the model. Max=900. Min=1E-6. Tolerance=0. Select Module -> Step. Increment size:Initial=0. Select the whole of left section(plane) and hold down control key to deselect the bottom-left point(see figure 27). Select Module -> Load. Type:Automatic. Click OK. Select the whole of front section(plane X-Y)(for easier selection click the icon in the ”prompt area” and select faces from the list and then 24 . Type:Automatic. Enter time period as 10. 1.

Figure 27: Boundary Condition on the left face .U1 constrained select ”by angle” from the list in the prompt area) and click Done and then just tick the box next to U3 to constrain that degree of freedom. Click Predefined Field -> Create.U3 constrained 4. Select the whole assembly and click Done and then enter 421 for the magnitude of temperature. 25 . Click OK. Select Other -> Temperature and click Continue. Figure 28: Boundary Condition on the front face .

Initial temperature for the entire model 3. Click Done.Figure 29: Predefined Field .1 Partitioning 1. 3. 26 . Select the face as shown in the figure 31 and click Create partition. select the entire model and the edge 1(choose by edge angle) as shown in figure 34.7. Repeat the same procedure for the faces as shown in the figure 32 and 33 and now entire PC Board should turn green(figure 33). A partition should be created and it should turn green(structured mesh). Click Tools -> Partition. select the entire model and click Done. Select Extrude Along Direction and select the edge 2(pointing down) as shown in the same figure. Check for direction and flip if required. Click Create partition. 2.7 Mesh This is one of the most important modules since accuracy of the results will depend on the meshing of the assemblies. 3. This module can be used to generate meshes and even verify them. Select Cell -> Extrude/Sweep edges. Select Cell -> Extend face. See figure 30. Select Module -> Mesh. See figure 35. Select Part -> Full-Model from the list in the left window.

it is mandatory) Figure 31: Partition .Extend face 27 .Figure 30: Partitions are required for the whole model(for orange colored ones.

Figure 32: Partition .Extend face Figure 33: Partition .Extend face 28 .

Figure 34: Partition .Extrude edges 29 .

Figure 35: Partition .The edges have been extruded 30 .

select the entire model and click Done. click Point and Normal. Then. Then. Then. Figure 36: Partition . 31 . At the end of this operation. the model should look similar to figure 41. 6. And select point and normal as shown in the figure 40 and click Create partition. Select Cell -> Define cutting plane.Select the point as pointed by the arrow and the line in pink 5. See figure 39.4. And select point and normal as shown in the figure 36 and click Create partition. And select point and normal as shown in the figure 38 and click Create partition. click Point and Normal. Select Cell -> Define cutting plane. select the entire model and click Done. click Point and Normal. See figure 37. Select Cell -> Define cutting plane. select the entire model and click Done.

At the end of previous operation 32 .Figure 37: Partition .

At the end of previous operation 33 .Select the point as pointed by the arrow and the line in pink Figure 39: Partition .Figure 38: Partition .

Figure 40: Partition .At the end of previous operation 34 .Select the point as pointed by the arrow and the line in pink Figure 41: Partition .

select the entire model and click Done. Select Cell -> Define cutting plane. And select point and normal as shown in the figure 42 and click Create partition. the model should look similar to figure 43. Figure 42: Partition . click Point and Normal.At the end of previous operation 35 .7. At the end of this operation. Then.Select the point as pointed by the arrow and the line in pink Figure 43: Partition .

the model should look similar to figure 45. Then. And select point and normal as shown in the figure 44 and click Create partition. Select Cell -> Define cutting plane. Figure 44: Partition . select the entire model and click Done. click Point and Normal.Everything is green! 36 .Select the point as pointed by the arrow and the line in pink Figure 45: Partitioning done .8. At the end of this operation.

01 and click OK.2 Meshing 1.7. click Done and select Structured from the list and click OK. accept the default options and click OK. Enter bias ratio as 10 and number of elements as 18. 2. In the process you will be able to learn how to partition any complicated geometry with minimum partitioning. Select the edges(click near the top end of the edges) as shown in the figure 47 and click Done. Select the edges(click near the left end of the edges) as shown in the figure 46 and click Done. Click Seed -> Edge Biased. Click Mesh -> Element Type. Click Mesh -> Controls. Select the entire model. 4. you can proceed to the meshing section but it is suggested that you try different partitioning methods and analyze the results. Enter bias ratio as 10 and number of elements as 18. 37 . In the approximate global size field enter 0. Switch to wire-frame view. Click Seed -> Edge Biased.Now. Select the entire model. 3. 3. Figure 46: Edges biased towards the solder(left) 5. Click Seed -> Part.

Figure 47: Edges biased towards the solder(top) 38 .

6. Enter bias ratio as 10 and number of elements as 8. Figure 48: Edges biased towards the solder(right) 7. Click Seed -> Edge Biased. Figure 49: Edges biased(Top view) towards the solder 39 . Enter bias ratio as 10 and number of elements as 16. Click Seed -> Edge Biased. Select the edges(click near the right end of the edges) as shown in the figure 48 and click Done. Select the edges(click near the bottom end of the edges) as shown in the figure 49 and click Done.

Figure 51: Ceramic . Enter bias ratio as 10 and number of elements as 8. Now. Figure 50: Edges biased(Top view) towards the solder 9. Click Done and in the window that opens select Sweep and click OK. See figure 53. Click Seed -> Edge By Number. Click Mesh -> Controls and select all the cells except the ones in the corner edge(see figure 52). select ceramic from the list of sets and click replace. Then.”Edge by number” operation for the edges shown 10. click the create display group icon. Select the edges as shown in the figure 51 and enter 14 for the number of elements. Click Seed -> Edge Biased. 40 .8. click Mesh -> Region and select all the cells(the whole ceramic) and click Done. Select the edges(click near the top end of the edges) as shown in the figure 50 and click Done.

Now. Click Mesh -> Region and select all the cells and click OK. 41 .Figure 52: Ceramic . click the create display group icon.Select all except the cells in green Figure 53: Ceramic Mesh 11. select cap from the list of sets and click replace.

Click Seed -> Edge By Number. Now. Click Mesh -> Controls and select all the cells except the ones in the corner edge(see figure 55).”Edge by number” operation for the edges shown 13. click Mesh -> Region and select all the cells(the whole solder) and click Done. click the create display group icon. Select the edges as shown in the figure 54 and enter 14 for the number of elements. Figure 54: Solder . See figure 56. Click Done and in the window that opens select Sweep and click OK. select solder from the list of sets and click replace.Select the cells as shown 42 .12. Then. Figure 55: Solder .

Click Mesh -> Controls and select all the cells. click the create display group icon. click Mesh -> Region and select all the cells and click OK. Now. select PC Board from the list of sets and click replace. Figure 57: Complete Mesh of the model 43 . Click Done and in the window that opens select Sweep and click OK. 15. click the create display group icon. Click Mesh -> Region and select all the cells and click OK. select copper from the list of sets and click replace.Figure 56: Solder Mesh 14. Now. Then.

Then. I would suggest. you can try to create a better mesh than this one and be proud of doing it. In the window that opens. Click Job -> Manager. so that you will become familiar with different kinds of meshes. just explore all the tabs and leave the default options as it is. There are quite a few dark patches which should not have been there. Now. 2. since you have gained a little experience in Abaqus now.It should be noted that the mesh created above is not a perfect mesh.. Select Module -> Job. Enter job name as 3DSolder and click Continue. After the job has been submitted. Click OK. you to experiment with the mesh by playing around with the mesh controls. select the current job and click Submit. the analysis can be monitored by clicking Monitor. 44 . click Create. seeding etc. 3.8 Job Job module can be used to create and manage analysis jobs and submit them for analysis. Now. 1.

To plot undeformed shape select Plot -> Undeformed Shape from the main menu bar. Here. Select Result -> Field Output from the main menu bar. 2. 4.1 Selecting the field output to display 1.4 Postprocessing The results generated from the analysis can be enormous so it requires additional processing which is termed postprocessing. Click OK. not all the modules of postprocessing are explained.1. 4.1 Visualization Here the model can be viewed and various plots can be generated. can be selected. PEEQ.2 Plotting 1. stress components etc. 45 . Here. You can explore different modules and try to generate plots for different parameters and get meaningful results out of them.1. To plot deformed shape select Plot -> Deformed Shape from the main menu bar. 4. one of the various parameters like CEEQ.

. Abaqus 6.7-4 Documentation. 2. TU Berlin 46 . FEM-Simulationen und Zuverlssigkeit von Advanced Packages LWF. International Electronic Manufacturing Technology 2006 3. Uni Paderborn. IFM.Bibliography 1. Improving Solder Joint Reliability of WLP by Means of a Compliant Layer . Lee Hun Kwang et al.

Sign up to vote on this title
UsefulNot useful