MODUL VISUAL FOXPRO MERCUSUAR

TABLE Table merupakan kerangka utama dalam database. Karena semua elemen database dari paling kecil ke paling besar bermula dari table. Cara membuat Table : • Masukkan perintah berikut pada Command Window : CREATE <nama table> • Maka akan muncul pengisi struktur table seperti dibawah ini :

Masukkan field-field pada : Nama field pada Field, Tab, pilih type data pada Type, Tab, ketik lebar field pada Width, Tab, ketik desimal (jika tipe Numeric), Tab, pilih index (Ascending, Descending, None), Tab, Tab, masukkan field yang lain. Akhiri dengan tekan OK, muncul pertanyaan “Input record data now”, Jawab Yes (bila langsung mengisi record) atau No (jika tidak akan mengisi record).

Memodifikasi Table • Masukkan perintah ini pada Command Window MODIFY STRUCTURE • Cara pengoperasiannya sama dengan pengoperasian langkah-langkah membuat table. FORM Form adalah tool dalam pemrograman visual untuk merancang tampilan masukan (input). Langkah-Langkah membuat Form : Dengan Wizard • Klik menu File, Pilih New, muncul

• Pilih Style Form (Standard. Picture Button. Menjalankan Form : DO FORM <nama form> Hasil dari form muncul seperti contoh berikut : • Pengoperasian Form : Add untuk menambah record. Pilih Table. • Klik dua kali (Double Klik) pada tombol yang akan diberi rutin. No Button. Boxed. Ketik rutinnya. pilih Form Wizard... ganti teksnya dengan nama tombol yang diinginkan. pilih jenis tombol (Text Button. Klik Close. lepaskan. Shadowed. Klik Next. Membuat Tombol Pengoperasian Form. Pilih Form Control Toolbar). • Ketik judul form. Memberi Rutin agar tombol dapat difungsikan. Colorful). Stone.1 Prev ke record sebelum Next ke record sesudah Bottom ke record terakhir Exit menutup form Membuat Form secara manual • Masukkan perintah berikut pada Command Window CREATE FORM <nama form> Atau Klik Menu File. pilih Table. Atur posisi field. Klik Finisih. Pilih Form. Klik menu View. Pilih Table yang ada (kalau tidak ada Klik tombol . pilih New File • Muncul Form kosong. arahkan pointer mouse ke form yang kosong. Embosed.. Ketik nama file form. Klik Close. Klik Ascending (urut kecil – besar) atau Descending (urut besar – kecil). • Pilih field yang dijadikan kunci urutan. klik Wizard. Tutup window Data Environment. Klik Save. Klik tahan fields. Fancy. Custom).MODUL VISUAL FOXPRO MERCUSUAR Klik Form. Klik Next. • Klik tombol >> untuk memilih semua field dari table yang akan dibuat form. Pilih New. . Flex. pilih Caption. Save untuk menyimpan record Print mencetak record Edit untuk meng-edit record Delete untuk menghapus record Find untuk mencari record Top ke record no. OK. OK. Pilih Data Environment. • Klik Command Button pada Toolbox Form (bila tidak muncul pilih View. Klik Next. OK). Chiseled.. • Berikut rutin untuk tombol-tombol tertentu. Klik View pilih Properties. Klik Add.

Klik Next • Pilih Field Layout (Columns.Refresh Ke record Sesudah (Next) If EOF() Go Bottom Else Skip Endif ThisForm. pilih Titles/Summary. Landscape).Refresh Menghapus Delete ThisForm. Klik Add. Pilih New. Ledger. • • • • • Klik Check Box pada Title Band. pilih Quick Report.Release REPORT Report adalah tool dalam pemrograman visual yang digunakan untuk merancang laporan. Klik icon Preview. Klik Next. Pilih Report. . Klik OK Ketik Judul Laporan pada tempat sudah disediakan. OK). Atur posisi. Pilih field-fieldnya dan Klik tombol >>.Refresh Keluar ThisForm.. Langkah-langkah membuat report Dengan Wizard • Klik Menu File. Untuk melihat hasil report ke printer klik Icon ! atau dari menu Report pilih Run Record. Klik Next • Pilih field yang dijadikan kunci pengelompokan. Klik Finisih. maka field akan masuk kedalam report. Pilih New.Refresh Ke Record Akhir (Bottom) Go Bottom ThisForm. Klik Wizard. Pilih Report. Untuk melihat hasil report. • Pilih nama table (bila belum ada. Untuk menyimpan. OK. klik menu tombol Close [X] jawab Yes. Klik menu Report. Presentation. Row) dan Pilih Orientation (Portrait. Klik Menu Report. Untuk menambah Judul. OK. Klik Ascending (urut kecil – besar) atau Descending (urut besar – kecil). pilih table. Pilih Report Wizard..MODUL VISUAL FOXPRO MERCUSUAR Tambah data Append Blank ThisForm. Klik Next • Pilih Style Form (Executive..Refresh Ke record Sebelum (Prev) If BOF() Go Top Else Skip -1 Endif ThisForm. Klik Save. Casual).Refresh Ke Record Pertama (Top) Go Top ThisForm. • Ketik judul Report. Klik Next • Pilih field yang dijadikan kunci urutan. Banded. Membuka File Report Masukkan perintah berikut pada Command Window REPORT FORM <nama report> Membuat Form secara manual • Masukkan perintah berikut pada Command Window CREATE REPORT <nama form> Atau Klik Menu File. Ketik nama file Report. klik tombol . pilih New File Muncul report dalam keadaan kosong.

Maka menjadi seperti contoh berikut : • • • • Pilih field pada bagian Available fields dan tekan tombol Add> maka field pindah ke bagian Selected fields. Pilih Field Name. masukkan kriteria penyaringan. Untuk menyaring data klik bagian Filter. Pilih Criteria. Klik Other. Klik Icon ! untuk melihat hasil Query. Jalankan hasil query. Akhiri dengan menyimpan file Query. Klik OK. Langkah membuat Query • Masukkan perintah ini dalam Command Windows CREATE QUERY <nama query> • Pilih table pertama. OK. pilih table kedua (dan seterusnya). • Akhiri dengan tekan tombol Close.MODUL VISUAL FOXPRO MERCUSUAR QUERY QUERY adalah tool dalam pemrograman visual yang digunakan untuk menghubungkan beberapa table menjadi satu relasi atau join. . OK.

Sign up to vote on this title
UsefulNot useful