AXIAL, BENDING, TORSION, COMBINED AND BUCKLING ANALYSIS OF A BEAM

Instructor: Professor James Sherwood Revised: Dimitri Soteropoulos Programs Utilized: ABAQUS CAE 6.9-EF1 Problem Description: In this tutorial, a finite element model of a beam will be constructed and analyzed using ABAQUS CAE. The analysis will look at stresses and displacements associated with multiple loading conditions for a steel I-beam. The beam will be “clamped” at one end and be loaded on the other end with prescribed displacements for axial, torsion and bending loads. A unit force will be applied to find the critical buckling load and the associated mode shape. The cross section of the beam is shown in Figure 1. The cross section dimensions are summarized in Table 1. The length of the beam is 90 cm.

Table 1. Cross Section Dimensions a b t1 t2 6 cm 7 cm 1 mm 2 mm

Figure 1. Beam Cross Section

ABAQUS CAE BEAM TUTORIAL

1

REV 03.16.2011

Creating the Model Geometry   Go to the Start Menu and open Abaqus CAE You may be prompted with an Abaqus/CAE 6.9 Extended Functionality box (Figure 1). Close this box by clicking the X in the top right hand corner.

Figure 1. Abaqus/CAE 6.9 Extended Functionality box.

ABAQUS CAE BEAM TUTORIAL

2

REV 03.16.2011

Once the Extended Functionality box is exited, the ABAQUS CAE Viewport should look similar to Figure 2. (Please note the model tree is the series of functions listed on the left hand side of the viewport, while the module is the list of icons to the right of the model tree)

Model Tree

Figure 2. ABAQUS CAE Viewport   To create the model geometry of the steel I-beam, a sketch of the cross section must be generated. Using the left mouse button, double click Parts in the model tree and the Create Part (Figure 3a) dialog box appears. Enter a new name for the part (I-BEAM), and under the Base Feature tab choose Shell for shape and Extrusion for type. Change the approximate size option to 0.5. The Create Part dialog box should look identical to Figure 3b. Click Continue… and the graphics window will change to a set of gridlines.

ABAQUS CAE BEAM TUTORIAL

3

REV 03.16.2011

Figure 3a. Create Part Dialog Box

Figure 3b. Create Part Dialog Box (I-BEAM)

For the first step in generating the model geometry, a rectangular box must be created. Click the Create Lines: Rectangle (4 lines) icon in the module. (Remember, the module is the series of icons to the right of the model tree) In the viewport click once with the cursor, then drag the cursor to any other place in the viewport and click again. A yellow rectangle should be visible in the viewport. Click the Create Lines: Connected icon in the module, hover the cursor along the top horizontal line of the rectangle until a white circle appears (Figure 4). The circle should appear at the midpoint of that line.

 

ABAQUS CAE BEAM TUTORIAL

4

REV 03.16.2011

Figure 4. Midpoint of Horizontal Line  Once the white circle appears on the horizontal line, click with the cursor and draw a vertical line which connects to the bottom horizontal line. You will know that the line is vertical if there is a V located on the right side of the line (Figure 5).

Figure 5. Vertical Line

ABAQUS CAE BEAM TUTORIAL

5

REV 03.16.2011

At the bottom of the viewport. a New dimension: box should appear (Figure 6). At this point the line should turn red and its corresponding dimension should appear. it will now be given the proper dimensions. The sketch should resize to the appropriate dimension.059 for the vertical line) Figure 7.16.06 will appear when 0. The sketch should resize to the appropriate dimension and look similar to that in Figure 7. New Dimension Box       Enter a value of 0.059 in the new dimension box and hit Enter. At this point the line should turn red and its corresponding dimension should appear.  Figure 6.059 is entered for the vertical height. Since an arbitrary rectangle was drawn in the initial sketch. Move the cursor away from the vertical line and click. make sure to enter a value of 0.2011 . Click the Add Dimension icon in the module and click the top horizontal line in the sketch. Enter a value of 0. a New dimension: box should appear.07 in the New Dimension box. Dimensioned Sketch ABAQUS CAE BEAM TUTORIAL 6 REV 03. At the bottom of the viewport. The dimension values are being input in units of meters. Move the cursur away from the horizontal line and click. Make sure to keep a consistent set of units when creating any model. Hit Enter. Using the cursor click the middle vertical line. (Please note: due to significant figures in the sketch mode a value of 0.

Edit Base Extrusion Dialog Box Figure 9b.9) ABAQUS CAE BEAM TUTORIAL 7 REV 03. Repeat the previous step but drag the cursor over the far right vertical line.2011 . Figure 9a. Click and hold the left cursor button while dragging the cursor over the far left vertical line and then let go. The Edit Base Extrusion dialog box will appear (Figure 9a). Click Done. Final I-Beam Cross Section    Press Escape on your keyboard to exit the Auto-Trim tool. After this value has been entered the Edit Base Extrusion dialog box should look similar to Figure 9b. Figure 8. If this was done correctly the left vertical line should disappear.16. If the process was done correctly the sketch should look similar to that in Figure 8. This value will extrude the geometry 90 cm (0.  To properly create the I-Beam cross section. click the Auto-Trim icon in the module. In the Depth: category enter a value of 0. At the bottom of the viewport you will be prompted to Sketch the section for the shell extrusion.9.9m) in the Z direction. Edit Base Extrusion Dialog Box (0.

Sketch mode will automatically be exited and a grey I-Beam will appear (Figure 10). After the material properties have been entered.  Click OK.16. Extruded I-Beam Model Defining Material Properties  To define material properties for this model. The cross section sketch will be extruded into a three dimensional part. double click on Materials in the model tree and the Edit Material dialog box will appear (Figure 11a). Click OK. highlight Elasticity and click Elastic.  ABAQUS CAE BEAM TUTORIAL 8 REV 03. and click the Mechanical tab. Enter a Name for the material (STEEL). Enter values of Young’s Modulus = 200E09 Pa. Figure 10. and Poisson’s Ratio = 0. the Edit Material dialog box should look similar to Figure 11b.2011 .3.

and Homogeneous under the Type tab. double click Sections in the model tree and the Create Section dialog box will appear (Figure 12a). Create Section Dialog Box Figure 12b. It may be of interest to save the file after each section of this tutorial. All of the dimensions have been input in meters. Edit Material Dialog Box  Figure 11b. the model should be saved. Enter a Name for the section (FLANGE). At this point in preprocessing. The units chosen for the definition of the material properties should be consistent and dictate what units should be used for the dimensions of the structure. Edit Material Dialog Box (Steel)  Please note there is no dropdown menu or feature in ABAQUS that sets specific units. Create Section Dialog Box (FLANGE) ABAQUS CAE BEAM TUTORIAL 9 REV 03.Figure 11a.cae*) file.16. and choose Shell under the Category Tab. Click File then click Save.2011 . Name the file I-Beam Tutorial. Creating Sections  To create a shell section in ABAQUS. The file will save as a Model Database (*. therefore the respective Young’s Modulus units should be entered in Pa (Pascals). Your Create Section dialog box should look similar to that in Figure 12b. Click Continue…  Figure 12a.

If both the flanges and web had the same thickness only one section would need to be created. When this is done the number of Thickness integration points will default to 3. the dropdown menu could be used to prescribe a different material to this section. The Edit section dialog box should look similar to that in Figure 13. Under the basic tab enter 0. and choose Shell under the Category Tab.16. Click OK.001 for the Shell thickness (This value will be used to define a thickness of 1 mm for both the top and bottom flanges). Change the Thickness integration rule: to Gauss. the Material is defaulted to STEEL. Double click Sections in the model tree and the Create Section dialog box will appear (Figure 14a). and Homogeneous under the Type tab. Click Continue… ABAQUS CAE BEAM TUTORIAL 10 REV 03. Enter a Name for the section (WEB). If multiple materials had been created.   The Edit Section dialog box will then appear where a value for the respective Shell thickness can be prescribed for this section. Edit Section Dialog Box (FLANGE)    Since the flanges have a different specified thickness than the web.2011 . another section with the appropriate shell thickness for the web must be created. Your Create Section dialog box should look similar to that in Figure 14b. Figure 13. Because only one material has been created.

Figure 14a. Click OK. The Edit section dialog box should look similar to that in Figure 15. When this is done the number of Thickness integration points will default to 3. Change the Thickness integration rule: to Gauss. Under the basic tab enter 0.16. Edit Section Dialog Box (WEB) ABAQUS CAE BEAM TUTORIAL 11 REV 03. Figure 15. the Material is defaulted to STEEL. the dropdown menu could be used to prescribe a different material to this section. Because only one material has been created.002 for the Shell thickness (This value will be used to define a 2 mm thickness for the web). Create Section Dialog Box (WEB)    The Edit Section dialog box will then appear where a value for the respective Shell thickness can be prescribed for this section. If multiple materials had been created. Create Section Dialog Box Figure 14b.2011 .

16.Assigning Sections  Now that the shell sections have been created. Selected Flange Sections ABAQUS CAE BEAM TUTORIAL 12 REV 03. click the + to the left of the Parts icon. If the sections have been chosen correctly they will change color from grey to red (Figure 17). Next. double click Section Assignments. In the model tree. click the + to the left of the part called I-BEAM. Click Done. click the 2 sections of the top flange and the 2 sections of the bottom flange. Model Tree Expansion (Parts)  After the model tree has been expanded. they can be assigned to the geometry.  2 Top Sections 2 Bottom Sections Figure 17. Figure 16.2011 . While holding the shift key on the keyboard. this will further expand the model tree’s options. further expanding the model tree (Figure 16).

 The Edit Section Assignment dialog box will appear (Figure 18a). Under the Shell offset option make sure the drop down definition is set to Middle surface. Edit Section Assignment (FLANGE) ABAQUS CAE BEAM TUTORIAL 13 REV 03. Using the drop down menu under the Section option. Using the drop down menu under the Section option. The Edit Section Assignment dialog box should look identical to that in Figure 19b. choose the WEB section that was created. Next. The top and bottom now should now turn to a blue color. Figure 19a. Figure 18a. Under the Shell offset option make sure the drop down definition is set to Middle surface. The Edit Section Assignment dialog box should look identical to that in Figure 18b. choose the FLANGE section that was created. Edit Section Assignment (FLANGE)   Click OK. Click Done. Edit Section Assignment   Figure 18b. Double click Section Assignments. Edit Section Assignment Figure 19b.16. using the cursor click the web of the I-beam. the web must be assigned its respective section. The Edit Section Assignment dialog box will appear (Figure 19a). If the section has been chosen correctly it will change color from grey to red.2011 .

In this model.  Click Ok. Click Done. If this selection is done correctly. the elements will be made with dimensions as close as possible to 1 cm by 1 cm. To exit the rotate command press Escape on the keyboard) 2 Top Edges   Web Edge Side Edge 2 Bottom Edges Figure 20. Hover the cursor over the Seed Edge: By Number icon and release the button on the cursor.e keep the aspect ratio of length to width to be as close to 1 as is possible. (Note: To rotate the beam click F3 on the keyboard then left click and drag the cursor to rotate the part. While holding the shift key on the keyboard. Creating a Mesh  When creating a finite element mesh with shell or plate elements. click the top and bottom edges of the flanges.2011 . The first step in creating a mesh is to seed the part. To create a mesh for the model geometry. Selected Edges ABAQUS CAE BEAM TUTORIAL 14 REV 03. A total of eight lines should be selected since the part should be rotated and the four edges on the other end of the beam should also be clicked.16. double click Mesh (Empty) in the model tree. Click and hold the Seed Part icon in the mesh module and six icons will appear. The web of the I-Beam should now turn a blue color. it is best to make elements as square as possible. i. then the geometry should change color to pink. If the edges have been selected correctly they will turn a red color (Figure 20). thus making the complete model blue.

Hit Enter on the keyboard Click Done. The edge should turn from a pink to a red color if it has been selected correctly. The edges will now appear to be seeded with evenly spaced pink points along their length. This will seed the selected edges to have six evenly spaced elements along their length. A total of two edges should be selected since the part should be rotated and the edge on the other end of the beam should also be clicked.16. Click Done.            Click Done. A total of four lines should be selected (Figure 20). Next. Click Done. In the Number of elements along the edges: prompt at the bottom of the viewport enter a number of 3. In the Number of elements along the edges: prompt at the bottom of the viewport enter a number of 6. click the web edge of the I-Beam (Figure 20). If the edges have been selected correctly they will turn a red color. Hit Enter on the keyboard. In the Number of elements along the edges: prompt at the bottom of the viewport enter a number of 90. This will seed the selected edges to have three evenly spaced elements along their length. Hit Enter on the keyboard.2011 . This will seed the selected edge to have ninety evenly spaced elements along its length. while holding the shift key on the keyboard. ABAQUS CAE BEAM TUTORIAL 15 REV 03. Finally. click the four edges along the length of the I-Beam.

16. To do this task. Figure 22. Model Tree Expansion (Assembly) ABAQUS CAE BEAM TUTORIAL 16 REV 03. If this procedure was done correctly. The model tree will expand and should look identical to Figure 22. In the mesh module. it can be brought into the assembly. click the Mesh Part icon bottom of the viewport you will be prompted if it is OK to mesh the part? Click Yes.  The part is now ready to be meshed. At the Figure 21. Meshed Geometry Creating an Instance  Now that the part has been meshed. . the geometry will turn blue (Figure 21).2011 . click the + to the left of Assembly in the model tree.

 Figure 24. Double click on the Instances icon in the expanded model tree. If this step was done correctly the model should turn a blue color (Figure 24).2011 . Create Instance ABAQUS CAE BEAM TUTORIAL 17 REV 03. Click OK. This feature will allow multiple parts to be brought into the assembly. Figure 23. then this step would allow them to be entered into the assembly. The Create Instance dialog box will appear (Figure 23).16. If multiple parts had been created. Create Instance Dialog Box  The I-BEAM part is selected by default because only one part has been created for this tutorial.

In the model tree. Edit Step Dialog Box  Click OK to accept the default values for the various options.16. Static or Dynamic. Figure 26.Creating a Step   A Step is where the user defines the type of loading. Create Step Dialog Box (LOADING STEP) Click Continue…. Create a Name for the step called LOADING STEP. e.g.g. support constraints and forces. Figure 25a. ABAQUS CAE BEAM TUTORIAL 18 REV 03. The Create Step dialog box will appear (Figure 25a).2011 . Create Step Dialog Box  Figure 25b. The Create Step dialog box should look identical to Figure 25b. e. General. and the Edit Step dialog box will immediately appear (Figure 26). double click the Steps icon. and defines the boundary conditions. Under Procedure type choose General > Static.

2011 .Creating Sets  At this point 4 sets will be created to simplify the application of loads and boundary conditions in the upcoming steps. Figure 28a. Create Set Dialog Box (FIXED END)  Click Continue… The model will to a turquoise color with a visible mesh. While holding the Shift key on the keyboard. Make sure to double click the Sets option that is underneath the I-BEAM part in the model tree (Figure 27). click all of the nodes at one end of the beam. Create Set Dialog Box   Figure 28b. In this tutorial the beam was rotated such that the nodes on the right side of the beam were selected for the fixed end (Figure 29).16. Double click Sets in the model tree. ABAQUS CAE BEAM TUTORIAL 19 REV 03. To ensure each node is selected properly they will turn to a red color. Create a Name for the set called FIXED END. and under the type option make sure to choose Node. A total of 19 nodes should be selected. Sets Option in Model Tree  The Create Set dialog box will immediately appear (Figure 28a). The Create Set dialog box should look identical to that in Figure 28b. Figure 27.

The Create Set dialog box should look identical to that in Figure 30b.16. Create Set Dialog Box (LOAD END)   Click Continue… The model will turn to a turquoise color with a visible mesh. Create Set Dialog Box   Figure 30b. Double click Sets(1) in the model tree. Figure 30a. and under the type option make sure to choose Node. Fixed End Set   Click Done. While holding the Shift key on the keyboard.2011 ABAQUS CAE BEAM TUTORIAL . click all of the nodes at the opposite end of the beam that the FIXED END set was created. The Create Set dialog box will immediately appear (Figure 30a). 20 REV 03.Figure 29. Another set will be created for the loading end of the I-Beam. To ensure each node is selected properly they will turn to a red color. In this tutorial the beam was rotated such that the nodes on the left side of the beam were selected for the load end. Create a Name for the set called LOAD END. Click Done. A total of 19 nodes should be selected.

and under the type option make sure to choose Node.2011 . ABAQUS CAE BEAM TUTORIAL 21 REV 03. Likewise. Create Set Dialog Box (TOP FLANGE) Click Continue… The model will turn to a turquoise color with a visible mesh. To verify that the sets were not created on the same end of the beam. The model tree will expand and should look identical to Figure 31.   Figure 32a. The Create Set dialog box should look identical to that in Figure 32b. Finally two more sets will be created. Create a Name for the set called TOP FLANGE. click the LOAD END set in the model tree and the 19 nodes included in that set will turn red in the viewport. one for the TOP FLANGE and the other for the BOTTOM FLANGE. Create Set Dialog Box  Figure 32b. Double click Sets(2) in the model tree. The Create Set dialog box will immediately appear (Figure 32a). Created Sets Model Tree  Click the FIXED END set in the model tree and the 19 nodes which are included in that set will turn red.16. click the + to the left of Sets (2) in the model tree. Figure 31. These sets will be created to apply the torsional load to the model.

ABAQUS CAE BEAM TUTORIAL 22 REV 03. Now a set will be created for the BOTTOM FLANGE. Figure 34a. To ensure each node is selected properly they will turn to a red color (Figure 33). Node Selection Top Flange Set   Click Done.2011 . While holding the Shift key on the keyboard. Figure 33. Create a Name for the set called BOTTOM FLANGE. and under the type option make sure to choose Node. Double click Sets(3) in the model tree. Create Set Dialog Box (BOTTOM FLANGE) Click Continue… The model will turn to a turquoise color with a visible mesh. The Create Set dialog box will immediately appear (Figure 34a). Create Set Dialog Box  Figure 34b. A total of 7 nodes should be selected. click the nodes at the end of the top flange where the LOAD END set was created. The Create Set dialog box should look identical to that in Figure 34b.16.

and under the Step drop down menu make sure to choose Initial. The Create Boundary Condition dialog box should look identical to that in Figure 36b. Node Selection Bottom Flange Set  Click Done. click the nodes at the end of the bottom flange where the LOAD END set was created. ABAQUS CAE BEAM TUTORIAL 23 REV 03.16. Apply Constraint Boundary Conditions   Boundary conditions will be defined which will simulate a fixed (also known as “clamped”) beam at one end with a tip load. While holding the Shift key on the keyboard. and choose Symmetry/Antisymmetry/Encastre under the Types for Selected Step option. To ensure each node is selected properly they will turn to a red color (Figure 35). Under the Category option choose Mechanical. Figure 35. Create a Name for the boundary condition called FIXED. A total of 7 nodes should be selected.2011 . Double click BCs in the model tree and the Create Boundary Condition dialog box will appear (Figure 36a).

2011 . ABAQUS CAE BEAM TUTORIAL 24 REV 03. If this selection is done correctly you will be immediately prompted by the Region Selection dialog box (Figure 37). Click Continue… The Edit Boundary Condition dialog box will immediately appear.FIXED END. Create Boundary Condition Figure 36b.Figure 36a. Region Selection Dialog Box   Using the cursor. Create Boundary Condition (FIXED)    Click Continue… Using the cursor. The Edit Boundary Condition dialog box should look identical to that in Figure 38.16. Click ENCASTRE (U1=U2=U3=UR1=UR2=UR3=0). click Sets… at the bottom right side of the viewport. click I-BEAM-1. Figure 37.

Create Boundary Condition  Click Continue… Figure 39b. Applying an Axial Load to the Beam   A 0. Figure 39a.01% axial strain will be applied to the end of the beam as a prescribed displacement.Figure 38.16. Double click BCs(1) in the model tree and the Create Boundary Condition dialog box will appear (Figure 39a). The Create Boundary Condition dialog box should look identical to that in Figure 39b. Under the Category option choose Mechanical. Create a Name for the boundary condition called AXIAL. Edit Boundary Condition Dialog Box  Click OK. Create Boundary Condition (AXIAL) ABAQUS CAE BEAM TUTORIAL 25 REV 03. and under the Step drop down menu make sure to choose LOADING STEP. and choose Displacement/Rotation under the Types for Selected Step option.2011 .

Check the box to the left of U3 and enter a value of 0. The Region Selection dialog box will immediately appear (Figure 40).00009.16. Figure 40. Edit Boundary Condition Figure 41b.LOAD END. Using the cursor click I-BEAM-1. The Edit Boundary Condition dialog box should look identical to that in Figure 41b.2011 . Figure 41a. Since the I-Beam cross section was sketched in the X Y plane. Edit Boundary Condition (AXIAL) ABAQUS CAE BEAM TUTORIAL 26 REV 03. a displacement will be added in the Z direction. Region Selection Dialog Box   Click Continue… The Edit Boundary Condition dialog box will immediately appear (Figure 41a).

16. If the prescribed displacement has been applied correctly small orange arrows will be visible at the nodes (Figure 42).0295 m (0. The Create Boundary Condition dialog box should look identical to that in Figure 43b.059/2). The y-distance from the center of the beam to the top or bottom flange is 0. Click OK. Applied Axial Load Applying a Torsional Load to the Beam  An equal and opposite displacement will be imposed on opposite sides of the beam to simulate a torque on the beam.00258 m. and choose Displacement/Rotation under the Types for Selected Step option. Under the Category option choose Mechanical. Double click BCs(2) in the model tree and the Create Boundary Condition dialog box will appear (Figure 43a). ABAQUS CAE BEAM TUTORIAL 27 REV 03. Create a Name for the boundary condition called TORSION TOP. and under the Step drop down menu make sure to choose LOADING STEP. Figure 42. The load is to be a 5° twist at the end of the beam.2011 . To find the required displacement in the x-direction to achieve the 5° twist use:   Where x is the prescribed displacement and is equal to 0.

Create Boundary Condition Figure 43b. Create Boundary Condition (TORSION TOP)   Click Continue… The Region Selection dialog box will immediately appear. Click I-BEAM-1.2011 .00258.TOP FLANGE. ABAQUS CAE BEAM TUTORIAL 28 REV 03.Figure 43a. The Edit Boundary Condition dialog box should look identical to that in Figure 45b.16. Region Selection Dialog Box  Click Continue… The Edit Boundary Condition dialog box will immediately appear (Figure 45a). the Region Selection dialog box should look identical to that in Figure 44. Figure 44. Since this displacement will be applied to the top flange in the +X direction click the box to the left of U1: and enter a number of 0.

Figure 46a. The Create Boundary Condition dialog box should look identical to that in Figure 46b. Edit Boundary Condition   Figure 45b. Double click BCs(3) in the model tree and the Create Boundary Condition dialog box will appear (Figure 46a). Edit Boundary Condition (TORSION TOP) Click OK. Under the Category option choose Mechanical.16. Create Boundary Condition Figure 46b. If the procedure has been completed correctly small orange arrows will appear pointing in the +X direction at the end of the top flange. Create Boundary Condition (TORSION BOTTOM) ABAQUS CAE BEAM TUTORIAL 29 REV 03. and choose Displacement/Rotation under the Types for Selected Step option. Create a Name for the boundary condition called TORSION BOTTOM. An equal and opposite displacement will be prescribed to the bottom flange.Figure 45a.2011 . and under the Step drop down menu make sure to choose LOADING STEP.

BOTTOM FLANGE. Edit Boundary Condition Figure 48b. Figure 47.16.  Click Continue… The Region Selection dialog box will immediately appear. The Edit Boundary Condition dialog box should look identical to that in Figure 48b. Region Selection Dialog Box  Click Continue… The Edit Boundary Condition dialog box will immediately appear (Figure 48a). the Region Selection dialog box should look identical to that in Figure 47. Edit Boundary Condition (TORSION BOTTOM) ABAQUS CAE BEAM TUTORIAL 30 REV 03.2011 . Click I-BEAM-1. Figure 48a.00258. Since this displacement will be applied to the bottom flange in the -X direction click the box to the left of U1: and enter a number of -0.

a prescribed displacement in the –Y direction will be imposed on the tip of the beam. If the procedure has been completed correctly small orange arrows will appear pointing in the -X direction at the end of the bottom flange. Figure 49. The Create Boundary Condition dialog box should look identical to that in Figure 50b. Double click BCs(4) in the model tree and the Create Boundary Condition dialog box will appear (Figure 50a). and choose Displacement/Rotation under the Types for Selected Step option. Create a Name for the boundary condition called BENDING.2011 . and under the Step drop down menu make sure to choose LOADING STEP. Both the axial and torsional loads are applied in this view. Under the Category option choose Mechanical. An expanded view of the loading end of the beam is shown in Figure 49. ABAQUS CAE BEAM TUTORIAL 31 REV 03. Click OK. Axial and Torsional Loads Beam in Bending  Finally.16.

Figure 51. Click I-BEAM-1. Region Selection Dialog Box  Click Continue… The Edit Boundary Condition dialog box will immediately appear (Figure 52a). ABAQUS CAE BEAM TUTORIAL 32 REV 03. the Region Selection dialog box should look identical to that in Figure 51.Figure 50a. The Edit Boundary Condition dialog box should look identical to that in Figure 52b. Create Boundary Condition (BENDING)   Click Continue… The Region Selection dialog box will immediately appear. Create Boundary Condition Figure 50b.006. Since this displacement will be applied to the load end in the -Y direction click the box to the left of U2: and enter a number of -0.16.LOAD END.2011 .

Axial. All three loading conditions are applied in this view (Axial. If the procedure has been completed correctly small orange arrows will appear pointing in the -Y direction on the loading end of the beam. Edit Boundary Condition  Figure 52b. ABAQUS CAE BEAM TUTORIAL 33 REV 03. Torsion and Bending Loads. An expanded view of the loading end of the beam is shown in Figure 53.16. and Bending). Figure 53.2011 . Torsion. Edit Boundary Condition (BENDING) Click OK.Figure 52a.

This will expand the model tree and should look similar to Figure 54. While holding Ctrl on the keyboard click the AXIAL. The pop up menu should look similar to that in Figure 55. Release the Ctrl button on the keyboard and right mouse click one of the selected boundary conditions. To do so click the + to the left of BCs (5) in the model tree. Pop Up Menu (Suppress)  Click Suppress. and TORSION BOTTOM boundary conditions.2011 ABAQUS CAE BEAM TUTORIAL . At this point the selected boundary conditions should be highlighted blue. Please note that the FIXED boundary condition should not be suppressed for any analysis since is needed to clamp the end of the beam and is not considered a loading condition. the others can be suppressed. suppressing the loads is helpful rather than deleting the loads when they are unwanted for the analysis. Figure 54. If this is done correctly a red X will appear to the left of the boundary conditions in the model tree.16. Since only the BENDING boundary condition is of interest for this analysis. An analysis for the bending loading condition will be completed. 34 REV 03. Since this tutorial calls for multiple loading conditions. Note: Suppressed BCs will not write to the inp file. Model Tree Expansion (BCs)  Once the model tree has been expanded all off the created boundary conditions can be viewed. TORSION TOP.   Figure 55.

Figure 56. Figure 57. Create Job Dialog Box (BENDING)   Click Continue… The Edit Job dialog box will immediately appear (Figure 57). i. In the Create Job dialog box. Thus the use of the underline in the name. The Create Job dialog box should look identical to that in Figure 56. A job will take the input file created by the preprocessor and process the model. Edit Job Dialog Box (BENDING)  Accept the default values and click OK. you have been preprocessing the model. Blank spaces are not allowed in a job name.e.2011 . create a Name for this job called BENDING. ABAQUS CAE BEAM TUTORIAL 35 REV 03.16. double click the Jobs icon in the model tree. Up to this point.Creating a Job  To create a job for this model. perform the analysis.

Click OK. click File and in the dropdown menu click Set Work Directory… (Figure 58). Figure 58.Setting the Work Directory  To ensure that the input files write to the correct folder.2011 .16. Set Work Directory  The Set Work Directory screen will immediately appear (Figure 59). ABAQUS CAE BEAM TUTORIAL 36 REV 03. At the top of the screen. Click Select… and use standard Windows practice to select (and possibly create) a subdirectory. Figure 59. setting the work directory must be accomplished. Set Work Directory (FOLDERS)   Click OK.

. It may be helpful to go to the folder on the computer to which the work directory is set to ensure that the input file was written there. Now that the correct directory has been sourced in the command window type abaqus inter j=BENDING and then hit enter.inp) of this model to the work directory.g. Figure 60. This choice will write an input file (.16. first click the + next to the Jobs(1) icon in the model tree.Writing the Input File (. To access a specific directory within that drive type cd followed by the specific folder name in that directory (e.inp)    To write the input file of the job that was created. Abaqus Command Prompt (COMPLETED) ABAQUS CAE BEAM TUTORIAL 37 REV 03.A) then hit Enter. To change directories in the Abaqus Command type the directory of choice followed by a colon (D:) then hit Enter. If the job has completed successfully the Abaqus prompt should look similar to Figure 60. Model Analysis (ABAQUS Command) Method #1      Go to the Start Menu and open Abaqus Command ABAQUS is set to a default directory (Example E:\>).2011 . cd APPLIED STRENGTHS T. Right click the job called BENDING and click the Write Input option.

Because the last step of creating the model was to create a job/write (and possibly submit) an input file. If you see a warning:  Click OK. Postprocessing using ABAQUS CAE   After the analysis has successfully completed in the Abaqus Command window using Method #1 or using Method #2. The intent of this warning is to prevent the user from accidentally overwriting a previously completed analysis with the same name. Right click the BENDING job and then click Results.16. the model should turn to a green color and the truss will have rotated to an isometric view (Figure 61).  Figure 61. the BENDING job should still be highlighted in ABAQUS CAE model tree. The model will now be submitted for analysis by ABAQUS and the progress can be viewed in the status window at the bottom of the screen. Analysis Results Isometric View ABAQUS CAE BEAM TUTORIAL 38 REV 03. If this selection was done correctly.Method #2    An alternative method for submitting an *. return to view the ABAQUS CAE viewport.2011 .inp file for processing by ABAQUS can be accomplished with ABAQUS CAE Right click the job called BENDING and click the Submit option.

The model should look similar to that in Figure 63. then click it.  To rotate the truss back into the X Y plane for viewing. click View in the toolbar at the top of the screen. Views Toolbar  To view the deformed shape of the model. Deformed Shape (BENDING) ABAQUS CAE BEAM TUTORIAL 39 REV 03. Next. Figure 63. Click Toolbars and make sure the option Views has a check mark to the left of it. click the Plot Contours on Deformed Shape icon in the Visualization module. Figure 62. The Views toolbar will appear (Figure 62). If not. and the Apply Front View button can be clicked to view the model in the X Y plane.2011 .16.

this will change the contour color to represent the third invariant stress levels. Figure 65. The I-Beam model should look similar to that in Figure 65. Third Invariant Stress Contour ABAQUS CAE BEAM TUTORIAL 40 REV 03.2011 . Figure 64. Mises Dropdown  Using the cursor click Third Invariant.16.Obtaining Stress Values in Elements  To obtain the stresses in an element first the appropriate type of stress must be viewed. At the top of the viewport underneath the top toolbar click the drop down menu Mises (Figure 64).

At the top toolbar click Tools (Figure 66). Now that the appropriate stress contour is being viewed. output stress values will be obtained for different elements.16. Query Dialog Box (ELEMENT) ABAQUS CAE BEAM TUTORIAL 41 REV 03.2011 . Click Element under the General Queries option. The Query dialog box should look similar to that in Figure 67b. Toolbar Tools  The Query dialog box will immediately appear (Figure 67a). Figure 67a. and then click Query… Figure 66. Query Dialog Box Figure 67b.

16. (To resume the torsion condition right click TORSION TOP & BOTTOM in the model tree and click resume).2011 . Stress Value Figure 68. At this point click the element on the model for which the stress value is desired. Please note: two torsional loads must be suppressed since there is a load for both the top and bottom flanges. Suppress both the BENDING and AXIAL boundary conditions and Resume both of the TORSION boundary conditions. To complete both the AXIAL and TORSION loading return to the model tree by clicking the Model tab at the top left of the screen. Modeling Different Loading Conditions  This tutorial completes the post processing for the BENDING loading condition of the project. Stress Value in Viewport  Without exiting the Query dialog box click another element to view the stress value. Recall that the elastic modulus was prescribed to be 200x109 Pa and all dimensions were input in meters therefore the output stress values are in units of Pa. The value of the stress will then appear at the bottom of the viewport (Figure 68). Please note: the stress value listed corresponds to the element outlined with a red box in the viewport. Create a new Job called TORSION and complete the post processing as needed. To complete the analysis using the TORSIONAL load.   ABAQUS CAE BEAM TUTORIAL 42 REV 03. Earlier in the tutorial the AXIAL & TORSIONAL boundary conditions were suppressed.

Choose the ODB field output option (Figure 70b).  Likewise. S Dropdown  Using the cursor click RF. Please note: two torsional loads must be suppressed since there is a load for both the top and bottom flanges.2011 . To obtain the reactions at the nodes click the Create XY Data icon in the Visualization module. For the best analysis. this unit load should be distributed amongst all of the nodes at the tip of the beam. If a combination of loading conditions is desired. However. The Create XY Data dialog box will appear (Figure 70a). Right click the AXIAL and then click Results. the AXIAL job should still be highlighted in ABAQUS CAE model tree. the amount of force to apply to each node is a function of the beam width of the element and the number elements connected to a node.   Figure 69. resume the respective boundary conditions and complete the post processing as needed. a unit axial load will be applied to the tip of the beam.16. Since the reaction force in the Z direction is desired click the Magnitude dropdown menu directly to the right of the RF dropdown and then click RF3. suppress the TORSION and BENDING conditions and create a new Job called AXIAL and complete the post processing as needed. Because the last step of creating the model was to create a job/write (and possibly submit) an input file.  ABAQUS CAE BEAM TUTORIAL 43 REV 03. Beam Buckling  For the beam buckling analysis. this will change the contour from viewing stresses to the magnitude of reaction forces. The reaction forces at the nodes at the end of the beam are to be determined. At the top of the viewport underneath the top toolbar click the drop down menu S (Figure 69).

This click will expand the selection for more options.16. All other reaction components should be left unchecked (Figure 71b). Create XY Data Dialog Box (FIELD) Click Continue… The XY Data from ODB Field Output dialog box will appear (Figure 71a). Click Plot. Create XY Data Dialog Box   Figure 70b. Make sure that Pick from viewport is selected in the Method section. When the elements have been selected they will turn a red color. While holding the Shift key on the keyboard. click the nodes on the model at the end of the beam which the load was applied. A total of 19 nodes should be selected. Scroll down and click the black arrowhead next to RF: Reaction force . ABAQUS CAE BEAM TUTORIAL 44 REV 03. Under the Variables tab click the Positions: drop down menu and change the selection to Unique Nodal.Figure 70a. and click Edit Selection. XY Data from ODB Field Output   Figure 71b. XY Data from ODB Field Output  Next click the Elements/Nodes tab.2011 . Figure 71a. Scroll down and check the box next to RF3.

XY Data Manager Dialog Box ABAQUS CAE BEAM TUTORIAL 45 REV 03. click the XY Data Manager icon in the Visualization module.  Figure 73. The XY Data Manager dialog box will appear (Figure 73). Figure 72. A plot should appear similar to that in Figure 72. This option is located directly to the right of the Create XY Data option.16.  Click Dismiss. Field Output Plot  To view the numerical values of the reactions at the nodes.2011 .

Import Node Numbers (Excel)  Double click each entry and enter the reaction force value in column B of the same Excel workbook (Figure 76). double click each selection and an Edit XY Data dialog box will appear (Figure 74).2011 ABAQUS CAE BEAM TUTORIAL . Edit XY Data Dialog Box    In this dialog box the value of the reaction force at the respective node is listed. To view the value. Click OK. Figure 74. At this point click start on the computer and open Microsoft Excel.16. In column A of a new Excel workbook enter the node numbers of the 19 nodes found in the XY Data Manager dialog box (Figure 75). Figure 75. 46 REV 03.

Return to the model tree by clicking the Model tab at the top left 47 REV 03.16. In this case the sum is 5164.9. Many of the nodes have the same respective reaction force and it may be beneficial to color code the nodes with the same reaction forces (Figure 77). Import Reaction Forces (Excel)  Use the SUM function in Excel to add all the forces in column B. Dividing each Reaction Force value by this total gives the respective force to apply to each node so as to have a net unit force on the end of the beam (Figure 77).Figure 76. Color Coded Unit Loads (Excel)  Now that the nodal forces are known return to Abaqus CAE and close the Edit XY Data and XY Data Manager dialog boxes. Figure 77.2011 ABAQUS CAE BEAM TUTORIAL .

Suppress the AXIAL boundary condition (Right click -> Suppress). Figure 78a.2011 . ABAQUS CAE BEAM TUTORIAL 48 REV 03. The only boundary condition that should still be resumed is the FIXED boundary condition. Expand Steps (2) in the model tree if it is not already expanded by clicking the + to the left of the Steps(2) listing. Right click LOADING STEP and left click Suppress. Under the Procedure type: drop down menu choose Linear perturbation and click Buckle. Create Step Dialog Box Figure 78b. Double click Steps (2) and you will be prompted by the Create Step dialog box (Figure 78a). The Edit Step dialog box should look similar to that in Figure 79. Under the Number of eigenvalues requested: option enter a value of 5 in the box.16. The Create Step dialog box should look similar to that in Figure 78b. Create a Name: for the step called BUCKLE. Create Step Dialog Box (BUCLKE)  Click Continue… The Edit Step dialog box will immediately appear.  hand side of the viewport.

and 430.412. ABAQUS CAE BEAM TUTORIAL 49 REV 03.779. 393. In the dialog box click the Mesh tab.Figure 79. Rather than individually load 19 nodes with its respective unit load value.16. Create a Name for the set called Nodes_3_6_10_11 and ensure that Node is selected under the type option. we will create 4 sets since there are repeated unit load values of 116. Next click In all partrelated modules and check the box next to Show node labels (Figure 81).2011 .557. Create Set Dialog Box (NODES_3_6_10_11)   Click Continue… At the top toolbar click View then click Part Display Options… and the Part Display Options dialog box will immediately appear. Edit Step Dialog Box (5 Eigenvalues)    Click OK. double click Sets (4) in the model tree and the Create Set dialog box will immediately appear. Similar to creating sets in the first part of the tutorial. The Create Set dialog box should look similar to that in Figure 80.711. 233. Figure 80.

10. This was done so that the appropriate unit load could be placed on the correct nodes. 6. Set Creation (Nodes 3. Part Display Options Dialog Box   Click OK. 11) ABAQUS CAE BEAM TUTORIAL 50 REV 03. When the nodes are selected they will turn a red color (Figure 82). Figure 82.Figure 81.16.2011 . 10. and 11. While holding Shift on the keyboard click nodes 3. At this point small purple node labels will appear on the model. 6.

Figure 84a. 573] Nodes [2. Create a Name: for the load called NODES_3_6_10_11. 104. 290. 473. 572. Double click Loads in the model tree and the Create Load dialog box will appear (Figure 84a). Ensure Mechanical is selected under Category and Concentrated force under Types for Selected Step. 476] Nodes [569. 7]  If all of the sets have been created correctly the model tree should have a total of 8 sets and look similar to Figure 83. 570.16. Create Load Dialog Box Figure 84b. The Create Load dialog box should look similar to that in Figure 84b. the appropriate loads can be applied to the nodes. All Created Sets  Now that the sets have been created. 289. Create Load Dialog Box (NODES) ABAQUS CAE BEAM TUTORIAL 51 REV 03.2011 . Repeat the same method to create sets for: Nodes [103. 475. New Sets Figure 83.  Click Done. 571. 474.

 Click Continue… In the bottom right hand side of the viewport click Sets… and the Region Selection dialog box will appear. Enter a value of -0.02261 in the CF3: option. Edit Load Dialog Box  Figure 86b.02261) Click OK. the Region Selection dialog box should look similar to that in Figure 85. Region Selection Dialog Box (NODES)  Click Continue… The Edit Load dialog box will immediately appear (Figure 86a).NODES_3_6_10_11. Small yellow arrows will be visible pointing in the –Z direction if the procedure has been completed correctly. Click I-BEAM-1. The model should look similar to that in Figure 87. Edit Load Dialog Box (-0.16.2011 . ABAQUS CAE BEAM TUTORIAL 52 REV 03. The Edit Load dialog box should look similar to that in Figure 86b. Figure 86a. Figure 85.

Figure 87. 475.16.04522 Nodes [569. 570. ABAQUS CAE BEAM TUTORIAL 53 REV 03. 473. 571. 289. 573] = -0.083333  If this procedure has been completed correctly there will be small yellow arrows located ALL the nodes on the loading end of the beam (Figure 88). 572. 290. create loads for the three other sets that were generated in the previous steps. Model Load (-0. 7] = -0.02261)  Using the same approach. 104.076227 Nodes [2. 474.2011 . 476] = -0. Loads of: Nodes [103.

the first buckling load is listed in the viewport to be 30200 Hz.Figure 88.16. Deformed Shape (Localized Buckle) ABAQUS CAE BEAM TUTORIAL 54 REV 03. Unit Load   Double click Jobs (1) in the model tree and create a job named BUCLKE. When viewing the results. the deformed shape should look similar to that in Figure 89. Write the input file and post process the job the same way as in the first part of this tutorial. Buckle Load Figure 89.2011 . Also.

inp file should look similar to that in Figure 90. This part of the . The . Open the BUCKLE. Figure 90.16.inp file should look similar to that shown in Figure 91.2011 .inp file using Notepad. These changes will be made by editing the . This will open the Find dialog box. Input File (. Shell Section Input File ABAQUS CAE BEAM TUTORIAL 55 REV 03. The model will now be edited to increase the thickness of the flanges from 1 mm to 5 mm and the web from 2 mm to 4 mm. Figure 91. Open the folder on the computer that the working directory is set to.  The buckled shape shown in Figure 89 is distorted and appears to be localized buckling of the thin flanges and webs and not overall Euler buckling of the column.inp)  While holding Ctrl on the keyboard press the letter F.inp files that are generated in the working directory. Enter Shell and then click Find Next.

The Open Database dialog box will appear. Double click the first item in the Results tab called Output Databases.16. Source to the BUCKLE_EULER. Figure 92.inp (Note: the . Abaqus Command Prompt (COMPLETED)   Return to the Abaqus CAE viewport and click the Results tab located at the top of the model tree.001 to 0.005 and change 0.inp extension MUST be entered in the file name) Go to the Abaqus Command window and source to the directory if it is not already sourced.odb and click OK. This is where we will change the thickness values of the flanges and web. If the analysis completed successfully the command window will look similar to that in Figure 93. Shell Section Input File (Increased)    Click File then click Save As… Enter a File name: for this input file called BUCKLE_EULER. Enter the command abaqus inter j=BUCKLE_EULER and hit Enter. Change 0. ABAQUS CAE BEAM TUTORIAL 56 REV 03.002 to 0. This section of the input file should look similar to Figure 92. Figure 93.2011 .004.

16. Deformed Shape (Euler Buckle)  The buckled shape is shown in Figure 94. Buckle Load Figure 94. the important lesson is that the finite element method can find critical buckling loads be they local or overall Euler buckling. the first buckling load is listed in the viewport to be 168712 Hz. ABAQUS CAE BEAM TUTORIAL 57 REV 03. However.2011 . That force distribution may not be the same as we did not increase the size of the web and flanges by the same scale factor. Thus. the buckling load may be slightly incorrect for this second buckling analysis. Also. When viewing the results. Note the buckling force that was applied was based on the force distribution over the nodes resulting from an axial pull on the thinner sections.  Conclusion  Save the file by doing either File > Save or clicking the disk icon   Close ABAQUS CAE: File > Exit or Ctrl+Q This completes the Finite Element Analysis of an I-Beam tutorial. the deformed shape should look similar to that in Figure 94. The localized buckling is not present in this view and the overall buckling looks to be Euler buckling and notice that the deflection is about the smaller area moment of inertia.

Sign up to vote on this title
UsefulNot useful