You are on page 1of 5

Character Rigging in Cinema 4D R10 1. Create selection sets for use later on as weighting between mesh and joints.

2. EX: Start with a loop selection around the arm right before shoulder. Create another loop at the wrist. 3. Use Fill Selection > Hold Shift > click between the two loops of polygons to select this section of polys in-between. 4. Repeat for other sections of the character mesh. RIGGING 1. Activate the Joint tool. In Att. Mgr., set Bone > To Child. Deselect the Root Null and Align Axis checkboxes. 2. In Right view, Ctrl-click joints to create the Spine. 3. Rename the first joint as Root. Rename remaining joints as Spine1, Spine2, Spine3, Head. 4. Shift-select all joints in the Spine. 5. Activate the Naming Tool. In Attr., click Add and name this set, Basic Spine. 6. Select Root joint > Ctrl-click to create Hip-Knee-Ankle-Toe joints. Rename joints in Object Mgr. 7. Shift select the Hip-to-Toe joints > activate the Naming Tool. 8. In Attr., click Add and name this set, Basic Leg. 9. Switch to Front view, and reactivate the Joint tool. 10. Shift-select the leg joints from Hip to Toe, and move the joints until theyre inside the mesh. 11. Select the top Spine joint to build the arm joints from here. 12. Ctrl-click to create the joints: Clavicle-Shoulder-Elbow-Wrist-First Knuckle. 13. In Top view, move the Arm joints until theyre inside the mesh. 14. Rename the joints: Clavicle> Shoulder> Elbow> Wrist> Finger. 15. Shift-select the joints from Clavicle-to-Finger > Naming Tool > click Add and name this set as, Basic Arm. 16. Select Finger joint, and Ctrl-click at top of finger to create an additional joint. 17. In Front view, align the joint inside the Finger mesh. 18. Hold down the Shift key, and click on the new joint to create the fingers knuckles. 19. Rename Finger joints: Finger1B, Finger2B, etc. 20. Select the first Finger joint > Ctrl-drag to create a copy of the fingers joints. 21. Select the new joints > Naming Tool > Replace > In Replace field, type B, in With field, type A. 22. With the new joints selected, choose proper viewport and move the joints into the mesh of the next finger. 23. Copy the finger joints again for the other fingers. Repeat the naming process. 24. Copy FingerB set > Naming Tool > Replace: Finger > With: Thumb. 25. Replace: B > With: (none) to rid of the B. Enable Match Case and click Apply. 26. Switch views in order to rotate the Thumb joints to line up inside the Thumb mesh. RENAMING JOINTS FOR LEFT SIDE 1. 2. 3. 4. 5. Ctrl-click the (+) sign next to the Root joint to unfold all of the joints created. Select the Hip, Clavicle and Head joints. In Object Mgr., Edit > Select Children. Activate Naming Tool > in Replace section > in Prefix field type L_. Click Replace Name. This should append all of the joints names with L_.

ADDING IK 1. 2. 3. 4. Select the L_Shoulder joint > Ctrl-Select the L_Wrist joint. Choose Character > IK Chain. Ctrl-Select the L_Hip, L_Ankle, L_Ball, and L_Toe joints. Hold Ctrl down, and select Character > IK Chain. (By holding Crtl, this tells the IK Chain tool to create multiple IK chains based on the selected joints.) 5. Create a Circle spline primitive, then duplicate it in the Object Mgr. 6. Select both Circles > Attribute Mgr. > Radius = 25. 7. Name first Circle, L_Elbow Pole. 8. Second Circle, L_Knee Pole. 9. To place these, enable Snapping by pressing the P key to bring up the Snapping menu. 10. Enable 3D Snapping and Axis Snapping. 11. Select the L_Elbow Pole circle > grab the Move tool > move circle until it snaps to the left elbow joint. 12. Repeat for L_Knee Pole by snapping it to the left knee. 13. Deactivate the Snapping tool. 14. Move the L_Knee Pole until it is in front of the knee. 15. Move the L_Elbow Pole until it is behind the arm. 16. Select the L_Shoulder IK tag > drag the L_Elbow Pole and drop it into the Pole field in the Attributes. 17. Move the L_Elbow Pole circle down in the Y axis until the hand joints are inside the hand mesh again. 18. Select the L_Hip IK tag > drag-drop the L_Knee Pole into the Pole field in the Attributes. MIRRORING THE RIG 1. Select the L_Hip, L_Clavicle, L_Head joints. 2. Select the Mirror Tool > in Attr., set Plane to World YZ > set Origin to World. 3. Deselect Weights option. Only Hierarchy, Tags, Position, and IK should be selected. 4. Under Options in Mirror attributes, set Replace to L_ and With to R_. 5. Click Mirror button. The entire right side of the joints will be created. ADDITIONAL CONTROLLERS FOR RIG 1. Create a spline as a controller for the Left foot. 2. With Loop Selection, select a loop of edges around the bottom of the Left foot. 3. Choose Structure > Edit Spine > Edge to Spline. 4. Rename spline, L_Foot Controller. 5. With spline selected, enter Point mode. 6. With mouse over viewport, press Ctrl+A to select all points of this spline. 7. In Coord. Mgr., set Y Size to 0 to flatten the points of the spline to a single plane area. 8. In Coord. Mgr., set Y Position to 0 to place the spline at the bottom of the Foot. 9. Repeat the process for the Right foot. Rename the spline, R_Foot Controller. 10. Create a similar spline for the hands. 11. Rename the splines, L_Hand Controller, and R_Hand Controller, respectively. 12. The axis for the hand controllers need to be moved to their proper locations.

13. Select the Axis tool in the left toolbar, and select the Move tool. 14. Press P to open the Snapping menu, and make sure only 3D Snapping and Axis Snapping are enabled. 15. With R_Hand Controller selected, move its Axis and snap it to the right wrist joint. 16. Snap the L_Hand Controller to the left wrist joint. 17. Select the R_Foot Controller and snap it to the Right ankle joint. 18. Snap the L_Foot Controller to the Left ankle joint. 19. Select all four Controllers in the Obj. Mgr., and move them outside of the hierarchy, placing them at the top of the Object Mgr. MERGING CONTROLLERS AND GOALS 1. Make the R_Wrist.Goal a child of the R_Hand Controller. 2. Make the L_Wrist.Goal a child of the L_Hand Controller. 3. Select R_Knee Pole, R_Ankle.Goal, R_Ball.Goal, and R_Toe.Goal, and make them children of the R_Foot Controller. 4. Repeat step 80 for the L_Foot Controller. 5. Select ALL of the Goals and Poles > In Coord. Mgr., set H, P and B coordinates to 0. 6. Ctrl-drag L_Ball.Goal twice to create two copies. Rename them, L_ToeWiggle and L_Ball Lift. 7. Ctrl-drag L_Toe.Goal to create a copy. Rename it, L_Toe Lift. 8. Make the L_Toe.Goal a child of L_ToeWiggle. 9. Make the L_Ankle.Goal a child of L_Ball Lift. 10. Select L_Ball Lift and L_Ball.Goal and make them children of L_Toe Lift. 11. Ctrl-drag R_Ball.Goal twice to create two copies. Rename them, R_ToeWiggle and R_Ball Lift. 12. Make a copy of R_Toe.Goal and rename it, R_Toe Lift. 13. Make R_Toe.Goal a child of R_ToeWiggle. 14. Make R_Ankle.Goal a child of R_Ball Lift. 15. Make R_Ball Lift and R_Ball.Goal children of R_Toe Lift. SPINE CONTROLLERS 1. Create a Text spline primitive and type S in the Text field. Set the Height to 50. 2. Move the S to just behind the Shoulder area. 3. Ctrl-drag the Text spline in the Obj. Mgr. to create a copy. Change the text to an H. 4. Move the H spline to just behind the Hips. 5. Rename the S spline, Shoulder Controller. 6. Rename the H spline, Hip Controller. 7. Make both splines editable, so you can reposition their axis. 8. Enable 3D Snapping and Axis Snapping. Select the Axis tool and Move tool. 9. With Shoulder Controller selected, move and snap the axis to the Spine joint. 10. Select the Hip Controller, and move/snap its axis to the Root joint. 11. Make the Shoulder Controller a child of the Hip Controller. 12. Choose the Linear Spine tool. In the Side view, create a shape above the head. Enable Closed Spline to close the shape. Rename it, Head Controller. 13. Enable 3D and Axis Snapping. Move the Head Controllers axis and snap it to the Head joint.

14. Add a Flower spline. Name it Master Controller. - In Object tab, set Plane to XZ. - Petals = 4. - Reduce Inner/Outer Radius to barely encompass the feet of the character. 15. Select ALL of the Poles, Goals, and Controllers and make them children of the Master Controller. ASSOCIATING CONTROLLERS WITH PROPER TAGS 1. Enable the Search field by clicking on the magnifying glass at the top of the Obj. Mgr. 2. Isolate the Left side of the rig by typing L_ in the search field. 3. Select the L_Wrist joint, and add a Constraint tag. 4. In Constraint Attr., under PSR tab, drag-drop the L_Hand Controller into the Target field. Make sure only Rotation option is selected. 5. In the Search field, type R_. 6. Select the R_Wrist joint, and add a Constraint tag. 7. In Constraint Attr., drag-drop R_Hand Controller into Target field under PSR tag. Activate only the Rotation option. 8. Clear search field. 9. Select Root joint, and add a Constraint tag. Drag-drop Hip Controller into the Target field under the PSR settings. Enable Position and Rotation options. 10. Select the Spine joint, and add a Constraint tag. Drag-drop the Shoulder Controller into the Target field of the PSR settings. Enable Rotation only. 11. In Search field, type Head. - Select Head joint, and add a Constraint tag. - Drag-drop Head Controller into Target field of PSR settings. - Enable Rotation only. 12. Add a Constraint tag to Head Controller. - Drag-drop Head joint into Target field of PSR settings. - Enable Position only. BINDING & WEIGHTING RIG TO MESH 1. Select the Root joint. - Edit > Select Children from Obj. Mgr. menu. - Ctrl-click mesh of character. - Character > Bind. 2. Switch back to Object Mode. (Select the icon with the orange triangle and two black arrows.) 3. Select the Weight tool. Click padlock icon in Attributes to lock panel. 4. Select the Root joint. - Activate the Options and Painting tabs in Weight tool attributes. - Under Options, switch Mode to Abs (Absolute). This will override current weight settings. - Set Strength to 100%. - Under Painting, set Falloff to None. 5. Paint area surrounding the Root joint. 6. Select the L_Hip joint and paint the area surrounding this joint. 7. Reduce Strength to 75% and paint the next edge loop outside of the weighted area. 8. Select the polys that make up the Left Foot. Select the Weight tool and turn up the Strength to 100%. 9. Select the L_Ankle joint. In Weight tool attr., click Apply Selected button. - Lower Strength to 50% and paint outer edge loop of weighted area. 10. Repeat this process for the remaining joints.

11. In Obj. Mgr., click on box with (+) sign to create an extra Obj. Mgr. interface. - Click the Eye to reveal the Filter selection. - Ctrl-click the Eye next to Joint so that only the joints show here. 12. To add weighting to existing weights, in the Weight tool attributes change the Mode to Add and set the Strength before painting. 13. Check the results of the Automatic Weighting by choosing the Weight tool and one-by-one selecting the joints of the rig. 14. Edit the weighting by painting where the weighting needs to be corrected. MIRRORING THE WEIGHT 1. Select the Loop Selection tool. 2. Select the edge loop that runs around the center of the character mesh. 3. Select the Fill Selection tool, and click on the Left side of the character mesh to select all of the polygons on the left half of the character mesh. 4. Hold down Ctrl, and click on the Point mode icon to convert the selection to points only. 5. Select the Spine joint, and then activate the Mirror tool. 6. Drag the Spine joint into the Target field of the Mirror tool attributes. - Make sure Plane is set to World YZ and Origin to Bind Mesh. - Select Tags and Weights options. - Click Mirror button. 7. Repeat step 6 for the Root joint. 8. To check the weighting for the character mesh, select the mesh in the Obj. Mgr. - Select the Weight tool. - Weighting should now appear as being evenly distributed on both halves of the character mesh. 9. To optimize the scene, you can get rid of extra Skin deformers. 10. Drag the Skin deformer below the character mesh and make it a child of the character Null, placing it between the Null and the character mesh. 11. You can now delete the remaining Skin deformers. ADDING USER DATA CONTROL SLIDERS (Example) 1. Select the Head Controller spline in the Object Manager. - In attributes, User Data > Manage User Data. - Click Add 5 times. - Name first Data, Jaw. - Change Interface to Float Slider, and click OK. 2. Add an Xpresso tag to the Head Controller. - Drag-drop the Head Controller into the Xpresso editor. - Click on red output box > User Data > add the user data names you created (i.e. Jaw). 3. Add the Jaw joint to the Xpresso editor. - Click the blue input box > Coordinates > Rotation > Rotation.P 4. Right-click inside Xpresso editor > New Node > Xpresso > Calculate > Range Mapper. 5. Select the Range Mapper node. - In its attributes, set Input Range to Percent, and Output to Degrees. - Set Output Upper to max. percentage needed. 6. In Xpresso editor, connect the Jaw output of Head Controller node to Input of the Range Mapper node. - Connect output of Range Mapper to Rotation.P of the Jaw node. 7. Go to the User Data slider for Jaw. - Drag the slider. The Jaw should now move based on the User Data Settings.