Manual STEP 5 V6.

6

1

Manual STEP 5 V6.6
Eng. Roberto Bairros dos Santos. www.bairrospd.kit.net

Manual STEP 5 V6.6

2

1

Índice: Exemplo prático de programação com STEP 5:............................................................. 4 1.1 Introdução ao exemplo: .......................................................................................... 4 1.1.1 Breve descrição da estação de lavagem:......................................................... 5 1.1.2 Diagrama elétrico do controle: ....................................................................... 6 1.2 Criando um programa em STEP 5 para controle estação de lavagem: .................. 7 1.2.1 Parametrizando o projeto:............................................................................... 7 1.2.2 Selecionando o modo trabalho” MODE”: ...................................................... 8 1.2.3 Selecionando a forma de representação dos operandos: ............................... 8 1.2.4 Nomeando o arquivo de impressão “Printer file”:.......................................... 8 1.2.5 Selecionando o modo representação: ............................................................ 9 1.2.6 Selecione o número de caracteres do comentário e símbolos: ....................... 9 1.2.7 Salvando as seleções:...................................................................................... 9 1.3 Criando o programa:............................................................................................. 10 1.3.1 Criando uma lista de endereços simbólicos: ................................................ 10 1.3.1.1 Editando a lista de símbolos: .................................................................... 11 1.3.1.2 Imprimindo ou mostrando os erros: ......................................................... 13 1.3.2 Editando o banco de dados: .......................................................................... 13 1.3.3 Editando o bloco de função FB: ................................................................... 17 1.3.3.1 Editando o nome do bloco de função: ..................................................... 17 1.3.3.2 Editando o comentário:............................................................................. 18 1.3.3.3 Editando o título do segmento 1 ............................................................... 18 1.3.3.4 Terminando o segmento 1: ....................................................................... 18 1.3.3.5 Corrigindo e editando símbolos:............................................................... 19 1.3.3.6 Corrigindo a linha de instrução: ............................................................... 19 1.3.3.7 Escrevendo o comentário do segmento: ................................................... 20 1.3.3.8 Deslocando entre os segmentos:............................................................... 20 1.3.3.9 Inserindo um novo segmento: .................................................................. 20 1.3.4 Documentando o programa: ......................................................................... 21 1.4 Transferindo os segmentos, blocos e arquivos: .................................................... 22 1.4.1.1 Verificando arquivos contidos em um diretório:...................................... 23 1.4.1.2 Como transferir os segmentos: ................................................................. 24 1.4.1.3 Verificando se O bloco transferido está no programa: ............................. 25 1.4.1.4 Transferindo segmentos:........................................................................... 25 1.4.1.5 Transferindo e renomeando blocos: ......................................................... 27 1.4.1.6 Renomeando um bloco: ............................................................................ 28 1.4.1.7 Transferindo um bloco de organização (OB): .......................................... 29 1.5 Gerenciando, Verificando e modificando um programa: ..................................... 30 1.5.1 Cross Reference (Referência cruzada): ........................................................ 30 1.5.2 Imprimindo a Lista cruzada:......................................................................... 31 1.5.3 Usando a função Search (Procura): .............................................................. 33 1.5.4 Corrigindo e reescrevendo o seu programa: ................................................. 34 1.5.5 Comparando blocos: ..................................................................................... 35 1.6 Carregando e testando o seu programa:................................................................ 36 1.6.1 Carregando um programa: ............................................................................ 36

Manual STEP 5 V6.6

3

1.6.2 Testando o programa: ................................................................................... 39 1.6.3 Ativando a função Block Status: .................................................................. 40 1.6.3.1 Corrigindo o programa: ............................................................................ 42 1.6.3.2 Verificando o valor de uma variável (Status variable):........................... 43 1.6.3.3 Forçamento das variáveis: ........................................................................ 45 1.7 Apêndice A:.......................................................................................................... 46

Manual STEP 5 V6.6

4

1

Exemplo prático de programação com STEP 5:

1.1

Introdução ao exemplo:

Este exemplo será usado para ajudá-lo a entender o modo de programação usando o STEP 5. O exemplo consiste em criar um programa para a automatização de uma lavagem de carro. Este exemplo irá mostrar como você deverá proceder para editar, documentar, testar e salvar o programa desenvolvido para em STEP 5. Este exemplo tem como principais objetivos: • Dar uma idéia da maneira de editar o programa. • Dar uma idéia da forma de planejar e implementar um projeto usando as ferramentas do STEP 5. O desenvolvimento do programa propriamente dita não fará parte deste exemplo, mas será descrito mais tarde em parágrafo específico. O programa completo consiste das seguintes partes: • Uma lista de símbolos para descrever os endereços absolutos. • Um bloco de função com 15 instruções montadas no formato de lista de instruções STL. • Um bloco de dados (Data Block) • Um bloco de organização OB1 para iniciar e controlar o ciclo de operação.

Manual STEP 5 V6.6

5

1.1.1 Breve descrição da estação de lavagem:
A figura abaixo ilustra uma estação de lavagem de carro:

O passo para a lavagem de um veículo segue os seguintes passos: 1. O carro se move para o local inicial da lavagem. 2. O carro é movimentado até a posição de lavagem. 3. A porta é fechada e a lavagem é iniciada. 4. Um banho de xampu é aplicado, o carro é molhado e esfregado com rolos de escova e então secado com jatos de ar quente. 5. Finalmente a porta é aberta e o carro é movido para fora. Algumas variáveis do processo poderão ser alteradas pelo operador da estação de lavagem. O controle deverá contar e armazenar o número de carros lavados.

Manual STEP 5 V6. este circuito é apresentado abaixo onde o controle é feito com um CLP do tipo 95U.1. e lâmpadas para simular os dispositivos de saída como motores e atuadores. .2 Diagrama elétrico do controle: Baseado na descrição acima você poderá descrever o circuito elétrico para implementação deste projeto.6 6 1. Você pode testar o seu programa montando chaves par simular os dispositivos de entrada como botões e sensores.

Para parametrizar um novo projeto você deverá usar a opção: “Project setting> Page 1”. Você poderá alterar os parâmetros posicionando o cursor na linha a ser alterada e pressionando a tecla F3=Select.S5D Symbols file: C: CARWASZ0.INI Os caracteres em negrito não podem ser modificados. Page 1 Um projeto novo aparece nomeado a primeira vez como: NONAMED. conforme a nomenclatura da Siemens. . 3. Para selecionar um projeto já existente você deverá selecionar: Load. isto é feito no menu Objeto>Project. 1. Gerenciar e testar o programa.2. neste exemplo os nomes poderão ser: Working directory: C:\S5_DATEN\EXAMPLE Program file: C: CARWASST.Manual STEP 5 V6. Especifique o diretório onde o seu programa deverá ser armazenado e nomeie os arquivos da forma que melhor lhe convier.2 Criando um programa em STEP 5 para controle estação de lavagem: Você deverá chamar o programa para controle da estação de projeto.1 Parametrizando o projeto: Você deverá começar parametrizando os arquivos necessários para o armazenamento do seu projeto. Você completa a edição com a tecla RETURN. 2. pois são fixados pelo programa STEP5. 1.6 7 1. Para criar um programa você deverá seguir os seguintes passos: • • • Criar e Parametrizar o projeto. Editar o programa.

mas não deve.2.3 Selecionando a forma de representação dos operandos: Selecione sim para a oopção símbolos “symbol=yes” e comentário “comment=yes” O parâmetro “display” passará automaticamente “Sym”. Primeiro pressione a tecla F3 duas vezes na caixa de diálogo. Para confirmar a seleção pressione a tecla RETURN (atenção: é a tecla RETURN e não a tecla Enter no teclado numérico!) . . 1.6 8 4. 1.INI.2.. monitorização. Confirme com a tecla OK e será selecionado o diretório de trabalho C:\S5_DATEN\EXAMPLE Pressione a tecla OK novamente para voltar para a página 1. o modo “on line” você deverá selecionar quando as funções necessitem do CLP conectado. Obs: Para selecionar use o mouse se você estiver trabalhando no windows ou use a tecla TAB para trocar de janela e as teclas “seta para cima” ou “seta para baixo” para trocar a opção dentro da janela.2.DR.Pressione a tecla F4 para mudar para mudar para a página 2: Page 2.4 Nomeando o arquivo de impressão “Printer file”: Escreva o nome do seu projeto “CARWAS” sobre o arquivo .2 Selecionando o modo trabalho” MODE”: O modo “off line” é usado para editar o programa sem o CLP.INI” é atualizado automaticamente.LS.. 5. somente no computador. Selecione o subdiretório EXEMPLE. tais como: Transferência e carga do programa. Complete o nome dos outros arquivos.. Você pode. alterar o programa “on line”.Manual STEP 5 V6. Para selecionar o diretório de trabalho: Woking dir:. se você esquecer de salvar no seu programa você poderá ficar com um arquivo desatualizado no computador! Para alterar a opção você deverá pressionar a tecla F3=Select.. as alterações feitas neste modo só atualizam o CLP. O nome do arquivo de documentação “ . 1.

. caso este já existir selecione e pressione a tecla OK você poderá ver a mensagem “Destinatin file already FD. simplesmente desconsidere clicando OK ou RETURN. Para retornar ao menu principal digite F8=RETURN. Se alguma mensagem referente a inexistência de arquivos em discos que não estão sendo usados aparecer.6 Selecione o número de caracteres do comentário e símbolos: O padrão para o número de caracteres para a descrição simbólica dos endereços absolutos é 8.2. Uma caixa de seleção será aberta onde você poderá escrever o nome “CARWAS” no campo file name:. já que este será o modo de representação a ser usado neste exemplo.7 Salvando as seleções: Para salvar a parametrização feita anteriormente você deverá pressionar a tecla F8 “RETURN” a fim de retornar ao menu principal. Outro modo de representação bastante usado é a lógica de relê “LADDER”.6 9 1. e para o comentário é reservado 40 caracteres. overwrite” O STEP 5 irá salvar o seu projeto no arquivo CARWASPJ.2.5 Selecionando o modo representação: Selecione a lista de instruções “STL” (lista de instruções) pressionando a tecla F3. no entanto recomendamos o modo STL uma vez que o programa foi escrito em DOS com recursos gráficos limitados.” no menu “Object”. No menu principal selecione a opção “Project. 1. Uma outra forma de salvar o programa diretamente da página 2 usando a tecla F5 para salvar como “save as” ou F6 para salvar “Save”.Manual STEP 5 V6. mas você poderá altera-los se quiser. 1. se o nome não existir a mensagem não será apresentada.. Estas alterações deverão ser finalizadas com a tecla RETURN.INI..2. Save as.

saídas.6 10 1. você poderá editar o programa de controle programando a lógica.3. Exemplo: “OPEN DOOR” (Abrir a porta) é o endereço simbólico usado para descrever o endereço absoluto da saída Q32. contadores.SEQ. Os endereços simbólicos ficarão armazenados no arquivo: C:CARWASZ0. tais com: entradas. Acompanhando o trabalho para a elaboração destas três etapas dará a você a experiência necessária para iniciar a trabalhar com o editor do STEP 5.1 Criando uma lista de endereços simbólicos: Endereços simbólicos são nomes que você atribui aos endereços absolutos presentes no seu programa. temporizadores. Iisto tornará o seu programa mais legível. banco de dados etc. Para tornar o programa mais inteligível você deverá gerar uma lista de endereços simbólicos para as entradas e saídas conforme a sua função dentro da lógica do programa. Você deverá desenvolver os seguintes passos para a implementação do programa. • Criação de um banco de dados para armazenar os parâmetros de tempo e contagem.Manual STEP 5 V6. . 1. • Criação de blocos de funções com uma lista de instruções para o controle do processo. e até mesmo lhe ajudará a continuar a edição de um programa antigo.2. assim quando uma outra pessoa for ler o seu programa ele terá melhores condições de entende-lo. • Criação de uma lista de endereços simbólicos. contadores e temporizadores necessários para a automatização da estação de lavagem. A intenção deste exemplo é mostrar os passos para organizar um programa sem entrar nos detalhes da lógica. flags. Isto é fundamental para um trabalho de manutenção. blocos de funções.3 Criando o programa: Uma vez nomeado e parametrizado o projeto.

2. e as colunas “Operand”.. 5.. Você vai digitar os símbolos em cada linha conforme o exemplo abaixo para a entrada I32. Para editar a tabela de símbolos siga os passos abaixo: 1. 4.0 baseado no diagrama elétrico.Para alterar o campo “Operand” você deverá digitar o endereço I32. Isto irá encerrar o processo. Digite “Keyswitch carwash on” e pressione a tecla de RETURN para finalizar a edição e passar para o campo seguinte ou a tecla TAB para voltar ao início do campo.Z*. para isto siga os passos a seguir: Operand Symbol Comment I 32. . quando o número de caracteres chegar a 8 o cursor saltará automaticamente saltará para o próximo campo. 6.INI. Você poderá ver uma tela com o cabeçalho com o título do seu projeto CARWASZO.6 11 1. Para editar a lista de símbolos você deverá entrar no editor de símbolos usando o caminho: Editor > assignment list ou pressione a tecla F7. Os endereços simbólicos serão armazenados no PC (PG) no arquivo tipo .SEQ.1 Editando a lista de símbolos: A lista de símbolos será editada na forma de uma tabela chamada: Tabela de símbolos.0 MAINSWIT Keyswitch “carwash on” Que é a chave usada para ligar a estação de lavagem! 3 .Manual STEP 5 V6.1. No campo “Symbol” digite “MAINSWIT”. Pressione a tecla F7=Enter. Na página 1 você já parametrizou o número de caracteres para estes campos.3.0 no modo “Insert” e pressionar o botão “SHIFT+curso para direita” ou TAB a fim de deslocar o cursor para o próximo campo. “Symbol” e “Comment”. Complete a lista com o restante dos endereços conforme a lista dada a seguir..

por exemplo . também não é possível usar os caracteres típicos do português como “ç”. x errors found”. se houver algum erro a linha incorreta será mostrada no topo da página. Após o processamento o programa mostrará a seguinte mensagem: ”n lines processed. no errors found” ou Se algum erro ocorrer a mensagem: ”error in line n” . .6 12 Lista de símbolos do exemplo: Note que não é possível colocar acento. “key not found” ou ”n lines processed. Ao pressionar a tecla F7=enter a linha do erro aparecerá na tela para correção. Se a sua edição terminou sem erros você já poderá ver a tabela de símbolos e poderá usar estes símbolos na edição do seu programa.Manual STEP 5 V6.

O banco de dados completo é apresentado no Apêndice A. ou tecle F2.3. para isto você deverá digitar o tipo e nome do seu banco de dados na caixa de diálogo. no caso deste exemplo digite: DB5.2 Editando o banco de dados: 1.6 13 1. . 3. Pressione a tecla “OK” e “Continue” o programa retornará para a menu principal. 2. Você poderá ler os erros diretamente na tela ou imprimi-lo.2) 1. neste caso nome deverá ser:DB5 e o caminho: C:CARWASST. Faça as correções necessárias no editor de símbolos e volte a editar os símbolos novamente (1.2 Imprimindo ou mostrando os erros: Se algum erro ocorrer você poderá mostrá-lo imprimi-lo seguindo as instruções abaixo: 1.1.3.Entrando no editor do banco de dados: Para editar o banco de dados você deverá selecionar o seguinte caminho: Editor > Data block > in the program file. 4.3.S5D. Confirme pressionando a tecla “OK”. 2. O editor deverá indicar o número zero para o primeiro na janela de edição aberta mais abaixo. Conferindo os dados do cabeçalho: Você deverá observar ao final do processo de nomeação do bloco de dados se o cabeçalho mostra o nome e o caminho correto do seu bloco de dados. Selecione o caminho: Management> assigment lists > Output error list. O primeiro passo consiste em nomear o banco de dados.Manual STEP 5 V6.

6. • Inserindo uma linha inteira: Posicione o cursor sobre a marca de formatação da linha e selecione a opção “Expand DF”. a menos que você pressione a tecla “Insert”.Manual STEP 5 V6. se o formato for válido o cursor saltará pára o próximo campo. • Inserindo um caractere: Posicione o cursor no caractere sobre o qual você quer inserir o novo caractere (o novo caractere será inserido sobre o caractere atualmente selecionado) digite o novo caractere.Entrando com o restante dos dados: Digite da mesma forma o restante dos dados conforme descrito no Apêndice A. neste caso (KH). . Entrando com o formato: Para entrar com um dado novo você deverá primeiramente especificar o tipo de dado a ser usado.6 14 3. 4. Se você entrou com um dado inválido será mostrada a mensagem: “Input illegal”. você deverá recuar para a esquerda o cursor e alterar o tipo de dado. Se o valor não for aceitável o cursor não se moverá. Entrando com o valor do dado: No segundo campo você deverá entrar com o valor do dado especificado no primeiro campo guardando a respectiva faixa de valores. Se tudo correr sem falhas o cursor será posicionado na próxima linha indicando o mesmo tipo de dado. Corrigindo entrada de dados: • Apagando um caractere: Posicione o cursor sobre o caractere e pressione a tecla DEL. • Apagando uma linha inteira: Posicione o cursor na marca de formatação da linha e pressione a tecla “DEL”. se você desejar altera o tipo de dado.

O editor estrará no o modo de inserção. mova o cursor ao "c" de controller e pressione F2 = Delete novamente. 9. Entre com o comentário descrito no Apêndice A completando cada linha com a tecla “Insert”. A descrição das teclas de software muda a tecla F1. 10.” para identificar o bloco (ex. Digitando os comentários do dado (DW): Você poderá editar ou corrigir o texto de comentário de um dado do tipo Word usando letras maiúsculas ou minúsculas até 32 caracteres. você deve especificar um número de livraria “LIB No. O texto é inserido neste ponto. Toda a palavra que você inseriu é apagada de uma só vez!. Saía do campo com a tecla Insert ou a tecla de RETURN. 10. Você retorna ao modo de correção usando a tecla F1 = Overwrite. Pressione a tecla “Insert” para retornar a área DW do editor do banco de dados. o cursor salta para o campo de LIB=. Posicione o cursor no "c" de controlador na segunda linha e pressione F1 = Insert. o modo de inserção é exibido e nova inserção pode ser feita.Manual STEP 5 V6. por exemplo. Você poderá inserir ou apagar linhas de comentários usando as teclas de função F1= Expand DC e F2=delete DC.. neste exemplo "2". Digite "Simatic". Entrando o título no banco de dados: Você pode entrar o título “Carwash: counters/timers” Pressione a tecle SHIFT F6. . Posicione o cursor no campo de comentário com “SHIFT + tecla seta direita”. Pressione “F2 = Lib no”. versão do banco de dados). Encerrando o comentário: Complete a inserção com tecla F8= Return e “Insert” ou “Insert” duas vezes. Agora posicione o cursor no "S" de Simatic e pressione F2 = Delete. 8. Entrando com o comentário do banco de dados: Você pode chamar editor do comentário pressionando a tecla SHIFT F7= Comment. 11. Você pode usar as teclas “Insert/delete” para inserir e apagar caracteres no campo de dados. passa para “Overwrite. digite o número de LIB. Você poderá movimentar o cursor para a próxima linha usando a tecla seta para baixo ou para cima.6 15 7. Entrando com o número da livraria LIB No: Como posso final para a edição do banco de dados. Editando correções no comentário do banco de dados: Para você experimentar como o "insert/delete" funciona no editor.

confirme “yes”. Completando a seção de edição do banco de dados: Complete a edição pressionando a tecla “Insert”. overwrite?” aparecer. Suas edições ou modificações ficarão salvas (em alguns casos você tem que confirmar duas vezes). Se a mensagem “DBn Already in file. .Manual STEP 5 V6.6 16 12.

5. Se o bloco já foi criado você deerá entrar no modo de edição digitando F6=Edit. Marque as opções “Confirm before overwriting” e “Update seq. 3. não é este o caso. Digite CARWAS e pressione a tecla Return novamente. Aqui você deverá entrar com o tipo e o número do bloco que você quer criar no campo disponível na caixa de tarefa.3 Editando o bloco de função FB: 1. Source file” com yes e clique OK novamente. 7. estas instruções são detalhadas em capítulo separado.S5D) e o comprimento do bloco (LEN=0).3. 2. . estes parâmetros deverão ser preenchidos pela instrução de chamada do bloco.” que somente tem função para aqueles blocos com parâmetros d entrada.Manual STEP 5 V6. Entre o tipo de bloco e dê um número que ainda não esteja sendo usado no programa.Você pode chamar a função para edição de um bloco de função a partir do menu “Editor> STEP5 block>in the program file 1”. A tela de edição do bloco de função será aberta..3. O cursor sai posicionado no campo “Name” com 8 caracteres disponíveis para edição. 6.6 17 1. no caso do nosso exemplo entre como tipo FB 5 e complete a sua entrada com a tecla “OK”. 1. Digite um bloco possível (depende do CLP) . O cursor irá saltar para o campo “Decl:. ao selecionar esta opção uma caixa de diálogo será aberta.1 Editando o nome do bloco de função: O cabeçalho do programa contém o nome FB5 e o caminho (C:CARWASST.. Pressione a tecla F3 “select” para entrar no modo de seleção. Editando as instruções no bloco de função: Após preencher o cabeçalho o cursor será posicionada na primeira linha para edição da seqüência de instruções do seu programa. neste modo será mostrado os blocos possíveis.3. 4.

Pressione a tecla TAB para deslocar para a direita ou SHIFT+TAB deslocar para esquerda.3. após isto o cursor deverá ser posicionado no segmento seguinte. 1.”. ou digite *** no último campo.3.Manual STEP 5 V6. você poderá inserir uma linha de edição extra usando a tecla F7=Vert exp. Para sair deste campo você deverá pressionar a tecla RETURN ou “Insert.2 Editando o comentário: 8. No nosso exemplo você deverá digitar como primeira instrução 1: C DB 5. 1. Você também poderá passar para o campo de comentário usando a tecla “Shift+F7=Extras” novas opções irão surgir você poderá mudar o campo usando as teclas F3=Fld left e F4=Fld right. Para apagar o campo de edição use a tecla F3=Delete na tela de edição. no entanto os símbolos já declarados em letras maiúsculas podem ser digitados com letras maiúsculas.3 Editando o título do segmento 1 10. 9. Editando o título do segmento: O segmento editado no parágrafo anterior não tinha título algum. para editar o título pressione “F6=Seg com” e “SHIFT F6= Title” digite: “Prepare program execution”.3. Editando a segunda linha do programa: No segundo segmento digite a instrução e os comentários pertinentes (conforme descrito no Apêndice A). Uma vez na última posição de edição para passar para o campo seguinte pressione a tecla SETA À DIREITA ou SETA ESQUERDA.3. Você deverá editar as instruções sem necessidade de pressionar a tecla de espaço.3. Após digitar a instrução você poderá ir para o campo de comentário deslocando o cursor para o último campo. Terminando o segmento Uma vez preenchido o primeiro segmento para ir ao segundo segmento você deverá pressionar a tecla “F6=Compl seg”. .6 18 1.3. 12. Digite a chamada do DB5 (contadores e temporizadores) “Call DB5(timer/counter values)” e então pressione a tecla RETURN para ir para a próxima linha de instrução.4 Terminando o segmento 1: 11.

1 no lugar do símbolo –POSPUL com isto o programa irá liberar a edição para você. uma diferença: As funções apagar “delete” e inserir “insert” afeta a linha toda.3. Para editar um novo símbolo. O programa irá abrir uma caixa de mensagem “Enter changed segment? “ selecione a opção “Yes” você deverá trocar a opção da edição para “Output” isto habilitará a edição do comentário.6 19 1. A lista de símbolos será aberta e seqüência apresentada é aquela gravada no arquivo *ZO.5 Corrigindo e editando símbolos: 13. Complete a correção pressionando F8=Return. a primeira vez que você digitar este símbolo o programa exibirá a mensagem: “No assignment. Corrigindo e editando símbolos: No nosso exemplo na quarta linha e na sexta linha do segmento 2 o símbolo – POSPUL. no entanto. 14. Quando você retornar ao segmento 2 complete. complete a linha com o símbolo “POSPUL” e o comentário “pulse flag for 10. (sybol not defined)” você deverá então completar a edição deste símbolo. Para apagar a linha posicione o cursor bem no início da linha.Manual STEP 5 V6.3.0 (only 1 cycle)”.3. 15.conforme a descrição abaixo: 1. Pressione F2=Edit symb e depois de editar o símbolo e o comentário pressione F2= insert. Na opção “Output” posicione o cursor na linha quatro e (onde você quer inserir o comentário) e pressione a tecla F1-Disp symb para chamar o editor de símbolo.INI e o cursor aparecerá sobre a linha descrita com F10. primeiro você deverá escrever F10. existe. . Ao final da edição você deverá digitar a tecla “Insert”.1.3.6 Corrigindo a linha de instrução: Você pode corrigir a linha de instrução da mesma forma que você fez com o bloco de dados.

Digite os textos para os segmentos 1 e 2. 17. Depois. Para escrever o comantário do segmento proceda como descrito a seguir: Pressione a tecla Shift F6=Seg com e shift F7=Comment ou pressione COM duas vezes.8 Deslocando entre os segmentos: Para deslocar entre os segmentos ou pressione F5=Seg fct e pressione a tecla F1=-1 ou F2=+1 para ir para o seguinte anterior ou seguinte respectivamente ou use as teclas “Page Up” e “Pag Down”.Manual STEP 5 V6.3.9 Inserindo um novo segmento: Para inserir um novo segmento use a tecla “F5=Seg fct” e depois “F5=Insert” novamente. 18.3. o cursor será posicionado na primeira linha do novo segmento vazio. 20.3. Você pulou as instruções do segmento 3 de propósito. pressione a tecla F1=New. completando cada linha com a tecla Return. Editando os segmentos 4 e 5: Uma vez que você tenha pressionado a tecla segment end. Uma característica especial do segmento 4 é a instrução de salto para a segunda instrução.3. Sob o caractere $ com o número do segmento você poderá escrever o comentário do seu segmento conforme descrito no Apêndice A.6 20 1. Pressione a teclas Page Up duas vezes e digite o rótulo do salto.3. 1.3. você irá inserir mais tarde este segmento.7 Escrevendo o comentário do segmento: 16. Edite o novo segmento e pressione a tecla Insert e confirme. digite neste ponto de instrução as instruções descritas no segmento 4 e 5. . o cursor é posicionado na primeira instrução do segmento 3. antes dos dois pontos. O rótulo do destino do salto (label) descrito como CONT deve ser posicionado no início da linha do destino do salto. Você retorna ao bloco de edição com a tecla F8=Return. 1.

sobre as opções que aparecem selecione “Word-oriented” e o tipo de impressão “standard”.Manual STEP 5 V6. Sua cópia impressa do programa CARWASST. 1. escreva no seu lugar CARWASDR. Inicie a impressão selecionando a tecla “OK” A cópia impressa contém os seguintes elementos para cada segmento: -o título do segmento e o número de segmento -as instruções com comentários de linha -os nomes dos operando contidos na lista de símbolos.4 Documentando o programa: Você poderá imprimir a seção do seu programa FB5. 2.6 21 1. O arquivo de impressão tem o nome padrão (default) NONAMEDR.INI definido na página 2 (Pag 2). Mude para o menu Documentation >standard output>STEP 5 blocks: Você poderá ver uma caixa de diálogo e você deverá entrar com os blocos e os segmentos. o banco de dados e a lista de símbolos.3.INI.S5D deverá corresponder ao programa mostrado no Apêndice A. . Primeiro entre com “FB5” especificando o bloco.

Para transferir o programa você deverá selecionar o menu Object>DOS file> Copy como descrito abaixo. overwrite?”. você poderá transferir os arquivos um por um usando a opção “single”. cópia apagamento de diretórios usando as funções do DOS no STEP 5. Selecione o menu “Copy” da opção “DOS file”. Por exemplo: Source drice: C:\S5_DATEN\DEFAULT (Arquivo fonte) Destination drive: C:\S5_DATEN\EXAMPLE. Uma tela de diálogo será aberta e você deverá selecionar o destino dos arquivos do programa. blocos e arquivos: Nós interrompemos a edição do programa da lavagem de carros carwash no quinto segmento e iremos adicionar agora as seções deixadas para trás no programa .6 22 1. Marque “all” na janela de modo de cópia “copy mode” e selecione “Yes” na opção de confirmação de sobre escrever “Confirm before overwriting”. Primeiro observe se o diretório está selecionado corretamente.4 Transferindo os segmentos. 5. Confirme a seleção selecionando “yes” e saia da opção usando a tecla ESC=Exit.Manual STEP 5 V6. no diretório \ S5_DATEN\DEFAULT. Se você tiver selecionado “Confirm before overwriting”.. Acione a transferência clicando em “transfer” ou pressione a tecla “RETURN”. use as funções do DOS como segue: 1. O programa STEP 5 mostra a opção que indica que o arquivo já existe e que você deve confirmar que ele pode ser sobre escrito.. 4. . (Arquivo destino) Você deverá copiar o arquivo PROEXA*. Para transferir o arquivo. 2. Isto irá ajudá-lo a familiarizar-se com a transferência.”file already exist. O programa completo está localizado com o nome PROEXA.* seguindo os seguintes passos: 3.

6 23 1. Transferir os blocos de organização. 3. A partir destas opções o arquivo do projeto CARWAS será arquivado como “PROEXA”. . Você pode substituir o FB5 incompleto pelo FB10 completo e alterar o nome do bloco de função para FB5. Agora que os dois programas já estão salvos em um mesmo diretório você pode alterar ou inserir as partes que estão faltando em seu programa. Você pode transferir segmentos que estão faltando.1 Verificando arquivos contidos em um diretório: Você pode verificar os arquivos contidos em um diretório seguindo o procedimento abaixo: Selecione o menu DOS>Directory observe todos os arquivos contidos no diretório PROEXA que devem ser copiados como se segue: Selecione o diretório: C:\S5_DATEN\EXAMPLE\ sobre “Drive\dir”.Manual STEP 5 V6.4. Alteando arquivos:: 1. 2.1. uma vez que os blocos de dados são semelhantes.

2 Como transferir os segmentos: Segmentos somente podem ser transferidos entre blocos do mesmo programa. 3. 5. overwrite?” não aparece a primeira vez que você transfere o programa..S5D\ ->\S5_DATEN\EXAMPLE” Quando você pressiona F3. 4.010 Already in file. Para transferir o bloco você deverá selecionar Objext>Blocks>Trasfer>File. Na lista que aparece sob “selection” e “block liste” selecione o bloco que você quer transferir FB10 neste exemplo.6 24 1.. confirme pressionando a tecla “OK” e saia da tarefa pressionando a tecla “ESC” ..4.1. Em seguida será mostrada a mensagem “Transfer comments as well?”. Responda “yes”. A mensagem “block(s) transferred” será apresentada. e Como destino “as destination C:\CARWASST. overwrite?” e “FBDO. Nota: A mensagem “FC10 Already in file. Confirme a mensagem com “yes”.Manual STEP 5 V6.. Depois pressione a tecla transfer ou clique na tecla RETUR o STEP 5 irá mostrar a mensagem “write preheader to FD?”. o STEP 5 irá abrir uma janela de diálogo complete como descrito abaixo: 1. isto significa que o FB10 deve primeiro ser transferido do programa PROEXST.S5D para o nosso programa CARWAS. Como origem especifique “as sourrce: C:\PROEXST. o STEP 5 mostra a localização no diretório de trabalho: 2.File.S5D ->\S5_DATEN\EXEMPLE\ “.

2.. é exibido na tela.4. Mova o cursor para segmentar 6 usando a tecla “Page Up” do teclado ou a tecla “+ “. 4.3 Verificando se O bloco transferido está no programa: 1.Manual STEP 5 V6. 1. você também pode imprimir esta lista ou transferi-los para outro arquivo. . Selecione o caminho abaixo “Object>Blocks>Directrory>in the program file. Entre no editor de bloco e pressione a tecla FB10 na caixa de trabalho. Depois pressione “output” ou pressione a tecla RETURN ou tecla “Insert” Uma lista dos blocos contidos no arquivo de programa CARWAS..1. Para transferir este buffer para FB5 5. Pressione as teclas “F5 = Seg fct” e depois “F4 = File”.4 Transferindo segmentos: 1.” no menu “Object” ou pressione a tecla F3=DIR na caixa de seleção (Directory file: settings).. Marcando a seleção correspondente. 3. Clique “All blocks” se já não estiver selecionado. 2.1. Selecione FB5 no editor de bloco e mova o cursor para segmento 5 no final do programa.4. Uma cópia de segmento 6 está carregada no buffer de sistema.. Complete a operação com a tecla F8 = Return e ESC = Exit você pode encerrar FB10 agora.6 25 1.

INI na opção “Symbol file”.. Desde o editor de bloco você pode acessar a lista de símbolos do programa atual. Você poderá verificar isto chamando o bloco FB5 novamente no editor de blocos. proceda como descrito abaixo: Vá para Página 1 da parametrização de projeto e entre PROEXAZ0. nem todos o operando nos segmentos novos estão escritos com os seus símbolos. é este método serve. Para transferir seções extensas do programa. porém. Então pressione F2 = Buffer para juntar o segmento 6 ao programa CARWAS. os operandos nos segmentos 6 e 7 são também exibido em forma simbólica. Com este procedimento. Pressione F5 = Seg Fct e F6 = Append (juncar unir). Você poderá encerrar então a edição. 7. Como você pode ver. Para corrigir esta situação.Manual STEP 5 V6. é muito demorado. Responda “Yes”.. . salve tudo pressionando a tecla F6. Isto é devido ao novo programa estar com a lista de símbolos incompleta.. e então. Repita o procedimento de transferência para segmente 7. você pode inserir ou retirar segmentos de outros blocos no arquivo de programa.6 26 6. Complete a operação pressionando a tecla F8 = Return e F7 =OK.

.6 27 1.005.. a mensagem de sistema "Delete comments as well? Será mostrada”.Manual STEP 5 V6. FC5 e FBDO. renomeie FB10 como FB 5. você deverá proceder como descrito abaixo: • Primeiro FB5 deve ser apagado inclusive os comentários.1. Confirme esta mensagem com “Yes” e a mensagem "block(s) deleted!" com OK. selecione "Object>Blocks>Delete" no menu Objet. 2. pelo bloco FB10 completamente.. Para apagar FB5. • 1. assim como.4. Entre com "FB5" na caixa de trabalho. • E então. Depois que você apertar Delete. Se você deve conferir o diretório do bloco para ter certeza que o bloco FB5 foi apagados.5 Transferindo e renomeando blocos: Para substituir o bloco FB5 no programa CARWAS.

4. "Obkect>Blocks>Transfer>File to File. . Quando você conferir o bloco diretório. Pressione a opção “Transfer” e confirme os mensagens de sistemas com “Yes”. 2." no menu Objeto e então ENTER.S5D e . você verá que há um FB5/FC5 novo junto com FB10/FC10.marque a opção "Copy block.6 Renomeando um bloco: 2 1.Manual STEP 5 V6.1..arquivo de destino “Dest”: C:CARWASST. com os operandos simbólico e todos os comentários.[ FB10 ] as [FB5 ]". No editor.. cheque se o FB5 novo está completo com 15 segmentos. Complete os campos com: .6 28 1. Para renomear FB10.

A operação de salto incondicional em OB 1 deve ser mudada agora para JU FB5 e as chamadas do banco de dados CDB 10 deve ser mudada para C DB 5 em FB 5...6 29 1.Marque todos os "OBs". exibirá os comentários "Transfer comments as well" (transferir os comentários também) o qual você deverá confirmar com OK e então "Blocks transferred" o qual você novamente confirme com “Yes”. o sistema. Quando você pressionar a tecla de transferência.. para isto siga o procedimento abaixo: 1.. supondo que o programa “CARWAS.1..” contém todos os blocos requeridos para o controlador. .7 Transferindo um bloco de organização (OB): Para completar o seu programa contendo FB5 e DB5 os blocos de organização que está faltando também devem ser transferidos..Manual STEP 5 V6. na caixa de trabalho. 2. Para transferir os OBs selecione "Object>Blocks> Transfer "no menu “Objet” e entre no arquivo de fonte com PROEXA. e no destino com o arquivo CARWAS.4.

Você pode experimentar agora algumas destas funções no programa CARWASH.Manual STEP 5 V6.INI). Chame o FB 5 no bloco o editor e posicione o cursor em segmento 2 na instrução “STARTUP”. e ainda renomear operandos no seu programa. 2. Pressione F2 = Reference seguido de F5 = Orig blkde Orig.5. Esta tabela contém todos os pontos no programa ao qual o operando pertinente estão endereçados. 6.7.Para Voltar a FB5 pressione a tecla F2 para voltar novamente para o OB 20.” 4. Você pode gerar este arquivo através do caminho "Management> Generate XRF" no menu principal. O bloco de organização OB 20 é exibido. O cursor é posicionado no primeiro bloco referência “OB20 :1/AN. 3. 1. No arquivo de XRF você deverá selecionar Página 1 das "settings".5 Gerenciando. documentar. que é o operando que a referências cruzada irá processar. O cursor ficará piscando agora debaixo de F 10. Você pode exibir as referências cruzadas agora para cada operando contido no editor de bloco seguindo a descrição a seguir: 1. . Verificando e modificando um programa: Além das funções do editor o STEP 5 possui umas séries de funções com as quais você pode conferir. Pressione F2 = Reference e mais uma vez F2 = Disp XRF. Confirme com a tecla “Insert” RETURN. Uma tabela de referências cruzada para o operando selecionado será exibida como na figura abaixo.1 Cross Reference (Referência cruzada): O STEP 5 armazena referências cruzadas para declarações que contêm o mesmo operando (até mesmo em outros blocos) no arquivo de XRF (* XR. Aperte F2 = Jump.6 30 1. Se necessário você pode mudar ao modo de edição e fazer modificações. Para retornar a tabela: Posicione o cursor no endereço que deseja pesquisar e pressione F2 duas vezes e a tecla de RETURN. 5.

F.2 Imprimindo a Lista cruzada: O menu de "documentation" lhe proporciona umas séries de listas dentro do qual as referências cruzadas ou são compiladas para um único operando (neste caso F 10.5. .7) ou para um grupo de operando (por exemplo eu. Os asteriscos ao lado de números de segmento indicam que o operando ocorre em uma instrução.7) em todos os blocos.Manual STEP 5 V6. SEG 2. Figure abaixo mostra a cópia impressa das referências cruzadas para o "outputs" em FB5 e os "conters" e a variável inicial (F 10. Você pode selecionar a lista você quiser marcando as opções na caixa trabalho “Output XRF list”. O segmento 2 no FB10 é então mostrado: 1.6 31 Você pode repetir o salto a outro bloco de referência posicionando o cursor em FB10:2/AN na Figura abaixo e pressione F2 = Jump. As referências cruzadas podem ser restringidas a um bloco particular ou estendido a fim de cobrir todos os blocos no programa. Q. contadores).

6 32 .Manual STEP 5 V6.

saída ou variável usada no seu programa.Manual STEP 5 V6. você pode executar uma busca através da referência cruzada. neste caso I 32. A primeira ocorrência deste operando é exibida no segmento 3 instrução 1.5 ou . etc. para isto proceda como descrito abaixo: O resultado da busca lhe dará informações sobre a localização no seu programa do endereço de entrada. Chame FB5 no editor de bloco e pressione a tecla F3 = Search. . O segmente 3 é exibido com o cursor na linha 9.3 Usando a função Search (Procura): Durante a sessão de edição. Esta função é muito útil quando você estiver depurando um programa feito por outra pessoa ou ainda quando você pensar em usar uma variável e quiser saber se esta variável já está sendo usada no seu programa.5. 1. etc. 2.6 33 1. Pressione F3 = Search novamente e F3 = Continue O segmente 4 é exibido com o cursor na linha 6. Aperte F2 (no seg1). Pressione F3 = Search novamente e F3 = Continue. 4.C-BACK. 3. Como a tecla de procura (KEY:) especifique um operando.

1.7 e pressione F2 (No seg 1).5 o endereço do operando novo: Q 1.7. Usando a função "rewiring" você pode renomear estes operandos.. vamos mostrar como você deve proceder para renomear um dos operando de saída em FB10.Manual STEP 5 V6. 3.7 foi alterado três vezes no lugar de -DRY.4 Corrigindo e reescrevendo o seu programa: 2ree Às vezes é necessário nomear um endereço novo para um operando já existente dentro do programa. por exemplo. Digite no operando velho: Q 33. o sinal para abrir e fechar as válvulas de ar para secar o carro agora é produzido por Q 1. Uma tabela é apresentada na qual você entra com o operando velho em representação absoluta no lado esquerdo (old operand) e o operando novo no lado à direita (new operand).Chame o bloco FB10 no editor e pressione F3 = Search.5.6 34 1. . . operando Q 1. Segmente 12. 4. renomear endereços de I/O diferentes. Chame a função “Management>Rewire>Manual” Confira o nome dos arquivos: (Program file C:CARWASST:S5D to Program file C:CARWASST:S5D) 2.7. Para ilustrar como esta função trabalha. Cheque se a modificação foi feita como segue: 5. Entre em FB5 no caixa de trabalho e confirme com OK. por exemplo.Digite no campo “Search” (procura) Q 1. . Complete sua entrada com a tecla “Insert” e confirme as mensagens de sistema com “Yes”.

Manual STEP 5 V6. Na caixa de trabalho. que você já modificou com a função “rewiring”.6 35 1. A caixa de trabalho STEP 5 exibirá todas as comparações como mostrado em Figura abaixo.S5D abaixo de " Compare with program file" e FB5 abaixo da lista de blocos.. Blocos não existentes são indicados pela mensagem 020D. Para isto proceda como indicado abaixo: 1.. Após fazer isto. entre com C:PROEXAST. quando.5 Comparando blocos: STEP 5 provê um função comparação que você pode usar para comparar blocos do mesmo tipo e mesmo número no PLC e no PC (PG). com o bloco de função FB original em PROEXA.. . As operações de STEP 5 discrepantes são listadas com os endereços em código de MC5. repita o bloco comparação marcando "todos os blocos". você poderá conferir o segmento 12. No menu de Project (Object).. então. Experimente esta função comparando o conteúdo do bloco de função FB5 em CARWAS. 3. chame os " Blocks>Compare> File . pressione a tecla “OK” ao final da pesquisa será apresentado uma tela onde você poderá visualizar o resultado da pesquisa." 2.5..file. Se não tiver nenhum PLC conectado você poderá comparar blocos entre arquivos de programas diferentes. 2 . Você também pode reconhecer que diferentes blocos de funções FBs são chamados em OB1.

2. Uma lista de todos os blocos carregados no PLC é gerada. . Transfer” no menu de objeto. Confira a carga gerando uma lista dos blocos no PLC.] " usando F3 = select e F6 = Save. Depois de pressionar “Transfer” (transferência). entre em C:CARWASST. 4. 1.6. Comentários e blocos que não tiveram transferido os seus cabeçalhos não são mostrados também.Manual STEP 5 V6.S5D como a fonte na caixa de trabalho e debaixo selecine “FB5” na lista de bloco “DB5” e finalmente “all OBs. Selecione “Blocks. 5. Para fazer isto.6 36 1.” (todos os blocos operacionais).1 Carregando um programa: Complete a carga do programa usando a função “Blocks> Transfer” no menu de objeto. Nota: Também são mostrados os blocos de sistemas do PLC. Confirme isto com OK. A lista só contém as seções do programa requeridas pelo controlador programável. 3. os blocos pertinentes serão copiados para o PLC. Se já não esta selecionado. uma vez mais marque a opção “all blocks” na caixa de trabalho. 1.6 Carregando e testando o seu programa: Para testar o programa carwash você tem que conectar um S5-95 ao seu programador. Estabeleça a conexão permanente entre o PC (PG) e o PLC como segue: Na Página 2 do menu de parametrização "Object>Project>Settings>Page2". Mude o modo a "online[cycl.

7 Reset da CPU S5-115U: Eventualmente a CPU entra em stop. Uma forma de sair da situação de STOP consiste em ressetar a CPU. Significado dos LED’s: LED VERMELHO LED VERDE X X X X SIGNIFICADO CPU iniciando no modo COULD restart.6 37 1. O painel da CPU é mostrado abaixo: 1: Chave de seleção STOP/ RUN 2: LED de indicação modo RUN. uma seqüência de acionamento das chaves do painel da CPU deve ser executada para que esta saia do stop e reset a memória. RE reset da memória retentiva. 3: LED indicação CPU em STOP.como por exemplo um loop infinito. com isto toda a memória é apagada e você pode então carregar o programa corrigido. A CPU S5-115U ou CPU’s desta família apresenta uma maneira peculiar para esta operação de reset. Modo STOP Modo RUN Programa rodando . esta seqüência é mostrada abaixo. 4: Chave para seleção dos modos de restart: NR reset da memória não retentiva. normalmente isto acontece quando uma parte do programa apresenta problemas.Manual STEP 5 V6. OR reset geral 5: Ledo de indicação de erro 6: BASP desabilitação dos módulos de saída.

7. Toda a área de identificação de erro: Existem duas maneiras de ressetar a emória: • OFFLINE através das chaves na CPU. Enquanto você segura a chave em baixo na posição OR troque a chave (1) para a posição ST para RN duas vezes. RN->ST RE->OR SEGURE. Solte a chave de restart (4) para a posição RE. 1. . ST->RN RN->ST ST->RN OR->RE SOLTE.Manual STEP 5 V6.7. • Toda a memória de dados (flags. Ligue a chave de seleção do modo de operação (1) para ST (stop).. neste caso serão ressetados as seguintes áreas de memória: • Memória de programa do CLP. a chave normalmente volta para a posição RE). temporizadores e contadores).2 Procedimento para o RESET usando as chaves da CPU: Ligue a alimentação da CPU. • ONLINE através da função “DELETE” do programa S5.6 38 1. O LED STOP irá apagar momentaneamente.1 Procedimento para o RESET geral: Você deverá proceder a um reset geral antes de carregar um programa novo. Ligue a chave (4) de restart para a posição mais baixa OR e mantenha nesta posição ( A chave não fica sozinha nesta posição.

você pode usar oito chaves on/off conectadas as entras (I32. LAD etc. por exemplo. Dependendo do método escolhido para a representação do programa (STL.1).3 Testando o programa: 2 Você pode testar o seu programa agora. Na tela do PC (PG) irá ser apresentado um diagrama dinâmico mostrando as reações do PLC com respeito as entradas e saídas.. I32.0 e I 33. uma forma de obter esta configuração é usando o simulador da Siemens (número de pedido 6ES5788-8MK11). Você pode usar um simulador para modificar as entradas e observar as saídas..0. .6 39 1... o bloco de função FB5. selecionando a função " block status" ou " status variable". pode ser visto on-line segmento por segmento e instrução por instrução com isto você poderá verificar se o seu programa está rodando corretamente.7) e dois botões (I33.7.) você poderá acionar o teste d programa no PC (PG).Manual STEP 5 V6.

e a mensagem DIRIJA CARRO DENTRO é exibido. o processo também pára no ramo. 3.Manual STEP 5 V6.6 40 1.. 1. Mova os interruptores I32.6 para cima. Mova o ponto de parada para segmentar 6 e mova a chave da entrada I 32. 2. 5.4 acende. Debaixo da informação de cabeçalho. O contador de passo e ACCU 1 têm o valor 1. 2. A exibição do RLO.0 e I32. Na coluna 5 da tabela A-2 você pode ver quais entradas devem ser ligadas. Agora mova o ponto de parada para segmentar 5 no qual de acordo com Figura KEIN MERKER no Apêndice A que é onde o processamento do programa da lavagem de carro realmente começa. Depois de pressionar o botão I 33. O RLO=1 na linha 1 indica que todos o pré-requisitos foram satisfeitos para o início do processamento tais como posicionamento inicial da lavagem e o contador de passo (. No segmento 4. Selecione a opção "Block status" no menu de teste (test). No simulador. O segmente 1 aparecerá descrito no método "STL" de representação. a instrução.3 para cima para “car in position”. o resultado de operação de lógica (RLO ) serão exibidos e os estados de ACCU 1 e ACCU 2 (acumuladro 1 e acumulador 2). Comece o processamento da lavagem de carros (carwash) movendo para cima os interruptores descritos como I32. as entradas ligadas têm o estado 1.STEP). Mova o cursor para a linha seguinte a operação de salto pressionando o cursor para abaixo três vezes.4 Ativando a função Block Status: 1.5 e I32. Mova o cursor de interrupção para o segmento 3 pressionando = a barra de rolagem para cima duas vezes. 6. No PLC. O RLO (estado atual dos endereços) correspondente é exibido e ao lado direito do botão com a mensagem " Status processing active ". a situação é semelhante. As entradas na coluna “status” (estado atual) e "SAC" (endereço dos contadores) esta informação é irrelevante neste exemplo. Agora troque o PLC para o modo RUN. troque todos os interruptores para a posição desligada (= off) e selecione o seletor de modo no PLC para STOP. Selecione o bloco de função FB5 na caixa de trabalho. o led da saída Q32.1 (= ON). Estada etc. 3. 4. marque as opções com “yes” e pressione a tecla OK.7.0 (start) o processo de . desaparece e você pode ver que a instrução do ramo seguinte não é processado e a mensagem “Statement not processed” é apresentada.

6 41 lavagem é iniciado. 9.Manual STEP 5 V6.3 é iluminado). No segmento 11. indicando a posição inicial do programa carwash. 7. 8. No segmento 14. o contador de passo retorna ao vlor 1. você deve usar as informações provenientes do RLO (Resultado da operação lógica) e dos conteúdos dos acumuladores ACCUs para corrigir estes erros . . Isto significa que o programa exemplo rodou todas as etapas e cumprir todas as tarefas.4 = 0) e a porta é fechado (Q 32. O contador de passo troca para 3. O contador de passo (.7 = on.STEP) mudanças para 2. Se erros de lógica acontecerem. Você pode seguir o tempo secagem (DT = 45 s). Simule as partes restantes do processo de lavagem mudando as entradas de acordo com Tabela A-2 dependendo da posição do ponto de parada.5 = 1.Mova o ponto de parada para o segmento 7 e para simular a porta fechada desligue a chave da entrada I 32. Simule as partes restantes do processo no passo 8 e passo 9 como descrito acima. você pode ver como o tempo de distribuição de cera WT é decrementado até 0 a um intervalo de tempo de 1 segundo disparado pela condição iniciais tendo a secagem sendo gerada automaticamente pelo contador de passo (= 7).6 = off e ligue a chave da entradaI 32. "As partes do processo que aplicam xampu (apply shampoo )". seguindo o estado da entrada I 32. mova o ponto de parada para segmentar 12.. giro das escovas (rotate brushes) e avanço do carro (carriage forwards) são iniciados (variável = 1). A mensagem para o motorista é desligada (Q 32.

PLC .6 42 1. para um arquivo 3. 2. por exemplo. Você deve posicionar o cursor na instrução que você quer modificar. Para transferir o bloco modificado ao PC (PG). apagar instruções já existentes ou inserir novas instruções. Com os passos esboçados acima. Transfer. e então.7. você aprendeu a modificar o programa no PLC.4.1 Corrigindo o programa: Para corrigir de Pará o programa proceda como nenhum abaixo de exemplo: 1. Selecione a opção "Blocks. .file" (Tranferir blocos do PLC para o arquivo) no menu objeto (Object) e entre com FB5 na caixa de trabalho. Mude o modo de edição com F6. Para isto pressione a tecla “Insert”e responde a mensagem "Enter modified segment?" (Entre em segmento modificado? ) e a próxima mensagem com “Yes”.Manual STEP 5 V6.

5 e I32. 2. O programa do carwash vai para o estado pronto com Q 32. Usando a tabela verdade. 7.7. 5. O STEP 5 acrescenta automaticamente o formato às suas entradas.0 e I 32. pressione F2 = Store (Armazenar) e especifique o número do bloco de variáveis (neste caso VB 5). Troque a chave de modo do PLC para RUN e a chave liga desliga da entrada I32. Uma tabela vazia com as colunas " Operands: "(Operandos) e " Formats: " (Formatos) será mostrada na tela." (ON).6 para "ligado.4.6 43 1. . 4. Os valores atuais dos operando (inicialmente todos os 0) e as mensagens são acrescentados “PLC in CYCLE” e “Status processing active” serão adicionados a coluna “Signal states”. Mova as chaves das entradas I32. Entre todos os operando de saída inclusive os temporizadores e contadores no formato absoluto ou simbólico e finalize cada linha com a tecla de RETURN.2 Verificando o valor de uma variável (Status variable): 1. complete estas preparações por pressionar a tecla de Insert ou F6 = Activate (Ativar).Manual STEP 5 V6.4 = 1 e C 2 = 1. Selecione a opção “Status variables” no menu de teste (Tert). 3. Mova todas as chaves liga-desliga no simulador para a posição desligado (OFF) e o botão seletor de modo de trabalho no PLC para STOP. Desta forma a sua lista de operando ficará com os mesmos conteúdos mostrado no Figura abaixo. Teste o bloco de função usando a função de verificação do valor das variáveis (Status variable) como segue: 6.1 para "ligado" (ON). você pode conferir novamente a reação do controlador a certas combinações de valores das entradas.

9. .0=ON. depois é só apertar a tecla Insert para continuar o processamento. P Terminar a função de verificação do valor das variáveis. Simule o carro sendo dirigido dentro ligando as chaves das entradas I 32.6 = desligado) o display DIRIJA CARRO PARAFORA é exibido e no último passo (I32.Manual STEP 5 V6.6 = OFF e ligando a chave da entrada I32. A porta será fechada (Q 32.5. O sistema de movimentação das escovas será movimentado para frente com as escovas girando e o jato de xampu aberto.7 = desligado. Simule o estado "porta fechada" desligando a chave da entrada I32.3 = desligado) o estado inicial é restabelecido com o display mostrando a mensagem CARRO NA ENTRADA e o contador de passo=1. e para frente ligando e desligando as chaves I32.3 = 1). Continue simulando as entradas até que os dois temporizadores WT e Dtconcluam suas contagense o programa chegue no passo = 8. I32. 11.6 44 8. Pressionando a tecla ESC você pode interromper o estado que processamento e inserir operandos adicionais na a lista. No passo 9 (I32. o contador passo muda para o valor 2 e o contador C 20 assume o valor C20 = 1. Simule o movimento do carro para trás.7 = ON. O PC (PG) exibe os estados das variáveis conforme mostrados no Figura abaixo. O STEP 5 exibe o valor das variáveis e o ponto de parada selecionado.4 e I32. pressione ESC = Saída e você voltará ao menu com F8.3 = ON e iniciando o carwash I33. 10.

você pode exibir os valores correspondentes às saídas e contadores (exatamente como na função Status).Formats”.1 para "Ligado "(ON) e o PLC de STOP para RUN. O PC (PG) exibirá a coluna " Force process image “ (Força processo imagem). Complete a edição de cada linha com a tecla de Return e escreva sobre o formato padrão com "KM".”(Termino do "forçamento) irá aparecer na tela.4. Uma vez mais.0/32. a saída Q32.7.5 devem ser ligados e a mensagem “End of force fct.Manual STEP 5 V6. ativando os interruptores no simulador um depois o outro.4/32. No PLC. . Acrescente C 2/C 20 e T 20/T 22 à lista e então pressione F6 = Activate. Você também pode exibir os estados atuais com o PLC no o modo de RUN. Experimente isto como segue: Entre com o padrão de bit KM = 00110011 no QB 32 e pressione Insert. uma lista de operandos deve estar montada para a execução desta tarefa. Você pode alterar agora diretamente as saídas de QB 32/QB 33 com o teclado e pode conferir a resposta do programa. (Operando – Formatos).6 45 1. Pressione ESC = Saída e troque a chave I32. Selecine a opção “Force variables” (forçamento das variáveis) no o menu de teste e digita as entradas e saídas como operando do tipo Byte (IB e QB) na a tabela vazia “Operands . então. Sua tela se assemelhará à tela ilustrada no a figura abaixo.0/I 32.1 e Q32.3 Forçamento das variáveis: Com esta função você pode modificar o valor das variáveis (por exemplo I/Q/F) diretamente no o byte do processo imagem.

6 46 1.Manual STEP 5 V6.8 Apêndice A: Conteúdo do banco de dados usado no programa “CARWAS”: .

Manual STEP 5 V6. . é mais fácil de usar símbolos para as variáveis de input/output.6 47 Listando as variáveis de entrada/ saída (input/output) Para descrever o processo e escrever o programa. Para isto as entradas e saídas ( I/Os) deverão ser copiados em uma tabela como mostrado abaixo.

6 48 Descrição da seqüência de processo. Um passo importante no desenvolvimento do programa é estabelecer a seqüência de controle baseado nas representações esquemáticas e na lista de todas as variáveis de processo. Isto pode ser alcançado. por exemplo. .Manual STEP 5 V6. . na forma de fluxogramas. Uma descrição verbal da seqüência de processo foi selecionada e as tarefa de controle são determinadas a partir de uma tabela verdade.Uma coluna corresponde a um número de controle que é descrito verbalmente na seqüência e então programada como um segmento em STL no passo seguinte do desenvolvimento de programa. representação das funções de controle na tabela verdade. A tabela verdade (Tabela KEIN MERKER) deverá ser lido como segue: .São listadas as condições que devem ser avaliadas em função do passo de controle lógico sobre a linha dupla e as ações que são executadas se as condições forem cumpridas estas ações são listadas é listado abaixo da linha dobro.

6 49 Descrição dos segmentos do programa: .Manual STEP 5 V6.

6 50 .Manual STEP 5 V6.

6 51 .Manual STEP 5 V6.

Sign up to vote on this title
UsefulNot useful