You are on page 1of 4

enable

config t
no ip domain-lookup
banner motd ^CUnauthorized access strictly prohibited and prosecuted to the full
extent of the law^C
!
!
line con 0
exec-timeout 0 0
logging synchronous
login
!
line vty 0 4
login
end
copy run start
=============R1===============
hostname R1
!
int fa0/1
no ip add
no shut
!
int fa0/1.10
encapsulation dot1Q 10
ip add 192.168.10.1 255.255.255.0
!
int fa0/1.12
encapsulation dot1Q 12
ip add 10.12.12.1 255.255.255.0
!
int fa0/1.13
encapsulation dot1Q 13
ip add 10.13.13.1 255.255.255.0
!
int s0/0/0
ip add 10.1.1.1 255.255.255.252
no shut
clock rate 64000
!
router rip
version 2
no auto-summary
network 10.0.0.0
network 192.168.10.0
!
router ospf 1
network 10.1.1.0 0.0.0.3 area 0
network 10.12.12.0 0.0.0.255 area 0
network 10.13.13.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
!
router eigrp 10
no auto-summary
network 10.1.1.0
network 10.12.12.0
network 10.13.13.0
network 192.168.10.0

!
=============R2===============
hostname R2
!
int fa0/1
no ip add
no shut
!
int fa0/1.12
encapsulation dot1Q 12
ip add 10.12.12.2 255.255.255.0
no snmp trap link-status
!
int fa0/1.20
encapsulation dot1Q 20
ip add 192.168.20.1 255.255.255.0
no snmp trap link-status
!
int s0/0/0
ip add 10.2.2.1 255.255.255.252
clock rate 64000
no shut
!
int Lo0
ip add 209.165.200.161 255.255.255.224
!
router rip
version 2
no auto-summary
network 10.0.0.0 n
network 192.168.20.0
!
router opsf 1
network 10.1.1.0 0.0.0.3 area 0
network 10.2.2.0 0.0.0.3 area 0
network 10.12.12.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
!
router eigrp 10
no auto-summary
network 10.1.1.0
network 10.2.2.0
network 10.12.12.0
network 192.168.20.0
=============R3===============
hostname R3
!
int fa0/1
no ip add
no shut
!
int fa0/1.13
encapsulation dot1Q 13
ip add 10.13.13.3 255.255.255.0
!
int fa0/1.30

encapsulation dot1Q 30
ip add 192.168.30.1 255.255.255.0
!
int s0/0/1
ip add 10.2.2.2 255.255.255.252
no shut
!
router rip
version 2
no auto-summary
network 10.0.0.0
network 192.168.30.0
!
router ospf 1
network 10.2.2.0 0.0.0.3 area 0
network 10.13.13.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0
!
router eigrp 10
no auto-summary
network 10.2.2.0
network 10.13.13.0
network 192.168.30.0
=======config vlan========
S1(config)#interface vlan10
S1(config-if)#ip address 192.168.10.2 255.255.255.0
S2(config)#interface vlan20
S2(config-if)#ip address 192.168.20.2 255.255.255.0
S3(config)#interface vlan30
S3(config-if)#ip address 192.168.30.2 255.255.255.0
===========SWITCHEZ==================
S1 (config)# spanning-tree vlan 1-1000 root primary
S1 (config)# vtp mode server
vtp domain cisco
s1 - vlan 10,12,13,20,30
S1 int fa0/1
switchport trunk allowed vlan 10,12,13
switchport mode trunk
int fa0/2
switchport access vlan 10
switchport mode access
int gigabitethernet0/1
switchport trunk allowed vlan 1,12,20
switchport mode trunk
int gigabitethernet0/2
switchport trunk allowed vlan 1,13,30

switchport mode trunk

S2 int fa0/1
switchport trunk allowed vlan 12,20
switchport mode trunk
int gi0/1
switchport trunk allowed vlan 12
switchport mode trunk
S2 - vtp mode client
vtp domain cisco
S3 int fa0/1
switchport trunk allowed vlan 13,30
switchport mode trunk
int fa0/2
switchport access vlan 30
switchport mode access
int gi0/1
switchport trunk allowed vlan 13
switchport mode trunk
S3 - vtp mode client
vtp domain cisco