P. 1
Axial+Bending+Torsion+Combined+Buckling Analysis of a Beam (Abaqus Cae) Jas

Axial+Bending+Torsion+Combined+Buckling Analysis of a Beam (Abaqus Cae) Jas

|Views: 21|Likes:
Published by apmapm

More info:

Published by: apmapm on Jan 31, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

01/31/2012

pdf

text

original

Sections

  • Problem Description:
  • Creating the Model Geometry
  • Defining Material Properties
  • Creating Sections
  • Assigning Sections
  • Creating a Mesh
  • Creating an Instance
  • Creating a Step
  • Creating Sets
  • Apply Constraint Boundary Conditions
  • Applying an Axial Load to the Beam
  • Click Continue…
  • Applying a Torsional Load to the Beam
  • Beam in Bending
  • Creating a Job
  • Setting the Work Directory
  • Writing the Input File (.inp)
  • Model Analysis (ABAQUS Command)
  • Method #1
  • Method #2
  • Postprocessing using ABAQUS CAE
  • Obtaining Stress Values in Elements
  • Modeling Different Loading Conditions
  • Beam Buckling
  • Conclusion

AXIAL, BENDING, TORSION, COMBINED AND BUCKLING ANALYSIS OF A BEAM

Instructor: Professor James Sherwood Revised: Dimitri Soteropoulos Programs Utilized: ABAQUS CAE 6.9-EF1 Problem Description: In this tutorial, a finite element model of a beam will be constructed and analyzed using ABAQUS CAE. The analysis will look at stresses and displacements associated with multiple loading conditions for a steel I-beam. The beam will be “clamped” at one end and be loaded on the other end with prescribed displacements for axial, torsion and bending loads. A unit force will be applied to find the critical buckling load and the associated mode shape. The cross section of the beam is shown in Figure 1. The cross section dimensions are summarized in Table 1. The length of the beam is 90 cm.

Table 1. Cross Section Dimensions a b t1 t2 6 cm 7 cm 1 mm 2 mm

Figure 1. Beam Cross Section

ABAQUS CAE BEAM TUTORIAL

1

REV 03.16.2011

Creating the Model Geometry   Go to the Start Menu and open Abaqus CAE You may be prompted with an Abaqus/CAE 6.9 Extended Functionality box (Figure 1). Close this box by clicking the X in the top right hand corner.

Figure 1. Abaqus/CAE 6.9 Extended Functionality box.

ABAQUS CAE BEAM TUTORIAL

2

REV 03.16.2011

Once the Extended Functionality box is exited, the ABAQUS CAE Viewport should look similar to Figure 2. (Please note the model tree is the series of functions listed on the left hand side of the viewport, while the module is the list of icons to the right of the model tree)

Model Tree

Figure 2. ABAQUS CAE Viewport   To create the model geometry of the steel I-beam, a sketch of the cross section must be generated. Using the left mouse button, double click Parts in the model tree and the Create Part (Figure 3a) dialog box appears. Enter a new name for the part (I-BEAM), and under the Base Feature tab choose Shell for shape and Extrusion for type. Change the approximate size option to 0.5. The Create Part dialog box should look identical to Figure 3b. Click Continue… and the graphics window will change to a set of gridlines.

ABAQUS CAE BEAM TUTORIAL

3

REV 03.16.2011

Figure 3a. Create Part Dialog Box

Figure 3b. Create Part Dialog Box (I-BEAM)

For the first step in generating the model geometry, a rectangular box must be created. Click the Create Lines: Rectangle (4 lines) icon in the module. (Remember, the module is the series of icons to the right of the model tree) In the viewport click once with the cursor, then drag the cursor to any other place in the viewport and click again. A yellow rectangle should be visible in the viewport. Click the Create Lines: Connected icon in the module, hover the cursor along the top horizontal line of the rectangle until a white circle appears (Figure 4). The circle should appear at the midpoint of that line.

 

ABAQUS CAE BEAM TUTORIAL

4

REV 03.16.2011

Figure 4. Midpoint of Horizontal Line  Once the white circle appears on the horizontal line, click with the cursor and draw a vertical line which connects to the bottom horizontal line. You will know that the line is vertical if there is a V located on the right side of the line (Figure 5).

Figure 5. Vertical Line

ABAQUS CAE BEAM TUTORIAL

5

REV 03.16.2011

a New dimension: box should appear. Make sure to keep a consistent set of units when creating any model. Since an arbitrary rectangle was drawn in the initial sketch. Enter a value of 0.  Figure 6. make sure to enter a value of 0. At the bottom of the viewport. At the bottom of the viewport. Click the Add Dimension icon in the module and click the top horizontal line in the sketch. The sketch should resize to the appropriate dimension. At this point the line should turn red and its corresponding dimension should appear. New Dimension Box       Enter a value of 0.2011 . it will now be given the proper dimensions. Dimensioned Sketch ABAQUS CAE BEAM TUTORIAL 6 REV 03. At this point the line should turn red and its corresponding dimension should appear.059 for the vertical line) Figure 7. The dimension values are being input in units of meters. Hit Enter.16.059 in the new dimension box and hit Enter. Move the cursur away from the horizontal line and click.059 is entered for the vertical height. The sketch should resize to the appropriate dimension and look similar to that in Figure 7. a New dimension: box should appear (Figure 6).06 will appear when 0. Using the cursor click the middle vertical line.07 in the New Dimension box. Move the cursor away from the vertical line and click. (Please note: due to significant figures in the sketch mode a value of 0.

The Edit Base Extrusion dialog box will appear (Figure 9a). Edit Base Extrusion Dialog Box (0.16. Click Done.9) ABAQUS CAE BEAM TUTORIAL 7 REV 03. This value will extrude the geometry 90 cm (0. Click and hold the left cursor button while dragging the cursor over the far left vertical line and then let go. Repeat the previous step but drag the cursor over the far right vertical line. If the process was done correctly the sketch should look similar to that in Figure 8.2011 . Edit Base Extrusion Dialog Box Figure 9b.9. After this value has been entered the Edit Base Extrusion dialog box should look similar to Figure 9b. In the Depth: category enter a value of 0. Figure 9a. If this was done correctly the left vertical line should disappear.9m) in the Z direction.  To properly create the I-Beam cross section. click the Auto-Trim icon in the module. Final I-Beam Cross Section    Press Escape on your keyboard to exit the Auto-Trim tool. At the bottom of the viewport you will be prompted to Sketch the section for the shell extrusion. Figure 8.

Figure 10. double click on Materials in the model tree and the Edit Material dialog box will appear (Figure 11a). the Edit Material dialog box should look similar to Figure 11b.3. After the material properties have been entered. Click OK. The cross section sketch will be extruded into a three dimensional part.  Click OK.16. and Poisson’s Ratio = 0. Enter a Name for the material (STEEL). Enter values of Young’s Modulus = 200E09 Pa. Sketch mode will automatically be exited and a grey I-Beam will appear (Figure 10). highlight Elasticity and click Elastic.  ABAQUS CAE BEAM TUTORIAL 8 REV 03. Extruded I-Beam Model Defining Material Properties  To define material properties for this model.2011 . and click the Mechanical tab.

16. Creating Sections  To create a shell section in ABAQUS. At this point in preprocessing. Edit Material Dialog Box  Figure 11b. the model should be saved. double click Sections in the model tree and the Create Section dialog box will appear (Figure 12a). and choose Shell under the Category Tab. The units chosen for the definition of the material properties should be consistent and dictate what units should be used for the dimensions of the structure. Create Section Dialog Box Figure 12b. Create Section Dialog Box (FLANGE) ABAQUS CAE BEAM TUTORIAL 9 REV 03. Edit Material Dialog Box (Steel)  Please note there is no dropdown menu or feature in ABAQUS that sets specific units.Figure 11a. Enter a Name for the section (FLANGE). therefore the respective Young’s Modulus units should be entered in Pa (Pascals). Click File then click Save. All of the dimensions have been input in meters.cae*) file. Click Continue…  Figure 12a.2011 . and Homogeneous under the Type tab. Name the file I-Beam Tutorial. It may be of interest to save the file after each section of this tutorial. The file will save as a Model Database (*. Your Create Section dialog box should look similar to that in Figure 12b.

001 for the Shell thickness (This value will be used to define a thickness of 1 mm for both the top and bottom flanges). Click OK. Enter a Name for the section (WEB). If multiple materials had been created. If both the flanges and web had the same thickness only one section would need to be created. When this is done the number of Thickness integration points will default to 3.   The Edit Section dialog box will then appear where a value for the respective Shell thickness can be prescribed for this section. Your Create Section dialog box should look similar to that in Figure 14b. Under the basic tab enter 0. and Homogeneous under the Type tab. the dropdown menu could be used to prescribe a different material to this section. Change the Thickness integration rule: to Gauss. Figure 13. The Edit section dialog box should look similar to that in Figure 13. Because only one material has been created. the Material is defaulted to STEEL.16. Double click Sections in the model tree and the Create Section dialog box will appear (Figure 14a). another section with the appropriate shell thickness for the web must be created. and choose Shell under the Category Tab.2011 . Click Continue… ABAQUS CAE BEAM TUTORIAL 10 REV 03. Edit Section Dialog Box (FLANGE)    Since the flanges have a different specified thickness than the web.

16. Create Section Dialog Box Figure 14b. Because only one material has been created.2011 . Under the basic tab enter 0. Figure 15.Figure 14a. Edit Section Dialog Box (WEB) ABAQUS CAE BEAM TUTORIAL 11 REV 03. Change the Thickness integration rule: to Gauss. If multiple materials had been created.002 for the Shell thickness (This value will be used to define a 2 mm thickness for the web). the Material is defaulted to STEEL. When this is done the number of Thickness integration points will default to 3. the dropdown menu could be used to prescribe a different material to this section. Click OK. The Edit section dialog box should look similar to that in Figure 15. Create Section Dialog Box (WEB)    The Edit Section dialog box will then appear where a value for the respective Shell thickness can be prescribed for this section.

Next. click the + to the left of the part called I-BEAM. Model Tree Expansion (Parts)  After the model tree has been expanded. further expanding the model tree (Figure 16). Click Done. Selected Flange Sections ABAQUS CAE BEAM TUTORIAL 12 REV 03.Assigning Sections  Now that the shell sections have been created. this will further expand the model tree’s options.  2 Top Sections 2 Bottom Sections Figure 17.2011 .16. they can be assigned to the geometry. click the + to the left of the Parts icon. click the 2 sections of the top flange and the 2 sections of the bottom flange. double click Section Assignments. If the sections have been chosen correctly they will change color from grey to red (Figure 17). Figure 16. In the model tree. While holding the shift key on the keyboard.

2011 . Double click Section Assignments. using the cursor click the web of the I-beam. Edit Section Assignment Figure 19b. The Edit Section Assignment dialog box should look identical to that in Figure 18b. Using the drop down menu under the Section option. choose the FLANGE section that was created. The Edit Section Assignment dialog box will appear (Figure 18a). Using the drop down menu under the Section option. Figure 19a. If the section has been chosen correctly it will change color from grey to red. Edit Section Assignment (FLANGE)   Click OK. Figure 18a. Click Done. Under the Shell offset option make sure the drop down definition is set to Middle surface. Edit Section Assignment (FLANGE) ABAQUS CAE BEAM TUTORIAL 13 REV 03. Next. the web must be assigned its respective section. Edit Section Assignment   Figure 18b.16. The top and bottom now should now turn to a blue color. choose the WEB section that was created. The Edit Section Assignment dialog box should look identical to that in Figure 19b. Under the Shell offset option make sure the drop down definition is set to Middle surface. The Edit Section Assignment dialog box will appear (Figure 19a).

If this selection is done correctly.2011 .16.e keep the aspect ratio of length to width to be as close to 1 as is possible. While holding the shift key on the keyboard. In this model. To exit the rotate command press Escape on the keyboard) 2 Top Edges   Web Edge Side Edge 2 Bottom Edges Figure 20. Click and hold the Seed Part icon in the mesh module and six icons will appear. it is best to make elements as square as possible. If the edges have been selected correctly they will turn a red color (Figure 20). Creating a Mesh  When creating a finite element mesh with shell or plate elements. The web of the I-Beam should now turn a blue color. Selected Edges ABAQUS CAE BEAM TUTORIAL 14 REV 03. To create a mesh for the model geometry. A total of eight lines should be selected since the part should be rotated and the four edges on the other end of the beam should also be clicked. (Note: To rotate the beam click F3 on the keyboard then left click and drag the cursor to rotate the part. i. Click Done. thus making the complete model blue. double click Mesh (Empty) in the model tree. the elements will be made with dimensions as close as possible to 1 cm by 1 cm.  Click Ok. Hover the cursor over the Seed Edge: By Number icon and release the button on the cursor. click the top and bottom edges of the flanges. then the geometry should change color to pink. The first step in creating a mesh is to seed the part.

In the Number of elements along the edges: prompt at the bottom of the viewport enter a number of 90. This will seed the selected edge to have ninety evenly spaced elements along its length. while holding the shift key on the keyboard. click the four edges along the length of the I-Beam.2011 . A total of four lines should be selected (Figure 20). In the Number of elements along the edges: prompt at the bottom of the viewport enter a number of 3. Click Done.16. Hit Enter on the keyboard Click Done. ABAQUS CAE BEAM TUTORIAL 15 REV 03. Hit Enter on the keyboard. This will seed the selected edges to have six evenly spaced elements along their length. A total of two edges should be selected since the part should be rotated and the edge on the other end of the beam should also be clicked. Hit Enter on the keyboard. click the web edge of the I-Beam (Figure 20). If the edges have been selected correctly they will turn a red color. In the Number of elements along the edges: prompt at the bottom of the viewport enter a number of 6. The edges will now appear to be seeded with evenly spaced pink points along their length. Click Done. Finally. The edge should turn from a pink to a red color if it has been selected correctly. This will seed the selected edges to have three evenly spaced elements along their length.            Click Done. Next.

Figure 22. The model tree will expand and should look identical to Figure 22. the geometry will turn blue (Figure 21). If this procedure was done correctly.16. In the mesh module. it can be brought into the assembly. Model Tree Expansion (Assembly) ABAQUS CAE BEAM TUTORIAL 16 REV 03. click the Mesh Part icon bottom of the viewport you will be prompted if it is OK to mesh the part? Click Yes. At the Figure 21. .  The part is now ready to be meshed.2011 . Meshed Geometry Creating an Instance  Now that the part has been meshed. click the + to the left of Assembly in the model tree. To do this task.

The Create Instance dialog box will appear (Figure 23). Create Instance ABAQUS CAE BEAM TUTORIAL 17 REV 03. Double click on the Instances icon in the expanded model tree. then this step would allow them to be entered into the assembly. Figure 23. Click OK. If this step was done correctly the model should turn a blue color (Figure 24). If multiple parts had been created. This feature will allow multiple parts to be brought into the assembly. Create Instance Dialog Box  The I-BEAM part is selected by default because only one part has been created for this tutorial.  Figure 24.2011 .16.

g. ABAQUS CAE BEAM TUTORIAL 18 REV 03. Figure 26.16. double click the Steps icon. Edit Step Dialog Box  Click OK to accept the default values for the various options. e. Figure 25a. In the model tree. Create a Name for the step called LOADING STEP. and the Edit Step dialog box will immediately appear (Figure 26). Static or Dynamic. Create Step Dialog Box (LOADING STEP) Click Continue….2011 .Creating a Step   A Step is where the user defines the type of loading. e.g. Create Step Dialog Box  Figure 25b. support constraints and forces. Under Procedure type choose General > Static. General. and defines the boundary conditions. The Create Step dialog box will appear (Figure 25a). The Create Step dialog box should look identical to Figure 25b.

ABAQUS CAE BEAM TUTORIAL 19 REV 03. Create Set Dialog Box (FIXED END)  Click Continue… The model will to a turquoise color with a visible mesh.Creating Sets  At this point 4 sets will be created to simplify the application of loads and boundary conditions in the upcoming steps. click all of the nodes at one end of the beam. Double click Sets in the model tree. To ensure each node is selected properly they will turn to a red color. Figure 28a. Create a Name for the set called FIXED END.2011 . Make sure to double click the Sets option that is underneath the I-BEAM part in the model tree (Figure 27). Sets Option in Model Tree  The Create Set dialog box will immediately appear (Figure 28a).16. and under the type option make sure to choose Node. A total of 19 nodes should be selected. Create Set Dialog Box   Figure 28b. In this tutorial the beam was rotated such that the nodes on the right side of the beam were selected for the fixed end (Figure 29). Figure 27. While holding the Shift key on the keyboard. The Create Set dialog box should look identical to that in Figure 28b.

The Create Set dialog box should look identical to that in Figure 30b. A total of 19 nodes should be selected. Figure 30a. Create Set Dialog Box   Figure 30b.Figure 29. Create Set Dialog Box (LOAD END)   Click Continue… The model will turn to a turquoise color with a visible mesh. Fixed End Set   Click Done. The Create Set dialog box will immediately appear (Figure 30a).2011 ABAQUS CAE BEAM TUTORIAL . click all of the nodes at the opposite end of the beam that the FIXED END set was created. To ensure each node is selected properly they will turn to a red color. Double click Sets(1) in the model tree. and under the type option make sure to choose Node. 20 REV 03. Create a Name for the set called LOAD END.16. Click Done. In this tutorial the beam was rotated such that the nodes on the left side of the beam were selected for the load end. Another set will be created for the loading end of the I-Beam. While holding the Shift key on the keyboard.

Create a Name for the set called TOP FLANGE.   Figure 32a. The Create Set dialog box should look identical to that in Figure 32b. Create Set Dialog Box  Figure 32b. one for the TOP FLANGE and the other for the BOTTOM FLANGE. The Create Set dialog box will immediately appear (Figure 32a). click the LOAD END set in the model tree and the 19 nodes included in that set will turn red in the viewport. Likewise. ABAQUS CAE BEAM TUTORIAL 21 REV 03. These sets will be created to apply the torsional load to the model.16. Figure 31.2011 . To verify that the sets were not created on the same end of the beam. and under the type option make sure to choose Node. Created Sets Model Tree  Click the FIXED END set in the model tree and the 19 nodes which are included in that set will turn red. Double click Sets(2) in the model tree. Create Set Dialog Box (TOP FLANGE) Click Continue… The model will turn to a turquoise color with a visible mesh. Finally two more sets will be created. The model tree will expand and should look identical to Figure 31. click the + to the left of Sets (2) in the model tree.

Double click Sets(3) in the model tree. The Create Set dialog box should look identical to that in Figure 34b. The Create Set dialog box will immediately appear (Figure 34a). Figure 34a. A total of 7 nodes should be selected. Create Set Dialog Box (BOTTOM FLANGE) Click Continue… The model will turn to a turquoise color with a visible mesh. Node Selection Top Flange Set   Click Done. and under the type option make sure to choose Node. Create a Name for the set called BOTTOM FLANGE. Figure 33. To ensure each node is selected properly they will turn to a red color (Figure 33).2011 . Create Set Dialog Box  Figure 34b.16. Now a set will be created for the BOTTOM FLANGE. click the nodes at the end of the top flange where the LOAD END set was created. While holding the Shift key on the keyboard. ABAQUS CAE BEAM TUTORIAL 22 REV 03.

ABAQUS CAE BEAM TUTORIAL 23 REV 03.16. The Create Boundary Condition dialog box should look identical to that in Figure 36b.2011 . and under the Step drop down menu make sure to choose Initial. Figure 35. click the nodes at the end of the bottom flange where the LOAD END set was created. Create a Name for the boundary condition called FIXED. Double click BCs in the model tree and the Create Boundary Condition dialog box will appear (Figure 36a). Apply Constraint Boundary Conditions   Boundary conditions will be defined which will simulate a fixed (also known as “clamped”) beam at one end with a tip load. While holding the Shift key on the keyboard. A total of 7 nodes should be selected. To ensure each node is selected properly they will turn to a red color (Figure 35). and choose Symmetry/Antisymmetry/Encastre under the Types for Selected Step option. Node Selection Bottom Flange Set  Click Done. Under the Category option choose Mechanical.

2011 . If this selection is done correctly you will be immediately prompted by the Region Selection dialog box (Figure 37). Click Continue… The Edit Boundary Condition dialog box will immediately appear.Figure 36a.FIXED END. Create Boundary Condition Figure 36b. The Edit Boundary Condition dialog box should look identical to that in Figure 38. Create Boundary Condition (FIXED)    Click Continue… Using the cursor. click Sets… at the bottom right side of the viewport. click I-BEAM-1. ABAQUS CAE BEAM TUTORIAL 24 REV 03. Region Selection Dialog Box   Using the cursor.16. Click ENCASTRE (U1=U2=U3=UR1=UR2=UR3=0). Figure 37.

2011 . Applying an Axial Load to the Beam   A 0. Create Boundary Condition  Click Continue… Figure 39b. Edit Boundary Condition Dialog Box  Click OK. Figure 39a. Create a Name for the boundary condition called AXIAL. Under the Category option choose Mechanical.Figure 38. and choose Displacement/Rotation under the Types for Selected Step option. The Create Boundary Condition dialog box should look identical to that in Figure 39b. Create Boundary Condition (AXIAL) ABAQUS CAE BEAM TUTORIAL 25 REV 03.01% axial strain will be applied to the end of the beam as a prescribed displacement.16. Double click BCs(1) in the model tree and the Create Boundary Condition dialog box will appear (Figure 39a). and under the Step drop down menu make sure to choose LOADING STEP.

a displacement will be added in the Z direction.LOAD END. Figure 41a.00009. Figure 40. Since the I-Beam cross section was sketched in the X Y plane. Using the cursor click I-BEAM-1. Edit Boundary Condition Figure 41b. Check the box to the left of U3 and enter a value of 0.16. Edit Boundary Condition (AXIAL) ABAQUS CAE BEAM TUTORIAL 26 REV 03.2011 . Region Selection Dialog Box   Click Continue… The Edit Boundary Condition dialog box will immediately appear (Figure 41a). The Region Selection dialog box will immediately appear (Figure 40). The Edit Boundary Condition dialog box should look identical to that in Figure 41b.

0295 m (0. The Create Boundary Condition dialog box should look identical to that in Figure 43b. and under the Step drop down menu make sure to choose LOADING STEP.2011 . Under the Category option choose Mechanical. Figure 42. Click OK.059/2). and choose Displacement/Rotation under the Types for Selected Step option. To find the required displacement in the x-direction to achieve the 5° twist use:   Where x is the prescribed displacement and is equal to 0. ABAQUS CAE BEAM TUTORIAL 27 REV 03. Create a Name for the boundary condition called TORSION TOP. Double click BCs(2) in the model tree and the Create Boundary Condition dialog box will appear (Figure 43a). The load is to be a 5° twist at the end of the beam. If the prescribed displacement has been applied correctly small orange arrows will be visible at the nodes (Figure 42).00258 m. Applied Axial Load Applying a Torsional Load to the Beam  An equal and opposite displacement will be imposed on opposite sides of the beam to simulate a torque on the beam. The y-distance from the center of the beam to the top or bottom flange is 0.16.

2011 . Click I-BEAM-1. ABAQUS CAE BEAM TUTORIAL 28 REV 03.Figure 43a. the Region Selection dialog box should look identical to that in Figure 44. Create Boundary Condition Figure 43b.00258. Create Boundary Condition (TORSION TOP)   Click Continue… The Region Selection dialog box will immediately appear. Figure 44.TOP FLANGE. Since this displacement will be applied to the top flange in the +X direction click the box to the left of U1: and enter a number of 0. Region Selection Dialog Box  Click Continue… The Edit Boundary Condition dialog box will immediately appear (Figure 45a). The Edit Boundary Condition dialog box should look identical to that in Figure 45b.16.

The Create Boundary Condition dialog box should look identical to that in Figure 46b. and choose Displacement/Rotation under the Types for Selected Step option.16. Create Boundary Condition Figure 46b. and under the Step drop down menu make sure to choose LOADING STEP.Figure 45a. Edit Boundary Condition (TORSION TOP) Click OK. Figure 46a. Create Boundary Condition (TORSION BOTTOM) ABAQUS CAE BEAM TUTORIAL 29 REV 03. Create a Name for the boundary condition called TORSION BOTTOM.2011 . An equal and opposite displacement will be prescribed to the bottom flange. If the procedure has been completed correctly small orange arrows will appear pointing in the +X direction at the end of the top flange. Double click BCs(3) in the model tree and the Create Boundary Condition dialog box will appear (Figure 46a). Under the Category option choose Mechanical. Edit Boundary Condition   Figure 45b.

Edit Boundary Condition (TORSION BOTTOM) ABAQUS CAE BEAM TUTORIAL 30 REV 03. Since this displacement will be applied to the bottom flange in the -X direction click the box to the left of U1: and enter a number of -0.16. Figure 47. Figure 48a. The Edit Boundary Condition dialog box should look identical to that in Figure 48b. Click I-BEAM-1.BOTTOM FLANGE.  Click Continue… The Region Selection dialog box will immediately appear. the Region Selection dialog box should look identical to that in Figure 47.2011 .00258. Region Selection Dialog Box  Click Continue… The Edit Boundary Condition dialog box will immediately appear (Figure 48a). Edit Boundary Condition Figure 48b.

ABAQUS CAE BEAM TUTORIAL 31 REV 03. and under the Step drop down menu make sure to choose LOADING STEP. and choose Displacement/Rotation under the Types for Selected Step option. Click OK. An expanded view of the loading end of the beam is shown in Figure 49. Under the Category option choose Mechanical. Axial and Torsional Loads Beam in Bending  Finally. Create a Name for the boundary condition called BENDING. a prescribed displacement in the –Y direction will be imposed on the tip of the beam.2011 . Figure 49. Both the axial and torsional loads are applied in this view. Double click BCs(4) in the model tree and the Create Boundary Condition dialog box will appear (Figure 50a). The Create Boundary Condition dialog box should look identical to that in Figure 50b.16. If the procedure has been completed correctly small orange arrows will appear pointing in the -X direction at the end of the bottom flange.

Create Boundary Condition Figure 50b.2011 .Figure 50a. the Region Selection dialog box should look identical to that in Figure 51. Create Boundary Condition (BENDING)   Click Continue… The Region Selection dialog box will immediately appear. The Edit Boundary Condition dialog box should look identical to that in Figure 52b. Region Selection Dialog Box  Click Continue… The Edit Boundary Condition dialog box will immediately appear (Figure 52a).LOAD END. ABAQUS CAE BEAM TUTORIAL 32 REV 03.16. Click I-BEAM-1. Since this displacement will be applied to the load end in the -Y direction click the box to the left of U2: and enter a number of -0.006. Figure 51.

All three loading conditions are applied in this view (Axial. and Bending). Torsion. If the procedure has been completed correctly small orange arrows will appear pointing in the -Y direction on the loading end of the beam. ABAQUS CAE BEAM TUTORIAL 33 REV 03. Edit Boundary Condition (BENDING) Click OK. Axial.16. Torsion and Bending Loads. An expanded view of the loading end of the beam is shown in Figure 53.2011 .Figure 52a. Edit Boundary Condition  Figure 52b. Figure 53.

2011 ABAQUS CAE BEAM TUTORIAL . TORSION TOP. and TORSION BOTTOM boundary conditions. Figure 54. Pop Up Menu (Suppress)  Click Suppress. Release the Ctrl button on the keyboard and right mouse click one of the selected boundary conditions. The pop up menu should look similar to that in Figure 55. If this is done correctly a red X will appear to the left of the boundary conditions in the model tree. To do so click the + to the left of BCs (5) in the model tree. This will expand the model tree and should look similar to Figure 54. 34 REV 03. the others can be suppressed. Since only the BENDING boundary condition is of interest for this analysis.16. Since this tutorial calls for multiple loading conditions. At this point the selected boundary conditions should be highlighted blue. While holding Ctrl on the keyboard click the AXIAL. Note: Suppressed BCs will not write to the inp file. Please note that the FIXED boundary condition should not be suppressed for any analysis since is needed to clamp the end of the beam and is not considered a loading condition.   Figure 55. Model Tree Expansion (BCs)  Once the model tree has been expanded all off the created boundary conditions can be viewed. suppressing the loads is helpful rather than deleting the loads when they are unwanted for the analysis. An analysis for the bending loading condition will be completed.

i. Thus the use of the underline in the name. perform the analysis. ABAQUS CAE BEAM TUTORIAL 35 REV 03. A job will take the input file created by the preprocessor and process the model. Figure 56. Create Job Dialog Box (BENDING)   Click Continue… The Edit Job dialog box will immediately appear (Figure 57).Creating a Job  To create a job for this model.e.2011 . Edit Job Dialog Box (BENDING)  Accept the default values and click OK. Up to this point. you have been preprocessing the model. The Create Job dialog box should look identical to that in Figure 56. In the Create Job dialog box. double click the Jobs icon in the model tree. Blank spaces are not allowed in a job name. create a Name for this job called BENDING. Figure 57.16.

click File and in the dropdown menu click Set Work Directory… (Figure 58). Figure 58. Click OK. ABAQUS CAE BEAM TUTORIAL 36 REV 03. setting the work directory must be accomplished. Figure 59.16. Set Work Directory (FOLDERS)   Click OK. At the top of the screen.Setting the Work Directory  To ensure that the input files write to the correct folder. Set Work Directory  The Set Work Directory screen will immediately appear (Figure 59). Click Select… and use standard Windows practice to select (and possibly create) a subdirectory.2011 .

A) then hit Enter..Writing the Input File (. first click the + next to the Jobs(1) icon in the model tree. Right click the job called BENDING and click the Write Input option. To access a specific directory within that drive type cd followed by the specific folder name in that directory (e. Model Analysis (ABAQUS Command) Method #1      Go to the Start Menu and open Abaqus Command ABAQUS is set to a default directory (Example E:\>).g.16. If the job has completed successfully the Abaqus prompt should look similar to Figure 60. Abaqus Command Prompt (COMPLETED) ABAQUS CAE BEAM TUTORIAL 37 REV 03.inp)    To write the input file of the job that was created. Now that the correct directory has been sourced in the command window type abaqus inter j=BENDING and then hit enter. To change directories in the Abaqus Command type the directory of choice followed by a colon (D:) then hit Enter. It may be helpful to go to the folder on the computer to which the work directory is set to ensure that the input file was written there. Figure 60.2011 .inp) of this model to the work directory. cd APPLIED STRENGTHS T. This choice will write an input file (.

Because the last step of creating the model was to create a job/write (and possibly submit) an input file. the model should turn to a green color and the truss will have rotated to an isometric view (Figure 61). Postprocessing using ABAQUS CAE   After the analysis has successfully completed in the Abaqus Command window using Method #1 or using Method #2.2011 . Analysis Results Isometric View ABAQUS CAE BEAM TUTORIAL 38 REV 03. The model will now be submitted for analysis by ABAQUS and the progress can be viewed in the status window at the bottom of the screen. If this selection was done correctly.Method #2    An alternative method for submitting an *. If you see a warning:  Click OK. The intent of this warning is to prevent the user from accidentally overwriting a previously completed analysis with the same name.16. return to view the ABAQUS CAE viewport.  Figure 61. the BENDING job should still be highlighted in ABAQUS CAE model tree.inp file for processing by ABAQUS can be accomplished with ABAQUS CAE Right click the job called BENDING and click the Submit option. Right click the BENDING job and then click Results.

If not. Next. Figure 62. Figure 63.  To rotate the truss back into the X Y plane for viewing.2011 . Views Toolbar  To view the deformed shape of the model. click the Plot Contours on Deformed Shape icon in the Visualization module.16. click View in the toolbar at the top of the screen. The Views toolbar will appear (Figure 62). and the Apply Front View button can be clicked to view the model in the X Y plane. then click it. Click Toolbars and make sure the option Views has a check mark to the left of it. The model should look similar to that in Figure 63. Deformed Shape (BENDING) ABAQUS CAE BEAM TUTORIAL 39 REV 03.

Obtaining Stress Values in Elements  To obtain the stresses in an element first the appropriate type of stress must be viewed. Third Invariant Stress Contour ABAQUS CAE BEAM TUTORIAL 40 REV 03. Mises Dropdown  Using the cursor click Third Invariant.16. Figure 65. At the top of the viewport underneath the top toolbar click the drop down menu Mises (Figure 64). The I-Beam model should look similar to that in Figure 65.2011 . Figure 64. this will change the contour color to represent the third invariant stress levels.

 Now that the appropriate stress contour is being viewed. Figure 67a. At the top toolbar click Tools (Figure 66). The Query dialog box should look similar to that in Figure 67b. output stress values will be obtained for different elements. Query Dialog Box (ELEMENT) ABAQUS CAE BEAM TUTORIAL 41 REV 03.16.2011 . Query Dialog Box Figure 67b. and then click Query… Figure 66. Toolbar Tools  The Query dialog box will immediately appear (Figure 67a). Click Element under the General Queries option.

The value of the stress will then appear at the bottom of the viewport (Figure 68). Earlier in the tutorial the AXIAL & TORSIONAL boundary conditions were suppressed. To complete both the AXIAL and TORSION loading return to the model tree by clicking the Model tab at the top left of the screen.   ABAQUS CAE BEAM TUTORIAL 42 REV 03. Recall that the elastic modulus was prescribed to be 200x109 Pa and all dimensions were input in meters therefore the output stress values are in units of Pa. (To resume the torsion condition right click TORSION TOP & BOTTOM in the model tree and click resume).16. Please note: the stress value listed corresponds to the element outlined with a red box in the viewport. Please note: two torsional loads must be suppressed since there is a load for both the top and bottom flanges. To complete the analysis using the TORSIONAL load. Create a new Job called TORSION and complete the post processing as needed. Stress Value in Viewport  Without exiting the Query dialog box click another element to view the stress value. Suppress both the BENDING and AXIAL boundary conditions and Resume both of the TORSION boundary conditions. Modeling Different Loading Conditions  This tutorial completes the post processing for the BENDING loading condition of the project. At this point click the element on the model for which the stress value is desired. Stress Value Figure 68.2011 .

Since the reaction force in the Z direction is desired click the Magnitude dropdown menu directly to the right of the RF dropdown and then click RF3. To obtain the reactions at the nodes click the Create XY Data icon in the Visualization module. If a combination of loading conditions is desired. Beam Buckling  For the beam buckling analysis.  ABAQUS CAE BEAM TUTORIAL 43 REV 03. the amount of force to apply to each node is a function of the beam width of the element and the number elements connected to a node. a unit axial load will be applied to the tip of the beam. The Create XY Data dialog box will appear (Figure 70a). Please note: two torsional loads must be suppressed since there is a load for both the top and bottom flanges. S Dropdown  Using the cursor click RF.2011 . Because the last step of creating the model was to create a job/write (and possibly submit) an input file. this unit load should be distributed amongst all of the nodes at the tip of the beam. the AXIAL job should still be highlighted in ABAQUS CAE model tree. resume the respective boundary conditions and complete the post processing as needed. The reaction forces at the nodes at the end of the beam are to be determined. Choose the ODB field output option (Figure 70b).   Figure 69. However. this will change the contour from viewing stresses to the magnitude of reaction forces.16. For the best analysis. suppress the TORSION and BENDING conditions and create a new Job called AXIAL and complete the post processing as needed.  Likewise. Right click the AXIAL and then click Results. At the top of the viewport underneath the top toolbar click the drop down menu S (Figure 69).

Under the Variables tab click the Positions: drop down menu and change the selection to Unique Nodal. Figure 71a. All other reaction components should be left unchecked (Figure 71b). Make sure that Pick from viewport is selected in the Method section. ABAQUS CAE BEAM TUTORIAL 44 REV 03. Scroll down and check the box next to RF3. Click Plot.2011 . While holding the Shift key on the keyboard.This click will expand the selection for more options. Create XY Data Dialog Box (FIELD) Click Continue… The XY Data from ODB Field Output dialog box will appear (Figure 71a). click the nodes on the model at the end of the beam which the load was applied.Figure 70a. and click Edit Selection. Scroll down and click the black arrowhead next to RF: Reaction force .16. A total of 19 nodes should be selected. Create XY Data Dialog Box   Figure 70b. When the elements have been selected they will turn a red color. XY Data from ODB Field Output  Next click the Elements/Nodes tab. XY Data from ODB Field Output   Figure 71b.

click the XY Data Manager icon in the Visualization module.16. The XY Data Manager dialog box will appear (Figure 73). This option is located directly to the right of the Create XY Data option. XY Data Manager Dialog Box ABAQUS CAE BEAM TUTORIAL 45 REV 03.2011 .  Figure 73. Figure 72. A plot should appear similar to that in Figure 72.  Click Dismiss. Field Output Plot  To view the numerical values of the reactions at the nodes.

Click OK. In column A of a new Excel workbook enter the node numbers of the 19 nodes found in the XY Data Manager dialog box (Figure 75). Figure 74. To view the value.16. double click each selection and an Edit XY Data dialog box will appear (Figure 74). Figure 75. 46 REV 03. Import Node Numbers (Excel)  Double click each entry and enter the reaction force value in column B of the same Excel workbook (Figure 76).2011 ABAQUS CAE BEAM TUTORIAL . Edit XY Data Dialog Box    In this dialog box the value of the reaction force at the respective node is listed. At this point click start on the computer and open Microsoft Excel.

Many of the nodes have the same respective reaction force and it may be beneficial to color code the nodes with the same reaction forces (Figure 77). Import Reaction Forces (Excel)  Use the SUM function in Excel to add all the forces in column B.9.16. Color Coded Unit Loads (Excel)  Now that the nodal forces are known return to Abaqus CAE and close the Edit XY Data and XY Data Manager dialog boxes.Figure 76. In this case the sum is 5164.2011 ABAQUS CAE BEAM TUTORIAL . Dividing each Reaction Force value by this total gives the respective force to apply to each node so as to have a net unit force on the end of the beam (Figure 77). Figure 77. Return to the model tree by clicking the Model tab at the top left 47 REV 03.

The Create Step dialog box should look similar to that in Figure 78b. Figure 78a. The only boundary condition that should still be resumed is the FIXED boundary condition. Expand Steps (2) in the model tree if it is not already expanded by clicking the + to the left of the Steps(2) listing.2011 . Create Step Dialog Box Figure 78b. Create a Name: for the step called BUCKLE. Double click Steps (2) and you will be prompted by the Create Step dialog box (Figure 78a). Create Step Dialog Box (BUCLKE)  Click Continue… The Edit Step dialog box will immediately appear. Suppress the AXIAL boundary condition (Right click -> Suppress). Under the Procedure type: drop down menu choose Linear perturbation and click Buckle. ABAQUS CAE BEAM TUTORIAL 48 REV 03.  hand side of the viewport. Under the Number of eigenvalues requested: option enter a value of 5 in the box.16. Right click LOADING STEP and left click Suppress. The Edit Step dialog box should look similar to that in Figure 79.

557. double click Sets (4) in the model tree and the Create Set dialog box will immediately appear. Edit Step Dialog Box (5 Eigenvalues)    Click OK. ABAQUS CAE BEAM TUTORIAL 49 REV 03. In the dialog box click the Mesh tab. we will create 4 sets since there are repeated unit load values of 116.779.2011 . Create a Name for the set called Nodes_3_6_10_11 and ensure that Node is selected under the type option.711. The Create Set dialog box should look similar to that in Figure 80. 233. Create Set Dialog Box (NODES_3_6_10_11)   Click Continue… At the top toolbar click View then click Part Display Options… and the Part Display Options dialog box will immediately appear.Figure 79. Next click In all partrelated modules and check the box next to Show node labels (Figure 81). and 430. Rather than individually load 19 nodes with its respective unit load value. 393.412. Similar to creating sets in the first part of the tutorial. Figure 80.16.

11) ABAQUS CAE BEAM TUTORIAL 50 REV 03. 6. When the nodes are selected they will turn a red color (Figure 82). This was done so that the appropriate unit load could be placed on the correct nodes.16. 10.2011 . Part Display Options Dialog Box   Click OK. Set Creation (Nodes 3. 6. 10. and 11.Figure 81. Figure 82. While holding Shift on the keyboard click nodes 3. At this point small purple node labels will appear on the model.

290. 571. 473. All Created Sets  Now that the sets have been created. 475.16. Double click Loads in the model tree and the Create Load dialog box will appear (Figure 84a). 572. 474. Create Load Dialog Box (NODES) ABAQUS CAE BEAM TUTORIAL 51 REV 03. 289. Ensure Mechanical is selected under Category and Concentrated force under Types for Selected Step. Repeat the same method to create sets for: Nodes [103. New Sets Figure 83. The Create Load dialog box should look similar to that in Figure 84b.  Click Done. 476] Nodes [569. Create Load Dialog Box Figure 84b. 570. 104. 573] Nodes [2.2011 . Figure 84a. the appropriate loads can be applied to the nodes. Create a Name: for the load called NODES_3_6_10_11. 7]  If all of the sets have been created correctly the model tree should have a total of 8 sets and look similar to Figure 83.

NODES_3_6_10_11. Figure 85. Edit Load Dialog Box  Figure 86b. Click I-BEAM-1. Edit Load Dialog Box (-0. Enter a value of -0.16. Region Selection Dialog Box (NODES)  Click Continue… The Edit Load dialog box will immediately appear (Figure 86a). The model should look similar to that in Figure 87. Small yellow arrows will be visible pointing in the –Z direction if the procedure has been completed correctly. The Edit Load dialog box should look similar to that in Figure 86b. Click Continue… In the bottom right hand side of the viewport click Sets… and the Region Selection dialog box will appear. the Region Selection dialog box should look similar to that in Figure 85.2011 . Figure 86a.02261 in the CF3: option.02261) Click OK. ABAQUS CAE BEAM TUTORIAL 52 REV 03.

02261)  Using the same approach. Loads of: Nodes [103.16. 571. ABAQUS CAE BEAM TUTORIAL 53 REV 03. 476] = -0. 289. 473.083333  If this procedure has been completed correctly there will be small yellow arrows located ALL the nodes on the loading end of the beam (Figure 88). 573] = -0. create loads for the three other sets that were generated in the previous steps. 7] = -0. 290. 475.04522 Nodes [569. 104.076227 Nodes [2.Figure 87. Model Load (-0. 570.2011 . 474. 572.

the deformed shape should look similar to that in Figure 89. Unit Load   Double click Jobs (1) in the model tree and create a job named BUCLKE.Figure 88. Deformed Shape (Localized Buckle) ABAQUS CAE BEAM TUTORIAL 54 REV 03. Also. Write the input file and post process the job the same way as in the first part of this tutorial. Buckle Load Figure 89.16.2011 . the first buckling load is listed in the viewport to be 30200 Hz. When viewing the results.

Open the folder on the computer that the working directory is set to. The .2011 .inp file should look similar to that shown in Figure 91. The model will now be edited to increase the thickness of the flanges from 1 mm to 5 mm and the web from 2 mm to 4 mm.  The buckled shape shown in Figure 89 is distorted and appears to be localized buckling of the thin flanges and webs and not overall Euler buckling of the column.inp file using Notepad. Shell Section Input File ABAQUS CAE BEAM TUTORIAL 55 REV 03. Figure 90.inp)  While holding Ctrl on the keyboard press the letter F. Input File (. This part of the .inp files that are generated in the working directory.inp file should look similar to that in Figure 90. Figure 91. These changes will be made by editing the . Open the BUCKLE. This will open the Find dialog box. Enter Shell and then click Find Next.16.

inp (Note: the . This section of the input file should look similar to Figure 92.inp extension MUST be entered in the file name) Go to the Abaqus Command window and source to the directory if it is not already sourced. The Open Database dialog box will appear.004.001 to 0.16. This is where we will change the thickness values of the flanges and web.2011 .002 to 0.odb and click OK. ABAQUS CAE BEAM TUTORIAL 56 REV 03. Enter the command abaqus inter j=BUCKLE_EULER and hit Enter. Double click the first item in the Results tab called Output Databases.005 and change 0. If the analysis completed successfully the command window will look similar to that in Figure 93. Figure 92. Change 0. Source to the BUCKLE_EULER. Abaqus Command Prompt (COMPLETED)   Return to the Abaqus CAE viewport and click the Results tab located at the top of the model tree. Figure 93. Shell Section Input File (Increased)    Click File then click Save As… Enter a File name: for this input file called BUCKLE_EULER.

Deformed Shape (Euler Buckle)  The buckled shape is shown in Figure 94.  Conclusion  Save the file by doing either File > Save or clicking the disk icon   Close ABAQUS CAE: File > Exit or Ctrl+Q This completes the Finite Element Analysis of an I-Beam tutorial. ABAQUS CAE BEAM TUTORIAL 57 REV 03.16. That force distribution may not be the same as we did not increase the size of the web and flanges by the same scale factor. the first buckling load is listed in the viewport to be 168712 Hz. the important lesson is that the finite element method can find critical buckling loads be they local or overall Euler buckling. When viewing the results. Thus. The localized buckling is not present in this view and the overall buckling looks to be Euler buckling and notice that the deflection is about the smaller area moment of inertia. Note the buckling force that was applied was based on the force distribution over the nodes resulting from an axial pull on the thinner sections.2011 . Buckle Load Figure 94. the deformed shape should look similar to that in Figure 94. Also. the buckling load may be slightly incorrect for this second buckling analysis. However.

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->