Introduction to EViews 5.

0
Prof. Anthony D. Becker Department of Economics St Olaf College Friday, September 09, 2005 INTRODUCTION EViews is a Windows-based, advanced econometric analysis package that is used in Econ 385 Econometrics. The program files for EViews are on the campus microcomputer network and can be accessed from any networked Windows computer on campus. Because we have only one set of complete manuals, this document will provide some basic instructions for using EViews. As you use the program, experiment with the commands presented here and try other commands and options to learn about the system. You cannot cause any damage by experimenting. If you get stuck or have any questions, please talk to me. Your questions are an important part of the process of learning to use EViews. Each EViews menu command will prompt you for its required information. You should try clicking on the various windows logos to learn how they work. Like most Windows programs, EViews has a good help facility available from the menu at the top of the page. Using the help files can provide answers to specific questions about the parts of EViews that you need to use. The combination of specific instructions in this document, your personal exploration, and reference to the EViews User's Guide (on-line as described below), and the help files should provide sufficient material for you to learn how to use EViews. Ask questions of both your classmates and of me when something is not clear or does not work as you think it should. In many cases one of your classmates will already have solved the problem.

You are responsible for learning how to use EViews.
EVIEWS BASICS In this document, the following conventions will be used. • The names of computer files will be in boldface, Times Roman: for example, arms data.wf1 • The names of data series (variables) in EViews will be in Arial: mexicoexrate • Words and commands you type at the keyboard will be in Courier: money • Commands from a menu will be in italics; a greater-than sign will connect a series of choices: File > Save As… • Important words and concepts will be underlined: work file

etc.Introduction to EViews Page 2 of 17 Two other EViews documents are available on-line through the Application Explorer (Start > St. it covers everything. I also strongly recommend that you maintain copies of all your work files on your personal network space and maybe even on a floppy disk. cut-and-pasted into other Windows programs. This feature let’s you have data in multiple frequencies in the same work file. . EViews Files and Logic: EViews organizes data. Some are part of the objects they will act on.exe and double-click it to launch EViews. Important objects may be copied into other Windows program using cut-and-paste. not all menus are accessed at the top of the window when using EViews. the EViews Command Reference. Most of the data entry.edb) and RATS (.000 variables. you can click on Start > St. saved. and then EViews5. If we need only data on GDP=C+I+G+NX. Each of these objects can be copied. (That is. There are a variety of database formats that EViews can read.rat) formats. graphs. One should practice safe computing at all times. you will also use EViews databases in some projects. macroeconomic time series called the Haver Analytics Database. Olaf Apps > Economics).000? We shouldn’t. A database is where we can store a large number of objects (usually data) for selective access. why should we read in all 17. will be done with menu commands just like all other Windows programs. gives the structure of all commands in EViews. or used for further analysis. We’ll use EView’s database feature to “fetch” only the variables we need into our work file. Many of these objects will need to be discarded because they are not important results and you need to avoid too much clutter." double-click on the P: drive. For example. then Apps. we will use a database of U. You can use more than one work file at a time and can copy objects between them. output. However. Olaf Apps > Economics > EViews. etc. Important and intermediate objects can be saved together in an EViews work file.pdf and Introduction to EViews 2004. The EViews User’s Guide is the complete user’s guide for EViews. with any College-owned Windows PC. graphing.) Look for EViews5. Starting EViews: There are a number of ways to starting EViews. As with all handouts in this class. In addition to the work file. statistical estimation. For example. The two we will use most often are EViews (. It contains data on over 17. Thus each object can be thought of as a piece of paper in your workspace that represents a specific task or result in a larger project. We’ll see some examples later. as objects. A second document. Work files should be saved regularly. Do not overlook the EViews help files as they cover almost all of the materials in the two guides. navigate to P:\>Apps>EViews5. Look in L:\2005-06 Semester 1\economics-385\Class Materials\ for Introduction to EViews 2004.doc. etc. this document is available in the Class Materials Directory.S. Our version of EViews also lets work files have multiple pages in much the same way that a Microsoft Excel file can have multiple pages. You can also double-click on "My Computer. zip disk.

From the main menu. A quick note about frequencies is in order. This does not mean that we have data for all of these years. OK. it may be OK. positively know what you are doing. monthly. Navigate to the class’s data directory (L:\2005-06 Semester 1\economics-385\Class Materials\Data) and open the work file named arms_race. daily) in the same work file.wf1. Do not fetch data into a work file that has a lower frequency than the work file. this file is in S:\Econ\Tony Becker\EViews. EViews will compute the average for the quarter from the monthly data. So. quarterly.2 EViews will let you but 1 2 For Economics faculty.1 Your EViews screen will look like this: Parts of the EViews screen: Main menu The command window Work file window Work file menu buttons Current date ranges for the work file List of objects in the work file From the information on the screen. The variables’ frequency is annual (one observation per year) and the maximum range of the data can be from 1959 to 1988. you can save series of different frequencies in the same database. If you absolutely. select File > Open… > Workfile.Introduction to EViews Page 3 of 17 TUTORIAL 1 – USING AN EXISTING WORK FILE On a Windows PC. However. When you fetch data from a database into your work file (see Tutorial 2) EViews will automatically convert it to the frequency you initially specified for the work file. launch EViews (Start > St. This is OK if the series in the database have a greater frequency (observations per year) than the work file’s settings. Olaf Apps > Economics > EViews). only that this is the maximum possible. weekly. we can tell that this work file contains two variables someone created (soviet and us) and two objects that EViews created: a constant called c and a variable called resid. . You cannot mix data series of different frequencies (annual. reading monthly data into a quarterly work file is OK.

The window shown below will appear. make your work file’s frequency the lowest of the various data series’ frequencies. This is one of several “views” of the us object. Notice the Freeze menu button. A window titled “Series: US” will open. if you are combining monthly (12 obs. There are two easy ways to do it: 1) Use the main menu: Select Quick > Series Statistics > Histogram and Stats and then type us into dialog box that pops up. that’s why.Introduction to EViews Page 4 of 17 what you are doing is interpolating between values so you don’t really have as many valid observations as it may appear. graph objects copy well into other programs like Word. make you work file’s frequency quarterly. EViews will automatically update all objects in your work file. If you create a new object with a command or menu (like the Freeze menu button) you need to name it (use the Name menu button) to place it in your work file. Type soviet c soviet(-1) us(-1) into the window as shown. 3 . Click this to make a frozen copy this window as a graph object for future use. Why would you do this? Because. if you change the values in a series or the sample range of your work file. A Regression: The easy way to do a regression is by using the main menu: Quick > Estimate Equation. Click Name and give it a name and description (optional) and you’ll see it appear in the list of objects in the work file. Try clicking the Bar or Line menu buttons for other views. Sheet will show you a spreadsheet of the data.3 Simple Statistics: Let’s get the statistics on us. 2) Double click us in the work file window. you should get the picture at right. For example. per year) and quarterly (4 obs. Click this window’s View menu button and select Descriptive Statistics > Histogram and Stats. per year) data series. When combining data series of different frequencies. Also. Either way.

also called the first lag.Introduction to EViews Page 5 of 17 What does this mean? It means we want soviet to be the dependent (Y) variable in a regression equation with the independent (X) variables being a constant term (c). and test statistics Equation diagnostic statistics Saving a Work File: Suppose the regression output looks good and you want to save it and your data and run off to dinner. the previous year’s soviet. standard errors. The (-1) indicates we want the value one time period before. To save your work file. Click the Name button and give the regression output a name (and description if you like). coefficients. Click OK to get the regression output: Parts of the regression output: o o o o o o o Dependent variable’s name Estimation method When the equation was estimated Actual range of data used Number of observations Variables. You will see it appear as an object in your work file with in front of it showing that it is an equation. and the previous year’s us. use the main menu command File > Save As… and then .

click navigate to the directory and double-click the file name to open the database. we will try to test this hypothesis using data from the Italian economy.edb. Launch EViews and then use the command File > Open > Database. it is located in the class data directory (L:\2005-06 Semester 1\economics-385\Class Materials\Data). Click OK in the “Database Specification” dialog and you will then see the “Database: ITAOECD” window as shown below. To find these variables. Conversely. You will get the dialog window shown at right. we will ask EViews what useful variables are in the database by clicking the Easy Query button. interest rates. If the Keynesian view of interest rate determination is correct.4 Do not save on the hard drive of a public computer. In this case. interest rates should rise. if money growth is less than GDP growth. 4 Of course. we’ll use the EViews database named itaoecd. and money supply. In this tutorial. But let’s start with a hypothesis.Introduction to EViews Page 6 of 17 save it in your own network space or on a floppy or zip disk. In the dialog box (shown at right) type gross in the space titled “AND description MATCHES” and then click OK. when the money supply grows faster than GDP we should see interest rates fall. AND GENERATING NEW SERIES In this tutorial we will get data from an EViews database and put it in a work file to do some analysis. In the “Open” window. Click Browse Files to navigate to the location of your database. CREATING A WORK FILE. We know we want data on GDP. TUTORIAL 2 – USING AN EVIEWS DATABASE. . on your own computer you can save on the hard drive but be sure to back up the drive every so often.

we have a quarterly work file but have read monthly data on money and interest rates from the database. an average would be appropriate. Double-click any of these to get more information about the variables. in macroeconomic data. Export the nominal money supply. third quarter). Click OK. However. 5 .6 See the EViews help files or manuals for more information about this. 6 For example. Before we go on. saved output. respectively (meaning start at 1971. Note its frequency (quarterly) and date range (1971 Q1 to 1990 Q3). to the work file. you can right-click the variable and select “Export to workfile…” from the menu. you can control how EViews converts frequencies by using the Options > Dates & Frequency Conversions… main menu item. quarterly and monthly values are sometimes labeled as “annual rates” or SAAR (seasonally adjusted annual rates). There are two other ways to export from a database to a work file. click OK. In converting to an annual frequency. Find an interest rate by typing rate into the “AND description MATCHES” area. The interest rate series we want is itaibor. make sure the “Workfile structure type” is “Dated – regular frequency” and select “Quarterly” for the “Date Specification” “Frequency. Save your work file again! Click the Save button on the work file window. it’s worth mentioning how EViews converts data of different frequencies. you can close the database window. EViews has converted the monthly data to quarterly by taking an average of the three monthly values for each quarter. Once this is done. We need a work file for our data series and results so let’s create one. Click OK and the data object will be put into your work file. itam1. In the work file dialog. first quarter. quarterly values of nominal GDP. not an average. you would want to use a sum (total). We still need data series for the money supply and interest rate so go back to the database window and click Easy Query again.” Enter a “Start date” and an “End date” of 1971:1 and 1990:3.Introduction to EViews Page 7 of 17 You will see three variable names show up in the database window. Switch to the database window and click itagdp. Using the main menu. Export this to the Tutorial 2 work file. In this tutorial. Taking an average will be appropriate in most cases. If you wanted to convert to an annual frequency. It turns out that we want itagdp. select File > New > Workfile…. suppose you have monthly data on the number of housing starts that month. then click the Export button. Give it a descriptive name (how about “tutorial 2”?) and save it to your network drive or disk. and end at 1990. Now EViews will have both database and a work file windows open. First. Find a money supply series by doing an Easy Query for money in the description. Second.wf1 will be created to contain all data series. A file with . However. you can double-click a variable name and click the Export to WF button in the window that pops up. when it is not.5 Now is a good time to save your work file: File > Save or File > Save As… will do it. and graphs.

7 8 The equation says. GDPGROWTH MONEYGROWTH RATECHANGE 0. and click OK. “Regress ratechange on the difference between moneygrowth and gdpgrowth.036591 -0. money. The d(x) function takes the difference (current minus past values) of a time series.480000 0.066667 0.085843 0.Introduction to EViews Page 8 of 17 Create Some New Variables. To EViews. Do they? Good! Now. We can generate a new series by clicking the Genr button on the work file window.031948 0. Generate this either by using the equation ratechange = itaibor – itaibor(-1) or the equation ratechange = d(itaibor). this means.” moneygrowth = (itam1 – itam1(-1))/itam1(-1) .” In EViews you can use a new variable in a regression without creating it by putting an expression in parentheses. Our hypothesis talks about GDP growth. click the Genr button. and include a constant.009804 -0.033673 -3. You should find that you have 78 observations of each variable with the following sample statistics. and when it grows slower.090124 7. interest rates fall.524537 Mean Median Maximum Minimum Std. and interest rates.037228 0. From the main menu.8 The interest rate change (name it ratechange) we want is just the amount of change (not percentage change) in itaibor.017328 0. when money grows faster than GDP. enter gdpgrowth = (itagdpitagdp(-1))/itagdp(-1) into the “Enter equation:” area of the dialog box. “gdpgrowth is equal to the difference between current and past GDP divided by past GDP. because we have levels of GDP. using the same process. double-click gdpgrowth to look at the numbers to make sure they seem allright. In the “Equation Specification” area enter ratechange c (moneygrowthgdpgrowth)and click OK. if rates rise.024784 1. select Quick > Estimate Equation…. A simple regression is all it will take to test this.7 In the work file.034567 0. we want to see if (moneygrowthgdpgrowth) is negatively related to ratechange. In terms of our data series. money growth. we’ll need to compute some new variables. we want to see if. and changes in the interest rates and. Dev. To create the growth rate in GDP. Check your work against mine.069274 0. To get back to the hypothesis. Check that you get the same regression output that is shown below.160000 0. generate moneygrowth.

it won’t work on zero or negative numbers. You know (or you do now) that the Federal Reserve makes daily exchange rates available and the daily rates between the U.032178 -13. will be smaller. if money growth is one percentage point larger than GDP growth. For example. The second trick uses one of the properties of natural logs. one uses a built-in percentage change function and the other uses the differences of the natural logs.8507 0. This means that when money growth is higher (larger) than GDP growth.668275 3. dependent var Akaike info criterion Schwarz criterion F-statistic Prob(F-statistic) You’ll notice that we could have computed GDP or money growth using the d(x) function: for example.1393972). that ln(x+a)-ln(x)≈a/x.93972 0. First trick is to use the @pch(x) function like this: moneygrowth = @pch(itam1). Of course.Introduction to EViews Page 9 of 17 Dependent Variable: RATECHANGE Method: Least Squares Date: 09/08/04 Time: 13:47 Sample(adjusted): 1971:2 1990:3 Included observations: 78 after adjusting endpoints Variable C MONEYGROWTHGDPGROWTH R-squared Adjusted R-squared S.069274 1.01) = (-0.495627 170. TUTORIAL 3 – GETTING DATA FROM ANOTHER SOURCE Suppose you are interested in the day-to-day movement in the exchange rate between the U. because the coefficient on (moneygrowthgdpgrowth) is negative and statistically significant.188884 -2.D.965078 t-Statistic 0. moneygrowth = d(itam1)/itam1(-1). Do the results support the Keynesian view? Yes. ratechange.0489 0.170358 6.S. and Mexico are at: .728704 4. In other words.005493 0. There are also two cooler tricks we can use to compute a percentage change directly. In fact. We could have used Quick > Estimate Equation and given the following equation specification: d(itaibor) c (@pch(itam1)-@pch(itagdp)) Give this a try to make sure it gives the same results. The effect of this on ratechange would be (-13.0045 -141.415211 Std. 10%) we could expect to see interest rates drop by over 1/8th of a percentage point. then the variable (moneygrowthgdpgrowth) would have a value of +0. of regression Sum squared resid Log likelihood Durbin-Watson stat Coefficient 0. Also.E.037566 1. In EViews. notice that the coefficient is statistically significant at the 95% level. 0. there is a difference-of-the-logs function – dlog(x) – that approximates the percentage change.524537 3.S.050065 0.93972) x (0.048922 Mean dependent var S. if the money supply grows one percentage point faster than nominal GDP (say. The “Prob” is the p-value for the test that the true coefficient is zero. That much of a change in interest rates is not terribly large but it still appears important. the dependent variable. and Mexico.0627 1. Error 0. we could have estimated the equation without using “Genr” at all.001373 Prob. It is also useful to look at whether an independent variable will have a large or small effect on the dependent variable.01. 11% vs.

In the dialog box (shown at right) click “Text” and then OK. Now launch Microsoft Excel.htm. click on the cell in column A. etc. Then give the “Copy” command: Edit > Copy or Ctrl-C.) and navigate to the Mexico exchange rate page. . Netscape. First. Firefox.federalreserve. But a web page is neither an EViews database (. Switch back to Excel. or from the keyboard Ctrl-A. ASCII = American Standard Code for Information Interchange. We’ll cover both methods. Both methods begin the same way. You should have a view that looks something like this: 9 If you care. Switch to the web browser and give it the “Select All” command: from the main menu Edit > Select All. What do you do? If you can get the data into a text file (also called ASCII9) or Microsoft Excel file (. If you do not use Paste Special in Excel this will not work so be careful.edb) nor work file (.gov/releases/h10/Hist/dat00_mx. row 1 (cell A1) and give Excel the “Paste Special” command: Edit > Paste Special….xls) you can read it directly into EViews. open a web browser (Internet Explorer.wf1). You can also cut-and-paste from another Windows program (like Excel) into EViews.Introduction to EViews Page 10 of 17 http://www.

Now. The completed dialog box is shown below. . your data is “By Observation” so make sure this is clicked. I chose mexicoexrate. and this is important. Click OK. (There is no currency trading on weekends. First. give the command File > Import > Read Text-Lotus-Excel….xls” so that you can see your spreadsheet. Finally.xls.) Save the file with some descriptive name such as mexico exchange rates. the “Upper-left data cell. change “Files of type:” to “Excel .Introduction to EViews On to Method 1: Reading an External File into EViews Page 11 of 17 Notice that the exchange rate data begins in cell B16 and that it is daily data with five-day weeks. Navigate to where you saved the spreadsheet and open it. It’s a good idea at this point to switch back to your web page and make sure what EViews says is the value for various days agrees with the web page. close the worksheet in Excel. Click the little button next to “Daily (5 day weeks)” and enter a start date of “1/3/2000” and an ending date of whatever today is. This time. Next. At the bottom of the dialog box. Click OK to read in the data. your data begins in cell B16. Launch EViews and create a new work file.” Then. Otherwise EViews may not be able to open it. You need to fill in a few things. there is only one series so give the data series a name. the “Excel 5+ sheet name” is probably Sheet 1 so type this in. Next. You will now see the “Excel Spreadsheet Import” dialog box. we are creating a work file with daily data and the date format is a little different.

3) Open the two variables as a “group” and compute their correlation. Switch to EViews and doubleclick your new (empty) object. get your data on screen by launching Excel and loading the spreadsheet with the Mexican exchange rate data. you first need to make a series object to hold the data. Here are a couple of ways to do it.wf1 as the name for my work file. use a new name for the new object: mexrate. o Copy the data either by using File > Copy or Ctrl-C. You should have a window like that shown at the right. and a Forecasting Model Save your work file before going any further. . Check to see if mexicoexrate and mexrate are the same.Introduction to EViews Now for Method 2 – Cut-and-paste Sometimes you might want to cut-and-paste data into EViews or even type it in by hand. In the window that opens. On your work file’s window you’ll see a button for “Objects. Click OK to create the object.” Click it and select “Series” as the “Type of Object. click the “Edit +/-” button. “Select” and “Copy” the data in Excel as follows: o Point to cell B16 (the top of the data column) with the mouse and click once. To do this.” Name the object something different than any existing objects. (See Tutorial 1) 2) Compute the difference between the two variables (See Tutorial 2) and see if this variable is always zero. Point to the space in the first column next to the date for your first observation. they should be. Next. then o Either hold down the button and drag to the end of the data OR o Hold down Shift and Ctrl (at the same time) and press the down arrow key. Then “Paste” by using File > Paste or Ctrl-V. Because we plan on pasting in the same exchange rate data for Mexico. Some Manipulations. 1) Compute sample statistics on each and compare them. I chose tutorial 3. Page 12 of 17 More of Tutorial 3: Groups.

Of course.2” part tells EViews to use the second difference.0 value all the time.5 may even have a break point some time around June 2002.) If the series are the same. close the group window. Click “Genr” again and this time use an equation of d2mexrate=d(mexrate. The first difference (as we mentioned above) is the difference between a current period’s value and the 10.5 3/01/00 1/30/02 12/31/03 MEXRATE To compute the first and second differences. A Simple Forecasting Model: . you should get correlations of one in all cases. Let’s see if we can 11.5 difference is the difference of the first 9. To compute the second difference. Series Manipulation: 8. You may want to look at line graphs or descriptive statistics of your two new series to see what they look like.0 differences. In the “Enter Equation” space type dmexrate=d(mexrate). it is not staying around the same 12.Introduction to EViews Groups: Page 13 of 17 EViews lets you create a group of series and keep these in your work file along with individual data series objects. To create a group. In you work file window. Be careful because any changes you make to series will be reflected in the group and any changes to data in the group will be reflected in the individual series. (You can also use the main menu and select Quick > Group Statistics > Correlations and then click OK. Then hold down Crtl and click once on the other series you want in the group. Click the “Genr” button on the work file window (or use the main menu command Quick > Generate Series…). To see all the different functions. The second 9. A new window will open with both series in it.0 past period’s value. This series is what we call “non-stationary. Click the series window’s “View” button and select Line Graph to see the values graphically over time. if you named your Mexican exchange rate something other than mexrate. respond OK to the “delete group” message. If all is OK. Click this window’s “View” button and select Correlations. we’ll use EViews built-in difference functions like we did in Tutorial 2. You will now have two new series objects in your work file: dmexrate (the first difference) and d2mexrate (the second difference). use the main menu command Help > Function Reference or check the EViews manuals. double-click on one of the exchange rate series.2).5 differences. It even looks like it 11. we can use the same d(…) function but with a small addition. The “.” That is. use that series name.0 make a stable series out of it by taking 10. click once on a series you want to be in the group. When you have selected all the series for the group right-click on the series and select Open > As Group from the pop-up menu.

248337 -0.8038 0. Dependent Variable: DMEXRATE Method: Least Squares Date: 09/13/04 Time: 11:30 Sample(adjusted): 4/14/2000 8/31/2004 Included observations: 392 Excluded observations: 751 after adjusting endpoints Variable C DMEXRATE(-1) DMEXRATE(-2) DMEXRATE(-3) DMEXRATE(-4) DMEXRATE(-5) DMEXRATE(-6) DMEXRATE(-7) DMEXRATE(-8) DMEXRATE(-9) DMEXRATE(-10) DMEXRATE(-11) DMEXRATE(-12) DMEXRATE(-13) 10 Coefficient -0.717728 -0.Introduction to EViews Page 14 of 17 One of the simplest single-equation forecasting models is called the AR(p) where “AR” means “autoregressive” and “p” is a number of “lags.989188 0.132839 -0. ending date.859511 2. Notice that it has statistically significant coefficients and a much larger R2 coefficient. 0. and for 24 to 36 lags for monthly data.1469 0.8040 0. Enter dmexrate c dmexrate(-1 to 20) for the “Equation Specification. click the “Name” button and name this object “FIRST” for first difference. the AR(2) forecasting model for variable X is: X t = β 0 + β 1 X t −1 + β 2 X t − 2 + ε t Xt is the current period’s value of the variable X and Xt-1 and Xt-2 are the two previous periods’ values of X called the first and second lags of X.3906 0.549259 -0.053672 0.050948 0. From the main menu.839405 Prob. When you get the equation window. etc. There isn’t a rule of thumb for daily data but 20 or 30 may be a good starting point.034092 0.125885 0. two or three lags should be enough.000225 -0. Remember that our Mexican exchange rate data is daily with five-day weeks.5091 0. the second-difference model seems to be a better forecasting model.” Your output from these two models should be similar to that in the tables below.051525 0.009282 -0.5832 0.635017 -0.052808 0.028600 -0. let’s estimate the AR(20) model for dmexrate.051587 0.453501 1.173820 -0. use Quick > Estimate Equation. 11 You will have a different sample size.012956 0. The model’s coefficients are β0.1029 0. an AR(20) model should be OK.052027 0. .” This specification means that dmexrate is the dependent variable.8944 0.248584 1.8621 0.076776 0.051499 t-Statistic -0.002535 0. An AR(3) model would have three lags.052120 0. a constant term (c) should be included.4018 As a rule of thumb.000337 -0. With daily data.9966 0.660873 0.052822 0.053437 0.053401 0.051505 0. and the first twenty lags of dmexrate should be the right-hand-side variables. and β2 and εt is the error term. an AR(4) would have four.419610 0.” For example.10 First.3232 0.043228 Std.012796 -0. for annual data.0160 0. β1.046132 0.087370 -0. 8 to 12 lags for monthly data. and excluded observations.11 At first glance. You will also have slightly different results.004263 -0.4734 0. Repeat this using d2mexrate and name that equation object “SECOND. Error 0. Now this is not proof that it is better but it is an indication that it may be better.036732 -0.052070 0.051179 0.

0000 0.932754 -0.109169 0.873662 -0.145559 -0.547189 -1.136833 0.051680 0. 0.7319 0.050497 0.621531 -2.051782 1.108259 -2.557285 -0.762470 -0.0000 0.026842 0.890930 -6.068769 0.7594 0.5780 0.978826 -0.135911 0.832205 0.049860 0.19919 -11.864031 596.052828 -0.465176 0.223992 -17.180165 -0.049757 0. of regression Sum squared resid Log likelihood Durbin-Watson stat Coefficient -0.859224 -0.028977 -0.070434 0.0000 0.494164 0.050744 0.135932 0.9579 0.Introduction to EViews DMEXRATE(-14) DMEXRATE(-15) DMEXRATE(-16) DMEXRATE(-17) DMEXRATE(-18) DMEXRATE(-19) DMEXRATE(-20) R-squared Adjusted R-squared S.134195 0.684563 -4.3228 0.D.894361 0.556863 -0.000582 -0.1850 -0.897055 -0.9930 1.8229 0.052495 t-Statistic -0.671045 -5. Error 0.876875 -0. dependent var Akaike info criterion Schwarz criterion F-statistic Prob(F-statistic) .990061 -0.076219 0.8571 0.922318 629.0486 0.E.217091 -6. dependent var Akaike info criterion Schwarz criterion F-statistic Prob(F-statistic) Dependent Variable: D2MEXRATE Method: Least Squares Date: 09/13/04 Time: 11:22 Sample(adjusted): 4/17/2000 8/31/2004 Included observations: 370 Excluded observations: 772 after adjusting endpoints Variable C D2MEXRATE(-1) D2MEXRATE(-2) D2MEXRATE(-3) D2MEXRATE(-4) D2MEXRATE(-5) D2MEXRATE(-6) D2MEXRATE(-7) D2MEXRATE(-8) D2MEXRATE(-9) D2MEXRATE(-10) D2MEXRATE(-11) D2MEXRATE(-12) D2MEXRATE(-13) D2MEXRATE(-14) D2MEXRATE(-15) D2MEXRATE(-16) D2MEXRATE(-17) D2MEXRATE(-18) D2MEXRATE(-19) D2MEXRATE(-20) R-squared Adjusted R-squared S.134130 0.46257 -9.054232 0.274529 -0.0001 0.3751 -0.5846 0.120841 0.E.093566 0.296083 0.2984 0.392107 -1.046618 0.0280 1.0000 0.107107 -2.128799 0.049822 -3.0003 0.0000 0.0500 0.005354 -0.7673 0.493434 -0.0000 0.306542 -0. of regression Sum squared resid Log likelihood Durbin-Watson stat 0.886141 17.125211 0.8844 0.1639 0.015965 -0.072734 -3.257135 -0.0442 0.052036 0.000000 Mean dependent var S.036381 -0.136250 0.118683 0.832703 -0.386028 -0.000357 0.001534 0.498196 Page 15 of 17 Mean dependent var S.328037 0.053767 0.0000 0.001135 0.090656 0.041245 0.967006 -1.263963 -0.019604 -1.017710 -0.049695 -0.020264 -0.888049 Prob.394794 0.002598 0.970058 0.051638 0.898082 Std.D.123966 -0.027767 -0.129943 0.068037 -3.0048 0.371687 -8.109679 0.051655 0.6952 0.342843 -0.101351 0.073750 0.840302 -2.04732 0.013287 -0.

rat for Mexico.rat”. See Tutorial 4 to access the OECD data. Click Browse Files and navigate to the OECD directory mentioned above.edb. jpnoecd.x format. Now you can do your Easy Query to find the time series you would like to use. you can switch to your work file and click Fetch. In this short tutorial. etc. To access the Haver database from EViews. If you already know the name of the variable you want. To re-estimate the equation using only lags 1 to 13 we just have to click the “Estimate” button on the equation output window and change the –20 to –13. 12 It is also in S:\Econ for department faculty use. For example.rat for Japan.” They are located in P:\Apps\EconData\OECD2004 and all the data file names end with . Double click on the datebase for the country you would like to use. Their names begin with a threeletter code that identifies the country followed by “oecd. This database is also in L:\2005-06 Semester 1\economics-385\Class Materials\.rat.000 time series on the U. The database will open in a window as before. Try it. we’ll explain how to open these as databases.pdf. there is mexoecd. see Tutorial 2 then use File > Open > Database to open P:\Apps\EconData\usecon.Introduction to EViews Page 16 of 17 Note that the coefficients for lags 14 through 20 are zero. Click OK.x File” and the DB File name/path will be for the file you selected. economy. You will see the dialog box at right.S.12 A NOTE ON THE ECONOMICS DEPARTMENT DATABASES Two of the large econometric databases the department purchases are the OECD Main Economic Indicators and the Haver Macroeconomic Database. You will return to the dialog at right only it will show the Database/File Type to be “RATS 4. We can probably eliminate them from the equation. A list of all the variables in all the OECD files and country codes is in L:\2005-06 Semester 1\economics-385\Class Materials\OECD_List_2004. (EViews does allow us to open them as work files but don’t do this. . The Haver database contains almost 20.) Use the following command: File > Open > Database. Most are either monthly or quarterly frequency. TUTORIAL 4 – USING RATS FORMAT DATABASES The department’s OECD Main Economic Indicators databases are in format that EViews calls “RATS 4. You will see all the RATS data files.

Links to other daily exchange rates are at http://www. the first difference is D.edb. 3) Work through Tutorial 3 and repeat the analyses for another country of your choice.gov/releases/h10/Hist/. Data can be found in the database usecon. Choose only a ten-year period for your work file. any ten years will do.Introduction to EViews EXERCISES: Page 17 of 17 1) Work through Tutorial 1 and then estimate a regression with us as the dependent variable and the same independent variables: c soviet(-1) us(-1). if you have a forecast of S for tomorrow. and the second difference is S.federalreserve. 2) Work through Tutorial 2 and then estimate the same model for the U. and the money supply M2 (look for one that is “NSA”). nominal GDP. figure out how you can forecast tomorrow’s X. Use the prime lending rate. 4) In Tutorial 3. the (apparently) better forecasting model was the one using second differences. Use this notation: the variable is X. Then: Dt = X t − X t −1 S t = Dt − Dt −1 = ( X t − X t −1 ) − ( X t −1 − X t − 2 ) = X t − 2 X t −1 + X t − 2 So. .S. The links to “Screen Reader” will give the pages like the one used in the tutorial.

Sign up to vote on this title
UsefulNot useful