Koneksi Database Access dengan Delphi Untuk melakukan koneksi dari Delphi ke Access dapat melalui 2 cara, yaitu

dapat melalui BDE (Borland Database Engine) dan juga dapat melalui ADO (ActiveX Data Object). Apabila akan melakukan koneksi ke Access menggunakan ADO, maka caranya adalah:
y y

Sisipkan komponen ADOConnection (berada dalam palette ADO) pada form. Misalkan kita akan melakukan koneksi ke Datasource ODBC bernama DATAKULIAH yang telah dibuat sebelumnya, maka selanjutnya ubah properties dari komponen ADOConnection seperti di bawah ini

y

y

Apabila properti CONNECTED berhasil diberi nilai True, maka berarti koneksi berhasil. Selamat Membuat program dekstop menggunakan delphi.

Program Aplikasi Perpustakaan dengan Delphi + Ms. Access Form Cetak Anggota Ahmad Rizal Abidin, M.Kom Karena project Prjpustaka sebelumnya sudah dibuat, pada modul 2. Membuat menu, maka pada kesempatan ini adalah melengkapi frmanggota yaitu dengan cara: 1. Mengaktifkan Delphi 7.0 dengan cara, klik Start, Klik All Program, Klik Borland Delphi 7, Klik Delphi 7. 2. Klik menu File, klik Open Project, tentukan folder tempat anda menyimpan project PRjpustaka, lalu klik prjpustaka dan klik open 3. Klik Menu file, Klik New, klik form, ganti caption pada properties dengan Cetak Data Anggota, dan pada name ketikkan frmcetakanggota. 4. Klik menu View, lalu klik forms dan double klik frmenu, klik file pada frmmenu, klik anggota dan ketikkan : frmcetakanggota.show; 5. Klik menu View, lalu klik forms dan double klik frmcetakanggota, lengkapi form tersebut seperti gambar berikut :

Gambar 1. Membuat form Cetak Anggota

Catatan : Form disamping terdiri dari : Ado connection, ADoQuery dan Dataset Button1 untuk cetak dan Button2 untuk Cancel Untuk membuat laporan kita menggunakan dua komponen pallete RAVE yaitu : RVProject dan RVDataSetConnection Mengkoneksikan database y Klik ADOQuery1 pada Form, klik ConnectionString («), klik Build, Klik Microsoft Office 12.0 Acces Database Engine OLEDB Provider (untuk office 2007) tetapi kalau menggunakan office XP dapat dipilih Microsoft jet OLEDB 4.0, test connection y Dan klik next, pada data source ketikkan : D:\perpustakaan\perpustakaan.accdb, dan yang terakhir klik test connection. Apabila test connection tampil keterangan tes connection succeeded, maka koneksinya sudah benar, tutup semua windows koneksi dengan cara klik OK. kembali ke frmCetakanggota. y Masih pada Adoquery1, klik SQL pada properties, lalu ketikkan : select * From anggota Dan Klik Active pada properties ganti false menjadi true. y Mengaktifkan DataSource, yaitu dengan cara klik Datasource pada form anggota, lalu klik Dataset pilih Adoquery1 y Mengkoneksikan RVDataSetConnection dengan dataset, dengan cara klik RVDataSetConnection, pada properties klik Dataset, lalu pilih AdoQuery1

Langkah-langkah membuat laporan dengan menggunakan RAVE 1. 2. 3. 4. Klik menu Tools pada delphi, klik RAVE designer Klik file, Klik New Klik File, Klik New Data Object Klik Direct Dataview

5. Apabila sebelumnya pernah membuat laporan dengan rave, maka akan ditampilkan pesan ³Warning! Duplicate Design-time Data Connections found with name ³RvDataSetConnection1´. Lalu klik Ok dan klik tombol Next 6. Klik finish 7. Klik RVDatasetconnection1 (DT), lalu Klik Finish 8. Untuk memastikan data yang akan dibuatkan reportnya dapat dilihat pada sudut kanan lembar kerja Rave yaitu seperti gambar berikut, dengan cara klik Data view Dictionary, Klik Dataview.

9. Klik menu tools pada Rave, lalu klik Report Wizard, Klik Simple Table 10. Klik Dataview1 dan Klik Next, Klik All (untuk mengikutsertakan seluruh data yang ada pada table) atau klik field tertentu saja yang akan ditampilkan, lalu klik Next, Klik Next, Klik next dan yang terakhir klik Generate 11. Untuk melihat hasil report dapat diklik menu File pada RAVE, lalu klik Execute report1 dan Klik OK 12. Tutup laporan 13. Klik Menu file pada RAVE, lalu Klik Save As, perintah ini untuk menyimpan Report, tentukan folder sama dengan project Delphi disimpan, beri nama file dengan nama PRJAnggota.rav, lalu Klik Save 10. Kembali Menu Project Delphi 11. Klik RVProject1, lalu pada properties klik ProjectFile, Klik tombol titik-titik, pilih file report yang akan ditampilkan (PRJanggota.rav) dan klik OK 12. Selanjutnya adalah Double klik pada tombol Cetak dan ketikkan koding sebagai berikut :
01 procedure TFrmCetBuku.Button1Click(Sender: TObject); 02 begin 03 adoquery1.Close; 04 adoquery1.SQL.clear; 05 adoquery1.SQL.Add('select kode, judulbuku from Anggota'); 06 adoquery1.Open; 07 adoquery1.Active := true; 08 RVproject1.Execute; 09 RVproject1.ExecuteReport('prjbuku.rav'); 10 end;

Program Aplikasi Perpustakaan dengan Delphi + Ms. Access Form Cetak Buku Berdasarkan ID Penerbit Ahmad Rizal Abidin, M.Kom Karena project Prjpustaka sebelumnya sudah dibuat, pada modul 2. Membuat menu, maka pada kesempatan ini adalah melengkapi frmanggota yaitu dengan cara: 1. Mengaktifkan Delphi 7.0 dengan cara, klik Start, Klik All Program, Klik Borland Delphi 7, Klik Delphi 7. 2. Klik menu File, klik Open Project, tentukan folder tempat anda menyimpan project PRjpustaka, lalu klik prjpustaka dan klik open 3. Klik Menu file, Klik New, klik form, ganti caption pada properties dengan Cetak Data Anggota, dan pada name ketikkan frmcetakanggota. 4. Klik menu View, lalu klik forms dan double klik frmenu, klik file pada frmmenu, klik anggota dan ketikkan : frmcetakanggota.show; 5. Klik menu View, lalu klik forms dan double klik frmcetakanggota, lengkapi form tersebut seperti gambar berikut : Gambar 1. Membuat form Cetak Buku Per Penerbit

Catatan : Form diatas terdiri dari : Groupbox, Edit1 dan label1 Ado connection, ADoQuery dan Dataset Button1 untuk cetak dan Button2 untuk Cancel Untuk membuat laporan kita menggunakan dua komponen pallete RAVE yaitu RVProject dan RVDataSetConnection 6. Mengkoneksikan database Klik ADOQuery1 pada Form, klik ConnectionString («), klik Build, Klik Microsoft Office 12.0 Acces Database Engine OLEDB Provider (untuk office 2007) tetapi kalau menggunakan office XP dapat dipilih Microsoft jet OLEDB 4.0, test connection Dan klik next, pada data source ketikkan : D:\perpustakaan\perpustakaan.accdb, dan yang terakhir klik test connection. Apabila test connection tampil keterangan tes connection succeeded, maka koneksinya sudah benar, tutup semua windows koneksi dengan cara klik OK. kembali ke frmCetakanggota. 7. Masih pada Adoquery1, klik SQL pada properties, lalu ketikkan :

select * From anggota Dan Klik Active pada properties ganti false menjadi true. 8. Mengaktifkan DataSource, yaitu dengan cara klik Datasource pada form anggota, lalu klik Dataset pilih Adoquery1 9. Mengkoneksikan RVDataSetConnection dengan dataset, dengan cara klik RVDataSetConnection, pada properties klik Dataset, lalu pilih AdoQuery1 Langkah-langkah membuat laporan dengan menggunakan RAVE Klik Disini« Klik Disinisi« untuk Rave Setelah selesai membuat Report dengan Rave dilanjutkan dengan 10. Kembali Menu Project Delphi pada form Cetak 11. Klik RVProject1, lalu pada properties klik ProjectFile, Klik tombol titik-titik, pilih file report yang akan ditampilkan (PRJanggota.rav) dan klik OK 12. Selanjutnya adalah Double klik pada tombol Cetak dan ketikkan koding sebagai berikut :
01 procedure TForm1.Button1Click(Sender: TObject); 02 begin 03 adoquery1.Close; 04 adoquery1.SQL.Clear; adoquery1.SQL.add('select * from Penerbit,buku where penerbit.id_penerbit = buku.id_penerbit and buku.id_penerbit = "'+ edit1.Text +'"'); 06 adoquery1.Open; 05 07 if not adoquery1.Eof then 08 begin 09 10 rvproject1.Execute; rvproject1.ExecuteReport('prjbukupenerbit.rav');

11 end 12 else 13 showmessage('Data tidak ditemukan'); 14 end;

FLOWMAP Flowmap adalah campuran peta dan flow chart, yang menunjukkan pergerakan benda dari satu lokasi ke lokasi lain, seperti jumlah orang dalam migrasi, jumlah barang yang diperdagangkan, atau jumlah paket dalam jaringan. Flowmapmenolong analis dan programmer untuk memecahkan masalah kedalam segmen-segmen yang lebih kecil dan menolong dalam menganalisis alternatif-alternatif lain dalam pengoperasian. http://mugi.or.id/blogs/yandi_tubagus/archive/2009/11/18/data-flow-diagram-dfd-danflowmap.aspx

Flowchart adalah penggambaran secara grafik dari langkah-langkah dan urut-urutan prosedur dari suatu program. Flowchart menolong analis dan

programmer untuk memecahkan masalah kedalam segmen-segmen yang lebih kecil dan menolong dalam menganalisis alternatif-alternatif lain dalam pengoperasian. Flowchart biasanya mempermudah penyelesaian suatu masalah khususnya masalah yang perlu dipelajari dan dievaluasi lebih lanjut.

Form Login dan Sign Up berbasis database dengan delphi 7
Sesuai dengan request saudara indra kemaren pada postingan saya sebelumnya,tentang membuat form login sederhana dengan delphi 7.beliau menanyakan kepada saya,bagaimana cara menambahkan form sign up pada tampilan form login tersebut. untuk menambahkan form sign up pada form login tersebut.pembaca perlu membuat 1 database terlebih dahulu..sebagai tempat penyimpanan data member/anggota yang nantinya melakukan registrasi dan pembaca juga perlu untuk menambahkan minimal 2 form tambahan..1 untuk form registrasi member dan yang satunya lagi untuk form konfirmasi..disini saya masih menggunakan cara yang sederhana..berhubung karna saya juga masih dalam tahap belajar..hehehe kalo tampilan form login yang saya buat sebelumnya seperti gambar dibawah ini :

Berarti pebaca perlu manmbahkan satu label lagi yang berfungsi sebagai link ke menu registrasi anggota yang akan kita buat nantinya.cara pembuatannya klik pada tab standard > label(StdCtrls) kemudian pada tab propertiesnya,rubah textnya misalnya ³ klik disini untuk registrasi´. Untuk pembuatan database member,berikut langkah ± langkahnya : 1. Start > all program > borland delphi 7 > database desktop hingga muncul tampilan seperti berikut :

2. Kemudian buat tabel baru dengan mengklik file > New > tabel jika muncul tampilan confirmasi tekan ok aja.. 3. Setelah itu isi field namenya seperti berikut :

4. Setelah itu save dengan nama user Nah sekarang tinggal mengisi database yang sudah anda buat tadi..berikut langkah ± langkah pengisiannya 1. Buka pada tampilan database desktop tadi,klik file > open > table kemudian cari database yang sudah anda buat.. 2. Setelah itu klik pada tab edit data dan masukkan isikan data hingga seperti gambar berikut :

pembaca tinggal membuat alias dari database yang baru pembaca buat tadi.caranya sebagai berikut : 1. Buka database yang sudah pembaca buat tadi dengan mengklik file > open > tabel

2. Setelah itu klik pada seperti gambar berikut :

tab Tools

>

alias

manager

hingga

muncul tampilan

3. Klik tab new dan buat database alias baru dengan nama ³user´ kemudian klik tab keep New dan tekan ok. Sekarang anda sudah berhasil membuat database baru beserta alias databasenya.. Untuk membuat form registrasi member,berikut langkah ± langkahnya : 1. Buka aplikasi delphi anda, kemudian cari form sign in yang sudah anda buat..jika belum tahu cara pembuatannya,silahkan baca postingan sebelumnya..klik disini. 2. Setelah itu,buat form baru dengan nama register..kemudian letakkan 4 buah componen DBEdit,4 buah label dan 2 buah button,dan jangan lupa, letakkan 1 buah componen table pada Tab BDE dan componen data source pada tab Data acces.setelah itu rubah masing ± masing caption dari componen ± componen tadi hingga tampilannya seperti gambar berikut :

Atur Properti Komponen Tabel:

a. Properti Komponen Tabel yang dirubah : Name : Tdftr DatabaseName : user TableName : user.db Active : True b. Properti Komponen Data Source yang dirubah : Dataset : Tdftr Name : DataSource1 Kemudian pada componen DBEdit atur properti seperti berikut : DataSource : DataSource1 DataField : atur sesuai dengan urutan label gambar diatas Setelah itu klik 2x pada button daftar, lalu paste code berikut : Tdftr.Append; // Meminta Record Baru BTambah.Enabled:=true; // Tombol aktif BBatal.Enabled:=true; end; kemudian klik 2x pada tombol batal dan paste code berikut : begin Tdftr.Cancel; BTambah.Enabled:=true; // Tombol aktif BBatal.Enabled:=false; end; nah..sekarang anda kembali kepada Form login, buat form baru lagi,rubah nama Form tersebut dengan ³msg´ kemudian save dengan nama msg juga,Edit tampilan formnya seperti gambar berikut :

Form ini akan tampil ketika user/anggota menginputkan user name dan password dengan benar.. Terakhir,anda kembali ke form login,kemudian tempelkan 1 buah componen table dan rubah propertinya seperti berikut :

a. Properti Komponen Tabel yang dirubah : Name : Tdftr DatabaseName : user TableName : user.db Active : True Setelah itu klik pada tombol login,dan paste code berikut : if (Enama.Text =Tdftr.Fields[0].AsString) or (EPassword.Text=Tdftr.Fileds[0].AsString) then begin MessageDlg('Maaf user name atau password anda salah', MTWarning, [MBOK], 0); Exit; end; Fmsg.Show end; untuk code pada tombol batal..anda tinggal mengcopy code pada tombol batal yang ada pada form registrasi diatas,karna funginya sama saja.. selesai. note : untuk membuat link sign up pada form login,klik 2x pada label yang tadi anda tambahkan kemudian copy code berikut : fregister.show semoga bisa membantu

Sign up to vote on this title
UsefulNot useful