Oracle BI EE Answers and Dashboards: Getting Started

Lab 2.1 - Oracle BI EE Answers and Dashboards: Getting Started
Section Objectives
At the end of this section, you should be able to: • • • • • Creating a Query and a Chart Working with Pivot Table Creating a Narrative View Creating Column Selectors and View Selectors Creating an Interactive Dashboard

Overview
This lab teaches you how to use Oracle Business Intelligence Answers to create queries, format views, charts, and add user interactivity and dynamic content to enhance the user experience. You create queries and work with views including charts, pivot tables, and narratives. You then create selectors to drive interactivity in your Business Intelligence requests, and build a custom Dashboard to contain the requests and views you've created. Finally, you work with dashboard prompts to filter your dashboard and populate variables. You will perform the following tasks: • • • • • Creating a Query and a Chart Working with Pivot Table Creating a Narrative View Creating Column Selectors and View Selectors Creating an Interactive Dashboard

Creating a Query and a Chart
In this topic you build and format a business intelligence request using Oracle BI Answers, and create and format a chart. You will perform the following tasks: • • • • Create a query Add a filter Create totals and format results Create a chart

Create a query
To create a query, perform the following steps: 1. The BI Servers should already running. If they are not, then start them in your Windows server. 2. Start the BI Dashboards by selecting Presentation Servicces in the Start Menu:

4. Expand the “Calendar” table and click the “Calendar Month Desc” column to add it to your query criteria. . Log in as “Administrator” with a Password of “Administrator” When the page loads. which appears in the right pane.3. select Answers: 5. click the “Plus” icon next to “Times” to expand it. In the left-hand selection pane of the Answers interface.

The Apply Saved Filter dialog box is displayed. this will cover from January to December 2001). add the “Prod Category” column. add “Measures > Sales Facts > Amount Sold (000)”. Drag the “Prod Category” column in front of the columns from the “Calendar” table in your query. From the Products table. Click the “Calendar Month Name” column to add it to your query. 9. Under Filters in the left-hand selection pane. Finally. You can reorder the columns in your query by clicking and dragging them. expand the SH folder and click the “Most Recent 12 Months”. Your query should look like this: 7. The query you are building has one measure and three attributes. . Your query criteria should look like this: 8. Add a saved filter to the query to limit the data to the last 12 months (based on the “SH” data. Now drag the column back to its original location.6.

can issue a query to the BI server. Examine the request XML that defines the view and the logical SQL that will be issued for the query. 10.This filter has been created and saved in a shared folder so that it can be used by other users. The Advanced tab can be made available only to specific users. The XML fully defines the query (including chart formats in case of charts). The SQL defines the content of the query. which has been created in the Oracle BI repository metadata to ensure that it is synchronized with the data. The filter uses a variable defined as the value of the maximum month ID. just like Answers. Click “OK” in the Apply Saved Filter dialog box to add the filter to your query. Note that any query or reporting tool that can issue SQL over ODBC connection. Click the “Advanced” tab. .

including logical SQL and views for the query. click the “All Choices” link to display all values for the column. In the “Create/Edit Filter” dialog box. . perform the following steps: 1. which are added automatically. Editing the logical SQL will change your view definitions. The SQL Issued field contains only the logical SQL that will be issued to the Oracle BI Server for processing. Add a filter To add a filter for the direct channel. using the selection pane. Click the Criteria tab.The Request XML defines the whole analysis. In the criteria pane. add “Channels > Channel Desc” to your query criteria. 2. button on the “Channel Desc” column to add a 3. Note the saw_X column aliases. click the “Filter” filter on that column.

The Limited Choices link will limit choices to those that are consistent with any pre-existing filters. Another way to achieve this result is to CTRL-click the column in the selection pane. The filter is added to the existing saved filter you used earlier. Verify that the Operator for the filter is set to "is equal to / is in" and then click the “Direct Sales” value in the list of choices. but doesn't add the column to the query criteria 7. Direct Sales is added as a value in the filter. 5. Click the “Delete” button (with and X) on the “Channel Desc” column to delete it from the criteria. Your query criteria should look like this: . You are filtering on the channel.4. but you don't need the column in your query. then clicking the All Choices link. Click “OK” to create the filter. You can also limit the list of choices by setting a match criteria using the Match drop-down menu and entering a string. 6. which opens the Create/Edit Filter dialog box with the selected column.

Later. Other ways to view results are by clicking the view buttons below the tabs in the Criteria pane. . As you will see. a Title view and a Table view. By default. or by clicking the Display Results button below the columns in your query criteria. Click the “Results” tab to view the results of your query. you can delete these default views and add other views to the Compound Layout. which contains two other views. 9. you will add these different types of views to a dashboard.8. the results are displayed in the Compound Layout view.

Return to the “Criteria” tab and remove the “Channel Desc” filter you just created by clicking the “X” next to the filter in the Filters section.10. .

Using the view-level controls. the default aggregation rule (SUM) is applied. Click the “Total By” icon above the “Calendar Month Desc” column to add subtotals by month to your results. Open the Edit Table View. import formatting from other queries. perform the following steps: Create totals and format results To create totals and format results. you can also set table-wide formatting properties. The measure is totaled each time the value in “Calendar Month Desc” changes. In this case.Creating Totals and Format Results To create totals and format results. 1. icon for the The column controls for each column are displayed with the results. but can be overridden using controls in the “Edit Formula” dialog box accessed through the Edit Formula icon in the Edit Table view or the Criteria tab. The default aggregation rule is set in the Oracle BI repository metadata. click the “Edit view” “Table” View in the “Compound Layout”. . perform the following steps: Click on the “Results” tab. and set grand totals for the entire table.

In the Display drop-down menu. select “Results Only” to eliminate the Header Toolbars.2. 5. select “Header Toolbars with Results” to access the Header Toolbars. In the Display drop-down menu. Verify that the grand total that you set for the results is present. . Scroll down to the bottom of the Results pane and click the “All Pages” button to navigate to the end of your results. 3. 4. Click the “Grand Total” button at the view level to add a grand total to your results.

. 7. or for all columns with the same data type. then select “Use 1000's Separator” option and click “OK”. This will display a comma separator in the number results for the column. Click the “Column Properties” icon above the “Amount Sold (000)” column. you can save the data format as the system-wide default for the column you are working with. In the Column Properties dialog box. If you have permissions as a Web administrator. click the “Data Format” tab. click in the dialog box to close the Save menu.6. Observe the Format save options available as a Web Administrator. Since you don't want to set this format as the system-wide default. In the “Edit Column Format” dialog box. select the “Override Default Data Format” option. click the “Save” button.

Click “OK” and verify that a 1000's separator is displayed in the results for the “Amount Sold (000)” column.8. .

Creating a Chart To create a chart. Pick “Chart” in the “View” menu. . perform the following steps: 1. 2. Select “Line” from the Graph drop-down menu and “2D” from the Type drop-down menu. By default charts are displayed as a Vertical Bar graph.

The available axes can change depending on the type of chart selected from the Graph drop-down list. You can also indicate whether measure labels appear for factual data plotted on an axis. change the custom title to “Calendar Month”. select “Prod Category” to create a separate line in the chart for each product category. 4. . select “Custom Title” and change the custom title to “Amount Sold”. You can select the columns to display as the different axes in the chart. In the Left tab of the Axis Titles & Labels dialog box. The column area of the chart view shows the columns that are included in the request. In the Bottom tab.3. Under the “Legends” icon in the column area of the left side of the “Chart” view. Click the “Axis Titles and Labels” icon. Click the “Redraw” button at the bottom to confirm the change.

For example.5. Click “OK”. Your chart should look like this: 6. enter “Category Sales Last 12 Months” as the chart title. you can toggle whether scale labels are displayed on the axes and set orientation guidelines for your labels. . and click “OK”. you can set overrides for the default data format on measures. select “Custom Title”. In the General dialog box. Explore some of the other options in the “Axis Titles & Labels” dialog box. similarly to the modification you made to the amount sold column in the steps above. In addition. Click the “General Chart Properties” icon.

After you've set both colors. Click the color box for Background Color and. in the Color Selector dialog box. using the same method as above. click “OK” to apply your changes.7. click the “Grid Lines” tab and set the major grid line color to white and the minor grid line color to light gray. select light gray from the palette and click “OK”. In the Additional Charting Options dialog box. . click the “Borders & Colors” tab and set the background color to light gray. 8. Click the “Additional Charting Options” icon. In the Additional Charting Options dialog box.

Your chart should look like this: 10. Sort the legend by sorting the data.9. You want to sort by month in ascending order and then by sales in the last month in descending order: • Click the Criteria tab and add the “Measures > Sales Facts Current Month > Amount Sold (000) Current Month” column to your query: .

• Click the “Order By” button in the Calendar Month Desc column. The arrow points down to indicate a descending sort. The arrow points up to indicate an ascending sort. and the number 2 is displayed to indicate a secondary sort. . The legend is sorted to match the order of the lines in the last month. 13. 11. Select “Compound Layout” from the View drop-down menu. Click the “Order By” button in the “Amount Sold (000) Current Month” column twice. 12. Click the “Results” tab to verify that your sort has been applied to the legend in your chart.

14. 15. Click the “Add View” link and select “Chart” to add the Chart view to the Compound Layout view. . A yellow line (or blue) will appear when you have a valid insertion point. Scroll to the bottom of the Compound Layout view and drag the Chart view above the Table view in the Compound Layout.

Click the “Delete View” icon in the Title view to delete it from the Compound Layout. . click the “Learn” folder. In the Choose Folder dialog box. 17. Enter “Category Sales” as the name and click “OK”. and then click the “Create Folder” button. In the Save Request dialog box. In the Create Folder In Shared Folders dialog box.16. enter “Learn” and click “OK”. Click the “Save Request” icon. click “Shared Folders”. 18.

.

When you see a blue line appear around the control. you will only view your results periodically. Examine the default pivot table that's created and displayed below the layout controls. Pick “Pivot Table” in the View menu. This opens the Pivot Table Layout page. Drag the “Amount Sold (000) Current Month” column from the Measures area to the Excluded area in your layout controls.Working with a Pivot Table In this topic you create a pivot table to examine your results and add calculations and formatting. perform the following steps: 1. This option displays the results of any layout modifications you make as you work in the Pivot Table layout. Measure labels for the measures in your query appear in blue as columns in the pivot table. 4. 2. . The measures are displayed at the intersection of the rows and columns. Deselect the “Display Results” option. 3. • • Create and set basic layout for a pivot table Add calculations and formatting to the pivot table Create and set basic layout for a pivot table To create and set the basic layout for a pivot table. Row headings for the dimensional attributes in your query are displayed in grey as rows by default. To speed performance. you have a valid insertion point and can drop the column.

5. Click the “Display Results” link to verify your changes in the pivot table. you have a valid insertion point and can drop the column. Your pivot table should look like this: . 6. Drag the “Calendar Month Name” column below the Calendar Month Description in the Columns area in your layout controls. Drag the “Calendar Month Desc” column below the Measure Labels in the Columns area in your layout controls. 7. When you see a blue line appear.

Add calculations and formatting to the pivot table. . Deselect the “Display Results” link.8.

Adding Calculations to a Pivot Table To add calculations and formatting to the pivot table. perform the following steps: 1. Click the “More Options” icon in the duplicated measure and select “Format Headings”. You need to add a measure to your pivot table to display the percentage of total monthly sales for each product category. 3. . 2. Duplicate the “Amount Sold” measure. change the caption to “% of Period” and click “OK”. In the Edit Format dialog box. Click the “More Options” icon in the “Amount Sold (000)” measure and select “Duplicate Layer”.

5. Click the “More Options” icon in the duplicated measure and select “Format Headings”. In the Edit Format dialog box. Click the “More Options” icon in the duplicated measure and select “Show Data As > Percent of > Column“. . 6.4. 7. Also note the other formatting options available in the dialog box. change the caption to “% of Period” and click “OK”.

you can present a measure as a percentage of the total amount for any dimension present in the pivot table layout. To total the values of the rows in each column. which is Month. Click the “More Options” icon in the duplicated measure and select “Show Data As > Percent of > Column“. . click the “Total” icon in the Rows layout control and select “After”. Note the other options that are available. for example a row or a section. This setting means that the measure will be displayed as a percentage of the column. Also note the other formatting options available in the dialog box.8. 9. You can also set alternate aggregation rules for the measure using the Aggregation Rule option (the default is Sum).

drag “Measure Labels” under “Calendar Month Name” in the Columns layout control. Click the “Display Results” link. 11. To show both measures together within each calendar month. click the “Total” icon in the Columns layout control and select “After”. Click the click the “More Options” select “Hidden”. 10. Your pivot table should look like this: . 14. To add totals for each column in each row. icon in the “Calendar Month Desc” column and 13.Note that you have formatting options available for the total row labels as well as values. Your pivot table should look like this: 12. Click the “Display Results” link.

Effective use of these would require additional attributes. Click “Yes” when prompted to replace on top of “Category Sales”. . Experiment. if you want. Save the request by clicking the “Save Request” icon. 15.Note that there are section and page levels of the pivot table that we have not used in this example. by temporarily dragging Prod Category to section and then page. Keep the same name and folder location.

The Narrative view allows you to add text to appear with the results to provide information such as context. and select the Sales History subject area by clicking the “SH” link in the Subject Areas list. 2. then click “OK”. or extended descriptions. . perform the following steps: 1. You want a query to detail what happened in the most recent month. and create and format a Narrative View. pointing out all product categories where sales are less than the previous month. select the “is less than” operator.Creating a Narrative View In this topic you build and format a business intelligence request using Oracle BI Answers. In the left selection pane of the Answers interface. • • • Create a query Add a filter Create a Narrative view Create a query To create a query. Click “Answers” to navigate to the Answers start page. explanatory text. 4. Add “Measures > Month Ago Facts> % Chg Amount Sold MAgo“ to your query. In the “Create/Edit Filter” dialog box. Your query should look like this: 5. and enter 0 as the value. 3. expand the “Products” table and click the “Prod Category” column to add it to your query criteria.

Click “OK”. . The filter is added to the existing saved filter you used earlier. Under Filters in the left selection pane. This filter has been created and saved in a shared folder so that it can be used by other users. 7.6. expand the “SH” folder and click the “Current Calendar Month” filter. The filter uses a maximum month variable defined in the Oracle BI repository metadata to ensure that it is synchronized with the data. Your filters should look like this: Add a saved filter to the query to limit the data to the current calendar month.

Adding a Filter To add a filter for the percent change in the amount sold. The filter is added to the existing saved filter you used earlier. then click “OK”. Your results should look like this: . Your filters should look like this: 4. 3. 2. select the “is less than” operator. Click the “Display Results” button to view the results of your query. In the “Create/Edit Filter” dialog box. and enter 0 as the value. click the “Filter” button on the “% Chg Amount Sold MAgo” column to add a filter on that column. perform the following steps: 1. In the criteria pane.

Create a Narrative view To create a narrative view. 3. “Prod Category”. select @1 in the narrative and click the Bold button. 2. In this example. and @2 refers to the second column. To highlight the column values in the narrative. Select “Narrative” from the View drop-down menu. all queried rows are displayed. . @1 refers to the first column in the query. Also add bold tags to @2%. In the “Narrative” view workspace. perform the following steps: 1. enter the following: “@1 declined @2% this month compared with last month” in the Narrative field. “% Chg Amount Sold MAgo”. The narrative is a combination of text and query column values. Note that you can control the number of row values returned in the Narrative view by setting the Rows to display value. By default.

Select “No Results” from the View drop-down menu.4. enter “No categories declined this month!” as the headline. Your results should look like this: 5. You need to create a No Results view to appear when there are no results for the query. In the “No Results” view workspace. 6. Enter “All categories had positive sales results compared with the previous month” as text. .

Your results should look like this: 8.7. Click the “Save Request” icon. select the “Learn” folder and save the request as “Narrative and No Results Views”. In the Choose Folder dialog box. .

Click the “Results” tab and select “Column Selector” from the View drop-down menu. Click the “Answers” link and open the first query you saved. Column selectors allow users to select from a group of columns. In the selection pane.Creating Column Selectors and View Selectors In this topic you build Column and View Selectors and experiment with their use in requests and dashboards. Click the “Modify” button. for example viewing different charts of the same data or quickly navigating to a pivot table to do trend analysis. View Selectors allow users to quickly navigate between different views of their queries. perform the following steps: 1. 3. . • • Create a Column Selector Create a View Selector Create a Column Selector To create a Column Selector. click “Shared Folders > Learn > Category Sales”. 2. substituting columns in their queries for comparative analysis.

Channel Desc. 6. currently “Prod Category”. and Channels. 5.Country. click the following columns to make them available in the Column Selector: Customers.4.Country Region. Your Column Selector in the results pane should look like this: . Customers. In the selection pane. Select the “Include Selector” option in Column 3.

Click the “Add View” link and select “Column Selector” to add the Column Selector view to the Compound Layout view. Notice that views that you have built for the active request appear in the View and Add View drop-down menus with green circle icons next to them. Select “Compound Layout” from the View drop-down menu. 8. .7.

Click “Yes” when prompted to replace on the previously created “Category Sales” request. Switch the column back to Channel Desc. . 11. as does the chart. Your Compound Layout view should look like this: Note that the third column in the table now reflects values for the Country column. 10.9. select “Country”. Save the request. In the Column Selector. 12. Scroll to the bottom of the Compound Layout and drag the Column Selector view above both Table and Chart views.

• You should now have a new view. • Click the “Menu” icon and select “Duplicate View”. Select “View Selector” from the View drop-down menu.Create a View Selector To create a View Selector. “Chart:2”: • In the Type drop-down menu. perform the following steps: 1. navigate to the “Chart” view. Duplicate the existing chart: • Using the Views menu. . select 3D. 2.

In the View Selector design workspace. and. 5.3. and “Pivot Table” in the “Available Views” field. 4. “Chart:2”. click the “Rename” button. Select “Chart” in the Views Included field. rename it “2D Chart”. in the Rename dialog box. Click the “Move Right” icon to add them to the Views Included field. Click “OK”. using CTRL + Right Click to select multiple views. select “Chart”. .

8. Rename “Chart:2” as “3D Chart” and “Pivot Table” as “Trend Data”. 3D Chart. Trend Data. Add the “View Selector” view using the “Add View” button and drag it above the “Table” view. .6. Use the View drop-down menu to navigate to the Compound Layout view. Delete the “Chart” view from the Compound Layout. Use the Move buttons to arrange the views in the list as follows: 2D Chart. 7.

Click “Yes” when prompted to replace on top of “Category Sales”. Select “Trend Data” from the View Selector. . 10.9. Keep the name as “Category Sales” and click “OK”. Your chart should now change to the Pivot Table view: 11. Save the Request.

set the Group Folder to “CountryManagers”. Click the “Settings” link and select “Administration”. In the Manage Dashboards window. name the dashboard “CountryManagers2”. 2. 3. click the “Manage Interactive Dashboards” link. .Creating an Interactive Dashboard In this topic you build a new shared Interactive Dashboard and add content you've saved in previous steps. perform the following steps: 1. In the “Create Dashboard” window. The Oracle BI Presentation Services Administration window offers access to many administrative features. To create an Interactive Dashboard. In the Oracle BI Presentation Services Administration window. including session monitoring and management of user and group privileges across the Oracle BI Presentation Catalog. click “Create Dashboard”. and click the “Finished” button. 4.

6. Finally. 5. Click “Finished” again to close the “Manage Dashboards” window. Your new dashboard is empty and should look like this: . Click the “Dashboards” link and then click the “CountryManagers2” Interactive Dashboard link to navigate to the new dashboard.The dashboard inherits the security of the group folder. click “Close Window” to close the Oracle BI Presentation Services Administration screen.

you can drag saved content from your Presentation Catalog directly into the dashboard. Drag the “Narrative and No Results” request into Section 1 of the dashboard layout.7. Click the “Page Options” button in the upper right corner and select “Edit Dashboard” to open the Dashboard Editor. 9. 10. Drag the “Category Sales” request onto the layout workspace. 11. You could also have dragged a Section object from the Dashboard Objects palette to create the section before dragging content into the section. In the Dashboard Editor. . Sections are automatically created in the layout to contain the requests and other objects you add to the dashboard. 8. expand the “Learn” folder where you've saved your work. In the left-hand selection panel. Sections and columns are containers you can use to control the layout of your dashboards. The layout area is highlighted in blue to indicate that you have a valid insertion point for the object. below the “Category Sales” request. Your dashboard layout should look like this: Notice that a section was automatically added to contain the request.

select “Properties > Show View > Narrative 1” to ensure that when the dashboard is presented. The Compound Layout is the default view. 14. The No Results view is always displayed if there are no results for the request at runtime. Click “Save” to save your changes and display the dashboard. Your dashboard should look like this: . the request will be in the Narrative view. In the “Narrative and No Results” object. note that the list is limited to views which you've created or worked with for the request. 13.12. 15. You can select any other view.

Leave the Answers tool open and logged in for the next topic. 18. Scroll to the bottom of the dashboard to verify that the narrative view appears correctly for the “Narrative and No Results” embedded request. It should look like this: Note that the Column Selector only applies to the request that contains it. Congratulations! You have successfully built your first Dashboard. . 17.16. not the narrative request in the same dashboard. it will only apply to the table and chart. If you select a column in the control.

Sign up to vote on this title
UsefulNot useful