A.

Introduction
C-Free là một môi trường phát triển tích hợp (IDE) của ngôn ngữ C/C++, hộ trợ nhiều trình biên dịch. Với phần mềm này bạn có thể soạn, build, chạy và gỡ rối chương trình thoải mái. Được tích hợp bộ phân tích mã nguồn, mặc dù C-Free là một công cụ phát triển nhẹ trên ngôn ngữ C/C++ nhưng nó có những tính năng mạnh mẽ cho phép bạn tận dụng nó cho project của mình Các tính năng bao gồm: 1. Hỗ trợ nhiều trình biên dịch, bao gồm: a. MinGW 2.95/3.x/4.x/5.0 b. Cygwin c. Borland C++ Compiler d. Microsoft C++ Compiler e. Intel C++ Compiler f. Lcc-Win32 g. Open Watcom C/C++ h. Digital Mars C/C++ i. Ch Interpreter 2. Tô sáng cú pháp ( tô sáng hàm, kiểu dữ liệu, hằng, vv..) 3. Smart Input – hỗ trợ soạn mã nguồn tốt hơn 4. Hỗ trợ thêm nhiều loại Project 5. Tiện ích tìm kiếm trong mã nguồn mạnh mẽ, cho phép nhảy tới dòng khai báo, định nghĩa 6. Tự động hoàn thành mã và Code parameters; 7. Liệt kê tất cả các các ký hiệu của chương trình 8. Có thể tuỳ biến các tiện ích a. Shortcuts; b. External Tools; c. Help ( hỗ trợ nhiều định dạng và cả trên web) 9. In màu ( in ra mã nguồn với cú pháp đã được tô sáng) 10. Hiện console window khi gỡ rối; 11. Chuyển đổi các project sang định dạng của C-Free

B.

Quick Start (Bắt đầu luôn)
1. Build và chạy một file đơn

C-free có thể dịch một file đơn thành một chương trình đơn giản theo các bước sau a. Khởi động C-free b. Bấm nút “New File” (Ctrl + N) trên thanh công cụ, một vùng để soạn thảo còn trống xuất hiện ở bên phải. Bấm chuột phải và chọn “Code Template” sau đó chọn “C template” từ menu popup

c. Đoạn mã sau sẽ xuất hiện #include <stdio.h> int main(int argc, char *argv[]) { return 0; } Sửa đổi đoạn mã trên: chèn một lệnh vào trước dòng “return 0”: printf("Hello, C-Free!\n") Sau đó lưu lại file với tên hellp.c rồi bấm nút Run ở trên thanh công cụ. C-Free sẽ bắt đầu built file này.Thông tin xuất ra sẽ được hiện ở cửa sổ Message. Bởi vì có một lỗi trong chương trình trên nên có một thông báo lỗi hiện ở cửa sổ Message. Bấm kép lên mẩu thông báo đó, chương trình sẽ nhảy đến dòng có lỗi và đổi màu nó. Sửa lỗi : Thêm dấu ; vào sau lệnh printf() .Run lại một lần nữa, chương trình sẽ built thành công. Dưới đây là kết quả chạy chương trình

Bạn có thể nhấn một phím bất kì hoặc click “Stop running” trên thanh công cụ để thoát khỏi console

2.

Tạo và Build một Project

Khi bạn làm việc với một chương trình lớn, và có nhiều file nguồn bạn có thể tạo ra một Project để quản lý các file nguồn đó. Với Project, C-Free có thể liên kết tất cả các file nguồn với nhau và build thành một chương trình sau khi chúng được dịch mà không có lỗi. Làm theo các bước dưới đây a. Vào menu “Project” và chọn “New..” hộp thoại “New Project” xuất hiện

Bây giờ bạn có thể lựa chọn loại Project, chẳng hạn “Console Application” nhập tên Project và chọn OK, sau đó hộp thoại hướng dẫn xuất hiện

Trong hộp thoại này chúng ta chọn “Application Type” là “An empty project”, chúng ta nhảy qua 2 bước và chọn “Next” hộp thoại thứ 3 xuất hiện

Trong hộp thoại chúng ta lựa chọn “Build Configurations” là “Mingw2.95” sau đó chọn “Finish”. Một Project trống đã được tạo ra nhưng nó không chứa một file nào cả b. Tạo ra 2 file mới, nhập đoạn mã dưới đây vào 2 file:

i). } /* a2.c */ #include<stdio.c */ #include<stdio. } Sau đó lưu 2 file này với tên tương ứng là “a1./* a1. chọn Yes và một hộp thoại khác xuất hiện . /* an extern varia void func() { printf("%d\n". i++.h> extern int i. func().h> int i. printf("%d\n". /* a global variable */ void func().c”.i). void main() { i=3. printf("%d\n".i).c” và “a2. sau khi lưu file một hộp thoại xuất hiện hỏi bạn có thêm file đã được lưu vào project hiện tại không. i+=2.

Nếu không có lỗi C-Free sẽ tạo ra một chương trình từ Project này và chạy nó . Cửa sổ cây thư mục “File Tree Window” hiện trạng thái của project sau khi thêm 2 file được lưu vào Project Bạn có thể tạo thư mục của mình trong Project.Trong hộp thoại này lựa chọn thư mục “Source Files” và ấn OK. và thêm file bạn muốn vào thư mục c. file vừa lưu được thêm vào project. Click vào “make ank Run” trên thanh công cụ để Build project này.

Toolbar chứa một vài lệnh hay dùng nhất. Tab bar liệt kê tất cả các file đang mở. Toolbar . File Tree window liệt kê tất cả file đang mở và file trong project đang mở. để chuyển qua lại giữa chúng. Message Window thông báo kết quả quá trình dịch 2.Tab bar -Code Editor (vùng soạn thảo) -Symbol windows -Message Window -File Tree Window -Status bar Menu chính (main menu) bao gồm hầu hết các lệnh của C-Free (một phần lệnh nằm trong các menu ngữ cảnh. Chương trình của bạn được mở trong Code Editor.Windows 1. Main window Cửa sổ chính chia thành các phần -Menu chính và thanh công cụ toolbar .

Có thể ẩn. 2.Toolbar gồm có 5 thanh công cụ con.2 Search Chứa lệnh tìm kiếm và lệnh liên quan đến vị trí con trỏ. Toolbar chứa các lệnh hay dùng nhất 2.1 Standard Thanh công cụ chuẩn chứa lệnh cơ bản về file và project 2. hiện các toolbar con này trong View>>Toolbar. chứa lệnh để gỡ rối .4 Debug Thanh gỡ rối sẽ hiện lên khi gỡ rối.3 Build/Execute Chứa lệnh dịch và chạy chương trình 2.

mã chương trình hiện ở đây để bạn xem và sửa nó. Tab của file thông thường và file của project được vẽ khác nhau: Bấm chuột phải lên các tab để đóng mở các file này 4. Khi mở 1 file C/C++. Breakpoint cũng sẽ hiện lên Ngoài mã chương trình vùng soạn thảo còn hiện .2. giúp chuyển nhanh giữa các file này. Nếu file được mở thuộc về một project đang mở. khi mở. Khi mở file. C-Free sẽ phân tích cú pháp file này và đưa các kí hiệu vào cửa sổ Symbol window và symbol panel để sử dụng. Tab bar Nó chứa tab của tất cả các file đang mở. con trỏ sẽ tự nhảy tới vị trí lần trước được lưu của nó.5 Help Chứa 2 lệnh liên quan đến Help 3. Code Editor Nằm ở trung tâm trong cửa sổ chính.

. theo mặc định những dòng sửa đổi chưa lưu chỉ thị bằng màu vàng. cơ sở dữ liệu về vị trí con trỏ. tự động thụt đầu dòng. Vào menu Tool>> “Editor Properties” để mở hộp thoại thiết lập cấu hình cho Code editor 5. File Tree Window Cửa sổ này liệt kê tất cả các file và file của project đang mở. và những dòng đã lưu được chỉ thị bằng màu xanh: -Số thứ tự của dòng -Bookmark đánh dấu -Màu khác cho dòng Code Editor cũng còn một số tính năng khác như hỗ trợ undo/redo nhiều lần.-Line Indecator (chỉ thị dòng) .

biến toàn cục và hàm trong project đang mở. có thể xem thông tim về tệp hoặc đổi tên nó trong cứa sổ này. bởi một bộ phân tích mã và tự đông cập nhật lúc soạn mã . Có thể vào menu View>> “File Tree Window” để hiện.Các project đang hoạt động có font chữ đậm. Cửa sổ này có thể để ở bên mé trái hoặc mé phải của màn hình soạn thảo. cũng có thể nổi lên trên cửa sổ chính. 6. ẩn cửa sổ này. macro. Class Window Cửa sổ này hiển thị tất cả khai báo lớp.

cũng có thể nổi lên trên cửa sổ chính.Cửa sổ này có thể để ở bên mé trái hoặc mé phải của màn hình soạn thảo. 7. File Browser Window Đây là một trình duyệt file . ẩn cửa sổ này. Có thể vào menu View>> “Class Window” để hiện.

Các kiếu kí hiệu khác nhau hiển thị bằng các biểu tượng khác nhau.8. Symbol panel nằm bên trên vùng soạn thảo. . Symbol Window/Panel Symbol window nằm bên trái vùng soạn thảo. tự động cập nhập trong quá trình soạn mã. Symbol window liệt kê tất cả các tên trong file hiện tại.

-Symbol Interpretation: Hiện khai báo của kí tự dưới con trỏ -Quick Find Sử dụng nút Quick Find để đặt con trỏ tới vị trí định nghĩa của kí hiệu dưới con trỏ hiện tại . Message Window .Symbol Panel chia làm 3 phần -Code Scope: Hiển thị phạm vi con trỏ đang đứng. “Jump to declaration” và “find Reference” 9. trong menu ngữ cảnh của nút này có 3 lệnh “Jump to Definition”.

Cửa sổ này hiện 2 loại thông điệp: thông báo của trình biên dịch và kết quả tìm kiếm file. Dưới đây là thông báo sau khi biên dịch Có thể thiết lập kiểu font. định dạng chữ cho thông điệp này Bấm chuột phải lên Message Window>> Properties để thiết lập tính chất của thông báo .

con trỏ vẫn ở chỗ cũ Đưa con trỏ về đầu dòng Đưa con trỏ về cuối dòng Đặt con trỏ vào trước dấu đóng mở ngoặc nhọn { hoặc } và nhấn tổ hợp phím này con trỏ sẽ nhảy qua lại vị trí 2 dấu đóng .Lệnh 1. Edit -Shift+Ctrl+C -Shift+Ctrl+I -Shift+Ctrl+U -Ctrl+J -Ctrl+H -Ctrl+C -Ctrl+X Chép thêm dữ liệu vào clipboard Thụt đầu dòng một khối văn bản được chọn Huỷ lệnh thụt đầu dòng một khối văn bản ở trên Mở danh sách đoạn mã mẫu Đóng . mở một cặp ngoặc tương ứng tạo một file mới Mở file đã có Lưu file Lưu tất cả sửa đổi của tất cả file và project -Ctrl+ -Ctrl+Y -Ctrl+T -Ctrl+End -Ctrl+Home -Ins -Ctrl+L -Home -End -Ctrl+Shift+B . mở chế độ cho phép bôi đen một khối văn bản theo cả cột nữa Copy đoạn văn bản được chọn vào clipboard Copy đoạn văn bản được chọn vào clipboard rồi xoá nó trên màn hình soạn thảo Xoá từ ngay sau con trỏ Xoá dòng có con trỏ Xoá từ ngay sau con trỏ Đưa con trỏ xuống cuối cùng trong trình soạn thảo Đưa con trỏ về đầu văn bản Chuyển giữa chế độ chèn và đè Chèn một dòng trắng vào sau dòng có con trỏ. File -Ctrl+N -Ctrl+O -Ctrl+S -Shift+Ctrl +S 2.

Hoặc ấn Shift+Ctrl+(Phím số) Có thể lập 10 bookmark cho mỗi file Để nhảy tới bookmark đã đánh dấu dùng tổ hợp phím Ctrl+Số -Ctrl+F -Ctrl+Shift+F -Ctrl+F12 -F12 -Alt+.1. Bookmark Đặt con trỏ xuống cuối một trang Đặt con trỏ lên đầu một trang Dán nội dung trong Clipboard vào đoạn văn bản Redo. -Ctrl+R 4.--Ctrl+PageDown -Ctrl+PageUp -Ctrl+V -Shift+Ctrl+Z -Ctrl+A -Ctrl+Z 3. Build -Ctrl+F11 mở hộp thoại tìm kiếm Mở hộp thoại tìm kiếm trong các file Nhảy tới phần khai báo của kí tự sau con trỏ Nhảy tới phần định nghĩa của kí tự sau con trỏ Nhảy tới vị trí con trỏ sau đó (trong bộ nhớ) nhảy tới vị trí con trỏ trước đó tìm kiếm và thay thế biên dịch và chạy project hoặc nếu file hiện tại . quay lại một bước Có thể lập một “bookmark” để đánh dấu một vị trí trong file.Đặt con chuột vào dòng muốn đánh dấu 2. Từ menu Search. để cho phép dùng chuột hoặc lệnh từ bàn phím nhảy tới vị trí đó. Search 3. Để tạo một bookmark: 1. -Alt+. huỷ bước Undo trước đó Chọn cả văn bản undo. chọn Toggle Bookmark. Mỗi bookmark đánh dấu một dòng.

chạy chương trình vừa sinh ra sẽ chạy. Debug F10 Thêm/xoá Breakpoint Dùng để dừng chương trình đang chạy tương ứng lệnh Run Dừng quá trình biên dịch(compiler) . bắt đầu quá trình liên kết Nếu không lỗi.-Clean trong khi build hoặc make có nhiều file trung gian được tạo ra. chương trình sinh ra không chứa thông tin debug. make. nếu không có lỗi sẽ tạo ra các file OBJ chứa mã máy khả chạy. và dĩ nhiên luôn được tối ưu -Shift+F11 Make một file hoặc project Making là quá trình: 1. -F5 Run: 1. sau khi liên kết những file này với thư viện hệ thống sẽ tạo ra file chương trình -F11 -Debug/Release Chuyển giữa 2 chế độ Debug và chể độ Release của cấu hình Build hiện tại -Build với chế độ Debug. 3. 2. 4. dùng lệnh này để dọn sạch các file đó Biên dịch file hiện tại. bạn có thể thay đổi tham số và ứng dụng chủ bằng cách sử dụng lệnh “parameters” Ctrl+F5 Stop 1. Nếu file khả chạy này là một thư viện liên kết đông hoặc tĩnh. 5. file đang mở sẽ được kiểm tra). 2. build . Lưu và biên dịch các file có thay đổi Nếu không có lỗi. chạy chương trình vừa sinh ra là quá trình Chạy lệnh Make Nếu Make không lỗi. file chương trình sinh ra chứa cả thông tin để giúp quá trình debug -build ở chế độ Release. Kiểm tra thay đổi trong tất cả file của project hiện tại ( nếu không có project nào mở. 2. ứng dụng chủ sẽ được khởi động và chạy. Khi chạy tham số số sẽ được thêm vào dòng lệnh.

Nếu Make thành công. 2.Alt+6 Alt+4 Alt+5 Ctrl+F8 F9 Ẩn. Chạy lệnh “Make”. chương trình không chứa bất cứ thông tin debug nào. bắt đầu quá trình debug Nếu chương trình tạo ra được built với chế độ “Release”. hiện cửa sổ “Console” khi gỡ lỗi Ẩn hiện cửa sổ “Local” khi gỡ rối Ẩn hiện cửa sổ Memory khi gỡ rối Chạy tới vị trí con trỏ Bắt đầu Debug Quá trình debug là quá trình 1. -------------------------------------OK ------------------------------------F7 Step Into Sử dụng lệnh này để bước vào mã lệnh trong hàm khi gỡ rối Shift+F7 F8 F9 Alt+3 6. Window Alt+  chuyển sang tab tiếp theo bên phải Bước ra ngoài một hàm và trở về vị trí gọi nó khi gỡ rối Step Over Stop Debug mở cửa sổ Watch khi gỡ rối . C-Free sẽ hiện thông báo sau -------------------------------------C-Free -------------------------------------No debugging symbols found target file Please rebuild the file/project with Debug configuration. và không thể Debug.

Alt+ Chuyển sang tab bên trái Alt+X Đóng file hiện tại .

com/download/bcppbuilder/freecommandLinetools.5 trong C-Free.borland. 1. Bấm next để nhảy qua trang chào mừng . bạn cũng có thể tải trực tiếp từ địa chỉ sau: ftp://ftpd.Compiler Support 1.com/Free.aspx?id=24778 Bạn cần đăng nhập với một developer user để tải về. Borland Dưới đây là các bước hướng dẫn bạn sử dụng trình biên dịch Borland C++ 5.codegear.1 cài đặt trình biên dịch Borland C++ Bạn có thể lấy Borland C++ Compiler từ địa chỉ sau: http://cc.exe Sau khi tải về ta sẽ cài đặt nó.

Trong trang này bạn có thể lựa chọn thư mục cài đặt trình biên dịch. 1. Bật C-Free. bạn có thể chọn thư mục khác sau đó ấn “Finish” để bắt đầu cài đặt. Thư mục ngẫu nhiên là “C:\Borland\BCC5.2 Cấu hình trình biên dịch Sau khi cài Borland C++ Compiler 5.5”.5 để sử dụng nó trong C-Free bạn cần thiết lập một số cấu hình đơn giản cho trình biên dịch này. vào menu “Build”>> “Build Options” hộp thoại mở ra .

hộp thoại “Compiler Location” xuất hiện .Bấm vào nút “>” chọn “New Configuration” Hộp thoại “New Configuration” xuất hiện Chọn Builder Type là “Borland C++ Compiler” và nhập Configuration Name là “bcc5. sau khi bấm “OK”.5” (có thể chọn tên bạn muốn).

5.Trong hộp thoại này chọn thư mục đã cài đặt Borland C++ 5. Nếu C-Free không tự phát hiện được. bạn hãy chọn “Location Manually” để tìm thư mục đó .

5” (hoặc tên mà bạn đã chọn) làm lựa chọn biên dịch 2.Cuối cùng chọn “OK”.com/download/ . Mỗi lần muốn sử dụng bạn chỉ cần chọn “bcc5. 2.softintegration.1 Ch Cài đặt Ch Bạn có thể tải gói cài đặt mới nhất từ website của Ch http://www. Bây giờ c-free của bạn đã có khả năng bắt lỗi giống hệt Turbo C của thầy và hoàn toàn thích hợp cho việc làm bài tập C/C++.

2 Cấu hình Ch Sau khi cài Ch để dùng nó ta cần cấu hình cho nó Vào menu Build >> Build Options. tới hộp thoại “choose Destination Location” i Trong hộp thoại này bạn cần chọn thư mục cài đặt Ch. Ch Projessional Edition và Ch Control System Toolkit chỉ miễn phí cho mục đích học tập.Ch cung cấp 2 phiên bản của gói để bạn tải về. Ch Standard Edition là bản miễn phí. một hộp thoại mở ra. 2. ta nhảy qua trang chào mừng và giấy phép. run ch –d To create a Ch startup configuration file (_chrc in Windows) in your home directory. Sau khi cài đặt. . có thể tải về và dùng tự nhiên. nếu là lần đầu tiên chạy Ch. Ở đây chúng ta sẽ cài bản Standard để minh hoạ Sau khi bắt đầu cài đặt. sau đó chọn Next.

bấm OK.Bấm nút “>” chọn New Configuration. và nhập “Configuaration name” là “ch” hoặc tên bạn muốn. hộp thoại “Compiler Location” hiện ra . hộp thoại mở ra Bạn chọn “Build Type” là “Ch Interpreter”.

nếu không thì chọn “Locate Manually” để tìm thư mục đó. sau đó chọn OK. . tất cả đường dẫn của Ch tự động được them.C-Free có thể phát hiện ra bộ cài Ch như hộp thoại trên.

dùng nhiều trình biên dịch có thể cho giải pháp toàn diện hơn. . 6. Hãy chỉnh sửa môi trường phát triển C++ kết hợp 3 hay 4 trình biên dịch.Kích OK. Không có trình biên dịch nào đáp ứng được mọi yêu cầu. thế là xong 2. trong bước cuối cùng của trình thuật sĩ. 5. 3. bạn có thể chọn cấu hình này để build project của bạn.3 Sử dụng Ch Sau khi cấu hình Ch interpreter bạn có thể dùng Ch trong C-Free bằng cách sử dụng cấu hình vừa tạo của Ch để build file Khi tạo một project mới. Digital Mars MinGW Cygwin Open Watcom Mặc định đã được cài sẵn vào C-Free Những trình biên dịch thông dụng nhất là Borland. Về phương diện này thì Borland và Visual C++ tỏ ra đặc biệt kém. Hơn nữa không gì tốt hơn là làm cho mã nguồn của bạn có khả năng làm việc với nhiều trình biên dịch. Visual C++ và MinGw của GCC. bạn sẽ thấy chất lượng chương trình của mình tăng lên rõ rệt. Tất cả giới dùng C++ chuyên nghiệp đều không dùng duy nhất một trình biên dịch. 4.

Hộp thoại Breakpoint xuất hiện. Quản lý breakpoint bằng hộp thoại này . xoá một “Breakpoint” Có 2 cách thêm một Breadpoint -Di chuyển con chuột tới bên trái mép trái vùng soạn mã. làm lại như thế để bổ breakpoint Khi một dòng có breakpoint ta gọi nó là dòng breakpoint. 4. bấm chuột trái. DEBUG C-Free cung cấp một số chức năng gỡ rối cơ bản 4.1 Thêm. Chỉ cần bâm chuột vào nút màu đỏ một lần nữa để bỏ breakpoint đó -đặt con trỏ tại dòng cần thêm breadpoint và ấn F10 hoặc nút Add/Remove Breakpoint trên thanh công cụ.4. Sau đó C-Free sẽ tô sáng dòng đó và hiện một breakpoint được thêm như hình dưới đây.2 Quản lý breakpoint Vào menu Debug>>Breakpoint.

4.3 Điều kiện cho breakpoint Bạn có thể chỉ định một điều kiện cho breakpoint. thanh công cụ để debug sẽ xuất hiện. nhập một điều kiện vào Condition và ấn nút Set 4. Từ hộp thoại breakpoint ở trên. Điều kiện là một biểu thức boolean trong ngôn ngữ C. Khi gặp breakpoint điều kiện chương trình chỉ dừng lại nếu điều kiện là đúng. Bấm lên nút này để chương trình chạy tới khi gặp breakpoint tiếp theo hoặc kết thúc.5 Dừng Debug . Chọn một breakpoint trong danh sách. 4.4 Bắt đầu gỡ rối (Start Debug) Để bắt đầu debug bấm nút “Start Debug” trên thanh công cụ. Khi chương trình bị ngắt ở một breakpoint. nút “Start Debug” sẽ chuyển sang chức năng “Continue”. bạn có thể thiết lập điều kiện cho breakpoint.

Bạn có thể bấm vào nút “Stop Into” trên thanh công cụ Debug để chạy vào trong thân hàm. bấm nút “Step Over” trên thanh công cụ “Debug”.Khi chương trình đang debug ta có thể dừng và trở về màn hình soạn thảo bằng cách bấm nút “Stop Debugging” trên thanh công cụ hoặc phím Ctrl+F9 4.7 Step Over (từng bước) Khi chương trình bị ngắt. Như dưới đây chương trình chạy qua breakpoint và dừng ở lệnh printf() . chương trình sẽ chạy tới lệnh tiếp theo. nó bị ngắt ở hàm UpperCase: Bây giờ bạn gọi lệnh “Step Into”.6 Step Into Khi chương trình bị ngắt ở một câu lệnh gọi hàm. Trong chương trình dưới đây. chương trình chạy vào trong hàm Upper Case 4.

cửa sổ Local hiện giá trị của tất cả các biến địa phương trong phạm vi hiện tại. và chọn “Inspect/Change” từ menu bật ra.12 Watch (theo dõi) Bạn có thể sử dụng cửa sổ watch để theo dõi giá trị của một biểu thức trong lúc gỡ rối.4. 4.11 Inspect/Change Bấm chuột phải lên một đối tượng trong cửa sổ Local. Bạn có thể nhập biểu thức bạn muốn theo dõi .10 Run to Cursor (chạy tới dòng đặt con trỏ) Locals (địa phương) Khi chương trình dừng ở trạng thái debug. Hộp thoại khác xuất hiện theo kiểu biến bạn click vào:kiểu mảng.8 Step Out (bước ra) Khi chương trình bị ngắt trong thân một hàm. chương trình sẽ chạy tới vị trí trả về của hàm 4. dưới đây hiện 2 biến cùng giá trị của nó trong hàm “computeValue” lúc chạy chương trình: 4.9 4.Bạn cũng có thể bấm kép lên một đối tượng trong cửa sổ Locals để mở hộp thoại tương ứng. You can also double click on one item in Locals window to display corresponding dialog. bấm nút “Step Out” trên thanh Debug . struct hoặc lớp: displays Inspector window. The other type variable: displays Change window. Bấm chuột phải lên cửa sổ watch và chọn “Add Watch” từ menu hiện ra.

14 Console Khi gỡ lỗi.13 Memory (bộ nhớ) Nhập địa chỉ của biến ví dụ &s. pVariable hoặc ex240ff50 vào cửa sổ Memory và ấn Enter. bạn có thể xem nội dung của biến trong bộ nhớ. C-Free giao tiếp với bộ gỡ rối GDB để lấy thông tin. Bạn cũng có thể nhập lệnh trực tiếp để giao tiếp với GDB .4. Theo mặc định cửa sổ console hiện tất cả danh sách thông điệp từ GDB.vd: 4.

.

-Where to search: có 3 lựa chọn: +Search all opened file +Search all file of project: tìm trong project hiện tại +Search in folder: Lựa chọn thư mục tìm. Find Dialog Hộp thoại này dùng để tìm kiếm kí tự trong văn bản. -Replace with: Nhập đoạn mới cần thay cho đoạn cũ -OK bấm nút này để bắt đầu thay thế 3. Nếu chọn “Search subdirectives” thì nó sẽ tìm trong tất cả các thư mục con của thư mục đã chọn. Find in file Tìm kiếm trong nhiều file. . -Search for: Nhập chữ cần tìm vào đây -Case Sensitivity: -Whole Word only: tìm một từ nguyên vẹn. Replace Tìm kiếm một đoạn văn bản và thay thế nó bởi đoạn khác -Search for: nhập từ cần tìm. Lựa chọn này cho phép tìm từ vị trí con trỏ -Seclected Text only: chỉ tìm kiếm trong đoạn văn bản được chọn 2. tức là tìm chữ A độc lập chứ không tìm những từ chứa chữ A -search from caret: mặc định tìm kiếm bắt đầu từ đầu file. Kết quả liệt kê ở Message Window -Text to find: -File Type: Nhập đoạn văn bản cần tìm Nhập phần mở rộng của file cần tìm.Dialog 1.

Bạn có thể lựa chọn font. lựa chọn loại file sẽ được tô sáng. tự đông thêm dấu đóng ngoặc. Editor Properties Dùng thay đổi thuộc tính của trình soạn thảo. tính năng của cửa sổ Symbol. biên soạn các đoạn mã mẫu . màu chỉ thị dòng sửa đổi.4. … Có thể tuỳ biến việc tô sáng cú pháp. File Properties Click lên một file trong File Tree Window>> “File Properties” để mở hộp thoại này. số dòng 5. Nó cho biết kích thước file. thời gian sửa đổi. thiết lập màu cho các kiểu kí hiệu. Thiết lập tính năng Nhắc mã.

Ngoài ra tệp mới cũng được hiển thị trong cửa sổ cây tệp File Tree Window b.2 a.1 Current Active File C-Free hỗ trợ mở nhiều file một lúc. cùng với việc một tab mới sẽ được tạo ra trên “Tab Bar”. 1.cpp. một của sổ soạn mã sẽ xuất hiện để bạn soạn mã. và bạn không cần phải tạo project cho một chương trình đơn giản. Open file (mở file) Cần gọi lệnh “open file” để mở một file đã có. bằng cách chọn lệnh “Compiler” hoặc “Run” để build và chạy trực tiếp chương trình 1. Bạn có thể kích hoạt một file bằng cách lựa chọn tab của nó trên tab file hoặc chọn nó từ cửa sổ file dạng cây để kích hoạt nó trong cửa sổ soạn thảo 1. Có thể gọi lệnh này từ menu file . với tiêu đề là tên file.4 Drag and Drop . có thể chọn nhiều file để mở cùng lúc c. Chọn file cần mở trong hộp thoại mở ra. dĩ nhiên bạn có thể thay đổi nó trong phần “Environment Options” Mỗi lần có một file mới được tạo ra. Phần mở rộng của file ngẫu nhiên sẽ là . d. Basic File Operation New File (tạo file mới) Tạo ra một file mới. năng File Mã lệnh chứa trong một file. thanh công cụ. chạy một file đơn.3 Lưu file Đóng file (close file) Compile File (biên dịch một file) C-Free hỗ trợ dịch. file tạo ra sẽ được lưu trong thư mục temp của C-Free và có tên là “untitled”.Using C-Free 1. liên kết. File ở trên cùng và file đang soạn thảo được gọi là “Current Active File” ( file hiện tại được kích hoạt). C-Free có những tiện ích quản lý file đầy đủ tính 1.

5 Export File (Xuất file) Bạn có thể xuất file hiện tại sang định dạng HTML hoặc RTF bằng cách vào menu File >> Export >> “HTML” hoặc “Rtf” tương ứng 1. Trong một project của C-Free bạn có thể build tất cả những file đó và sinh ra mã chương trình .1 introduction Khi chương trình của bạn có nhiều hơn một file bạn cần tạo ra một project để quản lý chúng. Project Group giúp bạn dễ dàng quản lý nhiều Project. Trong quá trình lập trình ta thường phải chuyển qua lại giữa 2 loại file đó.c/cpp). Bạn có thể tuỳ chỉnh việc in này trong hộp thoại “Page Setup”. Bạn có thể chuyển giữa các project của mình rất nhanh. C-Free hỗ trợ in màu với cú pháp tô sáng.trong thực tế C-Free tìm kiếm các tệp liên quan tuần tự như sau: Tìm kiếm theo đường dẫn tới thư mục chứa file hiện tại Tìm kiếm theo đường dẫn tới nơi chứa tất cả các file của project nếu có project đang được mở 2. Có hai cách File>>Print. bạn có thể in file hiện tại.h) và đặt phần thực thi của hàm hoặc lớp trong file nguồn (dạng . 2. Project Project là một tập hợp file. Trong C-Free các file trùng tên nhưng khác phần mở rộng được xem là các file liên quan.7 Mở file liên quan (Open Relative File) Khi viết một chương trình C/C++ thông thường chúng ta luôn đặt phần khai báo của hàm hoặc lớp trong một file tiêu đề (dạng . và “Project Group” là một tập Project. C-Free hỗ trợ bất kì qui mô project nào. C-Free cung cấp lệnh “Open Relative File” để thực hiện việc này. 1.C-Free hỗ trợ mở file bằng cách kéo thả file từ chương trình duyệt file sang cửa sổ của C-Free 1.6 Print file Nếu máy in được cài. Chọn nút Print trên thanh công cụ.

Khi mở một Project Group. là project mà hiện tại bạn đang làm việc.2 Tạo một Project Chọn “Project”>> “New” . Có thể tạo ra thư mục mới trong project File: Có thể được chứa trong một thư mục khác hoặc chính thư mục gốc của Project Build Configuration: project có thể chứa một hoặc nhiều cấu hình build để hỗ trợ nhiều trình biên dịch khi dịch. Breakpoints: project cũng chứa tất cả các breakpoint mà các file trong project chứa Vị trí con trỏ: project cũng lưu vị trí con trỏ của tất cả các file trong khi soạn thảo. Một project có thể thuộc về nhiều Project Group khác nhau. 2.Project và tất cả các file của nó được liệt kê trong “File Tree Window”. Trong hộp thoại hãy chọn kiểu project cần tạo. bấm . “Project group” chứa một project đang hoạt động. Bạn có thể điều chỉnh cấu hình này trong hộp thoại setting. Trong bước sau cùng. project đang hoạt động của Project group đó tự động sẽ được mở. Mỗi kiểu project sẽ có một trình thuật sĩ hướng dẫn bạn. Khi mở một file của project trong lần tiếp theo. Các tiện ích của project có một phần trong menu ngữ cảnh của “File Tree Window” Project của C-Free chứa cách yếu tố sau Thư mục: được sử dụng để phân loại file trong project. Bạn có thể chọn cấu hình mình cần. có một trang lựa chọn cấu hình để build. hộp thoại “New Project” xuất hiện. con trỏ sẽ được đặt ở vị trí cũ - Nếu bạn muốn làm việc với nhiều dự án đồng thời thì bạn cần tạo ra một “Project Group” để quản lý các project này. Tất cả các cấu hình để build đều được liệt kê trong trang này.

Trong hộp thoại xuất hiện. project đang mở sẽ được thêm vào project group hiện tại. và thiết lập projet này là project đang kích hoạt Nếu chọn No . C-Free sẽ đóng projedt group hiện tại và mở project này 2. tất cả các file liên quan có thể tìm thấy trong thư mục project. chọn project cần mở.kép lên một đối tượng để lựa chọn nó làm cấu hình mặc định Nếu projec được tạo thành công. C-Free mở project trực tiếp và tạo ra một project group ngẫu nhiên chứa project hiện tại Nếu có project được mở. Nếu hiện tại không có project nào được mở. C-Free sẽ hỏi bạn có muốn thêm project này vào “project group” hiện tại không “do you want to add this project to current project group ?” Nếu chọn Yes. 2.4 Thêm File vào Project Có 3 cách .3 Mở một Project Chọn “Project”>> Open hoặc nút “Open Project” trên thanh công cụ.

tất cả các file thêm vào bằng phương pháp này được liệt kê dưới thư mục gốc của project Bấm chuột phải lên một thư mục trong “File Tree Window” chọn “Add Files to Folder”. chọn file trong hộp thoại xuất hiện. chọn Project>>Save>>Save Project.- - Menu “project”>> “Add files to project”.8 Loại Project khỏi Project Group Bấm chuột phải lên project trong group trong cửa sổ “File Tree Window” chọn “Remove Project” 2. Lúc này file này sẽ bị loại khỏi project nhưng không bị xoá khỏi máy tính. Xuất hiện hộp thoại để chọn file thêm vào project hiện tại.7 Thêm Project vào Project Group Khi mở hoặc tạo ra một Project mới.5 Loại file khỏi Project Bấm chuột phải lên một file của project trong của sổ cây file. bạn có thể kéo thả file cần thêm vào thư mục project 2. một Project group ngẫu nhiên được tạo ra để chứa project.9 Kích hoạt Project Để kích hoạt project có thể bấm kép lên project trong project group hoặc bấm chuột phải và chọn “Activate” trong menu ngữ cảnh của “File Tree Window” . 2. Tất cả các file được mở được liệt kê trong của sổ cây file. Để lưu project vào đĩa. nếu hiện tại không có Project Group nào được mở trong C-Free. trong hộp thoại “New Project” bạn có thể chọn “Add to Current project group” để thêm project mới này vào project group hiện tại 2.Mặt khác nếu hiện tại có project group đang mở thì bạn sẽ được hỏi có thêm project vào Project group này không Khi tạo ra một project mới.6 Lưu Project/Project Group Việc thêm và xoá file khỏi project sẽ làm thay đổi project trong bộ nhớ trong. 2. Để lưu Project Group chọn Project>>Save Project Group. chọn “Remove from project”.

bạn sẽ thấy một lựa chọn “Copy from global” để cho bạn chọn Global Build Configuration từ danh sách để sử dụng cho việc build Project 3. Bạn có thể sử dụng hộp thoại “Project Settings” để thay đổi tham số của “Project Build” bằng cách vào Menu “Project”>> Settings để mở hộp thoại. Project Build Configuration là cách build hiện tại. Global Build Configuaration trở thành cấu hình build hiện tại. Khi không có project nào mở.2 Building Steps C-Free có thể build cả project và file đơn. Nghĩ một cách đơn giản. Thủ tục Build tuân theo các bước sau: . Global Build Configuration áp dụng để build một file đơn.Trong hộp thoại Project Settings. còn Project Build Configuaration áp dụng để build một project. bạn có thể lựa chọn Global Build Configuration trong danh sách để sử dụng trong việc build project .3. Bạn có thể dùng hộp thoại “Build Option” để thay đổi tham số của “Global Build” bằng cách vào menu Build>>Build Option để mở hộp thoại. 3.1 Build Build Configuration Bạn có 2 loại Build configuration: Global Build và Project Build. trong bước cuối cùng của trình thuật sĩ. Khi có project được mở. “Global Build Configuration” có thể dùng cho project theo 2 cách: Khi tạo project mới.

Quá trình build bao gồm các bước dịch (compiling) và liên kết (linking) Chi tiết của các lệnh như sau Single File Current Build Global Build Configuration Configuration Compile Biên dịch file hiện tại Project Project Build Configuration Make Build Biên dịch tất cả các file nguồn của project hiện tại So sánh thời gian của Kiểm tra những điểm thay file hiện tại với file đổi của file và biên dịch tất object và file chương cả những file nguồn đã sửa trình. 4. nó sẽ dịch kết các file object thành file và liên kết lại chương trình Biên dịch tất cả file nguồn Biên dịch file hiện tại của project hiện tại.1 Code Parser Code Completion (hoàn thành mã) . Nếu file hiện tại đổi. sau khi biên dịch liên đã bị sửa đổi. sau đó thành chương trình liên kết các file object thành chương trình 4.

...4.2 Code Hint (Nhắc khai báo của một tên) Khi bạn di con trỏ vào một kí hiệu nào đó (tên biến.) một cửa sổ hiện ngay cạnh cho biết khai báo của nó. hàm.

C_Free sẽ nhắc bạn những từ cần nhập. chọn một từ trong danh sách và ấn enter để điền nó vào đoạn mã. Khi bạn nhập 1 từ hoặc 2.3 chữ cái của từ này.3 Code Parameters Nhắc đối số cho hàm 4. Cấu hình nó trong hộp thoại Editor Propeties .4 Smart Input C-Free có thể nhớ các biểu tượng mà bạn đã gõ.4.