ARENA İLE SİMÜLASYON

Simülasyon, gerçek bir sistemin modelini tasarlama süreci ve sistemin işlemesi için sistemin davranışlarını anlamak ve değişik stratejileri değerlemek amacıyla bu model üzerinde denemeler yapmaktır. 1. ARENA PROGRAMI Arena programı, Siman’ı da piyasaya süren Systems Modeling Corparation adlı bir firmanın geliştirdiği Windows ara yüzüne sahip popüler bir simülasyon programıdır. Arena programı, başarılı bir simülasyon için gerekli olan animasyon, giren ve çıkan verinin analizi gibi fonksiyonları ayrıntılı ve kapsamlı bir şekilde içermektedir. Arena, bir program modeli oluştururken oluşturulmuş modeli çalıştırırken Siman komutlarını kullanır. Fakat bu programın özelliği komut bilgisine neredeyse hiç ihtiyaç duymamasıdır. Arena’da, şablonlarda kısa yolları verilmiş modülleri program sayfanıza ekleyerek ve bu modülleri çift tıklattığınızda açılan pencereye istenen bilgileri (geliş zamanı, yığın boyutu, bir sonraki istasyon adı v.b) girmek suretiyle model programınızı oluşturabilirsiniz. Arena, Windows altında çalıştığı için araç çubukları, menüler ve pencerelerle çalışmak konusunda büyük kolaylıklar sağlar. Arena model sisteminin gücü üretim, sağlık sektörü, akış hatları, bilgisayar ağları gibi ortamlarda özel uygulamalara imkan vermesinden ileri gelmektedir. Dosya işlemleri normal bir Windows penceresinde olduğu gibi çalışır. Yeni bir dosya açmak için File/New menüsü seçilebileceği gibi Ctrl+N tuş kombinasyonu da kullanılabilir. Mevcut bir model File/Open komutu ile açılır. Gerekli ise doğru klasörü seçip gerekli dosyayı bulduktan sonra o dosyayı açabilirsiniz. Modellerin kayıt edilmesi ise File/Save veya File/Save As komutu ile olur. File/Print komutu ile modellerin çıktısı alınabileceği gibi File/Print Preview ile önizleme yapılabilir. Bazı gerekli noktalar: • • • Arena’nın nesne temelli çizim sisteminde, öncelikle bir nesne seçilmeli sonra da gerekli işlemler yapılmalıdır. Nesnelerin özelliklerinin değiştirilebilmesi için Undo (File/Undo) ve Redo (File/Redo) komutları vardır. Arena’da mouse ile yapılan işlemlere sağ tıklamak da dahildir. Verdiğiniz en son komutun tekrar verilmesi durumunda tekrar aynı komut emrini vermek yerine sağ tıklayarak bu işlemi yapabilirsiniz. Ayrıca sağ tıklamak mevcut fonksiyondan kurtulmayı da sağlar. (Bir şekil çiziminden çizimi yaptıktan sonra çıkabilmek için.) • Çizim yaparken Shift tuşuna basılı tutmak bazı yapılan işlemlere özellikler kazandırır. Bu özellikler çizilen şekle göre değişir. Çizgiler yatay, dikey veya 45º açı ile; dikdörtgen çizimi kare ile; elipsler de daire ile çizilecek şekilde ayarlanır. • • Birden fazla açık arena penceresi ile çalışmak durumunda iseniz Ctrl+Tab tuşu ile bu pencereler arasında geçiş yapabilirsiniz. Klavyedeki Insert tuşuna basmak veya Ctrl+D tuş kombinasyonuna basmak model içinde ne seçili durumda ise o nesnenin kopyasını yaratır. Böylece yeni nesneyi taşıyabilir veya gerekli işleriniz yapabilirsiniz. 2. PROGRAM PROSEDÜRLERİ Arena’nın içerisinde 5 adet program prosedürü bulunmaktadır. Bunlar: 2.1 Input Analyzer: Veri girdisinin analizini yapar. Simülasyon yapmak için ihtiyaç duyduğumuz gelişler arası zaman, servis zamanı gibi bilgiler analiz edilir. Örneğin gelişler arası zaman şöyle ölçülmüştür: 1. parçanın gelişinden 2. parçanın gelişine kadar geçen zaman=5, 2. parça gelişinden 3. parça gelişine kadar geçen zaman=6 vs... Bu rakamlar not defterinde 5 6 4 6 5 7 7.4 6.3 şeklinde birer boşluk bırakılarak yazılır. Daha sonra bu text dosyasına bir isim verilerek kaydedilir ve program kapatılır. Daha sonra Input analyzerda file>yeni

e” elde edilir. file menüsünde bulunan Pack and Go komutuytla paketlenerek Avf uzantılı dosyalara dönüştürürler. çeşitli grafikler vasıtasıyla simülasyon sonuçlarının kolay anlaşılması için görselliğin sağlandığı programdır. araç çubukları ve bunların yaptıkları işlerden bahsedilecektir. Siman komutları kullanılarak yazılır ve Scenario Manager’da derlenir ve “program. İlk önce model program. 2. Bu da Arena’da çalıştırılarak simülasyon yapılır.3 Output Analyzer: Arena programında yapılan simülasyonun sonuçlarının analiz edildiği. Ekranda görülen her şey bir model oluştururken işimize çok yarayacak olan komutları içermektedir. 2. Ancak ana programda simülasyonlar kullanıcıdan veri girişi isteyen komutlar kullanarak yapılmışsa yalnızca istenen veriler girilerek simülasyon çalıştırılır. Görüldüğü gibi bir çok araç çubuğu ile yapılmaya çalışılan. Fit menüsünde bulunan Fit All sekmesine basarak verilerinizin en uygun olduğu dağılım ve ilgili veriler bulunur. Arena ilk çalıştırıldığında yeni bir model yaratmak için karşınıza çıkacak olan ekran aşağıdaki şekildeki gibidir. Sonra deneysel program yazılır ve derlenerek “program. . Fakat bu dosyalar üzerinde değişiklik yapılamaz.butonuna basarak yeni bir dosya açılır. simülasyonun basitleştirilmesi çalışmasıdır. Burada ileride açıklanacak olan kısımların bir çoğu yer almaktadır.2 Arena: Model programının oluşturulduğu ve bu programın çalıştırılması suretiyle simülasyonun yapıldığı ana programdır. Bu program sadece yapılmış programları çalıştırdığı için hard-diskte fazla yer kaplamaz. Scenario Manager’in avantajı Dos ortamına göre derleme ve link etme işleminin daha kolay yapılabilmesi ve ortaya çıkan hataların daha kolay debug (hata ayıklama) edilmesidir.m” dosyası elde edilir. Şimdi bu ekrandaki menüler.4 Scenario Manager: Siman veya Arena’da. Bu programdan elde edilen veriler Output Analyzerda işlenir. 2. Ana programda hazırlanmış simülasyonlar. 2. Bu programın yaptığı işlevin daha fazlası zaten Arena’nın ana programında run menüsünde yapılmaktadır.5 Arena Viewer: Ana programda hazırlanmış model programın çalıştırılıp sonuçlarının alınmasında kullanılır. Daha sonra model program ve deneysel program link edilir (birleştirilir) eğer bir hata yoksa “program. Arena Viewer’ın avantajı ise lisans istemeden her türlü bilgisayara yüklenip ana programda yapılmış simülasyonların çalıştırılmasıdır. birbirleriyle karşılaştırıldığı. Sonra yine file menüsünde bulunan Data File>Use existing sekmesine basılır ve açılan pencereden daha önce yapmış olduğunuz text dosyası seçilir. Siman kodlarıyla oluşturulmuş programların derlenmesinde ve link edilmesinde kullanılır. Yalnızca bu dosyalar Arena Viewer’da çalıştırılabilir.p” elde edilir.

Menüler açılımları aşağıda gösterilmiştir. MENÜLER Arena’ya başladığınız zaman File.1 File menüsü: Bu menü yeni Arena modellerinin yaratıldığı.Arena Programının Genel Olarak görünüşü 3. Modeller açık olmadan bazı menüler daha kısa sürecektir. Arrange. pencerelerin kapatıldığı modellerin kayıt edildiği kısımdır. 3. Arena’nın kullandığı renkleri değiştirirseniz. Bu yüzden aşağıda Arena’ya özel şeyler üzerinde yoğunlaşılacak ve bunların ayrıntısına da daha sonradan inilecektir. mevcutların açıldığı. Tools ve Help menülerini görebilirsiniz. Menüler içindeyken bile çalışabilecek olan kısa yollar ise her menü komutunun sağ tarafında yer alan kısa yol klavye kombinasyonlarıdır. Her menü altındaki çeşitli işlev ve yeteneğe sahip komutların mantıksal olarak bağlanmasıyla oluşturulmuştur. Run ve Window menüleri eklenir. View. Bir çok menü nesnesi standart Windows fonksiyonlarıdır. Bir modelin yerleşimiyle beraber Edit. Ayrıca menüler açıldıktan sonra komutlarda altı çizili harflerin klavyeden yazılması ile de bu komutlar verilebilir. Burada ayrıca AutoCAD (veya DXF formatındaki başka CAD programlarından) gibi programlardan CAD çizimleri alabilir bunları Arena içinde kullanabilir ve aktif elementler halinde kullanabilirsiniz. Module. bunları bir renk paleti şeklinde kayıt edebilirsiniz veya kayıtları olan renk paletlerini açabilirsiniz. Arena’nın yazdırma ayarları ile ilgili komutları bu .

Zoom Factor her seferinde Zoom yaptığınızda ne kadar yaklaşıp uzaklaştığınızı ayarlamanıza yarayacaktır. Arena’nın Find komutu aradığınız yazı ne ise onu bütün modüllerde ve animasyon nesnelerinde arayacaktır.Kopyalayıp veya kesip clipboard’a yerleştirdiğiniz nesneleri yapıştırmak için Paste komutu. Delete komutu her ne seçili ise onu silmeye yarar. Bir çok Windows uygulaması gibi Arena en son kullanılan dosyaları hatırlar ve bunların çabuk açılması için en son dört tanesini yine bu menü altında saklar. Properties ile nesnelerin özellikleri hakkında daha fazla özellik öğrenebilirsiniz. En alttaki Status Bar ise Arena’nın en altında .menüdedir. 3.3 View Menüsü: Bu menü ile modelleriniz ekrandaki görüntüsü ve hangi araç çubuklarının görüntülenmesi gerektiği ayarlarını kontrol edebilirsiniz. bu yaptığınız işlemin iki dosyada da otomatik olarak güncelleştirilmesini sağlamak için de Paste Link komutu kullanılır. Araç çubukları hangi düğme gruplarının yerleştirileceğinin ayarlandığı komuttur. geri aldığınız işlemleri tekrar yapabilirsiniz. Yaptığınız işlemleri geri alabilir. başka bir modele ve bazı durumlarda başka uygulamalara taşıyabilirsiniz. View hazır bulunan çeşitli görünümlere ve Names View ise kendi özel görünümü yaratmanıza yardım edecektir. Send komutu mesaj (mail) yollamanızı ve mesajınıza herhangi bir aktif modeli yerleştirmenizi sağlar. Bütün nesnelerin bir anda seçilmesi için Select All komutu bütün nesnelerin seçiminin bir anda kaybolması için de Deselect All seçeneği kullanılır. Object başka bir uygulamadan getirdiğiniz bir nesne ile ilgili çeşitli düzenlemeler yapmanıza olanak verir. 3. Exit komutu Arena’dan çıkmak için kullanılan yollardan bir tanesidir. Layers düzenleme ve çalıştırma durumlarında hangi nesnelerin gösterilip hangilerinin gösterilmeyeceğinin ayarlanacağı ve kontrol edileceği kısımdır. Grid ve Snap komutları eğer yerleştirdiğiniz nesneler için coğrafik bir grafiklik istiyorsanız işinize yarayacaktır. Insert new object grafik veya multimedya gibi diğer uygulamalardan çeşitli yerleştirmeler yapmanızı sağlar.2 Edit Menüsü: Burada Arena’ya nesneler ekledikçe onlarla ilgili seçenekleri içeren komutlar bulunacaktır. Seçili bir nesneyi kopyalayabilir veya kesebilirsiniz ve bunları mevcut modele. Duplicate seçtiğiniz nesnenin hemen yanına o nesnenin aynısından bir tane daha yapmaya yarayan komuttur. Modelinizde diğer dosyalar ile bir bağlantı var ise Links bu bağlantıları incelemenizi onları değiştirebilmenizi ve üstünde değişiklikler yapmanızı sağlar. Zoom seçeneği ile ekran üzerinde odaklanarak ayrıntı seviyesini azaltıp arttırabilirsiniz.

bulunan mouse’un ekran üzerinde hangi koordinatlarda bulunduğunu ve neler olduğunu gösteren durum göstergesinin ayarı ile ilgilidir. Scenario Manager bir çok farklı simülasyonun çalıştırılabilmesi için bir ortam yaratır.4 Tools Menüsü: Arena sadece modelleme ile değil aynı zamanda bir çok araçla da karşımıza geliyor. Smart Connections yapılan bu bağlantıların üç defa açı yaparak yerleşmesini sağlar. Rotate saat yönünde seçim yaptığınız nesneyi 90º döndürür. Input Analyzer model girdilerini belirlemek için çeşitli olasılık dağılımlarını kullanır.5 Arrange Menüsü: Buradaki komutlar modelleme modülleri ve grafikler için yerleşim ayarlarını içerir. Show modülün . License Summary Arena’nın yüklenmiş olan profesyonel sürümü hakkında bilgi vermeye yarar. Template Panel bir grup modelleme yapısını template araç çubuğuna yerleştirmeyi ve oradan kaldırmayı sağlar. Model Jump Wizard basit bir kaç girdi ile yeni bir proje yüklemek için basit bir Arena modeli oluşturmaktadır. Son olarak Options Arena’nın ihtiyaçlarınıza cevap vermesi için gerekli ayarlamalarınızın yapılacağı seçenekler bölümüdür. Aynı model üzerinde değişik veriler için farklı ayarlar ile çalışabilmeyi böylece onları analiz edebilmeyi sağlar. Show Visual Basic Editor. Auto-Connect daha önce yerleştirilmiş bir modülün yanına yerleşim yapılması durumunda otomatik olarak bu bağın kurulması işlemini yapar. Output Analyzer simülasyonunuzun sonuçlarının istatistiksel analizi için ortam hazırlar. Group eğer birden çok nesneyi bir yerden başka bir yere birbirlerine olan konumlarının bozulmadan hareket ettirmek istersek çok faydalıdır.6 Module Menüsü: Bu komutlar modelin mantık komutları ve onların geldikleri template ler ile ilgilidir. 3. Connect parçaların modülden diğerine geçişlerini göstermek için iki modülü bağlamaya yarar. Flip seçiminizi eksen varmış gibi eksen etrafında döndürmeye yarar. Visual Basic kodlarını yazabileceğiniz bir ortam hazırlar ve bir pencere açar. 3. 3. Bring to Front ve Send to Back seçili nesnelerin yerlerine göre üst veya altta kalmalarının ayarıdır. Group ve Ungroup seçili nesnelerin bir arada tutulması veya ayrılması için onların fiziksel görünüşlerinin bozulmadan yapılması ile ilgili ayarlardır.

8 Window Menüsü: Aynı anda birden çok açık modeliniz varsa bunları fiziksel olarak düzenleyebileceğiniz Cascade Tile gibi seçenekler bulunur. Eğer bu işlemi model yaptığınız bir alana koyarsanız bu sefer araç çubuğunun üstünde adını da görebilirsiniz ve araç çubuğunuz artık bir palet görünümündedir. View/Toolbars komutu karar verebilmeniz için araç çubuklarını seçmenize imkan verir. Son olarak açık herhangi bir modele geçiş yapmak için onun adına tıklama yeterlidir. duraksatılması veya yavaş yavaş adımlanması için gerekli komutları içerir. yoksa sadece animasyonunun mu gözüktüğünü ayarlamak içindir. 3. Bu araç çubukları genel aktivitelere çabuk ulaşmayı sağlar. Ayarlamayı yaptıktan sonra Arena yaptığınız . kontrol edilmesi. 4. Arena Help Topics seçilmesi durumunda İçindekilere ulaşılacaktır. Model yapımında veya ayarlarının yapılması sırasında eğer ihtiyacınız yok ise bütün araç çubuklarını kullanmak zorunda değilsiniz. Bu düğmelerden bazıları daha önce sözü geçen menülere ulaşmanın kısa yolları olabildiği gibi bazıları da bir komutu vermenin tek yolu olabilir. sonuçlara ve hatalara bakmak için ve simülasyonun nasıl çalıştığına ekranda nasıl gözüktüğüne dair işlemlerin yapılması için bir çok alternatif sunar. Bir çok modeli simge durumunda tutyorsanız onları düzenlemek için Arrabge Icons size yardımcı olacaktır. Breakpoint parçanın bu noktaya gelmesi halinde simülasyonun durmasını sağlar. Ayrıca istediğiniz araç çubuğunu üstüne basılı tutup taşımak suretiyle herhangi bir alana taşıyabilirsiniz. Use System Background Color ile Windows’un arka plan ayarları kullanılır. Bunun yanında hazırlık ve kontrol için. 3. Araç çubukları ile yaptığınız ayarlamaları her seferinde yapmak zorunda değilsiniz.7 Run Menüsü: Bu menü simülasyonun çalıştırılması. Araç çubuklarının görünümü Tools/Options komutundan da değiştirebilirsiniz. Standart ve View araç çubukları “Standart View” olarak birleştirilmişlerdir.9 Help Menüsü: Bu menü Arena içindeki yardım alma yollarından bir tanesidir.isminin mi. ARAÇ ÇUBUKLARI Arena içinde düğme grupları ve açılan menüler içeren bir çok araç çubuğuna sahiptir. 3.

seçilen kapalı alan veya çizginin çizgi. 4. simülasyonu çalıştırırken başka. Arena içinde düz. Ayrıca istenilen herhengi bir yere yazı yazmak. Bunun yanında modeli yarattığınız anda başka.2 View Araç Çubuğu Bu araç çubuğu yardımı ile Zoom yapabiliriz. 4.4 Draw Araç Çubuğu Draw araç çubuğundaki düğmelerin bir menü ile bağlantısı yoktur. Open komutuyla devam eden araç çubuğunda yapılabilen diğer işlemler modelleri kayıt etmek.1 Standart Araç Çubuğu: New (Yeni) komutuyla başlayıp. varsayılan ayarlarla yazdırmak için Print butonu. Burada verilen ikonların yaptıkları işlere Arrange menüsü altından da ulaşılabilinir. Arena bütün yaptığınız değişiklikleri hatırlayacaktır.3 Arrange Araç Çubuğu Seçilmiş bir nesneyi öne getirebilir veya onu arkaya gönderebilirsiniz. Bütün model. 4. Seçili nesneler ayrıca yatay veya dikey bir eksene göre döndürülebilir veya saat eksenine göre döndürülebilirler. 4. Briden fazla seçili nesne bir grup altında toplanabilir veya daha sonra bunları ungroup ile ayırabilirsiniz. Son olarak da iki modülü birbirine bağlamak için kullanılan Connect düğmesi yer alır. Cut Copy Paste ikonları. açılı ve kapalıalan oluşturacak çizgiler çizmeye yarayan kısımdır. 4.değişiklikleri hatırlayacaktır. Burada ayrıca Grid. Yardımı buradan almanın avantajı istediğiniz bir yere mouse yardımı ile tıklanması durumunda buradaki ilgili Help penceresi karşınıza çıkacaktır. Undo ve Redo ikonları ve enson olarak da yardım alabilmek için yardım ikonu. Buradaki komutlara View menüsü altından da ulaşılabilinir. ve değişik Arena pencerelerinde farklı araç çubukları kullanbilirsiniz. renk gibi özelliklerinin değiştirilmesi gibi işlemler yapılabilir. kırık.5 Color Araç Çubuğu . önceki görünüm veya görünüm için farklı bir seçenek arasından seçim yapabiliriz. Dolayısıyla direk olarak araç çubuğundan kontrol edilirler. Snap ve Layer ayarlarının yapılması mümkündür.

Kısaca bu ikonlardan bir tanesi üzerine tıkladıktan sonra gerekli açıklamaların yapılamasından sonra bunu yapmak istediğiniz modül üzerine götürün ve model içine animasyon yerleştirin. Arena modelinizi çalıştırırken çalışma modundasınızdır. Bu işlem de End komutu ile olur. Daha sonra Go diyerek simülasyona kaldığı yerden devam edebilirsiniz. Report simülasyon çalışırken duraklatıldıktan sonra bir şeyin sayısal değerine bakmak için kullanılır. Trace simülasyon içinde olan şeyler hakkında bilgilerin tutulduğu bir tarih kısmıdır. Simülasyona başlamadan evvel yapılması gereken işlemlerden birtanesi de simülasyonu çalıştırmakla ilgili belirtilmesi gerekenlerdir. En son kontrolden sonra başka bir işlem yapıldı ise öncelikle çalışmadan evvel kontrol edecektir. durdurulması. Bu pencerenin altındaki düğmeler hatanın yerinin bulmak ve gidermek için kullanılabilir. Aşağıda yapılabilecek işlemler açıklanmıştır. atlanması. Watch çalışma işleminde yer alacak değişkenlere ve açıklamalara göz atmanızı sağlar. Run Araç Çubuğu Kaset çalarlardakine benzer görünümdeki bu araç çubuğunda yapılan işlemler Simülasyonun çalıştırılması. Eğer diğer modellerde de saklamak istenen bir renk kombinasyonu elde dedildi ise yapılması gereken işlem File/Save Color Palette komutu ile bu işlem yapılabilir. Mesela simülasyonun tam ekran çalıştırılması gibi. Bu yüzden çoğu model oluşturma aracı çalışmaz.6 Animate Araç Çubuğu Bu araç çubuğu modellerin animasyonu için gerekli ikonları içerir. Modelin çalışmasını sonlandırmadan model üzerinde bir değişiklik yapamazsınız. Bu girişler Run menüsünden olabileceği gibi Run araç çubuğundan da olabilir. . Review Errors en son meydana çıkan Errors/Warnings penceresini tekrar açarak kontrol sırasında Arena’nın bulduğu hatalara göz atmak içindir. View Results mevcut veya en son yapılan simülasyonun çıktı özetidir. duraksatılması. ve model penceresinin arka planının rengini değiştirmeye yarar. yeniden başlatılması. Step modeli bir sonraki zaman basamağına atlatır. Eğer Arena bu aşamada bir hataya rastlar ise bu hataya Errors/Warnings penceresi yardımı ile bakabilir ve burada yapılacak düzeltmeleri yapabilirsiniz. Pause çalışmayı duraksatır ve böylece bir şeye bakılabilir. bu da Go gibi son kontrolden sonra başka bir işlem yapıldı ise onu kontrol edecektir. Check Model modelin çalıştırılmadan doğru çalışıp çalışmayacağını anlamak için yapılan bir kontrol işlemidir. ve bitirilmesidir. Setup çalışma işlemi hakkında bazı ayarlar yapmaya izin verir. Aşağı-düş ikonuna tıklanması ile hangi alanın renginin değiştirileceğine karar verildikten sonra istenen renge tıklanması suretiyle renk değiştirilmiş olur. yazıların. Command simülasyonun çalışması ile ilgili kontrollerin yapıldığı karşılıklı etkileşimli bir komut alanıdır. Break simülasyonun durdurulması için size zaman veya çeşitli koşullar koymanızı sağlar. Go komutu simülasyonu çalıştırır. 4. ileri alınması. Ama bazı zamanlar öncelikle işlerin yolunda gidip gitmediğini kontrol etmek gerekir. Fast-Forward animasyonu kaldırarak çok yüksek bir oranda simülasyonun çalışmasına ve çabuk sonuçlara ulaşmayı sağlar. Böylece ayrıntılı olarak neler olduğunu görebilirsiniz. Start Over en başa dönüp simülasyonu baştan çalıştırır. Genellikle model hazırladıktan sonra hemen çalıştırmak istenir.Çizimlerin ve animasyon nesnelerinin.

Speed animasyonun ne kadar hız ile gideceğini ayarlamaya yarar. Bir modüle bilgi girişi o modülün tutacağına çift tıklamak suretiyle açılan pencereden olur. Bu işlem aşağıdaki gibi Common paneli açacaktır. Daha sonra model penceresi üzerine gelindiğinde mouse dört yönlü bir ok halinde gözükecektir. Bu ayrıca yanlışlıkla yerleştirilmiş bir panelin kaldırılması içinde geçerli olan bir yöntemdir. Animate ve Statistics modülleri. Animasyon gereçleri genellikle modül tutacağının üzerinde isimler de genellikle altta yer alırlar. Bunun model programa hiçbir etkisi olmaz. Model3 diye isimlendirilirler. Yerleştirilen her modül en azından sadece isimi (modül tutacağı) de olsa bir kutu şeklinde gözükür. Yerleştirilen panel sol tarafta gösterildiği gibi içinde taşıdığı modüllerin ikonlarıyla beraber gözükecektir. Müşteriler film izlemek için sinema salonunun dış kapısına gelirler. Bu işlem için gerekli olan panel Common panelidir. Bu animasyon objelerinin yerini değiştirebilir. Örnek olarak Arrive modülü yerleştirildiği zaman üst kısmında daha sonra Station diyeceğimiz sağ tarafı yuvarlatılmış dikdörtgen ile ve altında da ismi ile beraber gelir. Simülasyonunu yapacağımız durum şu şekildedir. Server. üstünde oynama yapabilir hatta animasyon yapmak istemiyorsanız tamamen silebilirsiniz. Arrive. Simulate. Burada bulunan düğmeler standart düğmeler olarak adlandırılırlar. Modülün üstündeki bu şekil sadece animasyon amaçlı olup simülasyon çalıştırıldığında kullanıcıya ne olup bittiği hakkında bir fikir verir. 5. Açtığımız pencere otomatik olarak Model1 olarak isimlendirilecektir. Eğer ekrana sığmayacak kadar büyük olarak geliyorsa panelin içeriğinin tamamını görmek için üst taraftaki oklar kullanılmalıdır. İsimlerini değiştirmediğiniz sürece yarattığınız her yeni model Model2. Bir modül yerleştirmek için öncelikle yerleştirmek istenen modül ikonunun üstüne tıklanmalıdır. Bir panelden modüller yerleştirmiş olsanız dahi o paneli kaldırabilirsiniz. Modeli şu şekilde şematize edebiliriz: . Bu görünümün özelliğini değiştirmek isterseniz yapılacak işlem bu alan üzerinde sağ tıklamak ve istenen seçeneğin seçimidir. Bir modüle kendi bilgilerimizin verilmesinden sonra animasyon gereçlerini ve varsayılan ismi değiştirebiliriz. Bu işlem File/New veya Ctrl+N ile yapılabilir. Bir çok durumda modüller animasyon gereçleri veya varsayılan isim ile birlikte gelirler. BİR BİLET GİŞESİNİN SİMÜLASYONU Yapacağımız sinema gişesi simülasyon modeli için önce yeni bir model penceresi açılmalıdır. (Biz bunu Arrive modülünü kullanarak yapacağız) Daha sonra bilet gişesine doğru yürürler. Depart. (Burada servis istasyonu bilet gişesidir. Her ikonun altında modülün ismi veya isminin bir kısmı yer almaktadır. kaynak ise gişe memurudur) Daha sonra filmin gösterildiği salonun kapısına (Depart modülü) kadar yürürler. Yapacağımız model sadece altı çeşit modül içermektedir. Bir panel yerleştirme işlemi için Attach ikonundan açılan pencereden Common seçilebileceği gibi Tools/Options’dan da bu işlem yapılabilir. Modülün yerleşmesi istenen yere tıklanır ve modülümüz yerleşir. Sonra gerekli olan panel yerleştirilmelidir. Biletlerini alırlar.

Örneğin bu değer 2dk olsun.3 1. Sonra file>data file>use existing sekmesine gelerek bir kere tıklarız. Bu tür dosyalar Arena programının içerisinden yapılabilir. müşteri geldiğinde kronometredeki değeri kaydederiz. Arrival Data bu istasyona gelişlerin zaman aralığı ve cinsi ile ilgili bilgilerin verildiği kısımdır.5 2. İlk müşteri geldiğinde kronometreyi çalıştırırız.7 1. Örneğin yapmamız gereken gözlem sayısı 20 adet olsun. Burada verdiğimiz isim bu istasyonun bundan sonra Arena içinde nasıl çağırılacağını belirler. İstasyon ismi verirken dikkat edilmesi gereken nokta Türkçe karakter kullanmamak ve noktalama işareti bulundurmamaktır. Fakat bizim için daha kolay olan not defterine kaydettiğimiz değerlerdir.6 Elde ettiğimiz bu değerleri windows içerisinde olan başlat>programlar>donatılar>not defteri programını açarak buraya kaydederiz.1 2.5 3 2.9 2.1 0. İlk olarak Arrive modülünün ilk kısmı olan Enter Data kısmındaki istasyon adı kısmını değiştireceğiz. Zaman etüdü bilgilerimize dayanarak ne kadar sayıda gözlem yapacağımızı belirleriz.8 0.1 7.6 3.8 2.2 3.8 4. Önümüze dağılım dosyalarının yerini soran bir diyalog penceresi gelir. Bu kısma gereken değeri yazmak için bilet gişesinin bulunduğu bölgeye giderek gözlem yapmamız gereklidir.5 1.7 1.5 5. Yeni düğmesine basarak yeni bir dosya açarız. Varsayılan olarak bizden dst uzantılı olan dağılım dosyası ister.7 0. Bu şekilde müşteriler arası geliş zamanlarını kaydederiz. Dosyamıza varsayılan olarak adsız ismi verilir. . Elimize bir kronometre alarak ilk müşterinin gelmesini bekleriz. 2.Arrive Diyalog Kutusu Bilet gişesi örneği için Arrive modülüne birkaç veri gireceğiz. Sonra not defteri programını kapatarak Arena programında Tools menüsünde bulunan Input Analyzerı açarız. Biz bunu “gelisler” olarak değiştireceğiz. Varsayılan olarak gelen istasyon ismi Arrive 1 idi. Ölçtüğümüz değerler de sırasıyla şunlar olsun: 2 1.

Arena içinde herhangi bir dağılım vermek gerektiğinde yapılması gereken işlem dağılımın İngilizce adının ilk dört değerini girmek. Bu bilgi ister elle ister aşağı düş oku yardımıyla çıkan menüden seçerek verilebilir.Aşağıdaki açılır ok menüsünden All files veya txt seçeneği tıklanır ve daha önce yarattığımız adsız isimli dosyayı seçebiliriz. İkinci yol tercih edilir ise burada Logn(LogMean . Biz rota zamanı olarak 0. Son olarak da Leave Data kısmında Arrive modülünü terk eden parcaların izleyecekleri yolun belirlenmesi gerekir. Mark Time Attribute kısmı gelisler istasyonuna gelen her müşterinin zamanını belirtilmesi için ayrılan bir kısımdır. Burada önemli olan nokta değerler arasında en az bir boşluk olması gerektiğidir. bir parantez açmak ve girdiğiniz bu dağılımın ihtiyaç duyduğu verileri yazıp parantezi kapatmaktır.87) değerini Arrive modülündeki Time Between boşluğuna yazarız. Bu dosyaya çift tıklattığımızda Input analyzer buradaki verileri grafikte histogram şeklinde gösterir ve ortalama ve standart sapma gibi bilgileri bize verir. Kuyruk miktarının artması ve animasyonun daha iyi izlenebilmesi için kuyruk boyu yukarıdaki şekildeki gibi uzatılmıştır. Server modülünün kuyruk kısmı Server Dialog Kutusu Üstteki şekilde gözüken Server modülünün kuyruk kısmıdır. Elde ettiğimiz LOGN(2. Hemen sonra proses yani işlem yapılan bir yer yaratmamız gerekecek. Logn Lognormal dağılımı belirtmektedir. Bizim örneğimizde bu dağılım 2. Server modülünü de şekildeki gibi değiştirerek basit işlem modelimizin gelişlerini ve işlem zamanlarını vermiş bulunuyoruz. Böylece simülasyon sonucunda çıktı alabilmek için bize gerekli olan veriler elde edilecektir. istersek sabit bir değer istersek de bir dağılım verebiliriz. LogStd silinerek 1. LogStd) değeri karşımıza çıkar. Yine Arrival Data bölümünden Mark Time Attribute kısmına “gelis zamani” verisi girilmelidir.2 değerini veriyoruz. Bundan sonra yapacağımız işlem fit menüsündeki fit all seçeneğini tıklayarak verilerimizin en doğru şekilde uyduğu dağılımı belirlemektedir.6. Bu kısım üzerine tıklandığında üzerinde boy ayarlamaları yapılabilecek iki adet seçim karesi gözükecektir. Bu da Route kutusuna tıklanarak yapılacaktır.87 değeri yazılır. Buradaki LogMean yazısı silinerek 2.87 standart sapmaya sahip lognormal dağılımdır. Bizim örneğimizde sinemanın dış kapısından gelen müşteriler gişeye kadar yürümektedirler. . Route time olarak. Şüphe duyulması durumunda yapılacak işlem ok yardımıyla çıkan menüden uygun dağılımı seçmek oradaki yazı verisini ihtiyaç duyulan rakamsal veri ile yer değiştirmektir. 1. bu işlemlerin zamanlarının belirtildiği modül Server modülüdür.6 ortalama ve 1. Arena içinde işlemlerin yapıldığı.6.

Yukarıdaki şekilde vermiş olduğumuz değerleri incelersek modülümüzün adını gişe olarak değiştirdik. Şimdi müşterilerin sistemimizden çıkışları ile ilgileneceğiz.5dk değerini verdik. Arena penceresine bir adet yerleştirip gerekli ayarlamaları yapacağız. En son olarak da verilerin çıkış adresi olarak Route seçeneğini seçtik. Aşağıdaki şekil bu ayarlamaları nasıl yapmamız gerektiğini göstermektedir. en son olarak da gerekli değerleri girmemiz gereklidir. Örnek olarak biz işlem zamanı olarak ortalaması 2. Gişe memurunun her müşteri için bilet kesme zamanını yine yukarıdaki gibi kaydederiz ve input analyzerda da bu verilerin uyduğu dağılımı buluruz. İlk önce kullanacağımız arrive. Bizim örneğimizde gişeden (server) sonraki istasyon sinema salonunun kapısıdır (depart) Buradaki dikkat edilecek husus modülleri tek tek koyup da değerlerini tek tek girmemek gerekir. standart sapması 0. server. Tamamlanmış Depart Modülü Bu yapılan son işlemle modelimizin yapısı ile ilgili her şeyi tamamlamış bulunuyoruz. Ve Station kısmına bir sonraki istasyon olarak cikis ismini verdik. . Route Time olarak da müşterilerin gişeden sinema salonu kapısına yürüme zamanı olan 0. Şimdi yapmamız gereken işlem bu modelin simülasyonunun tamamlanabilmesi için Arena’daki ayarlarının yapılmasıdır. Son modülümüzün adı Depart.5dk. Modelimize müşterilerin gelişlerini. işlem görme zamanlarını vermiş durumdayız. depart modülünü yerleştirmemiz.5dk olan normal dağılım verdik. İşlem zamanını bulmak için yine gözlem yapmak zorundayız. sonra istasyon isimlerini vermemiz.

Tamamlanmış Simulate Modülü Projenin başlığı. simülasyonun kaç kere tekrar edeceği. Simülasyon sonuçlarını görmek için bir de Plot özelliğinden yararlanılacaktır. Plot eklemek için Animate modülünden yararlanılacaktır. Animate Modülü . Gerekli bilgiler aşağıdaki şekilde verilmiştir. Fakat Animate modülü ile yapmak biraz daha kolaydır. Ancak bu işlem Animate araç çubuğundan da yapılabilir. bu projenin kim tarafından yapıldığı. .İlk olarak bu simülasyonun ayarlarının yapılacağı Simulate modülü yerleştirilmelidir. Bu pencerede eğer tarih vermezsek Arena otomatik olarak bilgisayarda bulunan tarihi varsayılan olarak alacaktır. Buradan istediğimiz herhangi bir kuyruk miktarı veya bekleme zamanı gibi verileri bir grafik olarak almak için yararlanılacaktır. ne zaman başlayıp ne zaman biteceği gibi bilgiler verildikten sonra model için artık hazır durumdayız.

Daha sonra server modülünün sağ tarafındaki çıkış kutusunun içinden başlayarak aynı şekilde sinema salonunun kapısına kadar olan yolu belirledik. Simülasyonumuzun güzel gözükmesi için draw menüsünden yararlanarak yollar oluşturduk. Output Analyzerın nasıl kullanıldığını görmek için Statistics Modülününden yararlanıyoruz. Statistics modülünde 5 tane konu başlığı vardır. Elements paneliyle de yapabileceğimiz bu işlemi daha kolay yapabildiğimiz için Statisstics modülünü seçtik. Bizim yaptığımız zaman aralığını (Time Range). Bu ayarlamalar de aşağıdaki şekildedir. Böylelikle müşterilerimizin sinemanın dış kapısından içeri girdikten sonra gişeye kadar olan yolu rotalamış olduk. Plot Diyalog Kutusu Expressions bölümü Animate modülünün verilerinde otomatik olarak dolduruldu. Sinemamızın giriş kapısına arrive modülünün animasyon şeklini sinema salonunun giriş kapısına da deparet modülümüzün animasyon şeklini koyduk. Daha sonra sağ tarafta bulunan animasyon araç çubuğundaki route butonuna bastık ve cusorumuz + şekline geldi. Daha sonra Plot ile ilgili ayarlamalar yapmak üzere küçük grafik üzerine çift tıklanarak Plot ile ilgili ayarlamalarımızı yaptık. Gişe kuyruğundaki müşteri sayısını gösteren plotumuzu daha iyi görebilmek için büyüterek ortaya yerleştirdik. Bu örnekte sadece Plot istendiği için sadece o seçenek seçildi. Hemen sonra Data Object kısmında hangi nesneye ilişkin verilerden bir plot elde etmek istediğimizi belirttik. ve eksenlerle ilgili bilgileri vermek oldu. Bu modül simülasyonun çalışması esnasında istediğimiz istatistik türünün kaydını tutar ve ismini bizim belirlediğimiz dat uzantılı bir dosyaya kaydeder.Animate modülü yerleştirildikten sonra yapılması gereken işlemler aşağıdaki şekilde belirtilmiştir Animate modülünde ilk olarak animasyonu yapılan müşterilerden hangi göstergeler istendiğine karar verilmelidir. Daha sonra da bu veri ile ilgili bilgiler kısmını Information kısmı ile yaptık. Bunu yapmak da Display As kısmındaki dört seçenekten istenilenleri seçmek yardımı ile olur. Bunlar Tallies (akış zamanı ve . Sol taraftaki arrive modülümüzün animasyon şeklinin içine tıklattıktan sora müşterilerin izlemesini istediğimiz yolu belirleyerek server modülünün sol taraftaki giriş kutusunun içine tıkladık.

Simülasyonu çalıştırdığımız zaman akış zamanı ile ilgili bilgiler akiszamani. Açılır ok penceresinden “akis zamani” nı seçiyoruz. değişkenler.dat" şeklinde çift tırnak içinde yazıyoruz. Eğer başka istatistik bilgilerini de tutmak istiyorsanız farklı dosya isimleri vermeyi deneyiniz çünkü farklı dosya ismi vermezseniz son yaptığınız işlemin bilgileri kaydedilir. daha öncekiler silinir. konveyör. depolanan parçalar. transporter. Outputs (eğer simülasyonun tekrar sayısı birden fazlaysa. örneğin kaynağın boş kalma sıklığı gibi) Statistics Modülünün Tamamlanmış Hali Biz örneğimizde Tallies’de bulunan akış zamanı ile ilgili bilgilerin kaydını tutmak istiyoruz. . Ok deyip pencereyi kapatıyoruz. Sinemanın dış kapısı Simülasyonumuzu çalıştırdıktan sonra şu ekranı elde ederiz. Simülasyon bittikten sonra sonuçları görmek isteyip istemediğimiz sorulacaktır. istasyon gibi konu başlıklarıyla ilgili istatistikleri tutar. Counters (bizim örneğimizde müşteri sayısını kaydeder).). minumum. konveyör kullanımıyla ilgili olarak meşgul birim sayısı. Check dedikten sonra hiçbir hata olmadığına dair bir mesaj gelecek ve Go dediğimizde de simülasyon çalışacaktır.kuyrukta bekleme zamanı gibi bilgileri kaydeder). transporter. Bunun için add butonuna basıyoruz. Diğerleriyle ilgili olarak da o andaki sayısı kaydedilir. erişilebilir birim sayısı gibi bilgiler kaydedilir. Save observations to a file kutucuğuna bir tik koyarak bilgilerin kaydedileceği dosyayı "akiszamani. simülasyon çıktılarının değerlerinin ortalama. kuyruk.bizde bu dosyayı output analyzerda inceleyeceğiz Modelimizi tamamladıktan sonra Go diyerek Simülasyonu çalıştırabilir veya Check diyerek önce hataları bulmasını isteyebiliriz.dat isimli bir dosyaya kaydedilecek . Time-Persistent (kaynak. Bize Tally name soruyor. maksimum. Kaynak. standart sapma gibi değerleri verir) Frequencies (bir olayın oluş sıklığı gibi bilgileri kaydeder.

732 179 Run execution date : 12/15/2000 Model revision date: 15/12/2000 . ARENA Simulation Results KAĞAN EMRE YÜKSEL .4777 (Insuf) .3798 14.Sinema salonunun kapısı Eğer herşeyi doğru yaptık ise sonuçlarımız yaklaşık olarak şu şekilde olmalıdır.0 TALLY VARIABLES Identifier Average Half Width Minimum Maximum Observations _______________________________________________________________________________ gise_R_Q Queue Time 3.6261 (Insuf) 2.00000 12.License #9400000 Summary for Replication 1 of 1 Project: Gise Simulasyonu Analyst: Kağan Emre Yüksel Replication ended at time : 480.157 180 akis zamani 6.

her parçanın geldiği anın hafızada saklanmasını istememizdir. Yeni butonuna basarak output diyalog penceresini açıyoruz. Arrival Data bölümünde. Bu bir seferde bir çaların bir kere geldiğini belirtmektedir.00000 5. Gelişlerin kendisinin tarif edildiği kısım. Yığın boyutu anlamına gelir.0000 1.0000 1. Plot.0000 (Insuf) 1. Bundan sonra Statistics modülünde kaydını tuttuğumuz dosyaların analizini yapmak için output analyzerı açıyoruz. Bu seçeneği seçtiğimizde istasyon ismine gerek kalmadan .00000 1. Enter Data. Çünkü daha sonra akış zamanlarını ve parçaların ne zaman sistemi terk ettiklerinin ve ne kadar sistemde kaldıklarının hesabını bilmek isteyebiliriz. Arrival Data.00000 gise memuru Available 1. parçalar bir kere sisteme geldikten sonra parçalara neler olduğunu belirten kısım. Veya Arena’nın kendi verdiği varsayılan isimi kabul etmek gerekir. 6. parçalar için giriş noktasının tarif edildiği kısım. Bu değer Arena’nın otomatik olarak atadığı bir değerdir. Time Between alanına Logn(2.DISCRETE-CHANGE VARIABLES Identifier Average Half Width Minimum Maximum Final Value _______________________________________________________________________________ gise memuru Busy . Route seçeneğini seçtiğinizde ise 3 seçenek karşımıza çıkar bunlar StNm: istasyon ismi girilir. Bu özellik modül içindeki bütün gri alanlar için geçerlidir. Moving avarege. MarkTime Attribute kısmını gelis zamani olarak doldurduk.0000 COUNTERS Identifier Count Limit _________________________________________ musteri 179 Infinite Simulation run time: 0.dat dosyasını seçiyoruz.6.87) dağılımı verildi. Enter Data kısmında Station yani istasyon olarak Gelisler dedik.58 minutes. Table gibi seçenekleri seçerek çıktı dosyamızı daha ayrıntılı bir şekilde analiz edebiliriz. (bizim örnekte bu şekildedir) Seq: sequence yani sırayla manasına gelir.1 Arrive Modülü Arrive modülü parçaların dışarıdan modele doğru gelişlerinin doğuş yeridir. Daha sonra graph menüsünde bulunan Barchart. Leave Data.0000 # in gise_R_Q 1. Add butonuna basarak Statistics modülünde Save observatios to a file kısmına ismini yazdığımız akiszamani.0000 1. Bunun anlamı.1. Bu alanı mutlaka doldurmanız gerekir.3041 (Insuf) . ÇOK KULLANILAN MODÜLLERİN DETAYLI İNCELENMESİ 6. Arrive modülüne girebileceğimiz bilgi türleri üç kısma ayrılmıştır. Simulation run complete. Route veya Connect.90946 (Insuf) . Histogram. Leave Data kısmında Modülleri birbirlerine bağlamak için iki yol vardır. Arena içinde bir İstasyon parçaların transferi için ismi olan birer fiziksel yerdir. ilk olarak Batch Size olarak 1 değerini görmekteyiz.0000 . Çift tıkladığımız zaman içine gireriz ve Arrive diyalog kutusu karşımıza çıkar.

modüle gerekli olan istasyon ismin vermektedir. Project alanında projenin başlığı. Tally. kaynağı.2 Server Modülü Server modülü makinayı. Depart modülünün üç alanı Enter Data. Replicate alanında varsayılan tekrar sayısı 1’ dir. sistemi terk eden müşterilerin sayısını bilmek istiyorsak. Akis zamani adı verildi ve Arrive modülünde verdiğimiz dağılım olan gelis zamani Attribute kısmına yazıldı. Server Data. Server modülü de üç alandan oluşmuştur. Diğer bir seçenek ise Connecttir. Leave Data kısmına yine Route seçeneği seçilerek bir sonraki istasyon olan cikis yazıldı ve route time olarak 0. Kaynak ismini gise memuru olarak kabul ettik. Yine varsayılan olarak gelen değerler arasında kuyruk uzunluğu. Process Time alanını parçaların bu makinada ne kadar işlem görmelerini istiyorsak o değere göre doldurduk. Son seçenek Expr: Expression yani tanım demektir.5dk değeri girildi. Count.4 Simulate Modülü Çalışma uzunluğu. Enter Data’da istasyonu cikis ismiyle adlandırdık ve kalan kısımları varsayılan olarak bıraktık. projenin tarihi belirtilir. İstasyonlar birbirine kullanıcının verdiği tanıma göre bağlanır. bitiş zamanı 480 (dk) olarak belirtildi. Enter Data. (8 saat * 60 dk = bir günde çalışılan zaman) . müşteriler sistemi terk ederken onlar hakkında not almak istediğimiz herhangi bir şey olup olmadığı kısımlarında gerekli bilgileri verdik. Count alanında Individual Counter düğmesine tıkladık ve sayıcıya musteri adını verdik. 6. Enter Data. 6. kuyruğu. ve kuyrukta geçen süreler yer almaktadır. Başlangıç zamanı 0. Buna göre parçalar. müşterilerin sistemi terk etmeye nasıl başlayacakları.istasyonlar sırayla birbirine bağlanacaktır. Enter Data kısmında yaptığımız bütün işlem Station kısmına Server modülünün ismi olacak olan Gişe değerini yazmaktı. parçalara Server’ dayken neler olduğunu açıklamaktadır. Bu seçenekler Queue düğmesine tıklanır ise görülecektir. tekrar sayısı Simulate modülünden verilir. analiz yapanın adı. Resource Statistics kutusu varsayılan olarak seçili durumda geldi böylece gişenin kullanımını görebileceğiz. Interval kısmının seçilmesi ile Arrive modülünde müşteri gelis zamani belirtildiği zaman ile Depart çıktığı ana kadarki kaydın tutulması sağlandı. Böylece müşterinin akış zamanı Arrive modülünde başlayıp. Depart modülünde son buldu. Leave Data bölümü ise bu modülü terk eden parçaların kontrolü ile ilgilenir. Sistemi terk eden müşterilerin hesabının yapılması ve akış zamanlarının kayıtlarının tutulması için Tally alanında Individual Tally seçildi. modüller arasında hareket ederken herhangi bir zaman kaybına uğramadan direk olarak bir sonraki modüle geçerler. ve parçaların işlenmeleri için gerekli zamanları içerir. Böylece bu noktanın basit bir çıkış noktası olduğunu belirttik. Server Data kısmında.3 Depart Modülü Depart modülü sistemi terk eden parçaları göstermektedir. Server Data ve Leave Data bölümleri. 6. Müşteriler sistemi terk ettikçe birer birer artacak olan Depert modülünün üst kısmındaki kutucuktur.

SONUÇ Bu sonuçlar karşılaştırıldığında Arena’ nın diğer simülasyon programlarından farklı olduğu yerler gözükmektedir. hizmet temelli firmalara kadar bir çok dalda simülasyon yapılabilmektedir. Border ve Fill Area kısımlarıyla da renk ayarlamaları yapılabilir.6. Plot’ ların boyları üstlerine tıklandığında gelen köşe noktalardan değiştirilebilir. .5 Dinamik Plot Yerleştirdiğimiz Plot Kuyruktaki adedi hesaplamızı sağladı. Daha sonra bir sonraki ayarlamaya geçmek için bu kutuyu kapattık. C) desteklemektedir. Bu işlemi de templateler ve modüller oluşturarak sağlamaktadır. Ayrıca Arena içinde bulunan verilerin analiz yöntemleri de ister girdi ister çıktı olsun verilerin analiz edilmesinde kullanımı son derece kolaylaştırmıştır. Refresh olarak full seçildi. Animate modülünde Data Object kısmında ilk olarak Queue seçildi ve daha sonra Queue name kısmındaki menüden gise_R_Q seçildi. Sağ tarafta bulunan Area. Fortran.(burada bir tane olmasına rağmen ileride kuracağımız büyük modellerde bu çok daha fazla olacaktır. Bu menü bizi her birinin ismini hatırlama zorunluluğundan kurtarır. Bu şekilde üretim hattından. hazır yiyecek firmalarına. Plot ile ilgili diğer işlemler ancak bu grafiğin üzerine çift tıklanması durumunda ayarlanabilir. Arena’ da istendiği zaman SIMAN simülasyon dilinden modüller yerleştirilebilmekte ve elle simalasyon dili yardımıyla yazar gibi komutları ekranda tıklayarak yerleştirebilmekteyiz. Arena simülasyon dillerinin esnekliğinin yüksek seviyeli modelleme yeteneğini simülasyon dışı dillerle (Visual Basic. Plot alanının etrafının bir çerçeve ile çizilmesi istendi ve Bounding Box yaptık. Plot diye bahsettiğimiz şey Animate modülünün üstündeki grafiktir.) Information alanında Number In Queue kısmını seçtik. Son olarak da en altta X-Labels işaretlenerek grafiğin altında değerler olması sağlandı. 7. Expressions kısmı Plot edilecek nesnelerin listesini içerir.

Sign up to vote on this title
UsefulNot useful