Prof. Luis Bustos M., Juan Orellana C., y Sergio Muñoz N.

Stata

es un programa estadístico implementado para Windows 95 y superior, Unix y Macintosh. Este programa provee herramientas para el manejo de bases de datos, analizar datos utilizando estadística descriptiva e inferencial. Esta guía será desarrollada para Stata sobre Windows 95 / 98 y superior

Stata es totalmente compatible con todos los software de este sistema, tiene la filosofía Win95 y por lo tanto el sistema de menú e iconos. La pantalla principal de Stata, contiene cuatro ventanas. La más grande es la ventana de resultados; a la derecha, de arriba hacia a bajo, están las ventanas comandos previos (Review) y la de variables. En la parte más baja de la pantalla se encuentra la ventana de comandos (Stata Command). El propósito de esta guía es ejemplificar algunos comandos de Stata (entre muchos) y revisar algunas herramientas que Stata dispone para el manejo de bases de datos.

Objetivos
1.1 Manejar el ambiente de Stata 9.0. 1.2 Conocer el concepto de base de datos en Stata 9.0. 1.3 Aplicar las herramientas de presentación y resumen de datos usando el software Stata 9.0.

Partamos por lo primero!!! I.- Creación de una base de datos Stata. Supongamos que estamos interesados en analizar los datos de un ESTUDIO EN UNA UNIDAD DE CUIDADOS INTENSIVOS (Hosmer and Lemeshow, pág. 21 and Appendix). Se selecciona una muestra de 200 pacientes que fueron parte de un estudio en adultos admitidos en una Unidad de Cuidados Intensivos (UCI), los datos se encuentran en una base de datos excel, denominada uci200.xls, el cuestionario utilizado para el registro de los datos fue el siguiente Número de la encuesta (id): Estado vital (estvital): Sexo (sexo) Edad (edad) Servicio de donde se hizo el ingreso (servuci) Presenta infección al ingreso (infecing) Presión sistólica al ingreso (psistoli) Presión diastólica al ingreso (pdiastol) 0: Vivo 1 Muerto 0: Mujer 1: Hombre En años 0: Cirugía 1: Medicina 0: No En mmHG En mmHg 1: Sí Cuestionario

1

Pulso al ingreso (pulsoing) Tipo de admisión (tipoadm)

En minutos 0: Electiva 1 Urgencia

Base de datos uci200.xls

1ra fila se escriben las variables abreviadas

Ingresar 1era encuesta

Para crear una base de datos debemos considerar que ésta será una matriz que contendrá en cada fila el perfil de un paciente y en las columnas las variables. En nuestro ejemplo, la matriz de datos será de orden 200 filas (pacientes) por 10 columnas (variables). Para crear la base de datos anterior hay que hacer clic en datos, después en formulario La tecla tabulador permite avanzar de variable en variable

2

I. Convertir una base de datos Excel en una base de datos Stata. Para crear esta matriz de datos en Stata se deben seguir los siguientes pasos: 1.- Seleccionar y Copiar los datos de la base de datos Excel.

2.- Abra Stata (obvio ☺ ), desde inicio, programas, stata o bien desde un acceso directo. 3.- Stata dispone de un editor de Datos llamado Data Editor. Con su mouse haga un click en el icono que le corresponde. 4.- Ubique el cursor en la primera fila, primera columna. Click en Edit, luego Paste (pegar)

Editor

5.- Defina las variables. En el encabezado de cada columna haga doble click y complete los campos Name, Label y Format con el nombre de la variable (no más de 8 caracteres), la etiqueta ( no mas de 23 caracteres), y el tipo de variables (Ej. %8.0g indica que la variable es numérica de 8 dígitos y de formato general; %8.2f indica que la variable es numérica de 8 dígitos y de formato fijo con dos decimales). Para mas información sobre formato de

3

variables, recurra al menú Help, luego Search y escriba format

Doble click para desplegar propiedades

Etiqueta del estado vital

Definir y modificar variables

6.- Una vez escrito los label y definir las etiquetas, cerrar el editor para comenzar a utilizar el stata De esta forma usted ha creado su propia base de datos!!!!!!! NO OLVIDAR GRABAR SU BASE DE DATOS. También se dispone de un Programa de conversión de Datos, éste se llama StatTransfer y reconvierte datos de muchos formatos (Excel, Lotus, Dbase, etc.) a Stata y viceversa.

Nota: Si se desea crear una base de datos correspondiente a un gran cuestionario, entonces se recomienda usar un programa especializado, como el Epi Info o el Access. Estos softwares disponen de programas de entrada de datos más amigables y eficientes que el Excel y Stata.

4

II.- Análisis descriptivo de una base de datos. Si ya existe una base de datos stata, desde el menú principal de Stata, click en (open) y seleccionarla. Inmediatamente abierta la base de datos, usted verá en la ventana de variables el listado de todas ellas.

Comando stata que permite cargar una base de datos

Procedamos a revisemos algunos comandos de Stata. Ellos se escriben en la "ventana de comando" y siempre en minúsculas. Previo al análisis se recomienda crear un archivo que guarde todos los resultados que se realicen con la sesión activa, para esto siga las instrucciones:
4. Guardar

1. Presionar este botón para crear un archivo de texto donde se guarden todos los resultados desplegados en la ventana Results

2. Seleccionar Tipo de archivo “log” (texto)

3. Asignar un nombre con extensión *.doc o por defecto asigna *.log

5

1. describe (desc) : Describe el contenido de la base de datos activa.

2. codebook: Describe el contenido de los datos de una variable

6

3.- list : Permite listar datos en la ventana de resultados de las variables especificadas.

El operador == se usa para asignar un valor a una variable

. list

estvital sexo edad if edad==16

+------------------------+ | estvital sexo edad | |------------------------| 26. | Vivo Fem 16 | 142. | Vivo Masc 16 |

Veamos un poco de medidas de resumen.
4.- summerize (sum): Entrega las medidas de resumen de las variables bajo estudio.

5.- sort : Ordenar datos. Suponga que desea listar las cinco más bajas Presiones Sistólicas observados en la base. sort psistoli list id psistoli in 1/5

7

6. Preguntas y respuestas. 1.- ¿Cuál fueron los valores mínimos y máximos, el valor promedio y desviación estándar de la presión sistólica. 2.- ¿Quiero más detalles?, percentiles. R: ok!

Después de la coma se agrega la opción de detalles

3.- ¿Puedo obtener algunos Estadígrafos de edad y presión sistólica en función del estado vital? R: Si!!!!. bys = abreviación del comando by sort

8

4.- ¿Cómo puedo obtener algunas medidas de resumen de presión sistólica de los pacientes que ingresaron a la uci y que presentaron una edad superior o igual a 65 años? R:
. sum psistoli if edad>=65 Variable | Obs Mean Std. Dev. Min Max -------------+-------------------------------------------------------psistoli | 91 135.2418 35.74737 62 212 . sum psistoli if edad>=65 & estvital==1

Variable | Obs Mean Std. Dev. Min Max -------------+-------------------------------------------------------psistoli | 23 115.4348 36.52997 62 190

Nota: Si desea más información del comando if o cualquier otro comando de Stata, diríjase a la opción search del menú Help y obtendrá una lista completa de comandos relacionados con el que usted indicó. Debe seleccionar el comando específico (en letras verdes) y usted obtendrá descripción completa del comando y algunos ejemplos. Desea hacer tablas de resumen de Datos ..... de una entrada o dos o tres ..... ? 7.- tabulate (tabu): Despliega, en su forma simple, tablas de distribución de frecuencia. 1. ¿Cuál es el estado vital de los pacientes que ingresaron a la uci?

2. ¿Cuál es el estado vital de los pacientes que ingresaron a la uci y que tenían una edad superior o igual a 65 años?

9

3. ¿Cuál es la distribución del estado vital de los pacientes según tipo de admisión.

Fila

Columna

Opciones row = porcentajes por filas col = porcentajes por columnas nokey = para no desplegar los comandos de la tabla de contingencia. nofreq = despliega tabla de contingencia solamente con porcentajes

tab Sexo

sexo estvital, row nofreq nokey

| Estado Vital | Vivo Muerto | Total -----------+----------------------+---------Fem | 78.95 21.05 | 100.00 Masc | 80.65 19.35 | 100.00 -----------+----------------------+---------Total | 80.00 20.00 | 100.00

Seleccionar tabla y con botón secundario del Mouse elegir copy table Pegar en Excel: diseñar tabla y graficar

10

Click en opciones de graficos

Seleccionar

4. De la relación entre tipo de admisión y estado vital, encuentre el promedio, desviación estándar y frecuencia de presión sistólica: tabu tipoadm estvital, sum(psistoli)

11

III.- Creación de nuevas variables. 8. generate y replace : Permiten la creación de nuevas variables a partir de otras existentes o mediante supuestos y expresiones matemáticas. Las variables generadas aparecen inmediatamente en la ventana de variables al final de las otras

Algunos ejemplos. 1. Es muy frecuente que en un análisis estadístico sea necesario estandarizar variables, esto es reducirlas y centrarlas. A cada observación se debe restar la media y se dividir esta diferencia por la desviación estándar. En símbolos esto sería zi = (xi - media)/sd. Los datos estandarizados corresponderían a una nueva variable que hay que crear:

2. Si se desea crear una nueva variable que divida la edad en 4 grupos iguales, se deben usar los cuartiles y el siguiente procedimiento: a) Usar comando centile para encontrar los cuartiles pedidos. b) Usar generate y replace

Operadores lógicos:

&=y |=o

12

Para etiquetar las respuestas y recordar la codificación se procede de la siguiente manera:

sum edad if edad<=46.25 | edad>=72 La opción de o (|) indica unión de los valores extremos sum edad if sexo==1 Este comando entrega las medidas de resumen solo de los hombres, por esa razón doble igual para poder asignar lo que se desea evaluar Recordar: Una forma mas fácil de etiquetar es desde el editor 9. recode : Permite también generar una nueva variable, mediante el siguiente procedimiento 3. Se agrupará la edad en dos categorías, utilizando el percentil 50, mediante el siguiente procedimiento:

Opción que considera los siguientes tramos: 16-63 y 64-92

13

4. Si deseamos convertir los missing values (.) de una variable en el valor 99, una forma sería: recode variable .=99 5. Para eliminar una variable recién creadas, se procede así: Drop z1

Observación Una vez finalizada la sesión de trabajo hay que cerrar el archivo de texto para guardar los resultados para ello se escribe directamente en stata command o bien

Recordar de grabar los cambios realizados en la base de datos

Presionar este botón para cerrar archivo de texto con los resultados de la sesión activa. Este se puede abrir con cualquier editor de texto

Esta opción permite guardar los comandos utilizados durante la sesión de trabajo. Se utiliza cuando se diseña el plan de análisis, escribiendo directamente los comandos que permitan realizar el análisis propuesto, para ejecutar el archivo de programa (*.do) hay que presionar la siguiente opción

14

Sign up to vote on this title
UsefulNot useful