P. 1
WeldPlanner-2010_UsersGuide

WeldPlanner-2010_UsersGuide

|Views: 200|Likes:

More info:

Published by: 'Magda Looney Tesalonika' on Jun 26, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

03/23/2015

pdf

text

original

Sections

Insert the front cover image in this header, then position and resize it !

Weld Planner 2010
User's Guide

Distortion Engineering Workflow - Car Sub-Frame

Weld Planner 2010

USER'S GUIDE
Fast Distortion Engineering for all Kinds of Industry

The documents and related know-how herein provided by ESI Group subject to contractual conditions are to remain confidential. The CLIENT shall not disclose the documentation and/or related know-how in whole or in part to any third party without the prior written permission of ESI Group.

© 2010 ESI Group. All rights reserved.

October 2010
GL/WLDP/10/02/00/A

EXECUTIVE SUMMARY

This document describes a working session with the Weld Planner, based on practical examples. You will find in addition tips and tricks, frequently asked questions and known limitations and issues.

Weld Planner 2010 © 2010 ESI Group

i

USER'S GUIDE (released: October-10)

CONTENTS
WHAT DOES THE WELD PLANNER DO FOR YOU ........ 1 IMPORT MESHES .............................................................. 3 PREPROCESSING ............................................................ 5
Loading the Training Object ...................................................................... 5 Visualization of Objects ............................................................................. 7 Erase Welding Joints and Clamps from Screen ........................................ 8 Look Inside Components - Transparency .................................................. 9 Increase the Display of Weld Joints......................................................... 10 Generate Objects .................................................................................... 11 Delete Existing Joints / Objects ............................................................... 12 Generate New Joints ............................................................................... 13 Display / Inverse the Running Direction of Joints .................................... 14 Split Joints in Discontinuous Sections ..................................................... 15 Model the Progression of Welding Fabrication ........................................ 16 Determine the Length of Welding Joints .................................................. 17 Check the Joint Size that will Shrink ........................................................ 18 Erase Temporary Objects from Screen ................................................... 19 Define / Check Properties of Clamps ...................................................... 20 Define / Check Properties of Objects ...................................................... 21 Define the Weld Plan ............................................................................... 22 Store the Project ...................................................................................... 24 Separation of Components Until Welding ................................................ 25

SOLUTION ....................................................................... 27

Linear and Non-linear Geometry ............................................................. 27 Generate the Input for the Solution ......................................................... 28 Generate the Input for a Transient Solution............................................. 29 Solve the Project ..................................................................................... 30 Management of Large Structures ............................................................ 32
64-bit GUI Version .................................................................................... 32 DMP, Computation Time Reduction ......................................................... 32

FILE TYPES ..................................................................... 37 POST-PROCESSING ....................................................... 39
Load the Result File................................................................................. 39

CONTENTS

USER'S GUIDE (released: October-10)

ii

Weld Planner 2010 © 2010 ESI Group

Display Results ........................................................................................ 40

ADVANCED POSTPROCESSING ................................... 41 EXPORT OF THE DEFORMED GEOMETRY .................. 47

Step by Step Distortion & Stress ............................................................. 41 Computation of Model Differences .......................................................... 45

Apply the Distortion Vector to Modify the Mesh ....................................... 47

HOW TO GENERATE THE MOST EFFICIENT MESH ... 49 HOW TO MODEL ANGULAR DISTORTION ................... 53 TRAINING CD .................................................................. 57 TIPS AND TRICKS ........................................................... 59 FREQUENTLY ASKED QUESTIONS .............................. 65 KNOWN LIMITATIONS AND ISSUES ............................. 71

CONTENTS

Weld Planner 2010 © 2010 ESI Group

1

USER'S GUIDE (released: October-10)

WHAT DOES THE WELD PLANNER DO FOR YOU
With the Weld Planner, you can perform virtually Welding Distortion Engineering. You define components, joints, clamps and welding sequences in a weld plan, compute distortion and analyze distortion tolerances. The solution requires shell meshes and uses a fast shrinkage method.

The Weld Planner will help you to find the optimum between the amount of clamps and generated weld distortion.

WHAT DOES THE WELD PLANNER DO FOR YOU

USER'S GUIDE (release: October-10)

2

Weld Planner 2010 © 2010 ESI Group

WHAT DOES THE WELD PLANNER DO FOR YOU

Weld Planner 2010 © 2010 ESI Group

3

USER'S GUIDE (released: October-10)

IMPORT MESHES
The Weld Planner is working with shell meshes. You will find all about meshes in the document ‘How to Manage Meshes for Weld Planner Usage *.pdf’ It is included in chapter of the Weld Planner Getting Started Course, ‘How_To_Prepare_and_Import_Meshes’

Car Sub-Frame – Mesh in Visual Mesh

IMPORT MESHES

Weld Planner 2010 © 2010 ESI Group

5

USER'S GUIDE (released: October-10)

PREPROCESSING
LOADING THE TRAINING OBJECT
Open the file subframe.wpp in the folder \examples (installation folder) or .\ 03_First_Example\Files (Weld Planner Getting Started Course). In the installation folder \examples, you will find many other practical examples, like a ship panel, a segment of a bridge, a T-joint with deposit and basic validation tests of most simulation options.

PREPROCESSING Loading the Training Object

USER'S GUIDE (release: October-10)

6

Weld Planner 2010 © 2010 ESI Group

After loading the Subframe, you will get the following view

In the Object Tree on the right side, you will find pre-defined components, welds and clamps.

PREPROCESSING Loading the Training Object

Weld Planner 2010 © 2010 ESI Group

7

USER'S GUIDE (released: October-10)

VISUALIZATION OF OBJECTS
To visualize objects, you can do the following. Click with the middle mouse button on a component: It is the new rotation center of the screen. Click with the left mouse button on the screen and move: Rotate all visible objects Click with the right mouse button in the screen and move up and down: Zoom in and out. Click ‘Ctrl’ and with the left mouse button in the screen and move: Rotate all visible objects in the plane of the screen. Click with the right mouse button on a object: It disappears from screen Click with the right mouse button on the sign in the object list: The object appears again. With <Shift+Right click> you invert the visibility of the objects in the object group. Click with the left mouse button on the dotted sign left of an object: The object will be highlighted. Click the middle mouse button and move the mouse: Translate Roll the middle mouse button: Zoom in and out around the rotation center Click on to center the display

-

Click on any of the following symbols to position the display

PREPROCESSING Visualization of Objects

USER'S GUIDE (release: October-10)

8

Weld Planner 2010 © 2010 ESI Group

ERASE WELDING JOINTS AND CLAMPS FROM SCREEN
Click with the left mouse button on the object tree folder ‘Welds’ in the object tree. All welds are then marked blue. Click the left mouse button together with <Shift> or <Ctrl> to perform choices of groups of objects. With <Shift+Left click> you invert the choice of objects in an object group.

Then activate ‘Presentation Off’. The welds disappear from screen.

You can do that with all types of objects.

PREPROCESSING Erase Welding Joints and Clamps from Screen

Weld Planner 2010 © 2010 ESI Group

9

USER'S GUIDE (released: October-10)

LOOK INSIDE COMPONENTS - TRANSPARENCY
Click on the component QTV – It is marked blue .Then move the opacity button from right to left. The component QTV becomes transparent.

Now you can look inside the components.

PREPROCESSING Look Inside Components - Transparency

USER'S GUIDE (release: October-10)

10

Weld Planner 2010 © 2010 ESI Group

INCREASE THE DISPLAY OF WELD JOINTS
Erase all components from the screen (Mark all components in the object tree and switch ‘Presentation - Off’). In the object tree, mark all welds for which you need to increase the display. In the “Parts” selection move the ‘2D Point Size’ button from left to right to change the display of the weld seams.

PREPROCESSING Increase the Display of Weld Joints

Weld Planner 2010 © 2010 ESI Group

11

USER'S GUIDE (released: October-10)

GENERATE OBJECTS
In general, you always define ‘Node Sets’ and then you declare the object type. You can define Welds, Boundary Conditions, Bolts, Stops and Pre-deformation. If you generate node sets by clicking nodes, you can terminate the selection by clicking the selected node again. If you change the object type, it is moved into the corresponding folder in the object tree.

PREPROCESSING Generate Objects

USER'S GUIDE (release: October-10)

12

Weld Planner 2010 © 2010 ESI Group

DELETE EXISTING JOINTS / OBJECTS
In order to delete all joints (or other objects) physically from the database, mark all joints in the object tree, and click on will be deleted. . Attention, there is no undo. All joints

PREPROCESSING Delete Existing Joints / Objects

Weld Planner 2010 © 2010 ESI Group

13

USER'S GUIDE (released: October-10)

GENERATE NEW JOINTS
Click on ‘Weld Seams’ – ‘Weld Detection’ – ‘Find all Welds’. New welds are detected wherever components do have nodes in common. You have several options to guide this process.

You can generate welds in the Menu ‘Weld Seams’ either under ‘Weld Detection’ or ‘Weld Definition’.

There is a second option available to generate clamps and welds. Go to ‘Tools’ – ‘Welds/Clamps’.

PREPROCESSING Generate New Joints

USER'S GUIDE (release: October-10)

14

Weld Planner 2010 © 2010 ESI Group

DISPLAY / INVERSE THE RUNNING DIRECTION OF JOINTS
Click on the symbol left to the joint WELD_LTL_QTV_01. It will be highlighted. Bring it to the middle of the screen and zoom in. Click with the right mouse button on WELD_LTL_QTV_01. You can see animated arrows that show the running direction. Click on been reversed. , then display the running direction again. The running direction has

In case the part is huge, the display animation may appear too small. You can then scale the preview. Go to ‘Options’ – ‘Scale preview-arrow’. Just click on it – it will be done automatically depending on the assembly size.

PREPROCESSING Display / Inverse the Running Direction of Joints

Weld Planner 2010 © 2010 ESI Group

15

USER'S GUIDE (released: October-10)

SPLIT JOINTS IN DISCONTINUOUS SECTIONS
In order to be able to simulate a weld joint that is fabricated in discontinuous sections, you can split welds. The split weld will be automatically deleted, and only the subsets will be kept. You can re-join the subsets into welds again if required.

Before you split a joint, you should sort the nodes of the selected weld seams by clicking the symbol been split in two parts. . Below, the joint WELD__LCB_L__TCB_F__01 has

PREPROCESSING Split Joints in Discontinuous Sections

USER'S GUIDE (release: October-10)

16

Weld Planner 2010 © 2010 ESI Group

MODEL THE PROGRESSION OF WELDING FABRICATION
In order to simulate the progression of the fabrication of a weld, you should not split it. You should rather define in ‘Process Definition’ how many fabrication steps you want to simulate along a weld joint. Before you can simulate a joint in several steps, you should sort the nodes of the selected weld seams by clicking the symbol stepwise simulation may not be correct. . Otherwise, the results of the

In particular circular welds or lengthy welds on flimsy structures should be welded in several steps. You need to find out on your object how many steps lead to good results. In case of doubt simulate a transient welding with SYSWELD first.

PREPROCESSING Model the Progression of Welding Fabrication

Weld Planner 2010 © 2010 ESI Group

17

USER'S GUIDE (released: October-10)

DETERMINE THE LENGTH OF WELDING JOINTS
Mark the welds you want to measure and click on the symbol to measure the weld length. Next to the display, the weld length is exported into the file weld_length.csv.

PREPROCESSING Determine the Length of Welding Joints

USER'S GUIDE (release: October-10)

18

Weld Planner 2010 © 2010 ESI Group

CHECK THE JOINT SIZE THAT WILL SHRINK
Click on ‘Visual Effects’ – ‘Generate Tubes’ or ‘Generate Spheres’. All what is inside the tubes or spheres will shrink in the simulation. Tubes are temporary objects – they are not listed in the object tree.

The radius of the tube / the spheres is taken from the property ‘Half Bead Width’ you have entered as weld property for ‘MIG/MAG’, and multiplied with the factor KF in the material properties. To avoid misleading results in simulations, you should avoid modifying the KF factor. It is best practice to leave it to 1.0, and to generate a mesh that fulfills the requirements instead. In case ‘Laser’ is chosen as process, only the nodes of the joint are taken into account for the shrinkage, no matter what has been defined as tube width. Don’t worry if you do not find your process in the process list – the Weld Planner computes shrinkage. It is defined for all processes over the diameter of the tube and the captured nodes inside. Best practice is to choose always MIG/MAG and control the diameter of the tube.

PREPROCESSING Check the Joint Size that will Shrink

Weld Planner 2010 © 2010 ESI Group

19

USER'S GUIDE (released: October-10)

ERASE TEMPORARY OBJECTS FROM SCREEN
Temporary objects are edges, tubes or spheres along welding joints to illustrate the diameter of the molten zone modeled, spheres to represent selected nodes, graphic elements to illustrate the distance between nodes, and others. Go to ‘Visual Effects’ and delete temporary objects.

PREPROCESSING Erase Temporary Objects from Screen

USER'S GUIDE (release: October-10)

20

Weld Planner 2010 © 2010 ESI Group

DEFINE / CHECK PROPERTIES OF CLAMPS
Click on a clamp in the object tree. In the right bottom corner of software window, the properties related to the marked object are listed and can be defined / modified / checked.

PREPROCESSING Define / Check Properties of Clamps

Weld Planner 2010 © 2010 ESI Group

21

USER'S GUIDE (released: October-10)

DEFINE / CHECK PROPERTIES OF OBJECTS
Click on any object in the object tree. In the right bottom corner of software window, the properties related to the marked object are listed and can be defined / modified / checked.

PREPROCESSING Define / Check Properties of Objects

USER'S GUIDE (release: October-10)

22

Weld Planner 2010 © 2010 ESI Group

DEFINE THE WELD PLAN
Display all objects that should be included in the weld plan.

Then click on ‘Process Definition’

.

21 simulation steps are defined in the example below. 16 joints are done in two or three steps, followed by an unclamping step. Before you can simulate a joint in several sections, you should sort the nodes of the selected weld seams by clicking the symbol . In this example, we are evaluating the weld induced deformation of the component only. The sleeves are not welded.

PREPROCESSING Define the Weld Plan

Weld Planner 2010 © 2010 ESI Group

23

USER'S GUIDE (released: October-10)

Click in any field to mark it. If you click with the right mouse button in a cell, all cells right from this field are deactivated, and all cells left activated. Click on the first one with the right mouse button, then with the left mouse button, to clear a row. The black numbers next to ‘Weld Seams’ are not the weld seams, those are the weld steps. The black color is here a bit misleading.
ATTENTION:

·

The number given in ‘Number of Steps’ (top right) must be always larger then the total number of steps marked in the graphic field. The number of computed steps is generated from the marked graphic field, but limited to the ‘Number of Steps’.

PREPROCESSING Define the Weld Plan

USER'S GUIDE (release: October-10)

24

Weld Planner 2010 © 2010 ESI Group

STORE THE PROJECT
Store the project as My_Subframe.wpp.

PREPROCESSING Store the Project

Weld Planner 2010 © 2010 ESI Group

25

USER'S GUIDE (released: October-10)

SEPARATION OF COMPONENTS UNTIL WELDING
It is now possible to separate components – even though connected in a mesh – until they are welded. In order to get this done, you need to check ‘Components separated’. Then, there are two choices. Wire material is added. Then all added material must be defined as separated component, and end with the name –CONNECT. In case a joint is welded, all elements from –CONNECT linked to this joint become active. It works as well if joints are done in steps. No wired material is added for the joint. Then the algorithm finds all elements that are linked to the joint and the components, and deactivates a row of elements until the joint is done. In case of a T-Joint, it finds the elements of the ‘rib’, in order not to destroy the stiffness of the counterpart, which might be hollow.

-

Activation of separated components

Spot- and seam weld specimen

PREPROCESSING Separation of Components Until Welding

USER'S GUIDE (release: October-10)

26

Weld Planner 2010 © 2010 ESI Group

Definition of –CONNECT components
Attention:

·

It is today not straight forward to model the separation of components in case additional wire material is modeled. For details, please refer to the Getting Started course, chapter 06, ‘How to Get Good Results’.

PREPROCESSING Separation of Components Until Welding

Weld Planner 2010 © 2010 ESI Group

27

USER'S GUIDE (released: October-10)

SOLUTION
LINEAR AND NON-LINEAR GEOMETRY
In the top menu bar, there is a button named ‘Linear Geometry’. By default, a computation option for linear geometry is active. If this button if pressed a computation with non-linear geometry option will be activated.

What does this mean for the Weld Planner cases? There is a cantilever arm between the neutral phase of bending and the shrinkage force (tendon force) of a weld. In case the computation option is non-linear geometry, the cantilever arm will be continuously updated for each iteration within a load step, until equilibrium is reached. For a butt welded plate which is flimsy, this will lead to the typical horse saddle in unclamped status. In case the computation option is linear geometry, the cantilever arm is taken from the initial status and kept constant. This computation option does not lead to the typical horse saddle for butt welded plates. For most Industrial structures, it is not necessary to take into account non-linear geometry. For some welding specimen, in particular where the neutral phase of bending is close to the tendon force, it is mandatory. In case of doubt, first use a linear geometry option, then a non-linear geometry option. A computation with linear geometry is faster by magnitude (a factor 3 or more). In addition, you will always get a result, except for very bad simulation models. If you are in need to compute variants, a computation option for linear geometry may lead to significant cost savings.

-

-

Why can you choose between linear and non-linear geometry? -

SOLUTION Linear and Non-linear Geometry

USER'S GUIDE (release: October-10)

28

Weld Planner 2010 © 2010 ESI Group

GENERATE THE INPUT FOR THE SOLUTION
Click on ‘Input Deck’ and generate the input files for the solution. Make sure to choose the computation option (non-linear or linear) prior to generating the input files. The following two files are generated: My_Subframe.pc: PC file with VPS Implicit solver command files My_Subframe_geom.inc: File with mesh and groups

SOLUTION Generate the Input for the Solution

Weld Planner 2010 © 2010 ESI Group

29

USER'S GUIDE (released: October-10)

GENERATE THE INPUT FOR A TRANSIENT SOLUTION
Click on ‘File – Export – Sysweld’. You can export an .ASC file. In addition a file <Project_Name>_DATA30.ASC is written, in this case My_Subframe_DATA30.ASC. It contains all groups for a transient analysis as needed by the Excel® Welding Fabrication Planner. Load the file in Visual Mesh and inspect all groups. The first component will be duplicated as group COMPONENT_01, the second to COMPONENT_02, and so on. A set of 1D elements will be generated along the weld line node set to model the weld line. It is named J01_PATH. The same is done for all joints. In addition, groups to model start nodes, start elements and end nodes are generated. Any clamp group is duplicated into a group CLAMP_01, CLAMP_02 and so on.

SOLUTION Generate the Input for a Transient Solution

USER'S GUIDE (release: October-10)

30

Weld Planner 2010 © 2010 ESI Group

SOLVE THE PROJECT
Before you solve, check the project again. This version does not yet check the generated input deck for problems, and sends it to the solver as defined. Consequently, make sure that All components do have assigned a material and a wall thickness All weld joints do have assigned a process type and a half seam width All clamping conditions do have the necessary degrees of freedom blocked Click on Calculation ‘ the project. The progress is shown in a progress window. and solve

It is mandatory to generate an input deck before starting the simulation. If you close the software, load the file type WPP again and try to solve directly, it will not work. If nothing happens, the VPS Implicit solver is not yet installed or an environment variable is not yet set. Please refer to the installation manual for details. If the thermal simulation is carried out but the mechanical simulation stops in the first step, in most cases the available memory does not allow carrying out the simulation. You need to run the simulation on a 64 bit operating system or reduce the number of elements. The computation on 64 bit version can be launch on SMP or DMP/DP.

SOLUTION Solve the Project

Weld Planner 2010 © 2010 ESI Group

31

USER'S GUIDE (released: October-10)

SOLUTION Solve the Project

USER'S GUIDE (release: October-10)

32

Weld Planner 2010 © 2010 ESI Group

MANAGEMENT OF LARGE STRUCTURES
With the new version of the Weld Planner, you can manage very large model in a quite reasonable time to help you to reduce the time for design and manufacturing work. To achieve such goal developments have been achieved at the solver level and at the GUI one. The graphic user interface has been extended to support windows 64 bit version and the Sysweld solver has been replace by the VPS implicit solver one (Virtual Performance Solution 2010) to allow you to perform DMP computation on 64-bit windows platforms.

64-bit GUI Version
By definition, the difference between 32-bit computing, and 64-bit computing is the size of the dynamic allocation allocated. In a 32-bit world, an application can address 4GB of memory. For many of applications this is more than enough memory. However, if you work with very large datasets, 4GB suddenly becomes very limiting. The graphic user interface has been extended to the 64-bit operating system to offer you to load and display on your screen very large model with more than 3 million nodes.

DMP, Computation Time Reduction
You have the possibility with this new version of Weld Planner to perform DMP computation (Distributed Memory Parallelization). The parallelization of the finite element software mainly aims at reducing the computation time. Several executions (process) of weld planner can be launched on different processors. The main advantage is the automatic partitioning in X sub domains which allow you to share the memory between the different processors and strongly increase the computation speed up according to the number of processors used. On the following graphs, you can have detailed information about the speed up, the scalability and the memory allocated. The test case treated is a sub frame automotive test case, which contains more than 500 000 nodes and 24 joints.

SOLUTION Management of Large Structures

Weld Planner 2010 © 2010 ESI Group

33

USER'S GUIDE (released: October-10)

Subframe test case / Number of Nodes: 500 000 nodes

SOLUTION Management of Large Structures

USER'S GUIDE (release: October-10)

34

Weld Planner 2010 © 2010 ESI Group

450 400 350 300 250 200 150 100 50 0

TIME (mn)

1P

4P

8P

16P

32P

Computation Speed-up

14 12 10 8 6 4 2 0 1P 4P 8P
Scalability

Time Scale

16P

32P

SOLUTION Management of Large Structures

Weld Planner 2010 © 2010 ESI Group

35

USER'S GUIDE (released: October-10)

20 18 16 14 12 10 8 6 4 2 0

RAM/Proc

1P

4P

8P

16P

32P

Memory Allocated per processors

40 35 30 25 20 15 10 5 0 1P 4P 8P 16P 32P Total RAM

Total Memory Allocated

SOLUTION Management of Large Structures

Weld Planner 2010 © 2010 ESI Group

37

USER'S GUIDE (released: October-10)

FILE TYPES
In a Weld Planner simulation, several file types are used. Not all file types as illustrated below are used. The ones not used are grayed out in the explanations. The file types used in a Weld Planner simulation are the following. File type VDB: Visual Mesh binary data file. It is not directly used by the Weld Planner. Visual Mesh exports meshes in ASC format that are used by the Weld Planner. The file includes the mesh (elements, nodes), parts (components in Weld Planner) and collectors (node sets in Weld Planner, like welds, clamping conditions, bolts and stops). File type geom_inc: Mesh file. The content is documented in the VPS reference manual Manual. The file includes the mesh (elements, nodes), element groups (components in Weld Planner) and node groups (node sets in Weld Planner, like welds, clamping conditions, bolts and stops). You can read it with an editor. File type WPP: Weld Planner binary data file. File type <Project_Name>.pc: Solver command file. The format and content of solver command files is documented in the VPS Implicit solver reference manual. You can read it with an editor. File type <Project_Name>_result.DAT: Distortion result file. It contains nodes and displacements. You can read it with an editor. File type DSY: Binary results file with advanced results (stresses, plastic strains, and step by step distortion) that can not be reviewed with the Weld Planner. You can review these results with Visual Viewer.

-

-

-

FILE TYPES

Weld Planner 2010 © 2010 ESI Group

39

USER'S GUIDE (released: October-10)

POST-PROCESSING
LOAD THE RESULT FILE
Click on ‘Result Analysis’ the result file, which is in this case My_subframe_result.dat. and load

POST-PROCESSING Load the Result File

USER'S GUIDE (release: October-10)

40

Weld Planner 2010 © 2010 ESI Group

DISPLAY RESULTS
Check out all the options in ‘Analysis’.

Values of computed displacements can be displayed in an information window. Generate the window (mark Show / Hide with a hook) and then define the size of the information window with the scroll bar. Next, select the value you want to display under ‘Label’. Zoom into the part and move the nodes you want to measure inside the information window. You need to click once in the information window before the display of values is activated.

POST-PROCESSING Display Results

Weld Planner 2010 © 2010 ESI Group

41

USER'S GUIDE (released: October-10)

ADVANCED POSTPROCESSING
STEP BY STEP DISTORTION & STRESS
The Weld Planner stores next to the standard result file a file named *DSY. It contains distortion and stress results for each welding step. You can review these results with Visual Viewer. You will find videos to show how to work on the training CD, in the chapter ‘Advanced_Postprocessing\01_Step_by_Step_Distortion’. In case you can not display the video – please refer to the training CD, to chapter 99_Tools. Here you will find the Codecs you need and a freeware player that is included in the XP Codecs.

Step by step distortion of a panel bar system

ADVANCED POSTPROCESSING Step by Step Distortion & Stress

USER'S GUIDE (release: October-10)

42

Weld Planner 2010 © 2010 ESI Group

Weld Step by Weld Step Display of distortion in Visual Viewer – Car Chassis

Weld Step by Weld Step Display of distortion in Visual Viewer – Bridge Segment

ADVANCED POSTPROCESSING Step by Step Distortion & Stress

Weld Planner 2010 © 2010 ESI Group

43

USER'S GUIDE (released: October-10)

Comparison of variants in Visual Viewer- Car frame

Comparison of variants in Visual Viewer – Bridge segment

ADVANCED POSTPROCESSING Step by Step Distortion & Stress

USER'S GUIDE (release: October-10)

44

Weld Planner 2010 © 2010 ESI Group

Display of V. Mises Stresses in Advanced Post Processing

ADVANCED POSTPROCESSING Step by Step Distortion & Stress

Weld Planner 2010 © 2010 ESI Group

45

USER'S GUIDE (released: October-10)

COMPUTATION OF MODEL DIFFERENCES
Starting with Visual Viewer 6.5, it is possible to synchronize two variants and to compute and display the model differences.

Comparison of variants

ADVANCED POSTPROCESSING Computation of Model Differences

Weld Planner 2010 © 2010 ESI Group

47

USER'S GUIDE (released: October-10)

EXPORT OF THE DEFORMED GEOMETRY
APPLY THE DISTORTION VECTOR TO MODIFY THE MESH
Load the assembly, load the result and click on ‘Tools’ – ‘Apply Displacements’. The mesh coordinates will be modified with a scaling factor of 1. Then you can export the deformed mesh.

EXPORT OF THE DEFORMED GEOMETRY Apply the Distortion Vector to Modify the Mesh

Weld Planner 2010 © 2010 ESI Group

49

USER'S GUIDE (released: October-10)

HOW TO GENERATE THE MOST EFFICIENT MESH
The mesh should have Finite Element quality with connected components. It should be made of two dimensional elements. The element normal’s must not be aligned, it is however preferable to perform this operation, in case you want to pass the mesh on to a weld quality analysis with the Welding Fabrication Planner. The element quality is not checked, and degenerated elements will lead to a crash of the solver. Please check the mesh quality in a meshing tool before you will use it. The collectors in the mesh are recognized in the Weld Planner as components. It is necessary to define the components in the mesh before using it in the Weld Planner. The software is designed to accept existing meshes from crash, fatigue or structural analysis can be used. For details, please refer to the document ‘How to Manage Meshes For Weld Planner Usage *.pdf’ In the ‘Getting Started’ course. An efficient mesh for the Weld Planner looks as follows.

HOW TO GENERATE THE MOST EFFICIENT MESH

USER'S GUIDE (release: October-10)

50

Weld Planner 2010 © 2010 ESI Group

Efficient mesh for the Weld Planner

The mesh density and aspect ratios respect the gradients that occur in a welding process. Depending on the welding speed, transverse gradients are much higher as longitudinal gradients. In order to capture variants in the Energy / Unit Length of Weld in the applied shrinkage method, enough elements should exist in transverse direction. The elements can be longer in longitudinal direction, because the shrinkage method does not use a moving heat source. An aspect ratio of 1:10 should not be exceeded.

HOW TO GENERATE THE MOST EFFICIENT MESH

Weld Planner 2010 © 2010 ESI Group

51

USER'S GUIDE (released: October-10)

Thermal gradients in a real welding process

Simulation of a higher Energy / Unit Length of Weld – Applied shrinkage zone

HOW TO GENERATE THE MOST EFFICIENT MESH

USER'S GUIDE (release: October-10)

52

Weld Planner 2010 © 2010 ESI Group

Simulation of less Energy / Unit Length of Weld – Applied shrinkage zone

HOW TO GENERATE THE MOST EFFICIENT MESH

Weld Planner 2010 © 2010 ESI Group

53

USER'S GUIDE (released: October-10)

HOW TO MODEL ANGULAR DISTORTION
You need to model the deposit in the mesh as shown below. Butt joints will be modeled for this purpose with a small roof.

Modeling a T-Joint with deposit

HOW TO MODEL ANGULAR DISTORTION

USER'S GUIDE (release: October-10)

54

Weld Planner 2010 © 2010 ESI Group

Weld size – all inside the tube shrinks in the simulation.

HOW TO MODEL ANGULAR DISTORTION

Weld Planner 2010 © 2010 ESI Group

55

USER'S GUIDE (released: October-10)

The result: Angular distortion and longitudinal bowing

HOW TO MODEL ANGULAR DISTORTION

Weld Planner 2010 © 2010 ESI Group

57

USER'S GUIDE (released: October-10)

TRAINING CD
There is a training CD available. Please refer to your local contact to get a copy. It includes the following

TRAINING CD

Weld Planner 2010 © 2010 ESI Group

59

USER'S GUIDE (released: October-10)

TIPS AND TRICKS
You click on an object defined by node sets, but the entry is not highlighted in the object tree. Click first on any other object defined by node sets in the object tree, then click again on the desired object. It is also important to understand that you need to click very close to the center point of a sphere representing a node of the node set. Thus it helps to display the spheres with a scaling factor of one for identifying it in the object tree via clicking. We will try to improve that. You want to increase the size of the spheres that appear when you measure the distance between points. In the ‘Display’ menu, you will find a scroll bar for ‘3D Point Size’. You want to increase the line width of the mesh. In the ‘Display’ menu, you will find a scroll bar for ‘Line Width’. You want to have an edge like display more smooth. Click on a component. Then you will find on the right bottom a scroll bar for ‘Smoothing’. The value defines the angle between the normal vectors of elements that will be taken as limit for the display of the common edge. The object type listing of a selected object is not correct. This is a limitation of the present version. The choice of object types serves only to move objects in the object tree, but not to list the definition of declared objects. Once the object is moved into an object folder, the assignment of the object type is not stored. You want to erase visualizations like distance between two nodes. Click on ‘Visual Effects’ – ‘Delete Temporary Objects’ You want to define a contiguous number of joints in one simulation step. Press <Ctrl>, click on the first step of the joint (column n) with the right mouse button, and then click on the last step of the joint (column m) with the right mouse button. All steps between column n and m are marked for this joint. Make sure that the nodes of joints that are simulated in several steps are properly sorted. This button located just below the object tree is used to perform this operation.

-

-

-

-

You want to delete all definitions for all simulation steps in one row in the process definition. Click on the first joint, clamp, etc. with the right mouse button. All entries on the right side are deleted. Click on the first joint, clamp, etc. with the left mouse button. Also the first entry is deleted. You have generated your own material file in the ‘mat’ folder, but it does not appear in the GUI. Inside the file is a name. You need to set a name different to the existing names.

-

TIPS AND TRICKS

USER'S GUIDE (release: October-10)

60

Weld Planner 2010 © 2010 ESI Group

-

You want to generate input decks for an analysis. If you generate the input decks for analysis, the Weld Planner does not give a default name to the files to be generated. Instead you can choose a file name with any kind of extension <NAME>.<EXT> with the browser. The Weld Planner will ignore the extension .<EXT>, and generate the following set of files: · · VPS Implicit solver command file: <NAME>.pc VPS geometry file: <NAME>_geom.inc

In case you choose the filename <NAME>.wpp from the list, you will get the message "file exists, do you want to overwrite it?" Ignore this message; the file <NAME>.wpp will not be overwritten. The input files will be generated as described above. You want to export a mesh for a transient simulation with Visual Weld or Sysweld When you export geometry in Visual Weld or SYSWELD format (File - Export - SYSWELD) the Weld Planner writes out two geometry files in ASCII format (.ASC). The first one is a geometry file with all groups as defined in the Weld Planner. The second one is a geometry file with additional groups that are used by the Welding Fabrication Planner in order to perform transient welding with Visual Weld or SYSWELD. You can choose any <NAME>, the generated file names are then: · · Geometry Weld Planner: <NAME>_DATA1.ASC Geometry Welding Fabrication Planner: <NAME>_DATA30.ASC Spaces in <NAME> will be replaced by <_>. If the filename is already in the SYSWELD-format <NAME>_DATA<number>, the generated file names are:  Mesh for the Weld Planner: <NAME>_DATA<number>.ASC  Mesh for the Welding Fabrication Planner: <NAME>_DATA30.ASC If <number> is set to 30, <number> will be set to 31.

-

You want to start simulation outside the Weld Planner GUI If you have generated the input decks for a VPS simulation, you can also start the analysis outside the Weld Planner. Open VPS implicit solver in batch-mode, choose the path where you have written the command files and select <NAME>.pc as Input file.

-

You want to start a simulation in a different Weld Planner Session In case you want to start a job out of the Weld Planner, you need to write first the input decks again. Otherwise, the computation is not launched. In case you click on 'Computation' and nothing happens, you need to click on 'Input Deck' before.

TIPS AND TRICKS

Weld Planner 2010 © 2010 ESI Group

61

USER'S GUIDE (released: October-10)

-

You have closed the window that shows the progress of the simulation, but it seems that the computer is still carrying out computations. You need to terminate the simulation in the task manager. A computation has been carried out, but there are no results. This can have several reasons. You find a summary of possibilities hereafter. · There is a problem in the mesh, most likely degenerated elements. You need to use a mesh generator to check the quality of the mesh. Search in particular for problems with Aspect Ratio and the Jacobian, and for coincident nodes, free nodes and duplicated nodes and elements. Properties definition has not been completed. Make sure that all components do have a thickness, and that the property ‘half bead width’ is defined for all the welds in case of MIG / MAG (more general ARC). Clamping conditions do not block rigid body motions. Make sure that clamping conditions are present for each simulation step, and that the part is at least statically determined for unclamping. Rigid body motions must be blocked in any case The process definition is not yet completed. Please check the process definition. Only objects displayed are taken into account for the process definition. There is not enough RAM. In case of larger problems, you should use a computer with a 64 bit operating system. The part was fully clamped during welding, and when unclamping, a highly non-linear spring back occurs. This is sometimes the case for flimsy butt welded plates. In this case you need to unclamp in several steps. Please contact the local technical support; they will help you on this subject. In any case, you treat here a very sensitive case! You tried to simulate a thin sheet with a very long welding joint, and the joint was simulated in one step, with an option for non linear geometry. Such a case causes a highly nonlinear structural answer, which could be even buckling. The first measure is to simulate the joint in several steps. In addition, you should try first with an option for linear geometry. Last, you should care for that at least 3 nodes are captured perpendicular to the welding direction, for the simulation of shrinkage. You can check this with the display of tubes or spheres in the Weld Planner, and with the display of collectors in Visual Mesh. In case you are convinced that buckling may have caused the problem, try an option for linear geometry and check the result for compressive stresses in flimsy areas. It is basically possible to perform a buckling simulation including loads from welding – please contact your technical support for details on this subject. There is another problem not listed here. Please check the file <NAME>.out and search for ‘WARNING’ or ‘ERROR’.

-

·

·

· · ·

·

· -

Results look strange with an option for linear geometry, and are even not computed with an option for nonlinear geometry.

TIPS AND TRICKS

USER'S GUIDE (release: October-10)

62

Weld Planner 2010 © 2010 ESI Group

Check in the OUT file the displacement increment in the first Iteration. It should be in the range of a few mm at best. In case it is much higher, then there is most likely something wrong with the clamping conditions - the parts can move because they are not sufficiently fixed. In this case you should check the clamping conditions. You want to display results without first loading the file type WPP. This is not possible. You need to load a file type WPP before you load and display results. You want to increase the font size of the result legend. The result legend is a dynamic object that can be placed anywhere on screen and arbitrarily sized. Click inside with the left mouse button and keep it pressed to move the legend. Move the mouse button to the borders of the legend in order to get arrows that help to adjust the size of the display. Alternatively, scale the result to straight values. With decreased number of digits to display, the font size will increase.

-

-

You want to recover a result legend – there is no more legend display on screen. Choose 0....as post value and display, and then choose again a result value. You want to define own values for minimum and maximum value, but it does not work. Choose first ‘0 Own Setup’, and define your values and colors.

TIPS AND TRICKS

Weld Planner 2010 © 2010 ESI Group

63

USER'S GUIDE (released: October-10)

Then switch back to any other color selection. There is no information displayed in the Info Window. Click once inside, it should be displayed then. The information is only displayed for the component marked in the object tree. In case the component is marked but not inside of the Info Window, nothing will be displayed in the Info Window.

TIPS AND TRICKS

Weld Planner 2010 © 2010 ESI Group

65

USER'S GUIDE (released: October-10)

FREQUENTLY ASKED QUESTIONS
How to model a double sided T-Joint. First, you need to model the deposit from both sides, as shown in the previous example. Most likely, one heat source is tempering the results of the other. This can be modeled with a slightly different thickness of the shells modeling the filler material. In case you want to achieve good results, you should first do a simulation of a local model with SYSWELD, and then calibrate the results.

Double-sided a T-Joint with deposit

-

How to model distortion due to multi-pass welding? It is important to understand that the assembly to be modeled should be big enough in comparison to the wall thickness. Otherwise, modeling the problem with shells may not be valid. In case this pre-condition is fulfilled, the strategy is the same as explained for T- and Butt joints. First you should perform a 2D or 3D simulation of a local model with SYSWELD, and then you can calibrate the mechanical model based on shell assumptions. Although the wall thickness is high in the following example, it might be a subject for the Weld Planner, in case the overall housing is investigated.

FREQUENTLY ASKED QUESTIONS

USER'S GUIDE (release: October-10)

66

Weld Planner 2010 © 2010 ESI Group

Housing of the ITER

-

How to model a variation of +- 10% of the energy / unit length of weld? You can provide a mesh which refined enough to react with a change of 10% in the KF factor. Alternatively, you can modify the melting temperature or the thermal strains. It is important to understand that a mechanical model is applied, and not a physical model. Thus those measures are valid for the purpose of calibration. In future versions, a more comfortable GUI driven way to model variations in the energy / unit length of weld this action will be provided.

-

How to check the nodes captured for the purpose of shrinkage simulation? Load the exported mesh in Visual Mesh. The nodes that are involved in the shrinkage operation are included as collectors. It is advisable to have captured at

FREQUENTLY ASKED QUESTIONS

Weld Planner 2010 © 2010 ESI Group

67

USER'S GUIDE (released: October-10)

least 3 rows of nodes along a joint (one row is the weld line; the other two are situated left and right from the weld line).

Captured nodes along a weld line

-

How to check the number of simulation steps? The number of simulation steps is determined from the entries in the process definition. There is a field to define the number of simulation steps and the number of visible simulation steps. This is for the purpose of display only. The correct number is always derived from the marked entries in the process matrix. You also can check the file <NAME>.pc

-

How to check the solver commands used for the simulation? Check the file <NAME>.pc. How to check the time needed for the simulation? Check the file <NAME>.out for the entries ‘DATE-TIME’. Can I do advanced post-processing? Yes you can. Computed results are available in a format that is suitable for the Visual Viewer as well.

FREQUENTLY ASKED QUESTIONS

USER'S GUIDE (release: October-10)

68

Weld Planner 2010 © 2010 ESI Group

-

How about stresses and plastic strains? Stresses and plastic are computed and can be reviewed with Visual Viewer. You should do that in case you want to understand better what is computed in the background. It is important to understand that computed stresses are not correct in the molten and heat affected zone. The overall stress level should be OK, in case the computed distortion coincides well with the reality. Below you can see a comparison between a transient and a Weld Planner simulation. The amount of plastic strains should be not excessive; else there was a problem with thermal strains or the defined melting temperature.

V. Mises stresses as computed with VPS Implicit, taking into accounts all the physics

FREQUENTLY ASKED QUESTIONS

Weld Planner 2010 © 2010 ESI Group

69

USER'S GUIDE (released: October-10)

V. Mises stresses as computed with the Weld Planner

-

Is it possible to compute buckling? Not directly out of the Weld Planner. What you get, however, are the indicators for a buckling risk. Buckling is caused in case the amount of compressive stresses exceeds a certain limit. A Weld Planner computation delivers the overall stress fields in the structures, and you can use the Visual Viewer to indentify critical stress fields. Only the stresses in the weld joint, in the area of the molten zone, are not correct.

-

Is it possible to compute distortion repair with a flame? Yes it is. You should identify the heated zones as welds of punctual zones, and place them in the sequence after the welding process.

-

How to position clamps so that tolerances are kept? Apply first the minimum amount of clamping, and include all clamps that are mandatory for the manufacturing process. Then do a computation. At the point with the highest distortion, apply a clamp and redo a simulation. Continue, until all tolerance points are within the given tolerance. It is important to understand that this method is pragmatic engineering, and also other ways to optimize this goal are possible.

FREQUENTLY ASKED QUESTIONS

USER'S GUIDE (release: October-10)

70

Weld Planner 2010 © 2010 ESI Group

-

How to calibrate the result quality without measurements? You can use the mesh for a transient simulation with Visual Weld or SYSWELD. Compute one joint and unclamp, then calibrate the shrinkage. The result is usable for similar material and part characteristics. In order to get variants of +-10%, you need to modify for the time being the thermal strains or melting temperature in the material properties, or to define a fine enough mesh around the weld joint, so that a change in the diameter of the bead width in the process definition will lead to a change in the nodes that are involved in the shrinkage area inside the tube.

-

How good is the result quality? The training example (the sub-frame) has been compared with a transient welding simulation. The result comparison is listed below. Details can be found in the training course, day 3.

Distortion Direction
X Min X Max Y Min Y May Z Min Z Max

Shrinkage Transient
-0.49 0.55 -0.67 0.71 -0.31 1.27 -0.56 0.8 -0.65 0.72 -0.32 1.08

FREQUENTLY ASKED QUESTIONS

Weld Planner 2010 © 2010 ESI Group

71

USER'S GUIDE (released: October-10)

KNOWN LIMITATIONS AND ISSUES
Messages from THE VISUALIZATION TOOLKIT or Tcl/Tk (programming language)

In case you receive a message similar to the one displayed above, it is advisable to store your work and to restart. The cause of the message might have caused a bad addressing of memory, which could lead to a crash later on. You will help to improve the software in case you may report the cause of the message to the technical support. VTK Messages on graphic problems appear when the software is launched, or the GUI looks wired. The driver for the graphic accelerator may be overage. Right click on the desktop, and activate 'Properties'. Then click through Settings - Advanced - Troubleshoot and de-activate the hardware acceleration. Try again to launch the software. In case the problem is not solved, you need to update the driver for the graphic card; the OpenGL support required is missing.

KNOWN LIMITATIONS AND ISSUES

USER'S GUIDE (release: October-10)

72

Weld Planner 2010 © 2010 ESI Group

-

The software crashes when you try to load or import files. It has the same reason as for the VtK messages described above. In most cases, it is already sufficient to reduce the hardware acceleration by one level.

-

Loading a new project file or importing a new geometry. When you open a new project file type WPP or you import a new geometry, the geometry data in GUI will not be suppressed automatically. So you are able to import several parts from different mesh files. However, make sure that set names are not duplicated. The system will react with instability. If you want to start with a new geometry, first click on "File New" (<Ctrl> n), and confirm that you want to delete the present mesh / project from the memory (not from the disk).

-

Open projects with the old data-structure (before WP V1.1). The internal name for the "Surface and Wire" display mode has been changed in the new Weld Planner version. You can transform the old data structure to new data structure in the following manner: · · · · · Open the old project file type WPP Highlight all components in the object tree Ignore the error-message and click "Skip Message" Choose the Display-Mode "Surface and Wire" Save the project file

KNOWN LIMITATIONS AND ISSUES

Weld Planner 2010 © 2010 ESI Group

73

USER'S GUIDE (released: October-10)

-

Large Element/Node-IDs Element and node ID's above 10.000.000 are not managed well internally, and errors may occur. The problem can be solved with nodes and elements renumbering, which should be executed in any case before a meshed geometry is loaded. You can do that in the Weld Planner with ‘Tools – Renumber’.

-

Maximum number of weld steps The maximum number of weld steps indicated in the process window in the upper right corner must be higher then the number of weld steps graphically marked in the process field. In case you load a project as template and increase the number, it will not be recognized before you store and launch the project again. This bug is fixed in V1.2.

-

Generation of input decks without complete data If you try to generate an input deck without for example having assigned a bead width or clamping conditions, then you may receive VTK messages. This limitation is partly solved. Version V1.2 partly checks if the data is complete or not.

-

Display of results on the deformed structure Colored results of the deformed structure are displayed on the not deformed structure. The deformed displayed structure is grey. If you switch to display of distortion in x, y or z direction, and then click deformed structure, you will get the legend of the distortion vector again. You can use Visual Viewer for advanced PostProcessing.

-

Graphic export of the 3D display There should be no special signs or local letters in the path name, otherwise problems may occur.

-

A message about a memory problem is posted when the software is closed, or during certain post-processing actions This occurs in case you have displayed before deformed geometry, displacement vectors, and displacement values in the Info Window and in addition you display nodes with coordinates. This problem can be avoided in case you switch of deformed geometry, displacement vectors and don’t display nodes coordinate as long as you review result values in the Info Window.

KNOWN LIMITATIONS AND ISSUES

USER'S GUIDE (release: October-10)

74

Weld Planner 2010 © 2010 ESI Group

-

Crashes occur on 32 FAT file systems On 32 FAT file partitions, even with 64 bit XP or VISTA operating systems, the maximum file size can be 4GB. In case exceeded, it will crash without further notice.

-

Crashes on 32 bit systems in case of large problems The system is using an in-core solver, which results in the best possible solution time. However, it will manage up to 50.000 elements on 32 bit systems. In case Windows is started in 3GB mode, it will manage up to 60.000 elements. In case the given sizes are exceeded, it will crash. The solution is for V1.1 to use a 64 bit operating system. Starting from V1.2, and out of core solver is available that allows to manage up to 300.000 nodes on 32 bit systems. However, the hard disk is extensively used, and this will result in a higher computation time.

-

Messages ‘PRECISION NOT REACHED’ in the out file with linear geometry computation option, after iteration 3 This can happen in case elements are very large and thick, for example in bridge segment applications. The work around is to set the LARGE parameter from 1*5 to 1*8 in the file <file-name>.DAT. This problem is solved in V1.2.

-

Usage of meshes with bad element quality You need to check the mesh quality of the used meshes. The solver will try to solve even in case of bad meshes. This may sometimes even result in a crash. For details, please see the manual ‘How to Manage Meshes for Weld Planner Usage 120108.pdf’

KNOWN LIMITATIONS AND ISSUES

Weld Planner 2010 © 2010 ESI Group

75

USER'S GUIDE (released: October-10)

in chapter ‘How to Prepare and Import Meshes’ in the Weld Planner Getting Started course. Unmotivated crashes during display of newly generated graphic objects In case you find unmotivated crashes during display of weld lines etc, in structures with many elements and all objects displayed, please check the version of your graphic card and the date of the driver of this graphic card. The default VGA drivers from Windows are not powerful enough. You should have at least a graphic card with 256 MB RAM, not dated earlier then 2007, and driven by a recent driver. Huge models need more graphic power. In case the graphic card is overload or operated with an old driver, it will crash without further notice.

KNOWN LIMITATIONS AND ISSUES

Insert the back cover image in this header, then position and resize it !

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->