P. 1


|Views: 61|Likes:
Published by Fatema Yusuf Izzy

More info:

Published by: Fatema Yusuf Izzy on Jul 05, 2012
Copyright:Attribution Non-commercial


Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less






Discuss the advantages of Decision Tree. A decision tree is a decision support tool that uses a tree-like graph or model of decisions and their possible consequences, including chance event outcomes, resource costs, and utility. It is one way to display an algorithm. Decision trees are commonly used in operations research, specifically in decision analysis, to help identify a strategy most likely to reach a goal. If in practice decisions have to be taken online with no recall under incomplete knowledge, a decision tree should be paralleled by a probability model as a best choice model or online selection model algorithm. Another use of decision trees is as a descriptive means for calculating conditional probabilities. In decision analysis, a "decision tree" — and the closely related influence diagram — is used as a visual and analytical decision support tool, where the expected values (or expected utility) of competing alternatives are calculated. A decision tree consists of 3 types of nodes:1. Decision nodes - commonly represented by squares 2. Chance nodes - represented by circles 3. End nodes - represented by triangles Advantages: Decision trees:

Are simple to understand and interpret. People are able to understand decision tree models after a brief explanation.


Have value even with little hard data. Important insights can be generated based on experts describing a situation (its alternatives, probabilities, and costs) and their preferences for outcomes.


Use a white box model. If a given result is provided by a model, the explanation for the result is easily replicated by simple math.


Can be combined with other decision techniques. The following example uses Net Present Value calculations, PERT 3-point estimations (decision #1) and a linear distribution of expected outcomes (decision #2):

Example Decision trees can be used to optimize an investment portfolio. The following example shows a portfolio of 7 investment options (projects). The organization has $10,000,000 available for the total investment. Bold lines mark the best selection 1, 3, 5, 6, and 7, which will cost $9,750,000 and create

a payoff of 16,175,000. All other combinations would either exceed the budget or yield a lower payoff.

2) Describe network analysis in project management

Project management is concerned with the overall planning and co-ordination of a project from conception to completion aimed at meeting the stated requirements and ensuring completion on time, within cost and to required quality standards. Project management is normally reserved for focused, non-repetitive, time-limited activities with some degree of risk and that are beyond the usual scope of operational activities for which the organization is responsible. The core technique available to Project Managers for planning and controlling their projects is Network Analysis. Where projects become complex, it becomes difficult to see relationships between activities by using a Gantt Chart. For more complex projects Network Analysis techniques are used.

The following are the Network analysis techniques   PERT → Program, Evaluation and Review Technique CPM → Critical Path Analysis

Network Analysis or Critical Path Analysis (CPA) or the American “Program, Evaluation and Review Technique” (PERT) is one of the classic methods of planning and controlling the progress of projects.

The two most common and widely used project management techniques that can be classified under the title of Network Analysis are Programme Evaluation and review

Technique (PERT) and Critical Path Method (CPM). Both were developed in the 1950's to help managers schedule, monitor and control large and complex projects. CPM was first used in 1957 to assist in the development and building of chemical plants within the DuPont corporation. Independently developed, PERT was introduced in 1958 following research within the Special Projects Office of the US Navy. It was initially used to plan and control the Polaris missile programme which involved the coordination of thousands of contractors.

The use of PERT helps in visualsing the range of project completion dates and announcing more realistic project completion time target.

3) Describe the Project Evaluation and Review Technique (PERT). The Program Evaluation and Review Technique (PERT) is a network model that allows for randomness in activity completion times. PERT was developed in the late 1950's for the U.S. Navy's Polaris project having thousands of contractors. It has the potential to reduce both the time and cost required to complete a project. The Network Diagram In a project, an activity is a task that must be performed and an event is a milestone marking the completion of one or more activities. Before an activity can begin, all of its predecessor activities must be completed. Project network models represent activities and milestones by arcs and nodes. PERT is typically represented as an activity on arc network, in which the activities are represented on the lines and milestones on the nodes. The Figure 7.4 shows a simple example of a PERT diagram.

The milestones generally are numbered so that the ending node of an activity has a higher number than the beginning node. Incrementing the numbers by 10 allows for new ones to be inserted without modifying the numbering of the entire diagram. The activities in the above diagram are labeled with letters along with the expected time required to complete the activity.

Steps in the PERT Planning Process PERT planning involves the following steps: 1. Identify the specific activities and milestones. 2. Determine the proper sequence of the activities. 3. Construct a network diagram. 4. Estimate the time required for each activity. 5. Determine the critical path. 6. Update the PERT chart as the project progresses.

1. Identify activities and milestones The activities are the tasks required to complete the project. The milestones are the events marking the beginning and end of one or more activities. 2. Determine activity sequence This step may be combined with the activity identification step since the activity sequence is known for some tasks. Other tasks may require more analysis to determine the exact order in which they must be performed. 3. Construct the Network Diagram Using the activity sequence information, a network diagram can be drawn showing the sequence of the serial and parallel activities. 4. Estimate activity times Weeks are a commonly used unit of time for activity completion, but any consistent unit of time can be used. A distinguishing feature of PERT is its ability to deal with uncertainty in activity completion times. For each activity, the model usually includes three time estimates: • Optimistic time (OT) - generally the shortest time in which the activity can be completed. (This is what an inexperienced manager believes!) • Most likely time (MT) - the completion time having the highest probability. This is different from expected time. Seasoned managers have an amazing way of estimating very close to actual data from prior estimation errors. • Pessimistic time (PT) - the longest time that an activity might require. The expected time for each activity can be approximated using the following weighted average:

Expected time = (OT + 4 x MT+ PT) / 6 This expected time might be displayed on the network diagram. Variance for each activity is given by: [(PT - OT) / 6]

5. Determine the Critical Path The critical path is determined by adding the times for the activities in each sequence and determining the longest path in the project. The critical path determines the total time required for the project. If activities outside the critical path speed up or slow down (within limits), the total project time does not change. The amount of time that a non-critical path activity can be delayed without delaying the project is referred to as slack time. If the critical path is not immediately obvious, it may be helpful to determine the following four quantities for each activity: A. ES - Earliest Start time B. EF - Earliest Finish time C. LS - Latest Start time D. LF - Latest Finish time These times are calculated using the expected time for the relevant activities. The ES and EF of each activity are determined by working forward through the network and determining the earliest time at which an activity can start and finish considering its predecessor activities. The latest start and finish times are the latest times that an activity can start and finish without delaying the project. LS and LF are found by working backward through the network. The difference in the latest and earliest finish of each activity is that activity's slack. The critical path then is the path through the network in which none of the activities have slack. The variance in the project completion time can be calculated by summing the variances in the completion times of the activities in the critical path. Given this variance, one can calculate the probability that the project will be completed by a certain date. Since the critical path determines the completion date of the project, the project can be accelerated by adding the resources required to decrease the time for the activities in the critical path. Such a shortening of the project sometimes is referred to as project crashing.

6. Update as project progresses Make adjustments in the PERT chart as the project progresses. As the project unfolds, the estimated times can be replaced with actual times. In cases where there are delays, additional resources may be needed to stay on schedule and the PERT chart may be modified to reflect the new situation. Benefits of PERT PERT is useful because it provides the following information: a. Expected project completion time. b. Probability of completion before a specified date. c. The critical path activities that directly impact the completion time. d. The activities that have slack time and that can lend resources to critical path activities. e. Activities start and end dates.

4) Describe how you can display data using Gantt chart and Network Diagram Chart Displaying of Data There are several ways for displaying the data. Gantt Chart as well as Network Diagram Chart are two important tools by which it is possible to display project data. Gantt Chart The Gantt Chart is a horizontal bar chart that represents each task in the time scale of the project. Each task entered in the project will be shown. The Gantt Chart can be used to visually keep track of the tasks and also may be used to identify important points about each task. Those tasks that together control the completion date are known as the critical Path and are shown differently to highlight that fact. Gantt Charts can be printed and therefore these form the significant part of a regular report which shows the current progress, comparison with the original plan, and the new projected completion data. Changing the split between chart and table When the Gantt Chart view or the Task Entry view is selected, the Gantt Chart area has part of a table on the left and the bars on the right.

It is possible to move the dividing line between these two areas with the mouse pointer. When the pointer is on the dividing line, it changes to two vertical lines with left and right arrows. If the left button is held down then the dividing line can be moved to the left or right as required. Changing Time Scale It is possible to change the time scale on the right side of the chart directly by using the View, Zoom command or with the Format, Timescale command. Where the latter is chosen, the dialog box will provide the ability to change both the major and minor time scales and within each of these it will be possible to alter the units, the label, the alignment, and the count of the interval between the unit labels. Changing the Palette The Palette can be accessed from the Format, Bar command or by double clicking on the Gantt Chart. Using the dialog box, it is possible to maximise the information provided by the format of the bars on the Gantt Chart. The appearance of the existing bars can be changed and additional bars can be used. The full use of colour is also possible.

Format Bar For example it is possible to show the planned, actual and scheduled times for each task. Editing Tasks One method of editing tasks is changing them on the Gantt Chart using the mouse and dragging the changes into place.

Positioning the pointer at the beginning of a bar will change the pointer to a % sign and if the left button is pressed and the symbol dragged to the right a box will appear showing the amount of "percentage complete" that has been added. This information will then be updated throughout the system. If the pointer is placed in the centre of the bar it will change to a four-way arrow pointer. If the left button is held down it is then possible to drag the bar to the left or right in time, the changing dates options will be shown in a dialog box (see below) and, on clicking OK, the files will be updated with the new information.

Planning Wizard The third possibility is that the duration of the task can be changed by changing the length of the bar. If the pointer is positioned at the right end of the bar it will change into a right pointing arrow. If the left button is held down it is then possible to change the length of the bar and the respective change in duration is shown in a box. => Viewing the Gantt Chart · Select Gantt Chart from the View menu. · Place the pointer on the border between chart and table, hold the button down and drag the border left or right. · From the Format menu, select Timescale. Try changing the major and minor scales as view the changes at the bottom of the box. · From the View menu, choose Zoom. Try out the various changes that can be made to the amount seen. Network Diagram Chart The term Network Diagram is derived from Programme Evaluation and Review Technique which was invented for the management of Projects by paper based systems. The Network Diagram chart is a diagrammatic view of the tasks where the position of the task and the lines linking them together

represent the detailed steps that comprise the project. It is possible to modify the project in the Network Diagram by adding extra tasks or nodes and creating the links. Each task on the chart is known as a node and within the node is a selection of the data that is relevant to the task. The Nodes can have different boarders which represent the task type. Using the Format, Box Styles command Within this command box (shown below) there are many different types of Task, each of which can be given a combination of line style and colour to provide visual identification, for example the critical tasks can have thick red borders. The Network Diagram view must be active in order to see the Box Styles as an option in the Format menu.

Changing the contents of a Node The Data Template command in the Box Styles dialog allows change to the data that the node displays.

Setting the following is possible: · Grid Lines between the five areas - on or off. · The cross marks that indicate "In progress" or "Complete" on or off. · The format for the display of the dates. · The selection of the size of the Node - Small, Medium or Large. Modifying the layout of the Chart The Format, Layout command gives the ability to select how the interconnecting lines between the nodes will be shown.

=> View the Network Diagram Chart · Select Network Diagram Chart from the View menu. · From the View, menu, select Zoom and change the size of the Nodes · From the Format menu, select Box Styles and examine the different style of borders that are available to show different types of tasks.

· Also check how the contents may be changed using the Boxes Tab. · From the Format menu, select Layout and examine the different ways the lines can be displayed. · You can drag the boxes with the mouse. If you Zoom to 50% or Entire Project you will find it easier. · Double Click on a Node and examine the options in the dialog box. Zooming In and Out Zooming in can be useful when you want to focus on a particular Network Diagram box or group of Network Diagram boxes. Alternatively, zooming out can be helpful when you want to see as much of the project as possible on one screen. The more you zoom out, the more clear the paths become and the more unclear the text becomes. => To zoom in: · On the Standard toolbar, click the Zoom In button. · Repeat until you reach the desired size. => To zoom out: · On the Standard toolbar, click the Zoom Out button. · Repeat until you reach the desired size. Elements of the Network Diagram Chart Network Diagram Charts use to map out the tasks that are required to complete a project. The critical path consists of the sequence of tasks in the dark Network Diagram boxes. The tasks in the critical path can’t be delayed because they have no slack. However, delaying any of the light boxes is possible because they are not critical. Like the Gantt Chart, the Network Diagram Chart includes a status bar, an entry bar, and the toolbars. In addition, the Network Diagram Chart displays page guidelines so that you can control the placement of the Network Diagram boxes on a page-by-page basis. The perforated line on the right of the screen represents a page break.


List the steps involved in Steps involved in Autoregressive Model

The Autoregressive Model Interpreting this signal first begins with determining an actual equation for the signal. The best way to do that is by using an autoregressive model. An autoregressive model is simply a model used to find an estimation of a signal based on previous input values of the signal. The actual equation for the model is as follows: The Autoregressive Model

The Autoregressive Model

Figure 1: Wikipedia 2006 The model consists of three parts: a constant part, an error or noise part, and the autoregressive summation. The actual summation represents the fact that the current value of the input depends only on previous values of the input. The variable p represents the order of the model. The higher the order of the system, the more accurate a representation it will be. Therefore, as the order of the system approaches infinity, we get almost an exact representation of our input system. This system looks almost exactly like a differential equation. In fact, this equation can be used to find the transfer function for the signal. Steps involved in Autoregressive Model 1. Choose a value for p, the highest-order parameter in the autoregressive modelt o b e evaluated, realizing that the t -test for significance is based on n -2p1 degrees of freedom. 2. Form a series of p “lagged predictor” variables such that the first variable lagsby 1 time period, the second variable lags by 2 time periods, and so on and the last predictor variable lags by p time periods. 3. U s e M i c r o s o f t E x c e l t o p e r f o r m a l e a s t - s q u a r e s a n a l y s i s o f t h e m u l t i p l e regression model containing all p lagged predictor variables. 4. Test for the significance of Ap, the highest order autoregressive parameter inthe model.










m o d e l w i t h a l l p predictors is selected for fitting (equation 7.5) and forecasting (equation 7.6) (b) If the null hypothesis is not rejected, the p -th variable is discarded, steps 3and 4 are repeated with an evaluation of the new highest-order parameter whose predictor variable lags by p -1 years. The test for the significance of t h e n e w highest order parameter is based on a t -distribution whose degrees of freedomare revised to correspond with the new number of predictors.

5. Repeat







highest The

order model

autoregressive is used for

parameter iss t a t i s t i c a l l y


f i t t i n g ( e q u a t i o n 7 . 5 ) a n d forecasting (equation 7.6)


Write a short note on project crashing using network analysis.

Network Analysis is a core technique available to the Project Managers forplanning and controlling their projects. It has wide application in thearchitectural projects, transportations projects etc. Network analysis is amathematical model of analyzing complex problems, as in transportation orproject scheduling, by representing the problem as a network of lines and nodes.It can also be described as an analytic technique used during project planning todetermine the sequence of activities and their interrelationship within thenetwork of activities that will be required by the project. It involves breakingdown a complex project’s data into its component parts (activities, events,durations, etc.) and plotting them to show their interdependencies andinterrelationships. It real-life scenario, it can be used as a data processingmethod using topologically linked data such as street maps or river networks withthe purpose of determining the routes between geographic locations, and otheranalyses requiring the consideration of path and direction.

Networks A network is a set of points, called nodes, and a set of curves, called branches(or arcs or links), that connect certain pairs of nodes. In network analysis, onlythose networks are considered in which a given pair of nodes is joined by at mostone branch. Nodes are usually denoted by the uppercase letters and branches aredenoted by the nodes they use to connect.The following figure shows a network with 5 nodes.

Figure 2.1: Network

Figure 2.1 is a network consisting of five nodes, labeled A through E, and the sixbranches are defined by the curves AB, AC, AD, BC, CD and DE.A branch is oriented if it has a direction associated with it. Schematically,directions are indicated by the arrows. The arrow of the branch AB in Figure 2.1signifies that this branch is directed from A to B. Any movement along this branchmust originate at A and it must end at B. Any movement in the direction B to Awill not be permitted.If the two branches have a common node, then these two branches are said to beconnected. In figure 2.1, branches AB and AC are connected, but branches ABand CD are not connected. A path is a sequence of connected branches such thatin the alternation of nodes and branches, no node is repeated. A network is saidto be connected if for each pair of node in the network there exists at least onepath joining the pair. If the path is unique for each pair of nodes, the connectednetwork is called a tree. Equivalently, a tree is a connected network having onemore node than branch.In figure 2.1, {ED, DA, AB} is a path, but the sequence of connected branches{CA, AD, DC, CB} is not a path, as node C occurs in it twice. The network isconnected, and remains connected even if branches DA and AB are deleted.However, in case of the deletion of the DE, the network would not remainconnected, since there would not be a path linking D with E. Since D and C arejoined by the three paths, the network is not a tree.

2.3 Minimum-Span Problems

A minimum-span problem involves a set of nodes and a set of proposed branches,none of them oriented. Each proposed branch has a nonnegative cost associatedwith it. The objective is to construct a connected network that contains all the

nodes and is such that the sum of the costs associated with those branchesactually used is minimum. It is to be assumed that there are enough proposedbranches to ensure the existence of a solution. The minimum-span problem canbe solved by a tree. If two nodes in a connected network are joined by twopaths, one of these paths must contain a branch whose removal does notdisconnect the network. Removing such a branch leads to the lowering of thetotal cost. A minimal spanning tree may be found by initially selecting any onenode and determining which branch incident on the selected node has thesmallest cost. This branch is accepted as part of the final network. The networkis to be then completed iteratively. At each stage of the iterative process, theattention is to be focused on the nodes which are

already linked together. Allbranches linking these nodes to the unconnected nodes are considered, and thecheapest such branch is identified. In case of the ties, the branches are to bechosen arbitrarily in order to break the tie. The branch is accepted as part of thefinal network. The iterative process is to be terminated when all the nodes havebeen linked. In case that all the costs are distinct, it can be proved that theminimal spanning tree is unique and is produced by the above algorithm for anychoice of the starting node.Example 1 – Solve the minimum-span problem for the network given in the figurebelow. The numbers on the branches represent the costs of including thebranches in the final network.

Figure 2.2: Minimum-Span Problem Example

We arbitrarily choose A as our starting node and we consider all branchesincident on it; they are AE, AB, AD and AC, with costs 10, 2, 1 and 4,

We arbitrarily choose A as our starting node and we consider all branchesincident on it; they are AE, AB, AD and AC, with costs 10, 2, 1 and 4, respectively. Since AD is the cheapest, we add this branch to the solution, as

Figure 2.3 (a): Minimum-Span Problem Example 1

Figure 2.3 (b): Minimum-Span Problem Example 1

Figure 2.3 (c): Minimum-Span Problem Example 1

Figure 2.3 (d): Minimum-Span Problem Example 1

Figure 2.3 (e): Minimum-Span Problem Example 1

Shortest-Route Problems

A shortest-route problem involves a connected network having a nonnegative costassociated with each branch. One node is designated as the source, and the othernode

is designated as the sink. These terms don’t imply an orientation of thebranches. However, it suggests the direction in which the solution algorithmshould be applied. In the shortestroute problem, the objective is to determine apath joining the source and the sink such that the sum of the costs associatedwith the branches in the path is minimum.The following algorithm is to be used to solve the Shortest-route problems –Step 1 – Construct a master list by tabulating under each node, in ascending orderof cost, the branches incident on it. Each branch under a given node is writtenwith that node as its first node.Step 2 – Mark the source and assign it the value 0. Locate the cheapest branchincident on the source and encircle it. Next, mark the second node of this branchand assign this node a value equal to the cost of the branch. Delete from themaster list all other branches that have the newly marked node as second node.Step 3 – If the newly marked node is the sink, go to Step 5. If not, go toStep 4.Step 4 – Consider all marked nodes having un-circled branches under them in thecurrent master list. For each one, add the value assigned to the node to the costof the cheapest un-circled branch under it. Denote the smallest of these sums asM, and circle that branch whose cost contributed to M. Mark the second node of this branch and assign it the value M. Delete from the master list all otherbranches having this newly starred node as second node. Go to Step 3.Step 5 – Z* is the value assigned to the sink. A minimum-cost path is obtainedrecursively, beginning with the sink, by including in the path each circled branchwhose second node belongs to the path.

You're Reading a Free Preview

/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->