Tekla For Dummies rdheng@gmail.

com

TEKLASTRUCTURE V 10.0 BASIC TRAINING MANUAL

Email

: rdheng @gmail.com

---BASIC--1 of 28

Tekla For Dummies rdheng@gmail.com This section presents basic Tekla Structures vocabulary and concepts so that you can start modeling. For additional definitions of terms, see the Glossary. The illustration below shows the modeling guides you use in Tekla Structures windows.

View: To see your Tekla Structures model from virtually any angle, you can move and rotate the model. See Examining the model. You can also create views. A view is a representation of a model from a specific location. Each view is displayed in its own window inside the Tekla Structures window. Coordinate system The green cube in a model view represents the global coordinate system and lies at the global point of origin. In Tekla Structures, both the global and local coordinate systems are cartesian, with three axes (x, y, and z) perpendicular to each other. Work plane The red coordinate arrow symbol indicates the work plane, which is the current local coordinate system of the model. The arrow symbol shows the xy plane. The z direction follows the right-hand rule. You can reset the work plane so as to ease modeling and placing objects. Most of the commands, which are dependent on the coordinate system, use work plane coordinates; e.g. creating points, part positioning, and copying always comply with the work plane coordinate system. The work plane is the same in all views. Work area Tekla Structures indicates the work area of a view using green, dashed lines. Defining the work area makes it faster and easier to work with the model. Objects outside the work area still exist, but they are not visible. So you can confine to a substructure, for example, and the views to the model are simpler and quickly updated.

2 of 28

. Select the Create default view and grid checkbox if you want Tekla Structures to automatically create a grid and a view using the standard properties. Select the model from the Model directories list on the right of the Open model dialog box. double-click an entry followed by two dots.. 3. In the New model dialog box. Points outside the view plane are red.com Grid and view plane Cyan dash-and-dot lines show the projections of the grids which are visible on the view plane. 4.. or . Points located in the view plane are yellow. or . See Working with grids..Tekla For Dummies rdheng@gmail.. Creating a ne w model When you first open Tekla Structures. Tekla Structures displays this information in different reports and drawing titles. only the New model and Open icons are active. 3 of 28 . The appearance of points also shows which view plane you are using. click after the path. Click OK to open the model.. Click OK to create the new model. If you already have a model open. The Projectdialog box appears.. 2. Tekla Structures prompts you to save that model. double-click the desired entry. Enter directory paths in the Filter field and click the Filter button. If you already have a model open. Then type \ and the model name in the field. You can only have one model open at a time. To move down. See Opening a model. The Directories list and the Filter field and button in the New model dialog box work in a similar way to those in the Open model dialog box. Use the Directories list on the left of the Open model dialog box and the following techniques to browse files and folders above and below the current folder: One dot at the end of an entry indicates the current folder. in the field at the bottom of the dialog box. You can only have one model open at a time. click Properties > Project. Tekla Structures prompts you to save that model. Opening a model To open an Tekla Structures model: 1. 2. The remaining icons become active and the model name appears in the title bar of the Tekla Structures window. for example C:\ Tekla Structures_Models. Click File > Open. To update the project information. To create a new Tekla Structures model: 1. Click File > New. 3. The New model dialog box appears. Project setup Update the project information at the beginning of a project to make reports and drawings to display the correct information automatically. To move up.

Tekla For Dummies rdheng@gmail. Basic Tool bar The commands on the Standard toolbar are: • Create a new model • Open an existing model • Save the current model • Plot • Create a report • Open the drawing list • Wizard • Publish as Web page 4 of 28 .used commands. Most of the Tekla Structures icons work as follows: • A single-click executes the command. • A double-click displays the properties dialog box of the object type.com ---MODELING--Toolbar The toolbars contain icons which give easy access to some of the most frequently. and executes the command.

Tekla For Dummies rdheng@gmail. The following commands can be initiated from the View toolbar: • Create a new basic view • Create a view with three points • Create a view with two point • Open the list of named views • Pick work area • Fit work area by parts in selected views • Fit work area in selected views • Set work plane to view plane • Set work plane by three points • Set work plane to part top • Set work plane to part front plane Points The Points toolbar contains commands for creating points and construction objects you can use to place structural objects in a model. • • • • • • • • Create a grid Create a point array Create an extension point Create a line.com Edit The Edit toolbar contains commands for copying and moving. • • • • • • Copy and translate Copy and rotate Copy and mirror Move and translate Move and rotate Move and mirror View The View toolbar contains commands for creating views and setting the work area and work plane.line intersection point Create a projection point Create parallel points Divide a line Create arc points 5 of 28 .

• • • • Create a fitting Create a line cut Create a part cut Create a polygon cut Tools The commands on the Tools toolbar help you model. 6 of 28 . and pla tes.line intersection points Create an axis intersection point Create a point to any position Create a user-defined plane Create a construction line Create a construction circle Create a construction circle by three points Steel part The Steel toolbar contains commands for creating steel beams. • • • • • • • • • • Create a beam Create a column Create a curved beam Create a polybeam Create an orthogonal beam Create a twin profile Create a contour plate Create bolts Create a weld Create a reference object Detailing/Cutting part or object The Detailing toolbar contains commands for trimming parts. columns.com • • • • • • • • • • • Create an arc by three points Create a tangent point Create a plane-line intersection point Create part-line intersection points Create circle.Tekla For Dummies rdheng@gmail.

Snap switches specify exact locations on objects. If both these witches are off. click Xsnap. 7 of 28 . you can use Xsnap and have Tekla Structures display visual cues when you pick. or use the shortcut T. for example. if you are creating a beam. Main snap switches The two main snap switches illustrated in the following table define whether you can pick reference points or any other points on objects. even if all the other switches are on.you can see it snap to positions.g.com • • • • • • • Create an x measure Create a y measure Create a free measure Create an angle measure Create a bolt measure Open the model folder Inquire an object Components • • • • • • Create the current connection Display the AutoConnection dialog box Open the component catalog Previous Next Toolbar number XSnap To make it easier to snap to points and position. As you move the cursor over objects. e.Tekla For Dummies rdheng@gmail. end points. you cannot pick any positions. You can use snap switches any time Tekla Structures prompts you to specify a point. On the Setup menu. These switches have the highest priority. The cursor turns into a magenta crosshair. Snap switches help you to pick points to position objects precisely without having to know the coordinates or create additional lines or points. for example. part corners. and intersections. midpoints.

.Tekla For Dummies rdheng@gmail. All measurements are temporary. Options Use Options to set various default values for numbering. the distance between two points and between bolts. Remember to follow the prompts on the status bar. To open the Options dialog box. profile names and connections.. click Setup > Options. Click Measure to access the following options. 8 of 28 . The steps for each option are listed below the table.com Measure Use the Measure tool to measure angles. coefficients..

Tekla For Dummies rdheng@gmail. Numbering example 3.com Numbering This section explains how to change numbering settings and apply numbering in Tekla Structures. Applying numbering 9 of 28 . Topics: 1. Numbering settings 2.

marking is active (pop. parts and assemblies retain their original numbers. Pop-marking Pop-marking for NC files also affects numbering. Preconditions Description When you modify a model. 6. All the beams have the part position number P1. You should always use this option when you have changed numbering 10 of 28 . Interrupt numbering You can safely interrupt numbering before it is complete by clicking Cancel in the dialog box Tekla Structures displays while it is running. 1. Tools > Numbering > Modified Synopsis This command assigns position numbers to parts and assemblies modified after the last numbering session. Tekla Structures assigns marks to parts and assemblies. If you interrupt numbering. Tekla Structures will assign different numbers to identical parts if they have different pop marks. Tekla Structures numbers all the parts and assemblies modified since numbering was last carried out. Preconditions Description When you use this command. Number the model. Change beam P2 to be identical to the others. Tekla Structures checks all the parts and assemblies in the model. 3. Tekla Structures assigns different part position numbers to this part. Create three identical beams with the numbering series prefix P and start number 1. Tools > Numbering > Full Synopsis This command assigns marks to all parts and assemblies. Numbering is carried out according to the settings in the Numbering setup dialog box (see Numbering settings). Tekla Structures keeps a list of the parts that have been modified or created since numbering was last carried out.marks). When pop. Parts and assemblies keep their existing numbers if they have not been changed. Number the model. Number the model.com Numbering example This example explains how different numbering settings result in different part numbers when you modify a part. 2. apart from a difference in the position of the plates welded to them. Applying this option takes longer than numbering modified parts only. 5. Modify one of the beams. 4. as follows: Compare to old: P1 Keep number if possible: P2 Take new number: P3 Applying numbering When you apply numbering. You should now have two beams P1 and one P2. Example Two main parts in different assemblies are identical. Tekla Structures assigns them different numbers. If you use this command.Tekla For Dummies rdheng@gmail. according to which numbering settings you used. Parts that were numbered previously and have not been modified are not renumbered. In this case. even if they have not been modified.

If the model changes. You can create drawings and reports at any stage of the project. for example.com settings. If the drawings are not frozen. However. Tekla Structures indicates which drawings you need to update in the Drawings dialog box. and cast-unit drawings. and how Tekla Structures snaps to points. It is also useful when you want to make sure that Tekla Structures checks the numbering of all parts and assemblies.Tekla For Dummies rdheng@gmail. Snap Select switches and Snap settings are special toolbars containing switches which you can use to control which objects can be selected. etc. Use select switches to limit which object types can be selected. dimensions and marks in drawings are always correct. See Locking and freezing drawings). --DRAWING--Drawings integrated into the model Tekla Structures integrates the drawings and reports with the model. You can only open up-to-date drawings. or make them invisible. assembly. 11 of 28 . It also makes it impossible to delete parts and bolts from drawings. if only the Select marks switch is active. For more information.) from single-part. updating drawings deletes all drawing level modifications (additional dimensions. For example. even if you select the entire drawing area. Tekla Structures asks you to update the related drawings. In most other cases drawing modifications are permanent and are updated automatically. text. Tekla Structures only selects marks. you can filter out parts and bolts in drawings. See Drawing list and Drawing status flags. This means that. see Selecting drawing objects.

Tekla For Dummies rdheng@gmail. All commands are listed from left to right of the toolbar. It contains basic commands for saving.com Standard The Standard toolbar is visible by default. View The View toolbar contains commands for creating views and zooming. Edit The Edit toolbar contains commands for trimming and cutting drawing objects. 12 of 28 . and working with drawings. Text Add text and symbols to drawings using the Text toolbar. printing. Dimension Use the Dimension toolbar to edit dimensions.

you need to number the model. or should you modify them The details. A drawing flagged n has been updated. you can start creating drawings to issue. See Numbering parts and Numbering settings. See also Drawing status flags. or multi-drawings in Tekla Structures: 1. Creating drawings Once you complete a model. Prior to creating or editing assembly. 3. or multi-drawings. Topics L The drawing is locked. Locking and freezing drawings You can lock and freeze them so that they are not accidentally modified. updated. Setting drawing properties Tekla Structures creates drawings using the properties defined for each type of drawing. 13 of 28 . Locking and freezing drawings F The drawing is frozen. in the model are correct. * A drawing gets an * flag in four cases: A copied drawing has been modified. single-part. To view or modify drawing properties. You can also change drawing layout using the Properties menu. The drawing is a cloned drawing. Locking Locking prevents the drawings from being opened. even if the model changes. dimensions. cast-unit. A frozen drawing has been updated. Enter a name for the properties file and click Save as. Update the numbering of model objects. D A linked drawing has been modified. deleted.Tekla For Dummies rdheng@gmail. cloned. This is so that Tekla tructures connects the right objects to the right drawings.com Drawing Use the Drawing toolbar to create additional drawing objects. Create test drawings of different types of parts to see how well the predefined drawing properties and layouts suit your needs. Tekla Structures flags locked drawings for update (P or N) if the model changes. select a drawing type from the Properties menu in the Model Editor. etc. Modify drawing properties and layouts if necessary and save them. single-part. cast-unit. Tekla Structures warns you that numbering must be up to date. or modified. 2. You should also create drawings (and reports) periodically while modeling to check if: The predefined drawing properties and filters suit your needs. Before creating drawings Prior to creating assembly. and there are still other parts relevant to the drawing in the model.

etc.g.com Freezing Freeze a drawing when you want to keep manual editing (such as additional marks and dimensions) in the drawing even if the model changes. Table layouts Tables and templates In Tekla Structures. When Tekla Structures updates a frozen drawing. part and bolt lists) General notes Key plans DWG/DXF files Tables include information on drawing objects. or click File > Close drawing. Saving and closing drawings To save a drawing. we use the term tables to refer to various elements of the drawing layout.) is changed. A confirmation dialog box appears Tekla Structures prompts you save the drawing. revision table) Title blocks Lists (e. or . Close drawing To close a drawing. Table layout A table layout is a group of tables which appear together in a drawing of certain type and size. part marks.g.Tekla For Dummies rdheng@gmail. For information on how to define the location of autosave files and set their location see Autosave. close the drawing window. The drawing views are blue. Nothing else (dimensions. click File > Save. and the elements of table layout are red. Table layouts define: Which tables appear Where the tables are located How much space Tekla Structures leaves between the drawing frame and views The example below illustrates the relationship between the table layout and drawing views. If you change the model. 14 of 28 . Autosave Tekla Structures automatically saves drawings at set intervals. Tekla Structures updates the contents of the affected drawings and tables. it updates only the image of the member. such as: Tables (e.

or to an other table.com Table layout You define the location of each individual table in a table layout by binding it to the drawing frame. the lower right corner of the drawing title (the table) is bound to the lower right corner of the drawing frame (the reference object).Tekla For Dummies rdheng@gmail. 15 of 28 . Example In the illustration below.

You will define the majority of print settings when you set up the print device. either attached directly to your system. Creating reports 16 of 28 . Firstly you need to add printer aliases to the plotter catalog.com Setting up a print device Tekla Structures uses Windows drivers to write the print data directly to the Windows print device interface. By default several printer aliases are already defined. or available via a network. There are two stages to setting up a print device in Tekla Structures. you need point these printer aliases to a specific Windows printer. Secondly.Tekla For Dummies rdheng@gmail.

com 17 of 28 .Tekla For Dummies rdheng@gmail.

telah didesign dan analysis dengan menggunakan STAADPro. akan diberikan step by step penggunaan Tekla structure untuk sebuah project piperack. 18 of 28 .Tekla For Dummies rdheng@gmail. Modelling Struktur Pilihlah icon TeklaStructure untuk memulai pekerjaan detailing seperti dibawah ini. kemudian pilih new model dan isikan nama filenya “PR-007”atau lainnya. 1. Seperti terliat dibawah ini terlihat sebuah struktur piperack.com SAMPLE PROJECT Dibawah ini. sehingga proses detailing/shopdrawing berjalan lebih cepat. Salah satu feature dari teklastructure adalah dapat mengimport model struktur yang ada pada STAADPro.

com Untuk fasilitas import akan dibahas tersendiri mengingat kepentingan dan scope latihan ini hanya untuk dasar-dasar penggunakan Teklastructure. 19 of 28 . 2. Grid struktur sangat berguna baik dalam proses shopdrawing maupun pada saat konstruksi. Dengan referensi gridlah struktur tersebut dibagun dan diluruskan. column. welding Operasi copy-move-translate. F…. cutting-line cut.1. 1. 3. Untuk mempercepat proses modeling rubahlah view-render menjadi wireframe. EL8000. pilih wireframe. Kemudian akan keluar window sebagai berikut ini. Isikanlah data – data strukturnya. D. EL5000. plate bolt. B.Tekla For Dummies rdheng@gmail. kemudian juga arah Z atau elevasi EL0. Kemudian setelah selesai dapat pilih modify atau create. dengan cara double click view pada view-type. Kemudian pilih modifyok. rotate. 4…. Kemudian juga nama-nama dari gridnya arah X A. arah Y yaitu 1. mirror. Kemudian setelah tahap diatas selesai maka akan terlihat sebuah file Teklastruktur yang siap untuk dikerjakan. C. Pilihlah pada menu pointà Grids. Untuk memudahkan dalam memahami proses modeling maka akan dibagi menjadi beberapa bagian sebagai berikut: Pembuatan/set-up grid struktur atau as bangunan Membuat view dan save view Part: beam. Grid set up. baik arah horizontal (x dan y) maupun arah verikal (z).

Tekla For Dummies rdheng@gmail.com Kemudian dalam model akan terlihat seperti dibawah ini: Menu Toolbar Grid 20 of 28 .

1. Weld. Parts: Beam. Isikanlah GLA pada input Name. Pilihlah dari toolbar Create view by two point. Cut dan Line Cut Setelah kita dapat melalui dua tahapan diatas maka model tersebut telah siap untuk dimasukan object seperti diatas. Pada saat ini kita akan membuat view pada grid line A dan akan kita save dengan nama GLA. View sangat berguna dalam pemodelingan struktur. Setelah itu pilih modify – ok. Pembuatan View dan Save View. Kemudian dbl clik view yang telah muncul.2. 21 of 28 . Usahakan sesuai dengan arah pandang yang umum di gunakan yaitu dari kanan ke kiri atau dari bawah ke atas. Kemudian pilihlah point pertama dan kedua. Arah pandang struktur.3. Untuk pembuatan view lainnya dapat dilakukan seperti diatas. Column.com 1. Bolt.Tekla For Dummies rdheng@gmail.

Kemudian setelah diisikan semua maka pilih lah letak kolom tersebut pada Grid line A. Untuk memasukan column dalam dipilih pada toolbar “Create Column”.1. Kemudian isikanlah seperti di bawah ini.Tekla For Dummies rdheng@gmail. Column adalah object yang ada dalam xsteel mempunyai posisi vertical. Kemudian keluakanlah View GLA yang telah kita buat sebeluhnya. Seperti tampak pada gambar dibawah ini. 22 of 28 . Untuk pembuatan beam akan lebih mudah pada view tersebut.com 1.3. Column.

Beam. Untuk beam yang kedua. Pilihlah pada toolbar seperti dibawah ini “create beam”. Kemudian isikan lah data-data seperti di bawah ini ( sama seperti pada kolom. Titik pertama Titik Kedua 23 of 28 .com 1. Beam adalah object yang ada dalam xsteel biasanya mempunyai posisi datar / horizontal. Kemudia pilih titik pertama dan kedua seperti dibawah ini.Tekla For Dummies rdheng@gmail.2. Dbl klik toolbar beam “Create beam”. Biasa di lakukan dengan proses penggandaan yang akan dibahas kemudian. Setelah ini pilih apply-ok.3. tetapi kita tidak perlu ke tab position.

com Dalam pembuatan beam usahakan titik pertama ada pada di sebelah bawah-kiri dari titik ke dua. 1. Bolt.Tekla For Dummies rdheng@gmail. Seperti tampak di bawah ini. End Plate Haunced Buat lah seperti digambar diatas plate dan haunced. Dan begitu seterusnya untuk beam-beam lainnya. tahap selanjutnya adalah pembuatan detail sambungan antara kolom dan beam. Dalam tahap ini memerlukan bolt. Untuk bantuan titik-titik dapat di gunakan yang terdapat pada toolbar.3. caranya sama dengan proses pembuatan beam tetapi isilah untuk profile PL16*200 seperti terlihat dibawah ini. Setelah beam dan kolom sudah berada alam model.3. plate. cut dan welding seperti yang akan dibahas di bawah ini. 24 of 28 . Untuk tahap ini kita gunakan dulu dengan beam properties. plate. cut dan welding Dalam pembuatan plate ada dua cara yaitu dengan beam properties dan contour plate.

Sumbu x adalah searah dengan titik 1 dan 2 sdang sumbu y adalah yang tegak lurus dari sumbu ½ atau x. dan diameter baut. tolerance. Setelah itu tekan middle button mouse. Bolt pada end plate dan column flange 25 of 28 . Pilihlah part yang akan dibaut yaitu plate dan column flange. kemudian titik pertama dan kedua. grade.Tekla For Dummies rdheng@gmail. Seperti terlihat dibawah ini. Setelah itu pilih apply—ok.com Sedang untuk bolt dapat dipilih pada toolbar steel. Dbl klik lah kemudian isikanlah data – data jarak baut. sebagai sumbu x dan y.

Setelah tahap ini maka detail sambungan antara kolom dan beam sudah selesai dan dapat dilanjutkan pada tahap berikutnya yaitu cara menggandakan dan memindah object dalam model. pada detail sambungan diatas diasumsikan bahwa pada kedua ujung beam tersebut mempunyai detail sambungan yang sama. seperti terlihat dibawah ini.Tekla For Dummies rdheng@gmail.4. Cara kedua lebih cepat dari yang pertama dikarenakan kita dapat melakukan multiple pick object. Sebagai contoh. sehingga kita tidak perlu membuat ulang detail tersebut. end plate. move by three points dan sebagainya. 26 of 28 . Untuk memilh object dalam tekla dapat dengan dua cara yaitu dengan pick satu-satu atau dengan cara drag mouse.3. Welding simbol Untuk welding dapat dilakukan dengan cara pilih create weld toolbar. Sebelum kita melakukan kopi mirror set lah dulu ucs pada view GLA. Harus diperhatikan disini bahwa yang dipilih dahulu pada setiap operasi weld adalah mainpartnya . setelah itu pilih line-mirror pada tengah-tengah gridline 1 -2 kemudian pilih copy kemudian ok. Kemudian pilih mainpart setelah itu secondary part. 1. mirror. rotate. Dalam operasi penggandaan dan memindahkan object dapat dilakukan dengan berbagai macam yaitu translate. weld dan cut.com Jika ingin melihat rendered strukturnya dapat dilakukan dengan cara pilih bolt kemudian clik kanan – pilih view – basic view. Copy dan Move. Cukup dengan mengcopy-mirror seluruh object à bolt. Pada model tekla dan pilihlah object yang akan dicopy-mirror kemudian click kanan pilih copy à mirror.

Pada frame GLA sampai dengan GLE mempunyai persamaan frame sehingga dapat digandakan dengan cara copy translate. Isilah data-data seperti di bawah ini.com Kita tidak perlu isikan apapun dalam copy mirror. Sehingga hasil dari operasi tersebut dapat dilihat pada gambar dibawah ini. Caranya pilih semua object pada GLA kemudian click kanan pilih copy à translate.Tekla For Dummies rdheng@gmail. Kemudia pilih copy – ok. 27 of 28 . Untuk beam yang lain dapat digandakan seperti operasi di atas.

Untuk tahap selanjutnya yaitu pembuatan longitudinal beam dapat dilakukan seperti langkah – langkah diatas. kemudian juga detail sambungan antara kolom bias dilakukan dengan cara seperti di atas sesuai dengan detail sambungan yand ada.com Maka sampai disini struktur kita akan terlihat seperti diatas.Tekla For Dummies rdheng@gmail. V brace dan H brace yang ada seperti cara diatas. Pertama buat lengkaplah semua longitudinal beam. Maka model xsteel akan terlihat seperti dibawah ini: 28 of 28 . Untuk tahap selanjutnya pembuatan detail sambungan akan menggunakan component yang disediakan oleh xsteel.

Sign up to vote on this title
UsefulNot useful