You are on page 1of 14

INTRODUCCION A EXCEL 2007

Qu es y para qu sirve Excel2007? Excel 2007 es una hoja de clculo integrada en Microsoft O7ffice. Esto quiere decir que es los menus y las interfaces son muy similares a los otros programas de Office, como Word, Access, Outlook, PowerPoint. Esto es una gran ventaja puesto que muchos iconos y comandos funcionan de forma similar en todos los programas de Office. Excel es una hoja de clculo. Una hoja de clculo es un programa que es capaz de trabajar con nmeros de forma sencilla e intuitiva. Para ello se utiliza una cuadrcula donde en cada celda de la cuadrcula se pueden introducir nmeros, letras y grficos, as:

UTILIDADES DE EXCEL 2007


Excel 2007 es muy util para aplicaciones uqe requieren del uso de calculos, automticos, como por ejemplo, roles de pagos, facturas, inventarios, cuadros de notas, etc. Ya que para realizar operaciones entre aritmeticas entre series de nmeros, slo se debe trabajar con las formulas respectivas y los clculos sern realizados automticamente. De esta manera si existe una equivocacin al introducir un dato, simplemente se corrige el dato y automticamente y Excel vuelve a calcularlo todo. Esto es una gran ventaja cuando se trabaja con cantidades voluminosas de datos, por ejemplo si se estuviera haciendo un cuadro de notas con muchos aportes y observaciones a mano y al final se descubre un error de clculo en un promedio, entonces se debera volver a calcularlo todo. Pero con con Excel slo se debe corregir un dato. En Excel tambin se puede dibujar grficos a partir de los datos introducidos. Los estilos de los grficos se pueden escoger, seleccionando los ms representativos, en base a la aplicacin. Excel se puede utilizar para multitud de cosas, tanto en el plano personal como en el plano profesional. Desde llevar las cuentas familiares hasta los ms complejos clculos financieros.

CUADROS DE NOTAS EN EXCEL 2007


1. Es necesario crear un cuadro que refleje los aportes y las notas de los estudiantes, as.

2. Se puede dar formato a las celdas mejorando su presentacin. As:

Y adems ubicar encabezados que sean explicativos. As:

Luego se puede cambiar fuentes de letras, colores, y resaltar lo necesario, para obtener un cuadro similar al siguiente.

Una vez con nuestro libro avanzado, debemos tomar la buena costumbre de ir guardando los cambios, en caso de que ocurra un suceso externo (prdida de fluido elctrico, falla del sistema, etc). El proceso de grabacin es: Clic en botn de Office Guardar - Especificar el nombre y la ubicacin - Aceptar

Una vez con nuestro cuadro creado y guardado debemos proceder a la generacin de las frmulas, para que los clculos se realicen automticamente.

Para esto podemos resaltar las celdas a donde vamos a ubicar los primeros resultados parciales:

La NOTA1 ser el resultado de sumar Aporte1+Aporte2+Aporte3 del PRIMER PARCIAL, por tanto debemos codificar:

La NOTA2 ser el resultado de sumar Aporte1+Aporte2+Aporte3 del SEGUNDO PARCIAL, por tanto debemos codificar:

La SUMA ser el resultado de sumar NOTA1 (F12) + NOTA2 (J12) , por tanto debemos codificar:

En este caso las sumas se hacen especificando directamente las celdas a sumarse, pero en caso de ser un rango muy amplio de celdas se puede especificar un mtodo alternativo utilizando la funcin suma; con el formato SUMA (celda_inicial:celda_final). Para realizar el clculo de la Observacion, se debe utilizar la funcin lgica, llamada funcin SI. La funcin SI.

Realiza una comprobacin y devuelve un valor si la comprobacin es verdadera y otro valor si resulta falsa. Sintaxis: =SI(prueba_logica;valor_si_verdadero;valor_si_falso)

Ejemplo: =SI(A1>=18;"Es mayor de edad";"NO Es mayor de edad")

Explicacion: Nos ubicamos en la celda en la cual queremos que el mensaje se despliegue, y codificamos: =SI(A1>=18;"Es mayor de edad";"NO Es mayor de edad") La celda que contenga esta frmula contendr el valor de la celda, verificar el valor de la celda A1. Si este valor es mayor o igual a 18 desplegar el mensaje "Es mayor de edad", caso contrario desplegar el mensaje "NO Es mayor de edad".

Esta funcin es muy til para obtener valores dependiendo de alguna condicin.

Ahora nuestro caso plantea que: Los estudiantes que tienen una SUMA>=14 Aprueban. Por el contrario si la SUMA est entre 11 y 13.9, el estudiante esta Suspenso. Pero si el estudiante tiene una SUMA inferior a 11 entonces Reprueba. Para este caso nuestra codificacin ser:

=SI(K12>=14;"Aprobado";SI(K12>=11;"Suspenso";"Reprobado"))
Cubre a los estudiantes cuya suma, almacenada en la celda K12 es mayor a 14. (Aprobados) Cubre a los estudiantes cuya suma, almacenada en la celda K12 es mayor 11, pero menor a 14, por el caso contrario de la condicin anterior. (Suspensos) Cubre a los estudiantes cuya suma, almacenada en la celda K12 es menor a 14. (Reprobados)

En nuestro cuadro de notas, para obtener la observacin, codificaremos:

Una vez con datos nuestro cuadro de notas debera tener:

La nota de suspensin por su parte, la ingresar de forma manual el Usuario (Docente)

Para copiar las frmulas se debe arrastrar el mouse hacia las celdas que queremos que contengan la frmula.

Y llenar los datos necesarios.

Para validar la nota de suspensin podremos codificar utilizando la funcin O. Funcin O Comprueba si al menos algn valor lgico es verdadero y devuelve VERDADERO. Si todos los valores son falsos devuelve FALSO. Sintaxis Funcin O(valor_logico1;valor_logico2;...)

La funcin O puede ir dentro de la funcin SI. En nuestro caso. =SI(O(L12="Aprobado";L12="Reprobado");"No debe rendir";"") Explicacin. Si la observacin almacenada en L12 = "Aprobado" o L12="Reprobado", entonces el mensaje ser No debe rendir el examen de suspension, caso contrario, es decir, si L12=Suspenso, entonces se queda el casillero vacio para recibir la Nota de Suspensin, As:

El resultado final ser:

La observacin final necesita ser analizada ya que los estudiantes que tengan una SUMA entre 11 y 13.9, deben rendir la suspensin, y alcanzar el puntaje 21, para aprobar, por lo tanto la codificacin de esa celda ya con controles ser: =SI(L12="Suspenso";SI(M12+K12>=21;"Aprueba";"Reprueba");"") Explicacin: Si en la celda que esta la observacin (L12) dice Suspenso, solo en ese caso verificar que la Nota de Suspensin(K12) ms la SUMA(M12), sea mayor o igual a 21, si esto ocurre el mensaje ser Aprueba, caso contrario el mensaje ser Reprueba,y si es que la observacin no es Suspenso, significa que no debe rendir suspensin en cuyo caso el mensaje sera , que equivale a vaco.

El cuadro final ser:

A este cuadro aumentaremos mediante la funcion ContarSI. Para obtener la suma de los estudiantes que Aprueban, la suma de los estudiantes que Reprueban, y la suma de los estudiantes Suspensos.

De ese cuadro de resumen podremos generar un grfico, Para nuestro caso es bastante explicativo un grfico en pastel, con los porcentajes correspondientes a los estudiantes Aprobados, Reprobados, y Suspensos. El grfico en este caso tomar como referncia los resultados obtenidos por la funcin CONTAR.SI(), As

El resultado final ser:

Resumen de Programacin I
20% 40%

40%

Aprueban Suspensos Reprueban