You are on page 1of 3

RELACIONAR DATOS EN EXCEL Generalmente, los trabajos que el usuario realiza en Microsoft Excel vienen estructurados en libros u hojas

separadas. Por ejemplo, es común que se tenga un libro que contiene la base de datos de productos, precios asociados, descripción etc. y otros libros de trabajo para crear facturas, informes... a partir de los datos del primer libro. Esta vinculación podría hacerse tomando directamente los valores del libro de trabajo base haciendo clic en cada caso en la celda correspondiente o bien pegando vínculos. Pero cuando los datos fuente tienen una estructura similar a la que se muestra en la figura 1 y queremos, por ejemplo, extraer el precio de un determinado producto teniendo el código en el libro vinculado, es mucho más fácil y automático utilizar funciones como BUSCARV, BUSCARH, COINCIDIR E INDICE que lo harán automáticamente. Veamos con ejemplos sencillos el modo de relacionar dos tablas que se encuentran en dos libros diferentes en Microsoft Excel 5.0. Supongamos que partimos del siguiente libro, que contiene la base de datos de productos. Va a ser el libro base de donde se tomarán los datos. Tenemos otro libro en el cual vamos a rellenar una factura en base a estos datos. En el libro con la factura únicamente aparece el código del producto, este será el libro vinculado. La base de datos es la siguiente: A | B | C | D | ---|------- |---------------|---------| 2 | CODIGO | PRODUCTO | PRECIO | -------------|---------------|---------| 3 | A100 | Ordenador | 100 | ---|---------|---------------|---------| 4 | A200 | Impresora | 200 | ---|---------|---------------|---------| 5 | B100 | Ratón | 300 | ---|---------|---------------|---------| 6 | B200 | Monitor | 400 | ---|---------|---------------|---------| 7 | C100 | Teclado | 500 | ---|---------|---------------|---------| 8 | C200 | Discos | 600 | ---|---------|---------------|---------| 9 | C300 | Placa SVGA | 700..| ---|---------|---------------|---------|

Esta tabla representa el libro Base. En este primer ejemplo vamos a utilizar la función BUSCARV.

Esta es la factura que vamos a rellenar partiendo del libro base (supongamos que el libro base se llama DATOSVIN.XLS y que la hoja que contiene esta base se llama Producto): A | B | C | D | ---|------- |---------------|---------| 2 | CODIGO | PRODUCTO | PRECIO | -------------|---------------|---------| 3 | A200 | | | ---|---------|---------------|---------| 4 | C300 | | | ---|---------|---------------|---------| | | | | ---|---------|---------------|---------|

Esta tabla representa una hoja vinculada. La función BUSCARV buscará el código del producto en el libro inicial y devolverá el producto y el precio asociado a ese código. Como la función BUSCARV buscará a partir del código, debemos ordenar la base de datos original según el Código, de no hacerlo, los datos devueltos podrían ser erróneos. En la celda C3 introduciría la siguiente fórmula: =BUSCARV(B3;[DATOSVIN.XLS]Producto!$B$3:$D$9;2) Los argumentos de BUSCARV son: 1. Dato a buscar 2. Matriz de búsqueda 3. Columna de la matriz que queremos que devuelva. Es decir, quiero que busque el contenido de B3 (A200) en la primera columna del rango B3:D9 de DATOSVIN.XLS y que cuando lo encuentre, devuelva el contenido correspondiente de la segunda columna, esto es, el producto a que corresponde el código (de ahí que el último argumento sea 2). En la celda D3 pondría la fórmula: =BUSCARV(B3;[DATOSVIN.XLS]Producto!$B$3:$D$9;3) para que me devuelva el precio del producto. Llenando hacia abajo obtendría: A | B | C | D | ---|------- |---------------|---------| 2 | CODIGO | PRODUCTO | PRECIO | -------------|---------------|---------| 3 | A200 | Impresora | 200 | ---|---------|---------------|---------| 4 | C300 | Placa SVGA | 700 | ---|---------|---------------|---------| | | | | ---|---------|---------------|---------|

La función BUSCARV tiene un cuarto argumento: VERDADERO cuando queremos que si no

encuentra el valor exacto en la lista devuelva un valor de error y FALSO, en este caso, cuando no encuentra el valor en la lista toma el valor superior. Por ejemplo si pusiéramos: =BUSCARV(B3;[DATOSVIN.XLS]Producto!$B$3:$D$9;2;FALSO) y en la celda B3 tenemos C150, devolvería Discos. Si ponemos como argumento VERDADERO devolvería un valor de error.