Université de Kairouan Institut supérieur d’Informatique et de Gestion de Kairouan

A.U : Niveau : Module :

2012/2013 1 LA_RI Algorithmique I

x+z<y) 6) Ecrire (‘le produit de x et z est’. 3) Déclarer le tableau T avec deux méthodes différentes 4) Soit un tableau V formé de N chaînes de caractères avec N une constante égale à 20. Déclarer le tableau V avec deux méthodes différentes. z. y=3. 1) Remplir les cases de la matrice après exécution des instructions suivantes : T[1][2] ← 5 T[1][1] ← T[1][2] div 2 T[1][3] ← T[1][2] mod 2 T[1][4] ← T[1][2]+T[1][3] T[1][5] ← carrée(T[1][1]) T[2][2] ← T[1][2]*4 2) Pour le reste des cases refaire les mêmes opérations effectuées dans 1. x*z) Exercice 3 1) Déclarer un tableau T de 10 entiers. avec les colonnes de la première ligne en changeant le numéro de ligne par 2. 2) Quels sont les valeurs des cases de T après la déclaration ? . ’est égale à’. Exercice 2 Soit x=11. y) 3) Ecrire (x+y) 4) Ecrire (‘x+y’) 5) Ecrire (x.Travaux dirigé n°1 Exercice 1 Soit une matrice T formée de 2 lignes et 5 colonnes.5 et z=2 Que serait le résultat de chacune des instructions suivantes : 1) Ecrire (‘le contenu de y est y’) 2) Ecrire (‘le contenu de y est’. y.’+’.’<’.

en utilisant une variable auxiliaire . on considère les séquences d’algorithmes S1 et S2 suivantes : S1 si (x<5 ou y>2) et z> 3 alors alors x 1 si (z-y) > 0 alors z0 fin si S2 si x<5 ou (y>2 et z> 3) x 1 si (z-y) > 0 alors z0 fin si .en utilisant une variable auxiliaire .3) Quel est le type des indices de T ? Est-ce que les indices peuvent être de type réel ? 4) Peut-on utiliser un tableau contenant différents types (entier. etc. y et z trois variables de type entier. Exercice 4 Soit A un nombre donné formé de 4 chiffres.) ? 5) Nous avons besoins dans un algorithme de déclarer 10 tableaux de même type que T. Peut on utiliser une autre structure de données qui remplace ces déclarations ? Faire la déclaration de la structure de donnée proposée.sans utiliser une variable auxiliaire Exercice 6 Soient x.sans utiliser une variable auxiliaire 2) Ecrire un algorithme permettant de lire trois réels et d’effectuer leur permutation circulaire dans chacun des cas suivant : . on désire inverser A. caractères. Exemple Si A = 3215 après inversion A=5123 Ecrire un algorithme permettant d’inverser un nombre formé de 4 chiffres Exercice 5 1) Ecrire un algorithme permettant de lire deux réels et d’effectuer leur permutation dans chacun des cas suivant : .

b. y. z=1 Exercice 7 Donner une écriture plus concise des deux séquences algorithmiques suivantes : Séquence 1 Lire (a. y=1.y y+z sinon x 2 z y + z fin si fin si sinon y y+z x 2 z y + z Effectuer le tournage à la main de chacune des deux séquences et donner les valeurs de x. z=4 2) x=4. y=3. z (à la fin de chaque séquence) dans les 3 cas suivants : 1) x=4. c) si (a<b) alors a b b 0 cc+2 sinon a b cc+2 fin si Séquence 2 lire (x. y=5. z=4 3) x=1.y) si (a<b) alors x  y-x z y * 2 sinon x  y-x z y / 2 fin si .

Sign up to vote on this title
UsefulNot useful