fizemos o chines e deu certo. pode ser um caminho??

Inicio Mat [6x11] i,j para i = (1,6,1) para j = (1,6,1) se Mat [ij] = Mat( i + j = 7,8,9,10,11,12) imprimir fim se fim para fim para para i =(2,6,1) para j = (7,11,1) se Mat [i,j] = Mat(j-i= -1,-2,-3,-4,-5) fim se fim para fim para fim

Fabio Viana e Michael Rogerson

maior:inteiro inicio X <. z:real inicio // Seção de Comandos enquanto (z <> 1) faca escreval ("digite 2 números") leia (x) leia (y) z <.99 maior <.x fimse fimse fimenquanto escreval (menor) escreval (maior) .0 // Seção de Comandos enquanto (X <> 0) faca escreval ("digite 1 números") leia (x) se x <> 0 entao se x > maior entao maior <.caso alguem ainda esteja empacado fiz no visual.x fimse se x < menor entao menor <. se alguem quizer testar e so jogar no programa e apertar F9 EXERCICIO 1 algoritmo "semnome" // Função : // Autor : // Data : 24/06/2012 // Seção de Declarações var x.99 menor <. menor. y.(x + y) se ( z > 5 ) entao escreval (z) fimse fimenquanto fimalgoritmo EXERCICIO 2 algoritmo "semnome" // Função : // Autor : // Data : 24/06/2012 // Seção de Declarações var x. FOLHA 1 .RE: [INF194] Jucelito W.

1 vet[2] <.fimalgoritmo EXERCICIO 3 algoritmo "semnome" // Função : // Autor : // Data : 24/06/2012 // Seção de Declarações var x:inteiro vet : vetor [1..10] de inteiro inicio vet[1] <.77 vet[8] <.44 vet[6] <.4 vet[5] <.23 vet[3] <.66 vet[7] <.8 vet[9] <.7 vet[8] <.10] de inteiro inicio vet[1] <.2 vet[3] <..5 vet[6] <.100 // Seção de Comandos para x de 1 ate 10 passo 1 faca se vet[x] > 10 entao se vet[x] < 50 entao escreva (">10 e <50") escreval (vet[x]) .41 vet[5] <.10 vet[2] <.3 vet[4] <.37 vet[4] <.z.95 vet[10] <.84 vet[9] <.6 vet[7] <. soma:inteiro vet : vetor [1.10 // Seção de Comandos para x de 10 ate 1 passo -1 faca escreval (vet[x]) fimpara fimalgoritmo EXERCICIO 4 algoritmo "semnome" // Função : // Autor : // Data : 24/06/2012 // Seção de Declarações var x.9 vet[10] <.

fimse fimse fimpara para x de 1 ate 10 passo 1 faca z <. menor.z + 1 slidos <.x fimse se x > 10 entao s10 <.0 // Seção de Comandos enquanto (X <> 0) faca escreval ("digite 1 números") leia (x) se x <> 0 entao z <.slidos.99 maior <.s10 + x fimse fimse fimenquanto escreval (menor) escreval (maior) escreva ("total lidos") escreval (z) .s10.soma + vet[x] fimpara escreva ("soma dos numeros lidos = ") escreva (soma) fimalgoritmo EXERCICIO 5 algoritmo "semnome" // Função : // Autor : // Data : 24/06/2012 // Seção de Declarações var x.99 z <.slidos + x se x > maior entao maior <.maior:inteiro inicio X <.x % 2 se z = 0 entao escreva ("indice par") escreval (vet[x]) fimse fimpara para x de 10 ate 1 passo -1 faca escreva ("ordem decrescente") escreval (vet[x]) soma <.0 menor <.x fimse se x < menor entao menor <. z.

i.fat:inteiro inicio X <. vet2.3 vet1[4] <.99 z <..FAT * I fimpara escreva ("Fatorial = ") escrevaL (FAT) fimse fimenquanto fimalgoritmo EXERCICIO 7 algoritmo "semnome" // Função : // Autor : // Data : 24/06/2012 // Seção de Declarações var x.escreva ("------------------") escreva ("somatorio lidos = ") escreval (slidos) escreva ("------------------") escreva ("somatorio > 10 = ") escreval (s10) fimalgoritmo EXERCICIO 6 algoritmo "semnome" // Função : // Autor : // Data : 24/06/2012 // Seção de Declarações var x.1 vet1[2] <.0 // Seção de Comandos enquanto (X <> 0) faca escreval ("digite 1 números") leia (x) se x <> 0 entao FAT <.4 vet1[5] <.10] de inteiro inicio vet1[1] <.8 vet1[9] <.z:inteiro vet1. vet3 : vetor [1.9 .6 vet1[7] <.2 vet1[3] <.7 vet1[8] <.n.1 para I de 1 ate x passo 1 faca FAT <. z.5 vet1[6] <.

vet1[10] <."X" vet1[3] <.z + 1 fimpara fimalgoritmo EXERCICIO 8 algoritmo "semnome" // Função : // Autor : // Data : 24/06/2012 // Seção de Declarações var x."A" vet1[8] <."A" vet1[14] <.20] de caractere inicio vet1[1] <.z.2 vet2[3] <.6 vet2[7] <."X" vet1[2] <.8 vet2[9] <.10 vet2[1] <.9 vet2[10] <."A" vet1[19] <."Z" vet1[11] <."A" vet1[10] <.3 vet2[4] <."A" vet1[18] <."A" vet1[9] <."z" vet1[12] <."A" vet1[13] <.4 vet2[5] <."A" vet1[17] <."A" vet1[7] <."A" vet1[5] <.."X" z<-0 .y:inteiro vet1: vetor [1.vet1[x] + vet2[10-z] escreva (vet1[x]) escreva (" + ") escreva (vet2[10-z]) escreva (" = ") escreval (vet3[x]) z <."X" vet1[20] <.12 z<-0 // Seção de Comandos para x de 1 ate 10 passo 1 faca vet3[x] <."A" vet1[4] <.5 vet2[6] <.15 vet2[2] <."A" vet1[16] <."A" vet1[6] <."A" vet1[15] <.7 vet2[8] <.

1]:=21 mat[2..z + 1 fimpara se y = 0 entao escreva ("Eh Palindromo") senao escreva ("Nao eh Palindromo") fimse fimalgoritmo EXERCICIO 9 algoritmo "semnome" // Função : // Autor : // Data : 10/06/2012 // Seção de Declarações var mat: vetor [1.1.3.3]:=23 mat[2.5]:=15 mat[2.5]:=35 para I de 1 ate 3 passo 1 faca escreval(" ") para J de 1 ate 5 passo 1 faca escreva(" ") escreva (mat[i.5] de inteiro I.3]:=33 mat[3.3]:=13 mat[1.4]:=34 mat[3.5]:=25 mat[3.4]:=14 mat[1.2]:=12 mat[1.j]) fimpara fimpara fimalgoritmo .. x : inteiro inicio // Seção de Comandos mat[1.y + 1 fimse z <.y<-0 // Seção de Comandos para x de 1 ate 20 passo 1 faca se vet1[x] <> vet1[20-z] entao y <.2]:=32 mat[3.1]:=11 mat[1.1]:=31 mat[3.4]:=24 mat[2.2]:=22 mat[2. J.

FAT * I fimpara escreva (FAT) fimalgoritmo .1 para I de 1 ate N passo 1 faca FAT <. FAT. N :inteiro inicio // Seção de Comandos Faca enquanto N <> fim leia (N) FAT <.FATORIAL ( CAIU NA A1) algoritmo "Fatorial" // Função : Dá o n! do número // Autor : Alexandre Silva Gabriel // Data : 01/06/2012 // Seção de Declarações var I.