You are on page 1of 6

@INTE ACADEMIA

Curso de Excel

Sesin 21. Si
21.1. Ahorrar escritura En la lista de trabajadores nos hemos hartado de escribir y queremos automatizar ms la introduccin de datos. As, nos hemos propuesto asignar un nmero a cada categora profesional. Categora Encargado Oficial Pen Nmero 1 2 3

Vamos a crear una frmula que traduzca los nmeros que introduzcamos a las categoras. 1. 2. Abra Excel. Copie los siguientes datos.

3. 4.

Ahora vamos a escribir una frmula que traduzca los cdigos de categora al nombre de la categora que le corresponde. Haga clic en la celda C2. Escriba la siguiente frmula: =SI(B2=1;Encargado;SI(B2=2;Oficial;SI(B2=3;Pen))) Esta frmula contiene 3 condiciones. Si en la celda B2 est el nmero 1, la categora del trabajador es Encargado, si en celda B2 hay un 2, la categora del trabajador es Oficial, si en la celda B2 hay un 3, la categora del trabajador es Pen.

5.

Pulse la tecla Intro. Observe que, como el cdigo de la categora es 1, el nombre de la categora es Encargado. Copie la frmula hacia abajo y observe como cada

1/6

AINTE INFORMTICA

@INTE ACADEMIA

Curso de Excel

trabajador tiene su categora pero nos hemos ahorrado de escribir los nombres completos de las categoras.

21.2. Buscar Vamos a crear una hoja de clculo que traduzca los nmeros de las notas a letras. Si la nota est entre 0 y 5, la nota es suspenso, si la nota est entre 5 y 6 la nota es suficiente, si la nota est entre 6 y 7 la nota es bien, si la nota est entre 7 y 9 la nota es notable y si la nota est entre 9 y 10 la nota es sobresaliente. 1. 2. Entre en Excel. Copie los siguientes datos en una nueva hoja de clculo:

3. 4.

Haga clic en la celda C2. Escriba la siguiente frmula:

=BUSCARV(B2;$F$1:$G$6;2)

2/6

AINTE INFORMTICA

@INTE ACADEMIA

Curso de Excel

La frmula BUSCARV busca el valor de la celda B2 (2,3) en el rango de celdas donde hemos escrito las notas, es decir, de la celda F1 hasta la celda G6 y saca el valor de la segunda columna de la tabla, esto es, suspenso. 5. Copie esta frmula hacia abajo para comprobar que las notas se muestran correctamente.

21.3. Elegir Podemos elegir entre una serie de valores a partir de un nmero o ndice con la frmula elegir. Vamos a realizar lo mismo que hicimos en el apartado 1, pero usando la frmula ELEGIR. 1. Recuerde que asignbamos un nmero a cada categora. Copie los siguientes datos desde la hoja que realizamos en el apartado 1.

2. 3. 4.

Borre las frmulas desde la celda C2 hasta la celda C10. Haga clic en la celda C2. Escriba en C2 la siguiente frmula y pulse la tecla Intro:

3/6

AINTE INFORMTICA

@INTE ACADEMIA

Curso de Excel

=ELEGIR(B2;"Encargado";"Oficial";"Pen")
Esta frmula asigna un texto dependiendo del valor de B2. Si B2 vale 1, se introduce el texto Encargado en la celda C2, si B2 vale 2, se pone el texto Oficial, si B2 vale 3, se pone el texto Pen. 5. Copie la frmula hacia abajo.

21.4. Contar en una tabla Tenemos una lista de ventas diarias y queremos saber cuanto se ha vendido de cada artculo. Vamos a ver como hacer que Excel sume automticamente las apariciones de determinado producto. 1. Abra Excel e introduzca los siguientes datos en una hoja de clculo.

4/6

AINTE INFORMTICA

@INTE ACADEMIA 2. Copie la siguiente tabla a la derecha de las ventas.

Curso de Excel

3. 4.

Haga clic en la celda D2. Escriba la siguiente frmula y pulse Intro:

=CONTAR.SI($A$1:$A$20;C2)
Esta frmula cuenta cuantas celdas en el rango A1:A20, es decir, en la lista de ventanas, coinciden con la celda C2, es decir, el texto Camisa. 5. Copie la frmula hacia abajo y compruebe si efectivamente Excel ha contado correctamente.

21.5. Varias condiciones Hemos realizado un examen y hemos hecho un trabajo. Los alumnos aprueban si y solo s la nota del examen es mayor o igual que 5 y el examen ha sido realizado con xito. 1. Escriba los siguientes datos en una nueva hoja de clculo:

5/6

AINTE INFORMTICA

@INTE ACADEMIA

Curso de Excel

2. 3.

Haga clic en la celda D2. Escriba la siguiente frmula y pulse Intro:

=SI(Y(B2>=5;C2="S");"Apto";"No Apto")
Aqu hay una condicin doble as que usamos el operador lgico Y, que hace que tengan que cumplirse las dos condiciones, que la nota sea mayor o igual que 5 y que, al mismo tiempo, se haya entregado el trabajo. 4. Copie la frmula hacia abajo y compruebe que efectivamente.

6/6

AINTE INFORMTICA