You are on page 1of 50

PC-A

Lab Setup-MEN Part 1

Fe 0/1 SW-D
Fe 0/9
Fe 0/1
PC-B
Fe 0/24

Ge0/1
RT-A RT--B
2/2
SW-A
2/3 1/1
Fe 0/0/24 Fe 0/0/9
1/4
2/4 SW-E
2/5
1/2
Ge 0/0/1
Fe 0/0/4 Fe 0/0/4

2/0/6
1/0/4 SW-B Fe 0/0/1
1/0/0 Fe 0/0/8
Fe 0/0/8
Fe 0/0/1
RT-E 2/0/0
1/0/0 2/0/2 1/0/2
1/0/6
RT-D RT-C
Fe 0/0/1 Fe 0/0/8 Fe 0/0/1
Fe 0/0/8
Ge 0/0/1

Fe 0/0/4 Fe 0/0/4
SW-F
SW-C
Fe 0/0/9

PC-C

CX600- RT-C, RT-D, RT-E
C7609-RT-A, RT-B
CX200 – SW-B, SW-C, SW-E, SW-F,
Cisco3400 – SW-A, SW-D
Huawei 

 

<         >reset  saved‐config 

<         >reboot 

 

Cisco 

 

# delete nvram:startup‐config 

#reload 
Basic configuration commands - huawei

Operation Command
Enter the system view from the user view system-view
# Turn back to the user view from the system
quit
view.
Return to the user view from any other view return
Set the router name sysname sysname
Display the system version display version [ slot-id ]
Display the initial configuration information display saved-configuration
Display the current configuration information display current-configuration
Showing the basic information of device display device [ pic-status | slot-id ]

Telnet Configuration

PC---------3400/CX200D

100.0.0.x /27
PC Switch
Vlan 100

CX200D- SW-B, SW-C
Group1- SW-A
C3400-SW-A
Group2- SW-B
Group3- SW-C
Cisco

Switch(config)vlan 100

Switch(config)interface FastEthernet0/9
Switch(config-if)port-type nni
Switch(config-if)switchport access vlan 100
Switch(config-if)no shutdown
!
Switch(config)interface Vlan100
Switch(config-if)ip address 100.0.0.2 255.255.255.224

Switch(config)line vty 0 4
Switch(config-line)password 0 cisco
Switch(config-line)no login

Switch(config)enable secret cisco

After configured the ip address of the interface, configure the ip address of the
PC(suggest ip address of the PC is 100.0.0.5/27).

Note:- PC has two LAN cards. One will have IP of intranet (10.x.x.x) which is used for
your remote access. Don’t change this IP.

Use the second LAN card, which is connected to LAB setup.

Huawei

[Quidway]vlan 100

[Quidway]interface Ethernet0/0/9
[Quidway]port link-type access
[Quidway]port default vlan 100
[Quidway]undo shutdown
!
[Quidway]interface Vlanif 100
[Quidway]ip address 100.0.0.2 255.255.255.224

Configure a password for login in the Telnet mode
[Quidway] user-interface vty 0 4
[Quidway-ui-vty0-4] authentication-mode password
[Quidway-ui-vty0-4] set authentication password simple Huawei
[Quidway-ui-vty0-4] user privilege level 3
To give multiple telnet password

[Quidway] user-interface vty 0 4
[Quidway-ui-vty0-4] authentication-mode none
[Quidway-ui-vty0-4]
Super xxxxxx level 3
Super xxxxxx level 2
Management VLAN Configuration

Complete Scenario

RT-B RT-A RT-C

SW-B SW-C

SW-A

PC-B PC-C

PC-A

CX600- RT-C
Group1- PC-A, SW-A, RT-A
C7609-RT-A, RT-B
Group2- PC-B, SW-B, RT-B
CX200 – SW-B, SW-C
Group3- PC-C, SW-C, RT-C
Cisco3400 – SW-A
Group 1 - PC-A---------3400(SW-A)------7609(RT-A)

10.0.0.x /27
Vlan 127 10.0.0.x /27
PC-A SW-A RT-A
Vlan 127

192.168.1.x /30 192.168.2.x /30

RT-B RT-C

Switch-3400

Switch(config)#hostname SW-A

SW-A(config)#vlan 127

SW-A(config)#interface FastEthernet0/1
SW-A(config-if)#port-type nni
SW-A(config-if)#switchport access vlan 127
SW-A(config-if)#no shutdown

SW-A(config)#interface GigabitEthernet0/1
SW-A(config-if)#port-type nni
SW-A(config-if)#switchport mode trunk
SW-A(config-if)#switchport trunk allowed vlan all

SW-A(config)#interface Vlan127
SW-A(config-if)#ip address 10.0.0.2 255.255.255.224
SW-A(config-if)#no shutdown

SW-A(config)#ip default-gateway 10.0.0.1

Switch(config)line vty 0 4
Switch(config-line)password 0 cisco
Switch(config-line)no login

Switch(config)enable secret cisco

After configured the ip address of the interface, configure the ip address of the
PC(suggest ip address of the PC is 10.0.0.5/27)

Router – 7609

Configure L2 domain

Router(config)#hostname RT-A

RT-A(config)#vlan 127

RT-A(config)#interface GigabitEthernet1/1
RT-A(config-if)#switchport
RT-A(config-if)#switchport trunk encapsulation dot1q
RT-A(config-if)#switchport mode trunk
RT-A(config-if)#no shutdown

RT-A(config)#interface Vlan127
RT-A(config-if)#ip address 10.0.0.1 255.255.255.224
RT-A(config-if)#no shutdown
Configure Telnet

RT-A(config)#line vty 0 4
RT-A(config-line)#password 0 cisco
RT-A(config-line)#no login

RT-A(config)#enable secret cisco

Configure L3 Domain

RT-A(config)# interface GigabitEthernet1/2
RT-A(config-if)#ip address 192.168.1.1 255.255.255.252
RT-A(config-if)#no shutdown
RT-A(config)# interface GigabitEthernet1/6
RT-A(config-if)#ip address 192.168.2.1 255.255.255.252
RT-A(config-if)#no shutdown

On the Router, configure static routes for a non-directly connected network segment.
On RT-A, configure two static routes:

ip route 20.0.0.0 255.255.255.224 192.168.1.2
ip route 30.0.0.0 255.255.255.224 192.168.2.2
Group 2 ‐   PC‐B‐‐‐‐‐cx200(SW‐B)‐‐‐‐7609(RT‐B) 
 

20.0.0.x /27
Vlan 127 20.0.0.x /27
PC-B SW-B RT-B
Vlan 127

192.168.1.x /30

RT-A

Operation Command
Creating VLAN vlan vlan-id [ alias vlan-alias ]
Delete a VLAN undo vlan vlan-id [ |all]
In the VLAN view, configure a port or a group of port interface-type { interface-num [ to
ports to belong to a VLAN interface-num ] } & <1-10>
In the interface view, configure the port to belong
port access vlan vlan-id
to a VLAN
 
 
Operation Command
Specify the port type: trunk, access, hybrid port link-type { trunk/access/hybrid}
Cancel the port type setting undo port link-type { trunk/access/hybrid}
Setting VLAN allowed to pass Trunk port [undo] port trunk permit vlan { {vlan-id [ to vlan-id ]}&<1-10> | all }
Display the information about a VLAN display vlan vlan-id [/all]
 
 
Switch- Cx200
 
<Quidway>system-view
[Quidway]sysname SW-B

[SW-B]vlan 127
[SW -B-vlan127]port Ethernet 0/0/1

[SW-B-Ethernet0/0/1] port link-type access
[SW-B-Ethernet0/0/1]undo shutdown
[SW-B]interface GigabitEthernet 0/0/1
[SW-B-GigabitEthernet0/0/1]port link-type trunk
[SW-B-GigabitEthernet0/0/1]port trunk allow-pass vlan all
[SW-B-GigabitEthernet0/0/1]negotiation auto

[SW-B]interface Vlanif 127
[SW-B-Vlan127]ip address 20.0.0.2 255.255.255.224

[SW-B]ip route-static 0.0.0.0 0 20.0.0.1

[SW-B] user-interface vty 0 4
[SW-B-ui-vty0-4] authentication-mode password
[SW-B-ui-vty0-4] set authentication password simple huawei
[SW-B-ui-vty0-4] user privilege level 3

After configured the ip address of the interface, configure the ip address of the
PC(suggest ip address of the PC is 20.0.0.5/27)

Router – 7609

Configure L2 domain

Router(config)#hostname RT-B

RT-B(config)#vlan 127

RT-B(config)#interface GigabitEthernet5/1
RT-B(config-if)#switchport
RT-B(config-if)#switchport trunk encapsulation dot1q
RT-B(config-if)#switchport mode trunk
RT-B(config-if)#no shutdown

RT-B(config)#interface Vlan127
RT-B(config-if)#ip address 20.0.0.1 255.255.255.224
RT-B(config-if)#no shutdown
Configure Telnet

RT-B(config)line vty 0 4
RT-B(config-line)password 0 cisco
RT-B(config-line)login

RT-A(config)enable secret cisco

Configure L3 Domain

RT-B(config)# interface GigabitEthernet 5/2
RT-B(config-if)#ip address 192.168.1.2 255.255.255.252
RT-B(config-if)#no shutdown

On the Router, configure static routes for a non-directly connected network segment.

On RT-B, configure two static routes:
ip route 10.0.0.0 255.255.255.224 192.168.1.1
ip route 30.0.0.0 255.255.255.224 192.168.1.1
ip route 192.168.2.0 255.255.255.252 192.168.1.1
Group C‐  PC‐C‐‐‐‐cx200(SW‐C)‐‐‐‐‐cx600(RT‐C) 

30.0.0.x /27
Vlan 127 30.0.0.x /27
PC-C SW-C RT-C
Vlan 127

192.168.2.x /30

RT-A

Switch – Cx200

[Quidway]sysname SW-C

[SW-C]vlan 127

[SW-C-Ethernet0/0/1] port link-type access
[SW-C-Ethernet0/0/1]port default vlan 127
[SW-C-Ethernet0/0/1]undo shutdown

[SW-C]interface GigabitEthernet 0/0/1
[SW-C-GigabitEthernet0/0/1]port link-type trunk
[SW-C-GigabitEthernet0/0/1]port trunk allow-pass vlan all

[SW-C]interface Vlanif 127
[SW-C-Vlan127]ip address 30.0.0.2 255.255.255.224

[SW-C]ip route-static 0.0.0.0 0 30.0.0.1

[SW-C] user-interface vty 0 4
[SW-C-ui-vty0-4] authentication-mode none
[SW-C-ui-vty0-4] user privilege level 3
After configured the ip address of the interface,configure the ip address of the
PC(suggest ip address of the PC is 30.0.0.5/27)

 
 
Router-CX600
 
Configure L2 domain
 
[Quidway]sysname RT-C

[RT-C]vlan 127

[RT-C]interface GigabitEthernet 1/0/0
[RT-C-GigabitEthernet1/0/0]portswitch
[RT-C-GigabitEthernet1/0/0]port link-type trunk
[RT-C-GigabitEthernet1/0/0]port trunk allow-pass vlan all

[RT-C]interface Vlanif 127
[RT-C-Vlan127]ip address 30.0.0.1 255.255.255.224

Configure Telnet

[RT-C] user-interface vty 0 4
[RT-C-ui-vty0-4] authentication-mode password
[RT-C-ui-vty0-4] set authentication password simple huawei
[RT-C-ui-vty0-4] user privilege level 3

Configure L3 Domain
 
[RT-C]interface GigabitEthernet 1/0/2
[RT-C-GigabitEthernet1/0/2] ip address 192.168.2.2 30
[RT-C-GigabitEthernet1/0/2]undo shutdown
[RT-C-GigabitEthernet1/0/2]negotiation auto
 
On the Router, configure static routes for a non-directly connected network segment.

On RT-C, configure two static routes:
ip route-static 10.0.0.0 255.255.255.224 192.168.2.1
ip route-static 20.0.0.0 255.255.255.224 192.168.2.1
ip route-static 192.168.1.0 30 192.168.2.1
PC‐C‐‐‐‐CE‐SW‐C (CX200)‐‐‐‐‐‐SP‐SW‐B(CX200)‐‐‐‐‐‐SP‐SW‐D(ME3400)‐‐‐‐‐CE‐SW‐A(ME3400)‐‐‐‐‐PC‐A 

       0/0/9                  0/0/1      0/0/1  0/0/24     0/24    0/1          0/1               0/9 

         Vl 50        vl 25          vl 50 

PC‐C 
CE‐SW‐C Vlan 50 
0/9 0/1

0/1
SP‐SW‐B Vlan 25 
0/24

0/24
SP‐SW‐D Vlan 25 
0/1

PC‐A  0/1
Vlan 50 
CE‐SW‐A
0/9

CX200 – SW‐B, SW‐C 
Group1‐ PC‐A, SW‐A 
Cisco3400 – SW‐A, SW‐D 
Group2‐ SW‐B, SW‐D 
 
Group3‐ PC‐C, SW‐C 
 
CE-SW-C(CX200)

Vlan 50

Interface ethernet0/0/1
Port link-type access
Port default vl 50

Interface ethernet0/0/9
Port link-type access
Port default vl 50

SP-SW-B(CX200)

Vl 25

Interface ethernet0/0/1
Port link-type dot1q-tunnel
Port default vl 25

Interface ethernet0/0/24
Port link-type trunk
Port trunk allow-pass vlan all

SP-SW-D(ME3400)

System mtu routing 1600

Vlan dot1q tag native

Vl 25
Interface fastethernet 0/1
Switchport mode dot1q-tunnel
Switchport access vlan 25

Interface fastethernet 0/24
Switchport mode trunk
Port-type nni

CE-SW-A(ME3400)

Vlan 50

Interface ethernet0/1
Switchport mode access
Switchport access vlan 50

Interface ethernet0/9
Switchport mode access
Switchport access vlan 50
MSTP

All Huawei Switches are used for this Lab

All FastEtherent Ports are used for this lab

Allow-pass vlan all SWE
SWB
4
4

8
1 8 1
Allow-pass Allow-pass
vlan 200,300 vlan 100,200
Allow-pass Allow-pass
vlan 100,200 vlan 200,300

1 8 8 1

SWC 4 4 SWF
Allow-pass
vlan 200,400

CX200 – SW-B, SW-C, SW-E, SW-F
Group1- SW-B
Group2- SW-C
Group3- SW-E, SW-F
Huawei Switch Configuration

Vlan 100
Vlan 200
Vlan 300
Vlan 400

interface Ethernet 0/0/1
port link-type trunk
Port trunk allow-pass vlan 100,200
bpdu enable

interface Ethernet 0/0/8
port link-type trunk
Port trunk allow-pass vlan 200,300
bpdu enable
interface Ethernet 0/0/4
port link-type trunk
Port trunk allow-pass vlan all
bpdu enable

stp enable

[SWB]stp region-configuration
[SWB-mst-region]region-name reliance
[SWB-mst-region]revision-level 1
[SWB-mst-region]instance 1 vlan 100
[SWB-mst-region]instance 2 vlan 200
[SWB-mst-region]instance 3 vlan 300
[SWB-mst-region]instance 4 vlan 400

[SWB-mst-region]active region-configuration

Result Verification: display stp brief
Display stp instance 1
Additional info: Cisco Switch Configuration

Vlan 100
Vlan 200
Vlan 300
Vlan 400

SW-A
Interface fastethernet 0/1
Switchport trunk encapsulation dot1q (only for 3550)
Switchport mode trunk
Switchport trunk allowed vlan 100
Switchport trunk allowed vlan add 200
Port-type nni (only for 3400)

Interface fastethernet 0/8
Switchport mode trunk
Switchport trunk allowed vlan 200,300
Port-type nni

Interface fastethernet 0/4
Switchport mode trunk
Switchport trunk allowed vlan all
Port-type nni

spanning-tree mode mst

spanning-tree mst configuration
name reliance
revision 1
instance 1 vlan 100
instance 2 vlan 200
instance 3 vlan 300
instance 4 vlan 400

Result Verification: Show spanning-tree
Soln

MST1 – vl 100 topology

SWB SWE
24/Alt
24/DP

1/RT 9/RT

1/DP
9/DP

SWC/Root

MST2 – vl 200 topology

24/Alt 24/DP

9/Alt
1/RT 9/RT 1/DP

1/DP 9/DP 9/DP 1/Alt

SWD/Root 24/DP 24/RT SWC
MST3 – vl 300 topology
SWE/Root
24/RT 24/DP

9/Alt 1/DP

1/RT

9/DP

MST4 – vl 400 topology

SWE/Root
24/RT
24/DP

SWC/Root 24/DP 24/RT
OSPF 
 

  RTA(7609)

.5
                                                                                  
.2
 
.1 .6
.2  .1  .1 .2
.10 .9
                                                                                         

  RTE(CX)  RTD(CX) RTC(CX) RTB(7609)

 
Area1  Area0  Area2 
  10.0.1.0/30  10.0.0.0/30  10.0.2.0/30 

 

 

CX600‐ RT‐C, RT‐D, RT‐E  Group1‐ RT‐E 
C7609‐RT‐A, RT‐B  Group2‐ RT‐D, RT‐A 
  Group3‐ RT‐C, RT‐B 
 

 

 

 

 

 

 

 

 
 

1. Clear Previous Config
2. Config loopback0 IP= 10.0.255.ID
3. Config IP address
4. Enable OSPF on every interface
5. After finishing check LSDB
6. Test Pinging from Loopback0 of one router to other

Summary Routes

Summarize routes of area2

7. On RTB(area2) create 3 loopbacks as below
a. Loopback1 20.0.0.1/32
b. Loopback2 20.0.0.2/32
c. Loopback3 20.0.0.3/32

8. Enable ospf on all loopbacks or In ospf redistribute/import directly connected
routes
9. Check ip routes on RTD (separate route for each loopback is present)
10. In RTC (area2) summarise all loopback ips to 20.0.0.0/24
11. Again check ip routes on RTD(only on summary route)

Stub Area

Configure area1 as stub

12. Create interface Vlan on RTB Optional steps
a. Vlan 10 30.0.1.10/24
b. Vlan 20 30.0.2.20/24
13. Create static route on RTC to reach above vlan 10&20 on RTB
14. Import static route in ospf in RTC (imported routes will be external routes)

Note- Step 12 – 14 is not required if there is external routes already present

15. Check LSDB and routing table on RTE (you will see external routes)
16. On RTD and RTE configure area1 as stub
17. Again check LSDB and routing table on RTE (you will not see any external routes,
but a default route)
Totally Stubby

Configure area1 as totally stub

18. Configure RTD as stub no-summary
19. Check LSDB and routing table on RTE

NSSA

Configure area2 as totally stub

20. Configure RTC and RTB as nssa for area 2
21. Check routing table on RTC and RTB
22. Ping from area1 to area 2
Cisco 7609

Hostname RT-A

Interface gigethernet 1/1
No shutdown
Ip address 10.0.0.2 255.255.255.252

Interface loopback 0
Ip address 10.0.255.21 255.255.255.255

Interface loopback 1
Ip address 10.0.254.21 255.255.255.255

router ospf 100
network 10.0.0.0 0.0.0.255 area 0
network 10.0.255.21 0.0.0.0 area 0
area 1 stub
redistribute connected

ip route X.X.X.X X.X.X.X X.X.X.X
Cx600

Sysname RT-C

Interface gigetherent 2/0/2
Undo shutdown
Negotiation auto
Ip address 10.0.0.6 30

Interface loopback 0
Ip address 10.0.255.31 32

Interface loopback 1
Ip address 10.0.254.31 32

[RTC]ospf 100

[RTC-ospf-100]area 0
[RTC-ospf-100-area-0.0.0.0]network 10.0.0.0 0.0.0.255
[RTC-ospf-100-area-0.0.0.0]network 10.0.255.31 0.0.0.0

[RTC-ospf-100]area 2
[RTC-ospf-100-area-0.0.0.2]network 10.0.2.0 0.0.0.255

[RTC-ospf-100-area-0.0.0.2]stub
[RTC-ospf-100]import-route static
[RTC-ospf-100]import-route direct

[RTC]ip route-static X.X.X.X X.X.X.X X.X.X.X

[RTC-ospf-100-area-0.0.0.2]abr-summary 20.0.0.0 255.255.255.0 advertise
Bypass Switch Password (Cisco)
 

3400

1. Connect a PC with terminal‐emulation software to the switch console port. 
 

2. Power off the switch  
Reconnect the power cord to the switch 

 

Or  

 

Reload 

 

3. After the switch performs POST, the switch begins the autoboot process. The boot loader prompts 
the user for a break key character during the boot‐up sequence, as shown in this example:  
***** The system will autoboot in 5 seconds *****  

Send a break key to prevent autobooting.  

 

Ctrl‐Break is the break key. 

 

4. Initialize the flash file system:  
switch: flash_init

5. Load any helper files:  
switch: load_helper

6. Display the contents of flash memory:  
switch: dir flash:

The switch file system appears:  

Directory of flash:
13 drwx 192 Mar 01 1993 22:30:48 me340x-
metroipaccess-mz.122-25.EX
11 -rwx 5825 Mar 01 1993 22:31:59 config.text
18 -rwx 720 Mar 01 1993 02:21:30 vlan.dat
16128000 bytes total (10003456 bytes free)

7. Rename the configuration file to config.text.old.  
This file contains the password definition.  

switch: rename flash:config.text flash:config.text.old

8. Boot the system:  
switch: boot

You are prompted to start the setup program. Enter N at the prompt:  

Continue with the configuration dialog? [yes/no]: N

9. At the switch prompt, enter privileged EXEC mode:  
Switch> enable

10.  Rename the configuration file to its original name:  
Switch# rename flash:config.text.old flash:config.text
 

11. Copy the configuration file into memory:  
Switch# copy flash:config.text system:running-config
Source filename [config.text]?
Destination filename [running-config]?

Press Return in response to the confirmation prompts.  

The configuration file is now reloaded, and you can change the password.  

 

12. Enter global configuration mode:  
Switch# configure terminal

13. Change the password:  
Switch (config)# enable secret cisco123

14. Write the running configuration to the startup configuration file:  
Switch# copy running-config startup-config
 

The new password is now in the startup configuration.

 
15. After recovering the password, reload the switch:  
Switch> reload s
Proceed with reload? [confirm] y
 

16. Change the password back to cisco 
 

17. Write the running config to the file 
Switch# write memory 

 

3550

In this exercise we need to power OFF & ON the switches in step no. 2 & 3, there is only one switch for 
all switches, therefore all teams should perform these steps simultaneously. 

 

1. Attach a PC with terminal emulation to the console port of the switch. 
2. Switch OFF the power supply or Reload 
 

3. Hold down the mode button of the switch. This button is located on the left side of the front panel. 
While holding the button switch on the power supply 
 

4. Continue  holding  the  mode  button  and  observe  hyper  terminal  on  the  PC.  Once  you  get  switch 
prompt release the button 
Switch: 

 

5. Switch: load_helper  
6. Switch: flash_init 
7. Switch: dir flash: 
8. Switch: rename flash:config.text config.team1 (or flash:config.text flash:config.team1) 
9. switch: boot 
 

10. Enter ‘n’ for initial config dialog 
Enter ‘y’ for terminate auto install 

 

11. After booting is complete. You will get  
Switch> 
 

12. Switch> en 
13. Switch# 
 

14. Copy the config file from flash to memory 
Switch# copy flash:config.team1 running‐config 

Press enter for any prompt 

 

15. Change the password 
Switch# config t 

Switch# enable secret cisco123  

Switch# ^z 

 

16. Write the running config to the file 
Switch# write memory 

 

17. Exit and login with password cisco123 
18. Change the password back to cisco 
 

19. Write the running config to the file 
Switch# write memory 

 

 

 

 

 

 

 

 
CX200D

How to Recover the password?

How to Recover Bootrom passwords?
To clear and recover the Console passwords of CX200D, take these steps: 

 1. Connect the laptop to console

2. Clear the console interface password from backup configuration file.

3.Then save the modified configuration file on laptop as config.cfg.

Open the configuration file using WordPad or Notepad. Modify the configuration and save.

5. Power off CX200D

6. At least after 1 minute, power on CX200D

7. Type CTRL+B to enter BOOTROOM menu before timer expires as follows.

****************************************************

* *

* Basic BOOTROM, Ver 204 *

* *

****************************************************

Copyright 2000-2008 Huawei Tech. Co., Ltd.

Creation date: May 28 2008, 19:26:14

CPU L1 Cache : 32KB

CPU Clock Speed : 266MHz

BUS Clock Speed : 133MHz

Memory Size : 128 MB
Press Ctrl+B to enter Main Menu... 2

Password:

BOOTROM MENU

1. Boot with default mode

2. Enter serial submenu

3. Enter startup submenu

4. Display flash files

5. Modify BOOTROM password

6. Reboot

6. select option 2 to enter serial submenu.

Enter your choice(1-6): 2

SERIAL SUBMENU

1. Update BOOTROM small system

2. Download file to Flash through serial interface

3. Modify serial interface parameter

4. Return to main menu

7. select option 2 to download the Modified configuration file to Flash
Enter your choice(1-4): 2

Please Select File .

XMODEM downloading ...CC

Operation on laptop:

In  Hyperterminal‐Æ Transfer Æ Send fileÆ select protocol xmodemÆ browse the config file from the 
machineÆ Click on send 

download to SDRAM successfully!

 Press Enter to save it with default filename: cx200.cc

Otherwise,please input a new filename: config.cfg---------input the name(same as
the source file)

flash:/config.cfg already exist,

delete it?(Y/N):y---------overwrite the old one

Deleting file..done

Took time : 3s

Writing Flash.done

File length: 1152 bytes

Took time : 4s
SERIAL SUBMENU

1. Update BOOTROM small system

2. Download file to Flash through serial interface

3. Modify serial interface parameter

4. Return to main menu

8. select option 4 to go back to main menu.

Enter your choice(1-4): 4 -------------- Return to main menu

BOOTROM MENU

1. Boot with default mode

2. Enter serial submenu

3. Enter startup submenu

4. Display flash files

5. Modify BOOTROM password

6. Reboot

9. Enter startup submenu

Enter your choice(1-6): 3
Startup Configuration Submenu

1. Display startup configuration

2. Modify startup configuration

3. Return to main menu

8. Modify startup configuration

Enter your choice(1-3): 2

Note: startup file field can not be cleard

'.'=clear field; '^D'=quit; Enter=use current configuration

startup type(1: Flash 2: Server)
current: 1
new : ---------------------------- Enter

Flash startup file (can not be cleared)
current: cxv200r001c02b032.cc
new : ---------------------------- Enter

saved-configuration file
current: config.cfg
new : config.cfg---------------------------- Enter for same name or type

appropriate file name

license file
current:
new : ---------------------------- Enter
patch package
current:
new : ---------------------------- Enter

Startup Configuration Submenu

1. Display startup configuration

2. Modify startup configuration

3. Return to main menu

9. Return to main menu

Enter your choice(1-3): 3

BOOTROM MENU

1. Boot with default mode

2. Enter serial submenu

3. Enter startup submenu

4. Display flash files

5. Modify BOOTROM password

6. Reboot

9. Reboot

Enter your choice(1-6): 6
CX600

How to Recover Bootrom passwords?
To clear and recover the passwords of CX‐ 600, take these steps: 

1. Connect the laptop and master SRU of CX600 with console and Ethernet
interfaces

2. Power off CX600

3. At least after 1 minute, power on CX600

4. Type CTRL+B to enter BOOTROOM menu as follows:

****************************************************

* *

* 8090 boot ROM, Ver 216.00 *

* *

****************************************************

Copyright 2000-2008 Huawei Tech. Co., Ltd.

Creation date: Aug 1 2008, 09:31:03

CPU type : MPC7447A

CPU L2 Cache : 512KB

CPU Core Frequency : 1GHz

BUS Frequency : 133MHz

Press Ctrl+B to enter Main Menu... 2

Password:8090
5. Type CTRL+Z to enter hidden BOOTROOM menu as follows:

Main Menu (bootload ver: 216.00)

1. Boot with default mode

2. Boot from CFcard

3. Enter serial submenu

4. Enter ethernet submenu

5. Set boot file and path

6. Modify boot ROM password

7. List file in CFcard

8. Chkdsk CFcard

9. Set patch mode

10. Set version back signal

11. Reboot

Enter your choice(1-11): ----------------------------CTRL+Z

Hidden Menu

1. Enter to debug environment

2. Erase flash

3. Delete file from CFcard

4. Rename file in CFcard

5. Disable config password
6. Format CFcard

7. Disable Config Password From Slave MPU

8. Return to main menu

6. select option 4 to rename the startup configuration file as follows:

Hidden Menu

1. Enter to debug environment

2. Erase flash

3. Delete file from CFcard

4. Rename file in CFcard

5. Disable config password

6. Format CFcard

7. Disable Config Password From Slave MPU

8. Return to main menu

Enter your choice(1-8): 4

Change File(s) In CFcard List Submenu

1. Change File(s) name In CFcard

2. Change File(s) name In CFcard2

3. Return to Up menu

Enter your choice(1-3): 1
Please input the file name you want to rename, e.g.: test.txt

('*' for display all files in cfcard.)

cx600_3.cfg----------------------------input the source file name

12560 Oct 13 10:52 cx600_3.cfg

Please input new name: cx600_3_new.cfg----input the new name

File "cx600_3.cfg" will be renamed to "cx600_3_new.cfg" !

Are you sure? Yes or No(Y/N)y---------confirm

Rename successfully!

7. Repeat above steps for CFcard2

Change File(s) In CFcard List Submenu

1. Change File(s) name In CFcard

2. Change File(s) name In CFcard2

3. Return to Up menu

Enter your choice(1-3): 2
8. Return to Hidden Menu

Change File(s) In CFcard List Submenu

1. Change File(s) name In CFcard

2. Change File(s) name In CFcard2

3. Return to Up menu

Enter your choice(1-3): 3--------return to hidden Menu

Hidden Menu

1. Enter to debug environment

2. Erase flash

3. Delete file from CFcard

4. Rename file in CFcard

5. Disable config password

6. Format CFcard

7. Disable Config Password From Slave MPU

8. Return to main menu

Enter your choice(1-8): 8---------------return to Main Menu
Main Menu(bootload ver: 216.00)

1. Boot with default mode

2. Boot from CFcard

3. Enter serial submenu

4. Enter ethernet submenu

5. Set boot file and path

6. Modify boot ROM password

7. List file in CFcard

8. Chkdsk CFcard

9. Set patch mode

10. Set version back signal

11. Reboot

Enter your choice(1-11):2------------startup CX600

line Con 1 is available.----------------CX600 will boot with empty configuration

Recover configuration...OK!

Press ENTER to get started.

<Quidway>

<Quidway>

9. Configure the ip address(the same network with laptop) of
GigabitEthernet 0/0/0 interface
#

interface GigabitEthernet0/0/0

ip address 192.168.50.1 255.255.255.0

#

return

10. Run ftp server on laptop and upload the configuration file from CX600
to laptop

(Use WinFTPServer…. Make the server online before giving command
(server -> Go online))

<CX600-1>ftp 192.168.50.2

Trying 192.168.50.2 ...

Press CTRL+K to abort

Connected to 192.168.50.2.

220 3Com 3CDaemon FTP Server Version 2.0

User(192.168.50.2:(none)):aa

331 User name ok, need password

Enter password:---------------------------------- Enter

230 User logged in

[ftp]put cx600-1.cfg

200 PORT command successful.

150 File status OK ; about to open data connection

226 Closing data connection; File transfer successful.
FTP: 23281 byte(s) sent in 0.202 second(s) 115.25Kbyte(s)/sec.

[ftp]

11. Remove the password of console interface then save on laptop

user-interface con 0

authentication-mode password-----------------------remove

set authentication password cipher _C5V#J6:D ---remove

12. Download the configuration to CX600

<CX600-1>ftp 192.168.50.2

Trying 192.168.50.2 ...

Press CTRL+K to abort

Connected to 192.168.50.2.

220 3Com 3CDaemon FTP Server Version 2.0

User(192.168.50.2:(none)):a

331 User name ok, need password

Enter password:

230 User logged in

[ftp]get cx600-1.cfg

Warning: The file cx600-1.cfg already exists. Overwrite it? [Y/N]:y

Warning: The file cfcard:/cx600-1.cfg is a system resource file that is in use.
Overwrite it? [Y/N]:y

200 PORT command successful.

150 File status OK ; about to open data connection

226 Closing data connection; File transfer successful.

FTP: 23281 byte(s) received in 0.174 second(s) 133.79Kbyte(s)/sec.

[ftp]quit

13. Copy the new configuration file to slave#cfcard:/

<CX600-1>copy cx600-1.cfg slave#cfcard:/

Warning: File cfcard:/cx600-1.cfg will be copied to slave#cfcard:/cx600-1.cfg. C

ontinue? [Y/N]:y

Warning: File slave#cfcard:/cx600-1.cfg already exists. This operation will over

write it. Continue? [Y/N]:y

Warning: The file slave#cfcard:/cx600-1.cfg is a system resource file that is in

use, overwrite it?[Y/N]:y

100% completed.

14. Set next startup configuration and reboot CX600

<CX600-1>startup saved-configuration cx600-1.cfg

Info: Succeeded in setting the configuration for booting system.
<CX600-1>display startup

MainBoard:

Configed startup system software: cfcard:/v200r002c02b363.cc

Startup system software: cfcard:/v200r002c02b363.cc

Next startup system software: cfcard:/v200r002c02b363.cc

Startup saved-configuration file: NULL

Next startup saved-configuration file: cfcard:/cx600-1.cfg

Startup paf file: cfcard:/paf.txt

Next startup paf file: cfcard:/paf.txt

Startup license file: cfcard:/license.txt

Next startup license file: cfcard:/license.txt

Startup patch package: NULL

Next startup patch package: NULL

SlaveBoard:

Configed startup system software: cfcard:/v200r002c02b363.cc

Startup system software: cfcard:/v200r002c02b363.cc

Next startup system software: cfcard:/v200r002c02b363.cc

Startup saved-configuration file: NULL

Next startup saved-configuration file: cfcard:/cx600-1.cfg

Startup paf file: cfcard:/paf.txt

Next startup paf file: cfcard:/paf.txt

Startup license file: cfcard:/license.txt

Next startup license file: cfcard:/license.txt

Startup patch package: NULL

Next startup patch package: NULL
<CX600-1>reboot

Info: The system is now comparing the configuration, please wait:

Warning: current configuration will be saved to the next startup saved-
configuration file: cfcard:/cx600-1.cfg!

Continue [Y/N] N

System will reboot ! Continue ? [Y/N] Y
Cisco MEN

Loading IOS on Switch (Cisco)

Configure Management Vlan 127 on the switch

1. Connect PC to fa port

2. configure PC

Give IP address to PC from the table

3. Check the connectivity from PC command prompt
‘# ping 20.0.0.2
‘# ping 20.0.0.3
# ping 30.0.0.2

4. Install TFTP Server on PC (if already installed, ignore the step)

Install tftppd32-3.23-setup

5. Start TFTP server on PC

6. Login to your assigned switch through console

7. #copy tftp: me340x-metroaccessk9-mz.122-40.SE.bin flash:
# : give your TFTP server IP (PC IP)
# : press Enter for default file name

Or

#copy tftp: c3550-ipbasek9-mz.122-25.SEC.bin

Note:- If your TFTP server don’t have the IOS file, copy from switch flash to your PC first and then load
back to switch

RCOM - Learning and Development For Internal Circulation Only 1