SpringideInstall - Spring IDE - Trac

http://springide.org/project/wiki/SpringideInstall

Installation
Spring IDE is a set of Eclipse plugins packaged as a features. The features are hosted on a website (aka updatesite) which is accessed by Eclipse's update manager. Some ground-level requirements before going into the update procedure: Spring IDE requires a Eclipse 3.2 or 3.3 with platform-corresponding JDT, WTP and GEF installed (optionally Mylyn and AJDT) and Java 5 or Java 6 (Java 6 users see extra note). We strongly recommend downloading the Eclipse Europa 3.3 Java EE distribution from the download page at http://eclipse.org /downloads. That download contains all dependencies and you are ready to go. Clean Install - Installation without prior installation of Spring IDE: Point the Eclipse Update Manager to http://springide.org /updatesite. Don't try to install the "Spring IDE Dependencies (only for Eclipse 3.2.x)" from the "Dependency" category on Eclipse 3.3. This feature is intended only for Eclipse 3.2 and is to keep Spring IDE backward-compatible. You will not be able to continue with the installation if you select this feature on Eclipse 3.3 Optionally install or update Mylyn and AJDT from the linked associate sites. Update Install - Installation with prior installation for Spring IDE 2.x or 1.x: Delete all plugins and features with the name org.springframework.* from the plugins and features directory of your Eclipse installation or extension location. Restart your Eclipse and point the Eclipse Update Manager to http://springide.org/updatesite. Don't try to install the "Spring IDE Dependencies (only for Eclipse 3.2.x)" from the "Dependency" category on Eclipse 3.3. This feature is intended only for Eclipse 3.2 and is to keep Spring IDE backward-compatible. You will not be able to continue with the installation if you select this feature on Eclipse 3.3 Optionally install or update Mylyn and AJDT from the linked associate sites. Spring IDE 2.0.2 and Java 6: In order to use Spring IDE within an Eclipse running on Java 6 you need to install the "Spring IDE OSGi Extension (optional)" feature. This feature ships the "org.springframework.osgi.backport.util.concurrent " bundle which exports required packages for Spring 2.5 on Java 6. That will be solved in future releases by moving the "org.springframework.osgi.backport.util.concurrent" to the

1 of 3

24/02/2009 17:41

SpringideInstall - Spring IDE - Trac

http://springide.org/project/wiki/SpringideInstall

core feature. Spring IDE 2.0.3 and Java 6: 2.0.3 does not need the optional "Spring IDE OSGi Extension (optional)" feature to work on Java 6. Just install the desired features as you are used prior to 2.0.2. We strongly recommend that you follow the steps outlined in "Update Install" above for every update of your Spring IDE installation; especially if you used a development or nightly build version, but even for final version updates.

Required Software
Eclipse Platform
Eclipse 3.1 (or newer) is required to run Spring IDE 1.3.x with it's basic features (BeansView, BeansConfigValidator, BeansSearch). For Spring IDE 2.0 at least Eclipse 3.2.x is required. For Spring IDE's BeansGraph you have to install the corresponding version of Eclipse's Graphical Editing Framework (GEF).

WST: Web Standard Tools
To use the more advanced features of Spring IDE 1.3.x (BeansXmlEditor, WebFlowEditor) the Web Standard Tools (WST) (which is part of the Eclipse Web Tools Platform Project (WTP)) are required. WST itself has strict requirements, e.g. for version 1.0.x these are as follows: Eclipse 3.1.x GEF 3.1.x EMF/SDO/XSD 2.1.x JEM 1.1.0.x Starting with Spring IDE 2.0 the requirements are as follows: Eclipse 3.2.x Web Tools 1.5.x You can download WST and all required packages manually from here or use Eclipse's update manager as described here.

AJDT: AspectJ Development Tools
AJDT is not required, but to leverage full power of the Spring IDE's AOP support make sure to install them. If AJDT is not installed certain features of the AOP support are disabled. More specificaly the reference contributions to AJDT's Cross Reference view and AJDT's Visualiser are disabled. The BeansCrossReferencesView and-therefore-Spring IDE's internal AOP weaver and reference model can operate without having AJDT installed. You can download AJDT and all required packages manually from here or use Eclipse's update manager as described here.

2 of 3

24/02/2009 17:41

SpringideInstall - Spring IDE - Trac

http://springide.org/project/wiki/SpringideInstall

Alternate Types of Installation
Installation of Spring IDE with required dependencies from the Callisto Discovery Site
If you already have Eclipse 3.2 installed then you can also use Eclipse's update manager to install Spring IDE with all required features from the Callisto Discovery Site. A detailed description is available in the wiki page SpringideCallistoInstall.

Installation of archived version of Spring IDE's update site
An archived version of the update site (springide_updatesite_x.x.x.zip) can also be downloaded from http://springide.org/updatesite/ and used locally with Eclipse's update manager. Do not unzip these archives into your Eclipse installation directory. This will destroy your Eclipse installation! There is also a developer updatesite available where you can install development versions of Spring IDE from. The procedure to install from the dev updatesite is the same as described above; expect that you have to use http://springide.org /updatesite_dev/ as URL. Previous releases of Spring IDE can be installed from the updatesites http://springide.org/updatesite_1.1.x/ (Spring IDE 1.1.0 - 1.2.0) or http://springide.org/updatesite_1.x/ (Spring IDE 1.2.0 - 1.3.6).

See also: WebStandardTools, SpringideCallistoInstall, SpringideFaq, SpringideGuide

Attachments
AboutEclipse.png (71.6 kB) - added by cdupuis on 04/06/05 00:18:23. InstallUpdate.png (45.8 kB) - added by cdupuis on 04/06/05 00:18:44. NewUpdateSite.png (46.2 kB) - added by cdupuis on 04/06/05 00:18:58.

t a g s
Installation SpringIDE

3 of 3

24/02/2009 17:41

Sign up to vote on this title
UsefulNot useful