You are on page 1of 4

Clase 12: Funciones Lógicas

pero si debes escribir los acentos y otros caracteres especiales. Procede igual con el resto de los ejemplos en la tabla superior.Clase 12: Funciones Lógicas TEMA 1: Funciones lógicas No siempre se puede solucionar un problema con una fórmula simple. Es posible que en ciertas ocasiones requieras efectuar un cálculo que está condicionado por algún factor. Pero los operadores de comparación no sólo permiten evaluar cifras o números. antes de comenzar a estudiar estas funciones debes dominar totalmente el uso de los operadores de comparación. puesto que en la celda C2 efectivamente dice Alimentación. También debes asegurarte de que la cadena ingresada en la fórmula sea exactamente igual a la que contiene la celda. La fórmula pretende comprobar si el valor de la celda A3 es mayor que el de la celda B3. Por ejemplo. La única gran diferencia es que la cadena de texto incorporada en la fórmula debe ir encerrada entre comillas. Selecciona la celda F2 y arrastra el controlador de relleno hasta la celda F7. 1. devolverá FALSO cuando el valor sea A. también se puede comprobar si una celda contiene una cadena de texto determinada. sino un valor lógico: VERDADERO o FALSO. En dicha situación. La fórmula pretende comprobar si el valor de la celda A2 es igual al de la celda B2. En dicha situación una fórmula simple no te sirve. Abre el archivo logicas. En este caso. Operadores de comparación Los operadores de comparación en Excel son los siguientes: Operador = (igual) > (mayor que) < (menor que) >= (mayor o igual que) <= (menor o igual que) <> (distinto) Significado Igual a Mayor que Menor que Mayor o igual que Menor o igual que Distinto de Ejemplo =A2=B2 =A3>B3 =A4<B4 =A5>=B5 =A6<=B6 =A7<>B7 Ejecuta esta actividad: • • • Pon el cursor en la celda E2 y digita =A2=B2. La fórmula devolverá FALSO porque los valores no son iguales. verás que la fórmula devuelve FALSO en todos los casos excepto el primero. La fórmula pretende comprobar si en la celda D2 hay un valor que no sea A. sin embargo no te entregarán una cifra como resultado. Verás que la fórmula devuelve VERDADERO en todos los casos en que el valor de la columna D no sea A. ésta devolverá VERDADERO o FALSO. No hay diferencias entre minúsculas y mayúsculas. por ejemplo. La fórmula pretende comprobar si en la celda C2 dice “alimentación”. si la celda A20 contiene la palabra Inés y para comprobarlo tú escribes la fórmula =A20=”Ines ”. la fórmula devolverá FALSO. porque el valor de la celda A3 es menor que el de B3. Cada vez que ingreses una fórmula. un nombre. Pon el cursor en la celda E3 y digita =A3>B3. como haber logrado cierta meta (sobrepasar por ejemplo 1500 productos vendidos) y a los otros deseas aplicarle un criterio diferente. se utilizan las funciones lógicas que son las apropiadas para evaluar datos y efectuar una correcta toma de decisiones. porque tendrías que hacer tantas fórmulas como casos tengas que analizar.xls que se encuentra en la página web. según corresponda. la fórmula devolverá FALSO porque no incluiste el acento que tiene Inés en la celda. Pon el cursor en la celda G2 y digita la fórmula =D2<>”A”. Estos operadores te permitirán construir fórmulas tal como los operadores de cálculo tradicionales. Selecciona la celda G2 y arrastra el controlador de relleno hasta la celda G7. Ejecuta esta actividad: • • Pon el cursor en la celda F2 y digita la fórmula =C2=”Alimentación”. Página 2 de 4 . Por ejemplo. No obstante. pudiera ser que deseas otorgar una comisión a los empleados que cumplen cierta condición.

Se requiere mostrar el mensaje “Presupuesto en orden” si el gasto previsto es mayor que el gasto real.”EL NUMERO ES MAYOR”. Permite evaluar una condición y tomar decisiones basadas en dicha evaluación. De lo contrario. Función lógica SI Es quizá una de las funciones más poderosas de Excel. La fórmula debe ser válida para todos los casos. EJEMPLOS DE USO DE LA FUNCION SI Ahora usarás la función SI para encontrar solución a algunos problemas. Los otros debes solucionarlos por tu cuenta. La función debe digitarse en la fila 2 de una columna vacía a la derecha de la primera tabla de datos y luego se debe copiar a las celdas restantes. Valor_si_verdadero: Valor_si_falso: Ejecuta esta actividad: (Te recomendamos no usar el asistente de funciones con esta función) • • • • En la celda A20 digita 350. porque el número en la celda A20 es mayor que 300. en caso contrario en la celda debe aparecer el mensaje “Asignar más recursos”. de lo contrario en la celda debe aparecer el mensaje “Presupuesto en orden”."Presupuesto en orden". entonces podría mostrar el mensaje “EL NUMERO ES MENOR”.””EL NUMERO ES MENOR”) La función devolverá o ejecutará la acción que tú programaste en el argumento Valor_si_verdadero. Te proporcionaremos la fórmula en algunos casos. Por ejemplo."Presupuesto en orden") =SI(A2>B2. si el valor de la celda A20 es mayor que 300. la expresión se evalúa como VERDADERO. A20>300 es una expresión lógica."Asignar más recursos") Página 3 de 4 . En el fondo. a través de esta función se puede interrogar a Excel sobre un elemento existente en la planilla y. es el valor que la función devolverá si el argumento prueba_lógica resulta ser VERDADERO.VALOR_SI_VERDADERO. es el valor que la función devolverá si el argumento prueba_lógica resulta ser FALSO. Se requiere mostrar el mensaje “Presupuesto excedido” si el gasto previsto es menor que el gasto real. si el valor de la celda A20 efectivamente es mayor que 300. decidir qué se hará si la respuesta es VERDADERO y que se hará si la respuesta es FALSO. entonces podría mostrar el mensaje “EL NUMERO ES MAYOR”. debe proporcionar solución para todas las filas consideradas en la tabla. es decir.Clase 12: Funciones Lógicas 2. te darás cuenta de que cambia el mensaje. de acuerdo con la respuesta que Excel dé a esa pregunta. la expresión se evaluará como FALSO. La sintaxis de la función es la siguiente: =SI(PRUEBA_LOGICA. En la celda B20 ingresa la fórmula siguiente: =SI(A20>300."Presupuesto excedido". Si cambias el número en la celda A20 por uno menor. si el valor de la celda A20 no fuera mayor que 300.VALOR_SI_FALSO) Argumentos de la función: Prueba_ lógica: es cualquier valor o expresión que pueda evaluarse como VERDADERO o FALSO. Por ejemplo. Por ejemplo. =SI(A2<B2.

de lo contrario el gasto previsto debe quedar igual. de acuerdo con las siguientes directrices: • • El gasto previsto debe quedar igual si es mayor que el gasto real Si el gasto previsto es menor que el real se le debe agregar la diferencia entre gasto real y gasto previsto.Clase 12: Funciones Lógicas Soluciona lo siguiente: En una columna vacía se requiere recalcular el gasto previsto. Se debe calcular el gasto previsto con un 30% de descuento si el código del gasto es A.A2+B2-A2) Si el gasto corresponde al rubro Educación. en caso contrario la celda debe quedar en blanco. de lo contrario. =SI(A2>B2. se debe mostrar el mensaje “SIN REAJUSTE”. =(800+A3) =(A6*20%) =() Página 4 de 4 .A2. se le deben sumar 800 al gasto previsto. Si el gasto no corresponde al rubro Entretención se debe incrementar el gasto previsto en un 20%.