You are on page 1of 3

Clase 13: Funciones lógicas y anidación

O Devuelve VERDADERO si alguno de los argumentos es verdadero.D2="A"). se debe mostrar =SI(Y(A2<B2. Acepta hasta 30 argumentos.A2+500.. Si el rubro del gasto es Educación o el código del gasto es A.. Recuerda que anidar una función es incorporarla dentro de otra. se debe calcular el gasto previsto con un 10% de descuento. Acepta hasta 30 argumentos.. Por esta razón. Sintaxis Y(valor_lógico1.valor_lógico2."Presupuesto excedido".A2) previsto en 500. Si se desea evaluar más de una condición se debe recurrir a funciones SI anidadas y no siempre es fácil construir una fórmula de esta naturaleza. de lo contrario debe quedar igual. de lo contrario debe quedar igual. . dentro del SI se puede anidar las funciones Y – O Ejemplos: Si el gasto previsto es menor que el gasto real y el rubro del gasto es entretención.. Si el rubro del gasto no es Salud o el código no es A. Devuelve FALSO cuando todos los argumentos son falsos.Clase 13: Funciones Lógicas y anidación TEMA 1: Funciones lógicas Y . se debe incrementar el gasto =SI(O(C2="Educación".) O(valor_lógico1. existen otras funciones que se pueden anidar con más facilidad y que permiten evaluar más de una condición: las funciones Y – O Función Y Devuelve VERDADERO si todos los argumentos son verdaderos.O Uno de los únicos defectos que tiene la función SI es que es no puede evaluar más de una condición o prueba lógica. de lo contrario la celda debe quedar en blanco. Devuelve FALSO si cualquiera de los argumentos es falso.valor_lógico2. Si el gasto previsto es mayor que 1000 y el código del gasto es distinto de A.C2="Entretención"). de lo contrario se debe mostrar el mensaje “En orden”."En orden") el mensaje “Presupuesto excedido”. .) Página 2 de 3 . En este caso. se debe calcular el gasto previsto con un 20% de descuento.

"REGULAR"."SOBRESALIENTE"))) La fórmula evalúa la nota en cada celda dependiendo del intervalo en el que se encuentre y muestra el mensaje que corresponde. Una función anidada dentro de la función PROMEDIO sería una función de tercer nivel. la Función B es una función de segundo nivel.SI(B10<6. la función PROMEDIO y la función SUMA en la figura son funciones de segundo nivel porque son argumentos de la función SI. Si la Función B se utiliza como argumento de la Función A. Se usarán sólo funciones SI anidadas.5. Un caso típico sería que quisieras otorgar una comisión de un 5% sobre las ventas si éstas son menores que 1000.5 y SOBRESALIENTE si la nota es mayor o igual que 6. pero de un 10% si son menores que 2000 y de un 15% y 20% si son menores que 3000 y 4000 respectivamente.5.SI(B10<5. Probarás este caso con la planilla de notas que se encuentra en la parte inferior del archivo. Por ejemplo. el mensaje REGULAR si la nota es mayor o igual que 4 pero inferior a 5. Control de intervalos con la función SI En ciertas ocasiones las funciones lógicas resultan muy útiles para controlar intervalos y tomar decisiones cuando un valor se encuentra dentro de un intervalo determinado. Anidar funciones implica incorporar una función como argumento de otra función. Por ejemplo. Formulación Se desea mostrar el mensaje DEFICIENTE si la nota es inferior a 4."DEFICIENTE". y así sucesivamente. Solución Digita la fórmula en la celda D10 y luego cópiala al resto de las celdas. la fórmula en la figura utiliza una función PROMEDIO anidada y compara el resultado de esa función con el valor 50. el mensaje BUENO si la nota es mayor o igual que 5 pero inferior a 6."BUENO". =SI(B10<4. Muchas veces es posible que tengas que utilizar una función como uno de los argumentos de otra función. Una función puede contener como máximo siete niveles de funciones anidadas. Página 3 de 3 .Clase 13: Funciones Lógicas y anidación TEMA 2: Anidación de funciones Los casos del tema anterior son un ejemplo claro de lo que se conoce como anidación de funciones.