You are on page 1of 4

Cấu hình kỹ thuật NAT và DHCP trên router

Cisco

Thực hiện các cấu hình sau:
a) Set up hệ thống như sơ đồ trên (Nhưng ta sẽ giả sử là máy server đang nối với interface
fast ethernet của ISP Router luôn)
b) Do không có nhiều pc để test nên ta sẽ cấu hình 3 địa chỉ ip trên interface fastethernet của
Customer Router : ip address ip-address subnet-mask secondary
c) Router Customer cấu hình 1 đường default route chỉ ra cổng serial 1/0.
d) Cấu hình DHCP trên Customer Router để cấp ip động cho các máy nằm bên trong mạng
LAN.
e) Cấu hình NAT trên router customer cho phép đường mạng 172.16.10.0/24 sẽ đi ra net bằng
địa chỉ ip public : 210.100.109.0/30 (sử dụng NAT overloading )
f) Router ISP cấu hình định tuyến cho đường mạng của địa chỉ ip 210.100.109.1/32 mà ISP đã
cho thuê: ip route 210.100.109.1 255.255.255.255 210.105.200.2
g) Test:
_Tại router customer: Ping mở rộng sử dụng ip nguồn là các ip đã cấu hình trên interface fast
ethernet đến ip 203.162.4.190 của server trên internet (Ta sẽ thấy thành công).
_Dùng các câu lệnh debug để kiểm tra hoạt động của NAT
+ debug ip nat
Hướng dẫn:
Bước 1: Đặt IP cho các interface như mô hình trên

Lưu ý : Ta lấy loop0 trên router ISP để giả làm IP của server .
Bước 2: Cấu hình DHCP trên CR
Chỉ định dãy ip loại trừ không cho cấp động
CR#configure terminal
CR(config)#ip dhcp excluded-address 172.168.10.1 172.168.10.10
Cấu hình pool địa chỉ ip cho cấp động
CR(config)#ip dhcp pool abc
CR(dhcp-config)#network 172.168.10.0 255.255.255.0
CR(dhcp-config)#dns-server 172.168.10.10
CR(dhcp-config)#default-router 172.168.10.1
Test DHCP bằng cách cho máy client nhận ip động từ Customer Router
Bước 3: Cấu hình NAT
Tạo access-list để cho phép những ip nào được nat :
CR(config)#access-list 1 permit 172.168.10.0 0.0.0.255
Tạo pool địa chỉ để nat :
CR(config)#ip nat pool nat-pool 210.100.109.1 210.100.109.2 netmask 255.255.255.252
Cấu hình nat :
CR(config)#ip nat inside source list 1 pool nat-pool overload
Cấu hình chỉ định vùng inside và outside cho NAT trên từng interface
CR(config)#interface s1/0
CR(config-if)#ip nat outside
CR(config)#interface fa0/0
CR(config-if)#ip nat inside
Bước 4: Cấu hình default route ra internet :
CR(config)#ip route 0.0.0.0 0.0.0.0 s1/0
Bước 5: Tại router ISP : định tuyến cho những địa chỉ đã cung cấp cho khách hàng
ISP#configure terminal
ISP(config)#ip route 210.100.109.0 255.255.255.252 210.105.200.2
ISP(config)#interface loop 0
ISP(config-if)#ip address 203.162.4.190 255.255.255.0
Bước 6: Dùng lệnh ping mở rộng để test thử và dùng lệnh debug ip nat để theo dõi quá trình
NAT .
Tại pc trong mạng LAN nội bộ ta ping đến địa chỉ server ( giả sử là loop 0 của router ISP )

Ta thấy kết quả ping thành công mặc dù trên ISP không định tuyến cho mạng LAN của công ty
( chỉ định tuyến cho địa chỉ public mà ISP cho công ty thuê ) . Như vậy ta đã thấy đuợc công
dụng của kỹ thuật NAT .
Bước 7: Dùng lệnh debug ip nat để phân tích quá trình NAT:
CR#debug ip nat

Ta thấy khi pc trong mạng LAN ping tới server thì pc dùng địa chỉ source là 172.168.10.2 để đi
. Đến router CR , router CR sẽ chuyển 172.168.10.2 thành 210.100.109.1 (đây là địa chỉ

public mà công ty thuê của ISP , địa chỉ này được route trên internet).
Khi server trả lời lại lệnh ping thì server dùng địa chỉ destination là 210.100.109.1 , router ISP
sẽ route cho địa chỉ này đến router CR, router CR sẽ chuyển điạ chỉ destination này thành
172.168.10.2 và chuyển đến pc .
Như vậy khi các pc trong mạng LAN truy cập internet thì đều dùng chung 1 địa chỉ public . Đều
đó làm ta tiết kiệm đuợc số lượng địa chỉ public đáng kể với tình hình khan hiếm IP như hiện
nay , đó chính là ưu điểm của kỹ thuật NAT.