You are on page 1of 17

ODL010008

Static Route and RIP Configuration
Laboratory Exercise Guide
ISSUE 1.0

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0

Table of Contents

Table of Contents
About This Course ............................................................................................................................1
Test Instructions...........................................................................................................................1
About This Manual .......................................................................................................................1
Test Objectives ............................................................................................................................1
Test Tasks ...................................................................................................................................1
Relevant Materials .......................................................................................................................1
Chapter 1 Static routing ....................................................................................................................1
1.1 Networking and Service Introduction .....................................................................................1
1.2 Command Line List ................................................................................................................1
1.3 Configuration flow ..................................................................................................................1
1.4 Configuration procedure ........................................................................................................1
1.5 Result Verification ..................................................................................................................2
1.6 Configuration Reference ........................................................................................................2
Chapter 2 Default Route ...................................................................................................................3
2.1 Networking and Service Introduction .....................................................................................3
2.2 Command Line List ................................................................................................................3
2.3 Configuration flow ..................................................................................................................3
2.4 Configuration procedure ........................................................................................................3
2.5 Result Verification ..................................................................................................................4
2.6 Configuration Reference ........................................................................................................4
Chapter 3 Route Link Backup ..........................................................................................................5
3.1 Networking and Service Introduction .....................................................................................5
3.2 Command Line List ................................................................................................................5
3.3 Configuration flow ..................................................................................................................5
3.4 Configuration procedure ........................................................................................................5
3.5 Result Verification ..................................................................................................................6
3.6 Configuration Reference ........................................................................................................6
Chapter 4 RIP Configuration ............................................................................................................8
4.1 Networking and Service Introduction .....................................................................................8
4.2 Command Line List ................................................................................................................8
4.3 Configuration flow ..................................................................................................................9
4.4 Configuration procedure ........................................................................................................9
4.5 Result Verification ..................................................................................................................9
4.6 Configuration Reference ..................................................................................................... 10

Huawei.

i

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0

About This Course
Test Instructions
This Test Guide mainly describes the basic configuration methods and configuration
processes for a static route and the RIP routing protocol. It shows you how to configure
a static route and the RIP routing protocol.

About This Manual

,RELEASE

This Guide is applicable to VRP versions 3.30 RELEASE 0008 and 5.10
0039

Test Objectives   

To understand the basic principles of static routes and RIP.
To grasp configuration process for static routes and RIP.
To get familiar with configuration commands for static routes and RIP.

Test Tasks    

Configure a static route
Configure the default route
Configure route link backup
Configuring routing protocols

Relevant Materials  

VRP3.30 Operation Manual
VRP5.10 Operation Manual

Huawei.

1

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0

Chapter 1 Static routing
1.1 Networking and Service Introduction
L1: 1.1.1.1/32

L1: 2.2.2.2/32
.1

10.1.1.0/30

.2

R

R

RTA

RTB

Figure 1-1 Hands-in guide to a static route
Use the 10.1.1.0/30 network segment to connect RTA and RTB. Configure such a static
route that can make the 1.1.1.1/32 network segment access the 2.2.2.2/32 network
segment, and vice versa.

1.2 Command Line List
Table 1-1

Operation

Command

Add a static route

ip route-static dest-address { mask | mask-length } { interface-name
[ nexthop-address ] | nexthop-address } [ preference preference-value ]
[ reject | blackhole ]
ip route-static [ vpn-instance vpn-instance-name ] ip-address { mask |
mask-length } { nexthop-address | interface-type interface-number
[ nexthop-address ] } [ preference preference ]

1.3 Configuration flow

Configure IP address for
an interface

Configure a static route

1.4 Configuration procedure
1)

Configure interfaces.
Huawei.

1

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0

Create a loopback address 1.1.1.1/32 and an interface address 10.1.1.1/30 for RTA.
Create a loopback address 2.2.2.2/32 and an interface address 10.1.1.2/30 for RTB.
2)

Configure a static route

On RTA, configure a static route to the loopback address of RTB. Likewise, on RTB,
configure a static route to the loopback address of RTA.

1.5 Result Verification
Upon completion of configuration, execute the display ip routing-table command to
observe routing tables of the two routers.
[RTA]display ip routing-table
Routing Table: public net
Destination/Mask
Protocol Pre
1.1.1.1/32
DIRECT
0
2.2.2.0/30
STATIC
60
10.1.1.0/30
DIRECT
0
10.1.1.1/32
DIRECT
0
127.0.0.0/8
DIRECT
0
127.0.0.1/32
DIRECT
0

0
0
0
0
0
0

[RTB]display ip routing-table
Routing Table: public net
Destination/Mask
Protocol Pre
1.1.1.1/32
STATIC
60
2.2.2.2/32
DIRECT
0
10.1.1.0/30
DIRECT
0
10.1.1.2/32
DIRECT
0
127.0.0.0/8
DIRECT
0
127.0.0.1/32
DIRECT
0

0
0
0
0
0
0

Cost

Nexthop
127.0.0.1
10.1.1.2
10.1.1.1
127.0.0.1
127.0.0.1
127.0.0.1

Interface
InLoopBack0
Ethernet0/0
Ethernet0/0
InLoopBack0
InLoopBack0
InLoopBack0

Cost

Nexthop
10.1.1.1
127.0.0.1
10.1.1.2
127.0.0.1
127.0.0.1
127.0.0.1

Interface
Ethernet0/0
InLoopBack0
Ethernet0/0
InLoopBack0
InLoopBack0
InLoopBack0

1.6 Configuration Reference 

Configuration of router A:
[RTA]interface Ethernet 0/0
[RTA-Ethernet0/0]ip address 10.1.1.1 30
[RTA-Ethernet0/0]quit
[RTA]interface LoopBack 1
[RTA-LoopBack1]ip address 1.1.1.1 32
[RTA-LoopBack1]quit
[RTA]ip route-static 2.2.2.0 32 10.1.1.2 

Configuration of router A:
[RTB]interface Ethernet 0/0
[RTB-Ethernet0/0]ip address 10.1.1.2 30
[RTB-Ethernet0/0]quit
[RTB]interface LoopBack 1
[RTB-LoopBack1]ip address 2.2.2.2 32
[RTB-LoopBack1]quit
[RTB]ip route-static 1.1.1.1 32 10.1.1.1

2

Huawei Technologies Co., Ltd.

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0

Chapter 2 Default Route
2.1 Networking and Service Introduction
L1: 1.1.1.1/32

L1: 2.2.2.2/32
.1

10.1.1.0/30

.2

R

R

RTA

RTB

Use the 10.1.1.0/30 network segment to connect RTA to RTB. On RTB, configure a
default route to make RTA a gateway for RTB.

2.2 Command Line List
Operation

Command

Add a static route

ip route-static dest-address { mask | mask-length } { interface-name
[ nexthop-address ] | nexthop-address } [ preference
preference-value ] [ reject | blackhole ]
ip route-static [ vpn-instance vpn-instance-name ] ip-address
{ mask | mask-length } { nexthop-address | interface-type
interface-number [ nexthop-address ] } [ preference preference ]

2.3 Configuration flow

2.4 Configuration procedure
1)

Configure interfaces.

Create a loopback address 1.1.1.1/32 and an interface address 10.1.1.1/30 for RTA.
Create a loopback address 2.2.2.2/32 and an interface address 10.1.1.2/30 for RTB.
2)

Configure a static route and a default route

On RTA, configure a static route to the loopback address of RTB. On RTB, configure a
default route to RTA.
Huawei.

3

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0

2.5 Result Verification
Upon completion of configuration, execute the display ip routing-table command to
observe the routing table of RTB.
[RTB]dis ip routing-table
Routing Table: public net
Destination/Mask
Protocol Pre
0.0.0.0/0
STATIC
60
2.2.2.2/32
DIRECT
0
10.1.1.0/30
DIRECT
0
10.1.1.2/32
DIRECT
0
127.0.0.0/8
DIRECT
0
127.0.0.1/32
DIRECT
0

Cost
0
0
0
0
0
0

2.6 Configuration Reference
Configuration of RTA is same as above. 

Configuration of router A:
[RTB]interface Ethernet 0/0
[RTB-Ethernet0/0]ip address 10.1.1.2 30
[RTB-Ethernet0/0]quit
[RTB]interface LoopBack 1
[RTB-LoopBack1]ip address 2.2.2.2 32
[RTB-LoopBack1]quit
[RTB]ip route-static 0.0.0.0 0 10.1.1.1

4

Huawei Technologies Co., Ltd.

Nexthop
10.1.1.1
127.0.0.1
10.1.1.2
127.0.0.1
127.0.0.1
127.0.0.1

Interface
Ethernet0/0
InLoopBack0
Ethernet0/0
InLoopBack0
InLoopBack0
InLoopBack0

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0

Chapter 3 Route Link Backup
3.1 Networking and Service Introduction
L1: 1.1.1.1/32

L1: 2.2.2.2/32

.1 10.1.1.0/30 .2

R

.1 10.10.1.1/30 .2

RTA

R
RTB

Use the 10.1.1.0/30 and 10.10.1.0/30 network segments to connect RTA to RTB.
Configure two static routes with different priorities so as to implement link backup when
RTA accesses the 2.2.2.2/32 network segment.

3.2 Command Line List
Operation

Add a static route

Command
ip route-static dest-address { mask | mask-length } { interface-name
[ nexthop-address ] | nexthop-address } [ preference preference-value ] [ reject |
blackhole ]
ip route-static [ vpn-instance vpn-instance-name ] ip-address { mask |
mask-length } { nexthop-address | interface-type interface-number
[ nexthop-address ] } [ preference preference ]

3.3 Configuration flow

3.4 Configuration procedure
1)

Configure interfaces.

Create a loopback address 1.1.1.1/32 and two interface address 10.1.1.1/30 and
10.10.1.1/30 for RTA.
Create a loopback address 2.2.2.2/32 and two interface address 10.1.1.2/30 and
10.10.1.2/30 for RTB.
2)

Configure a static route
Huawei.

5

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0

On RTA, configure two static routes to the loopback address of RTB. Likewise, on RTB,
configure two static routes to the loopback address of RTA.

3.5 Result Verification
Upon completion of configuration, execute the display ip routing-table command to
view the routing table of RTA.
[RTA]display ip routing-table
Routing Table: public net
Destination/Mask
Protocol Pre
1.1.1.1/32
DIRECT
0
2.2.2.2/32
STATIC
60
10.1.1.0/30
DIRECT
0
10.1.1.1/32
DIRECT
0
10.10.1.0/30
DIRECT
0
10.10.1.1/32
DIRECT
0
127.0.0.0/8
DIRECT
0
127.0.0.1/32
DIRECT
0

Cost
0
0
0
0
0
0
0
0

Nexthop
127.0.0.1
10.1.1.2
10.1.1.1
127.0.0.1
10.10.1.1
127.0.0.1
127.0.0.1
127.0.0.1

Interface
InLoopBack0
Ethernet0/0
Ethernet0/0
InLoopBack0
Ethernet0/1
InLoopBack0
InLoopBack0
InLoopBack0

The configured static route with a smaller preference value is added to the routing
table.
Execute the shutdown command for the Ethernet0/0 interface of RTA and then view the
routing table of RTA.
[RTA]interface Ethernet 0/0
[RTA-Ethernet0/0]shutdown
[RTA-Ethernet0/0]
%Aug 12 10:26:29 2005 RTA PHY/2/PHY:
Ethernet0/0: change status to
down
%Aug 12 10:26:29 2005 RTA IFNET/5/UPDOWN:Line protocol on the interface
Ethernet0/0 is DOWN
[RTA]display ip routing-table
Routing Table: public net
Destination/Mask
Protocol Pre
1.1.1.1/32
DIRECT
0
2.2.2.2/32
STATIC
100
10.10.1.0/30
DIRECT
0
10.10.1.1/32
DIRECT
0
127.0.0.0/8
DIRECT
0
127.0.0.1/32
DIRECT
0

Cost
0
0
0
0
0
0

Nexthop
127.0.0.1
10.10.1.2
10.10.1.1
127.0.0.1
127.0.0.1
127.0.0.1

Interface
InLoopBack0
Ethernet0/1
Ethernet0/1
InLoopBack0
InLoopBack0
InLoopBack0

The active link fails and the standby link takes over its work. Therefore, the original
backup route with preference 100 becomes an active route.

3.6 Configuration Reference 

Configuration of RTA:
[RTA]interface Ethernet 0/0
[RTA-Ethernet0/0]ip address 10.1.1.1 30
[RTA-Ethernet0/0]quit
[RTA]interface Ethernet 0/1
[RTA-Ethernet0/1]ip address 10.10.1.1 30
[RTA-Ethernet0/1]quit
[RTA]interface LoopBack 1
[RTA-LoopBack1]ip address 1.1.1.1 32
[RTA-LoopBack1]quit
[RTA]ip route-static 2.2.2.2 32 10.1.1.2 preference 60
[RTA]ip route-static 2.2.2.2 32 10.10.1.2 preference 100 

Configure of RTB:
[RTB]interface Ethernet 0/0
[RTB-Ethernet0/0]ip address 10.1.1.2 30

6

Huawei Technologies Co., Ltd.

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0
[RTB-Ethernet0/0]quit
[RTB]interface Ethernet 0/1
[RTB-Ethernet0/1]ip address 10.10.1.2 30
[RTB-Ethernet0/1]quit
[RTB]interface LoopBack 1
[RTB-LoopBack1]ip address 2.2.2.2 32
[RTB-LoopBack1]quit
[RTB]ip route-static 1.1.1.1 32 10.1.1.1 preference 60
[RTB]ip route-static 1.1.1.1 32 10.10.1.1 preference 100

Huawei.

7

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0

Chapter 4 RIP Configuration
4.1 Networking and Service Introduction
RTA

RTB
.1

10.1.1.0/30

.2

RTC
.1

192.2.2.0/30

R

R

R

L0: 2.2.2.2/32

L0: 1.1.1.1/32

.2

L0: 3.3.3.3/32

RTA, RTB and RTC are configured with RIP V2. Multicast address is used to send
messages. The network segment of RTA may access the network segment of RTC,
and vice versa.

4.2 Command Line List
Operation

Command

Enable RIP and enter RIP view
Enable RIP on the specified network interface
Specify the interface version as RIP-2
Perform the universal MD5 authentication for RIP-2
Import routes of other protocols

8

rip
rip [ process-id ] [ vpn-instance vpn-instance-name ]
network network-address
rip version 2 [ broadcast | multicast ]
rip authentication-mode md5 usual key-string
rip authentication-mode md5 { nonstandard password
key-id | usual password } }
import-route protocol [ cost value ] [ route-policy
route-policy-name ]

Huawei Technologies Co., Ltd.

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0

4.3 Configuration flow

Start the RIP to enter RIP view

Apply RIP to the specified interface

Specify RIP-2 for an interface

Configure an authentication mode

4.4 Configuration procedure
1)

Configure interfaces.

Configure interfaces according to the above networking diagram.-s
2)

Starting up RIP

3)

Apply RIP-2 to the corresponding loopback network and interface address

4)

Configure the MD5 authentication mode

4.5 Result Verification
Upon completion of configuration, observe routing tables of the three routers.
[RTA]display ip routing-table
Routing Table: public net
Destination/Mask
Protocol Pre
1.1.1.1/32
DIRECT
0
2.2.2.2/32
RIP
100
3.3.3.3/32
RIP
100
10.1.1.0/30
DIRECT
0
10.1.1.1/32
DIRECT
0
127.0.0.0/8
DIRECT
0
127.0.0.1/32
DIRECT
0
192.2.2.0/30
RIP
100

Cost
0
1
2
0
0
0
0
1

[RTB]display ip routing-table
Routing Table: public net
Destination/Mask
Protocol Pre Cost
1.1.1.1/32
RIP
100 1
2.2.2.2/32
DIRECT
0
0

Huawei.

Nexthop
127.0.0.1
10.1.1.2
10.1.1.2
10.1.1.1
127.0.0.1
127.0.0.1
127.0.0.1
10.1.1.2

Interface
InLoopBack0
Ethernet0/0
Ethernet0/0
Ethernet0/0
InLoopBack0
InLoopBack0
InLoopBack0
Ethernet0/0

Nexthop
10.1.1.1
127.0.0.1

Interface
Ethernet0/0
InLoopBack0

9

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0
3.3.3.3/32
10.1.1.0/30
10.1.1.2/32
127.0.0.0/8
127.0.0.1/32
192.2.2.0/30
192.2.2.1/32

RIP
DIRECT
DIRECT
DIRECT
DIRECT
DIRECT
DIRECT

100
0
0
0
0
0
0

1
0
0
0
0
0
0

[RTC-rip]display ip routing-table
Routing Table: public net
Destination/Mask
Protocol Pre Cost
1.1.1.1/32
RIP
100 2
2.2.2.2/32
RIP
100 1
3.3.3.3/32
DIRECT
0
0
10.1.1.0/30
RIP
100 1
127.0.0.0/8
DIRECT
0
0
127.0.0.1/32
DIRECT
0
0
192.2.2.0/30
DIRECT
0
0
192.2.2.2/32
DIRECT
0
0

192.2.2.2
10.1.1.2
127.0.0.1
127.0.0.1
127.0.0.1
192.2.2.1
127.0.0.1

Ethernet0/1
Ethernet0/0
InLoopBack0
InLoopBack0
InLoopBack0
Ethernet0/1
InLoopBack0

Nexthop
192.2.2.1
192.2.2.1
127.0.0.1
192.2.2.1
127.0.0.1
127.0.0.1
192.2.2.2
127.0.0.1

Interface
Ethernet0/1
Ethernet0/1
InLoopBack0
Ethernet0/1
InLoopBack0
InLoopBack0
Ethernet0/1
InLoopBack0

The routing tables show you that RTA may access RTB ‘s loopback address via RIP,
and so does RTB and RTC.
You can ping RTC’s loopback address form RTA
[RTA]ping 3.3.3.3
PING 3.3.3.3: 56 data bytes, press CTRL_C to break
Reply from 3.3.3.3: bytes=56 Sequence=1 ttl=254 time=2
Reply from 3.3.3.3: bytes=56 Sequence=2 ttl=254 time=2
Reply from 3.3.3.3: bytes=56 Sequence=3 ttl=254 time=2
Reply from 3.3.3.3: bytes=56 Sequence=4 ttl=254 time=2
Reply from 3.3.3.3: bytes=56 Sequence=5 ttl=254 time=2
--- 3.3.3.3 ping statistics --5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 2/2/2 ms

4.6 Configuration Reference 

Configuration of RTA:
[RTA]interface Ethernet 0/0
[RTA-Ethernet0/0]ip address 10.1.1.1 30
[RTA-Ethernet0/0]rip version 2 multicast
[RTA-Ethernet0/0]quit
[RTA]interface LoopBack 0
[RTA-LoopBack1]ip address 1.1.1.1 32
[RTA-LoopBack1]rip version 2 multicast
[RTA-LoopBack1]quit
[RTA]rip
[RTA-rip]network 1.1.1.1
[RTA-rip]network 10.1.1.0
[RTA-rip]undo summary 

Configuration of RTB:
[RTB]interface Ethernet 0/0
[RTB-Ethernet0/0]ip address 10.1.1.2 30
[RTB-Ethernet0/0]rip version 2 multicast
[RTB-Ethernet0/0]quit
[RTB]interface LoopBack 0
[RTB-LoopBack1]ip address 2.2.2.2 32
[RTB-LoopBack1]rip version 2 multicast
[RTB-LoopBack1]quit
[RTB]interface Ethernet 0/1
[RTB-Serial1/0]ip address 192.2.2.1 30
[RTB-Serial1/0]rip version 2 multicast
[RTB-Serial1/0]rip authentication-mode md5 usual Huawei
[RTB-Serial1/0]quit

10

Huawei Technologies Co., Ltd.

ms
ms
ms
ms
ms

ODL010008 Static Route and RIP Configuration Laboratory Exercise
Guide ISSUE1.0
[RTB]rip
[RTB-rip]network 192.2.2.0
[RTB-rip]network 2.2.2.2
[RTB-rip]network 10.1.1.0
[RTB-rip]undo summary 

Configuration of RTC:
[RTC]interface Ethernet 0/1
[RTC-Serial1/0]ip address 192.2.2.2 30
[RTC-Serial1/0]rip version 2 multicast
[RTC-Serial1/0]rip authentication-mode md5 usual Huawei
[RTC-Serial1/0]quit
[RTC]interface LoopBack 0
[RTC-LoopBack1]ip address 3.3.3.3 32
[RTC-LoopBack1]rip version 2 multicast
[RTC-LoopBack1]quit
[RTC]rip
[RTC-rip]network 3.3.3.3
[RTC-rip]network 192.2.2.0
[RTC-rip]undo summary

Huawei.

11