You are on page 1of 38

Uberlândia, 11 de abril de 2012.

P1) Neste algoritmo houve a tradução de um fluxograma para pseudo-linguagem em que, iniciando em C1, se L1 for verdadeiro, o algoritmo seguira o caminho de C2, se não seguirá para L3. O algoritmo passará por varias estruturas de „‟falso ou verdadeiro‟‟ e de repetição até que chegue a C12 e, portanto, ao fim. Inicio c1 se l1 entao c2 enquanto l2 faca c3 c4 fimenquanto senao enquanto l3 faca c5 se l4 entao se l5 entao c6 c7 fimse senao c8 c9 fimse c10 fimenquanto c11 fimse

c12 fimalgoritmo

P02) Número primo é aquele que é divisível por 1 e por ele mesmo. O programa em questão diz se determinado número é primo ou não. O programa pede um valor n e faz o seguinte teste: se o resto da divisão de n por d(que inicialmente vale 2) for igual a 0, então d é divisor de n. Se d é divisor de n, então n não é um número primo. Se d não for divisor de n então admite-se outro valor para d(d + 1) até que d seja maior que n. Quando d for maior que n, o programa sai do laço e diz se n é primo ou não, seguindo a mesma lógica: será primo se não existir nenhum d divisor de n, a não ser o próprio n. Algoritmo: "Números primos" var p: logico n, d: inteiro inicio escreval ("Este programa diz se um número é primo ou não.") escreval ("Digite um valor para n:") leia(n) p <- verdadeiro d <- 2 enquanto ((d <= raizQ(n)) e (p = verdadeiro)) faca se (n%d = 0) entao p <- falso

Y <.falso.3*2. X <. L: inteiro inicio A <.d+1 fimenquanto se p = verdadeiro entao escreval (n.1*5. C: logico X.fimse d <. ." é um número primo") senao escreval (n.verdadeiro.X + 1.falso. B." não é um número primo") fimse fimalgoritmo P3) O Algoritmo utiliza uma função lógica. B <. através da condição „se‟ encontra-se o valor de L = 0 Algoritmo: “Lógico” var A. Y: real V.0. C <. X <. se C ou ((X+Y>5) ou (nao A e B)) entao L <.

1.L) fimalgoritmo P4) Neste algoritmo foi usado a estrutura de repetição “enquanto. o procedimento de soma e escrita de cada resultado seria igual ao primeiro caso. o algoritmo escrevesse na tela todos os valores inteiros que existiam entre os 2 números escritos pelo usuário.senao L <.faca” para que se pudesse fazer com que. fimse.. Algoritmo: “Inteiros min. seria escrito o valor do primeiro na tela e o algoritmo somaria o valor com 1 e escreveria cada resultado até que chegasse ao segundo valor escrito pelo usuário.max” var a. dados 2 valores pelo usuário do programa. Se o primeiro fosse menor que o segundo. escreval ("valor de L =". b : inteiro Inicio escreva ("Digite 2 valores:") leia (a. Se o segundo valor fosse menor que o primeiro. b) se b>a entao enquanto (b>=a) faca escreva (a) a<-a+1 .

Se o segundo fosse menor que o primeiro.fimenquanto senao enquanto (a>=b) faca escreva (b) b<-b+1 fimenquanto fimse fimalgoritmo P5) Neste algoritmo foi usado as estruturas “enquanto. a lógica de soma e subtração usada seria a mesma. escrevendo cada valor obtido. até que o segundo atingisse o valor do primeiro. ..faca”e “se..entao” para que se pudesse escrever os valores existentes entre dois números escritos pelo usuário na forma crescente ou decrescente. Se o primeiro valor fosse maior que o segundo o algoritmo salvava os valores em variáveis distintas e começaria a desenvolver a parte crescente de forma que seria escrito o primeiro valor e se somaria a 1. também escrevendo cada valor. Se o usuário escolhesse ”D”. fazendo assim que se obtivesse uma sequência de valores crescentes ou decrescentes. o algoritmo iria desenvolver a sequencia de forma decrescente da seguinte forma: se compararia o segundo valor ao primeiro e se iria subtraindo 1. até que se chegasse ao segundo valor dado pelo usuário.

") leia (ordem) y<-a x<-b se b>a entao enquanto (b>=a) faca se (ordem = "C") entao escreval(a) a<.a + 1 senao se (ordem = "D") entao enquanto (b>=y) faca escreval(b) .") leia (a) escreval ("Digite outro valor.y.b.x : inteiro ordem: caractere Inicio escreval ("Digite um valor.") leia (b) escreval ("Escolha C para ordem crescente e D para ordem decrescente.Algoritmo: “Crescente ou decrescente” var a.

b<-b-1 fimenquanto fimse fimse fimenquanto senao enquanto (a>=b) faca se (ordem = "C") entao escreval(b) b<-b+1 senao se (ordem = "D")entao enquanto (a>=x) faca escreval(a) a<-a-1 fimenquanto fimse fimse fimenquanto fimse fimalgoritmo .

.") . a soma dos valores anteriores se somaria com este novo valor. a partir do segundo valor. respeitando uma função “repita” até que o usuário digitasse “-1”.z. digite '-1'") leia(x) se (x=-1) entao escreval("Fim. Uma terceira variável faria o papel de “soma” e.k:real inicio escreval("Digite um preço.entao”e „‟repita.até” para que se pudesse obter um algoritmo que lesse quantos valores o usuário decidisse e somasse todos até que o usuário digitasse o valor “-1” e finalizasse o programa.") fimse se (x<>-1)entao repita escreval("Digite outro preço.. a cada novo valor obtido. O algoritmo consiste em o primeiro valor dado pelo usuário ser armazenado em uma variável e. se desejar encerrar digite '-1'. dando a soma final.P6) Neste algoritmo foram usadas as funções “se. o programa dá a somatória total e encerra o funcionamento. Algoritmo: “Preço” var x. Se desejar encerrar. os valores seriam armazenados em uma outra variável . Uma vez digitado o valor “-1”.y.

Feito isso o programa escreverá os valores de x e se encerrará. a razão da p. Em seguida x assumirá valores do primeiro termo até a variável an com passo razão.a. sendo eles o primeiro termo da p.a. A partir dos valores inserido a variável na(último termo da p.a) assumira o valor da multiplicação da razão pela soma do primeiro termo e a subtração do número de valores existentes na p. Algoritimo: “Progressão aritmética” var .a por 1. z) fimse fimse fimalgoritmo P7) Neste exercício o programa irá ler 3 valores.a e o números de valores existentes na p.leia(y) se (y>=0) entao z<-x+y x<-z k<-y fimse ate (y=-1) se (y=-1) entao escreval("A soma dos valores é:".

x: inteiro inicio escreval("Digite o valore do primeiro termo") leia(a1) limpatela escreval("Digite o valor da razao") leia(razao) limpatela escreval("Digite o numero de valores existentes na pa") leia(N) limpatela an <.N.a1 + (N-1) * razao para x de a1 ate an passo razao faca escreva(x) fimpara fimalgoritmo P8) O Algoritmo pede o número de termos. a partir disso usando a função “para n de n ate 1” fica estabelecido a fórmula da P.razao.G .an.G “an<-a1*q^(n-1)” de onde é possível extrair os N primeiros termos da P. o primeiro termo e a razão.a1.

usando variáveis temporárias se pode fazer a soma e a média das voltas e comparar para adquirir-se a melhor e a pior volta do piloto. Informa-se uma variável que irá valer de 1 até o numero de voltas dado pelo usuário. q. n :inteiro an : real inicio escreval (" Digite o número de termos:") leia (n) escreval ("Digite o primeiro termo: ") leia (a1) escreval (" Digite a razao: ") leia (q) para n de 1 ate (n) faca an<-a1*q^(n-1) escreva (an) fimpara fimalgoritmo P09) O algoritmo funciona informando-se no início o numero de voltas e os tempos de cada volta. . A cada valor desta variável serão coletados as durações das voltas e.Algoritmo: “Progressão Geométrica” var a1.

" volta") leia(tempo) se (k=1) entao melhorvolta<-k menorvolta<-tempo fimse se (menorvolta>tempo) entao menorvolta<-tempo melhorvolta<-k fimse soma<-soma+tempo k<-k+1 fimenquanto media<-soma/(k-1) escreval("A media dos tempos das voltas é:".soma: real inicio k<-1 soma<-0 escreval("Digite o numero de voltas:") leia(n) enquanto (k<=n) faca escreval("Digite o tempo da ".media) escreval("O melhor tempo foi de:".Algoritmo: “Número de voltas” var n.k.menorvolta.media.menorvolta) escreval("A volta em que o menor tempo ocorreu foi a volta:".melhorvolta) fimalgoritmo P10) .k.melhorvolta: inteiro tempo.

Quando constata-se que um número é perfeito (pelo método descrito no 2º parágrafo). então x não é divisor de n. o programa guarda a soma deste primeiro divisor em uma variável y usando a expressão y = y + x. a contagem. totp. assim. No final. dizendo se cada um é perfeito. x. então x é divisor de n. a variável totp assume o valor de totp + 1. o programa usa a seguinte condição: se o resto da divisão de n por um valor x(inicialmente 1) for igual a zero. Se o resto da divisão for diferente de 0. Para fazer a soma dos divisores de determinado número. Outra função é a contagem. o programa faz o teste: se n é igual a y(soma dos divisores). então n é um número perfeito. abundante quando for menor que a soma dos seus divisores. Se x for divisor de n. Para isso. Se for menor do que y. totr: inteiro . é um número reduzido. com n adquirindo valores de 1 a 200. quantos abundantes e também quantos reduzidos. tota. e reduzido quando for maior que a soma de seus divisores. O mesmo acontece com os reduzidos e abundantes.Este programa faz a lista dos números de 1 a 200. O programa conta quantos números perfeitos existem de 1 a 200. Algoritmo: "classificanumeros" var n. y. abundante ou reduzido. O programa faz o teste para n. Inicialmente todas estas variáveis valem 0. é um número abundante. utilizase as variáveis totp(total de perfeitos). O número será perfeito quando for igual à soma dos seus divisores. e x recebe outro valor para teste (x+1) enquanto x for menor que n. tota(total de abundantes) e totr(total de reduzidos). e se for maior. fazendo.

0 fimse senao se n < y entao escreval (n:3.tota + 1 se n = x entao y <.1 enquanto (x < n) faca se ((n % x)=0) entao y <.inicio totp <.0 tota <.x + 1 fimenquanto se n = y entao escreval (n:3." é um número abundante") tota <.totr + 1 se n = x entao y <.0 totr <.totp + 1 se n = x entao y <." é um número perfeito") totp <.y + x fimse x <." é um número reduzido") totr <.0 fimse senao se n > y entao escreval (n:3.0 fimse fimse .0 para n de 1 ate 200 faca x <.

fimse fimse fimpara escreval ("O número total de números perfeitos é".totr) fimalgoritmo P11) No algoritmo é pedido um número e através de um teorema é possível verificar se ele é primo ou não. x: inteiro k: logico inicio escreval ("Digite um número:") leia(n) k <. Algoritmo: “Números Primos” var n.tota) escreval ("O número total de números reduzidos é". Usando a função „enquanto‟ foi introduzido o teorema ((x <= raizQ(n)) e (k = verdadeiro)) e com o artifício „se‟ foi possível estabelecer as condições para números primos.totp) escreval ("O número total de números abundantes é".2 enquanto ((x <= raizQ(n)) e (k = verdadeiro)) faca se (n%x = 0) entao k <.falso .verdadeiro x <.

Se o resto for diferente de 0. ignora-se este valor de m e faz-se o teste com o próximo (m+1). x(um dos números) deve ser igual a q(soma dos divisores de y) e y(o . Para dois números serem amigos. o programa pede dois valores x e y no começo. Para determinar a soma dos divisores de x e y. é feito o seguinte teste: se o resto da divisão de x por m(inicialmente 1) for igual a 0. Para determinar a quantidade de divisores p. usa-se q e n. respectivamente.x+1 fimenquanto se k = verdadeiro entao escreval (n. Usa-se o mesmo método para calcular a soma dos divisores de y." é um número primo") senao escreval (n. usase. da seguinte forma: y = y + m. Para fazer esse teste." não é um número primo") fimse fimalgoritmo P12) Se um número é igual à soma dos divisores de outro. a diferença é que ao invés de usar-se p e m. a soma dos divisores de um deve ser igual ao outro. Ou seja. enquanto m < x. esses números são amigos.fimse x <. as variáveis p e q. então m é divisor de x e é adicionado ao valor de y(inicialmente 0).

") . são amigos.1 enquanto (n < y) faca se ((y % n)=0) entao q <. Se não.0 escreval ("Este programa diz se dois números são amigos ou não. q: inteiro inicio p <.m + 1 fimenquanto n <.q + n fimse n <.outro número) deve ser igual a p(soma dos divisores de x). m.") escreval ("Digite um valor para x:") leia(x) escreval ("Digite um valor para y:") leia (y) m <.0 q <.n + 1 fimenquanto se (x = q) e (y = p) entao escreval ("estes números são amigos. n.p + m fimse m <. Se isso acontecer. Algoritmo "numerosamigos" var x. não são amigos. p.") senao escreval ("Estes números não são amigos. y.1 enquanto (m < x) faca se ((x % m)=0) entao p <.

Assim. Por último. tipo1. c. e. menor. e atribuiria o valor de 1 para outra variável. tipo2. individual. se chamaria o numero de usuários de energia na cidade de uma variavel. para se poder dar o consumo total de cada um dos 3 tipos de consumidores existentes foi necessário armazenar cada consumo nas variáveis “tipo1” . As informações de cada consumidor seriam armazenadas e assim se poderia dizer qual o total cada consumidor teria que pagar. x. “tipo2” . codigo: inteiro p.fimse fimalgoritmo P13) Neste algoritmo. Algoritmo: “Consumo de energia” var n. se coletaria todos os dados que o algoritmo pede para o primeiro usuário e após o acontecido se somaria 1 ao valor desta outra variável para que se pudesse coletar os dados dos usuários seguintes até que esta se tornaria igual ao numero de consumidores totais. “tipo3” e assim. maior. no final da execução o algoritmo exibiria na tela cada somatória de cada tipo de consumidor. tipo3: real z. soma. k. o maior e o menor consumo registrado entre todos os consumidores. no final da coleta de dados daria para informar a média geral dos consumos. mg : real inicio . comparando os consumos.

. em reais. de sua cidade: ") leia(p) escreval("Forneça a quantidade de consumidores:") leia (n) escreval("Codigos: Para residencial. 2."o consumidor ( 1. 2 ou 3 ): ") leia (codigo) se (k=1) entao menor<-c maior<-c fimse se (menor>c) entao x<-menor . em kWh: ") leia(c) escreval ("Digite o código do " .3.k."o consumidor.k<-1 tipo1<-0 tipo2<-0 tipo3<-0 escreval ("Forneça o preço de kWh. Para comercial. Para industrial.") enquanto (k<=n) faca escreval ( " Forneça o consumo de energia do" .k.1.

tipo1 + c senao se (codigo = 2)entao tipo2<-tipo2 + c senao tipo3<-tipo3 + c fimse fimse individual<.menor<-c maior<-x fimse se (maior<c) entao z<-maior maior<-c menor<-z fimse se (codigo = 1) entao tipo1<.k."o consumidor irá pagar R$". individual.(p)*(c) soma<-soma + c mg<.soma/n escreval ("O ".) k<-k+1 .

") escreval("O total de consumo comercial foi de ". " kwh.100 Algoritmo: “Contagem de dinheiro” var din: inteiro . ") escreval ("O total de consumo industrial foi de ".fimenquanto escreval ("O maior consumo. tipo3. em kWh foi de ". tipo2." e o menor foi de ". ex: enquanto (din >= 100) faca x100 := x100+1 din := din .") escreval ( "A média geral do consumo foi de"." kwh") fimalgoritmo P14) O Algoritmo calcula o menor número possível de notas a ser decomposto. mg." kwh.tipo1."kwh.maior. menor) escreval ("O total de consumo residencial foi de ". com o uso da função „ate‟ define-se um valor positivo. utilizando „enquanto‟ é possível separar os valores de acordo com as notas que se somam para a decomposição.

x10. x50. din. x5."reais") x100 := 0 x50 := 0 x10 := 0 x5 := 0 x1 := 0 enquanto (din >= 100) faca x100 := x100+1 din := din .50 fimenquanto enquanto (din>=10) faca x10 := x10 + 1 .100 fimenquanto enquanto (din>= 50) faca x50 := x50 + 1 din := din .x100. x1: inteiro inicio Repita escreval ("Digite um valor") Leia (din) ate (din>0) escreval ("o valor que será decomposto é:".

dividendo. x5) escreval ("e de 1 é de:".c. x1) fimalgoritmo P15) O algoritmo pede dois números e através da função „enquanto‟ usando o artifício „MOD‟ é possível calcular o MDC entre os dois números Algoritmo: “MDC” var a.b.1 fimenquanto escreval ("A quantidade de notas de 100 é:". x10) escreval ("de 5 é:". x100) escreval ("de 50 é:".din := din . x50) escreval ("de 10 é:". divisor:inteiro .5 fimenquanto enquanto (din >=1) faca x1 := x1 + 1 din := din .10 fimenquanto enquanto (din>=5) faca x5 := x5 + 1 din := din .

Na outra condição se o resto da divisão do número por 400 for diferente de 0 então a variável x .c fimenquanto escreva (" O MDC é igual a ". senão teremos outra condição.b enquanto ((dividendo MOD divisor) <> 0) faca c <.divisor divisor <.(dividendo MOD divisor) dividendo <.a divisor <.inicio // Seção de Comandos escreval("Digite o primeiro número:") leia (a) limpatela escreval("Digite o segundo número:") leia (b) limpatela dividendo <.divisor) fimalgoritmo P16) Neste exercício o programa irá ler o valor inserido e logo em seguida há uma condição. Se o resto da divisão entre o número digitado e 400 for 0 então o programa irá escrever que o ano é um ano bissexto.

y: inteiro inicio // Seção de Comandos escreval("Digite um ano") leia(ano) limpatela se(ano MOD 400 = 0) entao escreval(ano." é um ano bissexto") senao .assumirá o valor do resto da divisão entra o ano por 4 e variável y assumirá o valor do resto da divisão entre o ano e 100. Se a variável x for igual a e a variável y for diferente de 0 o programa escreverá que o ano é um ano bissexto.ano. se essa última condição não for satisfeita o programa escreva que o ano não é um ano bissexto e se encerrará.(ano MOD 4) y <." é um ano bissexto") senao se (ano MOD 400 <> 0) entao x <. Algoritmo: “Ano Bissexto” var x. e então teremos outra condição.(ano MOD 100) se (x = 0) e (y <> 0) entao escreval(ano.

a+c soma3 <. que é: se a for igual à b e c então o programa escreverá que o triângulo é equilátero. Se esta condição não for satisfeita o programa entrará em outra condição. senda elas a. a for igual a c e a for diferente de b então o programa escreverá que o triângulo é isósceles.b+c sub1 <.a-c sub3 <.b-c Em seguida temos uma condição. Se essa condição também não for satisfeita o programa entrará em . b for maior que sub 2 e menor que soma 2 e c for maior que sub 3 e menor que soma 3 então entraremos em outra condição.a+b soma2 <. ou. sendo ela: se a for igual a b e a for diferente de c.a-b sub2 <. b e c. se a for maior que sub 3 e menor que soma 3. disponíveis da seguinte forma: soma1 <. Logo no começo teremos 3 somas e 3 subtrações entre as variáveis." não é um ano bissexto") fimse fimse fimse fimalgoritmo P17) Neste exercício o programa irá ler 3 variáveis.escreval(ano.

sub1. que é: se a for diferente de b e de c e b for diferente de c então o programa escreverá que o triângulo é escaleno.y-z .x-y sub2 <.z. Se nenhuma das condições citadas for satisfeita o programa escreverá que a condição de existência de um triângulo não foi satisfeita e se encerrará Algoritmo: “Triângulos” var x.") escreval("digite um valor para x:") leia(x) escreval("digite um valor para y") leia(y) escreval("digite um valor para z") leia (z) soma1 <.soma2.x+z soma3 <.soma3.sub2.uma última condição.sub3: inteiro inicio escreval ("Este programa classifica um triângulo em isósceles. escaleno ou equilátero.soma1.y.x-z sub3 <.y+z sub1 <.x+y soma2 <.

se (x > sub3) e (x < soma3) e (y > sub2) e (y < soma2) e (z > sub3) e (z < soma3) entao se (x=y) e (x<>z) ou (x=z) e (x<>y) entao escreval("O triângulo é isósceles") senao se (x=y) e (y=z) entao escreval("O triângulo é equilátero") senao se (x<>y) e (y<>z) e (z<>x) entao escreval("O triângulo é escaleno") fimse fimse fimse senao escreval("A condição de existência de um triângulo não foi satisfeita.") fimse fimalgoritmo P18) Neste exercício o usuário irá digita um valor de 1 a 5 para votar em um dos 3 candidatos ou nulo ou em branco. Se a resposta dada pelo usuário for 1 então o . Em seguida o programa irá ler a resposta e entrará na primeira condição.

se a condição não for satisfeita ele entrará em outra condição. Se a resposta for 3 então o programa adicionará 1 à variável siclano. nul. Se a resposta for 2 então o programa adicionará 1 à variável beltrano. O programa irá repetir a ação acima até que a soma entre todas as variáveis seja igual a 99. ful.Sicrano") escreval ("3. Escolha seu candidato:") escreval ("1. se a condição não for satisfeita ele entrará em outra condição.Fulano") escreval ("2.Beltrano") escreval ("4. sic. Se a resposta for 4 então o programa adicionará 1 à variável votonulo.programa adicionará 1 à variável fulano. Se a resposta for 5 então o programa adicionará 1 à variável votobranco. Algoritmo: “Votação” var resp. se a condição não for satisfeita ele entrará em outra condição. Quando isso acontecer o programa ira escrever quantos votos cada variável recebeu e irá se encerrar.Voto nulo") escreval ("5.Voto branco") enquanto resp <> 99 faca . bran: inteiro inicio escreval ("Este programa é usado para as eleições presidenciais. se a condição não for satisfeita ele entrará em outra condição. bel. se a condição não for satisfeita ele entrará em outra condição.

escreval ("Digite o número correspondente ao seu candidato:") leia (resp) escolha (resp) caso 1 escreval ("Você votou em Fulano") ful <.bran + 1 caso 99 interrompa outrocaso escreval ("Voto inválido") .ful + 1 caso 2 escreval ("Você votou em Sicrano") sic <.bel + 1 caso 4 escreval ("Você votou nulo") nul <.nul + 1 caso 5 escreval ("Você votou em branco") bran <.sic + 1 caso 3 escreval ("Você votou em Beltrano") bel <.

ful) escreval ("Total de votos para Sicrano:". Na segunda parte do algoritmo teremos outra condição. digite um valor maior que 0".bel) escreval ("Total de votos nulos:".fimescolha fimenquanto escreval ("Total de votos para Fulano:". Enquanto o número inserido for maior que 10 o programa irá dividi-lo por 10 e a variável k assumirá o valor de k + 1 e em seguida o programa imprimirá o valor de k(número de algarismos de n(número inserido). Enquanto o número inserido for maior ou igual a 1 a variável b assumirá o valor do resto da divisão entre o número e 10. Logo depois n(número inserido) assumirá o valor da divisão da subtração de n por b por 10. Algoritmo: “soma dos dígitos” var .nul) escreval ("Total de votos em branco:".sic) escreval ("Total de votos para Beltrano:". Em seguida a variável soma assumirá o valor de soma + b.bran) fimalgoritmo P19) Neste exercício o programa irá ler um valor e em seguida entrará em um loop que é: enquanto o valor inserido não for maior que 0 a seguinte mensagem irá aparecer "valor inválido. Quando o número for maior que 0 o programa irá entrar em uma condição. Feito isso o programa imprimirá a soma dos algarismos do número inserido.

1 escreval("Digite um número inteiro maior que zero") leia(n) enquanto (n<0) faca escreval(" Digite um valor maior que zero") leia(n) fimenquanto r <.0 enquanto n >= 1 faca b <.int((n-b) / 10) fimenquanto escreval("A quantidade de dígitos é:".soma + b n <.b: inteiro r: real inicio k <.n MOD 10 soma <.r/10 k <.k+1 fimenquanto soma <.soma. z. n.k.n enquanto (r>10) faca r <. k) .

como por exemplo: 123 será imprimido como 321. soma) fimalgoritmo P20) Neste algoritmo o programa lerá um valor.escreval("A soma dos algarismos é ".y.c) fimalgoritmo P21) .v: inteiro inicio // Seção de Comandos leia(x) limpatela y <.int(y / 10) v <.z.v.int(x / 10) z <. Em seguida o programa desmembra os algaritimos do valor inserido e os reordena de trás para frente.x MOD 10 c <.z.y MOD 10 escreval("O palíndromo desejado é".c. Algoritmo: “Palindromo” var x.x.

Usamos as variáveis dia. A variável b é a divisão da subtração das variáveis a e c por 100.") leia (mes) escreval ("Digite o ano em que você nasceu. c. A variável c é o resto da divisão da variável a por 100.int((a . A variável f é utilizada para o levantamento do perfil psicológico.") leia (ano) a <.c) / 100) d <. d. todas com valores inteiros. mes e ano se referem. c. respectivamente.") leia (dia) escreval ("Digite o mês em que você nasceu. b.Este programa levanta o perfil psicológico de uma pessoa a partir de certas contas feitas com a data de nascimento da mesma. mes. A variável a é a soma mes + ano + dia*100. A variável d é a soma das variáveis b e c A variável f é o resto da divisão da variável d por 5. mes. As variáveis dia. Algoritmo "perfilpsicologico" var dia.dia*100 + mes + ano c <. f: inteiro inicio escreval ("Este programa levanta o seu perfil psicológico. f.int(d % 5) escolha (f) .a % 100 b <. ao dia. a. a. ano.") escreval ("Digite o dia em que você nasceu. mês e ano de nascimento da pessoa. b. ano. d.b + c f <.

i:inteiro k.x. o resultado seria guardado em 2 novas variáveis.. Algoritmo: “Somatória” var n.caso 0 escreval ("Tímido") caso 1 escreval ("Sonhador") caso 2 escreval ("Paquerador") caso 3 escreval ("Atraente") caso 4 escreval ("Irresistível") fimescolha fimalgoritmo P22) Neste algoritmo foi usada a função “para i de . ate . sendo que este segundo seria de 1 até tal limite. o valor da primeira variável seria ele próprio.t:real . Quando o numero elevado e dividido fosse 1.p.r. Então se teria a variável “soma” e esta no final seria somada ao valor da primeira variável para que se obtivesse a somatória total.w. porem quando elevado e divido por 2 até o limite determinado pelo usuário . “ para que se pudesse fazer a somatória do determinado numero elevado e dividido por outro numero.v.. sendo que uma para a elevação do numero e outra para a divisão deste.

inicio escreval("Digite um valor para x") leia(x) limpatela escreval("Digite um valor para n") leia(n) limpatela para i de 1 ate 1 faca k<-x fimpara para i de 2 ate n faca p <-x^i t<-p/i v<-t+w w<-v fimpara r<-k+w escreval(r) // Seção de Comandos fimalgoritmo P23) .

. P24) O corpo do laço enquanto será executado 5 vezes e os valores de x e y imediatamente após a saída desse laço serão. 5 e 5. respectivamente. 5 e 5.O corpo do laço enquanto será executado 5 vezes e os valores de x e y imediatamente após a saída desse laço serão. respectivamente.