You are on page 1of 20

Ejercicios del Primer Corte En VB2008

Por Manuel Fernndez y Lisbeth Pacheco


Ejercicios resueltos en el primer parcial traducidos al Visual Basic 2008, se incluyen anlisis y algoritmos en Algor. El proceso de toma de datos es a travs de proceso interactivo.

01/02/2009

Ejercicios del Primer Corte En VB2008


1 de feb.

Contenido
Ejercicio 1 .......................................................... 3 Anlisis del Problema .................................................................................................................. 3 Tabla de Variables ....................................................................................................................... 3 Algoritmo..................................................................................................................................... 3 Cdigo en Visual Basic 2008 ........................................................................................................ 3 Ejercicio 2 .......................................................... 4 Anlisis del Problema .................................................................................................................. 4 Tabla de Variables ....................................................................................................................... 4 Algoritmo..................................................................................................................................... 4 Cdigo en Visual Basic 2008 ........................................................................................................ 5 Ejercicio 3 .......................................................... 5 Anlisis del Problema .................................................................................................................. 5 Tabla de Variables ....................................................................................................................... 5 Algoritmo..................................................................................................................................... 5 Cdigo en Visual Basic 2008 ........................................................................................................ 6 Ejercicio 4 .......................................................... 6 Anlisis del Problema .................................................................................................................. 7 Tabla de Variables ....................................................................................................................... 7 Algoritmo..................................................................................................................................... 7 Cdigo en Visual Basic 2008 ........................................................................................................ 8 Ejercicio 5 .......................................................... 8 Anlisis del Problema .................................................................................................................. 9 Tabla de Variables ....................................................................................................................... 9 Algoritmo..................................................................................................................................... 9 Cdigo en Visual Basic 2008 ...................................................................................................... 10 Ejercicio 6 ......................................................... 11 Anlisis del Problema ................................................................................................................ 11 Tabla de Variables ..................................................................................................................... 11

Ejercicios del Primer Corte En VB2008


1 de feb.

Algoritmo................................................................................................................................... 11 Cdigo en Visual Basic 2008 ...................................................................................................... 12 Ejercicio 7 ......................................................... 13 Anlisis del Problema ................................................................................................................ 13 Tabla de Variables ..................................................................................................................... 13 Cdigo en Visual Basic 2008 ...................................................................................................... 14 Ejercicio 8 ......................................................... 15 Anlisis del Problema ................................................................................................................ 15 Tabla de Variables ..................................................................................................................... 15 Algoritmo................................................................................................................................... 15 Cdigo en Visual Basic 2008 ...................................................................................................... 16 Ejercicio 9 ......................................................... 17 Anlisis del Problema ................................................................................................................ 17 Tabla de Variables ..................................................................................................................... 17 Algoritmo................................................................................................................................... 17 Cdigo en Visual Basic 2008 ...................................................................................................... 18

Ejercicios del Primer Corte En VB2008


1 de feb.

Ejercicio 1
Dado un nmero, positivo, negativo o nulo, desarrolle un programa que determine e imprima el valor absoluto de dicho nmero, sabiendo que el valor absoluto de un nmero positivo o nulo es dicho nmero; mientras que el valor absoluto de un nmero negativo, es dicho nmero multiplicado por (-1).

Anlisis del Problema


Qu informacin est presente?
Un valor positivo negativo o nulo

Qu resultados exige?

Cmo lo logro?
Si el valor es negativo, se multiplica por la constante (-1) y se convierte en positivo; cualquier otro caso, se toma el nmero original

El valor sin signo

Tabla de Variables
Descripcin del dato Un valor positivo, negativo o nulo El valor absoluto del valor anterior Nombre de la Variable X Y Tipo de Dato O Entero Real O Lgico O Cadena O Entero Real O Lgico O Cadena

Algoritmo
Algoritmo once Variables X, Y: Real Inicio Imprimir "Numero a determinar el valor absoluto:" Leer X Si X < 0 entonces Y <- X * (-1) sino Y <- X finsi Imprimirln "Valor Absoluto del Numero es:", Y Fin

Cdigo en Visual Basic 2008


Module Module1 Sub Main() 'Declaracin de Variables Dim X, Y As Double 'Lectura de los datos Console.WriteLine("Numero a determinar el valor absoluto:") X = Console.ReadLine() 'proceso para determinar los resultados If X < 0 Then

Ejercicios del Primer Corte En VB2008


1 de feb. Y = X * (-1) Else Y = X End If 'impresin de resultados Console.WriteLine("Valor Absoluto del Numero es:" & Y) 'instruccin para que la ventana de ejecucin quede activa hasta que el usuario no pulse una tecla Console.ReadKey() End Sub End Module

Ejercicio 2
Dados dos nmeros cualesquiera, desarrolle un programa que imprima el mayor de los dos nmeros.

Anlisis del Problema


Qu informacin est presente?
1. Un primer valor (A) 2. Un segundo Valor (B)

Qu resultados exige?
Imprimir el mayor valor entre ambos nmeros

Cmo lo logro?
Si A > B Mayor es A, sino, Si B > A Mayor es B, sino, son iguales

Tabla de Variables
Descripcin del dato Un primer valor Un segundo valor Nombre de la Variable A B Tipo de Dato O Entero Real O Lgico O Cadena O Entero Real O Lgico O Cadena

Algoritmo
Algoritmo doce Variables A, B: Real Inicio Imprimir "Primer Valor:" Leer A Imprimir "Segundo Valor:" Leer B Si A > B entonces Imprimir A sino Si B > A entonces Imprimir B sino Imprimir "Son iguales los valores" finsi finsi Fin

Ejercicios del Primer Corte En VB2008


1 de feb.

Cdigo en Visual Basic 2008


Module Module1 Sub Main()

'Declaracin de Variables Dim A, B As Double 'Lectura de los datos Console.Write("Primer Valor:") A = Console.ReadLine Console.Write("Segundo Valor:") B = Console.ReadLine 'proceso para determinar los resultados e impresin If A > B Then Console.WriteLine("El mayor valor es " & A) Else If B > A Then Console.WriteLine("El mayor valor es " & B) Else Console.WriteLine("Son iguales los valores") End If End If 'instruccin para que la ventana de ejecucin quede activa hasta que el usuario no pulse una tecla Console.ReadKey() End Sub End Module

Ejercicio 3
Dados dos nmeros cualesquiera, desarrolle un programa que imprima los valores ordenados en forma progresiva creciente, es decir, primero el menor de ellos y luego el otro.

Anlisis del Problema


Qu informacin est presente?
1. Un primer valor (A) 2. Un segundo Valor (B)

Qu resultados exige?
Imprimir los valores en secuencia creciente

Cmo lo logro?
Si A > B Imprime B, A, sino, imprime A, B (incluye el caso de iguales)

Tabla de Variables
Descripcin del dato Un primer valor Un segundo valor Nombre de la Variable A B Tipo de Dato O Entero Real O Lgico O Cadena O Entero Real O Lgico O Cadena

Algoritmo
Algoritmo trece Variables A, B: Real Inicio

Ejercicios del Primer Corte En VB2008


1 de feb. Imprimir "Primer Valor:" Leer A Imprimir "Segundo Valor:" Leer B Si A > B entonces Imprimir B, " ", A sino Imprimir A, " ", B finsi Fin

Cdigo en Visual Basic 2008


Module Module1 Sub Main()

'Declaracin de Variables Dim A, B As Double 'Lectura de los datos Console.Write("Primer Valor:") A = Console.ReadLine Console.Write("Segundo Valor:") B = Console.ReadLine 'proceso para determinar los resultados e impresin If A > B Then Console.WriteLine(B, " ", A) Else Console.WriteLine(A, " ", B) End If 'instruccin para que la ventana de ejecucin quede activa hasta que el usuario no pulse una tecla Console.ReadKey() End Sub

End Module

Ejercicio 4
a*x + b*y = c Un sistema de ecuaciones lineales d*x + e*y = f

c*e - b*f a*f - c*d Se puede resolver con las siguientes frmulas: x= y= a*e - b*d a*e - b*d Desarrolle un programa que lea los coeficientes de ambas ecuaciones (a, b, c, d, e y f) y determine los valores de x e y. Cuidado: evite la divisin por cero e imprima el mensaje adecuado.

Ejercicios del Primer Corte En VB2008


1 de feb.

Anlisis del Problema


Qu informacin est presente?
1. 2. 3. 4. 5. 6. Coeficiente de X en la 1ra Ec. Coeficiente de Y en la 1ra Ec Trmino independiente 1ra Ec Coeficiente de X en la 2da Ec Coeficiente de Y en la 2da Ec Trmino independiente 2da Ec

Qu resultados exige?

Cmo lo logro?

El valor de X y el valor de Y que hacen cumplir al mismo tiempo ambas ecuaciones

Si ae -bd 0 c*e - b*f a*f - c*d x=a*e - b*d y=a*e - b*d

Tabla de Variables
Descripcin del dato Coeficiente a Coeficiente b Coeficiente c Coeficiente d Coeficiente e Coeficiente f Denominador de la Solucin Solucin para X Solucin para Y Nombre de la Variable A B C D E F Deno X Y Tipo de Dato O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena

Algoritmo
Algoritmo catorce Variables a,b,c,d,e,f,deno,x,y: Real Inicio Imprimir "Coeficiente a:" Leer a Imprimir "Coeficiente b:" Leer b Imprimir "Coeficiente c:" Leer c Imprimir "Coeficiente d:" Leer d Imprimir "Coeficiente e:" Leer e Imprimir "Coeficiente f:" Leer f deno <- a*e - b*d si deno = 0 entonces ; si el denominador es cero, no existe solucion Imprimir "No tiene solucion el sistema de ecuaciones" sino x <- (c*e-b*f)/deno y <- (a*f-c*d)/deno Imprimirln "X=",x Imprimirln "Y=",y finsi Fin

Ejercicios del Primer Corte En VB2008


1 de feb.

Cdigo en Visual Basic 2008


Module Module1 Sub Main()

'Declaracin de Variables Dim a, b, c, d, e, f, deno, x, y As Double 'Lectura de los datos Console.Write("Coeficiente a:") a = Console.ReadLine Console.Write("Coeficiente b:") `b= Console.ReadLine Console.Write("Coeficiente c:") c = Console.ReadLine Console.Write("Coeficiente d:") d = Console.ReadLine Console.Write("Coeficiente e:") e = Console.ReadLine Console.Write("Coeficiente f:") f = Console.ReadLine 'proceso para determinar los resultados e impresin deno = a * e - b * d If deno = 0 Then ' si el denominador es cero, no existe solucion Console.WriteLine("No tiene solucion el sistema de ecuaciones") Else x = (c * e - b * f) / deno y = (a * f - c * d) / deno Console.WriteLine("La solucin del sistema de ecuaciones planteado es") Console.WriteLine("X=", x) Console.WriteLine("Y=", y) End If 'instruccin para que la ventana de ejecucin quede activa hasta que el usuario no pulse una tecla Console.ReadKey() End Sub End Module

Ejercicio 5
La distancia entre dos puntos de coordenadas cartesianas (X1, Y1) y (X2, Y2) se determina como . Dadas las coordenadas cartesianas de tres puntos, desarrolle un programa que

determine e imprima si el tringulo que forman es equiltero (tres lados iguales), issceles (slo dos lados iguales) o escaleno (tres lados diferentes). Determine e imprima, adems, el valor del rea que encierra segn el mtodo del semipermetro.

Ejercicios del Primer Corte En VB2008


1 de feb.

Anlisis del Problema


Qu informacin est presente?
1. 2. 3. 4. 5. 6. Abscisa del Punto 1 Ordenada del Punto 1 Abscisa del Punto 2 Ordenada del Punto 2 Abscisa del Punto 3 Ordenada del Punto 3

Qu resultados exige?
1. Un mensaje impreso que indique si el tringulo es equiltero, issceles o escaleno 2. El rea que encierra el tringulo segn su semipermetro

Cmo lo logro?
1. Calcular las longitudes de los lados del tringulo (L1, L2, L3) 2. Verificar la forma e imprimir el mensaje correspondiente 3. Semipermetro = (L1+L2+L3)/3 4. rea =(S(SL1) (SL2) (SL3))^0.5

Tabla de Variables
Descripcin del dato Abscisa del Punto 1 Ordenada del Punto 1 Abscisa del Punto 2 Ordenada del Punto 2 Abscisa del Punto 3 Ordenada del Punto 3 Longitud P1 P2 Longitud P2 P3 Longitud P3 P1 Semipermetro rea segn Semipermetro Abscisa del Punto 1 Ordenada del Punto 1 Abscisa del Punto 2 Ordenada del Punto 2 Abscisa del Punto 3 Ordenada del Punto 3 Longitud P1 P2 Nombre de la Variable X1 Y1 X2 Y2 X3 Y3 L1 L2 L3 S Area X1 Y1 X2 Y2 X3 Y3 L1 Tipo de Dato O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Entero Real O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Lgico O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena O Cadena

Algoritmo
Algoritmo quince Variables X1,Y1,X2,Y2,X3,Y3,L1,L2,L3,S,Area: Real Inicio Imprimir "Abscisa del Punto 1:" Leer X1 Imprimir "Ordenada del Punto 1:" Leer Y1 Imprimir "Abscisa del Punto 2:" Leer X2 Imprimir "Ordenada del Punto 2:" Leer Y2 Imprimir "Abscisa del Punto 3:" Leer X3 Imprimir "Ordenada del Punto 3:" Leer Y3 ; Distancia Punto 1 al Punto 2 (L1) L1 <- ( (X2-X1)*(X2-X1) + (Y2-Y1)*(Y2-Y1) )^0.5 ; Distancia Punto 2 al Punto 3 (L2) L2 <- ( (X3-X2)*(X3-X2) + (Y3-Y2)*(Y3-Y2))^0.5 ; Distancia Punto 3 al Punto 1 (L3)

Ejercicios del Primer Corte En VB2008


1 de feb. L3 <- ( (X1-X3)*(X1-X3) + (Y1-Y3)*(Y1-Y3))^0.5 ; Verificar tipo de Triangulo ; L1=L2=L3 -> Equilatero, sino ; L1=L2 o L1=L3 o L2=L3 -> Isosceles, sino ; Escaleno Si (L1=L2) AND (L2=L3) entonces Imprimirln "Forman un Triangulo Equilatero" sino Si (L1=L2) OR (L1=L3) OR (L2=L3) entonces Imprimirln "Forman un Triangulo Isosceles" sino Imprimirln "Forman un Triangulo Escaleno" finsi finsi S <- (L1+L2+L3)/2 Area <- (S*(S-L1)*(S-L2)*(S-L3))^0.5 Imprimirln "Area del Triangulo=",Area Fin

Cdigo en Visual Basic 2008


Module Module1 Sub Main() 'Declaracin de Variables Dim X1, Y1, X2, Y2, X3, Y3, L1, L2, L3, S, Area As Double 'Lectura de los datos Console.Write("Abscisa del Punto 1:") X1 = Console.ReadLine Console.Write("Ordenada del Punto 1:") Y1 = Console.ReadLine Console.Write("Abscisa del Punto 2:") X2 = Console.ReadLine Console.Write("Ordenada del Punto 2:") Y2 = Console.ReadLine Console.Write("Abscisa del Punto 3:") X3 = Console.ReadLine Console.Write("Ordenada del Punto 3:") Y3 = Console.ReadLine 'proceso para determinar los resultados e impresin ' Distancia Punto 1 al Punto 2 (L1) L1 = ((X2 - X1) * (X2 - X1) + (Y2 - Y1) * (Y2 - Y1)) ^ 0.5 ' Distancia Punto 2 al Punto 3 (L2) L2 = ((X3 - X2) * (X3 - X2) + (Y3 - Y2) * (Y3 - Y2)) ^ 0.5 ' Distancia Punto 3 al Punto 1 (L3) L3 = ((X1 - X3) * (X1 - X3) + (Y1 - Y3) * (Y1 - Y3)) ^ 0.5 ' Verificar tipo de Triangulo ' L1=L2=L3 -> Equilatero, sino ' L1=L2 o L1=L3 o L2=L3 -> Isosceles, sino ' Escaleno

10

Ejercicios del Primer Corte En VB2008


1 de feb. If (L1 = L2) And (L2 = L3) Then Console.WriteLine("Forman un Triangulo Equilatero") Else If (L1 = L2) Or (L1 = L3) Or (L2 = L3) Then Console.WriteLine("Forman un Triangulo Isosceles") Else Console.WriteLine("Forman un Triangulo Escaleno") End If End If S = (L1 + L2 + L3) / 2 Area = (S * (S - L1) * (S - L2) * (S - L3)) ^ 0.5 Console.WriteLine("Area del Triangulo=" & Area) 'instruccin para que la ventana de ejecucin quede activa hasta que el usuario no pulse una tecla Console.ReadKey() End Sub End Module

Ejercicio 6
Dados tres valores A, B y C, desarrolle un programa que, sin utilizar operadores lgicos, imprima el valor central y un mensaje que indique en que variable est contenido. Por ejemplo, si A=9, B=3 y C= 2, el valor central es 2 y est contenido en la variable C.

Anlisis del Problema


Qu informacin est presente?
1. El valor A 2. El valor B 3. El valor C

Qu resultados exige?

Cmo lo logro?

Imprimir el valor central de los tres

Verificando las relaciones entre ellos

Tabla de Variables
Descripcin del dato El valor A El valor B El valor C Nombre de la Variable A B C Tipo de Dato O Entero Real O Lgico O Cadena O Entero Real O Lgico O Cadena O Entero Real O Lgico O Cadena

Algoritmo
Algoritmo dieciseis Variables A, B, C: Real Inicio Imprimir "Valor de A:" Leer A Imprimir "Valor de B:" Leer B

11

Ejercicios del Primer Corte En VB2008


1 de feb. Imprimir "Valor de C:" Leer C ; A <= B <= C C <= B <= A -> Valor B es central ; B <= A <= C C <= A <= B -> Valor A es central ; A <= C <= B B <= C <= A -> Valor C es central ; Como no se pueden usar AND u OR, solo se puede hacer una pregunta a la vez Si A <= B entonces Si B <= C entonces Imprimir "Valor Central es B:",B Sino ; A <= B, B > C Si A <= C entonces ; A<C<B Imprimir "Valor Central es C:",C Sino ; C<A<B Imprimir "Valor Central es A:",A finsi finsi sino ; B<A Si C <= B entonces ; C<B<A Imprimir "Valor Central B:",B Sino ; B<A, B<C Si A<=C entonces ; B<A<C Imprimir "Valor Central A:",A Sino ; B<C<A Imprimir "Valor Central C:",C finsi finsi finsi Fin

Cdigo en Visual Basic 2008


Module Module1 Sub Main() 'Declaracin de Variables Dim A, B, C As Double 'Lectura de los datos Console.Write("Valor de A:") A = Console.ReadLine Console.Write("Valor de B:") B = Console.ReadLine Console.Write("Valor de C:") C = Console.ReadLine 'proceso para determinar los resultados e ' A <= B <= C C <= B <= A -> Valor B ' B <= A <= C C <= A <= B -> Valor A es ' A <= C <= B B <= C <= A -> Valor C es 'Como no se pueden usar AND u OR, solo se la vez If A <= B Then impresin es central central central puede hacer una pregunta a

12

Ejercicios del Primer Corte En VB2008


1 de feb. If B <= C Then Console.WriteLine("Valor Central es B:" & B) Else ' A <= B, B > C If A <= C Then ' A<C<B Console.WriteLine("Valor Central es C:" & C) Else ' C<A<B Console.WriteLine("Valor Central es A:" & A) End If End If ' B<A If C <= B Then ' C<B<A Console.WriteLine("Valor Central B:" & B) Else ' B<A, B<C If A <= C Then ' B<A<C Console.WriteLine("Valor Central A:" & A) Else ' B<C<A Console.WriteLine("Valor Central C:" & C) End If End If End If Else 'instruccin para que la ventana de ejecucin quede activa hasta que el usuario no pulse una tecla Console.ReadKey() End Sub End Module

Ejercicio 7
Dados tres valores A, B y C, desarrolle un programa que, utilizando operadores lgicos, imprima el valor central y un mensaje que indique en que variable est contenido. Por ejemplo, si A=9, B=3 y C= 2, el valor central es 2 y est contenido en la variable C.

Anlisis del Problema


Qu informacin est presente?
4. El valor A 5. El valor B 6. El valor C

Qu resultados exige?

Cmo lo logro?

Imprimir el valor central de los tres

Verificando las relaciones entre ellos

Tabla de Variables
Descripcin del dato El valor A El valor B El valor C Nombre de la Variable A B C Tipo de Dato O Entero Real O Lgico O Cadena O Entero Real O Lgico O Cadena O Entero Real O Lgico O Cadena

13

Ejercicios del Primer Corte En VB2008


1 de feb.

Algoritmo diecisiete Variables A, B, C: Real Inicio Imprimir "Valor de A:" Leer A Imprimir "Valor de B:" Leer B Imprimir "Valor de C:" Leer C Si (A<=B) and (B<=C) or (C<=B) and (B<=A) entonces Imprimir "Valor Central es B:",B sino Si (B<=A) and (A<=C) or (C<=A) and (A<=B) entonces Imprimir "Valor Central es A:",A sino Imprimir "Valor Central es C:",C finsi finsi Fin

Cdigo en Visual Basic 2008


Module Module1 Sub Main() 'Declaracin de Variables Dim A, B, C As Double 'Lectura de los datos Console.Write("Valor de A:") A = Console.ReadLine Console.Write("Valor de B:") B = Console.ReadLine Console.Write("Valor de C:") C = Console.ReadLine 'proceso para determinar los resultados e impresin ' A <= B <= C C <= B <= A -> Valor B es central ' B <= A <= C C <= A <= B -> Valor A es central ' A <= C <= B B <= C <= A -> Valor C es central If (A <= B) And (B <= C) Or (C <= B) And (B <= A) Then Console.WriteLine("Valor Central es B:" & B) Else If (B <= A) And (A <= C) Or (C <= A) And (A <= B) Then Console.WriteLine("Valor Central es A:" & A) Else Console.WriteLine("Valor Central es C:" & C) End If End If 'instruccin para que la ventana de ejecucin quede activa hasta que el usuario no pulse una tecla Console.ReadKey() End Sub End Module

14

Ejercicios del Primer Corte En VB2008


1 de feb.

Ejercicio 8
Dada las coordenadas de un punto en el plano cartesiano, desarrolle un programa que, sin utilizar operadores lgicos, determine e imprima en que cuadrante est, o si est en el eje X, o en el eje Y, o el origen del plano cartesiano.

Anlisis del Problema


Qu informacin est presente? Qu resultados exige?
1. 2. 3. 4. 5. 6. 7.

Cmo lo logro?
Cuadrante I: (X>0) y (Y>0) Cuadrante II: (X <0) y (Y > 0) Cuadrante III: (X<0) y (Y <0) Cuadrante IV: (X>0) y (Y<0) Eje X: (Y=0) y (X0) Eje Y: (X=0) y (Y0) Origen (X=0) y (Y=0)

1. 2.

Abscisa del punto Ordenada del punto

Imprimir una constante literal que indique en que cuadrante del plano cartesiano est, o en que eje, o si est en el origen

Tabla de Variables
Descripcin del dato Abscisa del punto Ordenada del punto Nombre de la Variable X Y Tipo de Dato O Entero Real O Lgico O Cadena O Entero Real O Lgico O Cadena

Algoritmo
Algoritmo dieciocho Variables X, Y: Real Inicio Imprimir "Abscisa del Punto:" Leer X Imprimir "Ordenada del Punto:" Leer Y ;Cuadrante I: (X>0) y (Y>0) ;Cuadrante II: (X <0) y (Y > 0) ;Cuadrante III: (X<0) y (Y <0) ;Cuadrante IV: (X>0) y (Y<0) ;Eje X: (Y=0) y (X<>0) ;Eje Y: (X=0) y (Y<>0) ;Origen (X=0) y (Y=0) Si X > 0 entonces ;Cuadrante I o IV o Eje Y Si Y > 0 entonces Imprimir "Primer Cuadrante" Sino Si Y < 0 entonces Imprimir "Cuarto Cuadrante" Sino Imprimir "Eje Y" Finsi Finsi Sino Si X < 0 entonces ;Cuadrante II o III, o Eje X Si Y > 0 entonces

15

Ejercicios del Primer Corte En VB2008


1 de feb. Imprimir "Segundo Cuadrante" Sino Si Y < 0 entonces Imprimir "Tercer Cuadrante" Sino Imprimir "Eje X" Finsi Finsi Sino Si Y = 0 entonces Imprimir "Origen de Coordenadas" Sino Imprimir "Eje Y" FinSi Finsi Finsi Fin

Cdigo en Visual Basic 2008


Module Module1 Sub Main() 'Declaracin de Variables Dim x, y As Double 'Lectura de los datos Console.Write("Abscisa: ") x = Console.ReadLine Console.Write("Ordenada:") y = Console.ReadLine 'proceso para determinar los resultados e impreifn 'Cuadrante I: (X>0) y (Y>0) 'Cuadrante II: (X <0) y (Y > 0) 'Cuadrante III: (X<0) y (Y <0) 'Cuadrante IV: (X>0) y (Y<0) 'Eje X: (Y=0) y (X<>0) 'Eje Y: (X=0) y (Y<>0) 'Origen (X=0) y (Y=0) If x > 0 Then 'Cuadrante I o IV o Eje Y If y > 0 Then Console.WriteLine("Primer Cuadrante") Else If y < 0 Then Console.WriteLine("Cuarto Cuadrante") Else Console.WriteLine("Eje Y") End If End If Else If x < 0 Then 'Cuadrante II o III o Eje X If y > 0 Then Console.WriteLine("Segundo Cuadrante") Else If y < 0 Then Console.WriteLine("Tercer Cuadrante")

16

Ejercicios del Primer Corte En VB2008


1 de feb. Else Console.WriteLine("Eje X") End If End If Else If y = 0 Then Console.WriteLine("Origen de Coordenadas") Else Console.WriteLine("Eje Y") End If End If End If 'instruccin para que la ventana de ejecucin quede activa hasta que el usuario no pulse una tecla Console.ReadKey() End Sub End Module

Ejercicio 9
Dada las coordenadas de un punto en el plano cartesiano, desarrolle un programa que, utilizando operadores lgicos, determine e imprima en que cuadrante est, o si est en el eje X, o en el eje Y, o el origen del plano cartesiano.

Anlisis del Problema


Qu informacin est presente? Qu resultados exige?
8. 9. 10. 11. 12. 13. 14.

Cmo lo logro?
Cuadrante I: (X>0) y (Y>0) Cuadrante II: (X <0) y (Y > 0) Cuadrante III: (X<0) y (Y <0) Cuadrante IV: (X>0) y (Y<0) Eje X: (Y=0) y (X0) Eje Y: (X=0) y (Y0) Origen (X=0) y (Y=0)

3. 4.

Abscisa del punto Ordenada del punto

Imprimir una constante literal que indique en que cuadrante del plano cartesiano est, o en que eje, o si est en el origen

Tabla de Variables
Descripcin del dato Abscisa del punto Ordenada del punto Nombre de la Variable X Y Tipo de Dato O Entero Real O Lgico O Cadena O Entero Real O Lgico O Cadena

Algoritmo
Algoritmo diecinueve Variables X, Y: Real Inicio Imprimir "Abscisa del Punto:" Leer X Imprimir "Ordenada del Punto:" Leer Y

17

Ejercicios del Primer Corte En VB2008


1 de feb. ;Cuadrante I: (X>0) y (Y>0) ;Cuadrante II: (X<0) y (Y > 0) ;Cuadrante III: (X<0) y (Y <0) ;Cuadrante IV: (X>0) y (Y<0) ;Eje X: (Y=0) y (X<>0) ;Eje Y: (X=0) y (Y<>0) ;Origen (X=0) y (Y=0) Si (X>0) and (Y>0) entonces Imprimir "Primer Cuadrante" Sino Si (X<0) and (Y>0) entonces Imprimir "Segundo Cuadrante" Sino Si (X<0) and (Y<0) entonces Imprimir "Tercer Cuadrante" Sino Si (X>0) and (Y<0) entonces Imprimir "Cuarto Cuadrante" Sino Si (Y=0) and (X>0) entonces Imprimir "Eje X" Sino Si (X=0) and (Y<>0) entonces Imprimir "Eje Y" sino Imprimir "Origen de Coordenadas" Finsi Finsi Finsi Finsi Finsi Finsi Fin

Cdigo en Visual Basic 2008


Module Module1 Sub Main() 'Declaracin de Variables Dim x, y As Double 'Lectura de los datos Console.Write("Abscisa: ") x = Console.ReadLine Console.Write("Ordenada:") y = Console.ReadLine 'proceso para determinar los resultados e impreifn 'Cuadrante I: (X>0) y (Y>0) 'Cuadrante II: (X <0) y (Y > 0) 'Cuadrante III: (X<0) y (Y <0) 'Cuadrante IV: (X>0) y (Y<0) 'Eje X: (Y=0) y (X<>0) 'Eje Y: (X=0) y (Y<>0) 'Origen (X=0) y (Y=0) If (x > 0) And (y > 0) Then Console.WriteLine("Primer Cuadrante")

18

Ejercicios del Primer Corte En VB2008


1 de feb. Else If (x < 0) And (y > 0) Then Console.WriteLine("Segundo Cuadrante") Else If (x < 0) And (y < 0) Then Console.WriteLine("Tercer Cuadrante") Else If (x > 0) And (y < 0) Then Console.WriteLine("Cuarto Cuadrante") Else If (y = 0) And (x > 0) Then Console.WriteLine("Eje X") Else If (x = 0) And (y <> 0) Then Console.WriteLine("Eje Y") Else Console.WriteLine("Origen de Coordenadas") End If End If End If End If End If End If 'instruccin para que la ventana de ejecucin quede activa hasta que el usuario no pulse una tecla Console.ReadKey() End Sub End Module

19