You are on page 1of 31

1 Microsoft Excel Avanzado

Manual del Estudiante

INTRODUCCIN A EXCEL 2013 BSICO


A diferencia de versiones anteriores, al abrir Excel 2013 observars la pantalla inicio la cual nos permite realizar diferentes acciones como abrir los libros de Excel que hayan sido utilizados recientemente o crear un nuevo libro ya sea en blanco o basado en alguna plantilla.

1. En la esquina superior izquierda se encuentra la barra de herramientas de acceso rpido que nos permite colocar los comandos que deseamos tener siempre disponibles en dicha rea. De manera predeterminada tenemos el botn Guardar y los comandos Hacer y Deshacer. 2. La cinta de opciones es precisamente donde se encuentran la gran mayora de los comandos de Excel que nos ayudan a trabajar con la herramienta. Los comandos estn organizados en fichas y de manera predeterminada Excel 2013 muestra 7 fichas: Inicio, Insertar, Diseo de pgina, Frmulas, Datos, Revisar y Vista. Al lado izquierdo de la ficha Inicio se encuentra el botn Archivo que nos llevar a la vista Backstage donde encontraremos los comandos necesarios para guardar, abrir o imprimir un libro as como algunos comandos adicionales. 3. Debajo de la cinta de opciones se encuentra la barra de frmulas que es de suma importancia ya que nos permite ingresar y editar las frmulas para realizar clculos con los datos. As mismo en esta rea tenemos el cuadro de nombres que siempre muestra la direccin de la celda que est actualmente seleccionada. 4. El rea de trabajo de una hoja est representada por columnas y filas. Las columnas estn identificadas por letras y las filas por nmeros y en esta rea es donde colocamos nuestros datos. De manera predetermina Excel 2013 crea un libro con una sola hoja y cuyo nombre se puede encontrar en la etiqueta ubicada en la parte inferior izquierda del rea de trabajo. Junto a dicha etiqueta se encuentra un botn con el smbolo + que nos permite crear nuevas hojas. 5. En la parte inferior de la ventana de Excel 2013 se encuentra la barra de estado donde la herramienta mostrar mensajes de importancia y en su extremo derecho encontramos los botones para cambiar la manera en la que visualizamos un libro as como el nivel de acercamiento de la hoja.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

2 Microsoft Excel Avanzado


Manual del Estudiante

Escribir datos
Tenga en cuenta las siguientes especificaciones:

Controlador de relleno: pequeo cuadro verde situado en la esquina de la seleccin, cuando se le


seala con el puntero cambia a una cruz negra.

Referencia a una celda: se indica primero la letra de la columna seguida del nmero de fila.
Columna A Columna B

Celda A1 Celda Activada Fila 4

Celda C1

Celda A3
Los tipos de datos que aceptan las celdas son:

Controlador de Relleno

Nmeros: las celdas pueden aceptar nmeros reales, fechas como nmeros etc., los datos
se ubican a la derecha. Texto: las celdas almacenan caracteres o texto que se ubican a la izquierda.

A este proceso tambin se le conoce como captura o ingreso de informacin.

Ingreso de Datos: Numricos, Texto, Fecha y Hora

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

3 Microsoft Excel Avanzado


Manual del Estudiante

Seleccin de una nueva celda activada


Despus de ingresar un dato a una celda al presionar Enter automticamente se seleccionar una celda contigua, que por defecto es la de abajo. Esta configuracin se puede cambiar de la siguiente forma: 1. Haga Clic en Archivo

2. Haga clic en Opciones

3. Haga clic en la lista Avanzadas

4. En opciones de edicin, en la casilla despus de presionar entrar, Seleccionamos: Abajo, Arriba, Derecha e Izquierda.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

4 Microsoft Excel Avanzado


Manual del Estudiante

Para escribir en dos lneas dentro de una celda


Seleccione una celda, escriba el texto de la primera lnea y luego presione la combinacin Alt + Enter, luego escriba la siguiente lnea.

Celda que hace el efecto de Alt +Enter

Insertar
Muchas veces es necesarios cambiar la ubicacin de las celdas, columnas y filas en una hoja, ya sea para insertar varios datos. Una vez insertados los datos puede hacer las siguientes inserciones: Celdas desplazndose hacia la derecha Celdas desplazndose hacia abajo Filas Columnas

Insertar celdas desplazndose hacia la derecha


1. Seleccionamos la celda A3, Clic botn Derecho.

2. Del men contextual, haga Clic en Insertar, activa la primera opcin del cuadro presentado, aceptar.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

5 Microsoft Excel Avanzado


Manual del Estudiante

3. Resultado final

Insertar celdas desplazando hacia abajo


Hacer los dos primeros pasos del ejercicio anterior, pero ahora activa la segunda opcin del men contextual Insertar.

Insertar una columna


Seleccione la columna B, clic botn derecho, del men contextual seleccione Insertar.

Eliminar una columna


De la misma forma como se inserta una columna, con la diferencia en el men contextual en vez de seleccionar insertar seleccionamos eliminar.

Rellenar series
Existen ocasiones en que se desea copiar la informacin de una celda hacia otras que se encuentran en forma contigua a esta, arriba, abajo, izquierda o derecha, usaremos el controlador de relleno para rellenar un grupo de celdas. 1. 2. 3. 4. 5. Seleccionamos la primera celda ejemplo celda D1 Escriba el primer dato, ejemplo UANCV-PUNO Lleve el puntero al controlador de relleno Haga arrastre hasta la celda que desea Clic en alguna celda fuera de la serie

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

6 Microsoft Excel Avanzado


Manual del Estudiante

Insertar objetos desde el Word Art


Seleccione de la cinta de opciones Insertar, el men Texto y seleccione Word Art

Formato de filas y columnas Ancho de columnas y filas


Por defecto el ancho de una columna es 10.71 y de una fila es de 15, para poder modificar se debe de realizar los siguientes procedimientos.

El Ratn: arrastre el borde situado a la derecha del encabezado de la columna hasta que
esta tenga el ancho que desea.

Cuadro de dialogo: Vamos a la cinta de opciones, seleccionamos Inicio luego formato en


celdas, seleccionamos ancho de columna.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

7 Microsoft Excel Avanzado


Manual del Estudiante

Cinta de Opciones. Inicio modificar tamao

Ajustar el ancho al Contenido


De la misma forma al Cuadro de Dialogo Vamos a la cinta de opciones, seleccionamos Inicio luego formato en celdas, seleccionamos Autoajustar ancho de Columna.

Formato condicional
Si una celda contiene los resultados de una formula u otros valores que desea evaluar, pueden identificarse las celdas utilizando formatos condicionales, como color, negrita, etc. Seleccionamos las celdas B3:B8, luego seleccionamos Inicio. Formato Condicional en Estilos, elegir Resaltar Reglas de Celdas, seleccionamos Entre.

En la Ventana Entre Generamos Condiciones.

Resultado Final.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

8 Microsoft Excel Avanzado


Manual del Estudiante

Bordes, sombreados y alineacin


Presionamos la combinacin Ctrl + 1. Acceso rpido. Seleccionamos las celdas a Modificar, Clic botn derecho y seleccionamos de la lista de opciones Formato de Celdas.

FORMULAS

Formulas
Una frmula es una expresin matemtica para realizar clculos bsicos y complejos. La estructura o el orden de los elementos de una formula determina el resultado final el clculo. Celda: permite guardar distintos valores Constante: es el valor que no cambia. Los operadores: especifican el tipo de clculo con los elementos de una formula.

Operadores aritmticos Operador aritmtico + (Signo Mas) -(Signo Menos) *(Asterisco) /(Barra oblicua) %(Signo de Porcentaje) ^(Acento Circunflejo) Significado suma Resta Negacin Multiplicacin Divisin Porcentaje Exponente 3+3 3-3 -3 3*3 3/2 20% 3^2 Ejemplo

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

9 Microsoft Excel Avanzado


Manual del Estudiante

Escribir formulas empleando Constantes


En cualquier formula el carcter inicial es el signo =, seguido de la expresin seguido de un Enter. Seleccione la celda A1, digite la siguiente formula.

Formula Utilizando Celdas


1. Ejemplo 1.
Se desea calcular el salario que va a recibir un trabajador que realiza sus labores en 30 das, (celda C4) y le pagan por da 12 soles (Celda C5), calcular la multiplicacin Jornal * nmero de das.

Formula: =C3*C4

Para el uso del porcentaje se escribe directamente con el signo %, o tambin se puede escribir como nmero y aplicar formato de Celdas. En el ejemplo anterior se requiere calcular la bonificacin del 15% de su Salario y un descuento del 3% de la suma del salario + la bonificacin, obtener el neto que va a recibir el trabajador.

=15%*C5 =3%*(C5+C6) =C5+C6-C7

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

1 Microsoft Excel Avanzado


Manual del Estudiante

Frmulas que vinculan celdas


Escriba el siguiente cuadro

Coloque el cursor en la celda E5 Dar clic derecho y seleccione copiar Colocar el cursor en la celda C8 Hacer clic derecho y seleccionar pegado especial Haga clic en pegar vnculo Nota. Si modificamos la celda E5: automticamente cambia la celda C8

Referencias
Referencias relativas
Cuando se crea una formula, normalmente las referencias de celdas o de rango se basan en su posicin relativa respecto a la celda que contiene la formula. Ejemplo: la celda B2 contiene la frmula de =A1, Excel buscara el valor una celda por encima.

Referencias absolutas
Las referencias absolutas identifican las celdas por sus posiciones fijas en la hoja de clculo.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

10

1 Microsoft Excel Avanzado


Manual del Estudiante

Ejemplo: si la formula multiplica la celda C4 por la celda D1 =C4*$D$1 y puede copiarse la formula en otra celda.

Referencias Mixtas
Son donde se combinan las referencias Relativas y Absolutas, donde se pueden tener las siguientes combinaciones: Fila Relativa: Columna Absoluta o Fila Absoluta: Columna Relativa. =$A1. Fila A es Absoluta, Columna 1 es Relativa =A$1. Fila A es Relativa, Columna 1 es Absoluta

Funciones Aritmticas y Estadsticas


Definicin
Las funciones son formulas predefinidas que ejecutan clculos utilizando valores especficos, denominados argumentos, por ejemplo SUMA y MAX.

Argumentos
Pueden ser Texto, Valores Lgicos como verdadero y falso, matrices, constantes, formulas u otras funciones.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

11

1 Microsoft Excel Avanzado


Manual del Estudiante

Estructura
La estructura de una funcin comienza por el Nombre de la funcin, seguido por un parntesis de apertura, los argumentos de la funcin separada por comas y un parntesis de cierre.

=SUMA(D2,E2:E8,10,20)
Funciones elementales
Tenemos el siguiente cuadro de notas de alumnos:

Funcin. SUMA
Sintaxis. SUMA(numero1;numero2)Ejemplos: =SUMA(3;2;verdadero) = 6 =SUMA(A1;B1;2) = 2

Funcin PROMEDIO
Sintaxis. PROMEDIO(numero1;numero2) ejemplos: Si A1:A5 se denominan puntos y contienen los nmeros 10,7,9,27 y 2:

=PROMEDIO(A1:A5) = 11 =PROMEDIO(puntos) = 11 =PROMEDIO(A1:A5;5) = 10 Devuelve la media aritmtica de los argumentos.


12

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

1 Microsoft Excel Avanzado


Manual del Estudiante

Funcin MAX
Sintaxis. MAX(numero1;numero2) ejemplos: Pregunta. Cul es el promedio final ms alto Si A1:A5 contienen los nmeros 10,7,9,27 y 2:

=MAX(A1:A5) = 27 =MAX(A1:A5;30) = 30 Devuelve el valor mximo de un conjunto de valores

Funcin MIN
Sintaxis. MIN(numero1;numero2) ejemplos: Pregunta. Cul es el promedio final mas bajo. Si A1:A5 contienen los nmeros 10,7,9,27 y 2:

=MIN(A1:A5) = 2 =MIN(A1:A5;0) = 0 Devuelve el valor minimo de un conjunto de valores

Funcin CONTAR.SI
Sintaxis. CONTAR.SI(rango;criterio) ejemplos: Pregunta. Cuantos alumnos estn aprobados en el promedio final. Supongamos que el rango A3:A6 contiene manzanas, naranjas, melocotones y manzanas respectivamente.

=CONTAR.SI(A3:A6;manzanas) = 2

Funcin SUMAR.SI
Sintaxis. SUMAR.SI(rango;criterio;rango_suma) ejemplos: Pregunta. Cuantos puntos acumulan en el promedio final los alumnos aprobados. Supongamos que el rango A1:A4 contiene los siguientes valores: 100, 200, 300 y 400, el rango B1:B4 tiene los siguientes valores: 7000, 14000, 21000 y 28000.

=SUMAR.SI(A1:A4;>160000;B1:B4) = 63000

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

13

1 Microsoft Excel Avanzado


Manual del Estudiante

Funcin CONTAR
Sintaxis. CONTAR(ref1;ref2) ejemplos: Pregunta. Cuantos alumnos tienen notas. Supongamos que el rango A1:A6 contiene los siguientes valores: 12/09/1999, 8, uancv, vacio, 23 y dos.

=CONTAR(A6:A6) = 3 =CONTAR(A4:A6) = 1 =CONTAR(A1:A6;2) = 4

Funciones lgicas, de informacin y condicionales 1. Funciones lgicas


Son importantes porque a travs de una expresin de pueden evaluar datos o valores que permitan responder a muchas interrogantes. Funciones lgicas bsicas O, Y, NO.

Funcin O
Sintaxis. O(valor_logico1;valor_logico2) devuelve verdadero si uno de los argumentos es verdadero. Pregunta. Cuantos calificaron; si aprobaron el examen1 o examen2 mayor o igual a 15.

=O(verdadero) = verdadero =O(1+1=1;2+205) = falso =O(A1:A3) = verdadero Nota. A1:A3 contiene verdadero, falso y verdadero.
14

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

1 Microsoft Excel Avanzado


Manual del Estudiante

Funcin Y
Sintaxis. O(valor_logico1;valor_logico2) devuelve verdadero si todos los argumentos son verdaderos. Pregunta. Cuantos calificaron; si aprobaron el examen1 o examen2 mayor o igual a 15.

=Y(verdadero;verdadero) = verdadero =Y(verdadero;falso) = falso =Y(2+2=4;2+3=5) = verdadero

Funcin NO
Sintaxis. NO(valor_logico) invierte el valor lgico del argumento. =NO(falso) = verdadero =NO(1+1=2) = falso

2. Funciones de informacin
Se utiliza para determinar el tipo de dato almacenado en una celda, incluyen un grupo de funciones conocidas como ES que devuelve un valor verdadero.

Funcin ESBLANCO, CONTAR.BLANCO


Sintaxis. ESBLANCO(valor) devuelve valor lgico verdadero si es una celda vaca. Sintaxis. CONTAR.BLANCO(rango) cuenta el nmero de celdas en blanco.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

15

1 Microsoft Excel Avanzado


Manual del Estudiante

3. Funciones condicionales
Es importante porque le permite aprender a crear expresiones lgicas utilizando condiciones, adems crear funciones anidadas dentro de otras condiciones. La funcin condicional en Excel es la funcin SI, esta funcin devuelve el valor de Verdadero o Falso. Sintaxis. SI(prueba lgica;valor_si_verdadero;valor_si_falso) Ejemplo: si desea mostrar el calificativo de aprobado o desaprobado en una celda seria asi: =SI(A1>=10,5;aprobado;desaprobado)

Anidar Funciones SI
En algunos casos tendr que utilizar una funcin como uno de los argumentos de otra funcin Ejemplo: obtener el calificativo de acuerdo a este cuadro.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

16

1 Microsoft Excel Avanzado


Manual del Estudiante

Condicin 1, si D2>=15 si cumple Bueno, sino cumple Condicin 2, si D2>=10,5 si cumple Regular, sino cumple Malo Ejemplo 2. Para utilizar correctamente la funcin SI anidada debemos utilizar una funcin SI como el tercer argumento de la funcin principal. Por ejemplo, para evaluar si una celda tiene alguna de las tres letras posibles (A, B, C) podemos utilizar la siguiente frmula: =SI(A1="A",100,SI(A1="B",80,60))

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

17

1 Microsoft Excel Avanzado


Manual del Estudiante

Grficos
Puede presentar los datos de Excel en un grfico, los grficos se vincular a los datos, puede crear grficos a partir de celdas o rangos no continuos.

Cuando usar grficos de columnas (simples y 3D)


Un grfico de columna muestra los cambios que han sufrido los datos en el transcurso de un periodo. Las categoras se organizan Horizontalmente y los valores verticalmente.

Cuando usar un grfico de lneas


Un grfico de lneas muestran las tendencias a intervalos equivalentes, para evaluar proyecciones.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

18

1 Microsoft Excel Avanzado


Manual del Estudiante

Cuando usar grficos Circulares


Un grfico circular muestra el tamao proporcional de los elementos que conforman una serie de datos en funcin de la suma de los elementos.

Algunas funciones de fecha


1. Hoy
Devuelve un nmero entero que representa a la fecha del sistema Sintaxis. =HOY()

2. Ahora
Devuelve un muero que posee arte entera y decimal, muestra la fecha y hora del sistema Sintaxis. = AHORA()

3. Da
Devuelve el nmero del da del mes que corresponde a una fecha. Sintaxis. =DIA(H15)

4. Mes
Devuelve el nmero de mes que corresponde a una fecha Sintaxis. =MES("15/01/79")

5. Ao
Devuelve el ao correspondiente a la fecha. Sintaxis. =AO("15/01/79")

6. Fecha
Devuelve el nmero de serie que corresponde a una fecha. Sintaxis. =FECHA(79;1;15)

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

19

2 Microsoft Excel Avanzado


Manual del Estudiante

PRIMER EXAMEN DE EXCEL AVANZADO NIVEL BSICO


APELLIDOS Y NOMBRES:_____________________________________________________________ FECHA:_____________________ CARRERA:__________________________

1. Qu combinacin de teclas debe presionar para escribir en dos lneas de texto en la misma celda?. ________________________ 2. Cmo selecciona celdas discontinuas?. ____________________ 3. Qu debe de realizar para asignar bordes a una celda?

4. En la celda A1 se tiene un valor de 200 y en la celda B1 el 18% Calcular en la celda C1 el nuevo monto incluyendo el IGV.

5. De los resultados de las siguientes expresiones: =10+20/5+10 =10+20/(5+10) =(10+20)/(5+10) Rpta:___________ Rpta:___________ Rpta:___________

6. Qu diferencias se tienen entre las celdas Absolutas y las celdas Relativas?

7. Explique paso a paso como crear una celda vinculada paso a paso.

8. Diga Usted Cul es el resultado de la siguiente formula? =SUMA(3;2;verdadero) Rpta:____________

9. Cul es la funcin que permite Contar bajo una condicin?

10. Supongamos que el rango A1:A4 contiene los siguientes valores del computador de cuatro marcas diferentes: 800, 900, 890 y 1000 $ respectivamente. El rango B1:B4 contiene las siguientes comisiones de venta correspondientes a estos valores: 27, 14, 21 y 28 $ a cuanto es igual: =SUMAR.SI(A1:A4;>=900;B1:B4) Rpta:______________

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

20

2 Microsoft Excel Avanzado


Manual del Estudiante

11. Si A1:A5 contiene: 20,20,30,5 y 15 =PROMEDIO(A1:A5;10) =MAX(A1:A5;1000;5000) =MIN(A1:A5;100;0) Rpta:__________ Rpta:__________ Rpta:__________

12. Diga Ud. Cul es el resultado de la siguiente expresin: =O(2+3>4;2+2+2=8) es igual a ___________ =Y(2+3>4;NO(VERDADERO)) es igual a ______________ 13. Si Ud. Tiene los siguientes datos: desde A1:A4 , Enero, Febrero, Marzo; Abril, B1:B4 contiene: 1000, 2000, 1500, 2500 y C1:C4 contiene: 10%, 20%, 15%, 30%. Cul ser la respuesta en las siguientes formulas? =SI(B3>1500;C3*1000;C3) es igual a _______________ =SI(A1=Enero;C1*B1+B1;0) es igual a _______________ 14. Si Ud. En la celda A1 ingresa una nota igual a 13,5 Cul ser el resultado, empleando la siguiente formula? =SI(A1>=18;"CATEGORIA A";SI(A1>=16;"CATEGORIA B"; SI(A1<13,5;"CATEGORIA C";"CATEGORIA D"))) es igual a ________________________ 15. Cuantas columnas y cuantas filas tiene una hoja de Excel 2013 y cules son las funciones para saber la cantidad de filas y columnas. Columnas: __________ Filas:_______________ Funcin: = Funcin: =

16. Ingresar N cantidad de Promedios, y por cada promedio tres cursos, de acuerdo al promedio evaluar si promedio es >=10,5 aprobado y desaprobado; evaluar Calificativo: Si promedio >=18 calificativo A, si promedio >=16 calificativo B, si promedio >=14 calificativo C, si promedio >=11 calificativo D, si promedio >=6 calificativo E, promedio >=0 calificativo F. Hacer el diagrama de flujo?

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

21

2 Microsoft Excel Avanzado


Manual del Estudiante

EXCEL 2010 PROGRAMACIN CON VBA

Bienvenido a este tutorial, si su trabajo implica desarrollar hojas de clculo o simplemente quiere saber lo mximo de Excel, ha llegado al lugar indicado. Temas. En este tutorial nos centramos en Visual Basic for Aplicaciones (VBA), lenguaje de programacin integrado en Excel, en concreto este tutorial mostrara como escribir programas para automatizar diversas tareas en Excel. Lo que necesita saber. Este tutorial proporciona un estudio ms exhaustivo de todas las funciones del programa, para sacar el mximo rendimiento de Excel. Crear libros de trabajo, insertar hojas, guardar archivos, etc Navegar a travs de un libro de trabajo Utilizar la cinta de opciones de Excel. Introducir formulas. Utilizar las funciones de hoja de Excel. Dar nombre a celdas y rangos. Utilizar las funciones bsicas de Windows, como tcnicas de gestin de archivos y el portapapeles.

COMANDOS DE ESTE TUTORIAL. Comandos de Excel. Excel 2010 y 2013 presenta una nueva interfaz de usuario sin Mens, Excel emplea una cinta de opciones, las palabras de la parte superior como (insertar vista, etc.) se conocen como fichas, si le damos un clic la cinta de opciones mostrara los iconos y los comandos ms tiles para esa tarea.

Comandos del editor de VBA. El editor de VBA es la ventana en la que se trabaja con cdigo de VBA, utiliza una interfaz con mens y barras de herramientas.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

22

2 Microsoft Excel Avanzado


Manual del Estudiante

Entradas. Se escriben por el teclado con tipo de letra Monoespacial.

Las entradas ms largas, se hacen con una lnea separada.

Cdigo de VBA. Cada lnea de cdigo ocupa una lnea separada, para hacer ms legible el cdigo,
utilizamos uno o varios tabulados para crear sangrados.

Libros. El objeto ms comn de Excel es el libro, todo lo que se hace en el Excel se realiza en un libro,
que se guarda con una extensin XLSX, un libro puede contener una cantidad ilimitada de hojas de clculo, mucho depende de la memoria.

Hojas. Las hojas de trabajo contienen celdas y estas almacenan datos y formulas, las hojas de trabajo
contienen 16384 columnas y 1048576 filas.

Etiquetas inteligentes. Es un pequeo icono que aparece en la hoja de trabajo tras realizar ciertas
acciones.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

23

2 Microsoft Excel Avanzado


Manual del Estudiante

Introduccin de datos. Excel interpreta cada entrada de celda como uno de los siguientes tipos.
Valor numrico (fecha y hora). Texto. Valor booleano (verdadero o falso) Una frmula. Una formula siempre empieza con el signo de (=), (+) y (-) como primer carcter de la formula.

Funciones de bsqueda
El desarrollo de esta funcin ensea cmo puede preparar una hoja en Excel en laque por ejemplo, puede obtener el precio de un producto con solo escribir en una celda su cdigo.

Buscar los valores especficos de una tabla

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

24

2 Microsoft Excel Avanzado


Manual del Estudiante

Su objetivo es escribir las frmulas que hagan posible ver en las celdas D2 y E2 la descripcin y el precio unitario del producto al que se hace referencia con el cdigo que ha introducido en la celda B2. Antes de emplear las funciones de bsqueda, asigne un nombre al rango en el que se encuentren los datos. 1. Seleccione el rango C9:E12 en el que se encuentra los datos de los productos. 2. Haga clic en el cuadro de nombres y escriba productos. 3. Pulse Enter. Ventajas de poner nombre al rango. Las frmulas con nombres son ms fcil de leer Hace ms fcil de trasladar la tabla de datos a otra hoja del libro Se utiliza una referencia absoluta para la tabla Elimina la necesidad de cambiar formulas si se aumenta o disminuye el nmero de filas en la tabla de datos

Escribir la formula en la celda D2, emplear la funcin BUSCARV. BUSCARV(valor buscado ; tabla ; columna a mostrar ; permitir intermedios) Escriba en la celda D2 la siguiente formula. =BUSCARV(B2;productos;2;FALSO) Para quitar el error en la celda D2, por no tener ningn dato en la celda B2, escribir la siguiente formula. =SI(ESBLANCO(B2);"";BUSCARV(B2;productos;2;FALSO)) En la celda E2 debe escribir la frmula que devuelve el precio unitario, cuyo cdigo ser escrito en la celda B2. =SI(ESBLANCO(B2);"";BUSCARV(B2;productos;3;FALSO)) En la celda F2 calcule el producto de la cantidad por el precio. =SI(ESBLANCO(B2);"";C2*E2)

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

25

2 Microsoft Excel Avanzado


Manual del Estudiante

Bsqueda de valores intermedios


En algunos casos Ud. Puede requerir que Excel busque un valor entre otros dos valores en la tabla de datos. Ejemplo: en la hoja de clculo se debe asignar una calificacin al promedio, utilizando la tabla de calificaciones del rango B9:C11.

Asignamos el nombre a las calificaciones, B9:C11. =BUSCARV(B2;calificaciones;2;VERDADERO)

Bsqueda Horizontal
Las tablas desde las cuales Ud. Puede desear tomar valores pueden estar dispuestas en horizontal o vertical, ejemplo

Si Ud. desea escribir el nombre de uno de los meses en la celda B5 y que en la celda B6 se vea el monto de la venta, necesita buscar el mes de la primera fila del rango A2:D3, a su vez asignarlo el nombre Ventas. =BUSCARH(B5;ventas;2;FALSO) =SI(ESBLANCO(B5);"";BUSCARH(B5;ventas;2;FALSO))

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

26

2 Microsoft Excel Avanzado


Manual del Estudiante

Filtros
Aplicar filtros es una forma rpida y fcil de buscar y trabajar con un subconjunto de datos de una lista, una lista filtrada muestra solo las filas que cumplan el criterio que se especifique para una columna.

Autofiltro sencillo
Cuando utilice autofiltro, aparecen las flechas de autofiltro a la derecha de los rtulos de columna de la lista filtrada. Ejemplo: aplicar un autofiltro sencillo a una lista 1. 2. 3. 4. Clic celda de la lista En el men datos seleccione filtro Clic en la flecha de la columna Clic en el valor a filtrar.

Usa de cuadros de listas.


Son utilizados para mostrar un grupo de posibles valores de los cuales puede elegir uno o varios. En el rango B2:C4 escriba una tabla con los tipos de datos.

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

27

2 Microsoft Excel Avanzado


Manual del Estudiante

Haga clic en el botn cuadro de listas y arrastre sobre las celdas A2:A4 Haga clic derecho del men contextual seleccione Formato de Control Excel mostrara el cuadro de dialogo Formato de control, active la ficha de Control

Haga clic en Rango de Entrada y arrastre el puntero del ratn B2:B4 Haga clic Vincular con la Celda, clic sobre la celda C6 Del cuadro Tipo de Seleccin marque simple

Cuando Ud. El elemento del cuadro de lista, vera en la celda C6 el nmero de fila del rango B2:B4

MACROS
Si utilizas Excel frecuentemente es posible que en alguna ocasin te hayas encontrado ejecutando una misma serie de acciones una y otra vez. Esas acciones que haces repetidas veces se podran automatizar con una macro. Una macro es un conjunto de comandos que se almacena en un lugar especial de Excel de manera que estn siempre disponibles cuando los necesites ejecutar. Ejemplos. Mostrar el mensaje Bienvenidos a Excel avanzado

En el editor de VBA escribimos el siguiente cdigo en el Modulo1

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

28

2 Microsoft Excel Avanzado


Manual del Estudiante

Cdigo para seleccionar una celda.

Insertar y eliminar datos

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

29

3 Microsoft Excel Avanzado


Manual del Estudiante

Significado de la FORMULA R1C1 La FORMULA R1C1 se emplea para colocar el resultado de una lnea de cdigo en la celda que actualmente est activa. Veamos el siguiente caso

Supongamos que queremos sumar los nmeros de la columna D y que el resultado aparezca en la celda F6 que es la que est seleccionada, el cdigo que se debera escribir es el siguiente

El parntesis destacado en rojo tiene por objetivo cubrir el tango donde estn los nmeros a sumar, o sea, desplazarme 2 columnas a la izquierda [-2] con 5 y 2 filas hacia arriba es decir [-5] y [-2]. Se entiende que R significan filas y C columnas y que anteponemos un - si nos desplazamos hacia la izquierda o hacia arriba. Cuando escribimos una funcin, como en el caso anterior, siempre debe ser escrita ActiveCell.FormulaR1C1 = "=SUM(R[]C[]:R[]C[])", pues el segundo igual es que caracteriza a la funcin y el parntesis el rango donde se aplica. Lo que se acaba de hacer es lo mismo que colocar =SUMA(D1:D3) en la celda F6

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

30

3 Microsoft Excel Avanzado


Manual del Estudiante

Instituto de Informtica. Uancv-puno

Ing. Noe Soncco Quispe

31