Expressões Aritméticas

• Denominamos expressões aritmética aquela cujos operadores são aritméticos e cujos operandos são constantes ou variáveis do tipo numérico (inteiro ou real)
Profº Thiago Sousa Chiqueto

Operando

Operador

Operando

Constante

Constante

Variável

Variável

Operadores Aritméticos
• Símbolos que representa as operações básicas da matemática: + * / Adição Subtração Multiplicação Divisão 2 + 3, X + Y 4 - 2, n - m 3 * 4, A * B 10 / 2, X1 / X2

Profº Thiago Sousa Chiqueto

Operadores Aritméticos
mod Resto da divisão 9 mod 4 1 27 mod 5 2 9 div 4 2 27 div 5 5
Profº Thiago Sousa Chiqueto

div

Quociente da divisão

Dividendo

Divisor

10 1
Resto da Divisão

3 3
Resultado Quociente

y) • rad (x) Potenciação Radiciação x elevado a y Raiz quadrada de x Profº Thiago Sousa Chiqueto • Exemplo: pot(2.3) 2³ rad(9) raiz quadrada de 9 .Operadores Aritméticos • pot(x.

Prioridades • Na resolução das expressões aritméticas. Prioridade 1 2 3 4 pot rad * / div mod +Operadores Parênteses mais internos • No caso de prioridades iguais a resolução deve ser efetuada da esquerda para a direita Profº Thiago Sousa Chiqueto . as operações guardam uma hierarquia entre si.

Exemplos prioridade Profº Thiago Sousa Chiqueto .

A + B = C . Profº Thiago Sousa Chiqueto • O resultado da relação será sempre um valor lógico. Tais valores podem ser representados por constantes. • Ex. variáveis ou expressões aritméticas.Expressão Lógica • Utilizamos os operadores relacionais para realizar comparações entre dois valores do mesmo tipo primitivo.

Exemplos Profº Thiago Sousa Chiqueto .

Profº Thiago Sousa Chiqueto .Operadores Lógicos • Utilizaremos três operadores básicos para a formação de novas proposições lógicas compostas a partir de outras proposições lógicas simples.

Profº Thiago Sousa Chiqueto .Tabela da Verdade • Tabela da verdade é um conjunto de todas as possibilidades combinatórias entre os valores de diversas variáveis lógicas. as quais possuem apenas duas situações (V ou F) em um conjunto de operadores lógicos.

Profº Thiago Sousa Chiqueto .

Exemplos: Profº Thiago Sousa Chiqueto .

Profº Thiago Sousa Chiqueto .

Profº Thiago Sousa Chiqueto .

como a definição dos tipos de variáveis usadas no algoritmo. • Por assemelhar-se bastante à forma em que os programas são escritos. encontra muita aceitação.Pseudocódigo • Esta forma de representação de algoritmo é rica em detalhes. .

Pseudocódigo • Representação textual dos passos envolvidos para a resolução de um problema. • Conjunto de regras que visam restringir e estruturar o uso do português na representação dos algoritmos. . • Aproxima-se do código fonte de linguagens de programação atuais.

Profº Thiago Sousa Chiqueto .Pseudocódigo • Algoritmo que recebe um nome e em seguida mostre-o como saída.

nome fim .Em Fluxograma: inicio “Digite seu Nome” nome “O seu nome é”.

nome) //mensagem+conteúdo variável fim //fim algoritmo .Pseudocódigo representando um algoritmo. algoritmo “exemplo1“ //nome do algoritmo var nome: caracter //variável nome inicio //inicio do algoritmo escreva(“Digite seu nome”) //mensagem ao usuário leia(nome) //leitura de nome escreva(“O seu nome é”.

73 m de altura. Caracter: composta de caracteres alfanuméricos – números. Real: Toda informação numérica (conjunto Nome da variável dos reais) ex: Ela tem 1. @) Lógico: pode assumir apenas duas situações: ex: A porta pode estar aberta ou fechada.Comandos Básicos • Declaração de Variáveis: Sintaxe: nome_variavel:tipo_de_dados Ex: Inteiro: Toda informação numérica var (conjunto dos inteiros) ex: Ele tem 15 irmãos nome:caracter. Tipo de dado . #. alfabéticos e especiais (%.

Exemplo de um algoritmo algoritmo “ex” var //local onde serão declaradas as variáveis nome:caracter //declaração da variável nome inicio //inicio do algoritmo escreva(“Digite seu nome”) //mensagem ao usuário leia(nome) //leitura de nome escreva(“O seu nome é”.nome) //mensagem+conteúdo variável fimalgoritmo //fim algoritmo .

Comandos Básicos • Comando de saída de dados: Sintaxe: escreva(“mensagem”) Ex: escreva(“escreva o seu nome”) comando Mensagem .

Exemplo de um algoritmo • • • • • • • • algoritmo “ex” var //local onde serão declaradas as variaveis nome:caracter //declaração da variável nome inicio //inicio do algoritmo escreva(“Digite seu nome”) //mensagem ao usuário leia(nome) //leitura de nome escreva(“O seu nome é”.nome) //mensagem+conteúdo variável fimalgoritmo //fim algoritmo .

Comandos Básicos • Comando de entrada de dados: Sintaxe: leia(variável) Ex: leia(nome). comando Variável leia(nome.sobrenome) comando Mais de uma variável .

nome) //mensagem+conteúdo variável fimalgoritmo //fim algoritmo .Exemplo de um algoritmo • • • • • • • • algoritmo “ex” var //local onde serão declaradas as variaveis nome:caracter //declaração da variável nome inicio //inicio do algoritmo escreva(“Digite seu nome”) //mensagem ao usuário leia(nome) //leitura de nome escreva(“O seu nome é”.

Exemplo 2 • Crie um algoritmo que receba o nome em uma variável e o sobrenome em outra variável.sobrenome). No final o algoritmo deve exibir o nome inteiro (nome. .

Resolução – Exemplo2 algoritmo “ex2” var x:caracter y:caracter inicio escreva(“digite o nome”) leia(x) escreva(“digite o sobrenome”) leia(y) escreva(x.y) fimalgoritmo .

Exemplo 3 • Crie um algoritmo em pseudocódigo que peça ao usuário para digitar um valor e mostre como resultado o numero que o usuário digitou multiplicado por 10. .

Resolução – Exemplo 3 algoritmo “ex3" var x:real r:real inicio escreva("digite um numero") leia(x) rx*10 escreva("o resultado é".r) fim algoritmo .

Mostre como resultado a multiplicação desses dois números.Exemplo 4 • Crie um algoritmo que peça para que o usuário digite dois números inteiros. .

y*x) fimalgoritmo .Resolução – Exemplo 4 algoritmo “ex4" var x:real y:real inicio escreva("digite um numero") leia(x) escreva("digite outro numero") leia(y) escreva("o resultado é".

Exercícios • Criar um algoritmo em pseudocódigo que receba 5 notas e mostre a média delas. em seguida mostra o nome e a nota de cada aluno. • Criar um algoritmo em pseudocódigo que receba o nome de três alunos e depois três notas. . • Crie um algoritmo em pseudocódigo que calcule o IMC de uma pessoa.

Para tal deve ser pedido o preço do kWh e a quantidade de kWh consumidos durante o mês.Exercícios • Deseja-se saber qual o montante a pagar no fim do mês. relativo ao consumo de electricidade. • Calcule a área do triângulo. sabendo que a fórmula para calcular essa área é (b*h)/2. Chiqueto . Profº Thiago S.