You are on page 1of 12

Licenciatura en Educacin en Matemtica y Computacin

Estructuras Bsicas de Programacin

Computacin I

Profesor Fredi Palominos V.

Licenciatura en Educacin en Matemtica y Computacin

Secuencia:
Corresponde a aquellas instrucciones que se realizan incondicionalmente, que no alteran el flujo del funcionamiento de un programa, y que se ejecutan una despus de otra, en el mismo orden en que se escriben. Ejemplo:

Leer a,b,c Imprimir b X b*b c

Computacin I

Profesor Fredi Palominos V.

Licenciatura en Educacin en Matemtica y Computacin

Ejemplo:
Algoritmo para frer un huevo:

1. Conseguir un sartn, un cuchara, aceite 2. Conseguir sal y un huevo 3. Encender la cocina, verter aceite y esperar que se caliente 4. Partir el huevo y depositar en la sartn 5. Poner un poco de sal y tirar aceite encima con la cuchara 6. Cuando este dorado, sacar de la cocina.
Computacin I

Leer datos

Proceso

Salida

Profesor Fredi Palominos V.

Licenciatura en Educacin en Matemtica y Computacin

Ejemplo:
Calcular el precio de venta de un producto:

1. 2. 3. 4.

Leer el precio_neto Iva precio_neto*0,19 Precio_venta precioneto + Iva Imprimir Precio_venta

Leer datos Proceso


Salida

Computacin I

Profesor Fredi Palominos V.

Licenciatura en Educacin en Matemtica y Computacin

Bifurcacin o Seleccin:
Permite alterar el flujo secuencial de un programa, en base a dos posibles alternativas. Cada posible alternativa se elige en funcin del valor de verdad de una expresin condicional (que puede ser verdadero o falso). Ejemplo:

SI a > = o ENTONCES Imprimir El valor de a es positivo SINO Imprimir El valor de a es negativo FINSI
Computacin I Profesor Fredi Palominos V.

Licenciatura en Educacin en Matemtica y Computacin

Ejemplo:
Calcular el valor absoluto de un nmero:

Leer X SI ( X > = 0 ) ENTONCES Abs X SINO Abs -X (-X sig. -1 * X ) FINSI Imprimir Abs

Computacin I

Profesor Fredi Palominos V.

Licenciatura en Educacin en Matemtica y Computacin

Ejemplo:
Resolver una ecuacin de segundo soluciones reales: ax^2 + bx + c = 0
Leer a, b, c Disc b^2 4*a*c SI ( Disc >= 0 ) ENTONCES X1 (-b+SQRT(Disc))/(2*a) X2 (-b-SQRT(Disc))/(2*a) Imprimir X1, X2 SINO Imprimir No hay soluciones reales FINSI
Computacin I Profesor Fredi Palominos V.

grado

con

Licenciatura en Educacin en Matemtica y Computacin

Bucles o Iteraciones:
Es una estructura que permite ejecutar cero, una o ms veces, un conjunto de instrucciones. La repeticin de las instrucciones depende de una expresin condicional que forma parte de la estructura del bucle. Cuando el flujo del programa llega al bucle, se revisa la expresin condicional. Si la expresin es verdadera, se ejecutan las instrucciones que estn dentro del bucle. Al terminar, nuevamente se chequea la condicin y si sigue siendo verdadera, se vuelve a ejecutar el conjunto de instrucciones.

Computacin I

Profesor Fredi Palominos V.

Licenciatura en Educacin en Matemtica y Computacin

Bucles o Iteraciones:
Se supone que en algn momento, el conjunto de instrucciones cambiara el valor de la expresin condicional a falso, de forma que la ejecucin del bucle termine. Formato:

MIENTRAS ( expresion-condicjonal ) ENTONCES ( instrucciones del bucle ) FINMIENTRAS

Computacin I

Profesor Fredi Palominos V.

Licenciatura en Educacin en Matemtica y Computacin

Ejemplo:
a=0 MIENTRAS ( a == 0 ) ENTONCES Imprimir Ingrese un nmero Leer num SI ( num < o ) ENTONCES Imprimir Ingrese un nmero positivo FINSI a = num FINMIENTRAS
Como finalmente, el valor de num se almacena en a, cuando se ingrese un cero para num, terminar el bucle y la ejecucin continuar en la siguiente instruccin.
Computacin I Profesor Fredi Palominos V.

Licenciatura en Educacin en Matemtica y Computacin

Ejemplo 2:
Suma = 0 i=1 MIENTRAS ( i <= 10 ) ENTONCES Suma = Suma + i i=i+1 FINMIENTRAS Imprimir Suma
Este algoritmo permite sumar los nmeros desde 1 a 10. Los valores los acumula en una variable que se denomina Suma, la que se inicia en 0 (elemento neutro de la suma) para que no altere el resultado.

Computacin I

Profesor Fredi Palominos V.

Licenciatura en Educacin en Matemtica y Computacin

Ejercicios:
Construya un algoritmo que : 1. Calcule 1!+2!+3!++N! 2. Ingrese 10 nmeros y que cuente cuntos de los nmeros ingresados son pares. 3. Ingrese 15 nmeros y que muestre el mayor, el menor y el promedio. 4. Crear un algoritmo que reciba a>=0 y b>=0 y que calcule: a!/((a-b)!b!) 5. Calcule (1+1) + (2+(1+2)) + (3+(1+2+3)) + (N+(1+2+N))

Computacin I

Profesor Fredi Palominos V.