You are on page 1of 10

INSTITUTO TECNOLOGICO DE CAMPECHE

ALGORITMOS
CARRERERA: ING. EN SISTEMAS COMPUTACIONAL
NOMBRE: FABIOLA GUADALUPE TUN HUCHIN

11

1.- Disear el algoritmo que lea el valor correspondiente a una distancia en millas marinas y las escriba expresadas en metros. Sabiendo que 1 milla marina equivale a 1852 metros. ALGORITMO Proceso milla_y_metros Escribir "distancia en millas"; Leer Dmillas; Dmetros<-Dmillas*1852; Escribir "distancia en metros:",Dmetros; FinProceso

DIAGRAMA

2.- Disear el algoritmo que calcule el rea y el permetro de un tringulo rectngulo dada la base y la altura. ALGORITMO Proceso area_y_perimetro Leer base,altura; area<-base*altura/2; perimetro<-base+altura; Escribir "area=",area; Escribir "perimetro=",perimetro; FinProceso DIAGRAMA

3.- Disear un algoritmo que calcule la multiplicacin de un nmero. ALGORITMO proceso multiplicacion Escribir "introducir un numero"; Leer z; Para i<-1 Hasta 60 Con Paso 1 Hacer Escribir z,"x",i,"=",z*i; FinPara FinProceso DIAGRAMA

4.- Disear el algoritmo que escriba el porcentaje descontado en una compra, introduciendo por teclado el precio de la tarifa y el precio pagado. ALGORITMO Proceso descuento Leer tarifa; Leer precio; Descuento<-tarifa-precio; Pd<-Descuento*100/tarifa; Escribir "porcentaje de descuento:",Pd; FinProceso DIAGRAMA

5.- Disear un algoritmo que eleve a cual exponente un numero dado. ALGORITMO Proceso potencia Leer base,exponente; potencia<-base^exponente Para i<-exponente Hasta 20 Con Paso 1 Hacer FinPara Escribir base, "elevado a la",exponente,"=",potencia; FinProceso DIAGRAMA

6.- Disear el algoritmo que tras introducir una medida expresada en centmetros la convierta en pulgadas (1pulgada = 2,54 centmetros). ALGORTIMO Proceso centifrados_pulgadas Escribir "valor en centimetros"; Leer cm; pulgadas<-cm/254; Escribir "pulgadas:",pulgadas; FinProceso DIAGRAMA

7.- Disear el algoritmo que pida por teclado dos nmeros enteros y muestre su suma, resta, multiplicacin,divisin y el resto (mdulo) de la divisin. Si la operacin no es conmutativa, tambin se mostrar el resultado invirtiendo los operadores. ALGORITMO Proceso operaciones_aritmeticas Leer num1,num2; Escribir "num1+num2=",num1+num2; Escribir "num1-num2=",num1-num2; Escribir "num1*num2=",num1*num2; Escribir "num1/num2=",num1/num2; Escribir "num2/num1=",num2/num1; Escribir "num1 mod num2=",num1 mod num2; Escribir "num2 mod num1=",num2 mod num1; FinProceso DIAGRAMA

8.- Disear el algoritmo que exprese en horas, minutos y segundos un tiempo expresado en segundos. ALGORITMO Proceso tiempo Leer segundos; horas<-segundos/3600; minutos<-segundos/60; segundos<-segundos mod 60; Escribir horas, "h"; Escribir minutos, "m"; Escribir segundos, "s"; FinProceso DIAGRAMA

9.- Disear el algoritmo que obtiene la ltima cifra de un nmero introducido. ALGORITMO Proceso ultima_cifra Escribir "introducir numero"; Leer n; Escribir "ultima cifra:",n mod 10; FinProceso DIAGRAMA