SERVICIO NACIONAL DE APRENDIZAJE (SENA

)

Programa de Análisis y Desarrollo de Sistemas de Información Número de Ficha: 180432

MINIESPECIFICACIONES DEL SISTEMA DE INFORMACIÓN PARA LA GESTIÓN DE CONSULTAS PSICOLÓGICAS “PSYCOSYSTEM”

APRENDICES: Julio Javier Barbosa Herrera Juan Camilo Rojas Zúñiga Mauricio Torres Santos

INSTRUCTOR(A): Maristela Pérez Correa

Cartagena de Indias D.T. y C., 05 de junio de 2012

MINIESPECIFICACIONES PSYCOSYSTEM Proceso 1: Iniciar sesión  Acción que dispara el proceso: Cargar la página principal  Datos necesarios para el proceso: Usuario: @nombre_usuario + contraseña  Precondición: Llegan los datos del usuario requeridos para el inicio de sesión Si (@nombre_usuario==@nombre_usuario) and (contraseña==contraseña) entonces Mostrar página de bienvenida del Administrador Si no Imprimir (“Datos de usuario incorrectos”) Fin Si  Postcondición: Ingreso al sistema validado. mostrando página de inicio del usuario Administrador .

Proceso 2: Gestionar Programas de Formación Subproceso 1: Registrar Programas  Acción que dispara el proceso: Clic en el botón “Registrar Programas”  Datos necesarios para realizar el proceso: Programa_formación = @ficha_programa + nombre + descripción  Precondición: Llegan los datos del programa a registrar Si (@ficha_programa==@ficha_programa) entonces Imprimir (“El número de ficha del programa ya existe”) Si no Registrar programa en la base de datos Imprimir (“Registro exitoso”) Fin Si  Postcondición: Datos del programa registrados Subproceso 2: Consultar Programas  Acción que dispara el proceso: Clic en el botón “Consultar Programas”  Datos necesarios para realizar el proceso: Programa_formación = @ficha_programa  Precondición: Llegan los datos de consulta del programa Si (@ficha_programa==@ficha_programa) entonces Mostrar datos del programa .

Programa_formación = @ficha_programa + nombre + descripción Si no Imprimir registrado”) Fin Si   Postcondición: Mostrar datos del programa (“El programa solicitado no está Subproceso 3: Actualizar Programas  Acción que dispara el proceso: Clic en el botón “Actualizar Programas”  Datos necesarios para realizar el proceso: Programa_formación = @ficha_programa  Precondición 1: Haber realizado el subproceso 2 (Consulta)  Postcondición 1: Mostrar datos modificables del programa: Programa_formación = nombre + descripción  Precondición 2: Llegan los datos modificados del programa  Postcondición 2: Datos del programa actualizados .

Proceso 3: Gestionar Aprendices Subproceso 1: Registrar Aprendices  Acción que dispara el proceso: Clic en el botón “Registrar Aprendices”  Datos necesarios para realizar el proceso: Aprendiz = @id_aprendiz + nombre + apellidos + fecha_nacimiento + tipo_sangre + dirección = (barrio+calle+manzana+lote) + teléfono + email Programa_formación = @ficha_programa  Precondición: Llegan los datos del aprendiz a registrar Si (@id_aprendiz==@id_aprendiz) entonces Imprimir (“El número de identificación del aprendiz ya existe”) Si no Registrar aprendiz en la base de datos Imprimir (“Registro exitoso”) Fin Si  Postcondición: Datos del aprendiz registrados Subproceso 2: Consultar Aprendices  Acción que dispara el proceso: Clic en el botón “Consultar Aprendices”  Datos necesarios para realizar el proceso: Aprendiz = @id_aprendiz + nombre + apellidos  Precondición: Llegan los datos de consulta del aprendiz .

Si (@id_aprendiz==@ id_aprendiz) entonces Mostrar datos del aprendiz Aprendiz = @ id_aprendiz + nombre + apellidos + fecha_nacimiento + tipo_sangre + dirección = (barrio+calle+manzana+lote)+ teléfono + email Si no Imprimir (“El aprendiz solicitado no está registrado”) Fin Si  Postcondición: Mostrar datos del aprendiz: Aprendiz = @id_aprendiz + nombre + apellidos + fecha_nacimiento + tipo_sangre + dirección = (barrio+calle+manzana+lote) + teléfono + email Programa_formación = @ficha_programa Subproceso 3: Actualizar Aprendices  Acción que dispara el proceso: Clic en el botón “Actualizar Aprendices”  Datos necesarios para realizar el proceso: Aprendiz = @id_aprendiz + nombre + apellidos  Precondición 1: Haber realizado el subproceso 2 (Consulta)  Postcondición 1: Mostrar datos modificables del aprendiz: Aprendiz = nombre + apellidos + fecha_nacimiento + tipo_sangre + dirección = (barrio+calle+manzana+lote) + teléfono + email  Precondición 2: Llegan los datos modificados del aprendiz .

 Postcondición 2: Datos del aprendiz actualizados Proceso 4: Gestionar Instructores Líderes Subproceso 1: Registrar Instructores  Acción que dispara el proceso: Clic en el botón “Registrar Instructores”  Datos necesarios para realizar el proceso: Instructor_líder = @id_instructor + nombre + apellidos Programa_formación = @ficha_programa  Precondición: Llegan los datos del instructor a registrar Si (@id_instructor==@id_instructor) entonces Imprimir (“El número de identificación del instructor ya existe”) Si no Registrar instructor en la base de datos Imprimir (“Registro exitoso”) Fin Si  Postcondición: Datos del instructor registrados Subproceso 2: Consultar Instructores  Acción que dispara el proceso: Clic en el botón “Consultar Instructores”  Datos necesarios para realizar el proceso: Instructor_líder = @id_instructor + nombre + apellidos .

 Precondición: Llegan los datos de consulta del instructor Si (@id_instructor==@ id_ instructor) entonces Mostrar datos del instructor Instructor_líder = @ id_instructor + nombre + apellidos Programa_formación = @ficha_programa Si no Imprimir (“El instructor solicitado no está registrado”) Fin Si  Postcondición: Mostrar datos del instructor: Instructor_líder = @id_instructor + nombre + apellidos Programa_formación = @ficha_programa Subproceso 3: Actualizar Instructores  Acción que dispara el proceso: Clic en el botón “Actualizar Instructores”  Datos necesarios para realizar el proceso: Instructor_líder = @id_instructor + nombre + apellidos  Precondición 1: Haber realizado el subproceso 2 (Consulta)  Postcondición 1: Mostrar datos modificables del instructor: Instructor_líder = @id_instructor + nombre + apellidos Programa_formación = @ficha_programa .

 Precondición 2: Llegan los datos modificados del instructor  Postcondición 2: Datos del instructor actualizados Proceso 5: Gestionar Familiares Subproceso 1: Registrar Familiares  Acción que dispara el proceso: Clic en el botón “Registrar Familiares”  Datos necesarios para realizar el proceso: Familiar = @id_familiar + nombre + apellidos + parentesco Aprendiz = @id_aprendiz Tiene_relación_con = @id_familiar + @id_aprendiz  Precondición: Llegan los datos del familiar a registrar Si (@id_familiar==@id_ familiar) entonces Imprimir (“El número de identificación del familiar ya existe”) Si no Registrar familiar en la base de datos Imprimir (“Registro exitoso”) Fin Si  Postcondición: Datos del familiar registrados Subproceso 2: Consultar Familiares  Acción que dispara el proceso: Clic en el botón “Consultar Familiares”  Datos necesarios para realizar el proceso: Familiar = @id_familiar + nombre + apellidos .

 Precondición: Llegan los datos de consulta del familiar Si (@id_familiar==@ id_ familiar) entonces Mostrar datos del familiar Instructor_líder = @ id_ familiar + nombre + apellidos Aprendiz = @id_aprendiz + nombre + apellidos Si no Imprimir (“El familiar solicitado no está registrado”) Fin Si  Postcondición: Mostrar datos del familiar: Familiar = @id_familiar + nombre + apellidos + parentesco Aprendiz = @id_aprendiz + nombre + apellidos Subproceso 3: Actualizar Familiares  Acción que dispara el proceso: Clic en el botón “Actualizar Familiares”  Datos necesarios para realizar el proceso: Familiar = @id_familiar + nombre + apellidos  Precondición 1: Haber realizado el subproceso 2 (Consulta)  Postcondición 1: Mostrar datos modificables del familiar: Familiar = nombre + apellidos + parentesco  Precondición 2: Llegan los datos modificados del familiar  Postcondición 2: Datos del familiar actualizados .

Proceso 6: Gestionar Consultas Psicológicas Subproceso 1: Registrar Consultas  Acción que dispara el proceso: Clic en el botón “Registrar Consultas”  Datos necesarios para realizar el proceso: Consulta = @cod_consulta + descripción + antecedentes_familiares + antecedentes_personales + recomendaciones + plan_de_trabajo Aprendiz = @id_aprendiz Instructor_líder = @id_instructor  Precondición: Haber registrado los datos de aprendiz. instructor líder. programa y familiar para poder registrar una consulta psicológica”) Si no Registrar consulta psicológica en la base de datos Imprimir (“Registro exitoso”) Fin Si  Postcondición: Datos de la consulta registrados . programa de formación y familiares Si (not(@id_aprendiz) or not(@id_instructor) not(@ficha_programa) or not(@id_familiar)) entonces or Imprimir (“Debe registrar los datos de aprendiz. instructor.

Subproceso 2: Ver Consultas  Acción que dispara el proceso: Clic en el botón “Ver Consultas”  Datos necesarios para realizar el proceso: Aprendiz= @id_aprendiz + nombre + apellidos  Precondición: Llegan los datos de consulta del aprendiz Si (@id_aprendiz==consulta.id_ aprendiz) entonces Mostrar consultas a las que ha asistido el aprendiz Consulta = @cod_consulta + descripción antecedentes_familiares + antecedentes_personales recomendaciones + plan_de_trabajo Aprendiz = @id_aprendiz + nombre + apellidos Instructor_líder = @id_instructor + nombre + apellidos Si no Imprimir (“El aprendiz solicitado no tiene consultas psicológicas registradas”) Fin Si  Postcondición: Mostrar datos de las consultas a las que ha asistido el aprendiz: Consulta = @cod_consulta + descripción + antecedentes_familiares + antecedentes_personales + recomendaciones + plan_de_trabajo Aprendiz = @id_aprendiz + nombre + apellidos Instructor_líder = @id_instructor + nombre + apellidos + + .

Subproceso 3: Actualizar Consultas  Acción que dispara el proceso: Clic en el botón “Actualizar Consultas”  Datos necesarios para realizar el proceso: Aprendiz= @id_aprendiz + nombre + apellidos  Precondición 1: Haber realizado el subproceso 2 (Consulta)  Postcondición 1: Mostrar datos modificables de la consulta psicológica del aprendiz solicitado: Consulta = descripción + antecedentes_familiares antecedentes_personales + recomendaciones + plan_de_trabajo  Precondición 2: Llegan los datos modificados de la consulta  Postcondición 2: Datos de la consulta actualizados + .