You are on page 1of 11

SISTEMA DE ENSINO PRESENCIAL CONECTADO TECNOLOGIA EM ANALISE E DESENVOLVIMENTO DE SISTEMAS CARLOS EDUARDO LOMBARDI FINEZI LUINARA LOPES PAES

MARCOS RODRIGO SILVA COSTA ROHAN CARLOS FERREIRA BERNARTT WARLLE DA SILVA DE ALMEIDA

PORTFÓLIO: LINGUAGENS E TECNICAS DE PROGRAMAÇÃO I

Redenção 2011
1

Prof.CARLOS EDUARDO LOMBARDI FINEZI LUINARA LOPES PAES MARCOS RODRIGO SILVA COSTA ROHAN CARLOS FERREIRA BERNARTT WARLLE DA SILVA DE ALMEIDA PORTFÓLIO: LINGUAGENS E TECNICAS DE PROGRAMAÇÃO I Trabalho apresentado ao curso de Analise e Desenvolvimento de Sistemas da UNOPAR – Universidade Norte do Paraná.ª Veronice de Freitas Redenção 2011 2 . para a disciplina de Linguagens e Técnicas de Programação I.

.........................SUMÁRIO 1 – INTRODUCAO ..................................................................................... 05 ALGORITIMO 02 ................................................................... 06 ALGORITIMO 03 ... 05 2.................. 11 3 ...................................................................1 – PARTE I.................................................................................................... 05 ALGORITIMO 01 ................................................................................................................................................................................ 10 4 – REFERENCIAS ......................................................................................................... 07 ALGORITIMO 05 .......... 04 2 – DESENVOLVIMENTO .................................................................... 08 ALGORITIMO 05 ........................... 09 3 – CONCLUSÃO..........................................................................................................................

O quarto algoritmo calcula a média das notas de cinco alunos.1. O quinto algoritmo. onde será documentado cada etapa do código. fara a conversão de um numero decimal em binário. 4 . INTRODUCAO Este trabalho tem como objetivo apresentar a estrutura de 05(quatro) algoritmos. com a linguagem Portugol (pseudocódigo) e O primeiro algoritmo apresenta o calculo da média de consumo de um veiculo e sua distancia percorrida. O segundo algoritmo recebe o nome de um funcionário e seu salario bruto e calcula os seus descontos a partir do valor do seu salario O terceiro algoritmo recebe o valor de uma compra e em cima desse valor que me é apresentado calcula quanto poderei dar de desconto.

“ KM/L”) FIMALGORITMO 5 .2. volume: REAL INICIO ESCREVA (“Algoritmo para calcular o consumo”) ESCREVA (“Distancia Total Percorrida (km): ”) LEIA (distancia) ESCREVA (“Volume de combustível gasto (l): ”) LEIA (volume) CM <.1. cm. distancia. DESENVOLVIMENTO 2.DISTANCIA / VOLUME ESCREVA (“Consumo Médio”. PARTE I ALGORITMO 01 ALGORITMO “consumo_media” VAR cm.

Y) ESCREVAL (“ Salario com Descontos INSS:”.ALGORITMO 02 ALGORITMO “SALARIO COM DESCONTO INSS” VAR X: CARACTERE Y: INTEIRO Z: REAL INICIO ESCREVAL (“ Digite o nome do Funcionário:”) LEIA (X) ESCREVAL (“Funcionário:”. X) ESCREVAL (“ Salario Bruto: “. X) ESCREVAL (“ Digite o Salario Bruto:”) LEIA (Y) SE Y > 1000 ENTAO Z <.Y – ( Y * 9 ) /100 FIMSE ESCREVAL (“ Funcionário:“. Z) FIMALGORITMO 6 .Y – (Y * 11) / 100 SENAO Z <.

val_compra * 10 /100 SENAO SE (val_compra > 5000) ENTAO desconto <.val_compra* 5 /100 SENAO SE (val_compra > 1000) E (val_compra < 5000) ENTAO desconto <. desconto. " reais") FIMALGORITMO 7 .val_compra * 15 /100 FIMSE FIMSE FIMSE ESCREVA (cliente. " o valor do desconto é:". desconto: REAL INICIO ESCREVA ("Digite o nome do cliente: ") LEIA (cliente) ESCREVA ("Digite o valor da compra: ") LEIA (val_compra) SE (val_compra <= 1000) ENTAO desconto <.ALGORITMO 03 ALGORITMO "valor_desconto" VAR cliente: CARACTERE val_compra.

0 ESCREVA ("Digite quantos alunos há na classe:”) LEIA (classe) PARA I DE 1 ATE classe FACA ESCREVA ("Digite a nota:”) LEIA (nota) SE nota < 7 ENTAO cont_media_baixa <. media) ESCREVA ("Total de alunos abaixo da média: ".0 classe <. media: REAL INICIO soma <. cont_media_baixa: INTEIRO nota. cont_media_baixa) FIMALGORITMO 8 .ALGORITMO 04 ALGORITMO "media_classe" VAR I. soma.soma + nota FIMPARA //calcular média media <-soma/classe ESCREVA ("A média é: ".cont_media_baixa + 1 FIMSE soma <. classe.

"1" + binario FIMSE valor <. binario) FIMALGORITMO 9 .valor div 2 FIMENQUANTO ESCREVAL ("O valor Decimal: ”.ALGORITMO 05 ALGORITMO "conversão_decimal_binario" VAR valor : INTEIRO binario : CARACTER // valor digitado em decimal // guarda o valor em binário INICIO ESCREVA ("Digite um número decimal:") LEIA (valor) // loop para conversão e montagem de tras para frente do binário ENQUANTO valor > 0 FACA SE (valor mod 2 = 0) ENTAO binario <."0" + binario SENAO binario <. valor) ESCREVA (“em binário é igual á: ”.

10 . pois se trata da base de todo e qualquer sistema de informação.3 – CONCLUSAO Este trabalho foi de grande importância. nos dando a capacidade de raciocinar. aumentando mais ainda nossa capacidade de aprendizado. Para um profissional de Analise de Sistemas é fundamental o estudo Logica de Programação e Algoritmos. aprender sempre cada vez mais. imaginando a resolução do problema. pude assimilar o conteúdo da disciplina. Espero continuarmos a estudar e Agradecemos o apoio e a colaboração de todos.

org/. São Paulo: Pearson. SISTEMA BINARIO. http://pt. 11 . PERINI. Luís Cláudio. Fundamentos da Administração de Informação.4 – REFERENCIAS SANTANA. Denise Dias.wikipedia. 2009. WEB SITE. acessado em 29 de maio de 2011.