You are on page 1of 10

INTELCOLABS 2013

Pra ctica 3
Leccio n 5
Spanning-tree


Objetivos:
Configuracin de Spaning-tree
Control de trfico en capa 2


BLOQUE 1: CONFIGURANDO STP

Para esta prctica considerar que los equipos estan agrupados de la siguiente manera:
Grupo 1: sw2001 a sw2004
Grupo 2: sw2009 a sw2012
Grupo 3: sw3001 a sw3004
Grupo 4: sw3010 a sw3012

1. Configurarse como root bridge de la vlan correspondiente: (tiempo estimado 5
min.)

Usar el comando:
Switch(config)# spanning-tree vlan <num-vlan> root primary

Switch Vlan
Sw2001 10
Sw2002 20
Sw2003 30
Sw2004 40
Sw2009 10
Sw2010 20
Sw2011 30
Sw2012 40
Sw3001 10
Sw3002 20
Sw3003 30
Sw3004 40
Sw3010 10
Sw3011 20
INTELCOLABS 2013
Sw3012 30


2. Revisar el status de Spaning-tree para cada vlan de la 10 a la 40. (tiempo
estimado 5 min.)

Para la VLAN que somos root bridge:

Switch(config)# show spaning-tree vlan 10

SW_2001#show spanning-tree vlan 10

VLAN0010
Spanning tree enabled protocol ieee
Root ID Priority 24586
Address 0012.7faf.ce80
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 24586 (priority 24576 sys-id-ext 10)
Address 0012.7faf.ce80
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 15 sec


Para la VLAN en la que no somos root bridge:

Switch(config)# show spaning-tree vlan 20

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/3 Desg FWD 19 128.3 P2p
Fa0/4 Desg FWD 19 128.4 P2p

SW_2001#show spanning-tree vlan 20

VLAN0020
Spanning tree enabled protocol ieee
Root ID Priority 24596
Address 0012.7fe7.ac80
Cost 38
Port 3 (FastEthernet0/3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32788 (priority 32768 sys-id-ext 20)
Address 0012.7faf.ce80
INTELCOLABS 2013
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec


Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/1 Altn BLK 19 128.1 P2p
Fa0/2 Altn BLK 19 128.2 P2p
Fa0/3 Root FWD 19 128.3 P2p
Fa0/4 Altn BLK 19 128.4 P2p


3. Verificacin de Spanning-tree: (tiempo estimado 10 min.)

a. show spanning-tree vlan <num-vlan> detail
SW_2001#show spanning-tree vlan 10 detail

VLAN0010 is executing the ieee compatible Spanning Tree protocol
Bridge Identifier has priority 24576, sysid 10, address 0012.7faf.ce80
Configured hello time 2, max age 20, forward delay 15
We are the root of the spanning tree
Topology change flag not set, detected flag not set
Number of topology changes 8 last change occurred 00:18:51 ago
from FastEthernet0/3
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 1 (FastEthernet0/1) of VLAN0010 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.1.
Designated root has priority 24586, address 0012.7faf.ce80
Designated bridge has priority 24586, address 0012.7faf.ce80
Designated port id is 128.1, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 590, received 34

b. show spanning-tree interface fa!1
SW_2001#show spanning-tree interface fa0/1

Vlan Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001 Desg FWD 19 128.1 P2p
VLAN0010 Desg FWD 19 128.1 P2p
VLAN0020 Altn BLK 19 128.1 P2p
VLAN0030 Desg FWD 19 128.1 P2p
INTELCOLABS 2013
VLAN0040 Desg FWD 19 128.1 P2p


4. Configurar la interface donde est mi PC en la vlan 10. (tiempo estimado 3 min.)

SW_2001#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SW_2001(config)#interface fa0/10
SW_2001(config-if)#switchport mode access
SW_2001(config-if)#switchport access vlan 10


5. Poner a tu PC remota la IP que se indica en la siguiente tabla. (tiempo estimado 5
min.)

"# $" %&S#&'&
"# Sw21 172.1.0.1 2!!.2!!.2!!.0
"# Sw22 172.1.0.2 2!!.2!!.2!!.0
"# Sw23 172.1.0.3 2!!.2!!.2!!.0
"# Sw24 172.1.0.4 2!!.2!!.2!!.0
"# Sw2( 172.1.0.9 2!!.2!!.2!!.0
"# Sw21 172.1.0.70 2!!.2!!.2!!.0
"# Sw211 172.1.0.71 2!!.2!!.2!!.0
"# Sw212 172.1.0.72 2!!.2!!.2!!.0
"# Sw31 172.1.0."1 2!!.2!!.2!!.0
"# Sw32 172.1.0."2 2!!.2!!.2!!.0
"# Sw33 172.1.0."3 2!!.2!!.2!!.0
"# Sw34 172.1.0."4 2!!.2!!.2!!.0
"# Sw31 172.1.0.90 2!!.2!!.2!!.0
"# Sw311 172.1.0.91 2!!.2!!.2!!.0
"# Sw312 172.1.0.92 2!!.2!!.2!!.0


6. Poner la direccin IP a mi switch en la VLAN correspondiente para que pueda
estar en el mismo dominio de broadcast de la PC. (tiempo estimado 5 min.)

S)$*#+ $" interface vlan
Sw21 172.1.0.1
Sw22 172.1.0.2
Sw23 172.1.0.3
Sw24 172.1.0.4
Sw2( 172.1.0.9
Sw21 172.1.0.10
Sw211 172.1.0.11
Sw212 172.1.0.12
Sw31 172.1.0.31
INTELCOLABS 2013
Sw32 172.1.0.32
Sw33 172.1.0.33
Sw34 172.1.0.34
Sw31 172.1.0.40
Sw311 172.1.0.41
Sw312 172.1.0.42


sw2002(config)#interface vlan 10
%LINK-5-CHANGED: Interface Vlan10, changed state to up
sw2002(config-if)#ip address 172.16.3.1 255.255.255.0
sw2002(config-if)#no shutdown
sw2002(config-if)#exit



BLOQUE 2: Configurando la funcionalidad Portfast

7. Hacer un ping extendido de mi PC a la PC de alguno de mis compaeros. (tiempo
estimado 2 min.)

8. Tirar la interface Fa0/10 en tu switch. Con esto se va a caer el ping de tu PC, ya
que acabas de tirar la interface donde est conectada. (tiempo estimado 3 min.)

S#$2001%conf t
&nter configuration co''ands( one per line. &nd wit) C*+,-..
S#$2001/config0%interface fa0-10
S#$2001/config-if0%s)utdown
S#$2001/config-if0%
12ar 1 0132"329."!!3 4,5*6-!-C78*9&:3 5nterface ;ast&t)ernet0-10( c)anged
state to ad'inistrati<el= down
12ar 1 0132"330."!!3 4,5*&>?@+@-!-A>:@#*3 ,ine protocol on 5nterface
;ast&t)ernet0-10( c)anged state to down
S#$2001/config-if0%

INTELCOLABS 2013

9. Levantar la interface Fa0/10 en tu switch. (tiempo estimado 5 min.)
Observar:
Cuantos pings tarda en le<antar.
Cuanto tie'po tardo en le<antar de nue<o la co'unicacin.
SW_2001#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
SW_2001(config)#interface fa0/10
SW_2001(config-if)#no shutdown
SW_2001(config-if)#
*Mar 1 01:29:48.635: %LINK-3-UPDOWN: Interface FastEthernet0/10,
changed state to up
*Mar 1 01:29:49.635: %LINEPROTO-5-UPDOWN: Line protocol on
Interface FastEthernet0/10, changed state to up
SW_2001(config-if)#


10. Configurar el puerto donde est la PC conectada con la funcionalidad portfast.
(tiempo estimado 5 min.)

S#$2001%configure ter'inal
&nter configuration co''ands( one per line. &nd wit) C*+,-..
S#$2001/config0%interface fa0-10
S#$2001/config-if0%spanning-tree portfast
4#arning3 portfast s)ould onl= be enabled on ports connected to a single
)ost. Connecting )ubs( concentrators( switc)es( bridges( etc... to t)is
interface w)en portfast is enabled( can cause te'porar= bridging loops.
Ase wit) C8A+5@*

4>ortfast )as been configured on ;ast&t)ernet0-10 but will onl=
)a<e effect w)en t)e interface is in a non-trunBing 'ode.
S#$2001/config-if0%

11. Hacer un ping extendido de mi PC a la PC de alguno de mis compaeros. (tiempo
estimado 2 min.)

12. Tirar la interface Fa0/10 en tu switch. Con esto se va a caer el ping de tu PC, ya
que acabas de tirar la interface donde est conectada. (tiempo estimado 3 min.)

S#$2001%conf t
&nter configuration co''ands( one per line. &nd wit) C*+,-..
S#$2001/config0%interface fa0-10
S#$2001/config-if0%s)utdown
S#$2001/config-if0%
INTELCOLABS 2013
12ar 1 0132"329."!!3 4,5*6-!-C78*9&:3 5nterface ;ast&t)ernet0-10( c)anged
state to ad'inistrati<el= down
12ar 1 0132"330."!!3 4,5*&>?@+@-!-A>:@#*3 ,ine protocol on 5nterface
;ast&t)ernet0-10( c)anged state to down
S#$2001/config-if0%

13. Levantar la interface Fa0/10 en tu switch. (tiempo estimado 5 min.)
Observar:
Cuantos pings tarda en le<antar.
Cuanto tie'po tardo en le<antar de nue<o la co'unicacin.
SW_2001#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
SW_2001(config)#interface fa0/10
SW_2001(config-if)#no shutdown
SW_2001(config-if)#
*Mar 1 01:29:48.635: %LINK-3-UPDOWN: Interface FastEthernet0/10,
changed state to up
*Mar 1 01:29:49.635: %LINEPROTO-5-UPDOWN: Line protocol on
Interface FastEthernet0/10, changed state to up
SW_2001(config-if)#


14. Configurando la proteccin de mis puertos de usuario final para posibles loops
ocasionados por switches que se conecten sin autorizacin y generen un loop.
(tiempo estimado 10 min.)

S#$2001/config0%spanning-tree portfast bpduguard default
S#$2001/config0%

,-*&3 todos los puertos configurados con la funcionalidad de spanning-tree portfast =
co'o puertos de acceso estarn protegidos por esta funcionalidad.

INTELCOLABS 2013

BLOQUE 3: Controlando el trfico en capa 2.

15. Para controlar el trfico haremos lo siguiente: (tiempo estimado 10 min.)

a. Revisar el estatus de spanning-tree de la vlan de acuerdo a la siguiente
tabla: (tiempo estimado 5 min.)

Switch Vlan
Sw2001 40
Sw2002 10
Sw2003 20
Sw2004 30
Sw2009 40
Sw2010 10
Sw2011 20
Sw2012 30
Sw3001 40
Sw3002 10
Sw3003 20
Sw3004 30
Sw3010 30
Sw3011 10
Sw3012 20

SW_2001#show spanning-tree vlan 20

VLAN0020
Spanning tree enabled protocol ieee
Root ID Priority 24596
Address 0012.7fe7.ac80
Cost 38
Port 3 (FastEthernet0/3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32788 (priority 32768 sys-id-ext 20)
Address 0012.7faf.ce80
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec


Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/1 Altn BLK 19 128.1 P2p
Fa0/2 Altn BLK 19 128.2 P2p
Fa0/3 Root FWD 19 128.3 P2p
Fa0/4 Altn BLK 19 128.4 P2p
INTELCOLABS 2013



b. Cambiar el costo a la interface que tenemos actualmente como Root Port
y solo en la vlan que se revis. (tiempo estimado 8 min.)

SW_2001#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
SW_2001(config)#interface fa0/3
SW_2001(config-if)#spanning-tree vlan 20 cost 100
SW_2001(config-if)#


c. ?e<isar de nue<o el status de spanning-tree para la <lan Cue les corresponde.
.tiempo estimado / min01

SW_2001#show spanning-tree vlan 20

VLAN0020
Spanning tree enabled protocol ieee
Root ID Priority 24596
Address 0012.7fe7.ac80
Cost 38
Port 4 (FastEthernet0/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32788 (priority 32768 sys-id-ext 20)
Address 0012.7faf.ce80
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/1 Altn BLK 19 128.1 P2p
Fa0/2 Altn BLK 19 128.2 P2p
Fa0/3 Altn BLK 100 128.3 P2p
Fa0/4 Root FWD 19 128.4 P2p


16. Hacer un ping extendido de mi PC a la PC de cada uno de mis compaeros.
(tiempo estimado 2 min.)

17. Tirar la interface Fa0/1 en tu switch: (tiempo estimado 2 min.)
Observar:
Cuantos pings se ca=eron.
Cuanto tie'po tardo en le<antar de nue<o la co'unicacin.
INTELCOLABS 2013

18. Levantar de nuevo la interface Fa0/1 y hacer las mismas observaciones que el
punto anterior. (tiempo estimado 2 min.)

19. Configurar ?apid Spanning-tree. .tiempo estimado 2 min01
S#$2001%configure ter'inal
&nter configuration co''ands( one per line. &nd wit) C*+,-..
S#$2001/config0%spanning-tree 'ode rapid-p<st
S#$2001/config0%

20. Hacer un ping extendido de mi PC a la PC de cada uno de mis compaeros.
(tiempo estimado 2 min.)

21. Tirar la interface Fa0/1 en tu switch: (tiempo estimado 2 min.)
Observar:
Cuantos pings se ca=eron.
Cuanto tie'po tardo en le<antar de nue<o la co'unicacin.

22. Levantar de nuevo la interface Fa0/1 y hacer las mismas observaciones que el
punto anterior. (tiempo estimado 2 min.)