You are on page 1of 5

Network Topology

Step 1: Configure PPP on HQ









Step 2: Configure Default Routing








HQ(config)#int s0/0/1
HQ(config-if)#encapsulation ppp
HQ(config-if)#ppp authentication chap
HQ(config-if)#exit
HQ(config)#username ISP password ciscochap

HQ(config)#ip route 0.0.0.0 0.0.0.0 s0/0/1
Step 3: Configure EIGRP Routing

Configure EIGRP routing on HQ, R1, and R2














Configure the bandwidth between HQ and R2







Configure R1 and R2 to summarize















HQ(config)#router eigrp 100
HQ(config-router)#network 10.0.0.0
HQ(config-router)#no auto-summary
HQ(config-router)#redistribute static

R1(config)#router eigrp 100
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary

R2(config)#router eigrp 100
R2(config-router)#network 10.0.0.0
R2(config-router)#no auto-summary


HQ(config)#int s0/1/0
HQ(config-if)#bandwidth 128

R2(config)#int s0/0/0
R2(config-if)#bandwidth 128
R1(config)#int s0/0/0
R1(config-if)#ip summary-address eigrp 100 10.10.10.0 255.255.255.128 5

R2(config)#int s0/0/0
R2(config-if)#ip summary-address eigrp 100 10.10.10.0 255.255.255.128 5
Step 4: Configure HQ with NAT








































HQ(config)#ip nat inside source static 10.10.10.132 128.107.0.10
HQ(config)#access-list 1 permit 10.10.10.0 0.0.0.255
HQ(config)#ip nat pool PUBLIC 128.107.0.4 128.107.0.7 netmask 255.255.255.252
HQ(config)#ip nat inside source list 1 pool PUBLIC overload

HQ(config)#int s0/0/1
HQ(config-if)#ip nat outside
HQ(config-if)#exit

HQ(config)#int s0/0/0
HQ(config-if)#ip nat inside
HQ(config-if)#exit

HQ(config)#int s0/1/0
HQ(config-if)#ip nat inside
HQ(config-if)#exit

HQ(config)#int fa0/0
HQ(config-if)#ip nat inside
HQ(config-if)#exit
Step 5: Configure Trunking.













Step 6: Configure VTP and VLANs
















Step 7: Configure the VLAN Interface and VLAN Access









S1(config)#int fa0/1
S1(config-if)#switchport mode trunk
S1(config-if)#exit

S1(config)#int gig1/1
S1(config-if)#switchport mode trunk
S1(config-if)#exit

S1(config)#int gig1/2
S1(config-if)#switchport mode trunk
S1(config-if)#exit

S1(config)#vtp mode server
Device mode already VTP SERVER.
S1(config)#vtp domain CCNA
Changing VTP domain name from NULL to CCNA
S1(config)#vtp password ciscovtp
Setting device VLAN database password to ciscovtp

S1(config)#vlan 10
S1(config-vlan)#name Student
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name Faculty
S1(config-vlan)#exit
S1(config)#int vlan 1
S1(config-if)#ip address 10.10.10.98 255.255.255.240
S1(config-if)#no shut
S1(config-if)#ip default-gateway 10.10.10.97

S1(config)#int fa0/4
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 10
Step 8: Configure Spanning Tree



Step 9: Configure Port Security






Step 10: Configure Inter-VLAN Routing


S1(config)#spanning-tree vlan 1,10,20 priority 4096
S1(config)#int fa0/4
S1(config-if)#switchport port-security
S1(config-if)#switchport port-security maximum 2
S1(config-if)#switchport port-security mac-address sticky
R2(config)#int fa 0/0
R2(config-if)#no shut

R2(config)#int fa0/0.1
R2(config-subif)#encapsulation dot1Q 1
R2(config-subif)#ip address 10.10.10.97 255.255.255.240
R2(config-subif)#exit

R2(config)#int fa0/0.10
R2(config-subif)#encapsulation dot1Q 10
R2(config-subif)#ip address 10.10.10.1 255.255.255.192
R2(config-subif)#exit

R2(config)#int fa0/0.20
R2(config-subif)#encapsulation dot1Q 20
R2(config-subif)#ip address 10.10.10.65 255.255.255.224
R2(config-subif)#exit