You are on page 1of 5

! !

! RouterA-1 !
! !
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
hostname RouterA-1
!
enable secret class
!
ip dhcp pool VOICE
network 172.16.10.0 255.255.255.0
default-router 172.16.10.1
option 150 ip 172.16.10.1
ip dhcp pool DATA
network 172.16.20.0 255.255.255.0
default-router 172.16.20.1
option 150 ip 172.16.10.1
!
no ip domain-lookup
!
interface FastEthernet0/0
no shutdown
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 172.16.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 172.16.20.1 255.255.255.0
!
interface FastEthernet0/0.99
encapsulation dot1Q 99
ip address 172.16.99.1 255.255.255.0
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.0
no shutdown
!
ip route 172.17.0.0 255.255.0.0 10.0.0.2
!
dial-peer voice 1 voip
destination-pattern 5...
session target ipv4:10.0.0.2
!
telephony-service
max-ephones 5
max-dn 5
ip source-address 172.16.10.1 port 2000
auto-reg-ephone
auto assign 1 to 5
!
ephone-dn 1
number 4001
!
ephone-dn 2
number 4002
!
line con 0
password cisco
login
!
line vty 0 4
password cisco
login
!
end
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! !
! Switch A-1 !
! !
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
hostname SwitchA-1
!
enable secret class
!
vlan 10
name VOICE
vlan 20
name DATA
vlan 99
name MANAGEMENT
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
!
interface range FastEthernet 0/2-24
switchport mode access
switchport access vlan 20
switchport voice vlan 10
spanning-tree portfast
power inline auto
shutdown
!
interface range FastEthernet 0/2-3
no shutdown
!
interface range GigabitEthernet 0/1-2
switchport mode access
switchport access vlan 20
switchport voice vlan 10
spanning-tree portfast
shutdown
!
interface Vlan99
ip address 172.16.99.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 172.16.99.1
!
line con 0
password cisco
login
!
line vty 0 4
password cisco
login
!
no ip domain-lookup
!
end
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! !
! RouterB-1 !
! !
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
hostname RouterB-1
!
enable secret class
!
ip dhcp pool VOICE
network 172.17.10.0 255.255.255.0
default-router 172.17.10.1
option 150 ip 172.17.10.1
ip dhcp pool DATA
network 172.17.20.0 255.255.255.0
default-router 172.17.20.1
option 150 ip 172.17.10.1
!
no ip domain-lookup
!
interface FastEthernet0/0
no ip address
no shutdown
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 172.17.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 172.17.20.1 255.255.255.0
!
interface FastEthernet0/0.99
encapsulation dot1Q 99
ip address 172.17.99.1 255.255.255.0
!
interface FastEthernet0/1
ip address 10.0.0.2 255.255.255.0
no shutdown
!
ip route 172.16.0.0 255.255.0.0 10.0.0.1
!
dial-peer voice 1 voip
destination-pattern 4...
session target ipv4:10.0.0.1
!
telephony-service
max-ephones 5
max-dn 5
ip source-address 172.17.10.1 port 2000
auto-reg-ephone
auto assign 1 to 5
!
ephone-dn 1
number 5001
!
ephone-dn 2
number 5002
!
ephone-dn 3
number 5003
!
line con 0
password cisco
login
!
line vty 0 4
password cisco
login
!
end
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! !
! Switch B-1 !
! !
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
hostname SwitchB-1
!
enable secret class
!
vlan 10
name VOICE
vlan 20
name DATA
vlan 99
name MANAGEMENT
!
interface FastEthernet0/1
switchport mode trunk
no shutdown
!
interface range FastEthernet 0/2-24
switchport mode access
switchport access vlan 20
switchport voice vlan 10
spanning-tree portfast
shutdown
!
interface range FastEthernet 0/2-3
no shutdown
!
interface FastEthernet0/4
switchport mode access
switchport access vlan 10
spanning-tree portfast
no shutdown
!
interface range GigabitEthernet 1/1-2
switchport mode access
switchport access vlan 20
switchport voice vlan 10
spanning-tree portfast
shutdown
!
interface Vlan99
ip address 172.17.99.2 255.255.255.0
!
ip default-gateway 172.17.99.1
!
line con 0
password cisco
login
!
line vty 0 4
password cisco
login
!
no ip domain-lookup
!
end

You might also like