You are on page 1of 27

215

Captulo 14

Programao linear, Anlise de dados
Trabalhando com o SOLVER
O Excel oferece mais ferramentas estadsticas. Via Dados encontra voc
Analise de Dados e o Add-in Solver. Se no encontrar, deve carreg-los.
Clique no boto do Microsoft Office e, em seguida, clique em Opes do
Excel.
Clique em Suplementos e, na caixa Gerenciar, selecione Suplementos do
Excel. Clique em Ir para.
Na caixa Suplementos disponveis, marque as caixas Ferramentas de
Anlise, Ferramentas de Anlise VBA e Solver. OK
Com o Analise de Dados vamos trabalhar mais frente. Neste momento,
dedicamo-nos ao Solver com o qual podemos, entre outros, resolver
problemas que so complicados demais para a ferramenta Atingir meta (Goal
Seek) que utilizamos no comeo do captulo 8. Para familiarizar-nos com o
Solver, vamos resolver outra vez o problema anterior.


O Solver encontra o mesmo resultado que encontramos usando Atingir Meta,
possivelmente com mais preciso:




216

Outros problemas para o Solver resolver lidam com programao linear (PL).
Ela usada para maximizar ou minimizar diversos tipos de problemas, por
exemplo problemas da tima mistura de produtos. Como exemplo podemos
citar as distribuidoras de petrleo que precisam determinar a quantidade de
aditivos a ser adicionada ao petrleo de forma a obter um certo tipo de
gasolina ao menor custo possvel ou, em certos casos, quere-se conhecer a
quantidade de gua que se pode adicionar a fim de atender s expectativas
mnimas dos clientes -como poder ligar o motor ou poder dirigir pelo menos um
quilmetro sem problemas srias.
Assim, temos o problema de buscar um valor extremo de uma grandeza que
depende de vrias variveis. Esta busca depende, muitas vezes, de restries
laterais que, em geral, podem ser formuladas em forma de igualdades ou
desigualdades. Geralmente, trata-se de uma otimizao linear onde se busca
minimizar ou maximizar o valor de uma funo objetivo linear z(x
1
,...,x
n
) = a
1
x
1

+ ... + a
n
x
n
. Neste caso, tambm as restries so equaes ou inequaes
lineares, ou seja, as equaes ou inequaes dos modelos de programao
linear (PL) tm a seguinte conotao:
a
11
x
1
+ a
12
x
2
+ ... + a
1n
x
n
<=/>= b
1
etc.
O mtodo implementado no Solver chamado de mtodo simplex que um
algoritmo que se aproxima iterativamente soluo tima. (O Solver foi
desenvolvido pela FrontLine Systems, mas, existem no mercado e no domnio
publico outros Solvers, por exemplo o LP_solve.)
Para conhecer o Solver, definimos um problema no qual se produz um produto
pela mistura das sustncias S
1
, ... ,S
n.
A sustncia S
i
contm as sustncias
bsicas B
1
, ... ,B
m
.
Suponhamos que um fabricante de comidas para animais de estimao
pretenda fabricar um produto novo pela mistura de S
1
e S
2
(cereais e carne)
que contm pelo menos 150g de gorduras, 200g de protenas, 250g
carboidratos e com um calor de combusto de 6800KJ, -e que deve ser, obvia-
mente, o menos custoso possvel. (Em comidas para animais de estimao,
boas fontes de minerais incluem suplementos minerais, peixe, carne, fgado,
lcteos e cereais.)
Tabela dos materiais bsicas em gramas por kg de cereais/carne
Cereais Carne Mnimo
Gorduras 100g 500g 150g
Protenas 500g 100g 200g
Carboidratos 400g 400g 250g
Combusto 8400kJ 17000kJ 6800kJ
Preo/kg 3,50 5,20


217

Sejam x = quantidade em kg de cereais por rao e y = quantidade em kg de
carne por rao.
Para as restries temos
Gorduras: 100x + 500y >= 150
Protenas: 500x + 100y >= 200
Carboidratos: 400x + 400y >= 250
Combusto: 8400x + 1700y >= 6800
A funo objetivo a minimizar : z = 3,5x + 5,2y
Entradas na planilha:
Coloque os dados numa planilha, veja o exemplo a seguir.
1. O Solver precisa duas clulas, por exemplo F1 e F2 (clulas variveis),
para armazenar as duas solues x e y.
2. F4 contm a funo objetivo =F1*3,5+F2*5,2
3. As condies laterais colocamos em H1:H4
H1: =F$1*B1+F$2*C1, copiar at H4.
4. Active o Solver.
5. Definir clula de destino: fazer clique na clula F4 e, depois, selecionar
Min. As Clulas variveis so F1:F2, faa um clique nelas. Clique no
boto Adicionar para adicionar as restries. A caixa de dialogo est
dividida em trs partes. Com o cursor no campo Referncia de clula,
faa um clique em H1; mude o smbolo <= para >= (para cada
desigualdade) e, com o cursor em Restrio, faa um clique na D1. Em
seguida, clique no boto Adicionar para colocar a desigualdade na lista
das restries. Agora o mesmo procedimento com H2 e D2 etc. Voc
deve terminar a ltima restrio com OK.
Se depois clicar em Resolver, aparecer em F1 a informao de que deve usar,
por rao, 406 gramas de cereais. Em F2 diz y = 219g de carne. Na clula F4
fica o preo da rao: 2,56 Reais.
Aps terminar, veremos a caixa de dialogo do Solver:
Manter soluo do Solver: Neste caso, vai manter na planilha atual os valores
encontrados pelo Solver.
Restaurar valores originais: Neste caso, vai manter os valores originais.
Existem mais Opes: Tempo mximo, Preciso, Mostrar resultado de iterao
....


218



Anlise de dados

Para descrever uma amostra, utiliza-se as seguintes estimativas:
Freqncia, mdia amostral, desvio padro amostral, mediana amostral. Estas
estimativas estimam a verdadeira mdia, o desvio padro e a mediana da
populao, que so desconhecidos. Chama-se os verdadeiros, mas ds-
conhecidos, valores populacionais de parmetros, definidos com letras Gregas.
As letras Romanas referem-se aos valores amostrais que so chamadas de
estadsticas. A pergunta bsica a responder : Como podemos obter estimativas
dos parmetros populacionais, a partir das estadsticas amostrais, e quo
precisas sero tais estimativas?
Para o seguinte exemplo precisamos das seguintes expresses:

1
1
m
i i
i
x f x
n
=
=

mdia amostral; =MDIA
2 2 2
1
1
( )
1
m
i i
i
s f x nx
n
=
=


varincia amostral; =VAR
s = s
2
= desvio padro amostral: =DESVAP
f
i
= freqncia absoluta =FREQNCIA, F
i
:= f
i
/n

= freqncia relativa


219
Existe outra definio da varincia com 1/n em vez de 1/(n-1). A diferena
entre as duas frmulas ser insignificante, se n fosse muito grande. A formula
com 1/n pode ser escrita como
2 2 2
1
m
i i
i
s x F x
=
=

. Esta , geralmente, uma


expresso mais conveniente para usar no clculo da varincia de uma
distribuio de freqncia do que a anterior.
Exemplo: Temos uma amostra de 35 valores (crianas por famlia) que foram
anotados no momento de receb-los, sem ser ordenados. Queremos determinar
os valores das estadsticas.
Na planilha a seguir, temos em A5:C16 os valores da amostra. Ao lado, D5:D10,
temos uma pequena lista das classes (0, 1, 2, ...,5).
E5: Selecionar E5:E10 e inserir a frmula =FREQNCIA(A5:C16;D5:D10), Ctrl
+Shift+Enter
B17: =SOMA(E5:E10)
B18: =MDIA(A5:C16)
B19: =VAR(A5:C16)
B20: =DESVAP(A5:C16)
G5: =E5/B$17, copiar at G10
Na coluna H calculamos a funo F da distribuio emprica,Fi, acumulada.
H5: =G5; H6: =G6+H5, copiar at H10. O ltimo valor da 1.
Para criar o grfico, selecionamos Barras>Barras agrupadas e Adicionar Rtulos


A seguir utilizamos para o mesmo problema a ferramenta Anlise de Dados
que mostra os mesmos valores para a funo F, mas em %.
Selecione Histograma com Intervalo de entrada: A5:C16. Intervalo do bloco
(=bin range, bin = intervalo): D5:D10. Intervalo de sada: $E$14 (ou outro)


220



Na caixa de dialogo, foi selecionado Percentagem Cumulativo e Resultado do
grfico. (Um diagrama Pareto um diagrama ordenado de barras.) O diagrama
mostra tambm a curva da funo F que termina em 100% = 1. O que
chamado de "bloco" o intervalo de classe que, em ingls, chamado "bin".

Distribuies

Neste pargrafo, estudamos distribuies contnuas. Em muitos casos prticos,
podemos supor que os dados tm uma distribuio Normal.
A distribuio Normal ocupa um lugar de preeminncia dentre as distribuies
da teoria estadstica. Ela especificada por 2 parmetros: a mdia popula-
cional, , e o desvio padro populacional, , ou tambm a varincia
2
.
A funo gaussiana de densidade de probabilidades, FGDP, definida por
2
1
( )
2
1
( )
2
x
f x e

= (1)
Esta funo tambm chamada funo normal de erros. (No caso de a varivel
X sendo discreta, f(x) tambm chamada funo de probabilidades. A varivel
aleatria X dita discreta, se assume valores num conjunto finito ou infinito
enumervel.) A distribuio normal simtrica em torno da mdia o que implica
que e mdia, a mediana e a moda so todas coincidentes.
A Probabilidade do evento "X<=x", ou seja P(X<=x) = F(x), ser calculada pela
funo


221
( ) ( )
x
F x f t dt

=

=P(X<=x) (2)
F(x) = funo distribuio de probabilidade, ou funo de distribuio cumu-
lativa (FDA).
conveno usar um F maisculo para a FDA, em contraste com o f minsculo
usado para a funo densidade de probabilidade (ou funo massa de probabi-
lidade).
Usando =0 e =1, proporciona a distribuio normal padro. Neste caso,
escreve-se, normalmente, e em vez de f e F.
Na prtica desejamos calcular probabilidades para diferentes valores de e ,
(usando =DIST.NORM). Mas, no necessrio trabalhar com diferentes
distribuies, para resolver um dado problema, basta transformar a varivel X
numa forma padronizada
X
Z

= , pois Z tem distribuio N(0,1). Podemos,


ento, escrever ( ) ( )
x
F x

= . Em Excel temos a funo =DIST.NORMP


que retorna a funo da distribuio cumulativa normal padro.
No seguinte exemplo vamos usar a funo DIST.NORM
Exemplo: Suponha que as espessuras de um particular tipo de pranchas
possam ser descritas por uma distribuio Normal, com mdia = 1,4cm e
desvio padro = 0,05cm. (Diremos, ento, que a varivel aleatria X =
espessura varia continuamente, e teremos uma distribuio contnua. Tomamos
a mdia aritmtica x e o desvio s como "boas" estimativas de e .)
Aleatoriamente tiramos da produo uma prancha e perguntamos:
a. Qual a probabilidade de que a espessura esteja entre 1,36cm e 1,48cm?
b. Qual a probabilidade de que ela seja major do que 1,45cm?
Ajuda:
a. Dada f(x), eq.(1), a probabilidade de X se encontrar no intervalo (x1,x2) pode
ser calculada atravs de integrao segundo eq. (2).
P(x
1
<=X<=x
2
) = F(x
2
) - F(x
1
).
b. F(x) calculamos com =DIST.NORM(x;;;1). Com o parmetro 0 obtm-se
f(x). O lado direito da eq. (2) representa a probabilidade de que a varivel X
tome um valor inferior ou igual a x.



222



Entradas:
1. Dados em B5:B8
2. E6: =DIST.NORM($B$7;$B$5;$B$6;1) (= F(x
1
))
E7: =DIST.NORM($B$8;$B$5;$B$6;1) (= F(x
2
))
3. G6: =DIST.NORM($B$7;$B$5;$B$6;0) (= f(x
1
) segundo eq.(1))
G7: =DIST.NORM($B$8;$B$5;$B$6;0) (= f(x
1
))
4. F10: =SE(B7="";"";E7-E6)
5. C11: =2*DIST.NORM(2;0;1;1)-1 ou =2*DIST.NORMP(2)
6. C12: =2*(1-DIST.NORM(2;0;1;1)) ou =2*(1-DIST.NORMP(2))
7. E12: =1-E7; G12: =E7
A probabilidade do desvio padro da mdia foi calculada com c = 2. Para a
distribuio Normal, a proporo de valores caindo dentro de dois desvios
padro da mdia, 2 , P(|X-u|<=2) = 2(2) -1 = 0,9545, ou 95,5%.
Ou seja, veja C11, 95,5% de todas as pranchas tm uma espessura que
desvia-se do valor esperado menos de c = 2 = 0,1cm.
C12: s 4,55% desviam-se mais de 0,1cm da mdia.
(A desigualdade de Tschebyschew, P(|X-u|<=k) > 1-1/k
2
,
d, com k=2, a
probabilidade P > 0,75. Esta reduo do limite a s 75% o preo que se paga
para a universalidade da estimao.)
Se queremos trabalhar com
X
Z

= , devemos pr = 0 e =1. Z(x


1
) =
(1,36-1,4)/0,05 = -0,8 Z(x
2
) = 1,6.


223

No Excel encontramos em Dados>Teste de Hipteses a opo "Tabela de
Dados". Por meio dela podemos substituir o valor na clula B8 sucessivamente
por outros valores, por exemplo pelos valores -2, -1, 8, ... , 12 em B24:B94,
veja a figura a seguir.




B5: 5; B6: 2; C23: =E7
B24: -2; B25: =B24+0,2 copiar at B94 (F5 e Ctrl d)
Selecione B23:C94 e em seguida selecione "Tabela de Dados" onde deixamos a
primeira opo no primeiro campo em branco:


O valor na clula B8 (1,48) ser ento substitudo pelos valores do intervalo
B24:B94. Excel coloca em todas as clulas de C24 at C94 a frmula matricial
{=TABELA(;B8)}. O grfico foi construdo com os valores nas colunas B24:C94.
Foi isso um exemplo de um analise "what-if": o que passaria, se a espessura
no for 1,4 mas ...?
(Com o mesmo mtodo podemos demonstrar que o quociente de diferencias se
aproxima ao valor limite, ou seja derivada da funo dada.


224
Veja a seguinte planilha na qual determinamos os valores do quociente
diferencial da funo f(x)=5x
2
para valores de h cada vez menores. D4: =D3/10
at E11. Excel coloca sucessivamente todos os valores de h na clula B3 e copia
o contedo de B10 para E3:E11.



Outro exemplo a avaliao de uma seqncia, por exemplo a famosa frmula
de Euler que j estudamos nas pginas 48 e 119. A planilha seguinte fcil de
entender:




Aproveitemos deste exemplo, para introduzir a tcnica de trabalhar com
arquivos seqenciais.
A primeira sub-rotina cria um arquivo seqencial com nmeros da forma
(1+1/n)
n
que devem tender ao infinito para valores de n crescendo cada vez


225
mais. A segunda sub-rotina l os nmeros e mostra num MsgBox os nmeros
criados.


Aqui temos o "output" da sub-rotina LerNumerosEuler:



226

A convergncia da seqencia
1
lim(1 )
n
n
e
n
= + muito lenta. O valor de
(1+1/1000)
1000
2,7169239.
Obviamente podemos traar as curvas das funes F(x) ou f(x) sem TABELA,
pois temos a funo DIST.NORM. Vamos, ento, e tracemos N(0,1) e N(5,2)
fazendo uso desta ltima funo:

Todos os valores vo da linha 6 at 76.
B6: =DIST.NORM(A6;$B$3;$B$4;0)
C6: =DIST.NORM(A6;$C$3;$C$4;0)
As curvas tm dois pontos de inflexo, simtricos em relao mdia, que
ocorrem quando x = + e x = -.
Graficamente, as curvas tm forma de sino, com concavidade voltada para
baixo entre os pontos de inflexo da curva, e convexidade para aqum e alm
desses pontos. O mximo de uma curva tm as coordenadas
1
( ; )
2


.
Assim, os mximos ficam em (0;0,399) para N(0;1) e em (5;0,1995) para
N(5;2)

A inverso de
Para determinar intervalos de confiana e para os testes de hipteses,
precisamos para um valor dado da funo (z) o valor z correspondente. Isso
significa que devemos resolver a equao (z) = 1- com respeito a z. No
possvel fazer isso em forma analtica, mas existem vrios mtodos numricos
para esta tarefa. A funo do Excel INV.NORM(;;) se baseia numa destes


227
mtodos aproximativos e retorna o inverso da distribuio cumulativa normal
para a mdia especfica e o desvio padro dados.
A seguinte planilha tem em F10 a funo:
=INV.NORM(Se(B5=1;B13;0,5+B13/2);B9;B10) e em F11:
=INV.NORM(Se(B5=1;B13;0,5+B13/2);0;1)
Veja, tambm, as explicaes para a distribuio_t mais frente.



O nmero real z

no qual a funo distribuio de probabilidade corresponde


ao valor na equao (integral) P(X<=z

) = (z

) = chamado de -
quantil ou 100-percentil. Geometricamente, z

corresponde ao limite direito


da rea sob a curva da funo (z).
-quantil de Z unicaudal:



228
O -quantil de Z bicaudal ilustrado pela seguinte figura.

-quantil de Z bicaudal:


A rea sob a curva normal (na verdade abaixo de qualquer funo de
densidade de probabilidade) 1. Ento, para quaisquer dois valores especficos
podemos determinar a proporo de rea sob a curva entre esses dois valores.
Para a distribuio Normal, a proporo de valores caindo dentro de um, dois,
ou trs desvios padro da mdia so:

Intervalo Probabilidade
1 68,3%
2 95,5%
3 99,7%
Veja p. 8
Intervalo de confiana
Problemas sobre intervalos de confiana para a mdia desconhecida de certa
populao tm muitas vezes a forma do seguinte exemplo:
Recebemos uma quantidade grande, N, de baterias, das quais queremos saber
em qual intervalo se encontra a mdia da varivel X (=durao da bateria).

O mtodo a usar recomenda avaliar uma amostra (tamanho n). Se o desvio
padro

=
x
/n for conhecido, sabemos que o intervalo aleatrio


229
[ ; ]
x x
X z X z
n n

+

contm com a probabilidade de confiana = 2(z)-1 (intervalo bicaudal).
Assim, devemos determinar z pela inverso de . Se
x
no for conhecido,
utilizamos a estimativa
2
1
1
( )
1
n
i
i
s x x
n
=
=



Se o tamanho da amostra for n<30, devemos utilizar a distribuio t.
O Excel tem para o intervalo de confiana a funo INT.CONFIANA.
Na planilha a seguir utilizamos INV.NORM para a inverso de e INT.CON-
FIANA(alfa;desv_padrao;tamanho) para o intervalo bicaudal de confiana.
o nvel de significncia utilizado para calcular o nvel de confiana. O nvel de
confiana igual a 1-, ou 100(1-)%, ou, em outras palavras, um alfa de
0,05 indica um nvel de confiana de 95%. Chama-se = 1- tambm de
coeficiente de confiana.


Amostras de tamanho pequeno

No ano 1908, W.S.Gosset propus a distribuio "Student", tambm chamada de
distribuio-t, que, no caso de amostras de tamanho pequeno, substitui a
distribuio Normal. (Student um pseudnimo de William Sealy Gosset, que
no podia publicar artigos usando seu prprio nome.)


230
Para calcular os intervalos de confiana, precisamos dos assim chamados
valores_t (t_quantiles), ou seja, precisamos da soluo da equao integral

s
(t
1-;f
) = 1-. Na seguinte planilha, calculamos os valores_t de duas maneiras.
Primeiro, utilizando a funo INV(p;f) do Excel que retorna o inverso da
distribuio_t. Segundo, utilizamos um dos algoritmos desenvolvidos para a
inverso da funo de distribuio Student.



Entradas para Excel:
G6: =SE(B16<=0,5;-INVT(E8;F);INVT(E8;F)); (nomeei E13 de F)
E7: =SE(B7=1;1-B16;0,5+B16/2)
E8: =SE(E7<=0,5;2*E7;2*(1-E7))
A frmula que foi usada no intervalo J6:J18
t (au+bu
3
+cu
5
+du
7
+eu
9
)/(92160f
4
)
As constantes so definidas da seguinte forma:
a = 92160f
4
+23040f
3
+2880f
2
-3600f-945
b = 23-40f
3
+15360f
2
+4080f-1920
c = 4800f
2
+4560f+1482
d = 720f+776; e = 79
u = quantil da distribuio N(0;1)
O clculo de u nas clulas J12:J18 baseia-se na seguinte frmula
z t-(a+bt+ct
2
)/(1+dt+et
2
+ft
3
) com t = (-2ln(1-))


231
a = 2,515517; b = 0,802853; c = 0,010328
d = 1,432788; e = 0,189269; f = 0,001308
Obtemos os z-quantiles dos valores 0 < <= 0,5 com z

= -z
1-
. Com estes z

-
quantiles da distribuio N(0,1) determinamos em seguida os x

-quantiles da
distribuio N(,) usando x

= +z

.
Seguem aqui as entradas para o clculo de t:
J6 (=A): =92160*F^4+23040*F^3+2880*F^2-3600*F-945
J7 (=B): =23040*F^3+15360*F^2+4080*F-1920
J8 (=C): =4800*F^2+4560*F+1482
J9 (=D): =720*F+776
Segue o clculo do quantil da distribuio N(0;1)
J12 (T): =RAIZ(-2*LN(1-Q))
J13 (ZA): =2,515517+T*(0,802853+0,010328*T)
J14 (NE): =1+T*(1,432788+T*(0,189269+0,001308*T))
J15 (ZQ): =T-ZA/NE
J16 (RG): =92160*F^4
J17 (H): =ZQ^2
J18 (TQ): =ZQ*(A+H*(B+H*(_C+H*(D+79*H))))/RG
G16: =SE(B16<=0,5;-TQ;TQ)
E15: =SE(B7=1;B16;0,5+B16/2)
E16: =SE(E15<=0,5;1-E15;E15)
Os resultados do Excel e os das frmulas diferem na quarta casa decimal. A
implementao das frmulas complicada e o uso da frmula INVT , obvia-
mente, prefervel implementao das frmulas. Por outro lado, interessante
saber o que se esconde por detrs de INVT.
bom saber que para amostras grandes (n > 30) a distribuio_t se aproxima
a uma distribuio Normal.


Intervalo de confiana para a distribuio "t"

Temos uma amostra pequena com x e s calculados (n<30). Queremos saber
em que intervalo podemos esperar a mdia . O intervalo buscado podemos
escrever como
x x
x a x a < < + onde
x
a o erro da estimativa da mdia
da populao (erro de amostragem).
x
a pode ser estimado atravs da seguinte


232
expresso
1 ; x f
s
a t
n

= , no caso de um intervalo de confiana unicaudal. No
caso dum intervalo bicaudal, temos de usar /2 em vez de . Se se tirar uma
amostra (n) de uma populao (N) pequena, precisa-se introduzir um fator de
correo k =
1
N n
N

.
Em base nestas aclaraes, criamos uma planilha do Excel.
E15: =SE(B9=0;1-B16;0,5+B16/2)
E16: =SE(E15<=0,5;2*E15;2*(1-E15))
E7: =SE(B7=1;B14-G19;"")
E8: =SE(B8=1;B14+G19;"")
E9: =SE(B9=1;B14-G19;""); E13 = F
F7: =SE(B7=1;"<=";"")
D8: =SE(B8=1;" <=";"")
G9: =SE(B9=1;B14+G19;"")
G16: =SE(B16<=0,5;-INVT(E16;F);INVT(E16;F))
G19: =B15*G16/RAIZ(B13) (erro de amostragem)



Exemplo:
Dez mensuraes (=amostra) so feitas para a resistncia de um certo tipo de
fio, fornecendo os valores X
1
, ...,X
10
. Suponha-se que X =10,48 ohms e =
1,36 ohms. Vamos supor que X tenha distribuio N(,) e que desejemos
obter um intervalo de confiana para , com coeficiente de confiana = 0,90.
Portanto, = 0,10.


233
A planilha "Distribuio-t" determina que o valor-t 1,833. Conseqentemente,
o intervalo de confiana procurado ser:
(10,48 - 10
-0.5
(1,83)(1,36); 10,48 + 10
-0.5
(1,83)(1,36)) = (9,69; 11,27)
Este intervalo corresponde ao resultado determinado pela ltima planilha.
Ao afirmar que (9,69;11,27) constitui um intervalo de confiana de 90% para ,
no estaremos dizendo que 90% das vezes a mdia amostral cair naquele
intervalo. A prxima vez que tiramos uma amostra aleatria, X presumvel-
mente ser diferente e, por isso, os extremos do intervalo de confiana sero
diferentes. O que estamos dizendo que 90% das vezes, estar contido no
intervalo ( X -1,83/n, X +1,83/n).

Testes de Hipteses
Nesta seo, encontraremos outra maneira de tratar o problema de fazer uma
afirmao sobre um parmetro desconhecido. Consideremos o seguinte
exemplo:
Um fabricante declara que a durao da vida X das N = 3000 baterias enviadas
pelo menos 230 horas (hiptese de nulidade). O fabricante e o comprador
das baterias so decididos a testar a hiptese de nulidade H
0
: 230 contra a
hiptese alternativa H
a
: < 230. Ao mesmo tempo querem determinar um
intervalo de confiana para a mdia desconhecida (sabe-se que a mdia
aritmtica X dos valores de uma amostra de tamanho n constitui uma "boa"
estimativa de ). Eles analisam uma amostra de n = 50 baterias e encontram
para uma estimativa de 223 horas; a estimativa do desvio padro s = 21
horas.
Para variar a metodologia, buscamos os valores de z =
-1
( ou (1+)/2) numa
pequena tabela que colocamos no bloco A24:C32



234
Podemos encontrar os valores nesta tabela numa tbua da distribuio Normal
ou por meio da funo INV.NORM(;0;1).
Entradas:
D32: =PROCV(B14;A24:C32;B34+1)
A34: = $D$32*E8/RAIZ(E6)*B35 (multiplicao com o fator B35: =RAIZ((B8-
E6)/(B8-1)))
B34: =SE(B13=1;2;1)
D34: = PROCV(B14;A24:C32;3)
E11: =SE(B11=1;B6+A34;"")
F11: =SE(B11=1;SE(E$7>=E11;"rejeitar";"aceitar");"")
E12: =SE(B12=1;B6-A34;"")
F12: =SE(B12=1;SE(E$7<=E12;"rejeitar";"aceitar");"")
E13: =SE(B13=1;B6-$D$32*E8/RAIZ(E6);"")
G13: =SE(B13=1;B6+$D$32*E8/RAIZ(E6);"")
E15: =SE(B13=1;SE(OU(E7<=E13;E7>=G13);"deveria rejeitar";"deveria
aceitar");"")
B17: =E7-$D$34*E8/RAIZ(E6)*B35
D17: =E7+$D$34*E8/RAIZ(E6)*B35








235
Comparao de duas Mdias

Dois instrumentos (multmetros) so usados para medir a intensidade da
corrente eltrica. O instrumento 1 produziu com 8 medies x
1
= 1,486, o
instrumento 2 deu com 13 medies x
2
= 1,492. Os desvios padres dos
instrumentos foram s
1
= 0,026 e s
2
= 0,021. (A amostra com o maior desvio
recebe o ndice 1.) A pergunta que se impe : As leituras de ambos os
instrumentos so significativamente diferentes ou pode-se dizer que as mdias

1
e
2
das populaes subjacentes so idnticas?
Para testar isso, devemos saber se as duas populaes tm as mesmas varin-
cias (Teste-F). (Isso o caso se o quociente s
2
1
/s
2
2
menor do que o valor
correspondente
1 2
1 ; , f f
F

da distribuio F que se obtm para = 0,05 por
meio de =INVF(0,05;7;12) (= 2,91). Este valor maior do que (s
1
/s
2
)
2
= 1,53.)
Como quantidade de teste y, utilizamos a diferena d = x
1
- x
2
:
1 2
1 2
d n n
y
s n n
=
+
. A varincia total vem dada por
2 2
2
1 1 2 2
1 2
( 1) ( 1)
2
n s n s
s
n n
+
=
+

(= pooled variance = varincia amostral combinada).
Temos como hiptese da Nulidade H
0
:
1
=
2
e como hipteses alternativas
H
a
:
1
<
2
;
1
>
2
;
1
#
2
No caso
1
>
2
rejeitamos H
0
, se y > t
1-a;f
. (Obtemos o valor de t com nossa
planilha da distribuio t.) Se escolhermos
1
<
2
, teremos como critrio de
rejeio de H
0
: y < -t
1-;f
.
Geralmente, escolhe-se
1
#
2
e rejeita-se H
0
, se |y| > t
1-/2;f
.
O intervalo de confiana de d (d-td/y; d+td/y).
Entradas:
B14: =((B10*B8^2+C10*C8^2)/H8); B15: =(1/B9+1/C9)
B16: =RAIZ(B14*B15); B17: =B12/B16 (=y)
E15: =SE(D15=1;H4*B16;-H4*B16)
F15: =SE(D15=0;H4*B16;""); H8: =B9+C9-2 (graus de liberdade)
G15: =SE(D15=1;SE(B12>E15;"1 maior do que 2";"2 maior do que
1");SE(OU(B12<E15;B12>F15);"rejeitar H
0
";"no rejeitar Ho"))
D20: =SE(D15=0;B12-H4*B12/B17;"")
F20: =SE(D15=0;B12+H4*B12/B17;"")
H4: =SE(B5<=0,5;-INVT(H11;F);INVT(H11;F))
H10: =SE(D15=1;1-B5;0,5+B5/2)
H11: =SE(H10<=0,5;2*H10;2*(1-H10))


236


Concluso: O teste no pode rejeitar a H
0
, porque a diferena d = -0,006 est
dentro do intervalo (-0,022; 0,022). Com um nvel de confiana de 90%
podemos supor que as duas populaes saram da mesma populao-me. Ao
nvel de significncia de 5%, a leitura do instrumento 1 no significativamente
diferente da leitura do instrumento 2.
Teste Qui-Quadrado (
2
; = letra grega chi)
Deseja-se verificar a afirmao de que o peso de meninas recm-nascidas
segue a distribuio Normal. Numa clinica foram pesadas n = 140 meninas e
seus pesos distribudos sobre 11 classes (blocos, bins) cada um de 200g.
Precisamos das seguintes informaes:
1. Os centros x
i
' dos intervalos e as freqncias absolutas observadas f
o,i
.
2. Frmula para o clculo do valor esperado para dados classificados em k
classes e n observaes:
'
1
1
k
i i
i
x x f
n
=
=


3. Frmula para a varincia amostral:
2 ' 2
1
1
( )
k
i i
i
s x x f
n
=
=


4. Frmula para
2
:
2
, , 2
1 ,
( )
k
o i e i
i e i
f f
f

; f
e
= freqncia esperada
5. A funo ("Fi"): =DIST.NORM(x;mdia;desv_padro;1)
6. A funo {=TABELA(;Bx)} do menu Dados, veja "Distribuio Normal"
7. A funo =INV.QUI(;f) para determinar o valor crtico de (Qui). f = 11
3 = 8 (nmero de classes condies = nmero de graus de liberdade).
As colunas A, B e D contm os valores observados.


237

Entradas:
C5: =(A5+B5)/2, copiar at C15; E5: =C5*D5, copiar
D16: =SOMA(D5:D15) (foi chamado de Numero)
E17: =SOMA(E5:E15)/D16 (=Mu)
F5: =(C5-E$17)^2*D5
F16: =(C5-E$17)^2*D5; F18: =RAIZ(F16/D16) (Sigma)
F20: =DIST.NORM(B20;B17;B18;1)
H3: =F20 (valor Fi)
Selecionar G3:H15 e escolher Dados/Teste de Hipteses/ Tabela de Dados


O valor de x em B20 ser automaticamente substitudo pelos valores em
G4:G15. G4 e G15 foram ocupadas te tal forma que H4 d o valor 0 e H15 1.
x tem o valor 10 para dar em H3 tambm 0.
Na coluna I esto os valores esperados (calculados) da freqncia absoluta.
I5: =(H5-H4)*D16, copiar at I15
J5: =(D5-I5)^2/I5, copiar at J15
J17: =SOMA(J5:J15); valor de Qui
2

O Qui
2
-crtico, para o nvel de 5%, com f = 8, 15,51 (=INV.QUI(0,05;8)). O
valor observado de Qui
2
ento altamente significativo e h bom motivo para
crer que o peso das meninas seja normalmente distribudo. Isso v-se tambm
no histograma onde os valores calculados (verdes) correspondem satisfatoria-
mente aos valores observados (vermelhos). (A regio crtica constituda de
valores maiores de Qui
2
-crtico.)


238
Quero terminar este exemplo com um anlise mais direto do problema. Trata-
se duma interpretao grfica dos dados. Vamos considerar as freqncias
acumuladas observadas como probabilidades acumuladas, P(Zz), de uma
varivel aleatria Z = (p )/ onde p o peso das meninas recm-nascidas.


O grfico dos valores z (que determinamos com nossa planilha "Inverso da
funo de distribuio") e do peso p deveria dar uma reta, pois
1 p
Z p

= =
a equao de uma reta. A intercepo com o eixo-p vai dar o valor esperado
e a inclinao dar 1/.
Na planilha vemos na coluna A os pesos observados e em B as freqncias
relativas f
r
. Em C temos as freqncias acumuladas: C7: =B7; C8= =B8+C7,
copiar at C16. Em C17 colocamos 0,999. D7: =INV.NORM(C7;0;1), copiar at
D17.
Antes de seguir adiante, fazemos o grfico. Observamos que os pontos dos
dados observados ficam perto duma reta. Isso nos deixa de pensar que,
efetivamente, estamos frente a uma distribuio Normal. O corte da reta com o
eixo de p corresponde, mais ou menos, a 3300g. Da inclinao da reta obtemos
= 360g. So estes os valores experimentais que colocamos nas clulas D18 e
D19. Na coluna F temos os valores esperados de p (F7: =INV.NORM
(C7;D$18;D$19)
A planilha mostra tambm uma anlise de regresso feita com "Anlise de
Dados". A reta da regresso y = -8,29 + 0,00253x. Na coluna G ficam os
valores calculados com esta equao.


239
mais simples fazer este anlise usando a funo PROJ.LIN do Excel.
necessrio selecionar duas clulas adjacentes, por exemplo E19 e F19. A
frmula = PROJ.LIN(D7:D16;A7:A16) uma frmula matricial e deve ser
inserida pressionando Ctrl+Shift+Enter. Resultado: em E19 aparece o valor
0,00253 e em F19 temos -8,29
Analise de Dados com o mdulo de regresso PROJ.LIN

Utilizaremos a funo PROJ.LIN quando buscamos relaes entre duas ou mais
variveis. Na planilha a seguir analisamos a afirmao de certo professor de
que alunos com boas notas em Ingls tambm so bons em Matemtica. O
professor quer comprovar esta hiptese com o seguinte material (hipottico):
Aluno 1 2 3 4 5 6 7 8 9 10 11 12
Ingls (X) 2 7 5 9 9 4 8 4 6 3 10 10
Matemtica (Y) 3 5 4 7 8 5 7 3 4 2 7 9
Os algarismos na tabela so pontos entre 1 e 10.
Busca-se, usando o Mtodo dos Mnimos Quadrados, a reta de regresso y = b
1

+ b
2
x.
Deixa-se guiar pela seguinte planilha.





240
Selecione F7:G11 e aplique a funo PROJ.LIN(C4:C15;B4:B15;1;1). Ela vai
tambm retornar os dados estatsticos de regresso adicionais. Ao pressionar
Ctrl+Shift+Enter, aplicamos a frmula matricial ao bloco selecionado.
Primeiro, aparecem os coeficientes de regresso b
1
= 0,658; b
2
= 0,729.
Debaixo seguem os desvios padres de b
1
e b
2
: o desvio padro de b
1
fica em
G8: 0,689, o de b
2
em F8: 0,099. ( Entre estes desvios existe a seguinte relao
1 2
2
1
b b i
s s x
n
=

, veja o captulo anterior, frmula (6).)
Em F9 encontramos o coeficiente de determinao R
2
= 0,844. Isso significa
que 84,4% da variao dos valores y (pontos em Matemtica) podem ser
explicados pela regresso. (Isso considervel, se bem que, neste exemplo,
puramente hipottico.)
Tambm podemos calcular os intervalos de confiana para os coeficientes
(desconhecidos)
1
e
2
da verdadeira reta de regresso =
1
+
2
x.
b
1
ts
b1

1
b
1
+ ts
b1
e b
2
ts
b2

2
b
2
+ ts
b2
Para f = n - 2 = 10 e 1 = 0,95 temos t = 2,228. O intervalo de 95% para
1

ser: -0,877
1
2,193.

Regresso linear mltipla
A funo PROJ.LIN preste-se, tambm, para avaliar uma amostra com duas ou
mais variveis como ilustramos no seguinte exemplo.
A direo de uma companhia de cosmticas acha que a ganncia y (por
persona) do produto "Cheiro de Ouro" no s depende do nmero de
habitantes x
1
da regio das vendas, como tambm das despesas publicitrias x
2

gastas por persona. Os seguintes dados devem ser analisados para detectar
uma possvel relao.
Regio Habitantes x
1
(Milhes)
Propaganda x
2

($/persona)
Lucros y
(por persona)
1 2,4 0,32 7,2
2 1,3 0,42 5,0
3 5,1 0,24 8,4
4 4,9 0,28 8,2
5 3,2 0,52 8,0
6 6,7 0,2 10,2
Busca-se uma equao de regresso da forma = a + b
1
x
1
+ b
2
x
2
.
um estimador para o lucro y. Os valores numricos de denominamos


241
estimativas. Neste exemplo, no estamos buscando uma reta, mas sim um
plano de regresso.



A coluna G vai receber os valores que calculamos por meio da equao de
regresso. Os valores da varivel dependente y esto em E2:E7 (E8 contm a
sua soma.) Selecione o intervalo C11:E15 para receber a frmula matricial =
PROJ.LIN(E2:E7;B2:C7;1;1), compare com o exemplo anterior.
O erro padro de y fica em D13 e H8, compare com equao (3) do captulo
anterior. Em nosso caso, s = 0,6884 com
2
2
( )
1
y y
s
n k

; n = nmero das
observaes (6), k = nmero das variveis independentes (2). O nmero dos
graus de liberdade f = n-k-1 = 3
s
2
o desvio padro de b
2
e o seu valor de 3,78 muito grande. De t = b
2
/s
2
=
3,245/3,78 = 0,858 < t
0,05;3
= 3,182 (= INVT(0,05;3)) segue que, para um
nvel de confiana de 95%, b
2
no significativamente diferente de 0. Isso
significa que a propaganda no teve xito. De fato, obtemos, utilizando
somente x
1
, um erro padro de 0,665 e a equao com = a + b
1
x
1
= 4,676 +
0,803x
1
um modelo satisfatrio para os lucros. Disso segue que foram gastas
grandes quantidades de dinheiro para as propagandas sem resultar em
aumentar os lucros.