You are on page 1of 11

UNIVERSIDAD NACIONAL DE

SAN ANTONIO ABAD DEL CUSCO

FACULTAD : INGENIERÍA
ELÉCTRICA, ELECTRÓNICA,
MECÁNICA Y MINAS
C.P. : INGENIERÍA ELECTRÓNICA

ASIGNATURA : TRANSMISIÓN DE DATOS Y REDES

PRÁCTICA Nº 01 : ‘CONFIGURACIÓN DE 3 PCs COMO
ROUTERs EN QUAGGA’

PRESENTADO POR : - Santos Aguilar Fernández, 081579-F
- Franklin Cardeñoso Fernández, 081117-B
- Luis Alberto Rojas Vicente, 083249-C
DOCENTE : Ing. Milton Velásquez Curo


Cusco, julio de 2014


CONFIGURACIÓN DE 3 PCs COMO ROUTERs EN QUAGGA’


1. OBJETIVOS:

 Obtener en forma analítica la configuración (ruteo y rip) de tres PCs en red para luego
realizar una práctica real con ellos.
 Utilizar las técnicas de análisis y diseño estudiadas en el salón de clases sobre la
configuración de redes, para conseguir configurar tres PCs en red.
 Con la ayuda de las herramientas de simulación como el Packet Tracer realice los gráficos
correspondientes de la práctica.
2. INTRODUCCIÓN TEÓRICA
Diseño de la red

2.1. Quagga
Quagga es un paquete de software de encaminamiento avanzado que proporciona los protocolos
de encaminamiento basados en TCP/IP. Quagga es una bifurcación o fork de GNU Zebra.
Zebra es un demonio que en los sistemas unix se encarga de manejar las tablas de ruteo. Se
encarga de imitar un enrutador físico. Maneja protocolos de ruteo como MPLS,BGP, OSPF, RIP
(protocolo), ISIS y dos versiones más de rip y ospf las cuales van orientadas a Ipv6. Se usa
directamente en los kerneles de BSD, solaris, linux; pero solo versiones de hace 2 o 3 años. Eso no
significa, sin embargo, que esté descontinuado pues en los kerneles nuevos de los Unix
mencionados usa quagga como su interfaz que interviene por sus librerías y lo convierte en
demonio alejado de la mano del usuario.
Quagga es un servicio de linux que nos permite enrutar redes usando a nuestro linux como un
router, para ello seguimos los siguientes pasos.
2.2. Pasos de la instalación de Quagga en Ubuntu 14.04
Instalamos Quagga con la siguiente línea de comandos en la terminal de Ubuntu primero
accediendo como súper usuario
santos@santos-Satellite-C845:~$ sudo su
2.2.1. Para instalar Quagga digitamos
root@santos-Satellite-C845:/home/santos# apt-get install quagga

2.2.2. Configuramos los demonios para que active zebra y ripd con el siguiente comando

#nano /etc/quagga/daemons y cambiamos a yes

zebra=yes
bgpd=no
ospfd=no
ospf6d=no
ripd=yes
ripngd=no
2.2.3. Después hay que entrar a la ruta cd /usr/share/doc/quagga/examples/ y copiar los archivos
zebra y ripd a la ruta /etc/quagga, quedaría así
#cp /usr/share/doc/quagga/examples/zebra.conf.sample /etc/quagga/zebra.conf
#cp /usr/share/doc/quagga/examples/ripd.conf.sample /etc/quagga/ripd.conf
2.2.4. Reiniciamos el servicio de quagga:
#sudo /etc/init.d/quagga
2.2.5. En seguida debemos configurar los demonios zebra.conf y ripd.conf para leer y escribir
# nautilus








Realizado para cada PC todo lo anterior. Ahora quedaría listo para proceder para configurar como
router las mismas.
2.3. Configuracion de PCs como routers
Ahora podremos acceder por separado con una interfaz interactiva a cada uno de los demonios.
Configuración de la Compu0
Para acceder a Zebra (Password por defecto zebra):
root@santos-Satellite-C845:/home/santos# telnet localhost 2601
Password:
Compu0> en
Password: zebra
Compu0# conf ter
Compu0(config)# interface eth0
Compu0(config-if)# ip address 192.168.2.1/24
Compu0(config-if)# no shutdown
Compu0(config-if)# exit
Compu0(config)# exit
Compu0# write
Configuration saved to /etc/quagga/router.conf

Luego comprobamos la configuración realizada con las siguientes lineas de comando
Compu0# show ip route
K>* 0.0.0.0/0 via 192.168.1.1, wlan0
S 0.0.0.0/0 [1/0] via 203.181.89.241 inactive
C>* 10.0.3.0/24 is directly connected, lxcbr0
C>* 127.0.0.0/8 is directly connected, lo
C>* 192.168.1.0/24 is directly connected, wlan0
C>* 192.168.2.0/24 is directly connected, eth0
S>* 192.168.3.0/24 [1/0] via 192.168.2.2, eth0

Compu0# show run
Current configuration:
!
hostname Compu0
password zebra
enable password zebra
!
interface eth0
ip address 192.168.2.1/24
ipv6 nd suppress-ra
!
interface lo
!
interface lxcbr0
ipv6 nd suppress-ra
!
interface wlan0
ipv6 nd suppress-ra
!
ip route 0.0.0.0/0 203.181.89.241
ip route 192.168.3.0/24 192.168.2.2

Para acceder a Rip (Password por defecto zebra):
root@santos-Satellite-C845:/home/santos# telnet localhost 2602
Password:
ripd> en
ripd# conf t
ripd(config)# router rip
ripd(config-router)# net 192.168.2.0/24
ripd(config-router)# exit
ripd(config)# exit
ripd# write
ripd# show ip rip
Codes: R - RIP, C - connected, S - Static, O - OSPF, B - BGP
Sub-codes:
(n) - normal, (s) - static, (d) - default, (r) - redistribute,
(i) - interface

Network Next Hop Metric From Tag Time
C(i) 192.168.2.0/24 0.0.0.0 1 self 0
ripd#

Reiniciamos el servicio de Quagga, para que la configuración anterior tenga efecto con
#sudo /etc/init.d/quagga
Después de configurar todo lo de Quagga procedemos a configurar la tarjeta de red. Para eso
editamos el archivo
#nano /etc/network/interfaces
auto eth0
iface eth0 inet static
address 192.168.2.1
netmask 255.255.255.0
network 192.168.3.0
broadcast 192.168.2.255
Luego le damos "control mas o" y enter y después "control mas x" para salir.
Después de hacer estas configuraciones hay que restaurar el servicio de red con el siguiente
comando
#sudo /etc/init.d/networking restart
Después hay que activar el enrutamiento en GNU/Linux con el siguiente comando:
#echo "1" > /proc/sys/net/ipv4/ip_forward
Y para que no se borre después de reiniciar el sistema utilizamos la siguiente línea
#echo "net.ipv4.ip_forward = 1" >> /etc/sysctl.conf
Es todo lo referente a la configuración del Compu0
Configuración de la Compu1 (PC con dos tarjetas de red)
Para acceder a Zebra (Password por defecto zebra):
# telnet localhost 2601
Password:
Compu1> en
Password: zebra
Compu1# conf ter
Compu1(config)# interface eth0
Compu1(config-if)# ip address 192.168.3.1/24
Compu1(config-if)# no shutdown
Compu1(config-if)# exit
Compu1(config)# interface eth1
Compu1(config-if)# ip address 192.168.2.2/24
Compu1(config-if)# no shutdown
Compu1(config-if)# exit
Compu1(config)# exit
Compu1# write
Configuration saved to /etc/quagga/router.conf

Luego comprobamos la configuración realizada con las siguientes líneas de comando
Compu1# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP,
O - OSPF, I - IS-IS, B - BGP, A - Babel,
> - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, wlan0
S 0.0.0.0/0 [1/0] via 203.181.89.241 inactive
C>* 10.0.3.0/24 is directly connected, lxcbr0
C>* 127.0.0.0/8 is directly connected, lo
C>* 192.168.1.0/24 is directly connected, wlan0
C>* 192.168.2.0/24 is directly connected, eth0
C>* 192.168.3.0/24 is directly connected, eth1

Compu1# show run
Current configuration:
!
hostname Compu1
password zebra
enable password zebra
!
interface eth0
ip address 192.168.3.1/24
ipv6 nd suppress-ra
!
interface eth1
ip address 192.168.2.2/24
ipv6 nd suppress-ra
!
interface lo
!
interface lxcbr0
ipv6 nd suppress-ra
!
interface wlan0
ipv6 nd suppress-ra
!
ip route 0.0.0.0/0 203.181.89.241
ip route 192.168.2.0/24 192.168.2.2
ip route 192.168.3.0/24 192.168.3.1

Para acceder a Rip (Password por defecto zebra):
# telnet localhost 2602
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.

Hello, this is Quagga (version 0.99.22.1).
Copyright 1996-2005 Kunihiro Ishiguro, et al.
User Access Verification
Password:
ripd> en
ripd# conf t
ripd(config)# router rip
ripd(config-router)# net 192.168.2.0/24
ripd(config-router)# net 192.168.3.0/24
ripd(config-router)# exit
ripd(config)# exit
ripd# write
ripd# show ip rip
Codes: R - RIP, C - connected, S - Static, O - OSPF, B - BGP
Sub-codes:
(n) - normal, (s) - static, (d) - default, (r) - redistribute,
(i) - interface

Network Next Hop Metric From Tag Time
C(i) 192.168.2.0/24 0.0.0.0 1 self 0
C(i) 192.168.3.0/24 0.0.0.0 1 self 0
ripd#

Reiniciamos el servicio de Quagga, para que la configuración anterior tenga efecto con
#sudo /etc/init.d/quagga

Despues de configurar todo lo de quagga procedemos a configurar las tarjetas de red. Para eso
editamos el archivo
#nano /etc/network/interfaces
auto eth0
iface eth0 inet static
address 192.168.3.1
netmask 255.255.255.0
network 192.168.3.0
broadcast 192.168.3.255
auto eth1
iface eth1 inet static
address 192.168.2.2
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255
Luego le damos "control mas o" y enter y después "control mas x" para salir.
Después de hacer estas configuraciones hay que restaurar el servicio de red con el siguiente
comando
#sudo /etc/init.d/networking restart
Después hay que activar el enrutamiento en GNU/Linux con el siguiente comando:
#echo "1" > /proc/sys/net/ipv4/ip_forward
Y para que no se borre después de reiniciar el sistema utilizamos la siguiente línea
#echo "net.ipv4.ip_forward = 1" >> /etc/sysctl.conf
Es todo lo referente a la configuración del Compu2
Configuración de la Compu3
Para acceder a Zebra (Password por defecto zebra):
# telnet localhost 2601
Password:
Compu3> en
Password: zebra
Compu3# conf ter
Compu3(config)# interface eth0
Compu3(config-if)# ip address 192.168.2.1/24
Compu3(config-if)# no shutdown
Compu3(config-if)# exit
Compu3(config)# exit
Compu3# write
Configuration saved to /etc/quagga/router.conf
Luego comprobamos la configuración realizada con las siguientes lineas de comando
Compu3# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP,
O - OSPF, I - IS-IS, B - BGP, A - Babel,
> - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, wlan0
S 0.0.0.0/0 [1/0] via 203.181.89.241 inactive
C>* 10.0.3.0/24 is directly connected, lxcbr0
C>* 127.0.0.0/8 is directly connected, lo
C>* 192.168.1.0/24 is directly connected, wlan0
C>* 192.168.3.0/24 is directly connected, eth0
S>* 192.168.2.0/24 [1/0] via 192.168.3.1, eth0

Compu0# show run

Current configuration:
!
hostname Compu3
password zebra
enable password zebra
!
interface eth0
ip address 192.168.3.2/24
ipv6 nd suppress-ra
!
interface lo
!
interface lxcbr0
ipv6 nd suppress-ra
!
interface wlan0
ipv6 nd suppress-ra
!
ip route 0.0.0.0/0 203.181.89.241
ip route 192.168.2.0/24 192.168.3.1

Para acceder a Rip (Password por defecto zebra):

# telnet localhost 2602
Password:
ripd> en
ripd# conf t
ripd(config)# router rip
ripd(config-router)# net 192.168.3.0/24
ripd(config-router)# exit
ripd(config)# exit
ripd# write
ripd# show ip rip
Codes: R - RIP, C - connected, S - Static, O - OSPF, B - BGP
Sub-codes:
(n) - normal, (s) - static, (d) - default, (r) - redistribute,
(i) - interface
Network Next Hop Metric From Tag Time
C(i) 192.168.2.0/24 0.0.0.0 1 self 0
ripd#

Reiniciamos el servicio de Quagga, para que la configuración anterior tenga efecto con
#sudo /etc/init.d/quagga

Después de configurar todo lo de Quagga procedemos a configurar la tarjeta de red. Para eso
editamos el archivo

#nano /etc/network/interfaces
auto eth0
iface eth0 inet static
address 192.168.3.2
netmask 255.255.255.0
network 192.168.3.0
broadcast 192.168.3.255
Luego le damos "control mas o" y enter y despues "control mas x" para salir.
Después de hacer estas configuraciones hay que restaurar el servicio de red con el siguiente
comando
#sudo /etc/init.d/networking restart
Después hay que activar el enrutamiento en GNU/Linux con el siguiente comando:
#echo "1" > /proc/sys/net/ipv4/ip_forward
Y para que no se borre después de reiniciar el sistema utilizamos la siguiente linea
#echo "net.ipv4.ip_forward = 1" >> /etc/sysctl.conf
Es todo lo referente a la configuración del Compu3
3. CONCLUSIONES
En el presente trabajo de utilización de Quagga en Ubuntu para configuración de PCs como
routers se tuvo que resolver muchas dificultades, desde la instalación de Ubuntu, configuración
de Quagga, lectura y escritura de los demonios de Quagga, y otros pormenores.
Con el demonio Zebra se configuro como router cada PC tal como aprendido en el salon de clases
con los comandos CLI (Packet Tracer).
Con el demonio Rip, se habilitó las redes asociadas a cada router, que son 192.168.2.0 y
192.168.3.0.
La prueba final consistio solamente en hacer el respectivo ping entre los routers (Pcs) conectados
entre sí. Dando por resultado un ping exitoso desde cualquier máquina.
4. BIBLIOGRAFÍA
La bibliografía utilizada en si fue bastante mencionamos a continuación algunas
http://todosobreredesdedatos.blogspot.com/p/configuracion-quagga-en-linux.html
http://red-orbita.com/?p=4814
Varios video tutoriales de YouTube