You are on page 1of 4

La función BUSCARV en Excel

La función BUSCARV en Excel nos permite buscar un valor dentro de un rango de datos, es decir, nos ayuda a obtener el valor de
una tabla que coincide con el valor que estamos buscando. Un ejemplo sencillo que podemos resolver con la función BUSCA! es
la b"squeda dentro de un directorio telefónico.
Si queremos tener #$ito para encontrar el tel#fono de una persona dentro del directorio telefónico de nuestra localidad debemos
tener el nombre completo de la persona. %osteriormente &abr' que buscar el nombre dentro del directorio telefónico para entonces
obtener el n"mero correcto.
Crear una tabla de búsqueda
%ara poder utili(ar la función BUSCARV debemos cumplir con algunas condiciones en nuestros datos. )n primer lugar debemos
tener la información organi(ada de manera vertical con los valores por debajo de cada columna. )sto es necesario porque la función
BUSCA! recorre los datos de manera vertical *por eso la +!, en su nombre- &asta encontrar la coincidencia del valor que
buscamos.
%or ejemplo, nuestro directorio telefónico deber.a estar organi(ado de la siguiente manera/
0tra condición que for(osamente debemos cumplir es que la primera columna de nuestros datos debe ser la columna llave, es decir,
los valores de esa columna deben identificar de manera "nica a cada una de las filas de datos. )n este ejemplo la columna 1ombre
servir' como la columna llave porque no &ay dos personas que se llamen igual.
Algo que debemos cuidar con la tabla de b"squeda es que si e$isten otras tablas de datos en la misma &oja de )$cel debes dejar al
menos una fila en blanco por debajo y una columna en blanco a la derec&a de la tabla donde se reali(ar' la b"squeda. Una ve( que
la tabla de b"squeda est' lista podemos utili(ar la función BUSCARV.
Sintaxis de la función BUSCARV
La función BUSCARV tiene 2 argumentos/
• Valor_buscado *obligatorio-/ )ste es el valor que se va a buscar en la primera columna de la tabla. %odemos colocar el
te$to encerrado en comillas o podemos colocar la referencia a una celda que contenga el valor buscado. )$cel no &ar'
diferencia entre may"sculas y min"sculas.
• Matriz_buscar_en *obligatorio-/ La tabla de b"squeda que contiene todos los datos donde se tratar' de encontrar la
coincidencia del Valor_buscado.
• ndicador_colu!nas *obligatorio-/ Una ve( que la función BUSCARV encuentre una coincidencia
del Valor_buscadonos devolver' como resultado la columna que indiquemos en este argumento. )l 3ndicador4columnas
es el n"mero de columna que deseamos obtener siendo la primera columna de la tabla la columna n"mero 5.
• "rdenado *opcional-/ )ste argumento debe ser un valor lógico, es decir, puede ser falso o verdadero. Con este
argumento indicamos si la función BUSCARV reali(ar' una b"squeda e$acta *FALSO- o una b"squeda apro$imada
*VERDADERO-. )n caso de que se omita este argumento o que especifiquemos una b"squeda apro$imada se
recomienda que la primera columna de la tabla de b"squeda est# ordenada de manera ascendente para obtener los
mejores resultados.
E#e!$lo de la función BUSCARV
%ara probar la función BUSCARV con nuestra tabla de b"squeda ejemplo que contiene información de n"meros telefónicos
seguimos los siguientes pasos/
5. )n la celda )5 colocar# el valor que deseo buscar.
%& )n la celda )6 comien(o a introducir la función BUSCARV de la siguiente manera/
=BUSCARV(
'& 7ago clic en la celda )5 para incluir la referencia de celda e introdu(co una coma *,- para concluir con el primer
argumento de la función/
=BUSCARV(E1,
(& %ara especificar el segundo argumentos debo seleccionar la tabla de datos sin incluir los t.tulos de columna. %ara el
ejemplo ser' el rango de datos A6/B55. Una ve( especificada la matri( de b"squeda debo introducir una coma *,- para
finali(ar con el segundo argumento/
=BUSCARV(E1,A2:B11,
)& Como tercer argumento colocar# el n"mero 6 ya que quiero que la función BUSCARV me devuelva el n"mero de
tel#fono de la persona indicada en la celda )5. ecuerda que la numeración de columnas empie(a con el 5 y por lo tanto
la columna 8el#fono es la columna n"mero 6. 9e igual manera finali(o el tercer argumento con una coma *,-/
=BUSCARV(E1,A2:B11,2,
*& %ara el "ltimo argumento de la función especificar# el valor :ALS0 ya que deseo &acer una b"squeda e$acta del
nombre.
=BUSCARV(E1,A2:B11,2,FALSO)
0bserva el resultado de la función reci#n descrita/
Una ventaja de &aber colocado el valor buscado en la celda )5 es que podemos modificar su valor para buscar el tel#fono de otra
persona y la función BUSCARV actuali(ar' el resultado autom'ticamente.
Errores co!unes al usar la función BUSCARV
• Si la columna llave no tiene valores "nicos para cada fila entonces la función BUSCARV regresar' el primer resultado
encontrado que concuerde con el valor buscado.
• Si especificamos un indicador de columna mayor al n"mero de columnas de la tabla obtendremos un error de tipo ;):<
• Si colocamos el indicador de columna igual a cero la función BUSCARV regresar' un error de tipo ;!AL0<
• Si configuramos la función BUSCARV para reali(ar una b"squeda e$acta, pero no encuentra el valor buscado, entonces
la función regresar' un error de tipo ;1=A.
La función BUSCARV es una de las funciones m's importantes en )$cel. )s necesario que dediques tiempo para aprender
correctamente su uso y ver's que podr's sacar muc&o provec&o de esta función.
Art+culos relacionados
Lista de validación y función BUSCA!