You are on page 1of 16

jeudi 16 décembre 2004

Rapport de TP2

Interconnexion de réseaux IP
(Routeur CISCO)
Ce travail est présenté à :
M. GRANDPIERRE Thierry
Par :
FOURNIER Alexandre
ROUSSEL Céline
PICHENEY Cyril
MAMMOU Omar
BOUJRAD Mohammed
BOUNMY Elodie
dans le cadre du cours de :
IN411 Réseaux

Ecole Supérieure d’Ingénieurs en Electronique et Electrotechnique

Table des matières
OBJECTIFS.................................................................................................................................................. 4
LISTE DU MATERIEL NECESSAIRE :.............................................................................................................. 4
ARCHITECTURE IP D’UN RESEAU D’ENTREPRISE ........................................................................ 5
QUESTION 1................................................................................................................................................ 5
QUESTION 2................................................................................................................................................ 5
QUESTION 3................................................................................................................................................ 6
CONFIGURATION IP DES STATIONS ET DES INTERFACES ROUTEURS.................................. 7
QUESTION 4................................................................................................................................................ 7
QUESTION 5................................................................................................................................................ 7
QUESTION 6................................................................................................................................................ 7
QUESTION 7................................................................................................................................................ 7
QUESTION 8................................................................................................................................................ 8
QUESTION 9................................................................................................................................................ 8
QUESTION 10.............................................................................................................................................. 9
QUESTION 11.............................................................................................................................................. 9
QUESTION 12.............................................................................................................................................10
QUESTION 13.............................................................................................................................................10
QUESTION 14.............................................................................................................................................10
QUESTION 15.............................................................................................................................................10
QUESTION 16.............................................................................................................................................10
QUESTION 17.............................................................................................................................................10
CONFIGURATION DE LA LS ENTRE LES 3 ROUTEURS ...............................................................11
QUESTION 18.............................................................................................................................................11
QUESTION 19 & 20 ....................................................................................................................................11
QUESTION 21.............................................................................................................................................11
QUESTION 22.............................................................................................................................................12
QUESTION 23.............................................................................................................................................13
INSTALLATION D’UNE LIAISON DE SECOURS...............................................................................15
CONCLUSION............................................................................................................................................16

Objectifs
Le but de cette partie du TP consiste à étudier l’interconnexion de niveau 3 de deux PC
au travers de deux routeurs CISCO.
PC2
|
|
PC1 ----------- ROUTEUR1 ---------- ROUTEUR2 -------------- ROUTEUR3 -------- PC3
|--------------------------------------------------------|

En particulier :
-

La configuration des interfaces des routeurs CISCO.
L’étude de filtrage au niveau 3.
Le routage statique
L’étude du trafic et des tables de routage.

Liste du matériel nécessaire :
-

3 routeurs CISCO
3 PC munis d’une carte Ethernet
des câbles 10baseT RJ45 (croisés)
La documentation du routeur CISCO
3 câbles WAN (câble Back to Back) de connexion routeur-routeur.

Architecture IP d’un réseau d’entreprise
Question 1

PC

PC
ETCD
Routeur
(CISCO)

ETCD

PC

Routeur
(CISCO)
PC

Point-to-Point

Il est absolument nécessaire d’avoir deux routeurs de chaque coté des deux LAN.
Chaque routeur va pouvoir gérer le LAN et la connexion extérieure de façon sécuritaire et
en même temps protéger le LAN des intrusions. La partie au centre est facultative. Pour
pouvoir circuler de façon rapide il serait bien d’avoir un réseau haut-débit pour
communiquer d’un réseau à l’autre. Cependant pour les ressources de l’entreprise, c’est
peut-être un peu cher. Il faudrait que le routeurs soient connectés chacun à un CSU
(Channel Service Unit) qui lui soit connecté à un commutateur d’une centrale
téléphonique. De plus, il faudrait débourser pour une ligne spécialisée.

Question 2
Pour le laboratoire nous avions 3 routeurs :
-

-

2 CISCO 2610 :
o 2 interfaces séries (pour connecter le routeur à un autre routeur)
o 1 interface RS232 (connecter au PC)
o 1 interface AUX
o 1 interface alimentation
CISCO ???

Question 3
193.10.10.1 RS232
194.10.10.1 RS232
20.0.0.1 s1

20.0.0.2 s1
195.10.10.2

PC1
193.10.10.2

20.0.0.0

R1
30.0.0.2 s0

R2

PC1

10.0.0.1 s0
195.10.10.0

30.0.0.0

10.0.0.0

193.10.10.0
30.0.0.1 s1

10.0.0.2 s0

R3
194.10.10.1 RS232
194.10.10.0

PC1
194.10.10.2

Configuration IP des stations et des interfaces routeurs
Question 4
« Pour qu’un équipement puisse communiquer avec un équipement d’un autre réseau, il a
besoin d’une passerelle (par défaut). Une passerelle est l’adresse IP de l’interface du
routeur qui est connectée au segment de réseau sur lequel se trouve l’hôte source. »
Polycopie cours IN411, « Sous-réseaux et masque de sous-réseau »

Question 5
Dans notre cas, nous avons utilisé Minicom pour se connecter au routeur. Avec le
terminal, Minicom reçoit les caractères ASCII envoyé par le routeur un à un. Minicom
nous affiche donc la configuration du routeur. Avec cette configuration initiale nous
pouvons par la suite configurer le routeur pour nos besoins. Si on voulait se connecter
directement sur le routeur, quelle adresse nous devrions joindre ?

Question 6
Pourquoi avoir plusieurs modes de travail ? Il faut savoir que plusieurs utilisateurs
peuvent travailler sur le routeur pour différentes raisons. Exemple : des utilisateurs qui
voudrait seulement connaître la configuration de différent routeurs, ou encore, des
utilisateurs qui voudrait connaître l’état d’un réseau via le routeur et bien entendue
l’administrateur réseau et l’ingénieur réseau. Tous ont un rôle spécifique avec des tâches
spécifiques. Pour bien structuré et sécurisé l’accès au routeur il y a différents paliers de
travail.

Question 7
Selon la documentation du laboratoire :
-

Entrer une configuration en mémoire : write mem
Copier une configuration : copy
Effacer une configuration en mémoire : erase startup-config
Sortir du mode exécutable : disable
Avoir de l’aide : help ou « ? »
Ouvrir une configuration PAD : pad
Envoyer de messages ECHO : ping
Avoir un journal sur l’activité du routeur : show

-

Configurer les protocoles modems : modemcap
Avoir de l’information sur l’exécution du système : show
Tracer un itinéraire : traceroute
Visualiser les connexions en service : show int
Configurer les interfaces : ip address
Travailler le côté IP du routeur : conf term

Question 8
Il suffit de se connecter via Minicom sur le routeur de s’authentifier et ensuite de lancer
la commande. Minicom envoie caractère par caractère sur le routeur et doit attendre un
caractère de fin de commande. Il regarde par la suite si la commande est faisable.
Pour lancer une commande il faut se placer dans la catégorie de la commande, car ces
dernières sont classées en catégories hierarchisées.

Question 9
Router#show conf
Using 688 out of 29688 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0/0
ip address 194.10.10.1 255.255.255.0
ip broadcast-address 0.0.0.0
!
interface Serial0/0
ip address 10.0.0.2 255.0.0.0
ip broadcast-address 0.0.0.0
!
interface Serial0/1
ip address 30.0.0.1 255.0.0.0
ip broadcast-address 0.0.0.0
!

ip classless
ip route 20.0.0.0 255.0.0.0 10.10.10.1
ip route 193.10.10.0 255.255.255.0 30.10.10.2
ip route 193.10.10.0 255.255.255.0 30.0.0.2
ip route 195.10.10.0 255.255.255.0 10.0.0.1
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Question 10
La commande est « show int ». Il faut être dans le mode « show ». C’est pratique si on
veut savoir la configuration de toutes les interfaces sans avoir la configuration au
complet.

Question 11
Table de routage : la table de routage d’un routeur sert à définir les routes que le routeur
doit utiliser. Les instances de la table sont en ordre d’exécution. Dans la table il y a les
différents chemins que le routeur doit emprunter pour joindre un réseau. Il y a aussi
toujours une route par défaut au cas où il ne trouve aucune route qui ne fonctionne.
Table ARP : « Les tables ARP mappent les adresses IP avec les adresses MAC
correspondantes. Les tables ARP sont des sections de mémoire RAM dans lesquelles la
mémoire cache est mise à jour automatiquement dans chaque équipement. […] Chaque
fois qu’un équipement souhaite envoyer des données sur le réseau, il utilise les
informations contenues dans sa table ARP. »
Polycopie cours IN411, « Sous-réseau et masque sous-réseau »
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set

C

194.10.10.0/24 is directly connected, Ethernet0/0

Router#show arp
Protocol Address
Internet 194.10.10.2
Ethernet0/0
Internet 194.10.10.1
Ethernet0/0

Age (min)
14
-

Hardware Addr
0001.0342.cdf3

Type
ARPA

0004.9ad3.39e0

ARPA

Interface

Question 12
IP, IPX les autres sont des protocoles de niveau plus bas : x25, Frame relay.

Question 13
Commande > hostname NewName

Question 14
Ip address 10.0.0.2 255.0.0.0 (Donner une adress ip de 10.0.0.0 avec un masque de
255.0.0.0).

Question 15
Oui. La configuration qui est dans la NVRAM c’est la configuration qui est active.

Question 16
La mémoire était vide. La commande pour la mettre active c’est « no shutdown ».

Question 17
Router#show arp
Protocol Address
Internet 194.10.10.2
Ethernet0/0
Internet 194.10.10.1
Ethernet0/0

Age (min)
14
-

Hardware Addr
0001.0342.cdf3

Type
ARPA

0004.9ad3.39e0

ARPA

Interface

Configuration de la LS entre les 3 routeurs

Question 18
Oui c’est nécessaire car il y a un sens pour les équipements. Pour que la communication
se fasse, un des deux routeurs doit générer une horloge pour synchroniser la
communication. Celui qui émet l’horloge est le DCE, le DTE se comporte comme une
machine lambda.

Question 19 & 20
Voici ce que chaque routeur a fait vis-à-vis chacun des deux routeurs auxquels il est
connecté :
Configurer chaque interface du routeur (serial 0 et serial 1) comme spécifié dans le
schémas du début. Chaque routeur effectue la commande « clock rate 2000000 ».
Chaque routeur ajoute des routes dans la table de routage.
Pour le routeur :
> ip route 193.10.10.0 255.255.255.0 20.0.0.0
> ip route 194.10.10.0 255.255.255.0 10.0.0.0
Pour le PC :
>route add default gw 195.10.10.2

Question 21
Dans notre cas, le routage ip etait déjà active, mais pour activer le routage IP il faut
lancer la commande : ip routing. Ensuite il faut ajouter les routes statiques :
Pour le routeur 1 :
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route
Gateway of last resort is not set
C
S

194.10.10.0/24 is directly connected, Ethernet0/0
20.0.0.0/8 [1/0] via 10.10.10.1
[1/0] via 30.0.0.2
195.10.10.0/24 [1/0] via 10.0.0.1
[1/0] via 30.0.0.2
193.10.10.0/24 [1/0] via 30.10.10.2
[1/0] via 30.0.0.2
10.0.0.0/8 is directly connected, Serial0/0
30.0.0.0/8 is directly connected, Serial0/1

S
S
C
C

Question 22
Oui
pc2b059-01:~# ping 194.10.10.1
PING 194.10.10.1 (194.10.10.1) 56(84) bytes of data.
64 bytes from 194.10.10.1: icmp_seq=1 ttl=254 time=2.23 ms
64 bytes from 194.10.10.1: icmp_seq=2 ttl=254 time=2.21 ms
64
64
64
64
64
64
64
64
64
64
64
64
64
64
64
64

bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes

[11]+

from
from
from
from
from
from
from
from
from
from
from
from
from
from
from
from

194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:
194.10.10.1:

Stopped

icmp_seq=3 ttl=254 time=2.32 ms
icmp_seq=4 ttl=254 time=2.28 ms
icmp_seq=5 ttl=254 time=2.27 ms
icmp_seq=6 ttl=254 time=2.24 ms
icmp_seq=7 ttl=254 time=2.22 ms
icmp_seq=8 ttl=254 time=2.22 ms
icmp_seq=9 ttl=254 time=2.23 ms
icmp_seq=10 ttl=254 time=2.25 ms
icmp_seq=11 ttl=254 time=2.23 ms
icmp_seq=12 ttl=254 time=2.24 ms
icmp_seq=13 ttl=254 time=2.23 ms
icmp_seq=14 ttl=254 time=2.32 ms
icmp_seq=15 ttl=254 time=2.31 ms
icmp_seq=16 ttl=254 time=2.27 ms
icmp_seq=17 ttl=254 time=2.25 ms
icmp_seq=18 ttl=254 time=2.22 ms
ping 194.10.10.1

pc2b059-01:~# ping 193.10.10.2
PING 193.10.10.2 (193.10.10.2) 56(84) bytes of data.
64
64
64
64
64
64
64

bytes
bytes
bytes
bytes
bytes
bytes
bytes

from
from
from
from
from
from
from

193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:

icmp_seq=4 ttl=62 time=3.16 ms
icmp_seq=5 ttl=62 time=1.49 ms
icmp_seq=6 ttl=62 time=1.51 ms
icmp_seq=7 ttl=62 time=1.49 ms
icmp_seq=8 ttl=62 time=1.50 ms
icmp_seq=9 ttl=62 time=1.52 ms
icmp_seq=10 ttl=62 time=1.53 ms

64
64
64
64
64
64
64
64
64
64
64
64
64

bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes
bytes

[6]+

from
from
from
from
from
from
from
from
from
from
from
from
from

193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:
193.10.10.2:

Stopped

icmp_seq=11
icmp_seq=12
icmp_seq=13
icmp_seq=14
icmp_seq=15
icmp_seq=16
icmp_seq=17
icmp_seq=18
icmp_seq=19
icmp_seq=20
icmp_seq=21
icmp_seq=22
icmp_seq=23

ttl=62
ttl=62
ttl=62
ttl=62
ttl=62
ttl=62
ttl=62
ttl=62
ttl=62
ttl=62
ttl=62
ttl=62
ttl=62

time=1.50
time=1.50
time=1.51
time=1.50
time=1.50
time=1.50
time=1.49
time=1.48
time=1.51
time=1.48
time=1.49
time=1.52
time=1.48

ms
ms
ms
ms
ms
ms
ms
ms
ms
ms
ms
ms
ms

ping 193.10.10.2

Nous avons capturé les trames sur l’interface routeur et nous avons vérifié que le ping
fonctionnait bien.

Question 23
Routeur 1
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C
S
S
S
C
C

194.10.10.0/24 is directly connected, Ethernet0/0
20.0.0.0/8 [1/0] via 10.10.10.1
[1/0] via 30.0.0.2
195.10.10.0/24 [1/0] via 10.0.0.1
[1/0] via 30.0.0.2
193.10.10.0/24 [1/0] via 30.10.10.2
[1/0] via 30.0.0.2
10.0.0.0/8 is directly connected, Serial0/0
30.0.0.0/8 is directly connected, Serial0/1

Router#show arp
Protocol Address
Internet 194.10.10.2
Ethernet0/0

Age (min)
14

Hardware Addr
0001.0342.cdf3

Type
ARPA

Interface

Internet 194.10.10.1
Ethernet0/0

-

0004.9ad3.39e0

ARPA

Installation d’une liaison de secours
Cette partie n’a pas été réalisée comme prévue car il y avait trois routeurs donc aucune
ligne backup. Cependant nous avons simulé une panne de lien entre deux routeurs. Au
commencement, avec le lien coupé il était impossible de rejoindre le routeur qui était
déconnecté. En ajoutant les bonnes entrées dans les tables de routages nous avons pu à
partir du routeur 1 joindre disons le routeur 3 via le routeur 2.

Conclusion