You are on page 1of 6

List of Router Configuration Commands:

Router> (User Exec Mode)

To transfer to Privileged Exec Mode:

Router> enable
Router# (Privileged exec mode)

To return to User Exec Mode:

Router# disable
Router>

To Transfer to Global Configuration Mode:

Router>enable
Router#config terminal
Router(config)# (Global Configuration Mode)

From any Configuration to return one step back:

Router(config)# exit
Router#exit (returned to Privileged exec Mode, putting exit one more time to
return one step back)
Router>

From any configuration to return back to User Exec Mode:

Router(config)#end
Router>

Interface Configuration Mode:

Router(config)#interface ethernet 0 (interface <interface-type> <interface-number>

Subinterface Configuration Mode

Router(config)#interface fastethernet 2.1 (2 is the interface number and 1 is the


subinterface number)
Router(config-subif)#

Line Configuration Mode:

It allows to configure VTY, console, and aux line parameters

Router(config)#line console 0 (line <interface-type> <interface-number>


Router(config-line)#

Router Configuration Mode:

Router(config)#router rip
Router(config-router)#

Setting a Password for Console Logon to the router:

Router(config)#line console 0
Router(config-line)#login
Router(config-line)#password <password> (note: if login command is omitted, the
router will not prompt for a password even though a password is set)

Telnet Password:

Telnet password secures remote access to the router using a telnet application. By
default, a password is required to establish a telnet connection to a router on
the virtual teletype (vty)
lines.

Router(config)#line vty 0 4
Router (config-line)#login
Router(config-line)#password <password>

Aux Password:

An aux password controls user-mode access to the auxilliary port. The auxilliary
port can be used to connect a modem to the router. Modems are commonly used to
provide out of band access to a Cisco router.

Router(config)#line aux 0
Router(config-line)#login
Router(config-line)#password <password>

Enable Password:

The enable password command allows you to set a password to restrict access to
privileged exec mode. The enable password is stored in the configuration file as a
plain text. If you require the enable password to be encrypted you should use the
enable secret command instead.

Router(config)#enable password cisco

Enable Secret:

To avoid the displaying of passwords within the configuration files, enable secret
command is used.

Router(config)#enable secret cisco

Message of the Day:

It is a message that is displayed when any incoming connection attempts to access


the router.
Using the banner motd command to specify banner text. The displayed text must be
enclosed within a pair of delimiting characters. Any letter or special character
can be used as the delimiting character as long as the delimiting character does
not appear in the message itself. The command interprets the character appearing
after MOTD as the delimiting character. Until the next occurrence of that
character, all text will be displayed as the banner text.

For example, to configure a router to display a message, �You have accessed the
router�,

Router(config)#banner motd $ You have accessed the router.$ (note: $dollar symbol
is the delimiting character)

Show Commands:
Show commands provide information that helps troubleshoot the configuration or
performance of the router.

Show running-config � Displays the active, running configuration of the router.

Show startup-config- Displays the saved configuration of the router stored in the
NVRAM. The startup configuration is copied into RAM each time the router boots.

Show interface- Displays the configuration related to the interfaces on the


router.

Show version � Displays the configuration of the system hardware, the ios version,
the system image filename and the current configuration register setting.

Configuring Interfaces:

Configuring Serial Interface 0

Router(config)#int serial 0
Router(config-if)#

Using Range command:

Router(config)#int range fa0/5-24


Router(config-if-range)#shutdown
Router(config-if-range)#int range gig0/1-2
Router(config-if-range)#shutdown
Router(config-if-range)#exit
Router(config-if)#exit
Router(config)#exit
Router#

Configuring Ethernet interface 0

Router(config)#int ethernet 0
Router(config-if)#

Enabling interface:

Router(config-if)#no shutdown

disabling interface:

Router(config-if)#shutdown

By default all interfaces on a cisco router are shutdown, to enable interface you
must issue the no shutdown command.

DCE and DTE Interfaces

Data circuit-teminating equipment (DCE) and data terminal equipment (DTE) are the
modes where serial interface operate. On a live network, the DCE interface,
provided by the service provider, is typically a connection to the channel service
unit/data service unit (CSU/DSU) and is responsible for providing clocking
information. In the lab environment, you might connect a DCE cable to a router to
simulate a carrier line. Cisco routers are DTE devices by default; therefore, if a
DCE cable is attached to the router, you need to provide clocking on the DTE
interface of the router by issuing the following clock rate command with the
required speed:

Router(config)#int s1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Interface Description:

It is used to identify important information.

Router(config)#int ethernet 0
Router(config-if)# description Skydome Lan Communication Building
Router(config-if)# exit

To view the cable connected to the interface show controller command in the
privileged exec mode is used.

To view the cable connected to the serial 0,

Router#show controller serial 0/0

Bandwidth Command:

Router(config)#int s1
Router(config-if)#bandwidth 64

IP Address Command

The ip command is specified at the interface level.

Router(config_if)#ip address <ip address> <subnet mask>

Router(config)#int S1
Router(config-if)#ip address 192.168.1.12 255.255.255.0

Verifying Network Configuration:

Ping, telnet, traceroute

Router# ping 10.2.4.12

Router#telnet 10.2.4.12 (Establishes a telnet session to specified remote devices)

Router#traceroute 10.2.4.12 (Displays the route that packets take to reach a


specified destination host.

Verifying and Troubleshooting Interfaces

Router#show interace serial 0


Router#show interface ethernet 0
Router#show interface brief

File Systems
Flash � stores the IOS image
TFTP- stores the IOS image and the configuration file
NVRAM � Stores the startup configuration file
RAM � stores the running IOS image, running configuration, and routing table.

Copy Command:
copy <source> <destination>

Router# copy flash tftp


Router#copy running-config startup-config
Router#copy tftp flash

Deleting a file:

Router# del flash:filename

Configuration of the Router used for Inter-Vlan Routing:

Router#erase startup-config (deleting what is inside of nvram)


Router#reload (restart the router)
Router>config t
Router(config)#hoastname R1
R1(config)#enable secret class
R1(config)#no ip domain-lookup
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 15
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#end

Configuration of Trunking Interface of R1:

R1(config)#int Fa0/0
R1(config-if)#no shutdown
R1(config-if)#int Fa0/0.10
R1(config-if)#encapsulation dot1q 10
R1(config-subif)#ip address 172.18.10.1 255. 255.255.0
R1(config-subif)#exit
R1(config-if)#int Fa0/0.20
R1(config-if)#encapsulation dot1q 20
R1(config-subif)#ip address 172.18.20.1 255. 255.255.0
R1(config-subif)#exit
R1(config-if)#int Fa0/0.30
R1(config-if)#encapsulation dot1q 30
R1(config-subif)#ip address 172.18.30.1 255. 255.255.0
R1(config-subif)#exit
R1(config-if)#int Fa0/0.40
R1(config-if)#encapsulation dot1q 40
R1(config-subif)#ip address 172.18.40.1 255. 255.255.0
R1(config-subif)#exit
R1(config-if)#int Fa0/0.50
R1(config-if)#encapsulation dot1q 50
R1(config-subif)#ip address 172.18.50.1 255. 255.255.0
R1(config-subif)#exit
R1(config-if)#int Fa0/0.60
R1(config-if)#encapsulation dot1q 60
R1(config-subif)#ip address 172.18.60.1 255. 255.255.0
R1(config-subif)#exit
R1(config-if)#int Fa0/0.70
R1(config-if)#encapsulation dot1q 70
R1(config-subif)#ip address 172.18.70.1 255. 255.255.0
R1(config-subif)#end
R1#copy running-config startup-config

<PIXTEL_MMI_EBOOK_2005>3##########################################################
#</PIXTEL_MMI_EBOOK_2005>