You are on page 1of 5

Divisin de Ingenieras

Algoritmia y programacin I
Ing. Karen Milena Gmez Quiroz

CICLO PARA
Un ciclo PARA realiza repetidamente la ejecucin de una serie de instrucciones, limitada
por el incremento o decremento de una variable contadora de tipo entero. El valor inicial
de esta variable depende de un rango establecido (lmite inferior- lmite superior). En ese
sentido, es posible asignar a la variable el valor de lmite inferior y realizar incrementos,
hasta que llegue al lmite superior, o el caso contrario, tomar el valor de lmite superior y
realizar decrementos sucesivos hasta el lmite inferior. La sintaxis del ciclo PARA es la
siguiente:

Caso 1: Incremento
Para (variable limite_inferior, variable limite_superior, 1) haga
<Instrucciones>
fin_para

Caso 2: Decremento
Para (variable limite_superior, variable limite_inferior,- 1) haga
<Instrucciones>
fin_para

Ejemplo 1

Realizar un algoritmo que permita calcular el factorial de un nmero.

Entrada = 0
Factorial = 1

Entrada = 3
Factorial = 123=6

Entrada = 4
Factorial = 1234=24

Entrada = 5
Factorial = 12345=120

Incremento

INICIO
| Entero numero 0, cont , fact 1
| Escriba (Digite el nmero:)
| Lea numero
| Para (cont1, cont<=numero, 1) haga
| | factfact*cont
| Fin_Para
| Escriba (El factorial de, numero, | es,fact)
FIN
Decremento

INICIO
| Entero numero 0, cont , fact 1
| Escriba (Digite el nmero:)
| Lea numero
| Para (contnumero, cont>=1, -1) haga
| | factfact*cont
| Fin_Para
| Escriba (El factorial de, numero, es,fact)
FIN
Divisin de Ingenieras
Algoritmia y programacin I
Ing. Karen Milena Gmez Quiroz

Ejemplo 2

Escriba un algoritmo que calcule una aproximacin al nmero PI teniendo en cuenta que

4
= 1
1
3
+
1
5

1
7
+
1
9

1
11


Para ello sumar N trminos y del valor obtenido despejar

INICIO
Entero n0, den 1, signo 1, cont
Real suma 0
Escriba (Digite el valor de N para calcular la aproximacin:)
Lea n
Para (cont 1, cont n, 1) Haga
suma suma + signo (1/den)
den den + 2
signo signo (-1)
F.Para
suma suma 4
Escriba(La aproximacin al nmero PI es: , suma)
Fin

Prueba de escritorio para N=4

cont suma den signo
valor inicial 0 1 1
1 1 3 -1
2
1
1
3

5 1
3
1
1
3
+
1
5

7 -1
4
1
1
3
+
1
5

1
7

9 1
Salida suma 4 = 2,895232381

Nota: Para que esta serie arroje un valor ms aproximado del valor de es necesario sumar
19 millones de trminos para obtener 7 decimales correctos.


Pregunta: Es posible hacer este ejercicio utilizando el caso del decremento? Si la
respuesta es SI, intntalo, si la respuesta es No, explica porque?

Divisin de Ingenieras
Algoritmia y programacin I
Ing. Karen Milena Gmez Quiroz


Ejemplo 3

Escriba un algoritmo para que genere la suma de N trminos de la siguiente serie:

1/2 + 3/4 + 7/8 + 15/16 + 31/32

INICIO
Real suma <-0
Entero num <- 1, den <- 2
Escribir ("Digite el valor de N para calcular la aproximacin:")
Leer n
Para (cont<-1, cont n, 1) Haga
suma <- suma + num/den
Escribia (num "/" den)
num<-num+den
den <-den*2
Fin Para
FIN

Prueba de escritorio para N=4


cont suma num den
valor inicial 0 1 2
1
1
2

3 4
2
1
2
+
3
4

7 8
3
1
2
+
3
4
+
7
8

15 16
4
1
2
+
3
4
+
7
8
+
15
16

31 32
Salida
suma = 3,0625









Divisin de Ingenieras
Algoritmia y programacin I
Ing. Karen Milena Gmez Quiroz



Ejemplo 4

Realice un algoritmo que calcule el e-nsimo trmino de la serie de Fibonacci que est
dada por la siguiente sucesin



Podemos calcular esta serie teniendo en cuenta lo siguiente:











INICIO
Entero n, preAnt 0, ant 1, sig, cont
Escriba (Digite el valor de N)
Lea n
Si (n = 1) Entonces
Escriba preAnt
Sino
Si (n=2) Entonces
Escriba (preAnt , ant)
Sino
Escriba (preAnt , ant)
Para (cont 3, cont n, 1) Haga
sig ant + preant
Escriba(sig)
preant ant
ant sig
Fin_Para
Fin_Si
Fin _Si
FIN





Divisin de Ingenieras
Algoritmia y programacin I
Ing. Karen Milena Gmez Quiroz


Ejercicios propuestos
Realizar con ciclo Para los ejercicios vistos en clase con ciclo Mientras que

1. Realice un algoritmo que muestre los nmeros pares menores o iguales que el

2. Realice un algoritmo que diga si un nmero es perfecto o no, es decir que la suma de
sus divisores es igual al mismo nmero.

3. Realice un algoritmo que lea un nmero de datos y calcule la media y la varianza de
estos.